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READ ME
In this chapter:

WHAT CAN YOU DO WITH IT?

The DEVONnote advantage
Getting started

4
4

System requirements
Installing, updating, uninstalling
Version history
License agreement
Credits

5
5
6
9
9

DEVONnote is an easy-to-use, intelligent note
pad which helps you sort out new stuff, manage
bookmarks, browse the web and use cross and Wikistyle links.

THE DEVONNOTE ADVANTAGE

DEVONnote is much more than just a notetaking
application. It is the #1 tool for collecting and
organizing info bits and snippets on the Mac.Use
DEVONnote to:
Write down your thoughts as plain or rich text,
highlight important passages
Clip data from documents or Web pages using
Services or the Dock menu
Make structure out of chaos. Connect your notes
with automatic Wiki links
Sort in new stuff or find similar documents, all with
just a single click
Surf the Web using the integrated browser, or
watch your favorite Web cams

WHY DEVONNOTE?

EDITIONS

DEVONnote keep all of your notes safe in one
place and organize them in a way that is meaningful
to you, using built-in artificial intelligence (AI).
DEVONnote treats web sites like "living" notes.
View them directly in the application and manage
your bookmarks like simple documents. Keep notes
and related bookmarks together.

DEVONnote is a streamlined version of
DEVONthink. You can find a feature comparison on
our web site.

GETTING STARTED
DEVONnote is a powerful application that may
require time to fully master. Open the Support
Assistant to read tips, tricks, and tutorials. Install
pre-made templates that extend DEVONnote's
functionality.

DEVONnote 2.9.17 Documentation, page 4

Other helpful resources are our company blog,
where we publish timely news and, sometimes, even
public betas, and our lively user form.
Continue here:
Visit our company blog
Visit our user forum

SYSTEM REQUIREMENTS
Mac with 64-bit CPU, 2 GB of RAM, and Mac OS
X Mavericks or later. In addition, we recommend a
broadband Internet connection. If obtained through
the App Store DEVONnote requires a 64-bit CPU
and Mac OS X Mavericks or later.

INSTALLING, UPDATING,
UNINSTALLING
Note: The following procedures do not apply
when you have purchased DEVONnote on
the Mac App Store. Installing, updating, and
uninstalling are handled by the App Store
application in this case.

INSTALLING AND UPDATING
Move the DEVONnote application package
to the Applications folder or any preferred
directory. Please note that macOS Services and
the connection to DEVONagent work only for
applications installed into the Applications folder,
and that logout and login or a restart is required
after installation.
To update an existing version of DEVONnote,
simply copy the application package from the disk
image to your Applications folder, replacing the
old version. Your database(s) will not be affected.
If you purchased DEVONnote in the Mac App
Store you can also download the update from the
DEVONtechnologies website. It will retrieve the
existing receipt and accept it as valid license.
UNINSTALLING
To remove (uninstall) DEVONnote completely from
your Mac, trash the following files and folders (~
stands for your Home folder):
DEVONnote
~/Library/Application Support/DEVONnote 2
~/Library/Preferences/com.devontechnologies.note.*
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VERSION HISTORY
New

Improved

Fixed

Removed

VERSION 2.9.17
This maintenance release makes it easier to insert links into plain text documents, enhances the validation of
entered links, and handles .textbundle document packages without third-party software. It also improves the
overall reliability and fixes bugs.
Insert Link To submenu added to the contextual menu of editable plain text documents.
Pressing the ⌘ Command modifier key when dragging from other apps doesn't move the items anymore if the
source app doesn't support this.
Improved validation of Format > Add Link.
Improved appearance of label colors in menus.
Improved handling of .textbundle document packages doesn't depend on installed third-party software
anymore.
Improved logging.
Improved bug reporting.
Improved overall reliability and performance.
Fixed an issue where document properties equal to the item's title were filtered from the internal metadata
store.
Fixed an issue where temporary files were not removed after dropping links from other applications to
DEVONnote.
Fixed an issue where the displayed location of items was sometimes the one in the trash even if locations
outside the trash existed.
Fixed an issue where verifying, backing up, restoring, and rebuilding databases didn't work in DEVONnote
2.9.16.
VERSION 2.9.16
This maintenance release improves the compatibility to macOS High Sierra and the overall performance and
reliability.
Improved importing.
Improved console logging.
Improved localizations.
Improved bug reporting.
Improved overall reliability and performance.
Fixed an issue where large numbers of entries in the Log panel could slow down importing files.
Fixed an issue where search results weren't shown in Three Pane and Split views after performing a search,
selecting another group, and performing the same search.
High Sierra — Fixed an issue where the group selector wouldn't close on machines with a Touch Bar.
VERSION 2.9.15
This maintenance release adds a new URL command for creating groups. It also improves the compatibility to
macOS High Sierra as well as the overall performance and reliability.
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URL command "x-devonthink://createGroup" for creating groups.
Tagging avoids items only located in the Tags group.
Toolbar search view is now also shown if no results are found.
Groups created while importing data are no longer automatically excluded from classification or tagging to
make it easier to manually classify them.
Improved detection of internet locations.
Improved handling of background tasks.
Improved memory management.
High Sierra — Improved compatibility to macOS High Sierra.
Fixed an issue where default document icons weren't scaled up correctly in icon views.
Fixed an issue where Go > Back/Forward was sometimes enabled after deleting items and emptying the trash.
Fixed an issue where importing previously exported folders into the Tags group could create duplicate tags.
Fixed an issue where pasting multiple tags into the Tags column of list views concatenated them.
Fixed an issue where renaming the currently selected item in icon views wasn't always possible.
Fixed an issue where the Help button of the smart group editor opened the wrong help topic.
Fixed glitches related to the handling of font preferences (macOS Sierra and later).
Fixed further minor bugs and glitches.
High Sierra — Fixed an issue where the Help menu appeared twice.
High Sierra — Fixed issues related to resizing oval and line PDF annotations.
High Sierra — Fixed further minor bugs and glitches.
VERSION 2.9.14
This maintenance release fixes a harmless issue related to exporting items.
Fixed an issue where exporting items or moving files or folders to external folders could cause wrong creation
dates (workaround).
VERSION 2.9.13
This maintenance release adds basic support for the Roccat web browser, opens links, images, and frames in
tabs more reliably, and verifies databases faster. It also improves the overall reliability and performance.
The URL of the frontmost browser window of Roccat is now captured, e.g., after taking plain or rich notes
using the Services menu.
Opening links, pictures, and frames in tabs is more reliable.
Slightly faster database verification.
Help > Report Bug sets the receiver if Postbox is the default email client.
Improved overall performance and reliability.
Fixed an issue where Link To and Insert Link To submenus no longer worked since version 2.9.12.
VERSION 2.9.13 ... 1.0.1
Skipped.
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VERSION 1.0
Initial release.
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LICENSE AGREEMENT
PLEASE READ THIS LICENSE CAREFULLY
BEFORE USING THIS SOFTWARE. BY USING THIS
SOFTWARE, YOU ARE AGREEING TO BE BOUND
BY THE TERMS OF THIS LICENSE AGREEMENT.
IF YOU DO NOT AGREE TO THE TERMS OF
THIS LICENSE, DELETE THE SOFTWARE OR
RETURN THE SOFTWARE AND RELATED

DEVONtechnologies' total liability to you for all
damages, losses and causes of action (whether in
contract, tort (including negligence) or otherwise)
exceed the amount paid by you for the Software.
Apple, Cocoa, ColorSync, Darwin, macOS,
QuickTime, Quartz and all other registered names
are trademarks of their respective owners.

DOCUMENTATION TO DEVONTECHNOLOGIES,
LLC.

CREDITS

1. License: The application and other components
(sound and graphics) accompanying this License,
whether on disk, in read only memory, or on
any other media (the "Software"), and the
related documentation are licensed to you by
DEVONtechnologies. You own the disk on which
the Software is recorded but DEVONtechnologies
and/or DEVONtechnologies' Licensor(s) retain
title to the Software and related documentation.
This License allows you to non-simultaneously use
the Software on multiple computers by the same
person.

AMINDETERMINATEPROGRESS

2. Restrictions: The Software contains copyrighted
material, trade secrets and other proprietary
material and in order to protect them you may
not decompile, reverse engineer, disassemble
or otherwise reduce the Software to a humanperceivable form. You may not sub-license, modify,
rent, lease, or create derivative works based upon
the Software in whole or in part. You may not
distribute the Software in any form, including,
but not limited to, electronic information service
distribution, bulletin board distribution, and
magnetic or optical medium distribution.
3. Disclaimer of Warranty on Software: You
expressly acknowledge and agree that use of the
Software is at your sole risk. The Software and
related documentation is provided "AS IS" and
without warranty of any kind.
4. Limitation of Liability: UNDER NO
CIRCUMSTANCES INCLUDING NEGLIGENCE,
SHALL DEVONTECHNOLOGIES BE LIABLE FOR
ANY INCIDENTAL, SPECIAL OR CONSEQUENTIAL
DAMAGES THAT RESULT FROM THE USE
OR INABILITY TO USE THE SOFTWARE OR
RELATED DOCUMENTATION. In no event shall

Copyright © 2007 Andreas Mayer. All rights
reserved.
Redistribution and use in source and binary forms,
with or without modification, are permitted
provided that the following conditions are met:
Redistributions of source code must retain the
above copyright notice, this list of conditions and
the following disclaimer.
Redistributions in binary form must reproduce the
above copyright notice, this list of conditions and
the following disclaimer in the documentation
and/or other materials provided with the
distribution.
Neither the name of the copyright holder nor the
names of its contributors may be used to endorse
or promote products derived from this software
without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE
COPYRIGHT HOLDERS AND CONTRIBUTORS
"AS IS" AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE ARE DISCLAIMED. IN
NO EVENT SHALL THE COPYRIGHT OWNER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY,
OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS
OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND
ON ANY THEORY OF LIABILITY, WHETHER
IN CONTRACT, STRICT LIABILITY, OR TORT
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(INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF
THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.
REGEXKITLITE
Copyright © 2008 John Engelhart. All rights
reserved.
Redistribution and use in source and binary forms,
with or without modification, are permitted
provided that the following conditions are met:
Redistributions of source code must retain the
above copyright notice, this list of conditions and
the following disclaimer.
Redistributions in binary form must reproduce the
above copyright notice, this list of conditions and
the following disclaimer in the documentation
and/or other materials provided with the
distribution.
Neither the name of the Zang Industries nor the
names of its contributors may be used to endorse
or promote products derived from this software
without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE
COPYRIGHT HOLDERS AND CONTRIBUTORS
"AS IS" AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT
LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE ARE DISCLAIMED. IN
NO EVENT SHALL THE COPYRIGHT OWNER OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY,
OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS
OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND
ON ANY THEORY OF LIABILITY, WHETHER
IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF
THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

MULTIMARKDOWN
Copyright (c) 2010-2014 Fletcher T. Penney
MultiMarkdown is released under both the GPL and
MIT licenses. You may pick the license that best fits
your needs.
Modifications to remove reliance on Glib2:
Copyright (c) 2011 Daniel Jalkut, licensed
explicitly MIT.
LyX export code (c) 2013-2014 Charles R. Cowan,
licensed under both GPL and MIT licenses.
Portions based on: peg-markdown. Copyright (c)
2008-2011 John MacFarlane. ODF output code
(c) 2011-2013 Fletcher T. Penney. peg-markdown
is released under both the GPL and MIT licenses.
You may pick the license that best fits your needs.
Original Markdown specification by John Gruber.
The GPL: This program is free software; you can
redistribute it and/or modify it under the terms of
the GNU General Public License as published by
the Free Software Foundation; either version 2 of
the License, or (at your option) any later version.
This program is distributed in the hope that it will be
useful, but WITHOUT ANY WARRANTY; without
even the implied warranty of MERCHANTABILITY
or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details. You
should have received a copy of the GNU General
Public License along with this program; if not, write
to the Free Software Foundation, Inc., 51 Franklin
St, Fifth Floor, Boston, MA 02110-1301 USA
The MIT License: Permission is hereby granted,
free of charge, to any person obtaining a copy of
this software and associated documentation files
(the "Software"), to deal in the Software without
restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute,
sublicense, and/or sell copies of the Software, and to
permit persons to whom the Software is furnished
to do so, subject to the following conditions:
The above copyright notice and this permission
notice shall be included in all copies or substantial
portions of the Software. THE SOFTWARE IS
PROVIDED "AS IS", WITHOUT WARRANTY OF
ANY KIND, EXPRESS OR IMPLIED, INCLUDING
BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR
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PURPOSE AND NONINFRINGEMENT. IN NO
EVENT SHALL THE AUTHORS OR COPYRIGHT
HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES
OR OTHER LIABILITY, WHETHER IN AN ACTION
OF CONTRACT, TORT OR OTHERWISE, ARISING
FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN
THE SOFTWARE.
SPARKLE
Copyright © 2006--2009 Andy Matuschak
Permission is hereby granted, free of charge, to
any person obtaining a copy of this software and
associated documentation files (the "Software"), to
deal in the Software without restriction, including
without limitation the rights to use, copy, modify,
merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to
whom the Software is furnished to do so, subject to
the following conditions:

The above copyright notice and this permission
notice shall be included in all copies or substantial
portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT
WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO
THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL
THE AUTHORS OR COPYRIGHT HOLDERS
BE LIABLE FOR ANY CLAIM, DAMAGES OR
OTHER LIABILITY, WHETHER IN AN ACTION OF
CONTRACT, TORT OR OTHERWISE, ARISING
FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN
THE SOFTWARE.
VIDEO JS
Copyright © 2010 Zencoder, Inc.
The Video JS player is used according to the LGPL
v3.
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COMMON TASKS
In this chapter:
Browse the Internet
Collect text snippets and other valuable data

12
12

Manage your bookmarks
Take notes
Write texts and outline projects

12
13
13

In this chapter you'll find a number of common ways
you can use DEVONnote for everyday tasks, from
surfing the Internet and making notes to cataloging
photos and archiving emails.

BROWSE THE INTERNET
Besides being a knowledge and information
database, DEVONnote acts as a web browser.
This extends the document-based approach to
knowledge to the World Wide Web. Because
DEVONnote is a database manager, its web browser
does not work in a windowed style like Safari or
DEVONagent Pro; rather, it's document-oriented.
This enables you to treat web pages the same way
as you treat documents. Whenever you select a web
document (bookmark), DEVONnote immediately
loads and displays its content live from the Internet
in the view/edit pane.
Possible uses:
Visit frequently used web sites in a convenient
interface
Integrate "live" content from the web with your
other documents
Grab data from web sites and store it in
DEVONnote
Continue to read here:
Create a new URL or HTML document
View "live" and local HTML pages

COLLECT TEXT SNIPPETS AND
OTHER VALUABLE DATA
Using macOS's handy Services menu, DEVONnote
is the premiere tool for collecting and organizing
information bits and snippets.
Select any piece of data and capture it to the
currently open database with a keystroke or a quick
visit to the Services menu. All Cocoa applications
such as TextEdit, Safari, or DEVONnote itself-as well as many new Carbon applications, e.g. the
Finder or Microsoft Office 2004--support this
mechanism.
DEVONnote automatically sets the title of the
newly created snippet to the first line of text, so
there's a good chance that you won't even need to
rename it. New snippets are always created in the
inbox.
Possible uses:
Collect recent news from your favorite web sites
Keep important information from any source and
your other project-related documents together
Create an info collection for a specific topic
Continue to read here:
Capture a note quickly using the Services menu
Use the Dock menu

MANAGE YOUR BOOKMARKS
With its integrated, document-based web browser,
DEVONnote can be used as a bookmark manager.
Organize all your bookmarks as bookmark
documents and visit the website simply by
selecting the bookmark in split or three panes view.
DEVONnote loads the page and displays it in the
view/edit pane.
If you want to open the Web page in your default
browser, simply ⌃ click (right-click) the bookmark
and choose Launch URL from the contextual menu.
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Possible uses:
Manage your bookmarks
Keep project-related web pages and other
documents together
Visit frequently used web sites in a convenient
interface
Integrate "live" content from the web with your
other documents
Grab data from web sites and store it in
DEVONnote
Continue to read here:
Create a new bookmark document
View "live" and local HTML pages

TAKE NOTES
DEVONnote is perfectly suited for taking notes and
organizing them.
Use DEVONnote's Take Note panel or its Dock menu
to quickly create new notes, write notes using the
advanced text editing capabilities of macOS, and
find a place to file them in your database using the
Classify & See Also button.
Possible uses:
Write down ideas before they vanish
Take quick phone messages
Keep project notes and your other project-related
documents together
Continue to read here:
Create new documents
Create a new note using the Dock menu
Revise notes and documents using the built-in rich
text editor

Organize your data using Classify and See Also

WRITE TEXTS AND OUTLINE
PROJECTS
With its hierarchical group structure, organization,
and navigation functions, as well as its advanced
text editing capabilities based on the macOS text
engine DEVONnote is perfectly suited for writing
text from notes to whole books.
Create new documents with just one click, find
related documents, and network them with Wikistyle or static cross-links. Because you are working
with databases in DEVONnote, you can switch from
one document to another with just one click, and
manage even large projects with ease.
By flagging groups and documents DEVONnote
can also be used as a simple outliner. Unlike other
outliners, DEVONnote uses documents as items and
groups for items that have sub-items. Use it with the
Split view to create an outliner look-and-feel.
Possible uses:
Write notes, white papers, and letters
Write and organize book chapters
Organize your ideas or projects in outlines
Create a network of information for your projects
or interests
Continue to read here:
Create new documents
Use the built-in rich text editor
Choose between various window layouts to match
your work style
Use the See also & Classify drawer
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IN & OUT
In this chapter:
Drag and drop
Importing and indexing

14
14

Services
Dock menu
Synchronizing with DEVONthink To Go 1.x

14
15
15

DEVONnote is not an island. It integrates with the
rest of your Mac and iOS devices in a variety of ways
to make it easy for you to add data to DEVONnote.

DRAG AND DROP
The easiest way to add data to DEVONnote, other
than creating the documents directly inside the
application, is to drag files or selected data, e.g. text,
images, etc., into a DEVONnote window or onto its
Dock icon.
Dragging files into a document list imports the file;
dragging text or images creates documents for
them. Dragging files into a rich text document adds
them as attachments to the document. Dragging
data to the Dock icon creates new documents in the
default destination.
Hold the ⌘Command key while dragging to
effectively move the file or folder into the database.
DEVONnote imports the dragged item and puts the
original into the Finder trash. This works identical
to File > Import > Files & Folders with the option Move
originals to trash enabled.

IMPORTING AND INDEXING
You import files with drag-and-drop or using the
File > Import menu item. Imported files are copied
into the database and appear as a document in
DEVONnote's interface.
Note: Importing files and folders exported by
ELO Office honors the metadata provided by ELO
Office and skips metadata files.

Indexing, adding files as pure references to the
database, is not available for DEVONnote.

SERVICES
The DEVONnote > Services menu gives you access
to special commands published either by other
applications, such as TextEdit or Safari, or by
services extensions such as DEVONtechnologies'
WordService or CalcService. Also, DEVONnote
publishes its own services in the Services menu.
DEVONNOTE SERVICES
DEVONnote installs several services for copying or
summarizing selected text, capturing a web page, or
searching documents in the database.
Take Plain/Rich Note: Adds selected text to the
global inbox from any application that support
services (!) as plain or rich text. Taking a rich text
note also copies images and clickable links. If
the source document is a web page or a news
feed, DEVONnote tries to capture the address
of the page or feed as well. This only works with
applications that support this feature, such
as Safari, DEVONagent Pro, and other web
browsers.
Capture Web Archive: Captures the web
page displayed in the frontmost window of
any WebKit-based browser (such as Safari
or DEVONagent Pro) as a web archive to
DEVONnote's inbox. This menu item is only
shown when available, e.g., when Safari is the
active application.
Append Plain/Rich Note: Adds selected text as
plain or rich text to the last note taken using the
DEVONnote Services menu items.
Note: After installing DEVONnote you need
to log out, then back in again for new services
and their shortcuts to be recognized. If one or
more DEVONnote Services menu commands do
not carry a shortcut, it may be because another
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application grabbed them. macOS will assign the
shortcut if no other application already uses the
same key combination.

DEVONnote has the ability to synchronize its
database with DEVONthink To Go, its companion
app for iPhone, iPad, and iPod touch devices.
Synchronizing with the device: DEVONnote uses

DOCK MENU
The Dock menu appears when you click DEVONnote's
icon in the Dock with the ⌃ key pressed, when you
right-click it, or when you left-click it and hold the
mouse button for one second or longer.
Use the Dock menu commands Import and Index
to import or index files. Copy something to the
Clipboard and use New with Clipboard to directly
create a document with the Clipboard contents
anywhere in your open databases. DEVONnote
will try to create a meaningful name for it. Finally,
choose Take Note to open the Take Note panel.

SYNCHRONIZING WITH
DEVONTHINK TO GO 1.X
Note: DEVONthink To Go 2 uses a new sync
mechanism not available for DEVONnote.
To continue syncing your database with
DEVONthink To Go please to not update to
version 2.

a special group named Sync to let you decide which
data you want to share with your iOS device. The
Sync group appears on the top group level of your
database and has a special icon that makes it stand
out from other groups. To select the items in your
database that you want to take with you on your
device, either move or replicate them into its Sync
group. You replicate items by dragging them with
the ⌘ and ⌥ keys held. You can add documents
as well as whole groups to the Sync group. Smart
groups are not yet supported and will be ignored
during synchronization.
Make sure your device is on the same Wi-Fi
network as this computer. On the device open the
DEVONthink To Go app, tap the sync button on the
app's home screen, and follow the instructions.
Visit the App Store: If you do not yet have
DEVONthink To Go installed on your device, learn
more about it or visit the App Store. If you have
problems synchronizing with DEVONthink To Go
1.x click here.
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MENUS
In this chapter:
The Application menu
The File menu

16
17

The Edit menu
The Data menu
The Format menu
The View menu
The Go menu

18
19
21
22
23

The Window menu
The Services menu
The Help menu
The Dock menu

24
24
25
25

A complete listing of all commands DEVONnote
offers in the menu bar, the global macOS Services
menu, and the handy Dock menu.

have purchased DEVONnote from the Mac App
Store. In this case, all updates are handled by the
App Store.
PREFERENCES, TRASH, AND CACHE
Preferences: Opens the Preferences.
Empty Trash: Moves the contents of the database
trash to your computer's file system trash.
Empty Cache: Empties the web browser cache.
This frees up space and makes sure that all, when
displaying a web page, all data is freshly loaded
instead of using a cached copy.
Note: If Index-captured items are contained in
the database trash when you use Empty Trash,
the option Also from disk will become available. If
chosen, it will send the externally linked files to
the system trash, too. Caution is advised!

THE APPLICATION MENU
The DEVONnote menu is similar to the application
menu in any other macOS application. It contains
commands for displaying the splash screen, opening
the Preferences window, accessing the Services
menu, hiding and showing windows, and, of course,
quitting the application.
ABOUT DEVONNOTE, ...
About DEVONnote: Shows information about
DEVONnote including the version number and
licensing information.
Check for Updates: Checks if updates for
DEVONnote are available. By default,
DEVONnote checks for updates automatically;
you can change the update settings in the
Preferences, Update pane.
Note: When checking for updates no information
is uploaded from your computer to the
DEVONtechnologies server. DEVONnote only
downloads a file listing the most current versions
to your Mac. This option is not available if you

PURCHASE, ...
Check Upgrade Options: Opens a web page that
lists the upgrade options available for your copy
of DEVONnote.
Purchase License: Opens the DEVONtechnologies
Online Shop and puts DEVONnote into your
shopping cart. If this copy of DEVONnote is
already licensed, you will be presented with the
choice of buying an upgrade for your existing
license or buying another full license.
Enter License: Use this command to enter your
licence code. Make sure you enter ALL the
details EXACTLY as they appear in the licence
code e-mail. It is best to use copy-and-paste for
transferring name, organization, and licence code
from the email message to the appropriate fields.
Note: Make sure that when you highlight the
information to copy and paste, no spaces before
or after the information are highlighted.
Note: Enter License changes into License and
Purchase License into Purchase License or Upgrade
as soon as you have entered a valid license code
(and a paid upgrade exists). Available options
DEVONnote 2.9.17 Documentation, page 16

depend on whether you have purchased your
copy in DEVONtechnologies' online shop or from
the Mac App Store.
SERVICES

DEVONnote reads these files when importing
and recreates your original data structure. If you
don't need the metadata, you can safely delete the
".DEVONtech_storage" files. Exporting also exports
tags).

The Services sub-menu gives your access to
special commands published by other macOS
applications such as TextEdit or Safari, or by

Document: Exports the currently viewed document.

services extensions such as our own WordService
or CalcService. Also, DEVONnote publishes its
own services. See also p. 24ff

with a number of standard plug-ins for exporting
documents in different formats. Currently the
following plug-ins are included:

THE FILE MENU
The File menu contains all commands that deal
directly with files in your volumes, databases, or
files that can be imported, exported, or linked. Also,
the File menu contains commands for printing
documents.
NEW WINDOW
New Window: Opens a new main window for an
open database. (If only one database is open, no submenu is available.) DEVONnote windows present
all documents and groups of a database in a Finderlike fashion, and are used to access all stored items.
The window also contains a view/edit pane for easy
viewing and editing of documents.
IMPORT
Import: Imports files or complete folders from
your volumes into the database. You can find a
list of all supported file formats in the appendix.
If not stated differently, data is imported to the
default destination. Finder labels, tags, and Spotlight
comments are honored whenever possible.

In addition, the Export sub-menu provides export
methods based on plug-ins. DEVONnote comes

as Website: Exports the selected items as
standalone web site that you can upload to
your web server and share with colleagues.
In the appearing dialog window, choose the
desired template, text encoding, and whether
DEVONnote should convert diacritics and
accented characters to HTML entities or not.
Check Create Index Pages to create "index.html"
pages with cross-links to all included documents.
Markdown and formatted notes are rendered to
HTML, other file types that cannot be displayed
in a web browser, e.g., Pages files, are converted
to PDF if possible. Cross-links are converted
correctly. For the export templates are used that
you can modify yourself.
as Template: Saves the selected documents as
a template, which can then be used to quickly
create new documents using Data > New >
With Template. To remove a saved template
or to organize your templates in sub-folders,
visit the folder '~/Library/Application Support/
DEVONthink Pro 2/Templates.noindex''~/
Library/Application Support/DEVONthink 2/
Templates.noindex' in the Finder, then create subfolders, move items, rename them, or trash them.
Export multiple documents and/or groups at once
to create e.g. a project template.

EXPORT
This sub-menu allows you to export selected
documents or groups to the file system.
Files and Folders: Exports the selected documents
and recreates the hierarchy you have built in
DEVONnote almost exactly. Metadata files
(".DEVONtech_storage") make sure that no
metadata such as comments, URLs, etc., are lost.

VERIFY
Like any database, DEVONnote needs a bit of
maintainance from time to time. All the commands
you'll need for this can be found here.
Verify & Repair: Verifies all database structures
and repairs them if necessary. Use this whenever
you feel it is necessary. By default, DEVONnote
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automatically verifies the database structure every
time you open a database; DEVONnote will advise
you to run this command when it finds significant
errors.
Backup & Optimize: Creates an internal backup
of the database and then optimize the database
structure. Optimizing removes unnecessary
internal elements from the database and rebuilds

THE EDIT MENU
The Edit menu contains all commands and options
relating to editing. You'll find the classic Mac cut/
copy/paste and find/replace commands here, as well
as many more.
UNDO AND REDO

the internal structure to optimize performance.
DEVONnote also creates internal backups on
a regular basis depending on the settings in the
Preferences, Backup tab.

Undo/Redo: Undoes your last action or redoes it.
Undo and Redo work for most actions.

Restore Backup: Restores an internal backup.
Choose the backup you want to restore from the
dialog window and click Open. You can identify
backups by their creation date.

Cut/Copy/Paste: Do exactly what their names say.

Note: Restoring a backup simply swaps the
current database and the backup. The backup
becomes the active database, the former
database becomes a backup. You'll never lose any
data by using this command.
Rebuild Database: Completely rebuilds the
database by exporting all items to a temporary
folder in the file system, creating an empty
database, and reimporting all items. This removes
any structural problems. Depending on the size of
your database, this can take from a few seconds to
several hours.
PROPERTIES
Database Properties: Opens the Database
Properties panel for your database that allows
you to change properties such as database name,
comments, and username/password.

CUT

Copy URL: Copies the URL of the selected or
frontmost document to the Clipboard.
Copy Item/Page Link: Copies a URL to the clipboard
that links to the selected document or group or even
to the currently displayed page. Paste this URL into
other documents in other applications to create a
back link to DEVONnote. Hold the ⇧Shift key to
reveal the Copy Page Link option. See also p. 76ff
Paste and Match Style: Pastes text from the
Clipboard into rich text documents, disregarding all
styles from the clipped text, and matching styles in
the current document.
Delete: Deletes the selected piece of text.
Complete: Tries to auto-complete the partial word
before the insertion caret. This standard macOS
function uses the currently active dictionary, which
you can change via the spell check panel (see below).
Select All/Deselect All: Selects or deselects the
complete content of the frontmost document. Hold
the ⇧Shift key to reveal the Deselect All option.

PAGE SETUP, PRINT

DOCUMENT EDITING

Page Setup: Sets your preferred page size.

Tags: Shows the Tags bar, if necessary, so that you
can enter your tags immediately.

Print: Prints the selected or front-most document.

Rotate Left/Right: Rotates a selected image or page
left and right.
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FIND
Find: This sub-menu contains commands for
finding and replacing text as well as for bringing
DEVONnote's database search field into focus.
In Database: Brings the search field of the
frontmost window into focus.
Find: Opens the standard panel for finding text
within a document.
Find Next/Previous: Jumps to the next, or
previous occurence, of the last search term.
Use Selection for Find: Copies the selected piece
of text to the Clipboard or into the search field of
the find panel, if it is opened.
Scroll To Selection: Scrolls the displayed
documents to the current selection.
Spelling and Grammar: Provides the standard
macOS functionality for checking text for spelling
or grammar errors. To choose the language used for
spell checking, or for auto-completion (see above),
open the spell checker panel with Edit > Spelling and
Grammar > Show Spelling and Grammar and choose
your language of choice from the pop-up menu.
Substitutions: Shows the standard Substitutions
preference panel and switch the available options
manually on and off: Smart Copy/Paste, Smart
Quotes, Smart Dashes, Smart Links, Data Detectors,
and Text Replacements. Data Detectors analyze
shown text and make context-sensitive actions
available, e.g., when you hover the cursor over a
phone number or postal address.
Transformations: Use this sub-menu to change
selected text to all lowercase or uppercase, or to
capitalize every word.
Speech: Starts or stops speaking the selected piece
of text.
Insert: Inserts special characters, the current date
and/or time, a checkbox, or a picture into your text.
Note: You can only embed a picture into a rich text
document, not into a plain text document, and a
checkbox only into a formatted note.
Special Characters: Shows the standard Special
Characters panel for inserting characters that you
cannot enter directly with your keyboard.

THE DATA MENU
The Data menu contains all commands that deal
directly with documents or groups. Here you'll
find commands for creating, labeling, classifying or
group new documents, and more.
NEW
New: Allows you to create new documents directly
from within DEVONnote.
With Clipboard: Creates a new document based
on the contents of the clipboard. Note: Some
applications such as Microsoft Word put data in
multiple formats into the Clipboard. DEVONnote
tries to select the most useful one, however, in
some cases it grabs an image instead of text (like
Microsoft Word). Workaround: Create a text
clipping for the text, or paste it into a TextEdit
window, then copy the text from there.
Plain Text: Creates a new plain text document.
Rich Text: Creates a new rich text document.
Formatted Note: Creates a new formatted note.
Bookmark: Creates a new bookmark. Type
the URL you like and name it; DEVONnote
automatically sets the value of its URL field in
the Info panel accordingly. If you don't type in a
name, DEVONnote looks up the page name on
the Internet and sets it automatically for you.
Group: Create a blank group. Appears as Tag if the
new group would be created in the Tags group.
Smart Group: Creates a new smart group, also
known as "saved search". DEVONnote opens the
Smart Group Editor, which lets you define your
search criteria. When saved, the contents are
updated every time you display the smart group's
contents.
You can add any document to the list of templates
using File > Export > as Template.
Some of the pre-defined templates are "smart
templates" or "template packages". They consist
of folders containing files for every supported
language. These take care of choosing the right
template variant for your language, adds the
template to your database, and modifies it, if
necessary. Some smart templates add the current
date, insert the clipboard contents, check if a

DEVONnote 2.9.17 Documentation, page 19

needed application is installed, and even access the
Contacts application to fill in your personal details
from your card. See also p. 71ff
Use Open Templates Folder to open the folder

Mark: Allows you to mark the item as flagged/
unflagged, locked/unlocked, and read/unread. Items
marked as unread show an unread marker in most
views. See also p. 64ff

containing the template files in the Finder and More
Templates to install additional templates.

DUPLICATE

OPEN

Duplicate: Creates a duplicate of the selected
items. The name of the new item ends in "copy", and

Open: Opens the selected document or group in
a separate document window. For groups, this
command opens a second main window rooted to
the selected group.
Open in Tabs: Opens the selected items in a new
tab. You need have more than one item selected for
this command to have an effect.
LAUNCH, REVEAL, SHOW
Launch URL: Opens the file, folder, or Internet
location indicated by the URL field in the Info Panel.
Unavailable for feed articles if DEVONnote is
already your default news feed reader.
Reveal: Reveals the location of the frontmost
document in either the same main window, if
possible, or by opening a new one.
Show in Finder: Opens a new Finder window for
the folder, including the frontmost or selected
documents. Naturally, this only works for
documents referring to a file in the file system
through the Path field in the Info panel.
SAVE
Save/Save All/Revert To Saved: Use these
commands to save the frontmost document, all
documents, or to restore the frontmost document
to the last saved version. Hold the ⇧Shift key to
show the alternative menu item Save All.
LABEL AND MARK
Label: Allows you to mark the selected groups or
documents with one of seven labels, just as in the
Finder. You can define the color and the text of the
labels in the Preferences, Colors tab.

because their contents are identical both items are
marked with the icon for duplicates (or, depending
on your preferences, show their name in bold and
blue).
Replicate: Creates a replicant for the selected
items. Unlike a duplicate or alias, a replicant is like
a second phone book entry for the same person.
(Definition: Aliases are little files containing a link
to the original file). When you replicate a group or
document in DEVONnote, you end up with two
replicants, not one alias and one original. Both items
have the same name and are marked with the icon
for replicants (or, depending on your preferences,
show their name in red).
MERGE, TOC, SEND BY EMAIL
Merge: Creates one big document out of several
selected ones. This works for text documents,
images, PDFs, sheets, and multimedia items. All
the original documents are embedded in the
resulting document and all tags are added, too.
If the selection contains only images, PDF, or
PostScript documents, DEVONnote generates
a PDF file; otherwise DEVONnote generates a
rich text document. Document types that cannot
be merged are attached if possible (e.g. PDFs are
added as attachments to a rich text document).
This command can also be used to merge multiple
selected groups/tags; in this case, the first group is
used as the destination.
Create Table of Contents: Creates a rich text
document with links to all selected documents. Use
this command e.g. for creating customized index
pages for the website export.
Send by Email: Creates a new message in
the default email application and adds the
selected items as attachments. Supported email
applications are Apple Mail, Airmail 2, Mailsmith,
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Microsoft Outlook, Postbox, and PowerMail. If the
selected item is an email message, the sender is
automatically inserted as the recipient and the text
of the original message is inserted instead of an
attachment. Notes: Postbox is currently only able
to send one selected file. Unsupported email clients
(e.g. Thunderbird) can only send the plain text of one
selected file.
GROUP
Group/Ungroup Items: Creates a new group
containing all the selected items. This is similar to
creating a new group and moving the selected items
into it. This command also works in the See Also &
Classify drawer. Ungroup does exactly the opposite; it
moves all items contained in the selected group one
level up and removes the now empty group.
See Also & Classify: Opens or closes the See Also &
Classify drawer of a main window.
Note: If the document you are auto-classifying
has replicants, these are deleted and only the
original document is placed into the new location.
This prevents multiple replicants from being
created when you are, for example, classifying
this document again.
MOVE TO TRASH
Move to Trash/Move All Instances to Trash: Moves
the selected items to the trash. If you have selected
a replicated item, Move All Instances to Trash (hold
the ⌥Option key to reveal) moves this item and all
its replicants to the trash.

THE FORMAT MENU
The Format menu contains the commands and
options dealing with all aspects of text formatting.
Here you'll find the standard font, alignment, and
ruler commands, as well as very special DEVONnote
commands.
Note: Many commands in this menu only work
with rich text, Markdown, or formatted notes.
Plain text documents do not allow formatting.

(That's why they're called "plain" text.) Some
formatting options are also available for editable
PDFs and web archives.
FONT
Font: This sub-menu is reponsible for controlling
the font and the document background color (rich
text documents only). Open the fonts panel with
Show Fonts, then increase or decrease the font size
of selected text with Bigger and Smaller, adjust the
text styles and the document background color.
Using Copy Font, copy the font formatting of
a selected piece of text or the passage of text
around the insertion caret. You can then apply the
formatting to selected text using Paste Font.
Style: Commands in this sub-menu apply a certain
style, such as italics, bold, or underlined, to selected
text. Also, the commands give you access to some
high-end font control like kerning, baseline shift,
ligatures, and character shape (only applicable to
Asian languages).
The most interesting part here is Styles, which opens
the macOS styles editor. You can step through all
the styles used in the current document and add
them to your favorites. Use the pop-up menu to
select a saved style and, if you don't need it any
more, delete it. You can use saved styles from the
ruler (see below).
Note: If you think the user interface for the styles
editor is less-than-wonderful, you're right. But
don't blame us, it's Apple's design :-)
Alignment: Align paragraphs left, right, centered,
or justified. Here, Asian or Arabic users can also
change the direction of writing, if desired.
Ruler: Show the ruler, which shows the tab stops
and contains alignment and styles buttons; copy the
current ruler (line width, indents, tab stops, etc.) and
paste it somewhere else.
Learn more about the ruler and the Styles Editor
here.
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HIGHLIGHT
Highlight, Highlight Color: In rich text documents,
editable PDFs, and web archives use Highlight to
highlight a selected piece of text just as you would
using with a colored pen on a piece of paper. To
remove highlighting, select the highlighted piece of
text and choose Highlight again. Use the Highlight
Color sub-menu to choose your favorite highlight
color.
SPACING
Spacing: This command is only available in rich text
documents; the command allows you to adjust the
line spacing of selected text. You can adjust the
line height to an exact value or define a minimum
and maximum height, adjust inter-line spacing, and
define the space before and after a paragraph.
Note: Paragraph spacings are not added to those
of the preceding or following paragraph; instead,
the maximum spacings from both paragraphs are
used to ensure a proper layout.
Link: Makes selected text a link to a URL (for
example, to a web page or to an email address). This
is a one-step command for writing the address into a
rich text document, selecting the address, selecting
Make Link (see below), and then changing the linked
text to anything you want.
List: Creates a bulleted list. Select your prefix, bullet
style, and suffix in the dialog sheet and click OK to
insert your list skeleton. In the list, press ↩ to insert
new items, and press ⇥ and ⇧⇥ to indent/de-indent
items, just as you would in any word processor.
Table: Inserts a new table into a rich text document
and opens the table inspector panel. Use the
table inspector to adjust the number of rows and
columns, cell alignments, cell colors, border widths,
and colors. Also, you can merge and split cells and
create tables within a cell.
MAKE LINK
Add Link: Makes the selected text clickable and asks
for a destination. Enter any valid URL you want the
text to link to.

Edit Link: Shows an editing sheet where you can
change the URL of the selected link.
Make/Remove Link: Makes selected text clickable,
or removes a link from the current selection. Where
you are taken to when you click the link depends on
the selected text:
If the text was a valid URL, the URL will be the
target of the link. Editing the link text later does
not change the target. Use the Edit Link command
of the contextual menu to edit the link target.
Otherwise, DEVONnote treats the link as a Wikistyle link. Clicking the Wiki-style link jumps to
a document with exactly the same name as the
linked text (or any document with a Wiki aliasof
that name). If there is no document of that name,
clicking the link creates a new rich text document
named after the linked text and pre-filled by the
template you set in the Preferences, Editing tab.
Make Plain/Rich Text: Converts a rich text
document to plain text and vice versa. Converting a
rich text to plain text removes all formatting, while
converting a plain text document to rich text applies
default rich text font settings to the document.
INVISIBLES
Show Colors: Shows the color panel, e.g., for
changing the foreground color of selected text in
rich text documents.
Show Invisible Characters: Toggles display of
invisible characters such as spaces, tabs, and line
feeds. Shown invisible characters appear in light
gray.
Allow Hypenation: Enables or disables hyphenation
for the current rich text document.

THE VIEW MENU
The View menu contains all the commands for
modifying the way DEVONnote displays groups and
documents.
VIEWS
Using these commands, you switch between
different layouts for main windows:
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Split
Three Panes
Tags
VIEW OPTIONS
Full Screen: Displays either the current document in
a full screen mode optimized for reading and editing,
or the frontmost window in full screen.
Document: Shows the current document in full
screen.
Window: Shows the current window in full screen.

Columns: This sub-menu lists all columns available
in the current view and allows you to show or hide
them individually. Use these options to show exactly
the information you need.
The Flag column shows the state (flagged or
unflagged). Clicking the flag or the empty spot
for the flag toggles the option. Unread items are
marked as read when the "unread" state is clicked.
Both Sort and Columns support a range of metadata
fields next to DEVONnote's own data fields.

To return to the normal view, press ⌘F7 respective

EXPAND AND COLLAPSE

⌃⌘F7 or the EscapeEscape key. You define the width

Expands and collapses all groups at once.

of the document full screen view as well as plain
text font, background color, and text color in the
preferences, Editing tab.
Quick Look: Opens the Quick Look panel for the
selected items.
Slideshow: Shows the selected items as Quick Look
slideshow. Visible only when you visit the View with
the ⌥ key held.
VIEW LAYOUT
Widescreen: Switches Split, Three Panes, and Tag
views between standard and widescreen layout.
Show/Hide Details: Switches between displaying
icons only or displaying icons together with detailed
information such as kind, label, size, word count,
creation date, and modification date.
Show/Hide Tags: Shows or hides the tag bar.
SORT AND COLUMNS
Sort: Sorts items in ascending or descending
order by various criteria: name, kind, date added,
creation/modification date, URL, path, word
count, flag, label, width x height, duration, location
(enclosing group hierarchy of the item), aliases,
and Spotlight comment. You also can sort items
manually by choosing Unsorted. DEVONnote
remembers sort settings for every group separately
and uses those settings when the group is displayed
in its own main window.

Zoom In/Out: Zooms into or out of the document.
ZOOM
Actual Size: Depending on the document type, you
can zoom the document to your needs:
Actual Size: Displays the document at actual size,
calculated using the resolution of the screen and
the resolution information of the image or PDF.
Zoom In/Out: Zooms in or out of the document.
TOOLBAR OPTIONS
Hide/Show Toolbar: Hides or shows the toolbar of
the frontmost window.
Customize Toolbar: Lets you configure the toolbar
of the frontmost window.

THE GO MENU
The Go menu contains all commands for navigating
the hierarchy of your DEVONnote database. Use
these commands to go backwards and forwards
through your documents, or to move back to the top
level of the group hierarchy.
TOP GROUP, ...
Top/Enclosing Group/Selected Group: Goes
back to the top level of the group hierarchy, to the
group enclosing the shown group (if any), or to the
selected group ("hoist"). These commands are only
useful when you have opened a group in a second
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main window, so that the "root" of the window is not
the top group of database, or when you are using
DEVONnote in outline mode.
Back/Forward: Moves backwards and forwards
through all documents/web pages you have visited
by following cross-links or Wiki-style links.
INSTANCES, HIGHLIGHTS

Close, Select Next/Previous Tab: Closes the active
tab or moves the focus to the next or previous tab.
Note: Tabbed browsing needs to be enabled for
these commands to work.
Keep Windows in Front: Keeps all DEVONnote
main windows in front of all other windows. Useful
for dragging contents from other applications to a
DEVONnote note.

Previous/Next Instance: Navigates backwards
and forwards through all instances of a replicated
document. Use these commands to find out where
the other instances of a replicated item are.
Alternatively, you can use a smart group to find all
documents that have replicants.

Bring All to Front: Brings all windows of
DEVONnote to the front. Hold the key to change
Bring All to Front to Arrange in Front.

Previous/Next Highlight: Navigates backwards and
forward through all highlighted passages within a
document, regardless of whether these passages
have been highlighted by a search or by manually
using Format > Highlight. Use these commands to
visit all found text passages or highlighted passages
in a document.

INFO PANEL

Note: Due to limitations in the system
frameworks it's not possible to navigate to the
first occurrence in web archives and HTML
documents.
Page: Navigates to the page with the entered page
number.
Time: Jumps to the specified time in a movie.

THE WINDOW MENU
As in any Cocoa application, the Window menu lists
all open windows of the active application and gives
you access to commands for managing them.
WINDOW COMMANDS
Close, Zoom, Minimize: These three commands
resemble the red, yellow, and green buttons of
any window title bar, and consequently close the
window, minimize the window to the Dock, or
maximize the window. No magic here. Hold the key
to change Minimize to Minimize all.

Window List: Selects any open window from the
menu to bring it to the front.

Show Info: Opens the Info panel that shows
basic information about selected items. As it is a
panel, selecting a new item updates the Info panel
accordingly.
DOCUMENT PROPERTIES
Show Properties: Opens the document properties
panel. View or edit the properties such as author,
subject, or keywords in the frontmost document.
LOG PANEL
Log: Opens the Log panel. The log lists error
messages and warnings that occurred while
importing new documents. It also opens
automatically when an error occurs. You can save
the log to a text file or clear it.
TAKE NOTE
Opens the Take Note panel that lets you quickly
write a plain text note and add it to the default
destination.

THE SERVICES MENU
The DEVONnote > Services menu allows access
to special commands published either by other
applications, such as TextEdit or Safari, or by
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services extensions such as DEVONtechnologies'
WordService or CalcService. Also, DEVONnote
publishes its own services in the Services menu.
See also p. 14ff

Hold the ⌥Option key to show the alternative
menu item Report Bug. It creates a new message in
yourdefault email client or Apple Mail containing
the Console log and all related crash logs in a Zip
archive, ready to be sent to DEVONtechnologies'
customer support.

THE HELP MENU
The Help menu contains commands for opening
the integrated help pages, the support assistant, or
visiting the DEVONtechnologies website.
DEVONNOTE HELP
These commands open the integrated help pages
that are equal to the document you're reading or
open the release notes.
TUTORIALS, SUPPORT ASSISTANT
Support Assistant: Opens the support screen
of the Welcome to DEVONnote assistant where
you can get support, retrieve your license code,
request a trial extension, or update your details in
DEVONtechnologies' customer database. You can
also install additional scripts or templates from the
assistant.
Note: If you purchased DEVONnote from the
Mac App Store, all options dealing with licenses
or upgrades are not available.
Tutorials: Opens the Tips and Tutorials screen of the
Welcome to DEVONnote assistant. The tutorials help
get you started by explaining everyday DEVONnote
tasks in step-by-step detail. This function requires
an Internet connection.
DEVONTECHNOLOGIES
These commands take you directly to the
corresponding pages on the DEVONtechnologies
web site. Visit our home page or the lively user
forum. If you have a question or suggestion, send
feedback directly to our development team.

THE DOCK MENU
The Dock menu appears when you click DEVONnote's
icon in the Dock with the ⌃ key pressed, when you
right-click it, or when you left-click it and hold the
mouse button for one second or longer.
DEVONnote's dock icon also displays a badge with
the number of new items, e.g., after adding new
data via the Services menu. Longer tasks--importing,
indexing, running scripts--show a progress indicator
on the dock icon, too.
For all macOS applications, the Dock menu provides
a selection of the commands of the application
menu.
<Window Name(s)>: Brings any open window of
DEVONnote to the front.
Remove from Dock: Removes DEVONnote
from the Dock. Only available if DEVONnote
was added permanently to the Dock and is not
currectly open.
Open at Login: Adds DEVONnote to your login
items.
Show In Finder: Reveals the DEVONnote
application package in the Finder.
Hide: Hides all windows of DEVONnote.
Quit: Quits DEVONnote.
Besides these standard commands, DEVONnote
adds a number of its own commands to the Dock
menu to make them easily accessible whenever the
application is running.
Take Note: Opens the Take Note panel.
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WINDOWS & PANELS
In this chapter:
Main window
Document window

27
32

Info panel
Document Properties
Take Note
Log
Preferences

33
34
34
34
34

Database Properties
Assistant

35
35

DEVONnote uses a number of windows to present
information. These windows are used for displaying
and manipulating groups and documents, finding
information, editing metadata, analyzing text, and
changing the properties of your database.
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MAIN WINDOW
Most of your time working with DEVONnote will
be spent in a main window. Main windows give you
access to your groups and documents, while also
allowing you to view and edit files.
Open a new main window with File > New Window.
DEVONnote also opens a new window when you
open a database; you can set this option by checking
Open New Window in Preferences, General tab.
The title of the window shows the name of
document or group if one is selected, as well as its
icon. Click-and-drag the icon to move it to another
group or database or to the Finder to export it.
Click the title bar with ⌘ pressed to reveal the
document's location within the database; select an
enclosing group to reveal it.
VIEWS
Different views present your information however
you prefer:

Split: Splits the window into an item list and a
view/edit pane. To switch between a vertical and
horizontal split, use View > Widescreen. The item
lists all groups and documents in the database,
and may contain one or more columns. By default,
it shows only item names. Expand/collapse
groups by clicking the gray triangle.
Three Panes: Resembles the way Apple Mail
displays folders, items, and contents. The pane
on the left displays all groups, the top right pane
displays the documents contained in the selected
group, and the view/edit pane at the lower right
shows the contents of the selected document,
and allows you to edit it if possible. Tip: When you
click the Home button on the toolbar, you can see
the files located in the root of your database.
Tags: Shows all documents in a database for
selected tags. Select a tag to show all items
carrying this tag; select multiple tags (e.g. by
selecting them with the ⌘ key held) to show
documents carrying all selected tags. Select no
tag to show all items. Delete tags by pressing the
Delete or Backspace key; this moves ordinary tags
to the trash and excludes group tags from tagging.
New documents created in this view are either
created in the group represending the tag or in
the global inbox, and are tagged with the selected
tag. See also p. 68ff
To adjust the size of the different panes, move the
mouse to the divider between two panes until the
mouse pointer changes into a line with two arrows.
Then, click on and drag the divider to adjust the size
of the panes.
ITEMS
DEVONnote displays groups and documents,
much as the Finder does. Select items with a single
click, and drag them from one group to another.
You can also drag items to the Finder or other
applications, or drag folders and files from the
Finder to DEVONnote. You can also drag selected
items or clippings such as text and images from any
application to DEVONnote and vice versa.
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Press the ⌘ and ⌥ keys to link to the dragged
item(s) instead of importing them to the database.
For Bookends 11.3.1 or later this adds a formatted
rich text instead of a simple reference.
Single-click items to rename them. Double-click
items to open them in a separate document window
or in their native application (depending on the
document type). For smart groups, double-clicking
them in any view except Icons view opens the Smart
Group Editor. Press the Space bar to preview the item
using Quick Look; close the preview with the close
gadget or press Escape or Space again to close it.
Colored item names, colored group icons, and
special icons tell you whether an item is a duplicate
or replicant, its read/unread status or what type of
search a smart group uses.
Empty groups are shown in gray.
Duplicates are shown with their name in blue;
replicants are shown in red. See also p. 20ff
Icons of feeds or other unread items show an
"unread" indicator in the State column. See also p.
40ff
Smart groups using dates are shown with a clock
icon; smart groups using the "unread" status are
marked with a unique icon, too.
Regular groups are shown in blue, while groups
also used for tagging are shown in yellow with a
"tag" icon embossed.
In addition, icons indicate whether a item is locked,
has an attached comment or script, or has been
indexed instead of imported. See also p. 67ff
To view or edit the contents of a document or group,
do the following:

Vertical/Horizontal Split/Columns View: Select
the group or document. The view/edit pane
shows the contents of the group or document.
Click the triangle in front of a group to expand it,
then select a document to view or edit.
Three Panes View: Select a group or sub-group,
then select the document you want to view or
edit. DEVONnote shows the group or sub-groups
content in the view/edit pane. Click the triangle
in front of a group to expand it. When you select
multiple groups or news feeds, the upper right
pane shows all documents in all selected groups
in one list, just like in Apple Mail. This does not
work for smart groups.
VIEW/EDIT PANE
The view/edit pane shows the content of the
selected document and, if possible, allows you to
edit it. You can edit plain and rich text.
Read more here about the various document types
that you can view or edit in this pane.
The view/edit pane can be subdivided into tabs
when you select one or more documents, right-click
them, and choose Open in Tabs from the contextual
menu. Create new tabs with the + button, close tabs
with their X button. You can also manage tabs by
right-clicking onto any tab to open the contextual
menu.
INFO BAR
Just below the toolbar you'll find the info bar.
For selected items it shows an icon, the file
name including location, and the kind, size,
and modification date. If you're not sure of the
document type, this is the place to look.
Use the slider located on the right side of the info
bar to adjust the size of icons.
TOOLBAR & SHORTCUTS
The toolbar of DEVONnote main windows carries
many commands for manipulating the way the
application displays information and handles
selected items. Many of the toolbar items are simply
shortcuts for menu commands. Here's a short list of
the available tools:
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Please find a list of shortcuts in the appendix. See
also p. 67ff
Navigation: Navigates to the top level of the
database, or one level up. Useful when you have
opened a second main window by double-clicking
a group, and now want to move up the groups
hierarchy in this window.
View: Switches between the possible views. See
above.
Actions: Provides commands for modifying the
selected documents, similar to the Action menu in
other views. Generally, the Action menu contains
a selection of the commands also available via the
contextual menu.
Group +: Creates an empty group.
Smart Group +: Creates a new smart group.
Plain/Rich Text +: Creates a blank plain or rich text
document.
Link +: Creates a new link document.
Mark Up: Highlights, underlines or strikes through
selected text. This option is available for rich text
documents, editable PDFs, and web archive.
Highlight: Highlights the selected piece of text
with the color selected in Preferences, Colors tab.
Open: Opens the selected documents in separate
document windows.
Launch URL: Opens the Internet location stored
in the URL field of the selected documents, e.g., a
web site URL in Safari.
Copy URL: Copies the Internet location stored in
the URL field of the selected document to the
clipboard.
Delete: Moves the selected documents to the
Trash.
Save: Saves all changes to the currently edited
document.
Import, Export: Imports new documents; Exports
the selected documents.
Reveal: Reveals the location of the selected items
in either the same main window, if possible, or by
opening a new one.
Show in Finder: Opens a new Finder window
showing the selected items.
Print: Prints the current or selected documents.
Info: Opens the Info panel.

Group/Ungroup Items: Group creates a new
group and moves all selected documents into it.
Upgroup moves all documents contained in the
selected groups one level up and then deletes the
then-empty group.
Find (search field): Lets you search your databases.
Select your search options from the magnifier
pop-up menu, enter your search term, and press
Return. Click the search field's search button
to return to the standard view. The pop-up
menu also lists the last 25 used search terms.
Check Prefix while typing to let DEVONnote
begin to search as you type. The last word of the
term is treated like a prefix ('word*'). Add more
characters to refine and to speed up the search
and press Enter or ↩ to finish the search, or to
search for whole words only.
Bigger, Smaller Font: Increases or decreases the
font size.
Subscript, Superscript: Makes selected text
subscipt or superscript.
Ruler: Shows or hides the ruler for rich text.
Fonts: Shows the standard macOS Font panel.
Colors: Shows the standard macOS Colors panel.
Make Plain/Rich Text: Converts the current text
document to plain or rich text.
Highlighting: Highlights selected text. The pop-up
menu lets you select the highlight color.
Link: Makes selected text a Wiki-style link. If the
text is a URL, the link points to that URL.
Zoom: Zooms in, out, or to view width, or shows
the document in 1:1.
Full Screen: Shows the selected documents in full
screen mode. Press ⌘F8 to return to windowed
mode.
(Capture) Note: Captures selected elements of a
web page as a rich text document to either the
current group or to the inbox.
DEVONagent: Opens DEVONagent. If the view/
edit pane or frontmost window displays a web
page, it opens the same URL in DEVONagent.
Refresh: Refreshes the selected news feeds.
Backup: Creates an internal backup of the
database and then optimizes the database
structure; same as File > Backup & Optimize.
Verify: Verifies the database structure; same as
File > Verify & Repair.
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Send by Email: Creates a new message in
the default email application and adds the
selected items as attachments. Supported email
applications are Apple Mail, AirMail, Mailsmith,

New Smart Group: Creates a new smart group in
the sidebar.
Edit: Opens the smart group editor (only available
for smart groups).

Microsoft Outlook, Postbox, and PowerMail. If
the selected item is an email message, the sender
is automatically inserted as the recipient and the
text of the original message is inserted instead of

Delete Smart Group: Removes the selected smart
group from the sidebar.

an attachment. Notes: Postbox is currently only
able to send one selected file. Unsupported email
clients (e.g. Thunderbird) can only send the plain
text of one selected file.
Take Note: Lets you take a quick note.
Note: Not all of these commands are always
available. You can customize the toolbar
by selecting View > Customize Toolbar or by
clicking with ⌃ pressed (right-click) the toolbar
background and selecting Customize Toolbar from
the contextual menu.
CONTEXTUAL MENU
The contextual menu (which appears when you
right-click or ⌃ click an item) offers a range of
commands tailored to what you wish do with the
clicked object.
Most of the commands offered by the contextual
menu have counterparts in a main menu, so you'll
recognize them immediately. However, to save
menu bar real estate, DEVONnote gives you access
to some options only via the contextual menu.
New Window: Opens a new main window.
Open Database: Opens the selected database.
Close Database: Closes the selected database.
Delete Database: Closes the selected databases,
and moves it to the Finder's trash.
Empty Trash: Empties the trash can.
Database Properties: Shows the Database
Properties of the selected database.
Add to Favorites: Adds the selected item to the
favorites.
Remove from Favorites: Removes the selected
item from the favorites.
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New: Creates a new document.
Open: Opens a selected document(s) in a new
window.
Open in Tabs: Opens a selected document(s) in a

Mark: Marks the selected items as flagged/
unflagged, read/unread, locked/unlocked and
shows/hides the state of the items.
Move To Trash/Move All Instances To Trash:

new tab.
Open With: Opens a selected document(s) with an
external application.
Reveal: Reveals the location of the selected items

Moves the selected document or all instances
of the selected documents, such as including all
replicants (if any), to the trash. Hold the ⌥Option

in either the same main window, if possible, or by
opening a new one.
Refresh Feed(s): Manually refreshes the selected
news feeds.
Launch URL: Opens the URLs indicated by the URL
field of the selected documents.
Copy URL: Copies the Internet location indicated
by the URL field of the selected document to the
clipboard.
Copy Item Link: Copies a unique URL refering
the selected item to the clipboard. Paste this
URL into any third-party application to directly
reference an item in your DEVONnote database.
See also p. 76ff
Show in Finder: Reveals the item's file in the
Finder.
Get Info: Opens the Info panel for the items.
Move Into Database: Imports the selected indexed
item (and its children, if necessary) into the
database. Only available for indexed items. Use
this command to consolidate your database.
Move To External Folder: Moves items added
to an indexed group from the database to the
connected folder in the filesystem. Only available
for items in an indexed group.
Exclude from Tagging: Excludes the selected
groups from tagging.
Move To >: Moves the group or document to the
group you select in the sub-menu. Note: Moving
items to another database cannot be undone.
Replicate To >: Creates a replicant of the group
or document in the group you select in the submenu. Note: Doesn't replicate if a replicate for
the item is already present at the destination.
Duplicate To >: Creates a duplicate of the group
or document in the group you select in the submenu. Note: Copying items to another database
cannot be undone.
Label: Changes the label of the selected items.

key to reveal the Move All Instances To Trash
command.
Thumbnails: Creates, updates, or deletes the
thumbnails for the selected items.
Convert: Converts the selected items to other
document formats.
Group: Creates a new group containing the
selected items. Appears as Tag if the new group
would be created in the Tags group.
Auto Classify: Classifies the selected items and
moves them to the group where they best fit.
Send by Email: Creates a new message in
the default email application and adds the
selected items as attachments. Supported email
applications are Apple Mail, AirMail, Mailsmith,
Microsoft Outlook, Postbox, and PowerMail. If
the selected item is an email message, the sender
is automatically inserted as the recipient and the
text of the original message is inserted instead of
an attachment. Notes: Postbox is currently only
able to send one selected file. Unsupported email
clients (e.g. Thunderbird) can only send the plain
text of one selected file.
Sort: Sorts the list of items to any available
criterium.
Empty Trash: Empties the trash (only available for
the trash).
In the Tags view, the following commands are
available:
Save Search: Available in the right pane of the Tags
view, this command creates a smart group from
one or multiple selected tags. Use it to select
some tags and to save the search as a smart group
for convenient access.
The Tabs bar offerst he following commands:
New Tab: Creates a new, empty tab. Choose a new
document and it will show up here.
Close Tab: Closes the selected tab.
Close all Tabs: Closes all tabs.
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Note: For your convenience, DEVONnote
also makes the Services menu, available via the
contextual menu.

DOCUMENT WINDOW
A document window is similar to the view/edit pane
of a main window. You open a document window by
double-clicking a document in any view of a main
window or by choosing Data > Open (or any of its
equivalents in contextual menus).
Depending on the type of information the document
contains, the toolbar of a document window offers
different sets of tools. Most of them are identical to
their counterparts in the DEVONnote main window
toolbar.
See the Documents chapter for a detailed
description of the various document types.
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INFO PANEL
The Info panel, just like its counterpart in the
Finder, displays additional information about a
selected document or group, from icon and name to
comments and other metadata.
Open the Info panel using the i icon from the
window toolbar or by selecting Window > Show Info"
The contents of the Info panel corresponds to the
currently selected object, so you can leave it open
all the time and it will always display the correct
information for the selected document or group.
HEAD ELEMENTS
Icon and Name: Just like in the Finder, the top
part of the panel displays the icon and the name
of the selected object. To change the name of the
document, use the Name field below.
Locked: The Locked checkbox indicates that the
object is write-protected. Check the checkbox
to protect documents from being accidentally
modified, or groups and documents from being
accidently deleted. Locked documents or groups are
marked with a padlock.
MAIN ATTRIBUTES
Name: Use this field to change the name of the
object.
Aliases: Enter one or more words here, separated
by semicolons, as alternative targets for Wiki-style
links. Generally, Wiki links refer to the name of
contents, and aliases make this system even more
flexible.
Path: This field contains the path to the file holding
the document's data. It is non-editable. You can click
the @ button to open the references file using the
Finder. In general this is equal to using Data > Open
With and choosing the default application.
URL: Smiliar to the Path field, the URL field is used
to link the document to an Internet address or
anything else that can be reached by a URL. This
field is used primarily by bookmarks, but you can
also use it to connect a document to a web page.

To visit the web page click the @ button next to this
field or select the document and use the contextual
menu command Launch URL.
INFORMATION ELEMENTS
Size: Shows the size of the item. For groups and
news feeds, this field shows the size of all contained
items.
Kind: Shows the selected document type (for
example text, RTF, etc.)
Added: Shows the date when the object was
actually added to the database.
Created, Modified: Shows the (editable) dates when
the object was created and when it was modified the
last time.
ADDITIONAL INFORMATION
This section lists metadata that has been stored
together with the item. Information shown depends
on the file type as well as the individual document.
ADDITIONAL ELEMENTS
Exclude from ...: These checkboxes allow you to
exclude this item from being used in classification,
see also, search, or tagging. Use this option to
exclude such things as temporary groups from
classification to increase the accuracy of the built-in
artificial intelligence.
Label: Shows the label assigned to this item and lets
you change it.
Tags: Shows the tags assigned to this item. You can
also edit tags here. See also p. 68ff
Location: Shows the location of this item inside the
database.
Instances: Shows how many replicants of this
document or group exist in the database and how
many duplicates DEVONnote has identified. Click
to show a pop-up menu listing all instances and
duplicates and their enclosing groups. Select any
item to reveal it. Point at an item for a second
to make a tooltip appear that shows the item's
location.
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Spotlight Comments: Stores other information
you want to attach to your document or group
(similar to the Spotlight comments field in the
Finder). Of course, the Comments field is searchable.
DEVONnote synchronizes the Spotlight comments
in the Finder with this field in the database. If this
application was purchased in the App Store, only
importing Spotlight comments is possible.
Note: You can modify the comments of multiple
selected items simultaneously, as long as the
comment of all selected items is either identical
or empty.

DOCUMENT PROPERTIES
The Document Properties panel gives you access to
all metadata stored for a selected document. This
metadata includes, but is not limited to:
Author
Company
Copyright
Title
Subject
Keywords
Comments
Depending on the document type, you can edit or
view these properties. More fields may be available
depending on the document type.

Change the hot key for opening the Take Note panel
in the preferences.
Note: For this function DEVONnote needs to be
running. This may change eventually.

LOG
The Log panel displays warnings and error messages
that occur, when importing files and folders and
performing other actions. The panel shows the
date of the message, the affected file, and a short
information about what happened.
You can save the list to a text file with the Save
button, and clear the log with the Clear button. To
sort the log, click the column title. (Click again to
reverse the sorting order.) Use the contextual menu
or double-click the entry to reveal an affected file in
the Finder.
Uncheck Show log automatically to prevent the log
popping up automatically. You can open the Log
panel at any time using Window > Log. For important
notifications the log is always shown automatically,
ignoring this setting.
Right-click or click with ⌃ held to perform additional
commands on log entries via the contextual menu,
e.g., to reveal a logged item or move a logged item
to the trash. Copy information from the log to the
clipboard with Edit > Copy, ⌘C, or the contextual
menu.

TAKE NOTE
The Take Note panel, opened by hitting a hot key,
from the toolbar, or from the Window menu, allows
you to quickly enter a note, choose the destination,
and add tags and a URL to the note. If DEVONnote
can get the URL of the frontmost application, e.g.,
from Safari, it will also insert that information
automatically into the URL field.
Use the Format pop-up menu (in the panel) to
choose the document format for the new note. Use
the commands in the Format menu (from the menu
bar) to style your note.

PREFERENCES
The Preferences window, opened using DEVONnote
> Preferences, contains all available options, which
you can modify to adapt DEVONnote to your
personal needs.
Because the preferences are so important, we have
created a separate chapter for them.

The New Group button creates a new group in the
destination group selected above.
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DATABASE PROPERTIES
The Database Properties panel defines preferences
which are directly related to the database and not
to the application in general. Open the properties
panel using File > Database Properties for every open
database including the global inbox.
LOCATION
This section of the properties panel shows the
location of the database package and any additional
options:
Location: Double-click any part of the database
location to reveal it in the Finder.
Create Spotlight Index: Check to make this
database available to Spotlight. Checking this option
lets DEVONnote create a folder in "~/Library/
Cache/Metadata" that Spotlight uses for accessing
the documents in the database. If you ever feel that
this folder is out-of-sync with the database, click
Rebuild to recreate this folder from scratch.
When viewing Spotlight results in a window, make
sure to have the Show all file extensions option in
Finder's Preferences, Advanced tab unchecked. If this
option is checked, the Finder displays the generic
names of the metadata cache files instead of the
name of the referenced document.
Starting with version 2.0.6, DEVONnote adds
information to the Spotlight metadata that makes it
possible to preview many file types directly from the
Spotlight results window. Supported are text and
rich text (RTF and RTFD) files. DEVONnote needs
to be installed on the machine viewing the Spotlight
results. You may need to rebuild the Spotlight index
to activate this function.
Note: Rebuilding the Spotlight index can become
necessary after copying a database from one
computer to another.

Exclude Groups from Tagging: Excludes all groups in
this database from being used as tags. Ordinary tags
can always be added to items using the Tag bar.
STATISTICS
This section displays some basic statistics about
how many documents your database contains, file
sizes, etc.
NAME AND COMMENTS
Name: Enter a name for your database here. It will
appear in the title bar of every main window of this
database.
Note: This does not change the file name for
the database package. You cannot change the
name of or add commments to the database
representing the global inbox.
Comments: Enter your own comments about the
database here, e.g., a project description.
PROTECTION
To prevent other people from opening DEVONnote
and accessing your data, click on the padlock button
to unlock the entry fields, enter a user name and
password, and then click on the padlock button again
to lock your changes and hide the password.
Note: This is a simple password protection.
DEVONnote does not yet provide file encryption
for enhanced security. For better protection,
create an encrypted disk image using Disk Utility
and store your database on that encrypted
volume or disk.

ASSISTANT
The integrated Assistant combines a welcome screen
with tips, web and video tutorials, installable extras,
and a suppport page that guides you through the
available support options.
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WELCOME
This screen welcomes you when you start
DEVONnote for the very first time. It offers:

Both tips and tutorials are updated live from
DEVONtechnologies' server so it's a good idea
to check back on a regular basis. The latest tip or
tutorial is also always mentioned on the welcome

An introductory screencast
The option to subscribe the free
DEVONtechnologies newsletter, as well as a
number of welcome tips
The tip of the day

screen.

The extra of the day

extras that you can download and install from
DEVONtechnologies' server:

You can access all other screens of the assistant
from here, too.
GET SUPPORT
The support screen guides you through the
three common steps for troubleshooting
DEVONnote. In addition, you can have your license
code resent in case you don't have it anymore,
request a trial extension, update your details in
DEVONtechnologies' customer database, or buy an
upgrade or a second license.
TIPS AND TUTORIALS
Here you can find the latest tips and tutorials to
help you squeeze the best out of DEVONnote.
Tutorials can be slideshows describing basic tasks in
DEVONnote or screencasts.

INSTALL EXTRAS
On the extras screen, DEVONnote lists all available

Scripts
Templates
Plugins
Browse the list of extras and install them with the
Install button. The last line of the description shows
where in the Templates menu the extra will show up
after installation. Remove installed extras with the
Remove button.
The extras are updated live from
DEVONtechnologies' server so it's a good idea to
check back from time to time. The latest extra is also
always mentioned on the welcome screen.
Note: If one of these categories does not show up
in your copy of DEVONnote, there might be no
extras of this type (yet) available for DEVONnote.
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DOCUMENTS
In this chapter:
General
Plain and rich texts

37
38

Formatted notes
Web pages, HTML pages, feeds
Office documents, email, and others

40
40
42

All documents are displayed in DEVONnote in
views. Each view features its own tools, contextual
menu commands, and hidden keyboard shortcuts. In
this chapter, we will look at many of those features.

GENERAL
All documents are displayed in DEVONnote in views
(not to be confused with the different layouts in
main windows, also called views. Each view has
its own tools, contextual menu commands and
keyboard shortcuts.
Documents are automatically saved every
five minutes after the last modification, when
deactivating the window, or when quitting
DEVONnote.
Currently, DEVONnote features the following view
types:
Plain and RichText
Office and other documents
HTML pages, Web pages, Feeds
NAVIGATION BAR
At the top of the view/edit pane DEVONnote shows
a navigation bar that gives you access to some
additional tools that deal directly with the contents
of the document. Which tools are available depends
on the type of the document.

Navigates back to the last visited document
after following a link.
Navigates back to the next visited document
after going back.
Reloads the displayed page in a web view. This
item is only visible for document types that
support reload, e.g. bookmarks.
Shows an action menu with options for opening
the shown page in Safari, copy its address, or
capture the page in a variety of formats.
Shows the system-wide sharing menu.
Locks or unlocks the item.
Scrolls to the previous highlight, e.g., a search
term occurrence.
Scrolls to the next highlight, e.g., a search term
occurrence.
Scrolls to the next page of the displayed
document.
Scrolls to the previous page of the displayed
document.
Switches to text-only mode.
Switches from text-only mode back to the
(standard) preview mode.
Opens the See also & Classify drawer.
Shows a list of the most important words of the
document.
Switches the tag bar on and off.
The text-only mode can be useful for selecting text
in items that are displayed using Quick Look or to
view or edit the source code of an HTML document.
In preview mode DEVONnote uses Quick Look to
show Pages documents and other filetypes in their
original layout. Select any word from the menu to
show documents also dealing with this keyword.

DEVONnote 2.9.17 Documentation, page 37

URL: Shows the URL associated with the displayed
item. If a PDF annotation is selected the URL field
shows the associated URL if available. Click to
launch the URL in its default application. Hold
the ⌥ or the ⌘ key to open the URL in a new tab.
Holding Shift-Option or Shift-Command opens the
URL in a new tab and selects it.
Word Count: Shows the number of paragraphs,
words, and characters of the displayed text.
Page Count: Shows the number of pages as well
as the page number of the currently displayed
page. Click the page number in PDF or PostScript
documents and enter a page number to jump
directly to that page.
TAG BAR
The Tag bar, which can be shown or hidden, shows
all tags associated with the document. Click the
tag bar and type to add tags; select a tag and press
the Delete or Backspace key to remove it. See also p.
68ff
When you type the name of a tag, DEVONnote
offers automatic completion. Choose the right
option with the mouse or the arrow keys and press
↩ or Enter to accept it. Press Escape to use whatever
you entered. Auto-completion prefers ordinary tags
(tags represented in the Tags group) over groups
used as tags, and also matches sub-strings. Press ⇥
to enter another tag.
Note: The Tag bar is also visible for multiple
selected documents when all the documents have
the same tags attached. Use it to change the tags
on multiple documents.
TOOLBAR & SHORTCUTS
Please find a list of shortcuts in the appendix. See
also p. 68ff

PLAIN AND RICH TEXTS
The view for plain and rich text documents is
basically a built-in incarnation of TextEdit, and you
use it in a very similar fashion. Of course, text views
support the Edit > Find commands and all options of
the Format menu.

THE RULER
For rich text documents, DEVONnote supports the
standard ruler that the TextEdit engine of macOS
provides. Show or hide it with Format > Ruler >
Show/Hide Ruler.
The ruler contains the following elements:
Tab Stops: Place tab stops with the mouse, then
remove them by dragging them off the ruler.
Drag new tab stops (left aligned, centered, right
aligned, or decimal aligned) from the repository
at the right side to their desired positions on the
ruler. Use the mouse to adjust the left and right
margins and indent.
Styles: Select a predefined text style from the popup menu. To define your own styles, choose Other
to open the standard macOS style editor. In the
style editor, navigate back and forth through the
styles of your document or the stored favorite
styles. (Use the radio buttons to switch between
document and favorite styles.) Click Select to
select all occurences of text with the displayed
style in the document, click Apply to apply the
style to selected text, or click Done to leave the
style editor. To add a style from your document
to Favorites, click Add To Favorites; to remove a
favorite, click Remove From Favorites.
Alignment: Align the current paragraph (the one
with the insertion caret inside) left, centered,
justified, or right by clicking the according
alignment buttons in the ruler.
Spacing: Choose the desired spacing for the
current paragraph from the Spacing pop-up
menu. Choose Other to enter values other than
the ones shown.
Lists: Make the current paragraph a list (indented
and with a bullet or numbered) by choosing the
desired list style from the Lists pop-up menu.
Choose Other to define your own list style.
Note: The built-in "mini outliner" is an nice
feature. On any blank line in a rich text document
(doesn't work for plain texts), type ⌥⇥ to create
a bullet point (macOS shows dashes instead of
bullets). Press ↩ for the next item, and so on.
Additional ⌥⇥ will increase the indentation; a
↩ on a blank list line will decrease it. The mini
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outliner uses hyphens to indicate list items by
default. Right-click to choose all kinds of list
styles.
ATTACHMENTS
You can attach other documents to rich text
documents simply by dragging them into the text.
Technically the rich text document becomes a .rtfd
package and the dragged file is saved as part of
the package. Drag items into plain texts with
⌘Command and ⌥Option pressed to insert only
their titles.
Use the contextual menu to show an attachment's
content in a Quick Look preview.
Double-click attachments to edit them externally.
Note: You cannot attach files to plain text
documents. You need to convert them to rich text
before you can attach other files.
DRAG-AND-DROP
Besides dragging text from and to text documents
you can also drag the following:
Files: Adds the file as an attachment to a rich text
document. Hold ⌘Command and ⌥Option to
insert only a link to the file.
Contact cards: Drag a card from Contacts holding
⌘Command and ⌥Option to insert a link to the
card.
Calendar event: Drag a Calendar event to insert a
short text summary of the event including a link
to Calendar.

CONTEXTUAL MENU
Add Link: Makes the selected piece of text a
WikiLink. The destination of the WikiLink is a
document with the same name as the selected
text. If no document with that name exists,
clicking the created link creates it using the
template you have set in the Editing Preferences.
Add tag [word]: Tags the document with the
selected word (only available if the word is not
already a tag of the document).
Copy Link: Copies a link to the Clipboard (only
available for selected links).
Edit Link: Edits the destination of a selected link.
Highlight: Highlights the selected piece of text
with the color you select in the sub-menu.
Insert Link To: Inserts a link to an item you select
in the sub-menu (only available when no text is
selected).
Insert: Inserts special elements into the text (such
as a page break, the current date or a bullet).
Same as the Insert sub-menu of the Edit menu.
Insert Link To: Inserts a cross-link to the group or
document you select in the sub-menu.
Link To: Makes the selected piece of text a crosslink and links it directly to the group or document
you select in the sub-menu.
Look Up [word]: Looks the selected text up in
macOS's Dictionary.
Open Alias: Follows a selected link (only available
for a selected Wiki-style link resolved by an alias).
Aliases are defined for each item separately in
the Info panel.
Open Link in Browser: Opens the selected link in
the default browser or application (only available
for a selected link).
Open Link in New Tab: Opens the selected link in a
new tab.
Quick Look Attachment: Opens a Quick Look
panel for the selected attached link or file.
Remove Link: Makes a selected link simple text.
Search selected phrase: Searches for the selected
text as a phrase.
Search with Google: Opens your default browser
and searches for the selected text in Google.
Search with Spotlight: Searches for the selected
text using Spotlight.
See [word]: Opens a drawer with documents
related to the selected word.
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See Related Text: Opens a drawer with documents
related to the selected text passage (only
available when more than one word is selected).
Set Name As: Renames the document according to
the selected piece of text (needs to be less than
256 characters).
Split Document: Splits the document at the
current insertion mark position.

FORMATTED NOTES
Formatted notes allow to write simple formatted
text including embedded images that can be viewed
on any system with just a web browser. While the
range of formatting options is smaller that that of
rich text they are much more compatible to today's
standards. You can find all available formatting
commands in the Edit and Format menus. By default
formatted notes use the font set in Preferences >
Editing for rich texts and notes.
Technically formatted notes are based on HTML,
the language of the world-wide web. Images are
embedded directly into the HTML code so that
formatted notes are completely self-contained.
The HTML code is also cleaned from unnessessary
tags and an identifying meta tag is inserted that
lets DEVONnote distinguish formatted notes from
normal HTML pages. Form tags, e.g., for checkboxes
and input fields are not removed and the status of
checkboxes and form fields is retained.

CONTEXTUAL MENU
Add Link: Lets you enter a URL and makes the
selected text a link to it.
Add Tag [word]: Tags the document with the
selected word (only available if the word is not
already a tag of the document).
Edit Link: Edits the destination of a selected link.
Highlight: Highlights the selected piece of text
with the color you select in the sub-menu.
Insert > ...: Inserts special characters or
checkboxes into the document.
Link To: Makes the selected piece of text a crosslink and links it directly to the group or document
you select in the sub-menu.
Look Up [word]: Looks the selected text up in
macOS's Dictionary.
Open Link in Browser: Opens the selected link in
your default web browser.
Open Link in New Tab: Opens the selected link in a
new tab.
Remove Link: Makes a selected link simple text.
Search selected phrase: Searches for the selected
text as a phrase.
Search with Google: Opens your default browser
and searches for the selected text in Google.
See [word]: Opens a drawer with documents
related to the selected word.
See Related Text: Opens a drawer with documents
related to the selected text passage (only
available when more than one word is selected).
Set Name As: Renames the document according to
the selected piece of text (needs to be less than
256 characters).

WEB PAGES, HTML PAGES, FEEDS
HTML views display web pages stored in the
database or downloaded "live" from the Internet
by using the Safari web browser engine of macOS.
Pages are rendered similar to Safari or any other
WebKit-based browser such as DEVONagent Pro.
Command-click links to open them in a new tab.
Shift-click links to capture them as bookmarks.
DEVONnote does not display news feeds. You can
find news feeds support in DEVONthink Pro and
higher.
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HTML views support the Edit > Find commands
as well as the See Also & Classify drawer. To edit
the source code of an HTML document, use the
navgiation bar to switch from preview to plain text
mode.
HTML pages containing form tags, e.g., for
checkboxes and input fields, save changed
form values with the HTML code. DEVONnote
also supports some XHTML headers in HTML
documents, e.g., for styles and scripts. You can
reference local images and other resources using a
downward-relative path (traveling subgroups; it's
not possible to travel up with '..' as documents can
have multiple parents).
In editable web archives you can use, e.g., the
highlighting commands from the Format menu or add
the Color tool to the toolbar to change text colors.
Editable web archives share many similarities with
formatted notes.
TOOLBAR & SHORTCUTS
Separate HTML or web browser windows feature
a default toolbar set that is more web-like than
text document windows. As with text document
windows, this toolbar can be configured individually.
Naturally, the DEVONnote offers only tools for
HTML views that are useful in a web environment.
Please find a list of shortcuts in the appendix.. See
also p. 68ff

CONTEXTUAL MENU
Back / Forward: Navigates back and forth to
previously visited pages.
Add Link: Allows you to enter a URL and makes the
selected text a link to it.
Add tag [word]: Tags the document with the
selected word (only available if the word is not
already a tag of the document).
Capture Frame: Captures the current frame in the
selected format to either the current group or to
the inbox.
Capture Link: Captures the selected link as
bookmark to either the current group or to the
inbox.
Capture Page: Captures the current page in the
selected format to either the current group or to
the inbox.
Capture Rich Text: Captures selected text to
either the current group or to the inbox.
Copy Frame Address: Copies the frame URL to the
Clipboard.
Copy Image Address: Copies the URL of an image
to the Clipboard.
Copy Image: Copies the image to the Clipboard.
Copy Page Address: Copies the page URL to the
Clipboard.
Copy: Copies selected text to the Clipboard.
Highlight: Highlights the selection in a web
archive. Using this command on a selection again
removes the highlighting.
Insert > ...: Inserts special characters or
checkboxes into the document.
Look up ...: Shows a definition, e.g. from macOS's
Dictionary, for the selected text.
Open ... in New Tab: Opens selected element in a
new tab.
Open Image in PhotoStickies: Opens the image in
PhotoStickies.
Open Link in Browser: Opens a link in your default
web browser.
Open Link in DEVONagent: Opens a link in
DEVONagent Pro.
Open Link in PhotoStickies: Opens a link in
PhotoStickies.
Reload: Reloads the page from the Internet.
Search Selected Phrase: Searches for the selected
text as a phrase.
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Search With Google: Searches for the selected
text in Google.
Search with Spotlight: Searches for the selected
text with Spotlight.
See [word]: Opens a drawer with documents
related to the selected word.
See Related Text: Opens a drawer with documents
related to the selected text passage (only
available when more than one word is selected).
Set As Thumbnail: Set the document's icon to the
selected image.
Set Name As: Sets the name of the document to
the selected piece of text (needs to be less than
256 characters).
Share: Shared selected text via the available
macOS sharing extensions.
Update Bookmark: Updates the URL of this
document to the current one, e.g., after
navigating to a sub-page.
For PDF pages more options become available:
Automatically Resize: When checked, the zoom
factor adjusts to the width resp. height of the
browser window.
Next Page, Previous Page: Skims through the
pages forward or backward.
Open with Preview: Opens the PDF in Preview.
Single Page, ...: Displays the PDF as single or
double pages and either page-by-page (use the
Next Page and Previous Page to skim through the
pages forward and backwards) or continously.
Zoom Out, Zoom In, Actual Size: Zooms in or out
of the document, or displays it in its actual size.
For HTML 5 videos the following additional options
are available:
Copy Video Address: Copies the video's URL to
the clipboard.
Mute: Mute or unmutes the video.
Open Video In Tab: Opens the video in a new tab.
Play/Pause: Plays or pauses the video.
Show/Hide Controls: Shows or hides the video
controls.

OFFICE DOCUMENTS, EMAIL, AND
OTHERS
Documents that DEVONnote cannot render
natively are displayed using QuickLook. But while
you have to press the Space bar in the Finder to open
a QuickLook head-up display, DEVONnote previews
these documents directly in the view/edit pane like
any other document format.
Among others, the following document types are
shown though QuickLook:
iWork documents (Pages, Numbers, Keynote)
Microsoft Office and OpenOffice documents
Mellel files (version 2.6 and higher)
...
For some document formats the preview allows you
to select and copy text, for other formats it doesn't.
If DEVONnote is able to interpret and convert
the document format, you can use the Text View/
Preview button in the navigation bar to switch to a
text view that allows you to select, copy, and drag
text. For email messages the alternative view is the
defaul view.
Note: The availability and quality of the preview,
as well as the possibility to select and copy
text, depends solely on the source application.
Developers can embed a QuickLook-compatible
preview diectly into the files, or write a preview
plugin and add it to either the source application,
or have you install it separately in ~/Library/
QuickLook. If a document that you want to view
in DEVONnote does not show a QuickLook
preview, please contact the maker of the source
application and ask them to add QuickLook
support.
TOOLBAR
For document previews based on QuickLook,
DEVONnote offers a number of toolbar items,
e.g., for moving back and forth through the other
documents contained in the same group or opening
the document in its source application.
Use Data > Open to open the document in a
separate document window instead of in its source
application.
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DRAWERS & SHEETS
In this chapter:
See Also & Classify
Smart group editor

43
44

the list shows the full title and location for it. This
part is only visible when the sorcerer's hat button is
used.
To move the document to one of the suggested

DEVONnote uses drawers to display the results of
the Classify and See Also functions that help you file
items and find relationships between items in the
database. The Smart Group Editor, which appears

groups, select the group and click Move To.
Alternatively double-click the group. For your
convenience, DEVONnote preselects a single group,
or multiple groups if it is unsure. Drag the file into

in a sheet, allows you to create or modify a smart
group (a.k.a. "saved search").

any item list to move it, e.g., into a main window. Use
the ⇧ and ⌘ keys to select more than one target.
This generates replicants.

SEE ALSO & CLASSIFY
The See Also & Classify drawer appears when you
select one (1) document in a main window and then
click the AI button (a small sorcerer's hat) in the
navigation bar at the top of the view/edit pane. This
button is only available in views that have a view/
edit pane.
It is also shown when you use the contextual menu
on selected text to show similar documents, e.g.,
See [word]' or See related text, or when you select a
topic from the topics pop-up menu in the document's
navigation bar.
To close the drawer, click the red close button.
When activated, DEVONnote analyzes the contents
of the selected document and compares it to all
data stored in the database. From this "knowledge,"
DEVONnote gives you one or both of the following
lists.
CLASSIFY
The Classify function helps you file documents by
making suggestions based on where you have filed
other documents. The Classify list shows which
groups the selected document would fit into best.
It also lists the location of the group and a graphical
score that shows how sure DEVONnote is about the
suggested placement. The tooltip for any entry in

Note: Any replicants of the document being
moved are deleted. The document is only
placed in the new locations, which allows you to
precisely classify the document again without
having to manually clean up old replicants.
SEE ALSO
See Also lists similar documents; thus, it helps
you find information likely dealing with the same
subject. The see-also list shows documents and/or
selected text or topics within documents that are
similar to the selected one (when you have used the
contextual menu items or the document's topics
pop-up menu). Like the classify list, this list shows
the path to the document and a graphical score of
how sure DEVONnote is about its decision. The
tooltip for any entry in the list shows the full title
and location for it.
To display a document in the drawer, select it. For
your convenience, DEVONnote always lists the
original document at the top of the list. This way
you can easily go back to the original document.
Double-click a document in the drawer to open it in
a separate window; drag it into an item list to move
it.
CONTEXTUAL MENU
Use the contextual menu on groups in the See Also
& Classify drawer for more commands.
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Open: Opens the selected item in a separate main
window.
Open in Tabs: Opens the selected item in a new
tab.

Search in: Select where you want this smart group
to search.
List of search predicates: Build your list of search
criteria (in search speak: "predicates") here. See

Open With: Opens the selected item in an external
application.
Launch URL: Opens the URL in the selected item's
URL field.

below.
Ignore Diacritics: Check this to treat letters with
diacritics, e.g., umlauts or accented characters,
the same as their regular counterparts.

Copy URL: Copies the Internet location stored
in the URL field of the selected item to the
clipboard.
Reveal: Shows and selects the selected item.
Show in Finder: Shows the selected item in the
Finder.
Move To: Moves the selected item to the group
you select from the sub-menu.
Replicate To: Replicates the selected item to the
group you select from the sub-menu.
Duplicate To: Duplicates the selected item to the
group you select from the sub-menu.
Label: Changes the label of the selected item.
Mark: Changes the check, lock, and read status of
the selected item.
Move All Instances To Trash: Moves all instances
of the selected item to the trash, including all
replicants (if any).
Group: Creates a new group containing the
selected item(s). Appears as Tag if the new group
would be created in the Tags group.

Fuzzy: Check this to search "unsharp" terms,
e.g., ignoring simple typos so that instances of
"Merkel" and "Merkle" are both found.

SMART GROUP EDITOR
The Smart Group Editor appears as a sheet when
you either create a new smart group using Data >
New > Smart Group, when you right-click a smart
group and choose Edit from the contextual menu, or
when you double-click a smart group.
In this sheet you set up a new smart group or edit an
existing one:

The list of predicates consists of a list of blocks,
each beginning with "All" or "Any", defining whether
all (Boolean AND) or any (Boolean OR) of the
contained predicates need to be true for the
document to be returned as a result. Predicates
themselves consist of the field to search (like
"Content" or "Tag"), and the condition and the data
that needs to be matched.
Note: In most predicates you can use wildcards,
Boolean operators, phrases, and parenthesis, too.
See also p. 73ff
Use the + and - buttons to add more predicates
to your smart group or to delete them. Hold the
⌥ modifier key and click a ... button to create
a "compound predicate," also called "branch".
Predicates can be in/outdented and rearranged via
drag-and-drop.
By adding more lines to a search and choosing
between "All" and "Any" you graphically create
a nested Boolean query with ANDs, ORs, and
parenthesis.
Example: To find all Microsoft Excel files use the
condition Filename ... ends in ... xslx. To find items
created in the last 7 days use the condition Date
created ... is ... Last Week.
PREDEFINED SMART GROUPS
When you create a new database, DEVONnote
adds a number of predefined smart groups for your
convenience:
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All Images: Shows all images.
All PDF Documents: Shows all PDF documents.
Duplicates: Lists all duplicates.
Recently Added: Lists all documents added this
week.

To Do: Shows all documents with visible but
unchecked state.
Note: Smart groups also filtering for date ranges
are shown with a clock icon.
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PREFERENCES
In this chapter:
General
Editing

46
47

Import
Take Note
Colors
Web
Backup

48
48
49
49
50

Update

50

The Preferences window, which you open by
selecting Preferences in the application menu,
is the place to go to change global settings for
DEVONnote. In addition to global settings,
databases also have separate settings in their
Database Properties window that you open using
File > Database Properties.
There is also a number of hidden preferences,
intended for customer support, but maybe useful
for you, too. See also p. 76ff

Alternating row colors in views: Check to color
every second row in item lists differently.
Display number of items inside groups: Check to
show the number of unread and read documents
contained in a group. Number will appear in
parenthesis after group names. If this option is
unchecked, news feed still show the number of
unread items.
Highlight Internet links in views: Check to show
link documents marked in blue and underlined in
item lists.
Mark duplicates and replicants in color: Check to
highlight duplicates marked in blue and replicants
marked in red in most views. When unchecked
duplicates and replicants are marked with file
property icons.
ALERTS
Click Reset to make DEVONnote show alerts again
that you previously dismissed with "Don't show
again" checked.

GENERAL

LABELS

Use the General tab to set the general settings for
the user interface.

Choose how you would like labels to be shown in
lists.

APPEARANCE
These options define some parts of the visual
appearance.

Classic: Tints the group/document icon (like on
Mac OS 9).
Modern: Puts the group/document name in a
colored bubble (like on older versions of Mac OS
X).
Dots: Shows a colored dot in the list (like on
macOS).
INTERFACE
These options define some parts of how you interact
with the user interface.
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Always open groups in a new window: When
checked, double-click a group to open it in a
separate window. When unchecked, double-click
the group to make it the new root of the current
window. Use Go > Top Group and Go > Enclosing
Group to go up the groups hierarchy again.
Retain view: When the above option, Always
open groups in a new window, is unchecked, the
actual view settings are maintained when you
navigate the group structure instead of the
group's individual settings being applied.
Enable tabbed browsing: When checked, click
with ⌘ pressed a link in web, PDF or text views
to open it in a new tab. When unchecked or the ⌘
modifier key isn't pressed, documents are opened
in the same view, in the default application or in
new windows.
FONTS
Use List Views Font to set the font DEVONnote uses
for displaying item lists in list.
Note: Hold the ⌥Option key to restore the
default fonts.

EDITING
The Editing tab defines all options that fine tune
DEVONnote's text editing behavior, from the ruler
units to WikiLink templates to summarization
options.

GENERAL
Display PDF attachments of rich texts: Show the
content of PDFs attached to RTF documents.
Check spelling while typing: Spell check
everything you write all the time.
Check grammar with spelling: Check the grammar
when checking the spelling.
Correct spelling automatically: Correct misspelled
words automatically.
Smart quotes: Use curly quotes instead of simple
English ones.
Smart copy/paste: Insert or remove spaces before
and after cut or pasted text.
Smart links: Detect web addresses and turn them
into clickable links automatically.
Smart dashes: Convert characters, e.g., two
hyphens into a proper dash.
Data detectors: Detect dates, times or addresses
in text, and show possible actions when the
mouse cursor moves over them.
Text replacement: Use the system-wide text
replacements when editing text.
AUTHOR, RULER UNITS AND FONTS
Author: Enter your name. It will be used as default
for metadata, e.g. for new rich text documents.
Ruler Units: Select your personal preference for
ruler units such as centimeters or inches, points
or picas.
Plain/Rich Text Font: Select your preferred fonts
for new plain or rich text documents. Note: By
their nature, plain text documents are always
displayed in the font selected, whereas rich text
documents can be styled any way the author
wants.
Note: Hold the ⌥Option key to restore the
default fonts.
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FULL SCREEN
Full Screen: Select your preferred font for reading
and editing plain text files in full screen mode.
By their nature, rich text documents are always
displayed using their own styles also in full screen
mode.
Background: Choose a background color for the
full screen mode. This setting only affects the
background of plain text files and the border
to the left and right of rich text documents. By
their nature, rich text documents bring their own
background color and so don't use the color you
set here.
Text: Choose a text color for the full screen mode.
Width: Choose a width for displaying documents
in full screen mode as a percentage of the screen
width. Use this setting if the presentation in full
screen mode appears too wide on a large screen.
WIKILINKS
WikiLinks: Check Automatic if you want to
make every word that is also the name of
another document or group in the database
automatically link to the document of the
same name (WikiLink). This mechanism can be
restricted to not link to groups, as well as to only
accept meshed words. (For example, words with
a capital letter in the middle like "QuickTime";
this is the classic WikiLink method to distinguish
between regular words and links.) Check Open
new documents in separate windows to open a new
window when you click a WikiLink, instead of
switching to the linked document.
Template: Enter a template text here. This will
be used to create a new document when you
make text a link that does not point to an existing
document yet. You can use various placeholders
to automatically insert text--the current date and
time, for example.

IMPORT
Here you decide which file types DEVONnote
imports and how those files will be named in the
database.

FILES
These options define whether DEVONnote imports
files of a given type when you import folders using
File > Import or via drag-and-drop.
<type>: Select all the file types you want
DEVONnote to recognize when importing
folders. DEVONnote always imports every file
you import manually.
Encoding: Choose the default encoding for
plain text documents. Select Automatic to let
DEVONnote choose the best encoding.
TITLES
Select how you want DEVONnote to name
imported documents: with file name extensions,
without file name extensions, or by using localized
display names (for example, on a German system
the "Applications" folder would appear as
"Programme").
NEW NOTES
Check Select (and display) automatically to
automatically select and display the last note you
have taken.
DESTINATION
Choose the default destination where data is stored
that's coming in from , DEVONagent Pro, news
feeds, or services.
Select group: A group selector is shown that lets
you choose the destination. The group selector
appears as a black panel floating on top of all
other windows. It does not bring DEVONnote to
the front. Use it to select the group where you
want to file the items and add tags.
Global inbox: The data is stored in the global inbox.

TAKE NOTE
The Take Note preference allows you to assign a
hotkey for opening the Take Note panel.
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To change the hotkey, click the Click to record
shortcut button, then press the hotkey that you want
to use. Press the Escape key to cancel recording a
new shortcut.

Display images when the page opens: Check this
option to diplay web pages with images. Just
remember, if unchecked, you may miss some
information.

COLORS

Animate images, Loop animation: Check these
options to run web graphics animations and to
run animated graphics in a loop.

Here you can name and choose the seven label
colors DEVONnote uses to mark documents and
groups, as well as set seven colors you can use to
highlight text.

WEB
The web preferences resembles the settings of most
web browsers. Use these preferences to define how
DEVONnote's displays web documents and "live"
web pages.
WEB CONTENT
These settings define how DEVONnote treats
special web contents:
Enable ...: Check these options to use installed
third-party plug-ins, (such as Flash or RealPlayer
plug-ins), and to run Java applets or JavaScript
scripts contained in, or linked to, a web page.
Block ...: Check Block pop-up windows to block popup windows, which are often advertisements;
check Only automatic JavaScript windows to block
only pop-up windows opened by JavaScript.
Uncheck this option if the web page you're
visiting uses pop-up windows for actual content.
(Some web content management systems do
this.) Check Block zooming to keep web sites
from automatically zooming windows to full size.
Check Block advertisement to block common inline
advertisements provided by some search engines.
Zoom text only: Check to zoom only the text and
uncheck to use Safari 4-style zooming.

ACCEPT COOKIES
Cookies are little text files with information that
web pages store on your computer use to recognize
you as a returning customer, among other things.
While most cookies are harmless, you may want to
control what is being stored on your hard disk.
Always: Accept all cookies.
Never: Don't accept any cookies.
Only from sites you navigate to: Accept cookies,
but only from web sites you navigate to (not from
other sites, such as ad trackers).
Delete cookies on quit: Delete all stored cookies
when you quit DEVONnote.
FONTS
Set the fonts you want to use for displaying web
pages; set separately for variable-width and fixedwidth text.
Note: Hold the ⌥Option key to restore the
default fonts.
STYLE SHEET
You can further control the way DEVONnote
displays web pages by applying a CSS style sheet
that changes the rendering on the fly.
Click Select and choose your style sheet to apply it to
DEVONnote's integrated web browser. Note: This
is for experts since it modifies how all web pages are
displayed and can lead to undesired effects.
TEXT ENCODING

IMAGES
These settings define how DEVONnote displays
graphics in web pages:

Select your desired text encoding for displaying web
pages. Automatic tries to choose the best available
encoding. If this does not work for you, choose a
more appropriate text encoding for your language
group.
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BACKUP

UPDATE

DEVONnote comes with a simple backup function
that backs up the database index on a regular bases.
These options define how often DEVONnote will
back up indexes.

Change the settings in this tab to define when you
want DEVONnote to check for new versions: never,
on startup, daily, weekly, or monthly. DEVONnote
only performs checks for updates when the
computer is connected to the Internet.

The backup automatically duplicates all important
database files and moves the duplicates into
a folder(s) named "Backup(.x)" within the
DEVONnote database folder/package. Select how
often you want to have the backup created--never,
daily, weekly, or monthly--and how many copies of
the index your want DEVONnote to keep. Of course,
you can create a backup at any time using Data >
Tools > Backup & Optimize.

Click Check Now to immediately check for a new
version.
Note: Disable the check for new versions
when your network connection is unstable
and you experience long delays when opening
DEVONnote. The Update pane is not available if
you have purchased DEVONnote from the Mac
App Store.

These options do NOT backup the whole database
to a secure location; they simply make sure there's
a copy of the index files in case the index get
corrupted. To back up your complete database, use
Time Machine or a third-party backup software.
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TROUBLESHOOTING
In this chapter:
Problems synchronizing with DEVONthink To Go
1.x
51
Repairing a defective database
DEVONnote crashes when opened
Recovering a lost password
Problems importing files
Problems using Services

51
52
53
53
53

DEVONnote behaves irrationally

53

DEVONnote was created with robustness in mind.
But any computer hardware or software, regardless
of how carefully developed and built, can write
defective data or destroy files. If you experience
problems with a database, please refer to the
methods below and also look at our FAQ.

If you still have problems with synchronizing, please
visit the user forum. If you don't find an answer
to your problem here, click here to contact the
DEVONtechnologies support team.

REPAIRING A DEFECTIVE
DATABASE
DEVONnote databases are packages containing of
your files and the supporting AI-based index. In rare
cases this index can get corrupted or out-of-sync.
But as your files are stored separately, this is not the
end of the world. If your database starts behaving
strangely, or if DEVONnote finds inconsistencies
during start-up, it is time for some housekeeping.
STEP 1: VERIFY & REPAIR

PROBLEMS SYNCHRONIZING
WITH DEVONTHINK TO GO 1.X
If you cannot properly synchronize your database
with DEVONthink To Go 1.x on your device, please
check the following:
Are both the iOS device and the Mac properly
connected to the same Wi-Fi network?
Have you moved, replicated, or copied documents
or groups to the Sync group? Please note that
smart groups are ignored during synchronization.
Have you checked your database on the device on
the database selection screen?
If you cannot see your Mac from your iOS device or
the connection is flaky, please try the following:
Create an ad-hoc Wi-Fi network from the Wi-Fi
icon in your Mac's menu bar.
Connect to this network from your iOS device.
Sync.
If the connection now works as expected, the
problem is related to your router, e.g., to security
measures such as packet filtering.

As a first step, use File > Verify & Repair to check your
database's consistency and allow DEVONnote to
take all necessary steps to repair any discovered
problems. If Verify & Repair was able to repair your
database, use File > Backup & Optimize to optimize
your database and have DEVONnote create an
internal copy of the index.
If Verify & Repair was not successful or your
problems are not resolved, proceed with the next
step.
STEP 2: RESTORE FROM BACKUP
DEVONnote keeps up to two copies of the index
files in case that the index is damaged beyond repair.
By changing the factory settings, you can change
when and how many internal backups DEVONnote
keeps in the Preferences, Backup tab.
To restore the index file(s) from a previously
saved internal backup, use File > Restore Backup.
DEVONnote presents you with a list of all available
backups. Choose the latest one and click Open.
This swaps the current set of index files with the
copy (the current set of index files becomes the
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backup, the backup becomes the current set) so
that data is never overwritten. Run File > Verify &
Repair to check the consistency of this index version
and if everything is in the right order File > Backup

Option 1: Restore your database from yourTime
Machine backup or whichever backup medium
you use. If you don't use Time Machine, we
strongly advise you to do so. External hard disks

& Optimize to optimize your database and have
DEVONnote create a fresh internal copy of the
good index.

are cheap, and Time Machine makes backing up
your important files quick and simple.
Option 2: If you do not have a current backup
of your documents, you can rescue your files

If the backed-up index files are also defective, try
the other backups, if available. If all backups are
broken or corrupted, proceed with the next step.
STEP 3: REBUILD YOUR DATABASE

manually, but you will lose any group structure.
To manually copy your files from the defective
database, show the folder ~/Application Support/
DEVONnote 2 in the Finder. Copy the files in the
"Files" subfolder, which are sorted by kind, to a
save location, e.g., the Desktop. Then create a
new database, re-import the files and recreate
your group structure.

Since your files and DEVONnote's index are stored
independently within the database folder the index
can be rebuilt at any time without you losing too
much metadata. To rebuild the database from
scratch, use File > Rebuild Database.

STEP 5: CONTACT SUPPORT

During the rebuild process, the complete index
is re-created; your actual files are not touched.
Any problems that occured during this process are
logged.

If none of the above steps helped solving the
problems you have with your database, please
contact DEVONtechnologies' support staff with a
precise-as-possible description of your problem.

Orphaned files: Orphaned files that could not be
imported while repairing are logged and moved to
the folder "Orphans" inside the database folder.
To rescue the orphaned files, show the folder ~/
Application Support/DEVONnote 2 in the Finder
and move the files in the "Orphans" sub-folder to a
save location, e.g., the Desktop, or directly re-import
them by dragging them to DEVONnote's Dock icon.
STEP 4: TIME MACHINE OR MANUAL RESCUE
If everything above failed, your database is severely
damaged. You have two options now:

DEVONNOTE CRASHES WHEN
OPENED
If a database is heavily damaged, it may be that
DEVONnote crashed when starting up or when
opening the database. In this case you cannot use
the built-in mechanisms to recover your data. But
you can revert to an internal backup manually. With
its factory setting, DEVONnote keeps up to two
copies of the index files in case the index is damaged
beyond repair. You can change how many internal
backups DEVONnote keeps in the Preferences,
Backup tab.
To revert to one of the internal backups, quit
DEVONnote, then locate the database folder (~/
Application Support/DEVONnote 2) in the Finder.
Inside you will find one or more folders named
"Backup(.x)". These folders contain copies of the
index files (named "*.dtMeta"). To manually revert to
one of the backups, copy the content of the backup
folder (all ".dtMeta" files) to the top level of the
database folder, replacing the existing, defective
files.
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Once you have reverted to one of the backups, try
opening DEVONnote again.

You can manage your Services in System Preferences
> Keyboard > Keyboard Shortcuts > Services.

If this solution di not help, please contact
DEVONtechnologies' support staff with a precise-

WHY DO THE SERVICES NOT WORK IN

as-possible description of your problem.

FIREFOX?

RECOVERING A LOST PASSWORD
If you have protected a database and you have
forgotten your password, do the following to
remove the password protection:
Close DEVONnote
Locate the folder "~/Library/Application Support/
DEVONnote 2/" in the Finder and open it
Move the file "Settings.plist" to the Trash
A future version of DEVONnote will feature
industry-strength encryption.

PROBLEMS IMPORTING FILES
WHY DOES DEVONNOTE NOT RECOGNIZE MY
FILES?
If DEVONnote does not recognize a file, make
sure the file has a proper file name extension.
DEVONnote needs a file name extension to
determine the file type. Add the correct file name
extension to your files (e.g., .txt for plain text
files, .rtf for rich text files, .pdf for PDFs and .doc for
Microsoft Word files) and try again.

PROBLEMS USING SERVICES
WHY DO THE SERVICES MENU COMMANDS
SHOW NO SHORTCUTS?
They should; however, the keyboard shortcuts
for Services menu commands are only requested
by the supplying application. macOS assigns
these shortcuts and has ultimate control over
which application or service gets what. If the
DEVONnote Services menu items do not have
shortcuts assigned, it is likely that macOS assigned
these shortcuts to another Services command, or
that they are used by the current active application.

Services work only in macOS applications based
on the so-called Cocoa framework. Examples for
Cocoa applications are Mail, Safari, TextEdit, etc.,
and, of course, all DEVONtechnologies applications.
However, Firefox is a port of a Unix application
not completely based on Cocoa. Therefore, it does
not support Services. Try using Camino instead--a
Cocoa browser based on the Firefox engine.

DEVONNOTE BEHAVES
IRRATIONALLY
No software on this planet is bug-free, and if an
application behaves irrational there is a good chance
that your have just found a bug. But there could also
be another cause: The application package could
have become damaged during an update or through
a bug in a totally unrelated piece of software on
your computer.
STRANGE APPLICATION BEHAVIOR
If something happens like
menus disappearing or silently refusing to do
anything,
windows showing graphical artefacts,
or applications not opening at all or opening with
strange error messages,
please try to trash the application package. Then
empty your web brower's cache, download the
software again, and re-install it. In many cases this
cures the problem.
If this does not help, try deleting DEVONnote's
preferences files located in "~/Library/Preferences"
and starting with "com.devon-technologies.think".
STRANGE BEHAVIOR RELATED TO DOCUMENTS
If the strange behavior only happens with a
particular document, it is likely that the document
is damaged, was created in a very old or extremely
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new file format that is no longer or not yet properly
supported, or uses a damaged or malfunctioning
Quick Look plugin.
Please file a support ticket and attach the document
in question, packaged as a .zip archive, so that we
check to see if the problem lies with DEVONnote or
if it the file itself.

STRANGE BEHAVIOR OF TABS
With Zooom/2 installed, tabs in tabbed windows
behave stragely, e.g., close when cursor hovers over
the tab. Another effect of Zooom/2 are scrolling
problems in programs such as iTunes. Disabling
Zooom/2 solves the problem.
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Do you have questions regarding our licensing
policy, our products in the Mac App Store, or
specific questions about DEVONnote?

GENERAL QUESTIONS
Do you have any job opportunities? Yes, we may. Please visit our Work @ DEVONtechnologies page for more
information about current open jobs at DEVONtechnologies.
Can I be a beta tester? Maybe. Our beta tester selection process is very deliberate; we try and select our beta
testers carefully so that we're not wasting anybody's time, yours and ours. We're looking for people who can
provide us with feedback quickly and clearly, who use different hardware and software from our other testers,
and who are willing to send us their personal data if it's needed for debugging.
If you want to be a beta tester, the best way to catch our eye is to be active in our user forums. We often ask
active participants on the user forums if they can help us test particular features and new products. You can, of
course, simply contact us.
Is the documentation available in my language? The online and PDF documentation is only available in English
at the moment. Localizing documentation and other text-intensive materials to Deutsch, Francais, etc. is costintensive and error-prone so that we have decided to concentrate our resources on developing stable, robust,
and feature-rich software. We will have localizations of the online help etc. as soon as we feel we have the
necessary resources.
Where does the name DEVONtechnologies come from? "Devonian (after Devon County, England), the
geologic period from 410 to 360 million years ago. Also called the Reptile Age or Age of Fishes. First amphibians
appeared on the land, that until then was only inhabited by trees and other plants -- it was the departure into a
new age." Named after the Devonian period, the DEVONtechnology marks the departure into a new age of data
processing.
Note: Ray Troll has even created songs and other art about this extremely important evolution step.

RELEASE SCHEDULES, MAC OS X, AND WINDOWS
When is the next release coming We try not to announce precise timelines or feature lists for future releases,
as we are a small software company with limited development resources; if one of us should happen to get
the sniffles, or if there are other outside factors we need to devote our limited time to, it can easily impact our
intended development schedules.
In planning releases, we try to strike a balance among:
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responding to customer requests,
the needs of our partners,
supporting new operating systems features,
providing consistent features across the product line,
working efficiently within the structure of the code, (similar features often get handled at the same time),
various business needs.
We cannot make any assumptions on how those various factors will impact our daily workflow; in fact, it's
often impossible to predict the final release date accurately when we start new projects. We try to plan our
releases with a long term perspective so that they ultimately serve the needs of our customers, even if they
don't necessarily get in everyone's favorite feature request every time.
Why are your applications not compatible with my pre-release version of Mac OS X? In the past, we've noted
that compatibility issues with a new major release of the operating system are usually resolved by Apple in the
final stages before its release, and don't require any action on our part. If you are already using a pre-release
version of Mac OS X, please check if our applications work with a newer pre-release, or wait until it reaches
the release candidate status. We will then make all necessary adjustments for making our apps run on the first
official release of the new version of Mac OS X.
Any chance of a Windows versions of your products? We're very commited to Mac OS X and the superior
Cocoa environment. For most of our applications, porting them to Windows would take longer than it would
to rewrite them from scratch on the Mac. If you need to use Windows software but still don't want to miss our
products consider running Windows on a Mac.

PURCHASING
Note: If you purchased or plan to purchase DEVONnote in the Mac App Store please click here to learn more
about the differences between our shop and the Mac App Store.
How do I purchase an upgrade? Please use DEVONnote > Check Upgrade Options to find out what you need to
upgrade and how much the upgrade is for you. If this option is not available in your copy of DEVONnote this
application might not be upgradable. Please visit the Upgrade Assistant on our web site instead.
What is your policy on software updates? Usually, all minor updates ('dot updates', such as version 1.2 to 1.3)
to our applications are free and require neither purchasing an upgrade nor requesting a fresh license code. We
charge for major upgrades, though, such as version 1.x to 2.x. If you purchased your license in our online shop
within a reasonable time frame before a paid upgrade release (between 30 days and 6 months, announced on
our website), we will provide you with a free upgrade. If you purchased this application on the Mac App Store
click here.
Can I get the bundle discount also later? Bundles are cheaper than multiple single licenses because a bundle
means less fees for the shop provider. But we grant the bundle discount under certain circumstances. Please
contact our sales staff if you purchased one of the bundled produts within the last two weeks.
Do you give a discount to students and educators? Yes, we give 25 percent off the regular price of
DEVONthink, DEVONagent, DEVONnote and the Infoworker's Bundle to students and educators. We also give
volume discounts to institution or faculties. Please visit our Students, Educators and NPOs page.
Do you offer NPO licenses? Yes, we offer free licenses to non-profit organizations (NPOs) in the sense of
charities. Learn more about our NPO program.
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Can I use your software on multiple computers? Yes, our license explicitly allows one and the same person to
use our application non-simultaneously on multiple Macs. So, for example, if you install one of our products on a
laptop, your office Mac, and your home Mac, you may do so as long as you only use one of them at a time.
I have no credit card. How can I purchase your software? We are selling currently through the online sales
agent Share*It to keep our administration as lean as possible. If you don't have a credit card, you can also pay via
PayPal or by purchase order, wire transfer, or even cash. See our online shop for more details.
In addition we are also selling some of our products through the Mac App Store. Please open the App Store
application on your Mac to learn more about which payment options Apple offers.
Can I have more time for evaluating your apps? No problem. We happily give out 30 day licenses for evaluation
purposes. Choose Help > Support Assistant to request a 30 day trial extension. This option is not available e.g. in
DEVONagent Express.
Why haven't I received my license code(s)? If you have purchased your license in our online shop and if there
have been no technical problems on our side, your license codes have been sent out to you immediately after
your purchase. Sometimes, however, they get stuck in spam protection filters (either yours or your ISP's).
Please, check your spam protection filter, and if you cannot find the license codes there, use Help > Support
Assistant to get them resent to you. If this also doesn't work, please contact us and we'll try to get your license
codes to you as quickly as possible.
Where can I buy a 1.x license code, e.g. for use on Mac OS X 10.4? License codes for legacy versions are no
longer available in our shop but even the latest license codes are always backward-compatible: You can use
a version 2.x license code also for version 1.x of the same product. To use a legacy product simply purchase a
license for the most recent version of the product in our online shop and use it with your legacy software.

MAC APP STORE
How do apps purchased in the Mac App Store differ? The Mac App Store requires so-called "sandboxing" of all
apps. Sandboxing puts the apps into a closed environment and restricts access to e.g. files, networks, printers,
etc. Therefore many apps sold through the Mac App Store have less features than their counterparts available
outside of the Mac App Store.
Do you charge for updates in the Mac App Store? No, updates are generally free in the Mac App Store (and we
don't charge for them outside of the Mac App Store, too).
Why are updates available always later that in your shop? All apps sold through the Mac App Store
are reviewed by Apple before being released. Therefore new versions appear immediately on the
DEVONtechnologies website but have to pass Apple's review before appearing also in the Mac App Store.
Do I get a license code? Apps purchased in the Mac App Store do not come with a license code but are "signed"
directly before downloading for your iTunes account.
Do you offer bundles in the Mac App Store? No, bundles are not supported by the Mac App Store.
How can I upgrade apps purchased in the Mac App Store? By Apple's rigid rules you couldn't. Upgrades are
simply not available on the Mac App Store and upgrade offers outside of the Mac App Store are not allowed. In
some of our apps there may be an upgrade option still available, though. Check the Read Me to see if this is the
case for you.
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Can I get a refund? We freely refund licenses purchased in our own shop. For apps purchased in the Mac App
Store we don't have access to the refund mechanism. Please contact Apple's Mac App Store support for a
refund.

YOUR SOFTWARE LICENSE
Why does DEVONnote not accept my license code? When you enter your license code and the 'Register'
button stayes greyed out, try to enter ALL details, including your name and organisation, EXACTLY as they
appear in our e-mail. Best practice is to copy-and-paste name, organisation (if entered) and license code
from our email into the appropriate fields of the registration dialogue window. Also, please check if you have
obtained the correct code for the correct edition of your software (e.g., a DEVONthink Pro license code will
not work for DEVONthink Pro Office and vice versa) as well as version (DEVONthink 2.x will not accept a 1.x
license code).
I have lost my license code. How can I retrieve it? Use Help > Support Assistant to open the Support Assistant
which has an option to get your license code resent to you. Alternatively visit the support area on our web site.
Does my license code work also for an older version? Yes, it does. All our license codes are backwardcompatible to legacy versions of the same product and edition.
Why do I have to enter my license code again? You only have to re-enter your license code after a complete
reinstall of your system without a backup of your home folder or when the license code file has been
deleted, e.g. by a preferences cleaner app. The license code is stored in a preference file in '~/Library/
Preferences' (where ~ is your home folder). As long as this file is intact, you'll NEVER have to enter your license
code again.
Why does my DEVONnote 1.x license not work anymore? DEVONnote with version numbers greater than
1.x are paid upgrades. To use them you may need a new license code. Please use DEVONnote > Check Upgrade
Options to find out what you need to upgrade and how much the upgrade is for you.
Why does your application say that it expired? When we release a public beta of one of our applications, we
remove the usual trial restrictions but make it expire at the end of the beta period. A new public beta or the final
release is, of course, available when this happens.
Please simply visit our Download page, download a newer version that the one you have installed, and replace
your copy with the newer one. FPlease first move the old application to the trash, then move the new one into
its place.
Note: Your license code will, of course, NEVER expire.

PRODUCT-RELATED QUESTIONS
All frequently asked questions specific to DEVONnote are located in the appendix. Please continue reading on
the following pages:
FAQ specific to DEVONnote
Troubleshooting tips and tricks
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All commercial DEVONtechnologies applications
are based on a proprietary AI technology, with
rock-solid database foundation that allow them to
manage large numbers of documents or knowledge
bits while analyzing them almost instantly at the
same time.

GENERAL CONCEPT
DEVONtechnology, on which all
DEVONtechnologies' applications are built, is a new
technology at the very beginning of its development.
DEVONtechnologies constantly improves the
technology and enhances it for more functionality,
efficiency, robustness and flexibility.
Development of the DEVONtechnology is a battle
on two main forefronts of information processing
technology. DEVONtechnologies is working hard
on unifying both the top-down and the bottomup AI concepts by imitating high-level functions
and simulating the basic functionality of natural
systems. This leads to highly functional, fast and
efficient AI systems that can be used in a great
variety of information processing contexts, such
as pattern recognition, signal processing and
information storage and retrieval.

FEATURES
The DEVONtechnology is a rock-solid foundation
suitable for a variety of completely independent
applications. Therefore it is ideal for the rapid
development of a huge range of new database-,

signal-processing- and language-analysis-driven
applications. The ability to deal with any kind of
digital data makes it extremely flexible.
The size of DEVONtechnology-based databases
can, depending on the type of data stored,
grow logarithmically and make indexing is
completely unnecessary. Also, applications based
on the DEVONtechnology improve themselves
continuously (the more data they handle, the better
the results), are language-independent and iron out
any irregularities by applying fuzzy logic.

STRUCTURE
The DEVONtechnology consists of a kernel and
several layers. Together they perform all the
underlying computing, from 'simple' data handling
to complex signal processing.
Kernel: The kernel is the foundation for all layers
and applications and is responsible for data
handling, semantic and associative data processing,
signal processing, fast statistic analyses and all
fuzzy algorithms. It has to be as fast, flexible, and
extensible as possible; it is 64-bit aware and uses a
generic, proprietary file format (see above) allowing
it to verify and repair low level data consistency,
featuring logarithmic growth of the database
and logarithmic speed decrease with increasing
database size. The DEVONtechnology kernel is
Unicode-aware, completely language-independent
and self-optimizing and self-organizing.
Layers: The layers form a shell around the kernel
and provide high-level functions for the applications
built on top of them. The database layer, for
example, is used to store and organize data and
supports all kinds of relations (1:n, n:1, n:n),
hierarchies and freeform databases. No indexing or
primary keys are required, strings can be unlimited
in size and it's possible at any time to extend the
range of pre-defined data types (Boolean, character,
float, double, signed, unsigned, string, date, time,
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blob, color, size, and point). Another layer, the XML
layer, makes it easy to handle XML code within the
DEVONtechnology; it has a very small overhead,
compared to DOM parsers or available XML
databases, requires no indexing and supports the
tight integration of other databases (and vice versa).

APPLICATIONS
Some of the most likely applications for the
DEVONtechnology are databases (knowledge
bases, expert systems, search engines, table-ofcontent-generators, instant data-mining), intelligent
agents, encryption, compression and archiving.
Other uses for DEVONtechnology may be chatbots, context-sensitive help, optical character

recognition (OCR), speech analysis, recognition
and synthesis, staticstics, thesauri and automatic
translations.
In particular, applications dependant on processing
human language, either written or spoken,
benefit from the flexible technology foundation.
So, DEVONtechnologies' main focus in the
development of new applications is in these areas:
databases, 'intelligent' agents, text and speech
analysis, statistics.
Look forward to see a great range of different
applications based on the DEVONtechnology.
A few have already been announced
on the DEVONtechnologies web site:
www.devontechnologies.com.
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Besides DEVONnote, DEVONtechnologies
publishes a number of other commercial, shareware,
and freeware applications, and services that you
may be interested in.

And don't forget to have a look at our very lively
user forum, where users of all skill levels meet to
discuss our applications, talk about our technology,
and exchange tips and tricks for DEVONnote & Co.

DEVONTHINK
Organize and work with all your documents,
bookmarks, email messages, text files, images, PDFs,
in one place, regardless where they originated.
Quickly capture data without interrupting your
workflow. DEVONthink's unique AI assists you in
getting the most out of your data collection.

OVERVIEW

Learn more about DEVONthink
Learn more about DEVONthink To Go for iOS

DEVONtechnologies is focused on developing
innovative applications for finding, storing, and
organizing information. Our main objective is to
make complex yet flexible technology that is both
easy to use and lightning fast.

Check your upgrade options if you want to
upgrade to a higher edition
Check your upgrade options if own DEVONnote
and want to upgrade to DEVONthink

DEVONthink
DEVONagent
DEVONsphere
DEVONnote
All applications are based on the
DEVONtechnology, a powerful and solid core
unique to DEVONtechnologies. DEVONthink,
DEVONnote, DEVONsphere, and DEVONagent
are only the first of many more DEVONtechnologypowered applications to come.
Also, we publish useful freeware apps and services
that help you in your everyday work with your Mac.

DEVONAGENT
DEVONagent Pro helps you search more efficiently
on the web. It searches multiple sources, frees
you from hunting for the really relevant results,
and gives you power tools for your research.
DEVONagent Express and DEVONagent Lite (free)
make searching the web as easy as using Spotlight.
Search Google, Bing, YouTube, Facebook, Twitter,
even the Mac App Store, right from the menu bar.
Learn more about DEVONagent Pro
Learn more about DEVONagent Express
Learn more about DEVONagent Lite

NEWSLETTER & USER FORUM
Would you like DEVONtechnologies to keep you
informed about updates and new product releases?
Subscribe to the newsletter.

DEVONSPHERE
Make your Mac smarter: Let DEVONsphere Express
keep track of related emails, articles on the same
subject, and similar web pages. Discover the hidden
connection between seemingly unrelated files.
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Learn more about DEVONsphere Express

DEVONNOTE
Your thoughts and ideas are valuable. DEVONnote
keeps them and provides you with unique tools and
artificial intelligence so that you can focus on things
that really matter: creating even more ideas.
Learn more about DEVONnote
Check your upgrade options if you want to
upgrade to DEVONthink

NEEDFUL THINGS
Search files on your hard disk, watch web cams,
create thumbnails, or access all your files and apps
from the menu bar. Reformat paragraphs in your
favorite word processor, do little calculations
anywhere you can type in text, or send text to your
Bluetooth-enabled mobile phone. And all this for
free.
Learn more about our freeware apps
Learn more about our freeware services
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Contextual Menu: The menu that appears when
you right-click (or ⌃-click) something; the

Iconology
Keyboard shortcuts
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Templates
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contextual menu gives you access to frequently

Web site export templates
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Template tags for Wiki-style links
Item links
Metadata
Hidden preferences
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In the appendices you will find additional
information that helps you getting familiar with
DEVONnote, such as a glossary of commonly used
terms, a listing of the Boolean operators used in
searches, and placeholders used in templates for yet
"targetless" WikiLinks.

GLOSSARY
Become familiar with these terms to get the most
out of working with DEVONnote.

used commands that deal directly with the
clicked object. Read more about the available
contextual menus in the Documents and
Windows chapters.
Item list: A list of items stored in the database.
Items can be documents, groups, or smart groups.
View/Edit Pane: A part of the DEVONnote main
and document windows that lets you view a
document or, when possible, edit it. The view/
edit pane displays the content of your documents
depending on their type. See also p. 28ff
View (1): The layout for a DEVONnote main
window. You can change the layout using the
commands found in the View menu.
View (2): The display for the various document
types inside the the view/edit pane or a document
window. See also p. 37ff
Window: DEVONnote uses three different types
of windows: main, document, and other. Main
windows show lists of items and, in some views,
also the contents of the selected document,
whereas document windows show documents
separately.

KEYBOARD SYMBOLS
⌘ The Command key, usually next to the Space bar.
⌥ The Option key.
⌃ The Control key (usually labeled with "ctrl").
⇧ The Shift key.
⇥ The Tab key.
↩ The Return key.
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DOCUMENTS & GROUPS
Database: A collection of all documents stored
in DEVONnote. DEVONnote only manages one
central database.

Trash: Stores all trashed items until you physically
delete them using DEVONnote > Empty Trash.
TAGS

Document: A file in the database, a plain or RTF
text, or a link. Technically a document is an
entry in the database with text or RTF content.
Sometimes simply referred to as "content".

Tag: A tag is a different visual representation of
a group. All documents contained in a group
that has not been excluded from tagging, get
the group's name "attached" as a tag. Tags

Default Destination: The default destination
group for incoming data. In DEVONnote this is
the special Inbox group.
Group: A collection of documents or other groups
inside the database. Similar to a folder in the file
system. See also p. 19ff
Inbox: A special group for data coming in to a
database.
News Feed: A news feed is like a web page, but
split into multiple newsbits. A feed reader or web
browser can split the feed "page" into its parts
and show each of them as a separate news item
and/or store it in a local database. DEVONnote
stores feeds in a database and displays them
like a group; contents are updated live from the
Internet as the connected feed changes. Older
news bits are kept, while fresh news bits are
added and marked as unread. When you add
a bookmark that points a feed to a database,
DEVONnote tries to add it as a proper feed
document if possible. DEVONnote can also be
defined as the system's RSS reader in Safari's
Preferences.
Replicant: A document or a group that appears
in more than one place in the database. Unlike
an alias in the file system, a replicant is not a
real document pointing to another file (usually
the original); rather it is a second entry in the
table of contents for the very same document.
Consequently, there is no original; when you
replicate a document you'll end up with two
replicants. See also p. 20ff
Smart group: Not a real group but a "saved search"
that appears like a group. Every time you visit
this smart group, DEVONnote runs the attached
search and displays it as the content of the group.
Create smart groups using the smart group
editor. DEVONnote creates a number of predefined smart groups when you create a new
database.

represented by a regular group appear grey in all
tag lists.
Group tag: Tags represented by a regular group.
Ordinary tag: Tags created through the Tag bar
or other means are created in a special top-level
group named "Tags". They are called "ordinary
tags" and appear blue in all tag lists.
ITEM PROPERTIES
Flagged/Unflagged: Items can be checked or
unchecked for your personal use, e.g., for creating
a to-do list, maintaining a shopping list, or writing
a list of project tasks.
Locked/Unlocked: Items can be locked to keep
them from being unintentionally deleted (groups,
documents) or modified (documents).
Read/Unread: Items can be marked read
or unread, which is useful for captured or
automatically downloaded news items or
documents that you want to read later. Both
unread items and groups containing unread items
are shown in bold.
The "flagged" and "locked" properties are indicated
by icons. See also p. 67ff
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SYNCHRONIZATION
Sync location: Sync locations are used to keep
your databases on all your devices in sync. They
summarize all information about which databases
to sync through what kind of connection (e.g.
direct connections to DEVONthink on a Mac,
WebDAV, CloudMe, Dropbox etc.) and with
which sync store.
Sync store: Server-based locations, e.g. WebDAV
or Dropbox, can contain multiple "sync stores".
Technically a sync store is a folder on the server
volume. Use multiple sync stores to e.g. sync both
your personal and your business databases at
the same location but keeping them separate
nevertheless. Sync stores can be encrypted and

each sync store at a location can have a different
encryption key.
Direct connection: A sync location that doesn't
store its data on a server but directly connects
to a Mac running DEVONthink or DEVONnote
respectively. When this device is not on the same
WiFi network or DEVONthink/DEVONnote is
not running the direct connection is disabled and
listed as offline.
Local database: A database that exists on this
device.
Remote database: A database that exists at the
sync location, e.g. on Dropbox, but is not yet
downloaded to this device.
Pending document: A document for which only the
metadata is locally available. This happens when
you choose not to synchronize indexed files for
the sync location.

FAQ (PRODUCT-SPECIFIC)
GENERAL
What is the difference between the various editions? While all three editions of DEVONthink, as well as
DEVONnote, share many features, there are some noticible differences. For instance, DEVONthink Pro is able
to deal with more than one database; features tables, forms, and categories; and comes with full AppleScript
support. DEVONthink Pro Office also comes with plugins for pro-grade email archiving, paper capture, and
Web sharing. You can find a complete listing of all differences on the feature comparison page.
Which languages does DEVONnote support? DEVONnote supports multilingual documents and Unicode and
so supports all Asian languages including Chinese, Japanese, and Korean, as well as non-Latin scripts such as
Cyrillic, Hebrew, and Arabic (including writing from right to left). Use Format > Alignment > Writing Direction to
adjust the writing direction.
Note: Asian languages, however, do not use word separators such as white space or punctuation. When
searching, you need to use wildcards. Use ~word or *word* in the search field or search window.
How do I completely uninstall DEVONnote? To completely remove DEVONnote from your Mac, see the
instructions in the Read Me.
DATABASES
Can I use more than one database? DEVONnote stores all data in a central folder in "~/Library/Application
Support/". To use multiple databases consider upgrading to DEVONthink Pro or higher.
How are my documents stored? DEVONnote stores all documents in sub-folders of '~/Library/Application
Support/DEVONnote 2' where ~ stands for your home folder.
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Inside the "Files.noindex" folder the actual documents are stored in sub-folders for their respective type and
further sub-folders that help DEVONnote to quickly locate them. Documents are never altered when you
copied them into the database. The file name of each document is exactly the same as the corresponding
document name that you see in DEVONnote.
In addition, the database folder contains a set of ten index files named with the suffix ".dtMeta" as well as a
"Settings.plist" file containing database-specific preferences. Finally, the database folder can contain one or
multiple folders named "Backup ...". They contain backups of the index files and are created automatically by
DEVONnote's backup function. They do not contain copies of all actual documents.
How can I move my database to another computer? Your database is the folder "~/Library/Application
Support/DEVONnote 2". To move it to another computer, copy it to the same location on the other computer.
Note: In general, DEVONnote databases are self-contained, so one can move a database to another
computer, open it and start using it. But if some of the content has been indexed instead of imported, it will
be necessary to also move the externally linked files to the other computer. This must be done in such a
way that the Paths to the external files remain valid. If everything is in your Documents folder on the first
computer, copying the externally linked folders and files to the Documents folder of the second computer
will probably work. Always quit the DEVONnote application before copying or moving a database, as copying
an open database may result in an incomplete or damaged copy.
Can I share my DEVONthink database using WebDAV or DropBox? You can, but it is definitely not
recommended as WebDAV servers do not fully support all properties of real hard disks. See below.
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ICONOLOGY
Additional icons behind item names, e.g., in main
windows, indicate that the item has been indexed
instead of imported, is locked, has a comment
attached, or is scripted. Groups also serving as tags
show a tag icon. Depending on your preferences,
replicants, duplicates, or replicated duplicates are
indicated with a little grey icon instead of appearing
in color.
Item is unread
Item has been flagged See also p. 20ff
Item is indexed, not imported
Item is locked See also p. 20ff
Item has a comment See also p. 33ff
Group is a tag, too See also p. 68ff
Item is a duplicate
Item has one or more replicant(s)
Item is a duplicate, but also has one or more
replicant(s)

KEYBOARD SHORTCUTS
Keyboard shortcuts make using DEVONnote much
more efficient. Some of the following shortcuts are
common to most macOS applications; others are
only available in DEVONnote. In addition, many
menu commands have keyboard shortcuts. These
are shown directly in the menu.
Note: You can change the shortcuts for menu
commands in System Preferences > Keyboard >
Keyboard Shortcuts > Application Shortcuts.
WINDOWS
Tab: Cycles focus through all entry areas and fields.
Shift-Tab: Cycles focus through all entry areas and
fields in reverse order.
Control-Tab: Cycles through all panes.
Control-Shift-Tab: Cycles through all panes in
reverse order.
Escape: Cancels processes, closes dialogs or Quick
Look previews, etc., depending on the context.

DOCUMENT LISTS
Navigating items:
Up/Down arrow: Navigates up and down in all
views. Use ⇧ to select multiple entries.
Left/Right arrow: Expands or collapses the
selected groups in Horizontal Split, Vertical Split
views, or navigates to previous/next item in other
views.
Option-click (the triangle in front of a group):
Expands or collapses all groups that are
containted within this group as well.
Option-Left/Right arrow: Expands or collapses
the selected groups and all their children in
Horizontal Split, Vertical Split views.
Selecting items:
Shift-click: Selects multiple items.
Shift-arrow: Extends the current selection.
Command-click: Adds an item to the selection.
Manipulating items:
Return: Renames documents.
Backspace: Deletes selected items.
Command-drag: Copies items to the drag
destination instead of moving it.
Command-Option-drag: Creates replicants for
the items at the drag destination. Dragging items
from the Finder to DEVONnote with ⌘ and ⌥
pressed indexes the item. Dragging items into
documents with ⌘ and ⌥ held inserts a link to the
item.
Command-Option-drag: Creates bookmarks for
address cards dragged in from Contacts.
Using items:
Option-double click or Command-Shift-O: Opens
selected documents/groups in a new tab or a new
main window (depending on whether tabbed
browsing is active or not) and closes the current
window ("hoist"). Change Always open groups in a
new window in Preferences, General tab to your
personal taste.
Tab: Jumps to the first or next editable column.
Space: Opens the standard Quick Look panel
showing a preview of the selected items.
Option-Space: Opens a full screen Quick Look
slideshow.
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VIEW/EDIT PANE

FORMATTED NOTES

Home/End: Goes to beginning of, or end of, any
view.
Page up/down: Scrolls one page up and down in

Drag, then hold Option: Copies selected text.
Shift-arrow: Extends current selection.
Command-click: Opens clicked URL in the default

any view.
Space/Shift-Space: Scrolls one page down or up in
non-editable views, e.g., web pages.
Command-click: Opens the target of a link in a

browser or application or in a new tab, depending
on your preferences.
Command-Shift-click: Opens a link in a new tab
and selects it (only if tabbed browsing is switched

new tab or separate window.
Command-Option-click (a cross-link or Wiki link):
Positions the insertion caret inside the link for
editing.
Option-click (a word): Looks for the clicked
word in the database, like the contextual menu
command See [word].

on).
Command-Option-click (1): Places the insertion
caret inside the text of a clickable link.
Command-Option-click (2): Opens a clicked crosslink or Wiki-style link in a separate document
window.
Option-click: Opens clicked URL in the default
browser or application or in a new tab, depending
on your preferences.

TEXT DOCUMENTS, MARKDOWN
Drag, then hold Option: Copies selected text.
Shift-arrow: Extends current selection.
Command-Option-drag: Inserts a cross-link for
groups or documents dropped into a rich text
document. Dragging files or folders from the file
system to a rich text document with ⌘ and ⌥
pressed creates links to them.
Command-click: Opens clicked URL in the default
browser or application or in a new tab, depending
on your preferences.
Command-Shift-click: Opens a link in a new tab
and selects it (only if tabbed browsing is switched
on).
Command-Option-click (1): Places the insertion
caret inside the text of a clickable link and opens
the link in a new
Command-Option-click (2): Opens a clicked crosslink or Wiki-style link in a separate document
window.
Option-drag: Selects text using a rectangular
selection ribbon.

HTML PAGES, WEB PAGES, FEEDS
Command-click: Opens clicked URL in the default
browser or application or in a new tab, depending
on your preferences. Equals clicking a link with
the third mouse button.
Command-Shift-click: Opens a link in a new tab
and selects it (only if tabbed browsing is switched
on).
Backspace/Shift-Backspace: Goes backwards and
forwards through the visited web pages.
SHEETS
Return: Moves one cell down for editing.
Shift-Return: Moves one cell up for editing.
Tab: Moves one cell to the right for editing.
Shift-Tab: Moves one cell to the left for editing.
Arrows: Moves the editing selection.
Escape: Stops editing.

TAGGING
DEVONnote supports tagging in a way that makes
groups and tags interchangeable. While this concept
may sound a bit strange at first, you will soon
discover why it is a smart way to approach tags and
group and to bring both together.
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INTRODUCTION
Technically, tags and groups are identical: both
are simply entries in a table that are somehow
"attached" to an item, usually a group or document.

Tags represented by a regular group are called
"group tags"; tags created without an existing group
are called "ordinary tags." See also p. 64ff

The difference is that tags are visualized as "labels
attached TO the item while groups are visualized as
groups CONTAINING the item." They are presented
differently, but internally they are the same.

THE TAGS GROUP

DEVONnote treats groups as tags and tags as
groups. When it shows you the tags associated with
an item, it presents you with a list of all groups that
the item is part of and that have not been excluded
from tagging.

group does not yet exist. In this case, DEVONnote
creates a group for the tag in the Tags group and
places a replicant into it.

Example: A document is located in the
group "Science > Paleontology > Dinosaurs".
Consequently, its tags are "Science,"
"Paleontology," and "Dinosaurs." Now you create
a sub-group of "Dinosaurs" named "Land-living"
and move the document into the new folder.
Automatically it is now tagged with "Science,"
"Paleontology," "Dinosaurs," and "Land-living."
The same happens when you replicate the
document into multiple groups: It is tagged with the
names of all enclosing groups (not excluded from
tagging) of all its replicants.
When you assign a tag using DEVONnote's user
interface, move a document, or replicate it to
another group, this is what happens:
Assign a tag: The item is replicated to the Tags
group.
Removing a tag: The item's replicate in the Tags
group is deleted.
Adding an item to a group: The group's name and
the names of all groups containing the group
appear as tags attached to the item.
Moving an item: The new group's name and the
names of all groups containing it appear as tags
attached to the item.
Replicating an item: The new group's name and
the names of all groups containing it appear as
tags attached to the item, too.
(Auto-) Classifying an item: This places the item
into a new group and replaces all assigned tags.

Every DEVONnote database contains a top-level
group named "Tags." It is used whenever you add a
tag to an item, e.g., through the tag bar, for which a

When you rename a group here all items associated
with it, (means: that have a replicant here) this
option will show the change.
USING TAGS
To use tags for selecting and finding documents or
browsing tags, DEVONnote offers the following
options:
Tags view: The tags view allows you to browse
your documents by tags. In the tags view, select
a tag to display all items which have this tag
assigned. Choose multiple tags, e.g., by clicking
anothe one with ⌘ held, which shows all items
carrying the selected tags.
Smart groups: Use smart groups to search for
items with given tags.
Wherever tags are shown, "ordinary tags" (tags
created in the special Tag group) appear blue, and
tags that are also regular groups appear grey. Tags,
in the Tag bar also show a pop-up menu when you
click their downward triangle. The menu shows
related tags that can be added to the item, and
reveals tags represented by a group.
ALIASES AND EXCLUDING FROM TAGGING
DEVONnote also honors aliases added to groups.
You can add "alternative names" to a group using
Info panel and later use these alternative names as a
tag.
Example: In the Info panel of the group
"Dinosaurs" you have added "Dinos" as an alias.
You can now tag items with "Dinos" and they
automatically will be moved or replicated to the
"Dinosaurs" group.
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Groups that you don't want to use as tags can be
excluded from tagging. Select the group and open
the Info panel. Check Exclude from … Tagging and the
group's name will no longer be shown as a tag for
items contained in it.
FINDER TAGS
DEVONnote supports Finder tags when importing
and exporting files.

FILE FORMATS
DEVONnote supports a variety of text formats,
including plain text, Rich Text Format (RTF) files, and
most Microsoft Word documents.
TEXT FILES
DEVONnote supports plain text files (as well as
Mac OS 9 SimpleText and Tex-Edit Plus files) in all
encodings supported by macOS, including Unicode
and UTF-8. By default, DEVONnote automatically
recognizes the encoding and the line endings used
by Mac, Windows, and Unix operating systems.
Extensions: adb, ads, aln, ans, applescript, asciidoc,
bat, bib, bibtex, c, cls, cmd, command, con, cp, cpp,
crash, css, csv, diag, dot, em, embl, entitlements,
erl, err, f, f70, f90, fasta, for, fountain, fpp, ft, gb,
genbank, gff, h, haml, hang, hlp, hpp, hs, hrl, id2xf,
inc, ips.beta, js, lhs, lisp, log, lst, lua, m, markdown,
md, mdwn, mediawiki, mi, mis, ml, mly, mm, mmi,
mml, msf, org, p, pas, pir, pl, pp, py, rb, rc, rst, sass,
scm, scpt, scptd, scriptSuite, scriptTerminology,
sdef, seq, sh, sqc, sql, srt, ss, strings, sty, sw, swift,
swiss, tab, tcl, tex, text, textile, txt, v, vcf, wrl, x,
xchatlog, xd, ychat
HFS type codes: TEXT, ttro, TERO, sEXT,
SimpleText, scpt, osas, APPL (AppleScripts
wrapped in an executable application)
Automatic recognition: DEVONnote also
recognizes plain text file formats defined by
third-party applications.
Rich Text Format: For Rich Text Format (RTF) files,
DEVONnote recognizes Mac, Windows, and ANSI
encodings as well as macOS RTF documents with
attachments (RTFD).

Extensions: rtf, rtfd
HFS type codes: RTF
FORMATTED NOTES
Formatted notes are HTML files with a reduced
set of possible tags that can be edited WYSIWYG.
While they share the ".html" file name extension
which allows you to view them using a standard web
browser, formatted notes feature an identifying
meta tag which DEVONnote uses to distinguish
them from regular HTML files.
Extensions: html
OFFICE AND OTHER DOCUMENTS
DEVONnote imports many Office file formats such
as Microsoft Office and OpenDocument documents,
as well as all other file formats for which Quick Look
support is available, e.g. Mellel (version 2.6 and
higher) or Scapple files, AppleScript scripts, or text
clippings.
Note: Quick Look is macOS' mechanism for
displaying a preview of almost any file type. In
the Finder, this function is invoked by pressing
the Space bar. Quick Look requires the maker
of the software that writes the document to
add additional preview information inside the
file (package), or to provide a Quick Look plugin
embedded into the application itself or installed
in a Library folder. If neither DEVONnote nor
the Finder can preview a document format that
you want to use, please contact the maker of
the software and ask it to provide Quick Look
support for its file format.
Due to the nature of Quick Look, the contents of a
document that is displayed using this technology,
e.g., an Apple Pages file, is sometimes not selectable.
Depending on the file format, a plain or rich text
alternative is available for some files, e.g., for email
messages. Where available, use the Text View/
Preview toggle button in the document's navigation
bar to switch back and forth between plain text and
preview modes.
Additional Quick Look plugins can be found on
QLPlugins.com.
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EBOOKS

BOOKMARKS

CHAT LOGS

Drag or paste Internet addresses from any Internet
application, or Internet location files from the
Finder, to DEVONnote to create a bookmark

DEVONnote understands the text format of logs
generated by Adium, iChat or Yahoo Messenger. You
can import these chats like rich text files.
Extensions: chat, chatlog, ichat
HFS type codes: YMSG

documents. DEVONnote is especially optimized
to accept Safari Bookmarks. Use bookmarks in
DEVONnote to integrate "live' content from the
Internet seamlessly with local documents.
Extensions: dtLink, ftploc, fileloc, inetloc, mailloc,
newsloc, url, vncloc, webbookmark, webhistory,
webloc
HFS type codes: ilht, ilft, ilfi, ilma, ilnw, ilaf, ilat, ilns,
ilge, ilvn, LINK

TEMPLATES
DEVONnote comes with a number of pre-fabricated templates for general use. Use these templates to add a
task list, a quote, or whole group structure for project management to your database.
MANAGING TEMPLATES
Templates are regular files stored in the Finder in the folder "~/Library/Application Support/DEVONnote 2/
Templates.noindex". Navigate to this folder in the Finder to manage your templates, rename them, organize
them in sub-folders, or delete them.
More templates are available as extras. See also p. 36ff
PRE-FABRICATED TEMPLATES
DEVONnote comes with the following pre-fabricated templates, which serve as great examples of the template
feature.
Note: Not all of the listed templates are available in DEVONnote as DEVONnote does not support
AppleScript. Templates based on simple files or on template packages are available, though.
General use:
Note: Adds a new note. If the clipboard contains text, it is automatically inserted; if the clipboard contains an
Internet address (URL), it is added to the note's link list.
Phone Note: Adds a new phone note, automatically inserting the current date and time.
Quote (from clipboard): Adds a rich text document for a quote or citation. The clipboard content is
automatically inserted and, it's an Internet address (URL), it is automatically made clickable.
Task List: Adds a simple task list.
Accounts & Passwords:
Online Account: Adds a document for storing online account details.
Serial Number: Adds a document for storing serial numbers.
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Contacts & Events:
Business Card: Adds the card selected in Contacts as a rich text document to your database.
Calendar Event: Adds a Calendar or iCal event you have copied to the clipboard (!) as a rich text document
to your database. You need to copy the event to the clipboard because Calendar/iCal does not yet provide a
mechanism to retrieve the selected event.
TEMPLATE PACKAGES
Besides the more complex smart templates, DEVONnote supports template packages. These are folders with
the file name extension ".dtTemplate" that contain one or multiple folders, one for each supported language.
This way, depending on the system language, you can let DEVONnote import the files in the right language.
Starting with version 2.8.4 template packages that don't need to support multiple languages can also go
without *.lproj subfolders. This further simplifies creating your own templates.
In addition, you can use the following placeholders in your file or folder names of your templates packages, as
well as in contained rich text, plain text, HTML, or XML files. During import they are replaced with actual data.
%time%: The current time
%date%: The current date
%shortDate%: The current date in short format
%longDate%: The current date in long format
%monthname%: The month name of the current date
%weekday%: The week day name of the current date
%day%: The day number of the current date
%month%: The month number of the current date
%year%: The year number of the current date
%author%: The author entered in Preferences > Editing > Author
%username%: The user's name
%fullUsername%: The user's full name
%organization%: The user's organization from Contacts
%emailAddress%: The user's email addresses from Contacts
%host%: The host name
%databaseName%: The database name
%databasePath%: The database's path
%groupName%: The name of the parent group
%topGroupName%: The name of the top group
%clipboard%: The clipboard contents as plain text
%styledClipboard%: The clipboard contents as rich text
%clipboardLink%: The clipboard contents as a clickable rich text link if the clipboard contains a valid URL
SMART TEMPLATES
Most of the prefabricated templates are "smart templates": They are not simple files, but actually AppleScript
packages that are executed when selected in the Data menu. These packages contain script code, as well as the
actual templates that they insert into your database. This has a number of advantages:
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The script can choose a localized template for your language; this is also possible using a template package.
The script can add information to the pre-fabricated template, e.g., the current date and time or data from the
Web.
The script can act intelligently on data on the clipboard: If it's a simple text, it adds the text; if it's a URL, it adds
it to a different area of the document and makes it clickable.
The script can check if a certain application is installed, e.g., OpenOffice, before adding a document.

WEB SITE EXPORT TEMPLATES
For exporting information as web site, DEVONnote
uses templates available in ~/Library/Application
Support/DEVONnote 2/Websites/ to create HTML
files from documents. You can choose the template
in the save dialog that appears when you use File >
Export > as Website
In the HTML templates, the following placeholders
can be used:
%charset%
%comment%

%content%
%databasePlusLocation%
%modification%
%stylesheet%
%title%
%url%
%tags%
These placeholders will be replaced with actual
information during the export. The placeholders will
only be replaced in documents that are converted
to HTML during export--namely plain text, rich text,
Microsoft Office/OpenOffice documents, scripts,
chat logs, and sheets.

SEARCH OPERATORS
In the toolbar search field you can use standard and extended Boolean operators, parenthesis, and more to fine
tune your search.
The syntax of the operators is compatible to DEVONagent and EasyFind, the Finder, Spotlight, common search
engines as well as common programming languages such as C, C++, Objective-C, Java, and JavaScript. The
complexity of the query is unlimited.
CASE
All terms are case-insensitive. You may, if you wish, use capitalization for proper names in a query, but
DEVONnote will ignore case in interpreting the query.
PRECEDENCE OF TERMS
Search terms and associated operators will be interpreted from left to right, except as modified by including
portions of the query within parentheses.
WILDCARDS
You can replace parts of words with wildcards matching one, multiple, or a range of characters:
?: Matches exactly one character.
*: Matches none, one, or multiple characters.
[a-b]: Matches one character of the range "a" through "b".
[abc...] or [a|b|c|...]: Matches one character out of the given list of characters.
[^...]: Matches one character that is not contained in the given list or range.
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BOOLEAN OPERATORS
The operators (often called Boolean operators) are words or symbols that establish logical rules for the terms in
the search query. If no operator is given, DEVONnote infers AND. The available Boolean operators are:
term1 AND term2: Contains term1 AND term2
term1 BUT term2: Contains term1 AND term2
term1 OR term2: Contains term1 OR term2
term1 XOR term2: Contains term1 or term2, but not both
term1 EOR term2: Contains term1 or term2, but not both
NOT term: Does not contain term
"term1": Contains the string of words term1, in exactly this form
Besides the classic Boolean operators, DEVONnote uses a number of operators that usually are found in highend databases. Use these operators as a replacement for AND and "quotes" to fine tune your query.
term1 OPT term2: term1 needs to occur, term2 can. If term2 does, the found document ranks higher in the
search results.
term1 NEAR term2: term1 occurs 10 words or less before or after term2
term1 NEAR/n term2: term1 occurs n or less words before or after term2
term1 BEFORE term2: term1 occurs before term2
term1 BEFORE/n term2: term1 occurs n or less words before term2
term1 NEXT term2: term1 occurs right before term2 (shortcut for BEFORE/1)
term1 NEXT/n term2: term 1 occurs n or less words before term2 (synonym for BEFORE/n)
term1 AFTER term2: term1 occurs after term2
term1 AFTER/n term2: term1 occurs n or less words after term2
~term1: Contains term1, also as part of a word
For convenience, some of these operators can also be abbreviated using commonly used symbols:
AND: &, &&, +
OR: |, ||
XOR: ^, ^^
NOT: !, Note: The symbols above are also used by the Finder and Spotlight for searches. Enter the vertical ruler
character for the OR operator by pressing ⌥7 (e.g. on European keyboards).
Operators are evaluated in the following priority: parenthesis > phrase/hyphens > (NOT) BEFORE/AFTER/
NEAR/NEXT > NOT > AND/OR/XOR/EOR. Terms with same priority but without parenthesis are evaluated
from left to right.
WHITE SPACE HANDLING
Words linked by non-white separators (e.g. www.devon-technologies.com or page_id) are treated like phrases
put into "quotes". Words separated by hyphens are handled like word1word2 OR "word1 word2". Characters
separated by dots are considered to be abbreviations and therefore handled like words separated by hyphens,
e.g., the term t.a.t.u is equal to "t a t u" OR tatu
EXAMPLES
By using any or all of the operators and rules layed out above you can create complex queries that find the exact
information you're looking for. Here are some example queries that show how the operators are used.
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Example: Devonian Dinosaurs
This query looks for all documents that contain the words "devonian" and "dinosaurs".
Example: (Steve NEAR Jobs) AND iMac BUT NOT MacBook OPT Pro
This query looks for documents that contain the words "Steve" and "Jobs" no farther ten words away from each
other, as well as the word "iMac" (no specific position relative to Steve and Jobs), but not the word "MacBook".
The word "Pro" does not need to occur, but if it does, the document is ranked higher in the list of search results.
Example: Paracetamol NEAR (~effect OR impact) AND ((side OR second*) NEAR/2 ~effect)
This query looks for documents containing the word "Paracetamol" near (within 10 words) to words either
starting with "effect" (and so also "effects") or "impact". In addition, the document needs to contain the word
"side" or any word starting with "second" located within two words range of any word starting with "effect".

TEMPLATE TAGS FOR WIKI-STYLE LINKS
In DEVONnote you can create new documents by first selecting some text in a rich text document and then
making it a link using the contextual menu. When you then click this link, DEVONnote creates the new
document using a template you set in the Editing Preferences. In this template, can use the tags below to
automatically insert the name of the link, the current date or other information. See also p. 21ff
%@: Name of link
%%: A "%" character
%a: Abbreviated weekday name
%A: Full weekday name
%b: Abbreviated month name
%B: Full month name
%c: Shorthand for "g%X %x," the locale format for date and time
%d: Day of the month as a decimal number (01-31)
%e: Same as %d, but does not print the leading 0 for days 1 through 9
%F: Milliseconds as a decimal number (000-999)
%H: Hour based on a 24-hour clock as a decimal number (00-23)
%I: Hour based on a 12-hour clock as a decimal number (01-12)
%j: Day of the year as a decimal number (001-366)
%m: Month as a decimal number (01-12)
%M: Minute as a decimal number (00-59)
%p: AM/PM designation for the locale
%S: Second as a decimal number (00-59)
%w: Weekday as a decimal number (0-6), where Sunday is 0
%x: Date using the date representation for the locale, including the time zone
%X: Time using the time representation for the locale
%y: Year without century (00-99)
%Y: Year with century (such as 1990)
%Z: Time zone name (such as Pacific Daylight Time)
%z: Time zone offset in hours and minutes from GMT (HHMM)
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ITEM LINKS
DEVONnote provides a URL (uniform resource
locator) for all documents and groups in its
database. While web URL typically begin with
"http://" or "https://", DEVONnote's URLs take the
form of "x-devonthink-item://" followed by a long
alphanumeric ID.
You get this item link by selecting a document or
group and choosing Edit > Copy Item Link, and you
can use it in any application that supports URLs, e.g.
the notes fields of OmniFocus tasks.
In addition you can manually extend the copied URL
with the following parameters:
reveal: Reveals a group instead of opening them.
Usage: reveal=1.
search: Directly jumps to the first occurence of the
search string. Usage: search=<string>.
Example:
x-devonthink-item://<groupID>?reveal=1
x-devonthink-item://<textFileID>?search=iPad
%20Pro
The first parameter after the ID is always added
after a questionmark (?), additional ones after an
ampersand (&).

METADATA
DEVONnote stores a large number of metadata
fields internally when importing documents
from the file system, e.g., from PDF, RTF, MP3,
EXIF/IPTC, HTML, and email messages as well as
from all files that deliver metadata through the
Spotlight metadata importer. Here's a partial list of
theoretically supported fields:
General:
Title
Headline
Subject
Creator
Producer

PDF and RTF:
Description
Copyright
Comment
URL
Keywords
Electronic correspondence:
Authors
Author email addresses
Recipients
Recipient email dddresses
Email addresses
Electronic publications:
Album
Composer
Contributors
Publishers
Editors
Organizations

HIDDEN PREFERENCES
There are a few settings in DEVONnote that you
cannot set through the Preferences window. Most
of them are intended to facilitate customer support
but they might be interesting for you as well.
Note: These hidden preferences are not an
official feature and could be changed or removed
with any update.
HOW TO ACCESS THE HIDDEN PREFERENCES
All hidden preferences are simple on/off switches.
You set and unset them using the "defaults"
command in the Terminal. To set preferences via the
Terminal DEVONnote must not be running or it will
overwrite your changes when you close it.
To set a preference using the Terminal, the
command line looks like this:
Terminal:
$ defaults write com.devontechnologies.note2
ShouldScaleAttachedImages -bool TRUE
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The above command activates the preference with
the key "ShouldScaleAttachedImages". Change
TRUE to FALSE to deactivate it. Use any of the
preferences keys below to activate or deactivate
them.
The preference AdditionalPlainTextExtensions is
best set from the Terminal. As it replaces the list
of additional plain text extensions we recommend
that you read the current list first (empty by default)
before adding your own to the end of the list.
Terminal:
$ defaults read com.devontechnologies.note2
AdditionalPlainTextExtensions
2014-07-31 08:25:27.101
defaults[21950:3312262] The domain/
default pair of (/Users/eb/Library/
Preferences/com.devon-technologies.note2,
AdditionalPlainTextExtensions) does not
exist

AVAILABLE HIDDEN PREFERENCES KEYS
AdditionalPlainTextExtensions: Adds additional
plain text extensions, separated by dots.
AdditionalXMLExtensions: Adds additional XML
file name extensions, separated by dots.
DisableBadgeLabel: Disable the badge label on
DEVONnote's Dock icon.
DisableFinderTags: DEVONnote no longer
imports or exports Finder tags.
EnablePDFDrawing: Enables DEVONnote's own
drawing of PDF pages. This was a workaround for
macOS Sierra and is incompatible to macOS High
Sierra.
RichNotesWithoutAttachments: Services create
RTF instead of RTFD.
ShouldScaleAttachedImages: Enables image
scaling in RTF documents.
SyncDebugLog: Enabled additional sync logging
for debugging.

$ defaults write com.devontechnologies.note2
AdditionalPlainTextExtensions string .otl.todotxt
$ defaults read com.devontechnologies.note2
AdditionalPlainTextExtensions
.otl.todotxt
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