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Read me


	
	
	
	DEVONnote is an easy-to-use, intelligent note pad which helps you sort out new stuff, manage bookmarks, browse the web and use cross and Wiki-style links.

	
	
	
	
	
	
	
	
	
The DEVONnote advantage

		Why DEVONnote? 

			
			
			
			DEVONnote keep all of your notes safe in one place and organize them in a way that is meaningful to you, using built-in artificial intelligence (AI). DEVONnote treats web sites like "living" notes. View them directly in the application and manage your bookmarks like simple documents. Keep notes and related bookmarks together.

		
		
		
		What can you do with it? 

			DEVONnote is much more than just a notetaking applicationIt is the #1 tool for collecting and organizing info bits and snippets on the Mac.Use DEVONnote to:

			
			
					Write down your thoughts as plain or rich text, highlight important passages

					Clip data from documents or Web pages using Services or the Dock menu

					Make structure out of chaos. Connect your notes with automatic Wiki links

					Sort in new stuff or find similar documents, all with just a single click

					Surf the Web using the integrated browser, or watch your favorite Web cams

			

		
		Editions 

			DEVONnote is a streamlined version of DEVONthink.  You can find a feature comparison on our web site. 

		
	Getting started

		DEVONnote is a powerful application that may require time to fully master. Open the Support Assistant to read tips, tricks, and tutorials. Install pre-made templates  that extend DEVONnote's functionality.

		[image: ]

		Other helpful resources are our company blog, where we publish timely news and, sometimes, even public betas, and our lively user form.

		Continue here:

				Open the Support Assistant [special link, not enabled in ebook] 

				Visit our company blog 

				Visit our user forum 

		

	System requirements

		A Mac computer with at least 2 GB of RAM, OS X 10.6.8 or later. In addition, we recommend a broadband Internet connection.

		Note: In 32-bit mode or on a computer with an older 32-bit CPU, we recommend  keeping the total number of elements the open database below 300,000 items and 200 to 300 million words. Larger databases could become unreliable due to low memory in 32-bit mode.


	Installing, updating, uninstalling

		Note: The following procedures do not apply when you have purchased DEVONnote on the Mac App Store. Installing, updating, and uninstalling are handled by the App Store application in this case.


		Installing and updating 

			Move the DEVONnote application package to the Applications folder or any preferred directory. Please note that Mac OS X Services and the connection to DEVONagent  work only for applications installed into the Applications folder, and that logout and login or a restart is required after installation.

			To update an existing version of DEVONnote, simply copy the application package from the disk image to your Applications folder, replacing the old version. Your database(s) will not be affected. If you purchased DEVONnote in the Mac App Store you can also download the update from the DEVONtechnologies website.  It will retrieve the existing receipt and accept it as valid license.

		
		32-bit vs. 64-bit mode 

			When opened in 64-bit mode DEVONnote is able to use all available physical memory. This means database size database is  limited only by the amount of available RAM and the speed of your computer. However, in 64-bit mode DEVONnote uses about 60 percent more RAM than in 32-bit mode.

			If you don't need 64-bit mode, you can disable it by selected DEVONnote application package in the Finder, e.g., by right-clicking DEVONnote's icon in the Dock and choosing Show in Finder, opening the Finder's Info panel, e.g., by pressing ⌘I, and checking Open in 32-bit mode in the General section.

		
		
		
		
		Uninstalling 

			To remove (uninstall) DEVONnote completely from your Mac, trash the following files and folders (~ stands for your Home folder):

			
					DEVONnote

					~/Library/Application Support/DEVONnote 2

				
				
				
					~/Library/Preferences/com.devon-technologies.note.*

				
				
				
				
				
				
				
				
			

		
	Version history

		Version 2.5.2 

			
			This maintenance update adds improvements to the user interface and fixes a number of bugs.

			
			Improved:

				
				
				
				
				
				
					Going up, e.g. via the toolbar or the Go  menu, retains the selection if possible.

				
					Text views don't scale too large attached images anymore.

				
				
				
					Faster and more reliable Sync Agent for synchronizing with DEVONthink To Go v1.

				
				
					German and French localizations.

					Overall reliability.

			

			Fixed:

				
				
				
				
				
				
					Changing the modification date via the Info  panel changed the creation date.

					Some contextual menu commands appeared even though the selection didn't contain usable data.

				
				
				
					Web windows/tabs were sometimes closed/reset after e.g. repairing and optimizing.

					Glitches of text rulers.

					Support Assistant didn't work on non-admin accounts due to a permission issue.

					Rare crash after quitting the app in fullscreen mode on OS X 10.7 and up.

					Several minor memory management issues.

					Further minor glitches.

			

		
		Version 2.5.1 

			
			This release fixes the broken DEVONthink To Go synchronization and a few minor glitches.

			
			Fixed:

				
					DEVONthink To Go synchronization was broken in version 2.5.

				
				
					Further minor glitches.

			

		
		Version 2.5 

			
			
			This release brings improved tagging including a "Tags" column in document lists that makes tagging multiple items much easier. In addition the update adds new standard editing options, editable creation and modification dates, and a number of minor user interface refinements such fewer unnecessary alerts and sheets.

			New:

				
				
				
				
					Smart groups  support new predicates; the "Tag is (not) ..." predicate supports wildcards.

					Some new options added to Preferences > Editing > General.

				
				
				
					Info  panel can be opened from action and contextual menus.

				
					Creation and modification dates can be edited via the Info  panel.

					Help button added to smart group editor. 

					Retina graphics.

			

			Improved:

				
					Better tagging with new smart group predicates, an optional editable Tags column, and the possibility to sort by tags; tags can be added to multiple items using the Tags  bar and the Info  panel.

				
				
				
				
				
				
				
				
				
					File > Export > Files & Folder  split into Export > Files & Folders and Export > Document.

				
				 
					Less unnecessary alerts and sheets.

					An alert (suppressable) is displayed before moving items to the trash.

					Log panel wraps long texts.

				
					Better validation of various menu items in case of no or read-only databases.

					Support improved for Notification Center on OS X 10.8 Mountain Lion.

					Synchronizing with DEVONthink To Go shows a warning when the Mobile Sync group is empty.

				
					Handling of aliases while merging tags and groups.

				
					More reliable import of web browser bookmarks.

				
					Importing both items and enclosing folders, e.g. by dragging from the Finder's List view, no longer creates duplicates.

					Orphaned files are now logged after ignoring errors reported by Tools > Verify & Repair.

				
					Reliability of automatic backups.

					Various other user interface improvements.

					English, French, and German localizations.

					Overall performance, efficiency, and reliability.

		

			Fixed:

				
				
				
				
				
					Name changes in DEVONthink To Go weren't properly applied on the Mac during sync.

					Reloading of web tabs wasn't possible in case of failures (e.g. being offline).

					Last selected and visible range of documents wasn't always restored.

					Last modification of group hierarchy right before quitting wasn't always commited.

					Background operations weren't always committed.

					Status bar wasn't always updated.

					Minor issue after duplicating an ordinary tag via drag-and-drop.

					Minor glitches related to full-screen mode.

					Some rare exceptions and crashes.

				
					Various minor display glitches.

			

			
		
		Version 2.4.3 

			This maintenance release recognizes FoldingText files as plain text documents, enhances compatibility to third-party hacks, improves the overall performance, and fixes a number of minor issues.

			
			New:

					.ft (FoldingText) added to list of known plain text extensions.

				
					Left/right arrow keys can be used to expand or collapse multiple selected items in list and outline views, too.

				
				
			

			Improved:

				
					OpenMeta  tag support, e.g. more reliable handling of file system events.

				
				
					Currently selected tab is usually retained, e.g. after capturing notes.

				
				
				
					Compatibility to third-party hacks.

					Default ruler units are centimeters on metric systems instead of inches.

					Error handling.

					Localization.

					Overall performance and reliability.

			

			Fixed:

				
				
				
				
				
				
				
				
					Send by Email couldn't attach files with non-ASCII characters in their name on OS X 10.8 Mountain Lion.

					Other minor bugs and glitches.

			

			
		
		Version 2.4.2 

			
			This maintenance release improves sorting, 64-bit support, and memory management, and fixes a number of minor issues. This update is recommended for all users.

			
			Improved:

				
				
				
				
					Make Rich Text automatically shows the ruler again if it was used the last time.

				
				
				
				
				
				
				
				
					Localized sorting of most views

					Compatibility of web views to web pages using buttons to open new windows.

					64-bit support.

					Memory management.

			

			Fixed:

				
					Number of duplicates displayed in Info  panel was not always correct.

					Select Group panel does not leave another apps' full screen mode.

				
				
				
				
				
					Further minor bugs and glitches.

			

			Removed:

				
				
					Due to sandboxing the App Store variant of DEVONnote no longer imports Spotlight comments unless the files or folders are already indexed by Spotlight.

			

		
		Version 2.4.1 

			This maintenance release improves the link handling of templates and fixes a number of bugs.

			Improved:

					Link handling of (smart) templates retains formatting (e.g. the font).

				
			

			Fixed:

					Handling of label predicates in smart group editor.

				
				
				
				
				
				
			

			
			
		Version 2.4 

			This release adds compatibility to OS X 10.8 Mountain Lion and support for new system-wide features such as notifications and sharing services. Thanks to 64-bit support the size of the database is now only limited by the amount of available RAM and the speed of the computer. DEVONnote 2.4 brings also other enhancements and important bug fixes. This update is recommended for all users.

			Note: Starting with this release DEVONnote requires OS X 10.6.8 or later and an Intel-based Mac.


			
			
			
			All editions:

					NEW: Compatibility to OS X 10.8 Mountain Lion.

					NEW: Simple 64-bit support so that the amount of data  is only limited by available real memory and the speed of the computer.

					NEW: Share button for sharing the current document or web page via services like iMessage, Mail, Twitter, Facebook, or AirDrop, or to add it to Safari's Reading List (OS X 10.8 Mountain Lion or later).

					NEW: Notifications. Clicking a notification opens the item in DEVONnote. (OS X 10.8 Mountain Lion or later)

					NEW: Documents can be moved, replicated, or duplicated by dragging its document icon from the title bar.

					NEW: Video tutorials, available via the Support Assistant or Help > Tutorials.

					NEW: Columns URL, Path, Aliases, and Spotlight Comment of search results are editable.

					NEW: Buttons to go to the previous/next highlight added to navigation bar of PDF/text documents.

					NEW: Additional optional toolbar items.

					NEW: Shortcut ⌃C for Move To button of See Also & Classify drawer.

					NEW: Autocompletion of tags, e.g. in the Tags bar, matches not only prefixes but also substrings.

					NEW: High resolution application icon for Retina screens.

					NEW: App Store version is sandboxed. Exporting of Spotlight comments is no longer possible, only importing.

					Improved: Tags in the Tags bar and the tags field of the Info panel are now sorted.

					Improved: Toolbar search results are automatically hidden after creating new items in three-pane and split view.

					Improved: Support Assistant shows an activity indicator while loading data.

					Improved: Much faster importing of Spotlight comments if the files/folders are indexed by Spotlight.

					Improved: Templates access the address book only if necessary.

					Improved: Support Assistant and Help > Contact no longer access the address book anymore on OS X 10.8 Mountain Lion or when DEVONnote was installed from the App Store.

					Improved: Error logging to Log panel.

					Improved: Compatibility to TextExpander.

					Improved: French and German localizations.

					Improved: Overall performance, reliability, and memory usage.

					Fixed: Clearing the toolbar search field did not revert the toolbar to text-only mode if necessary.

					Fixed: @ button next to URL field in Info panel beeped in case of success.

					Fixed: Typing after newly inserted/created links in RTF(D) documents used blue and underlined style.

					Fixed: Website export of rich text documents containing movies/sounds  didn't work.

					Fixed: Add tag contextual menu command didn't work.

					Fixed: Various minor issues in the Support Assistant.

					Fixed: Compiled using Xcode 4.4 and the OS X 10.7 SDK fixing a number of glitches.

					Fixed: More minor bugs and glitches.

					Removed: Obsolete menu command File > Export > to iPod.

			

		
		Version 2.3.5 

			This maintenance release  makes the tutorials easier accessible, improves some aspects of the user interface, and fixes a number of bugs and glitches. Mac App Store customers can now seamlessly update to copies downloaded from the DEVONtechnologies website  without purchasing another license.

			
			
			
			All editions:

					NEW: Tutorials are easier accessible.

					NEW: App Store users can seamlessly update to DEVONnote downloaded from the DEVONtechnologies website. 

					Improved: Text views use faster, non-contiguos layouting.

					Improved: Log  panel scrolls automatically to latest entry if sorted by date.

					Improved: Memory management.

					Fixed: Smart groups showed wrong icon on OS X 10.7.4.

					Fixed: Last opened windows aren't restored anymore after a crash or after using Force Quit.

					Fixed: Menu items didn't correctly change after registering the application.

					Fixed: More minor issues and rare crashes.

			

		
		Version 2.3.4  1.0.1 

			Skipped.

		
		Version 1.0 

			Initial release.

		
	License agreement

		PLEASE READ THIS LICENSE CAREFULLY BEFORE USING THIS SOFTWARE. BY USING THIS SOFTWARE, YOU ARE AGREEING TO BE BOUND BY THE TERMS OF THIS LICENSE AGREEMENT. IF YOU DO NOT AGREE TO THE TERMS OF THIS LICENSE, DELETE THE SOFTWARE OR RETURN THE SOFTWARE AND RELATED DOCUMENTATION TO DEVONTECHNOLOGIES, LLC.

		1. License: The application and other components (sound and graphics) accompanying this License, whether on disk, in read only memory, or on any other media (the Software), and the related documentation are licensed to you by DEVONtechnologies. You own the disk on which the Software is recorded but DEVONtechnologies and/or DEVONtechnologies Licensor(s) retain title to the Software and related documentation. This License allows you to non-simultaneously use the Software on multiple computers by the same person.

		2. Restrictions: The Software contains copyrighted material, trade secrets and other proprietary material and in order to protect them you may not decompile, reverse engineer, disassemble or otherwise reduce the Software to a human-perceivable form. You may not sub-license, modify, rent, lease, or create derivative works based upon the Software in whole or in part. You may not distribute the Software in any form, including, but not limited to, electronic information service 	distribution, bulletin board distribution, and magnetic or optical medium distribution.

		3. Disclaimer of Warranty on Software: You expressly acknowledge and agree that use of the Software is at your sole risk. The Software and related documentation is provided AS IS and without warranty of any kind.

		4. Limitation of Liability: UNDER NO CIRCUMSTANCES INCLUDING NEGLIGENCE, SHALL DEVONTECHNOLOGIES BE LIABLE FOR ANY INCIDENTAL, SPECIAL OR CONSEQUENTIAL DAMAGES THAT RESULT FROM THE USE OR INABILITY TO USE THE SOFTWARE OR RELATED DOCUMENTATION. In no event shall DEVONtechnologies total liability to you for all damages, losses and causes of action (whether in contract, tort (including negligence) or otherwise) exceed the amount paid by you for the Software.

		Apple, Carbon, Classic, Cocoa, ColorSync, Darwin, Mac OS X, QuickTime, Quartz and all other registered names are trademarks of their respective owners.

	Credits

		
		AMIndeterminateProgress 

			Copyright  2007 Andreas Mayer.  All rights reserved.

			Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

			
					Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

					Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

					Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

			

			THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

		
		
		
		
		RegexKitLite 

			Copyright  2008 John Engelhart. All rights reserved.

			Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

			
					Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

					Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

					Neither the name of the Zang Industries nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

			

			THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

		
		
		
		
		Sparkle 

			Copyright  20062009 Andy Matuschak

			Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

			The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

			THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

		
		Video JS 

			Copyright  2010 Zencoder, Inc. 

			The Video JS player is used according to the LGPL v3. 

		
	Common tasks


	In this chapter you'll find a number of common ways you can use DEVONnote for everyday tasks, from surfing the Internet and making notes to cataloging photos and archiving emails.


	
	
	
	
	
	
	
	
	
	
	
	
	

Browse the Internet

		Besides being a knowledge and information database, DEVONnote acts as a web browser.  This extends the document-based approach to knowledge to the World Wide Web. Because DEVONnote is a database manager, its web browser does not work in a windowed style like Safari or DEVONagent Pro;  rather, it's document-oriented.

		
		This enables you to treat web pages the same way as you treat documents. Whenever you select a web document (bookmark), DEVONnote immediately loads and displays its content live from the Internet in the view/edit pane. 

		
		Possible uses:

				Visit frequently used web sites in a convenient interface

				Integrate "live" content from the web with your other documents

				Grab data from web sites and store it in DEVONnote

			
		

		Continue to read here:

			
				Create a new URL or HTML document 

				View "live" and local HTML pages 

			
		

	Collect text snippets and other valuable data

		Using Mac OS X's handy Services menu,  DEVONnote is the premiere tool for collecting and organizing information bits and snippets.

		
		Select any piece of data and capture it to the currently open database with a keystroke or a quick visit to the Services menu. All Cocoa applications such as TextEdit, Safari, or DEVONnote itself--as well as many new Carbon applications, e.g. the Finder or Microsoft Office 2004--support this mechanism. 

		DEVONnote automatically sets the title of the newly created snippet to the first line of text, so there's a good chance that you won't even need to rename it. New snippets are always created in the inbox. 

		Possible uses:

				Collect recent news from your favorite web sites

				Keep important information from any source and your other project-related documents together

				Create an info collection for a specific topic

		

		Continue to read here:

				Capture a note quickly using the Services menu 

				Use the Dock menu 

			
			
		

	Manage your bookmarks

		With its integrated, document-based web browser,  DEVONnote can be used as a bookmark manager. Organize all your bookmarks as bookmark documents and visit the website simply by selecting the bookmark in split or three panes view. DEVONnote loads the page and displays it in the view/edit pane.

		
		If you want to open the Web page in your default browser, simply ⌃ click (right-click) the bookmark and choose Launch URL from the contextual menu.

		Possible uses:

				Manage your bookmarks

				Keep project-related web pages and other documents together

				Visit frequently used web sites in a convenient interface

				Integrate "live" content from the web with your other documents

				Grab data from web sites and store it in DEVONnote

		

		Continue to read here:

				Create a new bookmark document 

				View "live" and local HTML pages 

			
			
		

	Take notes

		DEVONnote is perfectly suited for taking notes and organizing them.

		
		Use DEVONnote's Take Note  panel or its Dock menu  to quickly create new notes, write notes using the advanced text editing capabilities of Mac OS X, and find a place to file them in your database using the Classify & See Also  button.

		Possible uses:

				Write down ideas before they vanish

				Take quick phone messages

				Keep project notes and your other project-related documents together

		

		Continue to read here:

				Create new documents 

				Create a new note using the Dock menu 

				Revise notes and documents using the built-in rich text editor 

				Organize your data using Classify and See Also 

		

	Write texts and outline projects

		With its hierarchical group structure, organization, and navigation functions, as well as its advanced text editing capabilities based on the Mac OS X text engine  DEVONnote is perfectly suited for writing text from notes to whole books.

		
		Create new documents with just one click, find related documents,  and network them with Wiki-style or static cross-links. Because you are working with databases in DEVONnote, you can switch from one document to another with just one click, and manage even large projects with ease.

		By flagging  groups and documents DEVONnote can also be used as a simple outliner. Unlike other outliners, DEVONnote uses documents as items and groups for items that have sub-items. Use it with the Split view  to create an outliner look-and-feel.

		Possible uses:

				Write notes, white papers, and letters

				Write and organize book chapters

				Organize your ideas or projects in outlines

				Create a network of information for your projects or interests

		

		Continue to read here:

				Create new documents 

				Use the built-in rich text editor 

				Choose between various window layouts  to match your work style 

				Use the See also & Classify drawer 

			
		

	In & out


	DEVONnote is not an island. It integrates with the rest of your Mac and iOS devices in a variety of ways to make it easy for you to add data to DEVONnote.


	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	

Drag and drop

		The easiest way to add data to DEVONnote, other than creating the documents directly inside the application, is to drag files or selected data, e.g. text, images, etc., into a DEVONnote window or onto its Dock icon.

		Dragging files into a document list imports  the file; dragging text or images creates documents for them. Dragging files into a rich text document adds them as attachments to the document. Dragging data to the Dock icon creates new documents in the default destination. 

	Importing and indexing

		You import files with drag-and-drop  or using the File > Import  menu item. Imported files are copied into the database and appear as a document in DEVONnote's interface.

		
		
		Indexing, adding files as pure references to the database, is not available for DEVONnote.

	Services

		The DEVONnote > Services menu gives you access to special commands published either by other applications, such as TextEdit or Safari, or by services extensions such as DEVONtechnologies' WordService or CalcService.  Also, DEVONnote publishes its own services in the Services menu.

		
		DEVONnote services 

			DEVONnote installs several services for copying or summarizing selected text, capturing a web page, or searching documents in the database.

			
				
					Take Plain/Rich Note: Adds selected text to the global inbox from any application that support services (!) as plain or rich text. Taking a rich text note also copies images and clickable links. If the source document is a web page or a news feed, DEVONnote tries to capture the address of the page or feed as well. This only works with applications that support this feature, such as Safari, DEVONagent Pro,  or NetNewsWire. 

					Capture Web Archive: Captures the web page displayed in the frontmost window of any WebKit-based browser (such as Safari or DEVONagent Pro) as a web archive to DEVONnote's inbox. This menu item is only shown when available, e.g., when Safari is the active application.

					Append Plain/Rich Note: Adds selected text as plain or rich text to the last note taken using the DEVONnote Services menu items.

				
				
			

		
		
		Note: After installing DEVONnote you need to log out, then back in again for new services and their shortcuts to be recognized. If one or more DEVONnote Services menu commands do not carry a shortcut, it may be because another application grabbed them. Mac OS X will assign the shortcut if no other application already uses the same key combination.


	Dock menu

		The Dock menu appears when you click DEVONnote's icon in the Dock with the ⌃ key pressed, when you right-click it, or when you left-click it and hold the mouse button for one second or longer.

		
		Use the Dock menu commands Import and Index to import or index files. Copy something to the Clipboard and use New with Clipboard to directly create a document with the Clipboard contents anywhere in your open databases. DEVONnote will try to create a meaningful name for it. Finally, choose Take Note to open the Take Note  panel.

	Synchronizing

		Note: DEVONthink To Go 2,  planned for release in 2013, will use the sync mechanism described above. Version 1.x, however, uses its own proprietary sync mechanism. The information below will become obsolete with the release of version 2.


		DEVONnote has the ability to synchronize its database with DEVONthink To Go,  its companion app for iPhone, iPad, and iPod touch devices.

		Synchronizing with the device: DEVONnote uses a special group named Sync to let you decide which data you want to share with your iOS device. The Sync group appears on the top group level of your database and has a special icon that makes it stand out from other groups. To select the items in your database that you want to take with you on your device, either move or replicate  them into its Sync group. You replicate items by dragging them with the ⌘ and ⌥ keys held.  You can add documents as well as whole groups to the Sync group. Smart groups are not yet supported and will be ignored during synchronization.

		Make sure your device is on the same Wi-Fi network as this computer. On the device open the DEVONthink To Go app, tap the sync button on the app's home screen, and follow the instructions.

		Visit the App Store: If you do not yet have DEVONthink To Go installed on your device, learn more  about it or visit the App Store.  If you have problems synchronizing with DEVONthink To Go 1.x click here. 

	Menus


	A complete listing of all commands DEVONnote offers in the menu bar, the global Mac OS X Services menu, and the handy Dock menu.


	
	
	
	
	
	
	
	
	
	
	
	
	

The Application menu

		The DEVONnote menu is similar to the application menu in any other Mac OS X application. It contains commands for displaying the splash screen, opening the Preferences window,  accessing the Services menu, hiding and showing windows, and, of course, quitting the application.

		
		About DEVONnote, ... 

			
					About DEVONnote: Shows information about DEVONnote including the version number and licensing information.

					Check for Updates: Checks if updates for DEVONnote are available. By default, DEVONnote checks for updates automatically; you can change the update settings in the Preferences, Update  pane.

			

			Note: When checking for updates no information is uploaded from your computer to the DEVONtechnologies server. DEVONnote only downloads a file listing the most current versions to your Mac. This option is not available if you have purchased DEVONnote from the Mac App Store. In this case, all updates are handled by the App Store.


		
		
		Preferences, Trash, and Cache 

			
					Preferences: Opens the Preferences. 

					Empty Trash: Moves the contents of the database trash to your computer's file system trash.

					Empty Cache: Empties the web browser cache. This frees up space and makes sure that all, when displaying a web page, all data is freshly loaded instead of using a cached copy.

			

			Note: If Index-captured items are contained in the database trash when you use Empty Trash, the option Also from disk will become available. If chosen, it will send the externally linked files to the system trash, too. Caution is advised!


		
		Purchase, ... 

			
					Check Upgrade Options: Opens a web page that lists the upgrade options available for your copy of DEVONnote.

					Purchase License: Opens the DEVONtechnologies Online Shop  and puts DEVONnote into your shopping cart. If this copy of DEVONnote is already licensed, you will be presented with the choice of buying an upgrade for your existing license or buying another full license.

					Enter License: Use this command to enter your licence code. Make sure you enter ALL the details EXACTLY as they appear in the licence code e-mail. It is best to use copy-and-paste for transferring name, organization, and licence code from the email message to the appropriate fields. Note: Make sure that when you highlight the information to copy and paste, no spaces before or after the information are highlighted.

			

			Note: Enter License changes into License and Purchase License into Purchase License or Upgrade  as soon as you have entered a valid license code (and a paid upgrade exists). Available options depend on whether you have purchased your copy in DEVONtechnologies' online shop or from the Mac App Store.


		
		Services 

			
					The Services sub-menu gives your access to special commands published by other Mac OS X applications such as TextEdit or Safari, or by services extensions such as our own WordService or CalcService.  Also, DEVONnote publishes its own services. [Read more...] 

			

		
	The File menu

		The File menu contains all commands that deal directly with files in your volumes, databases, or files that can be imported, exported, or linked. Also, the File menu contains commands for printing documents.

		
		New Window 

			New Window: Opens a new main window  for an open database. (If only one database is open, no sub-menu is available.) DEVONnote windows present all documents and groups of a database in a Finder-like fashion, and are used to access all stored items. The window also contains a view/edit pane for easy viewing and editing of documents.

		
		Import 

			Import: Imports files or complete folders from your volumes into the database. You can find a list of all supported file formats in the appendix.  If not stated differently, data is imported to the default destination.  Finder labels are honored whenever possible.

			
			
			
		
		Export 

			This sub-menu allows you to export selected documents or groups to the file system.

			Files and Folders: Exports the selected documents and recreates the hierarchy you have built in DEVONnote almost exactly. Metadata files (".DEVONtech_storage") make sure that no metadata such as comments, URLs, etc., are lost. DEVONnote reads these files when importing and recreates your original data structure. If you don't need the metadata, you can safely delete the ".DEVONtech_storage" files.

			Document: Exports the currently viewed document.

			In addition, the Export sub-menu provides export methods based on plug-ins. DEVONnote comes with a number of standard plug-ins for exporting documents in different formats. Currently the following plug-ins are included:

			
				
				
				
				
				
				
					as Website: Exports the selected items as standalone web site that you can upload to your web server and share with colleagues. In the appearing dialog window, choose the desired template, text encoding, and whether DEVONnote should convert diacritics and accented characters to HTML entities or not. File types that cannot be displayed in a web browser, e.g., iWork Pages files, are converted to PDF if possible. For the export, templates that you can modify yourself are used. [Read more...] 

					as Template: Saves the selected document as a template, which can then be used to quickly create new documents using Data > New > With Template.  To remove a saved template or to organize your templates in sub-folders, visit the folder '~/Library/Application Support/DEVONthink Pro 2/Templates.noindex''~/Library/Application Support/DEVONthink 2/Templates.noindex' in the Finder, then create sub-folders, move items, rename them, or trash them.

				
			

			
		
		
		
		Verify 

			Like any database, DEVONnote needs a bit of maintainance from time to time. All the commands you'll need for this can be found here.

			Verify & Repair: Verifies all database structures and repairs them if necessary. Use this whenever you feel it is necessary. By default, DEVONnote automatically verifies the database structure every time you open a database; DEVONnote will advise you to run this command when it finds significant errors.

			Backup & Optimize: Creates an internal backup of the database and then optimize the database structure. Optimizing removes unnecessary internal elements from the database and rebuilds the internal structure to optimize performance. DEVONnote also creates internal backups on a regular basis depending on the settings in the Preferences, Backup tab. 

			Restore Backup: Restores an internal backup. Choose the backup you want to restore from the dialog window and click Open. You can identify backups by their creation date.

			Note: Restoring a backup simply swaps the current database and the backup. The backup becomes the active database, the former database becomes a backup. You'll never lose any data by using this command.


			Rebuild Database: Completely rebuilds the database by exporting all items to a temporary folder in the file system, creating an empty database, and reimporting all items. This removes any structural problems. Depending on the size of your database, this can take from a few seconds to several hours.

		
		Properties 

			Database Properties: Opens the Database Properties panel  for your database that allows you to change properties such as database name, comments, and username/password. 

			
			
		
		Page Setup, Print 

			Page Setup: Sets your preferred page size.

			Print: Prints the selected or front-most document.
		
		
	The Edit menu

		The Edit menu contains all commands and options relating to editing. You'll find the classic Mac cut/copy/paste and find/replace commands here, as well as many more.

		Undo and Redo 

			Undo/Redo: Undoes your last action or redoes it. Undo and Redo work for most actions.

		
		Cut 

			Cut/Copy/Paste: Do exactly what their names say.

			Copy URL: Copies the URL of the selected or frontmost document to the Clipboard.

			Copy Item Link: Copies a URL to the Clipboard. This URL can be pasted into other documents in other applications to create a link to the item in DEVONnote.

			Paste and Match Style: Pastes text from the Clipboard into rich text documents, disregarding all styles from the clipped text, and matching styles in the current document.

			Delete: Deletes the selected piece of text.

			Complete: Tries to auto-complete the partial word before the insertion caret. This standard Mac OS X function uses the currently active dictionary, which you can change via the spell check panel (see below). 

			Select All/Deselect All: Selects or deselects the complete content of the frontmost document.

		
		Document editing 

			Tags: Shows the Tags  bar, if necessary, so that you can enter your tags immediately.

			
			
		
		Page editing 

					
					
			Rotate Left/Right: Rotates a selected image or page left and right.

		
		
		Find 

			Find: This sub-menu contains commands for finding and replacing text as well as for bringing DEVONnote's database search field into focus.

			
					In Database: Brings the search field of the frontmost window into focus.

					Find: Opens the standard panel for finding text within a document.

					Find Next/Previous: Jumps to the next, or previous occurence, of the last search term.

					Use Selection for Find: Copies the selected piece of text to the Clipboard or into the search field of the find panel, if it is opened.

					Scroll To Selection: Scrolls the displayed documents to the current selection.

			

			Spelling and Grammar: Provides the standard Mac OS X functionality for checking text for spelling or grammar errors. To choose the language used for spell checking, or for auto-completion (see above), open the spell checker panel with Edit > Spelling and Grammar > Show Spelling and Grammar and choose your language of choice from the pop-up menu.

			Substitutions: Shows the standard Substitutions preference panel and switch the available options manually on and off: Smart Copy/Paste, Smart Quotes, Smart Dashes, Smart Links, Data Detectors, and Text Replacements. Data Detectors analyze shown text and make context-sensitive actions available, e.g., when you hover the cursor over a phone number or postal address. Mac OS X 10.6 "Snow Leopard" or higher only.

			Transformations: Use this sub-menu to change selected text to all lowercase or uppercase, or to capitalize every word.

			Speech: Starts or stops speaking the selected piece of text.

			Insert: Inserts special characters, the current date and/or time, or a picture into your text. Note: You can only embed a picture into a rich text document, not into a plain text document.

			Special Characters: Shows the standard Special Characters panel for inserting characters that you cannot enter directly with your keyboard.

		
	The Data menu

		The Data menu contains all commands that deal directly with documents or groups. Here you'll find commands for creating, labeling, classifying or group new documents, and more.

		New 

			New: Allows you to create new documents directly from within DEVONnote.

			
					With Clipboard: Creates a new document based on the contents of the Clipboard. Note: Some applications such as Microsoft Word  put data in multiple formats into the Clipboard. DEVONnote tries to select the most useful one, however, in some cases it grabs an image instead of text (like Microsoft Word). Workaround: Create a text clipping for the text, or paste it into a TextEdit window, then copy the text from there.

					Plain Text: Creates a new plain text document. 

					Rich Text: Creates a new rich text document. 

					Script: Creates a new AppleScript script.

				
				
				
					Bookmark: Creates a new bookmark. Type the URL you like and name it; DEVONnote automatically sets the value of its URL field in the Info panel  accordingly. If you don't type in a name, DEVONnote looks up the page name on the Internet and sets it automatically for you.

				
					Group: Create a blank group. 

					Smart Group: Creates a new smart group, also known as "saved search". DEVONnote opens the Smart Group Editor , which lets you define your search criteria. When saved, the contents are updated every time you display the smart group's contents.
			
				
			

			
			You can add any document to the list of templates using File > Export > as Template. 

			Some of the pre-defined templates are "smart templates" or "template packages". They consist of  folders containing files for every supported language. These take care of choosing the right template variant for your language, adds the template to your database, and modifies it, if necessary. Some smart templates add the current date, insert the clipboard contents, check if a needed application is installed, and even access your Address Book to fill in your personal details from your card. [Read more...] 

			Use Open Templates Folder to open the folder containing the template files in the Finder and Update Templates Menu to update this menu when you have added new templates or made changes to the existing ones. Use More Templates to install additional templates. 

		
		Open 

			Open: Opens the selected document or group in a separate document window.  For groups, this command opens a second main window  rooted to the selected group.

			Open in Tabs: Opens the selected items in a new tab. You need have more than one item selected for this command to have an effect.

			
		
		Launch, Reveal, Show 

			Launch URL: Opens the file, folder, or Internet location indicated by the URL field in the Info Panel. 

			Reveal: Reveals the location of the frontmost document in either the same main window, if possible, or by opening a new one.

			Show in Finder: Opens a new Finder window for the folder, including the frontmost or selected documents. Naturally, this only works for documents referring to a file in the file system through the Path field in the Info panel. 

		
		Save 

			Save/Save All/Revert To Saved: Use these commands to save the frontmost document, all documents, or to restore the frontmost document to the last saved version.

		
		Label and Mark 

			Label: Allows you to mark the selected groups or documents with one of seven labels, just as in the Finder. You can define the color and the text of the labels in the Preferences, Colors tab. 

			Mark: Allows you to mark the item as flagged/unflagged, locked/unlocked, and read/unread. Items marked as unread show an unread marker in most views. [Read more...] 

		
		Duplicate 

			Duplicate: Creates a duplicate of the selected items. The name of the new item ends in "copy," and both items are shown in bold and blue because their contents are identical.

			Replicate: Creates a replicant for the selected items. Unlike a duplicate or alias, a replicant is like a second phone book entry for the same person. (Definition: Aliases are little files containing a link to the original file). When you replicate a group or document in DEVONnote, you end up with two replicants, not one alias and one original. Both items have the same name and are shown in red.

			Merge: Creates one big document out of several selected ones. This works for text documents, images, PDFs, sheets, and multimedia items. All the original documents are embedded in the resulting document and all tags are added, too. If the selection contains only images, PDF, or PostScript documents, DEVONnote generates a PDF file; otherwise DEVONnote generates a rich text document. Document types that cannot be merged, e.g., bookmarks, are ignored. This command can also be used to merge multiple selected groups/tags; in this case, the first group is used as the destination.

		
		
		Group 

			Group/Ungroup Items: Creates a new group containing all the selected items. This is similar to creating a new group and moving the selected items into it. This command also works in the See Also & Classify  drawer. Ungroup does exactly the opposite; it moves all items contained in the selected group one level up and  removes the now empty group.

			
			See Also & Classify: Opens or closes the See Also & Classify drawer  of a main window.

			
			Note: If the document you are auto-classifying has replicants, these are deleted and only the original document is placed into the new location. This prevents multiple replicants from being created when you are, for example, classifying this document again.


		
		Move to Trash 

			Move to Trash/Move All Instances to Trash: Moves the selected items to the trash. If you have selected a replicated item, Move All Instances to Trash moves this item and all its replicants to the trash.

		
	The Format menu

		The Format menu contains the commands and options dealing with all aspects of text formatting. Here you'll find the standard font, alignment, and ruler commands, as well as very special DEVONnote commands.

		Note: Many commands in this menu only work with rich text documents, as plain text documents do not allow formatting. (That's why they're called "plain" text.) Some formatting options are also available for editable PDFs and web archives.


		Font 

			Font: This sub-menu is reponsible for controlling the font and the document background color (rich text documents only). Open the fonts panel with Show Fonts, then increase or decrease the font size of selected text with Bigger and Smaller, adjust the text styles and the document background color.

			Using Copy Font, copy the font formatting of a selected piece of text or the passage of text around the insertion caret. You can then apply the formatting to selected text using Paste Font.

			Style: Commands in this sub-menu apply a certain style, such as italics, bold, or underlined, to selected text. Also, the commands give you access to some high-end font control like kerning, baseline shift, ligatures, and character shape (only applicable to Asian languages).

			The most interesting part here is Styles, which opens the Mac OS X Styles Editor. You can step through all the styles used in the current document and add them to your favorites. Use the pop-up menu to select a saved style and, if you don't need it any more, delete it. You can use saved styles from the ruler (see below).

			Note: If you think the user interface for the styles editor is less-than-wonderful, you're right. But don't blame us, it's Apple's design :-)


			Alignment: Align paragraphs left, right, centered, or justified. Here, Asian or Arabic users can also change the direction of writing, if desired.

			Ruler: Show the ruler, which shows the tab stops and contains alignment and styles buttons; copy the current ruler (line width, indents, tab stops, etc.) and paste it somewhere else.

			Learn more about the ruler and the Styles Editor here. 
			

		
		Highlight 

			Highlight, Highlight Color: In rich text documents, editable PDFs, and web archives use Highlight to highlight a selected piece of text just as you would using with a colored pen on a piece of paper. To remove highlighting, select the highlighted piece of text and choose Highlight again. Use the Highlight Color sub-menu to choose your favorite highlight color.

		
		Spacing 

			Spacing: This command is only available in rich text documents; the command allows you to adjust the line spacing of selected text. You can adjust the line height to an exact value or define a minimum and maximum height, adjust inter-line spacing, and define the space before and after a paragraph.

			Note: Paragraph spacings are not added to those of the preceding or following paragraph; instead, the maximum spacings from both paragraphs are used to ensure a proper layout.


			Link: Makes selected text a link to a URL (for example, to a web page or to an email address). This is a one-step command for writing the address into a rich text document, selecting the address, selecting Make Link (see below), and then changing the linked text to anything you want.

			List: Creates a bulleted list. Select your prefix, bullet style, and suffix in the dialog sheet and click OK to insert your list skeleton. In the list, press ⏎ to insert new items, and press ⇥ and ⇧⇥ to indent/de-indent items, just as you would in any word processor.

			Table: Inserts a new table into a rich text document and opens the table inspector panel. Use the table inspector to adjust the number of rows and columns, cell alignments, cell colors, border widths, and colors. Also, you can merge and split cells and create tables within a cell.

		
		Make Link 

			Link: Makes the selected text clickable and asks for a destination. Enter any valid URL you want the text to link to.

			Make/Remove Link: Makes selected text clickable, or removes a link from the current selection. Where you are taken to when you click the link depends on the selected text:

			
					If the text was a valid URL, the URL will be the target of the link. Editing the link text later does not change the target. Use the Edit Link command of the contextual menu to edit the link target.

					Otherwise, DEVONnote treats the link as a Wiki-style link. Clicking the Wiki-style link jumps to a document with exactly the same name as the linked text (or any document with a 
				Wiki alias of that name). If there is no document of that name, clicking the link creates a new rich text document named after the linked text and pre-filled by the template you set in the 
				Preferences, Editing tab. 

			

			Make Plain/Rich Text: Converts a rich text document to plain text and vice versa. Converting a rich text to plain text removes all formatting, while converting a plain text document to rich text applies default rich text font settings to the document.

		
		Invisibles 

			Show Colors: Shows the color panel, e.g., for changing the foreground color of selected text in rich text documents.

			Show Invisible Characters: Toggles display of invisible characters such as spaces, tabs, and line feeds. Shown invisible characters appear in light gray.

			Allow Hypenation: Enables or disables hyphenation for the current rich text document.

		
	The View menu

		The View menu contains all the commands for modifying the way DEVONnote displays groups and documents.

		Views 

			Using these commands, you switch between different layouts for main windows: 

			
				
				
				
					Split 

					Three Panes 

					Tags 

			

		
		View Options 

			
			Full Screen: Displays either the current document in a full screen mode optimized for reading and editing, or the frontmost window in full screen.

			
					Document: Shows the current document in full screen.

					Window: Shows the current window in full screen (OS X 10.7 Lion or higher only).

			

			To return to the normal view, press ⌘F7 respective ⌃⌘F7 or the ⎋ key. You define the width of the document full screen view as well as plain text font, background color, and text color in the preferences, Editing tab. 

			Quick Look: Opens the Quick Look panel for the selected items.

			Slideshow: Shows the selected items as Quick Look slideshow. Visible only when you visit the View with the ⌥ key held.

		
		View Layout 

			Widescreen: Switches Split, Three Panes, and Tag views between standard and widescreen layout.

			
			Show/Hide Details: Switches between displaying icons only or displaying icons together with detailed information such as kind, label, size, word count, creation date, and modification date. 

			Show/Hide Tags: Shows or hides the tag bar. 

		
		Sort and Columns 

			Sort: Sorts items in ascending or descending order by various criteria: name, kind, date added, creation/modification date, URL, path, word count, flag, label, width x height, duration, location (enclosing group hierarchy of the item), aliases, and Spotlight comment. You also can sort items manually, Unsorted, and choose to ignore umlauted characters when sorting elements. DEVONnote remembers sort settings for every group separately and uses those settings when the group is displayed in its own main window.

			Columns: This sub-menu lists all columns available in the current view and allows you to show or hide them individually. Use these options to show exactly the information you need.

			The State column shows the state (flagged or unflagged). Clicking the flag or the empty spot for the flag toggles the option. Unread items are marked as read when the "unread" state is clicked.

			Both Sort and Columns support a range of metadata fields next to DEVONnote's own data fields.

		
		Expand and Collapse 

			Expands and collapses all groups at once.

			Zoom In/Out: Zooms into or out of the document.

		
		Zoom, Full Screen 

			Actual Size: Depending on the document type, you can zoom the document to your needs:

			
					Actual Size: Displays the document at actual size, calculated using the resolution of the screen and the resolution information of the image or PDF.

				
					Zoom In/Out: Zooms in or out of the document.

				
				
			

		
		
		Toolbar Options 

			Hide/Show Toolbar: Hides or shows the toolbar of the frontmost window.

			Customize Toolbar: Lets you configure the toolbar of the frontmost window.

		
	The Go menu

		The Go menu contains all commands for navigating the hierarchy of your DEVONnote database. Use these commands to go backwards and forwards through your documents, or to move back to the top level of the group hierarchy.

		Top Group, ... 

			Top/Enclosing Group/Selected Group: Goes back to the top level of the group hierarchy, to the group enclosing the shown group (if any), or to the selected group ("hoist"). These commands are only useful when you have opened a group in a second main window,  so that the "root" of the window is not the top group of database, or when you are using DEVONnote in outline mode.

			Back/Forward: Moves backwards and forwards through all documents/web pages you have visited by following cross-links or Wiki-style links.

			
		
		Instances, Highlights 

			Previous/Next Instance: Navigates backwards and forwards through all instances of a replicated document.  Use these commands to find out where the other instances of a replicated item are. Alternatively, you can use a smart group  to find all documents that have replicants.

			Previous/Next Highlight: Navigates backwards and forward through all highlighted passages within a document, regardless of whether these passages have been highlighted by a search or by manually using Format > Highlight.  Use these commands to visit all found text passages or highlighted passages in a document.

			Page: Navigates to the page with the entered page number.

		
		
	The Window menu

		As in any Cocoa application, the Window menu lists all open windows of the active application and gives you access to commands for managing them.

		Window commands 

			Close, Zoom, Minimize: These three commands resemble the red, yellow, and green buttons of any window title bar, and consequently close the window, minimize the window to the Dock, or maximize the window. No magic here. Hold the  key to change Minimize to Minimize all.

			Close, Select Next/Previous Tab: Closes the active tab or moves the focus to the next or previous tab. Note: Tabbed browsing  needs to be enabled for these commands to work.

			Keep Windows in Front: Keeps all DEVONnote main windows in front of all other windows. Useful for dragging contents from other applications to a DEVONnote note.

			Bring All to Front: Brings all windows of DEVONnote to the front. Hold the  key to change Bring All to Front to Arrange in Front.

			Window List: Selects any open window from the menu to bring it to the front.

		
		Info Panel 

			Show Info: Opens the Info panel  that shows basic information about selected items. As it is a panel, selecting a new item updates the Info panel accordingly.

		
		Document Properties 

			Show Properties: Opens the document properties panel.  View or edit the properties such as author, subject, or keywords in the frontmost document.

		
		
		Log Panel 

			Log: Opens the Log panel.  The log lists error messages and warnings that occurred while importing new documents. It also opens automatically when an error occurs. You can save the log to a text file or clear it.

		
		
		Take Note 

			Opens the Take Note  panel that lets you quickly write a plain text note and add it to the default destination. 

				
	The Services menu

		The DEVONnote > Services menu allows access to special commands published either by other applications, such as TextEdit or Safari, or by services extensions such as DEVONtechnologies' WordService or CalcService.  Also, DEVONnote publishes its own services in the Services menu.

		[Read more...] 

	The Help menu

		The Help menu contains commands for opening the integrated help pages, the support assistant, or visiting the DEVONtechnologies website.

		
		DEVONnote Help 

			These commands open the integrated help pages that are equal to the document you're reading or open the release notes.  

		
		Tutorials, Support Assistant 

			Support Assistant: Opens the support screen of the Welcome to DEVONnote  assistant where you can get support, retrieve your license code, request a trial extension, or update your details in DEVONtechnologies' customer database. You can also install additional scripts or templates from the assistant.

			Note: If you purchased DEVONnote from the Mac App Store, all options dealing with licenses or upgrades are not available.


			Tutorials: Opens the Tips and Tutorials screen of the Welcome to DEVONnote  assistant. The tutorials help get you started by explaining everyday DEVONnote tasks in step-by-step detail. This function requires an Internet connection.

		
		DEVONtechnologies 

			These commands take you directly to the corresponding pages on the DEVONtechnologies web site. Visit our home page or the lively user forum.  If you have a question or suggestion, send feedback directly to our development team.

		
	The Dock menu

		The Dock menu appears when you click DEVONnote's icon in the Dock with the ⌃ key pressed, when you right-click it, or when you left-click it and hold the mouse button for one second or longer.

		DEVONnote's dock icon also displays a badge with the number of new items, e.g., after adding new data via the Services menu.   Longer tasks--importing, indexing, running scripts--show a progress indicator on the dock icon, too.

		
		For all Mac OS X applications, the Dock menu provides a selection of the commands of the application menu. 

		
				<Window Name(s)>: Brings any open window of DEVONnote to the front.

				Remove from Dock: Removes DEVONnote from the Dock. Only available if DEVONnote was added permanently to the Dock and is not currectly open.

				Open at Login: Adds DEVONnote to your login items.

				Show In Finder: Reveals the DEVONnote application package in the Finder.

				Hide: Hides all windows of DEVONnote.

				Quit: Quits DEVONnote.

		

		Besides these standard commands, DEVONnote adds a number of its own commands to the Dock menu to make them easily accessible whenever the application is running.

		
				Import: Imports new documents from the file system, same as File > Import. 

			
				New With Clipboard >: Creates a new document based on the contents of the Clipboard, same as Data > New > With Clipboard.  Choose the destination database and group from the sub-menu.

				Take Note: Opens the Take Note panel. 

			
			
			
			
			
		

	Windows & panels

	DEVONnote uses a number of windows to present information. These windows are used for displaying and manipulating groups and documents, finding information, editing metadata, analyzing text, and changing the properties of your database.

	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
Main window

		
		Most of your time working with DEVONnote will be spent in a main window. Main windows give you access to your groups and documents, while also allowing you to view and edit files.

		Open a new main window with File > New Window.  DEVONnote also opens a new window when you open a database; you can set this option by checking Open New Window in Preferences, General tab. 

		The title of the window shows the name of document or group if one is selected, as well as its icon. Click-and-drag the icon to move it to another group or database or to the Finder to export it. Click the title bar with ⌘ pressed to reveal the document's location within the database; select an enclosing group to reveal it.

		Views 

			Different views present your information however you prefer:

			
				
				
				
					Split: Splits the window into an item list and a view/edit pane. To switch between a vertical and horizontal split, use View > Widescreen.  The item lists all groups and documents in the database, and may contain one or more columns. By default, it shows only item names. Expand/collapse groups by clicking the gray triangle.

					Three Panes: Resembles the way Apple Mail displays folders, items, and contents. The pane on the left displays all groups, the top right pane displays the documents contained in the selected group, and the view/edit pane at the lower right shows the contents of the selected document, and allows you to edit it if possible. Tip: When you click the Home button on the toolbar, you can see the files located in the root of your database.

					Tags: Shows all documents in a database for selected tags. Select a tag to show all items carrying this tag; select multiple tags (e.g. by selecting them with the ⌘ key held) to show documents carrying all selected tags. Select no tag to show all items. Delete tags by pressing the Delete or Backspace key; this moves ordinary tags to the trash and excludes group tags from tagging. New documents created in this view are either created in the group represending the tag or in the global inbox, and are tagged with the selected tag. [Read more...] 

			

			To adjust the size of the different panes, move the mouse to the divider between two panes until the mouse pointer changes into a line with two arrows. Then, click on and drag the divider to adjust the size of the panes.

		
		
		Items 

			DEVONnote displays groups and documents, much as the Finder does. Select items with a single click, and drag them from one group to another. You can also drag items to the Finder or other applications, or drag folders and files from the Finder to DEVONnote. You can also drag selected items or clippings such as text and images from any application to DEVONnote and vice versa.

			Press the ⌘ and ⌥ keys to link to the dragged item(s) instead of importing them to the database. For Bookends 11.3.1 or later this adds a formatted rich text instead of a simple reference.

			Single-click items to rename them. Double-click items to open them in a separate document window or in their native application (depending on the document type). For smart groups, double-clicking them in any view except Icons view opens the Smart Group Editor . Press the Space bar to preview the item using Quick Look; close the preview with the close gadget or press ⎋ or Space again to close it.

			Colored item names, colored group icons, and special icons tell you whether an item is a duplicate or replicant, its read/unread status or what type of search a smart group uses.

			
					Empty groups are shown in gray.

					Duplicates are shown with their name in blue; replicants are shown in red. [Read more...] 

					Icons of feeds  or other unread items show an "unread" indicator in the State column. [Read more...] 

					Smart groups using dates are shown with a clock icon; smart groups using the "unread" status are marked with a unique icon, too.

					Regular groups are shown in blue, while groups also used for tagging  are shown in yellow with a "tag" icon embossed.

			

			In addition, icons indicate whether a item is locked, has an attached comment or script, or has been indexed instead of imported. [Read more...] 

			To view or edit the contents of a document or group, do the following:

			
				
					Vertical/Horizontal Split/Columns View: Select the group or document. The view/edit pane shows the contents of the group or document. Click the triangle in front of a group to expand it, then select a document to view or edit.

					Three Panes View: Select a group or sub-group, then select the document you want to view or edit. DEVONnote shows the group or sub-groups content in the view/edit pane. Click the triangle in front of a group to expand it. When you select multiple groups or news feeds, the upper right pane shows all documents in all selected groups in one list, just like in Apple Mail. This does not work for smart groups.

			

		
		View/edit pane 

			The view/edit pane  shows the content of the selected document and, if possible, allows you to edit it.  You can edit plain and rich text.

			Read more here about the various document types  that you can view or edit in this pane.

		
		Info bar 

			Just below the toolbar you'll find the info bar. For selected items it shows an icon, the file name including location, and the kind, size, and modification date. If you're not sure of the document type, this is the place to look.

			Use the slider located on the right side of the info bar to adjust the size of icons.

		
		Toolbar & shortcuts 

			The toolbar of DEVONnote main windows carries many commands for manipulating the way the application displays information and handles selected items. Many of the toolbar items are simply shortcuts for menu commands. Here's a short list of the available tools:

			Please find a list of shortcuts in the appendix. [Read more...] 

			
					Navigation: Navigates to the top level of the database, or one level up. Useful when you have opened a second main window by double-clicking a group, and now want to move up the groups hierarchy in this window. 

				
					View: Switches between the possible views. See above.

					Actions: Provides commands for modifying the selected documents, similar to the Action menu in other views. Generally, the Action menu contains a selection of the commands also available via the contextual menu.

				
				
			

			
					Group +: Creates an empty group.

					Smart Group +: Creates a new smart group.

					Plain/Rich Text +: Creates a blank plain or rich text document.

					Link +: Creates a new link document.

				
			

			
			
					Mark Up: Highlights, underlines or strikes through selected text. This option is available for rich text documents, editable PDFs, and web archive.

					Highlight: Highlights the selected piece of text with the color selected in Preferences, Colors tab. 

			

			
					Open: Opens the selected documents in separate document windows. 

				
					Launch URL: Opens the Internet location stored in the URL field of the selected documents, e.g., a web site URL in Safari.

					Copy URL: Copies the Internet location stored in the URL field of the selected document to the clipboard.

					Delete: Moves the selected documents to the Trash.

					Save: Saves all changes to the currently edited document.

					Import, Export: Imports new documents; Exports the selected documents.

					Reveal: Reveals the location of the selected items in either the same main window, if possible, or by opening a new one.

					Show in Finder: Opens a new Finder window showing the selected items.

				
					Print: Prints the current or selected documents.

					Info: Opens the Info panel. 

			

			
					Group/Ungroup Items: Group creates a new group and moves all selected documents into it. Upgroup moves all documents contained in the selected groups one level up and then deletes the then-empty group.

				
					Find (search field): Lets you search your databases. Select your search options from the magnifier pop-up menu, enter your search term, and press Return. Click the search field's search button to return to the standard view. The pop-up menu also lists the last 25 used search terms. Check Prefix while typing to let DEVONnote begin to search as you type. The last word of the term is treated like a prefix ('word*'). Add more characters to refine and to speed up the search and press Enter or ⏎ to finish the search, or to search for whole words only. 

				
			

			
					Bigger, Smaller Font: Increases or decreases the font size.

					Subscript, Superscript: Makes selected text subscipt or superscript.

					Ruler: Shows or hides the ruler for rich text.

					Fonts: Shows the standard Mac OS X Font panel.

					Colors: Shows the standard Mac OS X Colors panel.

					Make Plain/Rich Text: Converts the current text document to plain or rich text.

					Highlighting: Highlights selected text. The pop-up menu lets you select the highlight color.

					Link: Makes selected text a Wiki-style link. If the text is a URL, the link points to that URL.

				
			

			
					Zoom: Zooms in, out, or to view width, or shows the document in 1:1.

					Full Screen: Shows the selected documents in full screen mode. Press ⌘F8 to return to windowed mode.

			

			
				
				
				
					(Capture) Note: Captures selected elements of a web page as a rich text document to either the current group or to the inbox.

					DEVONagent: Opens DEVONagent.  If the view/edit pane or frontmost window displays a web page, it opens the same URL in DEVONagent.

					Refresh: Refreshes the selected news feeds.

					Backup: Creates an internal backup of the database and then optimizes the database structure; same as  File > Backup & Optimize. 

					Verify: Verifies the database structure; same as  File > Verify & Repair. 

			

			
				
					Send by Email: Creates a new message in the default email application and adds the selected items as attachments. Supported email applications are Apple Mail, Microsoft Outlook,  PowerMail,  Mailsmith,  and Postbox.  If the selected item is an email message, the sender is automatically inserted as the recipient and the text of the original message is inserted instead of an attachment. Notes: Postbox is currently only able to send one selected file. Unsupported email clients (e.g. Thunderbird) can only send the plain text of one selected file.

				
					Take Note: Lets you take a quick note. 

			

			Note: Not all of these commands are always available. You can customize the toolbar by selecting View > Customize Toolbar  or by clicking with ⌃ pressed (right-click) the toolbar background and selecting Customize Toolbar from the contextual menu.


		
		Contextual menu 

			The contextual menu (which appears when you right-click or ⌃ click an item) offers a range of commands tailored to what you wish do with the clicked object.

			Most of the commands offered by the contextual menu have counterparts in a main menu, so you'll recognize them immediately. However, to save menu bar real estate, DEVONnote gives you access to some options only via the contextual menu.

			
					New Window: Opens a new main window.

					Open Database: Opens the selected database.

					Close Database: Closes the selected database.

					Delete Database: Closes the selected databases, and moves it to the Finder's trash.

					Empty Trash: Empties the trash can.

					Database Properties: Shows the Database Properties  of the selected database.

			

			
					Add to Favorites: Adds the selected item to the favorites.

					Remove from Favorites: Removes the selected item from the favorites.

			

			
					New Smart Group: Creates a new smart group in the sidebar.

					Edit: Opens the smart group editor  (only available for smart groups).

					Delete Smart Group: Removes the selected smart group from the sidebar.

			

			
					New: Creates a new document.

					Open: Opens a selected document(s) in a new window.

					Open in Tabs: Opens a selected document(s) in a new tab.

					Open With: Opens a selected document(s) with an external application.

					Launch URL: Opens the URLs indicated by the URL field of the selected documents.

					Copy URL: Copies the Internet location indicated by the URL field of the selected document to the clipboard.

					Copy Item Link: Copies a unique URL refering the selected item to the clipboard. Paste this URL into any third-party application to directly reference an item in your DEVONnote database.

					Show in Finder: Reveals the item's file in the Finder.

					Get Info: Opens the Info  panel for the items.

					Move Into Database: Imports the selected indexed item (and its children, if necessary) into the database. Only available for indexed items. Use this command to consolidate your database.

					Move To External Folder: Moves items added to an indexed group from the database to the connected folder in the filesystem. Only available for items in an indexed group.

					Refresh Feed(s): Manually refreshes the selected news feeds.

					Exclude from Tagging: Excludes the selected groups from tagging.

					Move To >: Moves the group or document to the group you select in the sub-menu. Note: Moving items to another database cannot be undone.

					Replicate To >: Creates a replicant of the group or document in the group you select in the sub-menu.

					Duplicate To >: Creates a duplicate of the group or document in the group you select in the sub-menu. Note: Copying items to another database cannot be undone.

					Label: Changes the label of the selected items.

					Mark: Marks the selected items as flagged/unflagged, read/unread, locked/unlocked and shows/hides the state of the items.

					Move to Trash: Moves the selected items to the trash.

					Move All Instances to Trash: Moves all instances (including replicants) of the selected items to the trash.

					Thumbnails: Creates, updates, or deletes the thumbnails for the selected items.

					Convert: Converts the selected items to other document formats.

					Group: Creates a new group containing the selected items.

					Auto Classify: Classifies the selected items and moves them to the group where they best fit.

				
					Send by Email: Creates a new message in the default email application, and adds the selected items as attachments. Supported email applications are Apple Mail, Microsoft Outlook,  PowerMail,  Mailsmith,  and Postbox.  If the selected item is an email message, the sender is automatically inserted as the recipient, and the text of the original message is inserted instead of an attachment. Notes: Postbox is currently only able to send one selected file. Unsupported email clients (e.g. Thunderbird) can only send the plain text of one selected file.

					Sort: Sorts the list of items to any available criterium. 

					Empty Trash: Empties the trash (only available for the trash).

			

			In the Tags view, the following commands are available:

			
					Save Search: Available in the right pane of the Tags view, this command creates a smart group from one or multiple selected tags. Use it to select some tags and to save the search as a smart group for convenient access.

			

			
			
			Note: For your convenience, DEVONnote also makes the Services menu,  available via the contextual menu.


		
	Document window

		A document window is similar to the view/edit pane of a main window. You open a document window by double-clicking a document in any view of a main window or by choosing Data > Open (or any of its equivalents in contextual menus).

		
		Depending on the type of information the document contains, the toolbar of a document window offers different sets of tools. Most of them are identical to their counterparts in the DEVONnote main window toolbar.

		See the Documents  chapter for a detailed description of the various document types.

	Info panel

		The Info panel, just like its counterpart in the Finder, displays additional information about a selected document or group, from icon and name to comments and other metadata.

		
		Open the Info panel using the i icon from the window toolbar or by selecting Window > Show Info"  The contents of the Info panel corresponds to the currently selected object, so you can leave it open all the time and it will always display the correct information for the selected document or group.

		Head elements 

			Icon and Name: Just like in the Finder, the top part of the panel displays the icon and the name of the selected object.  To change the name of the document, use the Name field below.

			Locked: The Locked checkbox indicates if the object is write-protected. Check the checkbox to protect the document or group from being accidently modified. Locked documents or groups are marked with a padlock.

		
		Main attributes 

			Name: Use this field to change the name of the object.

			Aliases: Enter one or more words here, separated by semicolons, as alternative targets for Wiki-style links. Generally, Wiki links refer to the name of contents, and aliases make this system even more flexible.

			Path: This field contains the path to the file holding the document's data. It is non-editable. You can click the @ button to open the references file using the Finder. In general this is equal to using Data > Open With  and choosing the default application.

			URL: Smiliar to the Path field, the URL field is used to link the document to an Internet address or anything else that can be reached by a URL. This field is used primarily by bookmarks, but you can also use it to connect a document to a web page. To visit the web page click the @ button next to this field or select the document and use the contextual menu command Launch URL.

		
		
		Information elements 

			Size: Shows the size of the item. For groups and news feeds, this field shows the size of all contained items.

			Kind: Shows the selected document type (for example text, RTF, etc.)

			Added: Shows the date when the object was actually added to the database.

			Created, Modified: Shows the (editable) dates when the object was created and when it was modified the last time.

		
		Additional information 

			This section lists metadata that has been stored together with the item. Information shown depends on the file type as well as the individual document.

		
		Additional elements 

			Exclude from ...: These checkboxes allow you to exclude this item from being used in classification, see also, search, or tagging. Use this option to exclude such things as temporary groups from classification to increase the accuracy of the built-in artificial intelligence.

			Label: Shows the label assigned to this item and lets you change it.

			Tags: Shows the tags assigned to this item. You can also edit tags here. [Read more...] 

			Location: Shows the location of this item inside the database.

			Instances: Shows how many replicants of this document or group exist in the database and how many duplicates DEVONnote has identified. Click to show a pop-up menu listing all instances and duplicates and their enclosing groups. Select any item to reveal it.

			Spotlight Comments: Stores other information you want to attach to your document or group (similar to the Spotlight comments field in the Finder). Of course, the Comments field is searchable. DEVONnote synchronizes the Spotlight comments in the Finder with this field in the database. If this application was purchased in the App Store, only importing Spotlight comments is possible.

			Note: You can modify the comments of multiple selected items simultaneously, as long as the comment of all selected items is either identical or empty.


		
	Document Properties

		The Document Properties panel gives you access to all metadata stored for a selected document. This metadata includes, but is not limited to:

		
				Author

				Company

				Copyright

				Title

				Subject

				Keywords

				Comments

		

		
		Depending on the document type, you can edit or view these properties. More fields may be available depending on the document type.

	Take Note

		The Take Note panel, opened by hitting a hot key, from the toolbar, or from the Window menu,  allows you to quickly enter a note, choose the destination, and add tags and a URL to the note. If DEVONnote can get the URL of the frontmost application, e.g., from Safari, it will also insert that information automatically into the URL field.

		
		Check Rich Text to take a rich text note. Use the Format  menu to style your note.

		Change the hot key for opening the Take Note panel in the preferences. 

		Note: For this function DEVONnote needs to be running. This may change eventually.


	Log

		The Log panel displays warnings and error messages that occur, when importing files and folders and performing other actions. The panel shows the date of the message, the affected file, and a short information about what happened.

		
		You can save the list to a text file with the Save button, and clear the log with the Clear button. To sort the log, click the column title. (Click again to reverse the sorting order.) Use the contextual menu or double-click the entry to reveal an affected file in the Finder.

		Uncheck Show log automatically to prevent the log popping up automatically. You can open the Log panel at any time using Window > Log. 

		Right-click or click with ⌃ held to perform additional commands on log entries via the contextual menu, e.g., to reveal a logged item. Copy information from the log to the clipboard with Edit > Copy,  ⌘C, or the contextual menu.

	Preferences

		The Preferences window, opened using DEVONnote > Preferences,  contains all  available options, which you can modify to adapt DEVONnote to your personal needs.

		Because the preferences are so important, we have created a separate chapter  for them.

	Database Properties

		The Database Properties panel defines preferences which are directly related to the database and not to the application in general. Open the properties panel using File > Database Properties  for every open database including the global inbox.

		
		Location 

			This section of the properties panel shows the location of the database package and any additional options:

			Location: Double-click any part of the database location to reveal it in the Finder.

			
			Create Spotlight Index: Check to make this database available to Spotlight. Checking this option lets DEVONnote create a folder in "~/Library/Cache/Metadata" that Spotlight uses for accessing the documents in the database. If you ever feel that this folder is out-of-sync with the database, click Rebuild to recreate this folder from scratch.

			When viewing Spotlight results in a window, make sure to have the Show all file extensions option in Finder's Preferences, Advanced tab unchecked. If this option is checked, the Finder displays the generic names of the metadata cache files instead of the name of the referenced document.

			Starting with version 2.0.6, DEVONnote adds information to the Spotlight metadata that makes it possible to preview many file types directly from the Spotlight results window. Supported are text and rich text (RTF and RTFD) files. DEVONnote needs to be installed on the machine viewing the Spotlight results. You may need to rebuild the Spotlight index to activate this function.

			Note: Rebuilding the Spotlight index can become necessary after copying a database from one computer to another.


			
			
			Exclude Groups from Tagging: Excludes all groups in this database from being used as tags. Ordinary tags can always be added to items using the Tag bar.

		
		Statistics 

			This section displays some basic statistics about how many documents your database contains, file sizes, etc.

		
		Name and comments 

			Name: Enter a name for your database here. It will appear in the title bar of every main window  of this database.

			Note: This does not change the file name for the database package. You cannot change the name of or add commments to the database representing the global inbox.


			Comments: Enter your own comments about the database here, e.g., a project description.

		
		Protection 

			To prevent other people from opening DEVONnote and accessing your data, click on the padlock button to unlock the entry fields, enter a user name and password, and then click on the padlock button again to lock your changes and hide the password.

			Note: This is a simple password protection. DEVONnote does not yet provide file encryption for enhanced security. For better protection, create an encrypted disk image using Disk Utility and store your database on that encrypted volume or disk.


		
	Assistant

		The integrated Assistant combines a welcome screen with  tips, web and video tutorials, installable extras, and a suppport page that guides you through the available support options. Click here to open the Support Assistant. [special link, not enabled in ebook] 

		[image: ]

		Welcome 

			This screen welcomes you when you start DEVONnote for the very first time. It offers:

			
					An introductory screencast

					The option to subscribe the free DEVONtechnologies newsletter, as well as a number of welcome tips

					The tip of the day

					The extra of the day

			

			You can access all other screens of the assistant from here, too.

		
		
		Get support 

			The support screen guides you through the three common steps for troubleshooting DEVONnote. In addition, you can have your license code resent in case you don't have it anymore, request a trial extension, update your details in DEVONtechnologies' customer database, or buy an upgrade or a second license.

		
		Tips and tutorials 

			Here you can find the latest tips and tutorials to help you squeeze the best out of DEVONnote. Tutorials can be slideshows describing basic tasks in DEVONnote or screencasts.

			Both tips and tutorials are updated live from DEVONtechnologies' server so it's a good idea to check back on a regular basis. The latest tip or tutorial is also always mentioned on the welcome screen.

		
		Install extras 

			On the extras screen, DEVONnote lists all available extras that you can download and install from DEVONtechnologies' server:

			
					Scripts

					Templates

					Plugins

			

			
			Browse the list of extras and install them with the Install button. The last line of the description shows where in the  Templates  menu the extra will show up after installation. Remove installed extras with the Remove button.

			The extras are updated live from DEVONtechnologies' server so it's a good idea to check back from time to time. The latest extra is also always mentioned on the welcome screen.

			Note: If one of these categories does not show up in your copy of DEVONnote, there might be no extras of this type  (yet) available for DEVONnote.


		
	Documents


	All documents are displayed in DEVONnote in views. Each view features its own tools, contextual menu commands, and hidden keyboard shortcuts. In this chapter, we will look at many of those features.


	
	
	
	
	
	
	

General

		
		All documents are displayed in DEVONnote in views (not to be confused with the different layouts in main windows, also called views.  Each view has its own tools, contextual menu commands and keyboard shortcuts.

		Currently, DEVONnote features the following view types:

		
				Plain and RichText 

				Office and other documents 

				HTML pages, Web pages, Feeds 

			
			
			
		

		Navigation bar 

			At the top of the view/edit pane DEVONnote shows a navigation bar that gives you access to some additional tools that deal directly with the contents of the document. Which tools are available depends on the type of the document.

			
					[image: ] Navigates back to the last visited document after following a link.

					[image: ] Navigates back to the next visited document after going back.

					[image: ] Reloads the displayed page in a web view.

					[image: ] Shows the system-wide sharing menu. OS X 10.8 Mountain Lion or later only.

					[image: ] Locks or unlocks the item.

					[image: ] Scrolls to the previous highlight, e.g., a search term occurrence.

					[image: ] Scrolls to the next highlight, e.g., a search term occurrence.

					[image: ] Scrolls to the next page of the displayed document.

					[image: ] Scrolls to the previous page of the displayed document.

					[image: ] Switches to text-only mode.

					[image: ] Switches from text-only mode back to the (standard) preview mode.

				
				
				
					[image: ] Opens the See also & Classify drawer. 

					[image: ] Shows a list of the most important words of the document.

					[image: ] Switches the tag bar  on and off.

			

			The text-only mode can be useful for selecting text in items that are displayed using Quick Look  or to view or edit the source code of an HTML document. In preview mode DEVONnote uses Quick Look to show Pages documents and other filetypes in their original layout. Select any word from the [image: ] menu to show documents  also dealing with this keyword.

			
					URL: Shows the URL associated with the displayed item. Click to launch the URL in its default application. Hold the ⌥ or the ⌘ key to open the URL in a new tab. Holding Shift-Option or Shift-Command opens the URL in a new tab and selects it.

					Word Count: Shows the number of paragraphs, words, and characters of the displayed text.

					Page Count: Shows the number of pages as well as the page number of the currently displayed page. Click the page number in PDF or PostScript documents and enter a page number to jump directly to that page.

			

		
		Tag bar 

			The Tag bar, which can be shown or hidden,  shows all tags associated with the document. Click the tag bar and type to add tags; select a tag and press the Delete or Backspace key to remove it. [Read more...] 

			When you type the name of a tag, DEVONnote offers automatic completion. Choose the right option with the mouse or the arrow keys and press ⏎ or Enter to accept it. Press ⎋ to use whatever you entered. Auto-completion prefers ordinary tags (tags represented in the Tags group) over groups used as tags, and also matches sub-strings. Press ⇥ to enter another tag.

			Note: The Tag bar is also visible for multiple selected documents when all the documents have the same tags attached. Use it to change the tags on multiple documents.


		
		Toolbar & shortcuts 

			
			Please find a list of shortcuts in the appendix. [Read more...] 

		
	Plain and rich texts

		The view for plain and rich text documents is basically a built-in incarnation of TextEdit, and you use it in a very similar fashion. Of course, text views support the Edit > Find >  commands and all options of the Format  menu.

		
		The ruler 

			For rich text documents, DEVONnote supports the standard ruler that the TextEdit engine of Mac OS X provides. Show or hide it with 
			Format > Ruler > Show/Hide Ruler. 

			The ruler contains the following elements:

			
					Tab Stops: Place tab stops with the mouse, then remove them by dragging them off the ruler. Drag new tab stops (left aligned, centered, right aligned, or decimal aligned) from the repository at the right side to their desired positions on the ruler. Use the mouse to adjust the left and right margins and indent.

					Styles: Select a predefined text style from the pop-up menu. To define your own styles, choose Other to open the Mac OS X standard style editor. In the style editor, navigate back and forth through the styles of your document or the stored favorite styles. (Use the radio buttons to switch between document and favorite styles.) Click Select to select all occurences of text with the displayed style in the document, click Apply to apply the style to selected text, or click Done to leave the style editor. To add a style from your document to  Favorites, click Add To Favorites; to remove a favorite, click Remove From Favorites.

					Alignment: Align the current paragraph (the one with the insertion caret inside) left, centered, justified, or right by clicking the according alignment buttons in the ruler.

					Spacing: Choose the desired spacing for the current paragraph from the Spacing pop-up menu. Choose Other to enter  values other than the ones shown.

					Lists: Make the current paragraph a list (indented and with a bullet or numbered) by choosing the desired list style from the Lists pop-up menu. Choose Other to define your own list style.

			

			Note: The built-in "mini outliner" is an nice feature. On any blank line in a rich text document (doesn't work for plain texts), type ⌥⇥ to create a bullet point (Mac OS X shows dashes instead of bullets). Press ⏎ for the next item, and so on. Additional ⌥⇥ will increase the indentation; a ⏎ on a blank list line will decrease it. The mini outliner uses hyphens to indicate list items by default. Right-click to choose all kinds of list styles.


		
		Attachments 

			You can attach other documents to rich text documents simply by dragging them into the text. Technically the rich text document becomes a .rtfd package and the dragged file is saved as part of the package.

			
					Use the contextual menu  to show an attachment's content in a Quick Look preview.

					Double-click attachments to edit them externally.

			

			Note: Editing attachments requires OS X 10.7 Lion or higher. Also, you cannot attach files to plain text documents. You need to convert them to rich text  before you can attach other files.


		
		
		Contextual menu 

			
					Search with Spotlight: Searches for the selected text using Spotlight.

					Search in Google: Opens your default browser and searches for the selected text in Google.

					Quick Look Attachment: Opens a Quick Look panel for the selected attached link or file (OS X 10.7 Lion or higher).

					Copy Link: Copies a link to the Clipboard (only available for selected links).

					Edit Link: Edits the destination of a selected link.

					Highlight >: Highlights the selected piece of text with the color you select in the sub-menu.

					Insert >: Inserts special elements into the text (such as a page break, the current date or a bullet). Same as the Insert sub-menu of the Edit menu. 

					Insert Link To >: Inserts a link to an item you select in the sub-menu (only available when no text is selected).

					Look Up in Dictionary: Looks the selected text up in Mac OS X's Dictionary.

					Link To >: Makes the selected piece of text a cross-link and links it directly to the group or document you select in the sub-menu.

					Make Link: Makes the selected piece of text a WikiLink. The destination of the WikiLink is a document with the same name as the selected text. If no document with that name exists, clicking the created link creates it using the template you have set in the Editing Preferences. 

					Open Link: Opens the selected link in the default browser or application (only available for a selected link).

					Open Link in New Tab: Opens the selected link in a new tab.

					Open Alias: Follows a selected link (only available for a selected Wiki-style link resolved by an alias). Aliases are defined for each item separately in the Info panel. 

					Remove Link: Makes a selected link simple text.

					Search selected phrase: Searches for the selected text as a phrase.

					Set Title As: Renames the document according to the selected piece of text (needs to be less than 256 characters).

					Split Document: Splits the document at the current insertion mark position.

					Add tag [word]: Tags the document with the selected word (only available if the word is not already a tag of the document).

					See [word]: Opens a drawer with documents related to the selected word.

					See Related Text: Opens a drawer with documents related to the selected text passage (only available when more than one word is selected).

			

		
	HTML pages, web pages, feeds

		
		HTML views display web pages stored in the database or downloaded "live" from the Internet by using the Safari web browser engine of Mac OS X.  Pages are rendered similar to Safari or any other WebKit-based browser such as DEVONagent Pro. 

		
		DEVONnote does not display news feeds. You can find news feeds support in DEVONthink Pro  and higher.

		HTML views support the Edit > Find >  commands as well as the See Also & Classify drawer.  To edit the source code of an HTML document, use the navgiation bar  to switch from preview to plain text mode.

		In editable web archives you can use, e.g., the highlighting commands from the Format menu  or add the Color tool to the toolbar  to change text colors.

		Toolbar & shortcuts 

			Separate HTML or web browser windows feature a default toolbar set that is more web-like than text document windows. As with text document windows, this toolbar can be  configured individually. Naturally, the DEVONnote offers only tools for HTML views that are useful in a web environment.

			Please find a list of shortcuts in the appendix.. [Read more...] 

		
		Contextual menu 

			
					Reload: Reloads the page from the Internet.

					Open ... in New Tab: Opens selected element in a new tab.

					Open Link in Browser: Opens a link in your default web browser.

					Open Link in DEVONagent: Opens a link in DEVONagent Pro. 

					Open Link in PhotoStickies: Opens a link in PhotoStickies. 

					Capture Link: Adds the selected link to either the current group or to the inbox.

					Capture Page: Adds the current page as HTML document to either the current group or to the inbox.

					Capture Web Archive: Adds the current page as web archive to either the current group or to the inbox.

					Capture Note: Adds the selected text as a new note to either the current group or to the inbox.

					Capture PDF: Adds the current page as a PDF to either the current group or to the inbox.

					Capture Frame Address: Adds the URL of the current frame to either the current group or to the inbox.

					Capture Page Address: Adds the URL of the current page to either the current group or to the inbox.

				
					Copy Frame Address: Copies the frame URL to the Clipboard.

					Copy Image: Copies the image to the Clipboard.

					Copy Image Address: Copies the URL of an image to the Clipboard.

					Copy Page Address: Copies the page URL to the Clipboard.

					Open Image in PhotoStickies: Opens the image in PhotoStickies. 

					Copy: Copies selected text to the Clipboard.

					Highlight: Highlights the selection in a web archive. Using this command on a selection again removes the highlighting.

					Set Title As: Sets the name of the document to the selected piece of text (needs to be less than 256 characters).

					Search Selected Phrase: Searches for the selected text as a phrase.

					Add tag [word]: Tags the document with the selected word (only available if the word is not already a tag of the document).

					See [word]: Opens a drawer with documents related to the selected word.

					See Related Text: Opens a drawer with documents related to the selected text passage (only available when more than one word is selected).

					Update Bookmark: Updates the URL of this document to the current one, e.g., after navigating to a sub-page.

					Back / Forward: Navigates back and forth to previously visited pages.

			

			
				
				
				
				
					Capture Link: Captures the link and saves it to either the current group or to the inbox.

					Capture Note: Captures selected text to either the current group or to the inbox.

				
				
				
			

			For PDF pages, more options become available:

			
					Open with Preview: Opens the PDF in Preview.

					Automatically Resize: When checked, the zoom factor adjusts to the width resp. height of the browser window.

					Zoom Out, Zoom In, Actual Size: Zooms in or out of the document, or displays it in its actual size.

					Single Page, ...: Displays the PDF as single or double pages and either page-by-page (use the Next Page and Previous Page to skim through the pages forward and backwards) or continously.

					Next Page, Previous Page: Skims through the pages forward or backward.

			

		
	Office documents, email, and others

		Documents that DEVONnote cannot render natively are displayed using QuickLook. But while you have to press the Space bar in the Finder to open a QuickLook head-up display, DEVONnote previews these documents directly in the view/edit pane like any other document format.

		
		Among others, the following document types are shown though QuickLook:

		
				iWork  documents (Pages, Numbers, Keynote)

				Microsoft Office  and OpenOffice  documents

			
				Mellel  files (version 2.6 and higher)

				...

		

		For some document formats the preview allows you to select and copy text, for other formats it doesn't. If DEVONnote is able to interpret and convert the document format, you can use the Text View/Preview button in the navigation bar  to switch to a text view that allows you to select, copy, and drag text.

		Note: The availability and quality of the preview, as well as the possibility to select and copy text, depends solely on the source application. Developers can embed a QuickLook-compatible preview diectly into the files, or write a preview plugin and add it to either the source application, or have you install it separately in ~/Library/QuickLook. If a document that you want to view in DEVONnote does not show a QuickLook preview, please contact the maker of the source application and ask them to add QuickLook support.


		Toolbar 

			For document previews based on QuickLook, DEVONnote offers a number of toolbar items, e.g., for  moving back and forth through the other documents contained in the same group or opening the document in its source application. 

			Use Data > Open  to open the document in a separate document window  instead of in its source application.

		
	Drawers & sheets


	DEVONnote uses drawers to display the results of the Classify and See Also functions that help you file items and find relationships between items in the database.  The Smart Group Editor, which appears in a sheet, allows you to create or modify a smart group (a.k.a. "saved search").

	
	
	
	

See Also & Classify

		The See Also & Classify drawer appears when you select one (1)  document in a main window  and then click the AI button (a small sorcerer's hat) in the navigation bar  at the top of the view/edit pane. This button is only available in views that have a view/edit pane.

		
		It is also shown when you use the contextual menu on selected text to show similar documents, e.g., See [word]' or See related text, or when you select a topic from the topics pop-up menu in the document's navigation bar. 
	
		To close the drawer, click the red close button.

		When activated, DEVONnote analyzes the contents of the selected document and compares it to all data stored in the database. From this "knowledge,"  DEVONnote gives you one or both of the following lists.

		Classify 

			The Classify function helps you file documents by making suggestions based on where you have filed other documents. The Classify list shows which groups the selected document would fit into best. It also lists the location of the group and a graphical score that shows how sure DEVONnote is about the suggested placement. The tooltip for any entry in the list shows the full title and location for it. This part is only visible when the sorcerer's hat button is used.

			To move the document to one of the suggested groups, select the group and click Move To. Alternatively double-click the group. For your convenience, DEVONnote preselects a single group, or multiple groups if it is unsure. Drag the file into any item list to move it, e.g., into a main window. Use the ⇧ and ⌘ keys to select more than one target. This generates replicants. 

			Note: Any replicants of the document being moved are deleted. The document is only placed in the new locations, which allows you to precisely classify the document again without having to manually clean up old replicants.


		
		See Also 

			See Also lists similar documents; thus, it helps you find information likely dealing with the same subject. The see-also list shows documents and/or selected text or topics within documents that are similar to the selected one (when you have used the contextual menu items or the document's topics pop-up menu). Like the classify list,  this list shows the path to the document and a graphical score of how sure DEVONnote is about its decision. The tooltip for any entry in the list shows the full title and location for it.

			To display a document in the drawer, select it. For your convenience, DEVONnote always lists the original document at the top of the list. This way you can easily go back to the original document. Double-click a document in the drawer to open it in a separate window;  drag it into an item list to move it.

		
		Contextual menu 

			Use the contextual menu on groups in the See Also & Classify drawer for more commands.

			
					Open: Opens the selected item in a separate main window. 

					Open in Tabs: Opens the selected item in a new tab.

					Open With: Opens the selected item in an external application.

					Launch URL: Opens the URL in the selected item's URL field.

					Copy URL: Copies the Internet location stored in the URL field of the selected item to the clipboard.

					Reveal: Shows and selects the selected item.

					Show in Finder: Shows the selected item in the Finder.

					Move To: Moves the selected item to the group you select from the sub-menu.

					Replicate To: Replicates the selected item to the group you select from the sub-menu.

					Duplicate To: Duplicates the selected item to the group you select from the sub-menu.

					Label: Changes the label of the selected item.

					Mark: Changes the check, lock, and read status of the selected item.

					Move All Instances To Trash: Moves all instances of the selected item to the trash, including all replicants (if any).

					Group: Creates a new group containing the selected item(s).

				
			

		
	Smart group editor

		The Smart Group Editor appears as a sheet when you either create a new smart group using Data > New > Smart Group,  when you right-click a smart group and choose Edit from the contextual menu, or when you double-click a smart group.

		
		In this sheet you set up a new smart group or edit an existing one:

		
				Search in: Select where you want this smart group to search.

				List of search predicates: Build your list of search criteria (in search speak: "predicates") here. See below.

				Ignore Diacritics: Check this to treat letters with diacritics, e.g., umlauts or accented characters, the same as their regular counterparts.

				Fuzzy: Check this to search "unsharp" terms, e.g., ignoring simple typos so that instances of "Merkel" and "Merkle" are both found.

		

		The list of predicates consists of a list of blocks, each beginning with "All" or "Any", defining whether all (Boolean AND) or any (Boolean OR) of the contained predicates need to be true for the document to be returned as a result. Predicates themselves consist of the field to search (like "Content" or "Tag"), and the condition and the data that needs to be matched.

		Note: In most predicates you can use wildcards, Boolean operators, phrases, and parenthesis, too.[Read more...] 


		Use the + and - buttons to add more predicates to your smart group or to delete them. Hold the ⌥ modifier key and click a ... button to create a "compound predicate," also called "branch". Predicates can be in/outdented and rearranged via drag-and-drop.

		By adding more lines to a search and choosing between "All" and "Any" you graphically create a nested Boolean query with ANDs, ORs, and parenthesis.

		Predefined smart groups 

			When you create a new database, DEVONnote adds a number of predefined smart groups for your convenience:

			
					Duplicates: Lists all duplicates.

					All Images: Shows all images.

					All PDF Documents: Shows all PDF documents.

					To Do: Shows all documents with visible but unchecked state.

			

			
			
			Note: Smart groups also filtering for date ranges are shown with a clock icon.


		
	Preferences


	The Preferences window, which you open by selecting Preferences in the application menu,  is the place to go to change global settings for DEVONnote. In addition to global settings, databases also have separate settings in their Database Properties  window that you open using File > Database Properties. 


	
	
	
	
	
	
	
	
	
	
	
	
	
	
	

General

		
		Use the General tab to set the general settings for the user interface.

		Appearance 

			These options define some parts of the visual appearance.

			
					Alternating row colors in views: Check to color every second row in item lists differently.

					Display number of items inside groups: Check to show the number of unread and read documents contained in a group. Number will appear in parenthesis after group names. If this option is unchecked, news feed still show the number of unread items.

					Highlight Internet links in views: Check to show link documents marked in blue and underlined in item lists.

					Mark duplicates and replicants in color: Check to highlight duplicates marked in blue and replicants marked in red in most views. When unchecked duplicates and replicants are marked with file property icons.

					Colorize icons with label: Check to colorize the icon or thumbnail of items with the label color (like in Mac OS 9). When unchecked, labels are displayed in the Finder's style.

			

		
		Interface 

			These options define some parts of how you interact with the user interface.

			
				
				
					Always open groups in a new window: When checked, double-click a group to open it in a separate window.  When unchecked, double-click the group to make it the new root of the current window. Use Go > Top Group and Go > Enclosing Group  to go up the groups hierarchy again.

					Retain view: When the above option, Always open groups in a new window, is unchecked, the actual view settings are maintained when you navigate the group structure instead of the group's individual settings being applied.

					Enable tabbed browsing: When checked, click with ⌘ pressed a link in web, PDF or text views to open it in a new tab. When unchecked or the ⌘ modifier key isn't pressed, documents are opened in the same view, in the default application or in new windows.

			

		
		Startup 

			Choose whether you would like DEVONnote to open a fresh main window  on startup, re-open all windows active when you quit DEVONnote the last time, or do nothing. 

			Note: Even when you tell DEVONnote to not open a window on startup, it will always open at least one window when you open a database. When DEVONnote crashed or was quit by force no windows are restored; this prevents the same crash happening again.


		
		Fonts 

			
			Use List Views Font to set the font DEVONnote uses for displaying item lists in list.

		
		
	Editing

		
		The Editing tab defines all options that fine tune DEVONnote's text editing behavior, from the ruler units to WikiLink templates to summarization options.

		General 

			
					Display PDF attachments of rich texts: Show the content of PDFs attached to RTF documents.

					Check spelling while typing: Spell check everything you write all the time.

					Check grammar with spelling: Check the grammar when checking the spelling.

					Correct spelling automatically: Correct misspelled words automatically.

					Smart quotes: Use curly quotes instead of simple English ones.

					Smart copy/paste: Insert or remove spaces before and after cut or pasted text.

					Smart links: Detect web addresses and turn them into clickable links automatically.

					Smart dashes: Convert characters, e.g., two hyphens into a proper dash.

					Data detectors: Detect dates, times or addresses in text, and show possible actions when the mouse cursor moves over them (Mac OS X 10.6 or later).

					Text replacement: Use the system-wide text replacements when editing text (Mac OS X 10.6 or later).

			

		
		Ruler Units and Fonts 

			
					Ruler Units: Select your personal preference for ruler units such as centimeters or inches, points or picas.

					Plain/Rich Text Font: Select your preferred fonts for new plain or rich text documents. Note: By their nature, plain text documents are always displayed in the font selected, whereas rich text documents can be styled any way the author wants.

			

		
		Full Screen 

			
					Full Screen: Select your preferred font for reading and editing plain text files in full screen mode. By their nature, rich text documents are always displayed using their own styles also in full screen mode.

					Background: Choose a background color for the full screen mode. This setting only affects the background of plain text files and the border to the left and right of rich text documents. By their nature, rich text documents bring their own background color and so don't use the color you set here.

					Width: Choose a width for displaying documents in full screen mode as a percentage of the screen width. Use this setting if the presentation in full screen mode appears too wide on a large screen.

			

		
		WikiLinks 

			
					WikiLinks: Check Automatic if you want to make every word that is also the name of another document or group in the database automatically link to the document of the same name (WikiLink). This mechanism can be restricted to not link to groups, as well as to only accept meshed words. (For example, words with a capital letter in the middle like "QuickTime"; this is the classic WikiLink method to distinguish between regular words and links.) Check Open new documents in separate windows to open a new window when you click a WikiLink, instead of switching to the linked document.

					Template: Enter a template text here. This will be used to create a new document when you make text a link that does not point to an existing document yet. You can use various placeholders  to automatically insert text--the current date and time, for example.

			

		
		
	Import

		
		Here you decide which file types DEVONnote imports and how those files will be named in the database.

		Files 

			These options define whether DEVONnote imports files of a given type when you import folders using File > Import  or via drag-and-drop.

			
					<type>: Select all the file types you want DEVONnote to recognize when importing  folders. DEVONnote always imports every file you import manually.
 
					Encoding: Choose the default encoding for plain text documents. Select Automatic to let DEVONnote choose the best encoding.

				
			

		
		Titles 

			Select how you want DEVONnote to name imported documents: with file name extensions, without file name extensions, or by using localized display names (for example, on a German system the "Applications" folder would appear as "Programme").

		
		New notes 

			Check Select (and display) automatically to automatically select and display the last note you have taken.

		
		Destination 

			Choose the default destination  from which data is coming DEVONagent Pro,  news feeds,  and services  is stored:

			
					Select group: A group selector is shown that lets you choose the destination. The group selector appears as a black panel floating on top of all other windows. It does not bring DEVONnote to the front. Use it to select the group where you want to file the items and add tags. 

					Global inbox: The data is stored in the global inbox.

				
			
				
		
	Take Note

		
		The Take Note preference allows you to assign a hotkey for opening the Take Note panel. 

		To change the hotkey, click the Click to record shortcut button, then press the hotkey that you want to use. Press the ⎋ key to cancel recording a new shortcut.

	Colors

		
		Here you can name and choose the seven label colors DEVONnote uses to mark documents and groups, as well as set seven colors you can use to highlight text.

	Web

		
		The web preferences resembles the settings of most web browsers. Use these preferences to define how DEVONnote's displays web documents  and "live" web pages.

		Web Content 

			These settings define how DEVONnote treats special web contents:

			
					Enable ...: Check these options to use installed third-party plug-ins, (such as Flash or RealPlayer plug-ins), and to run Java applets or JavaScript scripts contained in, or linked to, a web page.

					Block ...: Check Block pop-up windows to block pop-up windows, which are often advertisements; check Only automatic JavaScript windows to block only pop-up windows opened by JavaScript. Uncheck this option if the web page you're visiting uses pop-up windows for actual content. (Some web content management systems do this.) Check Block zooming to keep web sites from automatically zooming windows to full size. Check Block advertisement to block common inline advertisements provided by some search engines.

					Zoom text only: Check to zoom only the text and uncheck to use Safari 4-style zooming.

			

		
		Images 

			These settings define how DEVONnote displays graphics in web pages:

			
					Display images when the page opens: Check this option to diplay web pages with images. Just remember, if unchecked, you may miss some information.

					Animate images, Loop animation: Check these options to run web graphics animations and to run animated graphics in a loop.

			

		
		Accept Cookies 

			Cookies are little text files with information that web pages store on your computer use to recognize you as a returning customer, among other things. While most cookies are harmless, you may want to control what is being stored on your hard disk.

			
					Always: Accept all cookies.

					Never: Don't accept any cookies.

					Only from sites you navigate to: Accept cookies, but only from web sites you navigate to (not from other sites, such as ad trackers).

					Delete cookies on quit: Delete all stored cookies when you quit DEVONnote.

			

		
		Fonts 

			Set the fonts you want to use for displaying web pages; set separately for variable-width and fixed-width text.

		
		Style Sheet 

			You can further control the way DEVONnote displays web pages by applying a CSS style sheet that changes the rendering on the fly.

			Click Select and choose your style sheet to apply it to DEVONnote's integrated web browser. Note: This is for experts since it modifies how all web pages are displayed and can lead to undesired effects.

		
		Text Encoding 

			Select your desired text encoding for displaying web pages. Automatic tries to choose the best available encoding. If this does not work for you, choose a more appropriate text encoding for your language group.

		
	Backup

		
		DEVONnote comes with a simple backup function that backs up the database index on a regular bases. These options define how often DEVONnote will back up indexes.

		The backup automatically duplicates all important database files and moves the duplicates into a folder(s) named "Backup(.x)" within the DEVONnote database folder/package. Select how often you want to have the backup created--never, daily, weekly, or monthly--and how many copies of the index your want DEVONnote to keep. Of course, you can create a backup at any time using Data > Tools > Backup & Optimize.  

		These options do NOT backup the whole database to a secure location; they simply make sure there's a copy of the index files in case the index get corrupted. To back up your complete database, use Time Machine or a third-party backup software.

		
	Update

		
		Change the settings in this tab to define when you want DEVONnote to check for new versions: never, on startup, daily, weekly, or monthly. DEVONnote only performs checks for updates when the computer is connected to the Internet.

		Click Check Now to immediately check for a new version.

		Note: Disable the check for new versions when your network connection is unstable and you experience long delays when opening DEVONnote. The Update pane is not available if you have purchased DEVONnote from the Mac App Store.


	Troubleshooting


	DEVONnote was created with robustness in mind. But any computer hardware or software, regardless of how carefully developed and built, can write defective data or destroy files. If you experience problems with a database, please refer to the methods below and also look at our FAQ. 


	
	
	
	
	
	
	
	
	
	
	
	
Problems synchronizing with DEVONthink To Go 1.x

		If you cannot properly synchronize your database with DEVONthink To Go 1.x on your device, please check the following:

		
				Are both the iOS device and the Mac properly connected to the same Wi-Fi network?

				Have you moved, replicated, or copied documents or groups to the Sync group? Please note that smart groups are ignored during synchronization.

				Have you checked your database on the device on the database selection screen?

		

		If you cannot see your Mac from your iOS device or the connection is flaky, please try the following:

		
				Create an ad-hoc Wi-Fi network from the Wi-Fi icon in your Mac's menu bar.

				Connect to this network from your iOS device.

				Sync.

		

		If the connection now works as expected, the problem is related to your router, e.g., to security measures such as packet filtering. Version 2.0 of DEVONthink To Go will use standard data packets that should also pass your router's security without any problems.

		If you still have problems with synchronizing, please visit the user forum.  If you don't find an answer to your problem here, click here  to contact the DEVONtechnologies support team.

	Repairing a defective database

		DEVONnote databases are packages containing of your files and the supporting AI-based index. In rare cases this index can get corrupted or out-of-sync. But as your files are stored separately, this is not the end of the world. If your database starts behaving strangely, or if DEVONnote finds inconsistencies during start-up, it is time for some housekeeping.

		Step 1: Verify & Repair 

			As a first step, use File > Verify & Repair  to check your database's consistency and allow DEVONnote to take all necessary steps to repair any discovered problems. If Verify & Repair was able to repair your database, use File > Backup & Optimize  to optimize your database and have DEVONnote create an internal copy of the index.

			If Verify & Repair was not successful or your problems are not resolved, proceed with the next step.

		
		Step 2: Restore from backup 

			DEVONnote keeps up to two copies of the index files in case that the index is damaged beyond repair. By changing the factory settings, you can change when and how many internal backups DEVONnote keeps in the Preferences, Backup tab. 

			To restore the index file(s) from a previously saved internal backup, use File > Restore Backup.  DEVONnote presents you with a list of all available backups. Choose the latest one and click Open. This swaps the current set of index files with the copy (the current set of index files becomes the backup, the backup becomes the current set) so that data is never overwritten. Run File > Verify & Repair  to check the consistency of this index version and if everything is in the right order File > Backup & Optimize  to optimize your database and have DEVONnote create a fresh internal copy of the good index.

			If the backed-up index files are also defective, try the other backups, if available. If all backups are broken or corrupted, proceed with the next step.

		
		Step 3: Rebuild your database 

			Since your files and DEVONnote's index are stored independently within the database folder the index can be rebuilt at any time without you losing too much metadata. To rebuild the database from scratch, use File > Rebuild Database.  

			
			
			During the rebuild process, the complete index is re-created; your actual files are not touched. Any problems that occured during this process are logged. 

			Orphaned files: Orphaned files that could not be imported while repairing are logged and moved to the folder "Orphans" inside the database folder. To rescue the orphaned files, show the folder ~/Application Support/DEVONnote 2 in the Finder and move the files in the "Orphans" sub-folder to a save location, e.g., the Desktop, or directly re-import them by dragging them to DEVONnote's Dock icon.

		
		Step 4: Time Machine or manual rescue 

			If everything above failed, your database is severely damaged. You have two options now:

			
					Option 1: Restore your database from yourTime Machine  backup or whichever backup medium you use. If you don't use Time Machine, we strongly advise you to do so. External hard disks are cheap, and Time Machine makes backing up your important files quick and simple.

					Option 2: If you do not have a current backup of your documents, you can rescue your files manually, but you will lose any group structure. To manually copy your files from the defective database, show the folder ~/Application Support/DEVONnote 2 in the Finder. Copy the files in the "Files" subfolder, which are sorted by kind, to a save location, e.g., the Desktop. Then create a new database, re-import the files and recreate your group structure.

			

		
		Step 5: Contact support 

			If none of the above steps helped solving the problems you have with your database, please contact DEVONtechnologies' support staff  with a precise-as-possible description of your problem.

		
	DEVONnote crashes when opened

		If a database is heavily damaged, it may be that DEVONnote crashed when starting up or when opening the database. In this case you cannot use the built-in mechanisms to recover your data. But you can revert to an internal backup manually. With its factory setting, DEVONnote keeps up to two copies of the index files in case the index is damaged beyond repair. You can change how many internal backups DEVONnote keeps in the Preferences, Backup tab. 

		
		
		
		To revert to one of the internal backups, quit DEVONnote, then locate the database folder (~/Application Support/DEVONnote 2) in the Finder. Inside you will find one or more folders named "Backup(.x)". These folders contain copies of the index files (named "*.dtMeta"). To manually revert to one of the backups, copy the content of the backup folder (all ".dtMeta" files) to the top level of the database folder, replacing the existing, defective files.

		Once you have reverted to one of the backups, try opening DEVONnote again.

		If this solution di not help, please contact DEVONtechnologies' support staff  with a precise-as-possible description of your problem.

	Recovering a lost password

		If you have protected a database and you have forgotten your password, do the following to remove the password protection:

		
				Close DEVONnote

				Locate the folder "~/Library/Application Support/DEVONnote 2/" in the Finder and open it

			
			
			
				Move the file "Settings.plist" to the Trash

		

		A future version of DEVONnote will feature industry-strength encryption.

	Problems importing files

		Why does DEVONnote not recognize my files? 

			If DEVONnote does not recognize a file, make sure the file has a proper file name extension. DEVONnote needs a file name extension to determine the file type. Add the correct file name extension to your files (e.g., .txt for plain text files, .rtf for rich text files, .pdf for PDFs and .doc for Microsoft Word files) and try again.

		
		
		
	Problems using Services

		Why do the Services menu commands show no shortcuts? 

			They should; however, the keyboard shortcuts for Services menu commands are only requested by the supplying application. Mac OS X assigns these shortcuts and has ultimate control over which application or service gets what. If the DEVONnote Services menu items do not have shortcuts assigned, it is likely that Mac OS X assigned these shortcuts to another Services command, or that they are used by the current active application.

			You can manage your Services in System Preferences > Keyboard > Keyboard Shortcuts > Services.

		
		Why do the Services not work in Firefox? 

			Services work only in Mac OS X applications based on the so-called Cocoa framework. Examples for Cocoa applications are Mail, Safari, TextEdit, etc., and, of course, all DEVONtechnologies applications. However, Firefox is a port of a Unix application not completely based on Cocoa. Therefore, it does not support Services. Try using Camino  instead--a Cocoa browser based on the Firefox engine.

		
	DEVONnote behaves irrationally

		No software on this planet is bug-free, and if an application behaves irrational there is a good chance that your have just found a bug. But there could also be another cause: The application package could have become damaged during an update or through a bug in a totally unrelated piece of software on your computer.

		Strange application behavior 

			If something happens like

			
					menus disappearing or silently refusing to do anything,

					windows showing graphical artefacts,

					or applications not opening at all or opening with strange error messages,

			

			please try to trash the application package. Then empty your web brower's cache, download the software again, and re-install it. In many cases this cures the problem.

			If this does not help, try deleting DEVONnote's preferences files located in "~/Library/Preferences" and starting with "com.devon-technologies.think".

		
		Strange behavior related to documents 

			If the strange behavior only happens with a particular document, it is likely that the document is damaged, was created in a very old or extremely new file format that is no longer or not yet properly supported, or uses a damaged or malfunctioning Quick Look plugin.

			Please file a support ticket  and attach the document in question, packaged as a .zip archive, so that we check to see if the problem lies with DEVONnote or if it the file itself.

		
		Strange behavior of tabs 

			With Zooom/2 installed, tabs in tabbed windows behave stragely, e.g., close when cursor hovers over the tab. Another effect of Zooom/2 are scrolling problems in programs such as iTunes. Disabling Zooom/2 solves the problem.

		
	FAQ


	Do you have questions regarding our licensing policy, our products in the Mac App Store, or specific questions about DEVONnote?

	
	
	
	
	
	
	

General questions

		Do you have any job opportunities? 
Yes, we may. Please visit our Work @ DEVONtechnologies page  for more information about current open jobs at DEVONtechnologies.

		Can I be a beta tester? 
Maybe. Our beta tester selection process is very deliberate; we try and select our beta testers carefully so that we're not wasting anybody's time, yours and ours. We're looking for people who can provide us with feedback quickly and clearly, who use different hardware and software from our other testers, and who are willing to send us their personal data if it's needed for debugging.

		If you want to be a beta tester, the best way to catch our eye is to be active in our user forums. We often ask active participants on the user forums if they can help us test particular features and new products. You can, of course, simply contact us. 

		Is the documentation available in my language? 
The online and PDF documentation is only available in English at the moment. Localizing documentation and other text-intensive materials to Deutsch, Francais, etc. is cost-intensive and error-prone so that we have decided to concentrate our resources on developing stable, robust, and feature-rich software. We will have localizations of the online help etc. as soon as we feel we have the necessary resources.

		Where does the name DEVONtechnologies come from? 
"Devonian (after Devon County, England), the geologic period from 410 to 360 million years ago. Also called the Reptile Age or Age of Fishes. First amphibians appeared on the land, that until then was only inhabited by trees and other plants  it was the departure into a new age." Named after the Devonian period, the DEVONtechnology  marks the departure into a new age of data processing.

		Note: Ray Troll  has even created songs and other art about this extremely important evolution step.


	Release schedules, Mac OS X, and Windows

		When is the next release coming 
We try not to announce precise timelines or feature lists for future releases, as we are a small software company with limited development resources; if one of us should happen to get the sniffles, or if there are other outside factors we need to devote our limited time to, it can easily impact our intended development schedules.

		In planning releases, we try to strike a balance among:

		
				responding to customer requests,

				the needs of our partners,

				supporting new operating systems features,

				providing consistent features across the product line,

				working efficiently within the structure of the code, (similar features often get handled at the same time),

				various business needs.

		

		We cannot make any assumptions on how those various factors will impact our daily workflow; in fact, it's often impossible to predict the final release date accurately when we start new projects. We try to plan our releases with a long term perspective so that they ultimately serve the needs of our customers, even if they don't necessarily get in everyone's favorite feature request every time.

		Why are your applications not compatible with my pre-release version of Mac OS X? 
In the past, we've noted that compatibility issues with a new major release of the operating system are usually resolved by Apple in the final stages before its release, and don't require any action on our part. If you are already using a pre-release version of Mac OS X, please check if our applications work with a newer pre-release, or wait until it reaches the release candidate status. We will then make all necessary adjustments for making our apps run on the first official release of the new version of Mac OS X.

		Any chance of a Windows versions of your products? 
We're very commited to Mac OS X and the superior Cocoa environment. For most of our applications, porting them to Windows would take longer than it would to rewrite them from scratch on the Mac. If you need to use Windows software but still don't want to miss our products consider running Windows on a Mac. 

	Purchasing

		Note: If you purchased or plan to purchase DEVONnote in the Mac App Store please click here to learn more about the differences  between our shop and the Mac App Store.


		How do I purchase an upgrade? 
Please use DEVONnote > Check Upgrade Options  to find out what you need to upgrade and how much the upgrade is for you. If this option is not available in your copy of DEVONnote this application might not be upgradable. Please visit the Upgrade Assistant  on our web site instead.

		What is your policy on software updates? 
Usually, all minor updates ('dot updates', such as version 1.2 to 1.3) to our applications are free and require neither purchasing an upgrade nor requesting a fresh license code. We charge for major upgrades, though, such as version 1.x to 2.x. If you purchased your license in our online shop within a reasonable time frame before a paid upgrade release (between 30 days and 6 months, announced on our website), we will provide you with a free upgrade. If you purchased this application on the Mac App Store click here. 

		Can I get the bundle discount also later? 
Bundles are cheaper than multiple single licenses because a bundle means less fees for the shop provider. But we grant the bundle discount under certain circumstances. Please contact our sales staff  if you purchased one of the bundled produts within the last two weeks.

		Do you give a discount to students and educators? 
Yes, we give 25 percent off the regular price of DEVONthink, DEVONagent, DEVONnote and the Infoworker's Bundle to students and educators. We also give volume discounts to institution or faculties. Please visit our Students, Educators and NPOs  page.

		Do you offer NPO licenses? 
Yes, we offer free licenses to non-profit organizations (NPOs) in the sense of charities. Learn more about our NPO program. 

		Can I use your software on multiple computers? 
Yes, our license explicitly allows one and the same person to use our application non-simultaneously on multiple Macs. So, for example, if you install one of our products on a laptop, your office Mac, and your home Mac, you may do so as long as you only use one of them at a time.

		I have no credit card. How can I purchase your software? 
We are selling currently through the online sales agent Share*It  to keep our administration as lean as possible. If you don't have a credit card, you can also pay via PayPal or by purchase order, wire transfer, or even cash. See our online shop  for more details.

		In addition we are also selling some of our products through the Mac App Store. Please open the App Store application on your Mac to learn more about which payment options Apple offers.

		Can I have more time for evaluating your apps? 
No problem. We happily give out 30 day licenses for evaluation purposes. Choose Help > Support Assistant to request a 30 day trial extension. This option is not available e.g. in DEVONagent Express.

		Why haven't I received my license code(s)? 
If you have purchased your license in our online shop and if there have been no technical problems on our side, your license codes have been sent out to you immediately after your purchase. Sometimes, however, they get stuck in spam protection filters (either yours or your ISP's). Please, check your spam protection filter, and if you cannot find the license codes there, use Help > Support Assistant to get them resent to you. If this also doesn't work, please contact us  and we'll try to get your license codes to you as quickly as possible.

		Where can I buy a 1.x license code, e.g. for use on Mac OS X 10.4? 
License codes for legacy versions are no longer available in our shop but even the latest license codes are always backward-compatible: You can use a version 2.x license code also for version 1.x of the same product. To use a legacy product simply purchase a license for the most recent version of the product in our online shop and use it with your legacy software. 

		

	Mac App Store

		How do apps purchased in the Mac App Store differ? 
The Mac App Store requires so-called "sandboxing" of all apps. Sandboxing puts the apps into a closed environment and restricts access to e.g. files, networks, printers, etc. Therefore many apps sold through the Mac App Store have less features than their counterparts available outside of the Mac App Store.

		Do you charge for updates in the Mac App Store? 
No, updates are generally free in the Mac App Store (and we don't charge for them outside of the Mac App Store, too).

		Why are updates available always later that in your shop? 
All apps sold through the Mac App Store are reviewed by Apple before being released. Therefore new versions appear immediately on the DEVONtechnologies website but have to pass Apple's review before appearing also in the Mac App Store.

		Do I get a license code? 
Apps purchased in the Mac App Store do not come with a license code but are "signed" directly before downloading for your iTunes account.

		Do you offer bundles in the Mac App Store? 
No, bundles are not supported by the Mac App Store.

		How can I upgrade apps purchased in the Mac App Store? 
By Apple's rigid rules you couldn't. Upgrades are simply not available on the Mac App Store and upgrade offers outside of the Mac App Store are not allowed. In some of our apps there may be an upgrade option still available, though. Check the Read Me  to see if this is the case for you.

		Can I get a refund? 
We freely refund licenses purchased in our own shop. For apps purchased in the Mac App Store we don't have access to the refund mechanism. Please contact Apple's Mac App Store support for a refund.

	Your software license

		Why does DEVONnote not accept my license code? 
When you enter your license code and the 'Register' button stayes greyed out, try to enter ALL details, including your name and organisation, EXACTLY as they appear in our e-mail. Best practice is to copy-and-paste name, organisation (if entered) and license code from our email into the appropriate fields of the registration dialogue window. Also, please check if you have obtained the correct code for the correct edition of your software (e.g., a DEVONthink Pro license code will not work for DEVONthink Pro Office and vice versa) as well as version (DEVONthink 2.x will not accept a 1.x license code).

		I have lost my license code. How can I retrieve it? 
Use Help > Support Assistant to open the Support Assistant which has an option to get your license code resent to you. Alternatively visit the support area  on our web site.

		Does my license code work also for an older version? 
Yes, it does. All our license codes are backward-compatible to legacy versions of the same product and edition.

		Why do I have to enter my license code again? 
You only have to re-enter your license code after a complete reinstall of your system without a backup of your home folder or when the license code file has been deleted, e.g. by a preferences cleaner app. The license code is stored in a preference file in '~/Library/Preferences' (where ~ is your home folder). As long as this file is intact, you'll NEVER have to enter your license code again.

		Why does my DEVONnote 1.x license not work anymore? 
DEVONnote with version numbers greater than 1.x are paid upgrades. To use them you may need a new license code. Please use DEVONnote > Check Upgrade Options  to find out what you need to upgrade and how much the upgrade is for you.

		Why does your application say that it expired? 
When we release a public beta of one of our applications, we remove the usual trial restrictions but make it expire at the end of the beta period. A new public beta or the final release is, of course, available when this happens.

		Please simply visit our Download page,  download a newer version that the one you have installed, and replace your copy with the newer one. FPlease first move the old application to the trash, then move the new one into its place.

		Note: Your license code will, of course, NEVER expire.


	Product-related questions

		All frequently asked questions specific to DEVONnote are located in the appendix. Please continue reading on the following pages:

		
				FAQ specific to DEVONnote 

				Troubleshooing tips and tricks 

		

	Technology

	All commercial DEVONtechnologies applications are based on a proprietary AI technology, with rock-solid database foundation that allow them to manage large numbers of documents or knowledge bits while analyzing them almost instantly at the same time.

	
	
	
	
General Concept

		DEVONtechnology, on which all DEVONtechnologies' applications are built, is a new technology at the very beginning of its development. DEVONtechnologies constantly improves the technology and enhances it for more functionality, efficiency, robustness and flexibility.

		Development of the DEVONtechnology is a battle on two main forefronts of information processing technology. DEVONtechnologies is working hard on unifying both the top-down and the bottom-up AI concepts by imitating high-level functions and simulating the basic functionality of natural systems. This leads to highly functional, fast and efficient AI systems that can be used in a great variety of information processing contexts, such as pattern recognition, signal processing and information storage and retrieval.

	Features

		The DEVONtechnology is a rock-solid foundation suitable for a variety of completely independent applications. Therefore it is ideal for the rapid development of a huge range of new database-, signal-processing- and language-analysis-driven applications. The ability to deal with any kind of digital data makes it extremely flexible.

		The size of DEVONtechnology-based databases can, depending on the type of data stored, grow logarithmically and make indexing is completely unnecessary. Also, applications based on the DEVONtechnology improve themselves continuously (the more data they handle, the better the results), are language-independent and iron out any irregularities by applying fuzzy logic.

	Structure

		The DEVONtechnology consists of a kernel and several layers. Together they perform all the underlying computing, from 'simple' data handling to complex signal processing.

		Kernel: The kernel is the foundation for all layers and applications and is responsible for data handling, semantic and associative data processing, signal processing, fast statistic analyses and all fuzzy algorithms. It has to be as fast, flexible, and extensible as possible; it is 64-bit aware and uses a generic, proprietary file format (see above) allowing it to verify and repair low level data consistency, featuring logarithmic growth of the database and logarithmic speed decrease with increasing database size. The DEVONtechnology kernel is Unicode-aware, completely language-independent and self-optimizing and self-organizing.

		Layers: The layers form a shell around the kernel and provide high-level functions for the applications built on top of them. The database layer, for example, is used to store and organize data and supports all kinds of relations (1:n, n:1, n:n), hierarchies and freeform databases. No indexing or primary keys are required, strings can be unlimited in size and it's possible at any time to extend the range of pre-defined data types (Boolean, character, float, double, signed, unsigned, string, date, time, blob, color, size, and point). Another layer, the XML layer, makes it easy to handle XML code within the DEVONtechnology; it has a very small overhead, compared to DOM parsers or available XML databases, requires no indexing and supports the tight integration of other databases (and vice versa).

	Applications

		Some of the most likely applications for the DEVONtechnology are databases (knowledge bases, expert systems, search engines, table-of-content-generators, instant data-mining), intelligent agents, encryption, compression and archiving. Other uses for DEVONtechnology may be chat-bots, context-sensitive help, optical character recognition (OCR), speech analysis, recognition and synthesis, staticstics, thesauri and automatic translations.

		In particular, applications dependant on processing human language, either written or spoken, benefit from the flexible technology foundation. So, DEVONtechnologies' main focus in the development of new applications is in these areas: databases, 'intelligent' agents, text and speech analysis, statistics.

		Look forward to see a great range of different applications based on the DEVONtechnology. A few have already been announced on the DEVONtechnologies web site: 
		www.devontechnologies.com. 

	Other Products


	Besides DEVONnote, DEVONtechnologies publishes a number of other commercial, shareware, and freeware applications, and services that you may be interested in.


	
	
	
	
	
	
Overview

		DEVONtechnologies is focused on developing innovative applications for finding, storing, and organizing information. Our main objective is to make complex yet flexible technology that is both easy to use and lightning fast.

		
				DEVONthink 

				DEVONagent 

				DEVONsphere 

				DEVONnote 

		

		All applications are based on the DEVONtechnology,  a powerful and solid core unique to DEVONtechnologies. DEVONthink, DEVONnote, DEVONsphere, and DEVONagent are only the first of many more DEVONtechnology-powered applications to come.

		Also, we publish useful freeware apps and services  that help you in your everyday work with your Mac.

		Newsletter & user forum 

			Would you like DEVONtechnologies to keep you informed about updates and new product releases? Subscribe to the newsletter. 

			And don't forget to have a look at our very lively user forum , where users of all skill levels meet to discuss our applications, talk about our technology, and exchange tips and tricks for DEVONnote & Co.

		
	DEVONthink

		Organize and work with all your documents  bookmarks, email messages, text files, images, PDFs  in one place, regardless where they originated. Quickly capture data without interrupting your workflow. DEVONthink's unique AI assists you in getting the most out of your data collection.

		
				Learn more about DEVONthink 

				Learn more about DEVONthink To Go for iOS 

		

		
				Check your upgrade options if you want to upgrade to a higher edition [special link, not enabled in ebook] 

				Check your upgrade options if own DEVONnote and want to upgrade to DEVONthink [special link, not enabled in ebook] 

		

	DEVONagent

		DEVONagent Pro helps you search more efficiently on the web. It searches multiple sources, frees you from hunting for the really relevant results, and gives you power tools for your research. DEVONagent Express and DEVONagent Lite (free) make searching the web as easy as using Spotlight. Search Google, Bing, YouTube, Facebook, Twitter, even the Mac App Store, right from the menu bar.

		
				Learn more about DEVONagent Pro 

				Learn more about DEVONagent Express 

				Learn more about DEVONagent Lite 

		

	DEVONsphere

		Make your Mac smarter: Let DEVONsphere Express keep track of related emails, articles on the same subject, and similar web pages. Discover the hidden connection between seemingly unrelated files.

		
				Learn more about DEVONsphere Express 

		

	DEVONnote

		Your thoughts and ideas are valuable. DEVONnote keeps them and provides you with unique tools and artificial intelligence so that you can focus on things that really matter: creating even more ideas.

		
				Learn more about DEVONnote 

				Check your upgrade options if you want to upgrade to DEVONthink [special link, not enabled in ebook] 

		

	Needful Things

			Search files on your hard disk, watch web cams, create thumbnails, or access all your files and apps from the menu bar. Reformat paragraphs in your favorite word processor, do little calculations anywhere you can type in text, or send text to your Bluetooth-enabled mobile phone. And all this for free.

		
				Learn more about our freeware apps 

				Learn more about our freeware services 

		

	Appendix


	In the appendices you will find additional information that helps you getting familiar with DEVONnote, such as a glossary of commonly used terms, a listing of the Boolean operators used in searches, and placeholders used in templates for yet "targetless" WikiLinks.


	
	
	
	
	
	
	
	
		
	
	

Glossary

		Become familiar with these terms to get the most out of working with DEVONnote.

		Keyboard symbols 

			
					⌘ The Command key, usually next to the Space bar.

					⌥ The Option key.

					⌃ The Control key (usually labeled with "ctrl").

					⇧ The Shift key.

				
					⇥ The Tab key.

					⏎ The Return key.

			

		
		Interface elements 

			
					Contextual Menu: The menu that appears when you right-click (or ⌃-click) something; the contextual menu gives you access to frequently used commands that deal directly with the clicked object. Read more about the available contextual menus in the Documents  and Windows  chapters.

					Item list: A list of items stored in the database. Items can be documents, groups, or smart groups. 

					View/Edit Pane: A part of the DEVONnote main  and document  windows that lets you view a document or, when possible, edit it. The view/edit pane displays the content of your documents  depending on their type. [Read more...] 

					View (1): The layout for a DEVONnote main window.  You can change the layout using the commands found in the View menu. 

					View (2): The display for the various document types inside the the view/edit pane or a document window.  [Read more...] 

					Window: DEVONnote uses three different types of windows: main, document, and other. Main windows  show lists of items and, in some views, also the contents of the selected document, whereas document windows  show documents separately.

			

		
		Documents & groups 

			
					Database: A collection of all documents stored in DEVONnote. DEVONnote only manages one central database.

				
					Document: A file in the database, a plain or RTF text, or a link. Technically a document is an entry in the database with text or RTF content. Sometimes simply referred to as "content".

					Default Destination: The default destination group for incoming data. In DEVONnote this is the special Inbox group.

					Group: A collection of documents or other groups inside the database. Similar to a folder in the file system. [Read more...] 

				
					Inbox: A special group for data coming in to a database. 

					News Feed: A news feed is like a web page, but split into multiple newsbits. A feed reader or web browser can split the feed "page" into its parts and show each of them as a separate news item and/or store it in a local database. DEVONnote stores feeds in a database and displays them like a group; contents are updated live from the Internet as the connected feed changes. Older news bits are kept, while fresh news bits are added and marked as unread. When you add a bookmark that points a feed to a database, DEVONnote tries to add it as a proper feed document if possible. DEVONnote can also be defined as the system's RSS reader in Safari's Preferences.

					Replicant: A document or a group that appears in more than one place in the database. Unlike an alias in the file system, a replicant is not a real document pointing to another file (usually the original); rather it is a second entry in the table of contents for the very same document. Consequently, there is no original; when you replicate a document you'll end up with two replicants. [Read more...] 

				
					Smart group: Not a real group but a "saved search" that appears like a group. Every time you visit this smart group, DEVONnote runs the attached search and displays it as the content of the group. Create smart groups using the smart group editor.  DEVONnote creates a number of pre-defined smart groups when you create a new database.

					Trash: Stores all trashed items until you physically delete them using DEVONnote > Empty Trash. 

			

		
		Tags 

			
					Tag: A tag is a different visual representation of a group. All documents contained in a group that has not been excluded from tagging, get the group's name "attached" as a tag. Tags represented by a regular group appear grey in all tag lists.

					Group tag: Tags represented by a regular group.

					Ordinary tag: Tags created through the Tag bar or other means are created in a special top-level group named "Tags". They are called "ordinary tags" and appear blue in all tag lists.

			

		
		Item properties 

			
					Flagged/Unflagged: Items can be checked or unchecked for your personal use, e.g., for creating a to-do list, maintaining a shopping list, or writing a list of project tasks.

					Locked/Unlocked: Items can be locked to keep them from being unintentionally modified.

					Read/Unread: Items can be marked read or unread, which is useful for captured or automatically downloaded news items  or documents that you want to read later. Both unread items and groups containing unread items are shown in bold.

			

			The "flagged" and "locked" properties are indicated by icons. [Read more...] 

		
	FAQ (product-specific)

		General 

			What is the difference between the various editions? 
While all three editions of DEVONthink, as well as DEVONnote, share many features, there are some noticible differences. For instance, DEVONthink Pro is able to deal with more than one database; features tables, forms, and categories; and comes with full AppleScript support. DEVONthink Pro Office also comes with plugins for pro-grade email archiving, paper capture, and Web sharing. You can find a complete listing of all differences on the feature comparison page. 

			Which languages does DEVONnote support? 
DEVONnote supports multilingual documents and Unicode and so supports all Asian languages including Chinese, Japanese, and Korean, as well as non-Latin scripts such as Cyrillic, Hebrew, and Arabic (including writing from right to left). Use Format > Alignment > Writing Direction  to adjust the writing direction.

			Note: Asian languages, however, do not use word separators such as white space or punctuation. When searching, you need to use wildcards. Use ~word or *word* in the search field or search window. 


			How do I completely uninstall DEVONnote? 
To completely remove DEVONnote from your Mac, see the instructions in the Read Me. 

		
		Databases 

			Can I use more than one database? 
DEVONnote stores all data in a central folder in "~/Library/Application Support/". To use multiple databases consider upgrading to DEVONthink Pro or higher.

			How are my documents stored? 
DEVONnote stores all documents in sub-folders of '~/Library/Application Support/DEVONnote 2' where ~ stands for your home folder.

			Inside the "Files.noindex" folder the actual documents are stored in sub-folders for their respective type and further sub-folders that help DEVONnote to quickly locate them. Documents are never altered when you copied them into the database. The file name of each document is exactly the same as the corresponding document name that you see in DEVONnote.

			In addition, the database folder contains a set of ten index files named with the suffix ".dtMeta" as well as a "Settings.plist" file containing database-specific preferences. Finally, the database folder can contain one or multiple folders named "Backup.x". They contain backups of the index files and are created automatically by DEVONnote's backup function. They do not contain copies of all actual documents.

			How can I move my database to another computer? 
Your database is the folder "~/Library/Application Support/DEVONnote 2". To move it to another computer, copy it to the same location on the other computer.

			Note: In general, DEVONnote databases are self-contained, so one can move a database to another computer, open it and start using it. But if some of the content has been indexed instead of imported, it will be necessary to also move the externally linked files to the other computer. This must be done in such a way that the Paths to the external files remain valid. If everything is in your Documents folder on the first computer, copying the externally linked folders and files to the Documents folder of the second computer will probably work. Always quit the DEVONnote application before copying or moving a database, as copying an open database may result in an incomplete or damaged copy.
			


			
			
			Can I share my DEVONthink database using WebDAV or DropBox? 
You can, but it is definitely not recommended as WebDAV servers do not fully support all properties of real hard disks. See below.

			Can I synchronize databases between multiple computers? 
Yes. [Read more...] 

		
		
		
		
	Iconology

		Additional icons behind item names, e.g., in main windows,  indicate that the item has been indexed instead of imported, is locked, has a comment attached, or is scripted. Groups also serving as tags show a tag icon. Depending on your preferences,  replicants, duplicates, or replicated duplicates are indicated with a little grey icon instead of appearing in color.

		
				[image: ] Item has been flagged [Read more...] 

				[image: ] Item is indexed, not imported 

				[image: ] Item is locked [Read more...] 

				[image: ] Item has a comment [Read more...] 

			
				[image: ] Group is a tag, too [Read more...] 

		

		
				[image: ] Item is a duplicate

				[image: ] Item has one or more replicant(s)

				[image: ] Item is a duplicate, but also has one or more replicant(s)

		

	Keyboard shortcuts

		Keyboard shortcuts make using DEVONnote much more efficient. Some of the following shortcuts are common to most OS X applications; others are only available in DEVONnote. In addition, many menu commands have keyboard shortcuts. These are shown directly in the menu.

		Note: You can change the shortcuts for menu commands in System Preferences > Keyboard > Keyboard Shortcuts > Application Shortcuts.


		Windows 

			
					Tab: Cycles focus through all entry areas and fields.

					Shift-Tab: Cycles focus through all entry areas and fields in reverse order.

					Control-Tab: Cycles through all panes.

					Control-Shift-Tab: Cycles through all panes in reverse order.

					Escape: Cancels processes, closes dialogs or Quick Look previews, etc., depending on the context.

			

		
		Document lists 

			Navigating items:

					Up/Down arrow: Navigates up and down in all views. Use ⇧ to select multiple entries.

					Left/Right arrow: Expands or collapses the selected groups in Horizontal Split, Vertical Split  views, or navigates to previous/next item in other views.

					Option-click (the triangle in front of a group): Expands or collapses all groups that are containted within this group as well.

					Option-Left/Right arrow: Expands or collapses the selected groups and all their children in Horizontal Split, Vertical Split  views.

			

			Selecting items:

					Shift-click: Selects multiple items.

					Shift-arrow: Extends the current selection.

					Command-click: Adds an item to the selection.

			

			Manipulating items:

					Return: Renames documents.

					Backspace: Deletes selected items.

					Command-drag: Copies items to the drag destination instead of moving it.

					Command-Option-drag: Creates replicants for the items at the drag destination. Dragging items from the Finder to DEVONnote with ⌘ and ⌥ pressed indexes the item. Dragging items into documents with ⌘ and ⌥ held inserts a link to the item.

					Command-Option-drag: Creates bookmarks for address cards dragged in from Address Book.

			

			Using items:

					Option-double click or Command-Shift-O: Opens selected documents/groups in a new tab or a new main window (depending on whether tabbed browsing  is active or not) and closes the current window ("hoist"). Change Always open groups in a new window in Preferences, General tab  to your personal taste.

					Tab: Jumps to the first or next editable column.

					Space: Opens the standard Quick Look panel showing a preview of the selected items.

					Option-Space: Opens a full screen Quick Look slideshow.

			

		
		View/Edit pane 

			
					Home/End: Goes to beginning of, or end of, any view.

					Page up/down: Scrolls one page up and down in any view.

					Space/Shift-Space: Scrolls one page down or up in non-editable views, e.g., web pages.

					Command-click: Opens the target of a link in a new tab or separate window.

					Command-Option-click (a cross-link or Wiki link): Positions the insertion caret inside the link for editing.

					Option-click (a word): Looks for the clicked word in the database, like the contextual menu command See [word].

			

		
		Plain and rich text documents 

			
					Drag, then hold Option: Copies selected text.

					Shift-arrow: Extends current selection.

					Command-Option-drag: Inserts a cross-link for groups or documents dropped into a rich text document. Dragging files or folders from the file system to a rich text document with ⌘ and ⌥ pressed creates links to them.

					Command-click: Opens clicked URL in the default browser or application or in a new tab, depending on your preferences. 

					Command-Shift-click: Opens a link in a new tab and selects it (only if tabbed browsing is switched on).

					Command-Option-click (1): Places the insertion caret inside the text of a clickable link.

					Command-Option-click (2): Opens a clicked cross-link or Wiki-style link in a separate document window.

					Option-drag: Selects text using a rectangular selection ribbon.

				
				
			

		
		HTML pages, web pages, feeds 

			
					Command-click: Opens clicked URL in the default browser or application or in a new tab, depending on your preferences.  Equals clicking a link with the third mouse button.

					Command-Shift-click: Opens a link in a new tab and selects it (only if tabbed browsing is switched on).

				
					Backspace/Shift-Backspace: Goes backwards and forwards through the visited web pages.

			

		
		Sheets 

			
					Return: Moves one cell down for editing.

					Shift-Return: Moves one cell up for editing.

					Tab: Moves one cell to the right for editing.

					Shift-Tab: Moves one cell to the left for editing.

					Arrows: Moves the editing selection.

					Escape: Stops editing.

			

		
		
		
	Tagging

		DEVONnote supports tagging in a way that makes groups and tags interchangeable. While this concept may sound a bit strange at first, you will soon discover why it is a smart way to approach tags and group and to bring both together.

		Introduction 

			Technically, tags and groups are identical: both are simply entries in a table that are somehow "attached" to an item, usually a group or document. The difference is that tags are visualized as "labels attached TO the item while groups are visualized as groups CONTAINING the item." They are presented differently, but internally they are the same.

			DEVONnote treats groups as tags and tags as groups. When it shows you the tags associated with an item, it presents you with a list of all groups that the item is part of and that have not been excluded from tagging.

			Example: A document is located in the group "Science > Paleontology > Dinosaurs". Consequently, its tags are "Science," "Paleontology," and "Dinosaurs." Now you create a sub-group of "Dinosaurs" named "Land-living" and move the document into the new folder. Automatically it is now tagged with "Science," "Paleontology," "Dinosaurs," and "Land-living."


			The same happens when you replicate the document into multiple groups: It is tagged with the names of all enclosing groups (not excluded from tagging) of all its replicants.

			When you assign a tag using DEVONnote's user interface, move a document, or replicate it to another group, this is what happens:

			
					Assign a tag: The item is replicated to the Tags group. 

					Removing a tag: The item's replicate in the Tags group is deleted.

					Adding an item to a group: The group's name and the names of all groups containing the group appear as tags attached to the item.

					Moving an item: The new group's name and the names of all groups containing it appear as tags attached to the item.

					Replicating an item: The new group's name and the names of all groups containing it appear as tags attached to the item, too.

					(Auto-) Classifying an item: This places the item into a new group and replaces all assigned tags.

			

			Tags represented by a regular group are called "group tags"; tags created without an existing group are called "ordinary tags." [Read more...] 

		
		
		The Tags group 

			Every DEVONnote database contains a top-level group named "Tags." It is used whenever you add a tag to an item, e.g., through the tag bar, for which a group does not yet exist. In this case, DEVONnote creates a group for the tag in the Tags group and places a replicant into it.

			When you rename a group here all items associated with it, (means: that have a replicant here) this option will show the change.

		
	
		Using tags 

			To use tags for selecting and finding documents or browsing tags, DEVONnote offers the following options:

			
					Tags view: The tags view allows you to browse your documents by tags. In the tags view, select a tag to display all items which have this tag assigned. Choose multiple tags, e.g., by clicking anothe one with ⌘ held, which shows all items carrying the selected tags.

					Smart groups: Use smart groups to search for items with given tags.

			

			Wherever tags are shown, "ordinary tags" (tags created in the special Tag group) appear blue, and tags that are also regular groups appear grey. Tags,  in the Tag bar also show a pop-up menu when you click their downward triangle. The menu shows related tags that can be added to the item, and reveals tags represented by a group.

		

		Aliases and excluding from tagging 

			DEVONnote also honors aliases added to groups. You can add "alternative names" to a group using Info panel  and later use these alternative names as a tag.

			Example: In the Info panel of the group "Dinosaurs" you have added "Dinos" as an alias. You can now tag items with "Dinos" and they automatically will be moved or replicated to the "Dinosaurs" group.


			Groups that you don't want to use as tags can be excluded from tagging. Select the group and open the Info panel.  Check Exclude from  Tagging and the group's name will no longer be shown as a tag for items contained in it.

		
	
		OpenMeta 

			OpenMeta  is an open standard for storing tags with files in the file system. Using OpenMeta applications can add tags to files and let other compliant applications  read them.

			DEVONnote supports OpenMeta when importing and exporting files. Files stored in the database are not tagged in OpenMeta-style, though assigned tags will be added to the files as soon as you export them.

		
		
	File formats

		DEVONnote supports a variety of text formats, including plain text, Rich Text Format (RTF) files, and most Microsoft Word documents.

		Text files 

			DEVONnote supports plain text files (as well as Mac OS 9 SimpleText and Tex-Edit Plus files) in all encodings supported by Mac OS X, including Unicode and UTF-8. By default, DEVONnote automatically recognizes the encoding and the line endings used by Mac, Windows, and Unix operating systems.

			
					Extensions: adb, ads, aln, ans, applescript, bat, bib, bibtex, c, cls, cmd, command, con, cp, cpp, crash, css, csv, dot, em, embl, erl, err, f, f70, f90, fasta, for, fpp, ft, gb, genbank, gff, h, haml, hlp, hpp, hs, hrl, id2xf, inc, js, lhs, lisp, log, lst, m, markdown, md, mdwn, mi, mis, ml, mly, mm, mmi, mml, msf, org, p, pas, pir, pl, pp, py, rb, rc, sass, scm, scpt, scptd, scriptSuite, scriptTerminology, sdef, seq, sh, sqc, sql, ss, strings, sty, sw, swiss, tab, tcl, tex, text, textile, txt, v, vcf, wrl, x, xchatlog, xd, ychat

					HFS type codes: TEXT, ttro, TERO, sEXT, SimpleText, scpt, osas, APPL (AppleScripts wrapped in an executable application)

					Automatic recognition: DEVONnote also recognizes plain text file formats defined by third-party applications.

			

			
			Rich Text Format: For Rich Text Format (RTF) files, DEVONnote recognizes Mac, Windows, and ANSI encodings as well as Mac OS X RTF documents with attachments (RTFD).

			
					Extensions: rtf, rtfd

					HFS type codes: RTF

			

		
		Office and other documents 

			DEVONnote imports many Office file formats such as Microsoft Office  and OpenDocument  documents, as well as all other file formats for which Quick Look support is available, e.g. Mellel (version 2.6 and higher)  files, AppleScript scripts, or text clippings.

			Note: Quick Look is Mac OS X 10.5's mechanism for displaying a preview of almost any file type. In the Finder, this function is invoked by pressing the Space bar. Quick Look requires the maker of the software that writes the document to add additional preview information inside the file (package), or to provide a Quick Look plugin embedded into the application itself or installed in a Library folder. If neither DEVONnote nor the Finder can preview a document format that you want to use, please contact the maker of the software and ask it to provide Quick Look support for its file format.


			Due to the nature of Quick Look, the contents of a document that is displayed using this technology, e.g., an Apple Pages file, is sometimes not selectable. Depending on the file format,  a plain or rich text alternative is available for some files, e.g., for email messages. Where available, use the Text View/Preview toggle button in the document's navigation bar  to switch back and forth between plain text and preview modes.

			Additional Quick Look plugins can be found on QLPlugins.com. 

		
		
		Chat logs 

			DEVONnote understands the text format of logs generated by Adium,  iChat or Yahoo Messenger.  You can import these chats like rich text files.

			
					Extensions: chat, chatlog, ichat

					HFS type codes: YMSG

			

			
		
		
		Bookmarks 

			Drag or paste Internet addresses from any Internet application, or Internet location files from the Finder, to DEVONnote to create a bookmark documents. DEVONnote is especially optimized to accept Safari Bookmarks. Use bookmarks in DEVONnote to integrate "live' content from the Internet seamlessly with local documents.

			
					Extensions: dtLink, ftploc, fileloc, inetloc, mailloc, newsloc, url, vncloc, webloc

					HFS type codes: ilht, ilft, ilfi, ilma, ilnw, ilaf, ilat, ilns, ilge, ilvn, LINK

			

		
		
		
		
		
		
	Templates

		DEVONnote comes with a number of pre-fabricated templates for general use. Use these templates to add a task list, a quote, or whole group structure for project management to your database.

		Managing templates 

			Templates are regular files stored in the Finder in the folder "~/Library/Application Support/DEVONnote 2/Templates.noindex". Navigate to this folder in the Finder to manage your templates, rename them, organize them in sub-folders, or delete them.

			More templates are available as extras. [Read more...] 

		
			Pre-fabricated templates 

			DEVONnote comes with the following pre-fabricated templates, which serve as great examples of the template feature.

			Note: Not all of the listed templates are available in DEVONnote as DEVONnote does not support AppleScript. Templates based on simple files or on template packages are available, though.


			General use:

				
					Note: Adds a new note. If the clipboard contains text, it is automatically inserted; if the clipboard contains an Internet address (URL), it is added to the note's link list.

					Phone Note: Adds a new phone note, automatically inserting the current date and time.

				
					Quote (from clipboard): Adds a rich text document for a quote or citation. The clipboard content is automatically inserted and, it's an Internet address (URL), it is automatically made clickable.

					Task List: Adds a simple task list.

				
			

			Accounts & Passwords:

					Online Account: Adds a document for storing online account details.

					Serial Number: Adds a document for storing serial numbers.

			

			Addresses & Dates:

					Address Book Card: Adds the card selected in Address Book as a rich text document to your database.

					iCal Event: Adds an iCal event you have copied to the clipboard (!) as a rich text document to your database. You need to copy the event to the clipboard because iCal does not provide a mechanism to retrieve the selected event.

			

			
			
			
			
			
			
			
			
		
		Template packages 

			Besides the more complex smart templates, DEVONnote supports template packages. These are folders with the file name extension ".dtTemplate" that contain one or multiple folders, one for each supported language. This way, depending on the system language, you can let DEVONnote import the files in the right language.

			In addition, you can use the following placeholders in your file or folder names of your templates packages, as well as in contained rich text, plain text, HTML, or XML files. During import they are replaced with actual data.

			
					%time%: The current time

					%date%: The current date

					%shortDate%: The current date in short format

					%longDate%: The current date in long format

					%monthname%: The month name of the current date

					%weekday%: The week day name of the current date

					%day%: The day number of the current date

					%month%: The month number of the current date

					%year%: The year number of the current date

			

			
					%username%: The user's name

					%fullUsername%: The user's full name

					%organization%: The user's organization from Address Book

					%emailAddress%: The user's email addresses from Address Book

			

			
					%host%: The host name

					%databaseName%: The database name

					%databasePath%: The database's path

					%groupName%: The name of the parent group

					%clipboard%: The clipboard contents as plain text

					%styledClipboard%: The clipboard contents as rich text

					%clipboardLink%: The clipboard contents as a clickable rich text link if the clipboard contains a valid URL

			

		
		Smart templates 

			Most of the prefabricated templates are "smart templates": They are not simple files, but actually AppleScript packages that are executed when selected in the Data menu.  These packages contain  script code, as well as the actual templates that they insert into your database. This has a number of advantages:

			
					The script can choose a localized template for your language; this is also possible using a template package. 

					The script can add information to the pre-fabricated template, e.g., the current date and time or data from the Web.

					The script can act intelligently on data on the clipboard: If it's a simple text, it adds the text; if it's a URL, it adds it to a different area of the document and makes it clickable.

					The script can check if a certain application is installed, e.g., OpenOffice, before adding a document.

			

		
		
	Web site export templates

		For exporting information as web site, DEVONnote uses templates available in ~/Library/Application Support/DEVONnote 2/Websites/ to create HTML files from documents. You can choose the template in the save dialog that appears when you use File > Export > as Website 

		In the HTML templates, the following placeholders can be used:

		
				%databasePlusLocation%

				'%comment%

				%url%

				%tags%

		

		These placeholders will be replaced with actual information during the export. The placeholders will only be replaced in documents that are converted to HTML during export--namely plain text, rich text, Microsoft Office/OpenOffice documents, scripts, chat logs, and sheets.

	Search operators

		In the toolbar search field  you can use standard and extended Boolean operators, parenthesis, and more to fine tune your search.

		The syntax of the operators is compatible to DEVONagent  and EasyFind,  the Finder, Spotlight, common search engines as well as common programming languages such as C, C++, Objective-C, Java, and JavaScript. The complexity of the query is unlimited.

		Case 

			All terms are case-insensitive. You may, if you wish, use capitalization for proper names in a query, but DEVONnote will ignore case in interpreting the query.

		
		Precedence of terms 

			Search terms and associated operators will be interpreted from left to right, except as modified by including portions of the query within parentheses.

		
		Wildcards 

			You can replace parts of words with wildcards matching one, multiple, or a range of characters:

			
					?: Matches exactly one character.

					*: Matches none, one, or multiple characters.

					[a-b]: Matches one character of the range "a" through "b".

					[abc...] or [a|b|c|...]: Matches one character out of the given list of characters.

					[^...]: Matches one character that is not contained in the given list or range.

			

		
		Boolean operators 

			The operators (often called Boolean operators) are words or symbols that establish logical rules for the terms in the search query. If no operator is given, DEVONnote infers AND. The available Boolean operators are:

			
					term1 AND term2: Contains term1 AND term2

					term1 BUT term2: Contains term1 AND term2

					term1 OR term2: Contains term1 OR term2

					term1 XOR term2: Contains term1 or term2, but not both

					term1 EOR term2: Contains term1 or term2, but not both

					NOT term: Does not contain term

					"term1": Contains the string term1, in exactly this form

			

			Besides the classic Boolean operators, DEVONnote uses a number of operators that usually are found in high-end databases. Use these operators as a replacement for AND and "quotes" to fine tune your query.

			
					term1 OPT term2: term1 needs to occur, term2 can. If term2 does, the found document ranks higher in the search results.

					term1 NEAR term2: term1 occurs 10 words or less before or after term2

					term1 NEAR/n term2: term1 occurs n or less words before or after term2

					term1 BEFORE term2: term1 occurs before term2

					term1 BEFORE/n term2: term1 occurs n or less words before term2

					term1 NEXT term2: term1 occurs right before term2 (shortcut for BEFORE/1)

					term1 NEXT/n term2: term 1 occurs n or less words before term2 (synonym for BEFORE/n)

					term1 AFTER term2: term1 occurs after term2

					term1 AFTER/n term2: term1 occurs n or less words after term2

					~term1: Contains term1, also as part of a word

			

			For convenience, some of these operators can also be abbreviated using commonly used symbols:

			
					AND: &, &&, +

					OR: |, ||

					XOR: ^, ^^

					NOT: !, -

			

			Note: The symbols above are also used by the Finder and Spotlight for searches. Enter the vertical ruler character for the OR operator by pressing ⌥7 (e.g. on European keyboards).


			Operators are evaluated in the following priority: parenthesis > phrase/hyphens > (NOT) BEFORE/AFTER/NEAR/NEXT > NOT > AND/OR/XOR/EOR. Terms with same priority but without parenthesis are evaluated from left to right.

		
		Date comparison operators 

			For comparing dates in smart groups the following operators are available:

			
					< date: Matches items that were created/edited/viewed before date.

					<= date: Matches items that were created/edited/viewed before or on date.

					>= date: Matches items that were created/edited/viewed after or on date.

					> date: Matches items that were created/edited/viewed after date.

			

		
		White space handling 

			Words linked by non-white separators (e.g. www.devon-technologies.com or page_id) are treated like phrases put into "quotes". Words separated by hyphens are handled like word1word2 OR "word1 word2". Characters separated by dots are considered to be abbreviations and therefore handled like words separated by hyphens, e.g., the term t.a.t.u is equal to "t a t u" OR tatu

		
		Examples 

			By using any or all of the operators and rules layed out above you can create complex queries that find the exact information you're looking for. Here are some example queries that show how the operators are used.

			Example: Devonian Dinosaurs


			This query looks for all documents that contain the words "devonian" and "dinosaurs".

			Example: (Steve NEAR Jobs) AND iMac BUT NOT MacBook OPT Pro


			This query looks for documents that contain the words "Steve" and "Jobs" no farther ten words away from each other, as well as the word "iMac" (no specific position relative to Steve and Jobs), but not the word "MacBook". The word "Pro" does not need to occur, but if it does, the document is ranked higher in the list of search results.

			Example: Paracetamol NEAR (~effect OR impact) AND ((side OR second*) NEAR/2 ~effect)


			This query looks for documents containing the word "Paracetamol" near (within 10 words) to words either starting with "effect" (and so also "effects") or  "impact". In addition, the document needs to contain the word "side" or any word starting with "second" located within two words range of any word starting with "effect".

		
	Template tags for Wiki-style links

		In DEVONnote you can create new documents by first selecting some text in a rich text document and then making it a link using the contextual menu.  When you then click this link, DEVONnote creates the new document using a template you set in the Editing Preferences.  In this template, can use the tags below to automatically insert the name of the link, the current date or other information. [Read more...] 

		
				%@: Name of link

				%%: A "%" character

				%a: Abbreviated weekday name

				%A: Full weekday name

				%b: Abbreviated month name

				%B: Full month name

				%c: Shorthand for "g%X %x," the locale format for date and time

				%d: Day of the month as a decimal number (01-31)

				%e: Same as %d, but does not print the leading 0 for days 1 through 9

				%F: Milliseconds as a decimal number (000-999)

				%H: Hour based on a 24-hour clock as a decimal number (00-23)

				%I: Hour based on a 12-hour clock as a decimal number (01-12)

				%j: Day of the year as a decimal number (001-366)

				%m: Month as a decimal number (01-12)

				%M: Minute as a decimal number (00-59)

				%p: AM/PM designation for the locale

				%S: Second as a decimal number (00-59)

				%w: Weekday as a decimal number (0-6), where Sunday is 0

				%x: Date using the date representation for the locale, including the time zone

				%X: Time using the time representation for the locale

				%y: Year without century (00-99)

				%Y: Year with century (such as 1990)

				%Z: Time zone name (such as Pacific Daylight Time)

				%z: Time zone offset in hours and minutes from GMT (HHMM)

		

	Metadata

		DEVONnote stores a large number of metadata fields internally when importing documents from the file system, e.g., from PDF, RTF, MP3, EXIF/IPTC, HTML, and email messages as well as from all files that deliver metadata through the Spotlight metadata importer. Here's a partial list of theoretically supported fields:

		General:

				Title

				Headline

				Subject

				Creator

				Producer

		

		PDF and RTF:

				Description

				Copyright

				Comment

				URL

				Keywords

		

		Electronic correspondence:

				Authors

				Author email addresses

				Recipients

				Recipient email dddresses

				Email addresses

		

		Electronic publications:

				Album

				Composer

				Contributors

				Publishers

				Editors

				Organizations
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