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Web Searching: Fed up with just a load of links? Using advanced search techniques, DEVONagent Pro takes on all those tedious search-and-review tasks releasing you to focus valuable time on relevant results.
The DEVONagent Pro Advantage

Why DEVONagent Pro?
Using advanced search techniques, DEVONagent Pro takes on all those tedious search-and-review tasks releasing you to focus valuable time on relevant results. It assists you in
information from the Web or your DEVONthink Pro Office databases with a powerful and flexible search architecture, has a powerful, research-oriented web browser and simple built-in archive, and tightly integrates with DEVONthink.
What DEVONagent Pro Does for You
Perfect Integration
Learn more about why you should use DEVONagent Pro, when you should use it, and how to run your first query: [Read more...]
Highlights of Version 3.0
DEVONagent Pro 3.0 comes with a reworked user interface, better browsing capabilities, new and updated plugins, and is based on a new technology foundation. Here's just a short list of what's new in DEVONagent Pro 3.0 compared to earlier versions:
System Requirements
Every Apple Mac computer with at least 512 MB of RAM, Mac OS X 10.5 or later. In addition, a broadband Internet connection (2 Mbps or faster) is highly recommended.
Installing, Updating, Removing
Just move the DEVONagent Pro application package to the Applications folder or any other directory you have access to. Please note that Mac OS X Services and the connection to DEVONthink work only for applications installed into one of the Applications folders, and that logout and login or a restart is required after installation.
To update an existing version of DEVONagent Pro, simply copy the application package from the disk image to your Applications folder, replacing the old version. Your database(s) will not be affected.
If you would like to switch from the Mac App Store variant of DEVONagent Pro to one directly downloaded from the DEVONtechnologies website you can do so at any time. The official version will accept your Mac App Store receipt as a valid license. Copies not downloaded from the Mac App Store also allow you to buy an upgrade to a higher edition or version (if available).
To remove DEVONagent Pro traceless from your computer, trash the following files and folders (~ represents your home folder):
Depending on whether you have installed the following extras or not, remove them, too:
Note: Some files may or may not be installed on your machine depending the version of Mac OS X you are using.
Trial Restrictions
Unregistered DEVONagent Pro runs for 60 hours of non-continous runtime. Close the app to stop the clock from ticking and re-open later to continue your evaluation. The menu extra is restricted to 100 searches alltogether until DEVONagent Pro is registered.
Getting Started
This chapter helps you get started with DEVONagent Pro. It explains why and when to use DEVONagent Pro, and how to run a first query, step-by-step.
Why use DEVONagent Pro?
The first misconception is that DEVONagent Pro is a simple front-end to Google or Bing. It is an Internet research assistant that takes over tedious research tasks such as weeding out bad search results, looking for linked documents, or finding information on a webpage.
Searches with DEVONagent Pro take longer than a quick search on a Web search engine because DEVONagent Pro downloads each resulting page instead of only presenting you with a link to it. They also return fewer results as DEVONagent Pro already filters out broken links, advertisements, and outdated pages. So the search takes longer but you save time because you do not have to do all this manually.
Reasons for using DEVONagent Pro include:
When to use DEVONagent Pro?
DEVONagent Pro does much more than a search on a Web search engine. And because it downloads all results to your Mac to analyse and post-process them, a search run takes between a few seconds and several minutes. Consequently, DEVONagent Pro is not necessarily the most useful tool for every search task.
Use DEVONagent Pro for:
Don't use DEVONagent Pro for:
First steps with DEVONagent Pro
A first search: While DEVONagent Pro is a real power tool, it does not need to be overly complex. Running a simple search using DEVONagent Pro is no more complicated than using Google or Bing.
The next steps: Now that you know how to run a first search you can make the next steps alone. Here are a few chapters for you to continue exploring DEVONagent Pro:
Finally, DEVONagent Pro itself and the DEVONtechnologies website offer additional information and assistance:
Common Tasks
This chapter explains common tasks in DEVONagent Pro step-by-step and points you to related topics.
How to find on the Internet
DEVONagent Pro's main objective is to find stuff on the Internet. It does so by sending a query, a search term, to a selected set of search engines, e.g. Google, collecting the results, analysing them, and presenting them to you.
You tell DEVONagent Pro which search engines to use by selecting a plugin (contains instructions telling DEVONagent Pro how to communicate with a search engine) or search set (combinations of multiple plugins and other options). DEVONagent Pro comes with a large number of pre-fab plugins and search sets. [Read more...]

Step by step: You are trying to find information about the WikiLeaks disclosure of diplomatic cables.
Click here [special link, not enabled in ebook] to make DEVONagent Pro run this search for you.
The best choice for a simple but comprehensive search is the pre-fab Web (Fast) search set. It is a multi-purpose search set that sends your query to the three major search engines: Google, Bing, and Yahoo. Alternatively you can choose plugins directly, e.g. the one for Google, in the magnifying glass pop-up menu.
DEVONagent Pro Advantage: You can use advanced Boolean operators and you are not presented by a simple list of links but a pre-processed summary including extracted topics. In addition, DEVONagent Pro queries multiple search engines for you with one single click.
Next steps:
Related topics:
How to search beyond Google
DEVONagent Pro can not only run queries on Google and Bing but comes with a large number of plugins that let it use less common search engines such as FindLaw, PubMed, or Highbeam.
Just choose the right plugin before you start your search from the magnifying glass
pop-up menu in the search field.

Step by step: You are trying to find newspaper articles about the former German defence minister who had to resign because he copied large parts of his doctor thesis.
DEVONagent Pro sends the results to the Highbeam article search engine and presents you with the results.
Click here [special link, not enabled in ebook] to make DEVONagent Pro run this search for you.
Next steps:
Related topics:
How to customize DEVONagent Pro
DEVONagent Pro can be customized to better fit your needs like most other Mac apps. You adjust all of DEVONagent Pro's setting in its Preferences.

Step by step: You want to exclude all links to eBay from the results.
This filters all results with addresses containing the string 'ebay.'
Next steps:
How to set up a search set to crawl feeds
DEVONagent Pro not only queries search engines for you. It can also go searching on its own by "crawling" a given list of webpages or news feeds and scanning them for the search term. This can be handy when you have a number resources that you need to watch, e.g. subject-specific news sites or feeds.

Step by step: You want to search one of the New York Times news feeds.
Repeat steps 6 and 7 for any feeds that you want to add to your "New York Times" search set. You can now use this set like any other search set or plugin. Instead of querying any search engines it will download the current state of all the feeds you have added and search them for occurences of your search term.
Next steps:
Related topics:
How to run a search automatically
Search sets are not only collections of rules about how to run a search. They are also the key to research automation in DEVONagent Pro. Add a default query to a search set and set its scheduler to make DEVONagent Pro run the search fully unattended, e.g. in the middle of the night, and execute chosen actions when it's done.

Step by step: You want to run the "Marketing" search set automatically once every day and send the results to you by email.
As the "Marketing" search set contains a default query on the General tab you are done. Tomorrow morning at 9 a.m. DEVONagent Pro will automagically activate and run a search for the default query of the "Marketing" set. When it is done it will send a summary email to the email address you have entered.
Note: Your Mac needs to be on at the time the search set is about to run. DEVONagent Pro is not able to wake your Mac up when it is sleeping.
Next steps:
Related topics:
How to archive search results
When you have found good data on the Internet very likely you're only half-way there. You will want to keep the best results for future reference. For this DEVONagent Pro comes with a built-in archive.

Step by step: You want to archive all results of a search run.
Step by step: You want to archive some results of a search run.
Alternatively to using Data > Add To Archive, Data > Add All To Archive, and Window > Archive you can use the Add, Add All, and Archive toolbar icons of the search window. You may need to add the tools to the toolbar using View > Customize Toolbar.
Next steps:
Related topics:
Queries
DEVONagent Pro provides powerful Boolean operators that allow one to precisely define a search query.
Queries can range from very simple one-word search terms to complex multi-term queries. The rules for formulating queries are rather simple, and with a bit of study of the rules and the Boolean operators, together with practice, users can 'tell' DEVONagent Pro exactly what to look for in a search.
Operators
Plugin/set selection
To quickly select which plugin or search set DEVONagent Pro uses start the query with the plugin's or search set's name or keyword followed by a colon.
Example: google:devonthink
Case
All terms are case-insensitive. You may, if you wish, use capitalization for proper names in a query, but DEVONagent Pro will ignore case in interpreting the query.
Precedence of terms
Search terms and associated operators will be interpreted from left to right, except as modified by including portions of the query within parentheses.
Boolean operators
The operators (often called Boolean operators) are words or symbols that establish logical rules for the terms in the search query. These are:
Beside the classic Boolean operators, DEVONagent Pro features a number of operators that can usually only be found on high-end databases. Use them as a replacement for AND and "quotes" to fine-tune your query.
Note: See chapter Designing a Search Query for examples on how to use all these operators effectively.
For convenience, some of these operators can also be abbreviated using commonly used symbols:
Note: The symbols above are also used by the Finder and Spotlight for searches. Enter the vertical ruler character for the OR operator by pressing ⇧7, ⇧\ or the appropriate keyboard combination for your keyboard layout.
You can replace parts of words with wildcards matching one, multiple, or a range of characters:
Note: Primary queries only support wildcards for sites, not for plugins or search engines.
Special rules
To search for a word that is also the name of an operator, put the word inside quotation marks. The following example searches all four terms including the word "near":
Example: Beach "near" Los Angeles
Designing a search query
Writing your query as simply and as precisely as possible is the key to good search results. Following are some tips on how to write a good query.
Designing a good query
Suppose you want to search for information about the mercury contamination of fish and to focus on information released by or referring to the United States Environmental Protection Agency.
One problem with trying a simple AND search for a group of words is that the Environmental Protection Agency is referred to in various ways: 'Environmental Protection Agency', 'EPA' and 'E.P.A.'"
If we tried the search string
Example: Environmental AND Protection AND Agency AND EPA AND E.P.A. AND fish AND mercury
we would probably get no results at all, as no single article would use all three terms for the environmental agency. And even if we were to get search results, we would get irrelevant results stemming from the terms environmental, protection and agency.
Here's a better way to design the query:
Example: ("Environmental Protection Agency" OR EPA OR "E.P.A.")
which will pick up the variants in naming the agency in articles. Note that the two strings enclosed in quotation marks will now be treated as phrases. This reduces ambiguity. Also note the use of parentheses and the OR operator. We now cover all three variants of common names used for the environmental agency. DEVONagent Pro will look for pages containing any one of those names.
There's another potential ambiguity, because it's possible that a large reference source might contain the word 'fish' in one section dealing with fishery resources, and contain the word 'mercury' in another section dealing with the history of barometers. We're simply not interested in that item. But if we use the NEAR operator between 'fish' and 'mercury' it's likely that we will get useful results, as this will place the space between the two terms at ten words or less.
The refined query now becomes:
Example: ("Environmental Protection Agency" OR EPA OR "E.P.A.") AND (fish NEAR mercury)
Notice that a second set of parentheses was used, so that DEVONagent Pro won't wrongly interpret the query as requiring that both the environmental agency name and 'fish' must be NEAR 'mercury'. Just that confusion would be created if we had written the query as:
Example: ("Environmental Protection Agency" OR EPA OR "E.P.A." AND fish) NEAR mercury
Indeed, the refined search returned highly relevant pages. Of course, this search focused on literature about mercury contamination of fish in the United States. One could replace the search strings in the first set of parentheses with, e.g., ("European Union" OR EU) to change the geographical focus.
Improving your query
Besides the typical Boolean operators AND, OR and NOT, DEVONagent Pro provides you with the much more powerful NEAR, BEFORE and AFTER operators. Typically, only scientific high-end databases feature them, but DEVONagent Pro makes them available for Web research, also.
Note: Because almost none of the Web search engines support these operators, DEVONagent Pro sends the simpler AND query to them and applies the more sophisticated operators to the resulting pages.
All three operators connect two search terms closer together than AND, but not as tightly as the phrase operator (double quotes). With the additional distance parameter (e.g., NEAR/5) you can also fine-tune the search results until you get only exactly the results you are looking for.
Example: (steve NEAR/2 jobs) BEFORE (intel NEAR (imac OR macbook)) AND "San Francisco"
Connecting 'steve' and 'jobs' with NEAR/2 prevents getting result pages of some Steve looking for a job in his page footer. BEFORE makes sure it's a page that mentions Steve Jobs first and then the Intel Macs. Finally, the quotes around 'San Francisco' find only pages dealing with the city of San Francisco, not the city San José and some Brother Francisco mentioned somewhere else on the page.
Use the proprietary NEAR, BEFORE and AFTER operators when AND delivers too many results and quoting delivers too few. Another example:
Example: document AND management AND mac
This query run with the Web (Fast) search set deliveres good results. But, many are not what we are looking for. Among many good pages, it also finds the Wikipedia article about Mac OS X because it contains all three words. But, of course, this article is not at all about document management on the Mac. But, we can refine this query with the special DEVONagent Pro operators:
Example: document NEAR/2 management NEAR mac
This time, DEVONagent Pro returns fewer results, all of them dealing exactly with our search subject, document management for the Macintosh, because the three words have to be mentioned near to each other in the text. In most cases, NEAR delivers more accurate results than AND.
First principle of a successful query
Make the query precise and unambiguous. DEVONagent Pro's tools for clarifying your query are really quite simple and can help you obtain a high percentage of useful results rather than a confusing mess of irrelevant results.
Search sets
The quality of a query relies not only on the entered search term, but it also relies heavily on the selected settings. Search sets are collections of all the parameters (settings) related to a search run. You use search sets to quickly tweak your settings, depending on what you are searching for on the Internet. This ensures that you always get the best results.
What are search sets?
Search sets are basically collections of all the parameters related to a search run:
Using these settings, you can create search sets specifically tailored for your research needs. For example, you could create your own sets for:
Choosing a search set
Choosing the search set that you want to use for a search run is easy: Click the magnifying glass icon
in a DEVONagent Pro search field and choose a search set from the pop-up menu that appears.
DEVONagent Pro comes with a number of predefined search set but you can easily also create your own.
Creating and managing sets

Search sets can be edited, rearranged, exported, imported or deleted. DEVONagent Pro comes with a couple of useful pre-defined sets, which you can tweak to your needs. Or, you can add new ones for your individual needs. Use Window > Search Sets to open the search set editor.
Note: Some of the settings can also be adjusted on-the-fly in the Settings and Advanced tabs.
The search set editor shows a list of all defined search sets and allows you to add new sets or delete the selected set using the + and - buttons like other Mac OS X applications, e.g., iTunes or iPhoto. Rearrange your search sets using drag-and-drop, and click the name of any set once to change its name.
Note: Some items can be dragged from one search set to another set e.g., URLs from the sites tab.
To change the settings defined in a set, select it in the list and change the parameters in the right-hand pane to fit your needs. Switch between the parameters areas, General, Advanced, Sites, Plugins, Actions, and Schedule by using the tabs above the parameter area.
Shortcut
To create a new search set with exactly the same settings as the current search run, click the + button next to the Stop button in the search window. This creates a new search set with exactly the same settings including the query as the default query.
Action menu
The Action menu, available from the toothwheel button below the search set list, gives you access to additional commands. [Read more...]
The contextual menu gives you direct access to frequently used commands.
Sharing sets
You can easily share search sets with other DEVONagent Pro users. Exported sets using either the contextual menu, the File > Sets menu command, or by simply dragging them e.g. to the Desktop. You can email exported sets and import them again into DEVONagent Pro simply by double-clicking them in the Finder.
General tab
On the General tab, you define the main parameters for this search set such as the default query, which filter and/or which scanner to use.

Default Query: Define a default query for this search set. DEVONagent Pro will automatically fill the query field with the default query, when you select this search set. This is especially useful if you are using either the same query every time you use this search set or if you are running this set on a schedule.
Example: esa AND (mission NEAR "venus express")
Read more about formulating a query here: [Read more...]
Secondary Query: When you enter something here, the primary term (the one that is entered or the default query) is only used for querying the search engines, but not for accepting or rejecting pages. Without a secondary query, DEVONagent Pro uses the primary query for both querying search engines and post-filtering the results.
You can use secondary queries for using different terms for querying the search engines and accepting/rejecting pages. Although the primary query is restricted to ten words, the secondary query is not restricted.
Example: Use the asterisk '*' as your default query to match everything, for example, when scanning a list of websites or RSS feeds; of course, this is not applicable with search engine plugins, only with the Sites list. To accept all pages delivered by a primary query, use the asterisk '*' as secondary query.
These options tell DEVONagent Pro to follow promising links on HTML pages and in news feeds.
Example: 'Devonian Period -County' follows links containing 'Devonian' or 'Period' but not containing 'County'.
Use the slider to define how many levels deep you want DEVONagent Pro to follow links. One or two levels generally make sense, more is often overkill.
Use the text field below the slider to provide an additional search query that defines which links DEVONagent Pro follows. Use this option to fine-tune your settings, if you find that DEVONagent Pro follows meanlingless links due to the construction of the result pages. Generally, you should leave this field blank and let DEVONagent Pro follow all links matching the entered or default query; the automatically chosen term is displayed in this case.
Example: Enter '*' to let DEVONagent Pro follow all links, regardless if their text description matches the query or not.
Express search
Check Express Search to enable 'express' mode. In 'express' mode DEVONagent Pro returns results fast but unfiltered. If unchecked DEVONagent Pro operates in 'agent' mode which is slower but returns post-filtered results and is much more precise and powerful.
Note: Scanners and secondary search terms, the similar pages filter, and following links require 'agent' mode. Some plugins may also require 'agent' mode, other may not support 'express' mode.
Language: Use this pop-up menu to filter out all pages that do not match the selected language (Dutch, German, English,...) or script system (Arabic, Greek, Hebrew,...) This filter does not simply look for language tags in the pages, but actually analyzes the page itself.
Ignore Diacritics: Check this option to automatically convert diacritics for the analysis into a normalized form. This also finds pages which contain German umlauts, French or Czech accents, or other diacritical characters.
Example: Uncheck Ignore Diacritics to search for a word with accented characters when you definitely don't want to find the unaccented variant.
Fuzzy: Check to search 'fuzzy'. This also finds words with similar but not identical spelling, e.g. 'gray' instead of 'grey'.
Filters: Check the following filters to automatically filter out special pages you don't want to include in the results list:
Scanner: Scanner plugins post-process and filter the list of found pages by formal criteria. Read more about about scanners in the appendix.
Example: Use the powerful feature unique to DEVONagent Pro to filter, for example, all pages except those containing a thumbnail gallery, linking to Office documents or containing email addresses.
Comments
Enter a brief description for a search set here. This description is shown in the tool tips of the magnifier pop-up menu in a search window.
Advanced tab
On the Advanced tab, you define in which parts of webpages DEVONagent Pro searches, which type of files it searches, and whether it accepts all pages or only new results in a search run.

Search in
Choose which parts of a document DEVONagent Pro searches for the query. Not all file types have all characteristics.
Files
Choose which file types DEVONagent Pro searches and accepts as results.
Results
Choose if you want DEVONagent Pro to accept only on new pages as results or all found pages.
DEVONagent Pro keeps an internal log of found results to recognize what's new. It also lists the number of results stored in the log. To clear the internal log, click the Reset button.
Sites tab
The Sites tab allows you to define a list of webpages that DEVONagent Pro scans when you use this search set. DEVONagent Pro downloads each of these pages and tests whether it matches your query or not, like your private little Google. Use it together with the default query to scan your frequently visited pages for important keywords.

Managing the Sites List
To add a page to the list, enter the URL into the location field at the bottom of the window. If the page requires a user name and password, enter them into the appropriate fields. Click the + button to add the page. To remove a page, select it in the list and click the - button.
You can also use drag-and-drop or copy/paste to add URLs to the sites list, and use the contextual menu to open the page in a browser window or copy the URL. This also adds the title of the page to the Info column if possible. You can copy URLs in this list to the clipboard or drag them to other applications, too.
You can use ranges like [01-31] or [1-31] to quickly add whole ranges of URLs. Add e.g. "http://www.classicfm.nl/playlist/per-dag/201202[01-29]" to add all playlist from .../20120201 through …|20120229.
Uncheck a page to exclude it temporarily from being scanned, check it to include it in the next search run.
Taking over URLs
To take over bookmarks from other applications and create new search sets from them, use drag-and-drop, copy/paste, or import bookmarks or OPML files. Open the settings editor and use File > Import or the Action menu to import bookmarks from Camino, Firefox, OmniWeb or Safari, as well as OPML files generated by news readers or DEVONthink.
Contextual menu
The contextual menu allows you to work with website addresses selected in the sites list.
Plugins tab
The Plugins tab defines which plugins (interfaces to search engines) DEVONagent Pro uses when you use this search set in the search window.

Plugin List
The plugins are grouped. Expand or collapse groups by clicking the grey triangle in front of the group name, like in the Finder. Check all plugins that you want DEVONagent Pro to use for this search set, uncheck all others. Check or uncheck a group to check or uncheck all plugins contained in it. Select a plugin to display a short description.
To find out which search engines a plugin uses to get results, use Window > Plugins & Scanners or see the appendix.
Example: Check "Images", "Info (Pictures)" and "Picsearch (Images)" to search all major picture search engines.
Results per Plugin
This value defines the number of results delivered by every plugin. It limits the result pool to the most relevant <n> results. Adjust this to whatever suits your requirements, the default value is 100.
Actions tab
The Actions tab enables you to attach additional actions to a search set that DEVONagent Pro executes after finishing a search run with this search set.

Interface
Results
Note: The email function uses the email account defined in Preferences, Email tab.
Schedule tab
The Schedule tab is what makes DEVONagent Pro a real information agent. It lets you schedule automatic query runs every hour, day or week and return the results by email, archive them internally or add them to your DEVONthink database.

Note: A scheduled search set uses the default query you enter on the "General" tab and runs this at the scheduled time. So, make sure to enter a default query when you use the scheduler.
Frequency, ...
Options
Menus
A complete listing of all commands DEVONagent Pro offers in the menu bar, the global Services menu, and the handy Dock menu.
The DEVONagent Pro menu
The DEVONagent Pro menu is similar to the application menu in any other Mac OS X application. It contains commands for displaying the splash screen, opening the preferences window, accessing the Services menu, hiding and showing windows, and, of course, quitting the application.
About DEVONagent Pro, ...
Note: For the check for updates no information is uploaded to the DEVONtechnologies server. DEVONagent Pro only downloads a file listing the most current versions to your Mac.
Purchase, ...
Note: Enter License changes into License as soon as you have entered a valid license code.
Services
The File menu
The "File" menu contains all commands that create new windows, open or save files or settings, and printing.
New Browser, ...
Page Setup, Print
The Edit menu
The "Edit" menu contains all commands and options relating to editing. You'll find the classic Mac cut/copy/paste and find/replace commands here, as well as many more.
Undo, Redo
Find
This sub-menu contains commands for finding and replacing text. In most parts it is similar to the Find command in most Mac application sbut also contains some DEVONagent Pro-specific items.
Spelling, ...
The Data menu
The Data menu provides commands for opening search results, exporting them to DEVONthink, archiving them, or organzing them in the built-in archive.
DEVONagent Pro adds 'DEVONagent Pro plus the name of the plugin used to find the page and its version to the comments when adding to DEVONthink.
Note: Use Delete and Delete & Exclude Domain with care. You cannot undo these commands.
The Sort menu
The Sort menu sorts search results in a variety of ways.
Unsorted, By Name, ...:
Top Level Domain means the last part of a website address. Usually it is defined by the country the website is located in, e.g., '.de' for Germany or '.cz' for the Czech Republic, or by function, such as '.com' for a world-wide commercial site or '.mil' for a US military site.
Relevance is the relevance of a result compared to the all collected results in respect to the query. This is the default sorting order.
Ascending, Descending:
The View menu
The View menu allows to switch between the various tabs of a Search window, to switch Cover Flow on and off, and to customize how objects are presented in web browser windows.
Digest, ...
Summary, Objects
The Web menu
The Web menu contains all commands that are directly related to Web browsing, from quickly switching Java on or off to switching between views and reloading a webpage. All commands in this menu act on the frontmost web browser window.
Enable Plugins, ...
Use these options to quickly switch plugins, Java, or JavaScript on and off without visiting the Preferences.
These three options switch the mode of the frontmost web browser window between different modes. Use these modes to view only the raw text of a layout-intensive webpage, or to switch to the source code to find information that is hidden in the code but not visible in the layout. DEVONagent Pro displays the source code with syntax coloring. The text only mode is also useful for copying/extracting information from pages with a complex table layout.
The History menu
As with any web browser, the History menu lists all webpages previously visited, divided into sub-folders for each day.
Back, Forward, Clear History
Visited webpages
The rest of the History menu lists the previously visited webpages, sorted from the top by their age.
The Go menu
The Go menu contains commands for navigating back and forth through all of the results of a results list in a search window or occurrences of a search word, as well as using and managing bookmarks.
Next/Previous Result/Occurrence
Besides the commands mentioned above, the Go menu gives you access to the bookmarks of Safari, Camino, Firefox, or OmniWeb, or DEVONagent Pro's own bookmarks list. Select which bookmarks DEVONagent Pro shows in the Go menu in the preferences.
For these commands to work a web browser window needs to be active and DEVONagent Pro use its own bookmarks. You cannot yet edit e.g. Safari's bookmarks from within DEVONagent Pro.
Bonjour
The Bonjour part of the Go menu lists web services advertised on the local network via Bonjour, e.g., printers with web interfaces or shared DEVONthink Pro Office databases.
Workspaces save the content and positions of all open windows so that you can restore them later. This is, e.g., ideal if you are working with the same set of windows over and over again. Save them as a workspace and recall them whenever you need them again.
The Window menu
As in any Mac application, the Window menu lists all open windows of DEVONagent Pro and gives you access to commands for managing them.
Window Commands:
Tab Commands:
Archive ... Downloads:
The Services menu
The Application > Services menu (where 'Application' is the name of the frontmost application) allows access to special commands published either by other Mac OS X applications, such as TextEdit or Safari, or by services extensions such as DEVONtechnologies' WordService or CalcService. Also, DEVONagent Pro publishes its own services in the Services menu.
The Services menu is a sub-menu of every application's application menu, the menu named after the application itself and carrying the About X, Hide ... and Quit commands. Services usually act on a selection, e.g. selected text or files.
Services provided by DEVONagent Pro:
Use Application > Services > Services Preferences to change keyboard shortcuts or hide selected commands to clean up the Services menu.
Note: After installing DEVONagent Pro you may need to log out and back in again for the Finder to recognize the new Services menu commands and shortcuts. If one or more DEVONagent Pro Services menu commands does not have a keyboard shortcut assigned to them, perhaps another application grabbed it. Mac OS X automatically assigns the correct shortcut when no other application asks for the same key combination.
The Scripts menu
The Scripts menu is located left of the Help menu and shows a graphic AppleScript 'S' symbol instead of a normal menu title. It contains a collection of useful, predefined AppleScripts you can use directly from within DEVONagent Pro.
Some of the scripts work without a selected document, others require you to select the document you want the script to interact with. In general, the script will tell you what you have to do when you select it from the Scripts menu.
The Help menu
The Help menu contains commands for opening the integrated help pages, the support assistant, or visiting the DEVONtechnologies website.
DEVONagent Pro Help
These commands open the integrated help pages that are equal to the document you're just reading or open the release notes.
Opens the support area of the Welcome to DEVONagent Pro assistant where you can e.g. read the FAQ, visit the user forum, download this documentation as printable or screen-readable PDFs, retrieve your license code, request a trial extension, or update your details in DEVONtechnologies' customer database. Choose Tutorials to directly open the assistant on the Tips & Tutorials page.
Click here [special link, not enabled in ebook] to directly open the assistant.
Note: If you have purchased DEVONagent Pro on the Mac App Store all options dealing with licenses or upgrades are not available.
DEVONtechnologies
These commands take you directly to the corresponding pages on the DEVONtechnologies website. Visit our home page or the lively user forum. If you have a question or suggestion, send feedback directly to our development team.
The Dock menu
The Dock menu appears when you ⌃-click or right-click DEVONagent Pro's icon in the Dock. In addition, DEVONagent Pro's icon hows a badge with the number of found results.

For all Mac OS X applications, the Dock menu provides a selection of the commands of the application menu.
Besides these standard commands, DEVONagent Pro adds a number of its own commands to the Dock menu to make them easily accessible, whenever the application is running.
The contextual menu extension
DEVONagent Pro installs its own contextual menu plugin. It inserts a Search in DEVONagent Pro menu item into the contextual menu of most Cocoa and Carbon applications.

Select some text, such as in an email, webpage or Pages document, ⌃-click or right-click the selection and select "Find with DEVONagent Pro. DEVONagent Pro opens a new search window with the selected text pre-filled into the query field.
Note: As Mac OS X 10.6 inserts the Services menu system-wide into the contextual menu, this extension is only installed on Mac OS X 10.5.
Windows and panels
DEVONagent Pro uses a number of different windows for running search queries, displaying webpages, setting up search sets or downloading files.
Search window

The search window is where you start search runs and work with the results. You open a new search window with File > New Search In its minimized form, the search window consists only of an entry field for the query, including a pop-up menu for selecting the search sets to be used, a Start/Stop button, and an Append button. In maximized form, it is divided into three tabs: digest, pages, and log. You can switch between minimized and maximized form by clicking the green window gadget. Also, you can choose whether you want to open new search windows as either minimized or maximized in the preferences, "General" tab.
To start a search run, select the correct search set from the magnifier pop-up menu in the entry field, enter your query and click the Start button. DEVONagent Pro then queries all search engines and scans all webpages defined by the search set. As soon as the search run has finished (or you have clicked the Stop button), DEVONagent Pro expands the search window, if necessary, and presents the results in either the Digest or the Results tab, depending on your preferences.
If you had already performed a search run, you can also use the Append button instead of Start to append the search results to the already collected ones instead of replacing them.
Note: DEVONagent Pro limites search runs to 500.000 result pages and 32 GB of data. This prevents flooding your hard disk when your search query or your Follow Links settings are too broad.
The magnifying pop-glass up menu
lets you select the search set you want to use for your search. For a general search, use the search set Web (Fast). You can define your own search sets in the Search Sets window which you can also open by selecting Edit Search Sets from the magnifier pop-up menu.
User-defined plugins are listed in bold.
Note: You can easily create a new search set by using the + button left of the search term field. Use this to run the same query with exactly the same settings again in the future.
Plugins: In addition, this pop-up menu gives you direct access to every installed plugin. This way, you don't have to define a search set just for querying a special search engine once. You can simply pick the one you want to use, enter the query and hit the Start button. Tool tips give you more information about each plugin.
Recent searches: Finally, the magnifying glass pop-up remembers the last 25 search terms (when private browsing is not enabled). You recall them simply by selecting them from the Recent Searches part of the menu. Remember to select the correct search set or plugin.
Status bar
The status bar below the search field shows information about the number and size of the downloaded files and found results and objects as well as unread results.
DEVONagent Pro's search window is divided into three views that present different aspects of the information that has been collected in a search run. You switch between the views by clicking the tabs that separate the search field from the rest of the window.
The digest differs from what traditional search engines and applications display. It is what makes DEVONagent Pro unique. Instead of simply listing the URLs of found pages, the digest shows a list of topic words and two-word expressions that DEVONagent Pro has extracted from the collected data. This list not only includes the entered search words, but also many other words that the artifical intelligence core of DEVONagent Pro found to be important and related to the query. You can sort this list by topic or relevance by clicking the column headers. The number of sentences with occurences is shown for each topic word.

Topics map: In the right hand side pane, DEVONagent Pro first shows short paragraphs from every found webpage, until you select one or more topic words. DEVONagent Pro shows an AI-generated visual representation of the selected topic and its relations to other topics in a mind-map style. Two-word expressions do not show a topics map; for multiple selected topic words DEVONagent Pro always picks the top one.
The selected topic becomes a big blob in the center of the map with all related topics arranged around it. The larger a blob and the more orange or red it is, the more important it is. Topics related to the selected word but that are not part of the topics list on the left, are shown in blue. Light grey lines show closer relationships between topics. Move the mouse over the topic blobs to highlight the connetions to other topics in the graph; click a blob to select it. Double-click a topic in the map to make it the center of the graph. DEVONagent Pro will recalculate the map accordingly. This is similar to selecting another topic word from the list to the left.
Using the arrow buttons in the bottom bar of the topics map area you navigate back and forth through the results in the digest.
Summary: Finally, below the topics map, DEVONagent Pro shows a summary of the extracted information sorted by relevance. At the end of each extract, you'll also find a link to the original source where DEVONagent Pro extracted the data from (click the link with ⌘ held to open it on a new tab instead of in a new window.) The summary delivers the actual answer to your query, effectively eliminating the need to go through a long list of links and visit hundreds of webpages manually.
This summary dynamically changes with whatever topic word or words you select in either the left hand side pane or the topics map. This way, you can use the topics map to navigate through the found information and re-focus the summary to whatever you are interested in. You can also click words in the summary with ⌥ held to refocus the topics map on the clicked word.
Note: You can also select multiple topics with the ⇧ and ⌘ keys, or enter your own keywords, separated by spaces, into the text field below the topics list. For the topics map, DEVONagent Pro will only use the first selected topic word. It does not work with words you enter into the keyword text field.
List or Cover Flow: The Pages tab is similar to what most search engines deliver, a list of all found URLs including the name of the webpage and a two lines excerpt from where on the page the search terms are found. Sort the list by all the criteria that you can find in the Sort menu. You can also drag results to DEVONthink to quickly archive them in your database.

You can browse the results also with Cover Flow. Double-click a page in Cover Flow to open it in a new web browser window; hold the ⌘ key to open the new window in the background.
All pages that you haven't checked yet show a dot in front of them, similar to unread messages in Apple Mail. You can also select results, drag them to other applications, such as an open TextEdit window, DEVONthink, or the Finder, or delete pages from the list that you have found to be unrelated to your research. A badge shows the number of found scanner objects.
Preview area: In the lower pane of the Pages tab, DEVONagent Pro displays either a text preview of the relevant text passages for pages selected in the list above, or all objects found by the automatically applied scanners . Switch between the text preview and the objects returned by the scanners using the navigation bar above the preview.
In addition you switch between small and large icons, download all or selected objects, and access the action menu from the navigation bar.
The Log tab lists all pages that DEVONagent Pro has skipped.
DEVONagent Pro skipped them because they:
You can find a complete list of all codes used in the log in the appendix.
Effectively, the log lists all pages you did not have to look at yourself because DEVONagent Pro did that job for you.

You can sort the list by date, address, or error message by clicking the respective column headers. Click them again to reverse the sorting order. Use copy-and-paste or drag-and-drop to e.g. move or copy URLs to the Downloads panel, to a search set, to DEVONthink, or other applications, e.g. Safari.
The Settings tab contains some of the options from the General and Advanced of search sets and overrides these settings TEMPORARILY.

The Settings tabs offers the following options:
Use the Settings tab to temporarily enable or disable options, for example to switch on a scanner without permanently messing up the search set.
Toolbar
The toolbar of DEVONagent Pro's main windows carries many commands for manipulating the way it displays information and for manipulating selected items. Many of them are simply shortcuts for menu bar commands. Here's a short list of the available tools:
Note: Not all of these commands are always available. You can customize the toolbar by selecting Viiew > Customize Toolbar or by Control- or right-clicking the toolbar background and selecting Customize Toolbar from the contextual menu.
Shortcuts & modifier keys
Like any Mac application, DEVONagent Pro uses modifier keys or shortcuts to quickly access frequently used functions or modifying a standard behavior.
Contextual menu
The contextual menu, which appears when you click something with the right mouse button or when you click while holding the ⌃ Control key down, offers a range of commands tailored to what you can do with the clicked object, for example a text passage.
Most of the commands offered by the contextual menu have counterparts in a main menu, so you'll recognize them immediately. However, to save menu bar real estate, DEVONagent Pro gives you access to some options only via the contextual menu.
In text areas, e.g., the text preview on the "Pages" tab, DEVONagent Pro also offers the standard contextual menu commands for text views:
Web browser

Besides being a research tool, DEVONagent Pro is a full-fledged web browser, based on the Safari engine (a.k.a. 'WebKit'). Open a new web browser window by choosing File > New Browser, clicking a link, or by choosing File > Open Location when no web browser window is frontmost.
To visit a website, enter its address into the address field of the toolbar and press ⏎ or Enter. Alternatively, drag a URL to DEVONagent Pro's application icon in the Finder or in the Dock, or into an open browser window.
Instead of a URL you can use keywords to directly send a simple query to a search engine. This effectively replaces the Google search field found in Safari and others. The keywords are defined by the plugins, but can be individually edited.
Example: Enter 'google apple computer' to query Google for 'apple computer'; enter 'mu devonthink' to query MacUpdate for 'devonthink'.
The tab bar below the toolbar lists all tabs of the web browser window. Each tab contains a different webpage. Use tabs to open multiple webpages without cluttering your screen with dozens of separate windows. Switch between tabs by simply clicking the tab you want to bring to the foreground. If all tab do not fit into the available space DEVONagent Pro shows an optional pop-up menu at the right hand side of the tab bar listing all available tabs.
Point to a tab for once second without clicking to shows a tooltip with a thumbnail preview of the webpage displayed on the tab. This is useful when you cannot remember which page you opened on which tab.
Inactive tabs show a close button instead of the webpage icon. Also, after the last tab, DEVONagent Pro shows a "+" button for creating new, empty tabs.
The toolbar of a web browser window can be customized like any other toolbar using View > Customize Toolbar. The following tools are available:
If a bookmark for the current page exists in the open DEVONthink Pro databases a small DEVONthink icon is shown on the right hand side of the address field.
The sidebar is the place in a web browser window where all additional information is presented, from bookmarks to the list of search results (if the page is part of the results of a current search run) and extracted objects. The sidebar is divided into several sub-tabs:
Bookmarks: Use the Preferences to choose what bookmarks and additional elements, e.g. Web servers announced via Bonjour, DEVONthink Pro bookmarks, or workspaces, are listed on the Bookmarks pane. If you are using DEVONagent Pro for your bookmark management use e.g. cut/copy/paste, drag-and-drop, or the contextual menu (see below) to edit your bookmarks.
Results: The Results pane lists all results of the search run the shown webpage belongs to. This pane is unavailable if the page does not belong to a currently open search run.
In addition, none, one, or multiple of the following tabs, unique to DEVONagent Pro, can be available:
Which, if any, of the above tabs are available depends on the webpage shown in the window. DEVONagent Pro collects all objects from the page using the available scanners and lists them in separate tabs in the sidebar. Click any found object to display it (double-click to open it in a new tab, if tabbed browsing is enabled, or a new browser window). Click with ⌘ pressed to open the result in a new tab. The Back button brings you back to the original page.
Bottom bar: The bar at the bottom of the sidebar gives you access to commonly used commands, depending on which tab is active.
Contextual menu: The contextual menu gives you direct access to commands acting on the selected items. Commands are only available when applicable.
The action menu (labeled with a toothwheel icon) makes frequently used commands conveniently accessible from the toolbar.
The See Also pane opens when you click the See Also button in the toolbar. It lists other pages related to the displayed page from three sources:
Click any item in the pane to display it; double-clicking opens it in a new tab or window. The original page stays at the top of the list so that you can easily go back to it at any time. Results from DEVONthink that have a URL associated with are also shown with a single click; results without URL open in DEVONthink on a double-click.
Shortcuts & modifier keys
Contextual menu
The contextual menu, which appears when you click something with the right mouse button or when you click while holding the ⌃ Control key down, offers a range of commands tailored to what you can do with the clicked object, for example a text passage.
Most of the commands offered by the contextual menu have counterparts in a main menu, so you'll recognize them immediately. However, to save menu bar real estate, DEVONagent Pro gives you access to some options only via the contextual menu.
If the WebKit developer extras are enabled more options are available.
When you ⌃-click or right-click the background of the page instead of a item, additional options can be available:
For PDF pages, different options become available:
On the Results pane of the sidebar the following additional options are available:
Archive window

The integrated archive is where you can store found pages for later reference. Open the Archive window with Window > Archive.
The archive resembles the three panes view of Apple Mail or DEVONthink: The left pane shows a list of groups, the right top pane displays page titles and URLs in a selected group, and the right bottom pane displays textual information related to the query that was used for finding a selected page. A search field in the toolbar allows you to search the archive by content, name or URL.
Groups
All archived pages are stored in groups. Groups are automatically created when you archive pages from the search window and are named after the search query. You can change group names at any time, delete groups or manually create new ones. You can also create sub-groups by selecting a group and then creating a new one. The number of items contained in a group is shown as a badge.
Note: Pages not related to a previous search run are archived in sub-groups of a top-level group named 'Incoming'. The sub-groups are named with the current date.
Create new groups by using the toolbar, the contextual menu or Data > New Group. Rename a group by clicking it once and waiting a second (like the Finder), or by selecting it and pressing the ⏎ or Enter key. Delete a group by selecting it and pressing Backspace, using the toolbar, the contextual menu or Data > Delete. To make a group a sub-group, drag it with the mouse or use the contextual menu.
Sort the groups by name or date with Sort > by Name or Sort > by Date. Reverse the sorting order with Sort > Ascending/Descending.
Pages
Like DEVONthink or Apple Mail, DEVONagent Pro shows the pages filed in a group when you select the group in the left pane. Select a page, and DEVONagent Pro also shows a text preview in the lower right pane with the original search words highlighted.
Rename a page by clicking it once and waiting a second (like the Finder), or by selecting it and pressing the ⏎ or Enter key. Delete an item by selecting it and pressing Backspace, using the toolbar, the contextual menu or Data > Delete. To move an item to another group, drag it or use the contextual menu. Items can also be dragged to DEVONthink.
To sort the pages list, click the relevance (first), title, URL or date column header. Click again to reverse the sorting order. The relevance column is only used when you search the archive using the toolbar search field.
Toolbar
The toolbar of DEVONagent Pro archive windows carries many commands for manipulating the way it displays information and for manipulating selected items. Many of them are simply shortcuts for menu bar commands. Here's a short list of the available tools:
Note: Not all of these commands are always available. You can customize the toolbar by selecting View > Customize Toolbar or by ⌃-clicking or right-clicking the toolbar background and selecting Customize Toolbar from the contextual menu.
Shortcuts & modifier keys
Like any Mac application, DEVONagent Pro uses modifier keys or shortcuts to quickly access frequently used functions or modifying a standard behavior.
Contextual menu
The contextual menu, which appears when you click something with the right mouse button or when you click while holding the ⌃ Control key down, offers a range of commands tailored for what you can do with the clicked object, forexample a text passage.
Most ofthe commands offered by the contextual menu have counterparts in a main menu, so you'll recognize them immediately. However, to save menu bar real estate, DEVONagent Pro gives you access to some options only via the contextual menu.
Search sets
The Search Set window is available via Window > Search Sets. Use it to modify the existing search sets or create new ones specifically tailored for your needs.
Because search sets are so important, we have created an extra chapter just about the search sets and the search sets editor. [Read more...]
Plugins and scanners
The Plugins & Scanners panel, available via Window > Plugins & Scanners, lists all installed plugins and scanners and shows additional information about them, for example their type, version and purpose. In addition it allows you to create new plugins for your favorite websites and search engines.

Also, you can enable or disable plugins or whole groups of plugins by checking or unchecking them. Use this to simplify the magnifying glass pop-up menu in the search window or the plugin list in the Search Sets window.
Plugins & Scanners
All plugins and scanners are arranged in groups. Click the grey triangle in front of a group to expand it, click it again to close it. Select a plugin or scanner to show additional information:
Name, info, identifier, description, and keywords of self-made XML plugins can be edited. User-defined plugins as well as the groups Browser, DEVONsphere, and Scanner are shown in bold.
Note: The group hierarchy is predefined and cannot be manually altered. If you have installed your own plugins, they appear in the top level of the hierarchy or are mirrored-in following the folder structure in '~/Library/Application Support/DEVONagent/Plugins/'.
Keywords are shortcuts that you can use to query the search engines defined by the plugin from the address bar of a web browser window.
Example: The Bing plugin comes with the predefined keyword 'bing'. To send a query to Bing, type e.g., 'bing devonthink' into the address bar of a DEVONagent Pro web browser window and press ⏎ or Enter.
This effectively replaces the search engine field that can be found in other web browsers, such as Safari, with a far more flexible approach. You can add your own keyword(s) to most plugins, separated by spaces, to make them quickly accessable from any open DEVONagent Pro browser window.
In addition the plugin's name is automatically used as keyword, too.
Using DEVONagent Pro's built-in plugin assistant you can easily create your own XML-based search plugin for your favorite search engine. To create your own plugin, choose File & New Plugin or use the New toolbar icon.
In the appearing sheet enter:
To get the URL for your search engine, run a search in your web browser, copy the URL, and paste it into the URL field of the to-be-created plugin. Then look for the URL parameter that transports the query, e.g. something like '&query=xxx'. Replace 'xxx' with '_agentQuery_'. This tells DEVONagent Pro where to enter the search term. The '_agentNumber_' and '_agentOffset_' placeholders are automatically inserted if necessary and possible. [Read more...]
Alternatively, if you want to create a plugin that simply searches a website, enter just the URL of the website. DEVONagent Pro will use standard search engines such as Google to run a site-specific search when you use this plugin.
DEVONagent Pro selects the Website or Search Engine radio buttons automatically, depending on the entered URL.
To test a build-in or self-created plugin use the Test toolbar icon. DEVONagent Pro will send 'Test' as the standard search term to the plugin and present you with the list of returned pages. Double-click results to view them in a new web browser window. Only XML plugins using 'EngineUrl' can be tested as testing XML plugins using 'EngineSite' is not necessary.
To edit and existing XML-based plugin double-click it or use the Edit toolbar icon. DEVONagent Pro shows an XML text editor with error checking that allows you directly edit the source code of the plugin. [Read more...]
The toolbar of the Plugins & Scanners windows lets you easily create new plugins, edit, test, and delete them.
Contextual menu
The contextual menu, which appears when you click something with the right mouse button or when you click while holding the ⌃ Control key down, offers a range of commands tailored for what you can do with the clicked object, forexample a text passage.
The test sheet also presents the following options in the contuextual menu:
Downloads
Window > Downloads opens the Downloads window. Use it to download files from the Internet to your computer. The download URL is automatically placed into the Finder comment of the downloaded file as well as in the 'kMDItemWhereFroms' extended file system attribute.

For URLs that require authentication, DEVONagent Pro asks for username and password. It also uses the system-wide cookies, and can start and stop downloads at any time.
Adding, resuming, retrying
To add files to the download manager, drag a link to the item from any DEVONagent Pro web browser window or any other application to the download manager window, paste a copied URL or ⌃-click a link in a DEVONagent Pro web browser window and choose "Add to Download Manager". ⌥-clicking links in the web browser or the objects drawer adds items to the download manager, too. Also, DEVONagent Pro automatically puts files it cannot display into the download manager, if you double-click them, e.g., .zip archive files.
DEVONagent Pro downloads files added to the download manager immediately. To remove a file from the download manager, select it and click the - button at the bottom of the window. To temporarily prevent an item from being downloaded, uncheck the checkbox in front of it. Check the checkbox to download the item. Use this to add items to the download queue, but download them later.
To resume or retry a failed download, select the file and click the back arrow button. Use the start/stop button (resembles the start/pause button of a VCR or tape player), to start or stop the entire queue.
You can also drag items from the download manager to other windows or to the Finder, or copy it to the clipboard. Drag-and-drop will send the URL of the item to the target window or application.
The action menu provides the same options as the contextual menu.
Contextual menu
The contextual menu, which appears when you click something with the right mouse button or when you click while holding the ⌃ Control key down, offers a range of commands tailored to what you can do with the clicked object.
Preferences
The Preferences window is, like in any Mac OS X application, available via DEVONagent Pro > Preferences. It contains all available options that you can modify to adapt DEVONagent Pro to your personal needs.
Because the preferences are so important, we have created a chapter just for them. [Read more...]
Assistant
The integrated Assistant combines a welcome screen with tips, tricks, and tutorials, installable extras, and a suppport page that guides you through the available support options.
Click here [special link, not enabled in ebook] to directly open the assistant.

Welcome
This screen welcomes you when you start DEVONagent Pro for the very first time. It offers:
You can access all other screens of the assistant from here, too.
Get support
The support screen guides you through the three common steps for troubleshooting DEVONagent Pro. In addition you can have your license code resent in case you don't have it anymore, request a trial extension, update your details in DEVONtechnologies' customer database, or buy an upgrade or a second license.
Tips and tutorials
Here you can always find the latest tips sand tutorials that help you squeeze the best out of DEVONagent Pro. Tutorials can be slideshows describing basic tasks in DEVONagent Pro or videos (as they become available).
Both tips and tutorials are updated live from DEVONtechnologies' server so it's a good idea to check back from time to time. The latest tip or tutorial is also always mentioned on the welcome screen.
Install extras

On the extras screen DEVONagent Pro lists all available extras that you can download and install from DEVONtechnologies' server:
Browse the list of extras and install them with the Install button. The last line of the description shows where in e.g. the Scripts menu or Plugins hierarchy the extra will show up after installation. Remove installed extras with the Remove button.
The extras are updated live from DEVONtechnologies' server so it's a good idea to check back from time to time. The latest extra is also always mentioned on the welcome screen.
Note: If one of these categories does not show up in your copy of DEVONagent Pro there might be no extras of this type (yet) available for DEVONagent Pro.
Preferences
The preferences window, which you open by selecting Preferences in the DEVONagent Pro menu, is the place where you change all global settings of DEVONagent Pro.
For your convenience, the preference panel is divided into tabs, just like System preferences. Select the tab you want to check or modify with the icons at the top of the preferences window.
General

This tab contains all options modifying the user interface and the summarization of search results.
Interface
These options define some parts of DEVONagent Pro's visual appearance.
This option defines which tab DEVONagent Pro shall show when a search run is done.
Summarization
These options define how DEVONagent Pro creates summaries.
Startup
These options let you define what DEVONagent Pro does when you open it.
Home page, ...
These options define the default home page and the folder for downloaded files.
Fonts
Define the fonts you want to use for searching and reading texts. Click the Select buttons to open the standard Mac OS X font panel.
Search
This tab contains all options dealing with the cache, the number of connections, and domains excluded from searching.

General
Create Previews
Choose whether DEVONagent Pro should create previews of visited or found pages immediately or just on demand, and how it generates thumbnails of webpages.
Note: DEVONagent Pro never sends more than just the URLs of the to-be-thumbnailed webpages to Thumbshots.com.
Max. Connections
Use this parameter to adjust the number of connections DEVONagent Pro uses concurrently to match the speed of your Internet connection and your computer.
Choose how large files can be that DEVONagent Pro downloads in search runs. Adjust this to your Internet connection speed. Files skipped due to file size are marked as "Too big" in the log tab of the search window.
Exclude Domains, …
Exclude Domains: Enter all domains you want to exclude from searching in this text field, separated by returns. Use this to exclude domains blocking automatic bots like DEVONagent Pro, e.g., 'sciencemag.org' or 'slashdot.org', or to ignore sites you don't like (for example 'google.com'). Domains skipped because they match one or more entries in this list are marked as 'Skipped' in the Log tab of the Search window.
Exclude Links: Enter URLs you want to exclude from being searched.
Note: Both fields also accept the '*' wildcards at the beginning or end of lines.
Menu extra
The options in this tab determine if DEVONagent Pro's menu extra is automatically started when you log into your account, if the menu should show icon previews, how results are opened when they are selected, and what hotkey you want to use to call the menu.

General
Search
In both cases DEVONagent Pro uses its unique artificial intelligence technology to rank the results, in Express mode only based on title, address, and a short summary, in Agent mode based on the full text of the page.
Open Results
Hotkey
Click the button to record any key combination you like to call the menu extra. Use the hotkey to open the menu extra also in OS X 10.7 Lion's fullscreen mode.
Web
The options in this tab resemble the settings of most web browsers. They define how DEVONagent Pro's built-in web browser windows display HTML documents and live webpages.

Web Content
These settings define how DEVONagent Pro treats some special Web contents.
Images
Use these otions to define how DEVONagent Pro displays graphics in webpages.
Accept Cookies
Cookies are little text files with information that webpages store on your computer, for example to recognize you as a returning customer. While most of them are harmless, you may want to have control over what is being stored on your hard disk.
Note: Delete cookies on quit deletes the cookies for all WebKit-based web browsers including Safari. All these browsers use the same single cookie file.
Standard/Fixed-width font
Set the font you want to use for displaying webpages, separately for variable-width and fixed-width text.
(Feed) Style Sheet
You can further control the way DEVONagent Pro displays webpages by applying a CSS style sheed for changing the rendering on-the-fly.
Note: Applying an external CSS style sheet to webpages is an expert option. It heavily affects the rendering of all webpages in DEVONagent Pro. It does not interfere with the search functionality of DEVONagent Pro, though.
Text Encoding
Select your desired text encoding for displaying webpages. Generally the default setting, Automatic should work fine. If not, choose a more appropriate text encoding for your language.
Enable to use the standard WebKit developers extras in web browser, e.g. the element inspector or the JavaScript console.
Tabs
Like many modern web browsers, DEVONagent Pro features tabbed browsing. This enables you to display multiple webpages in one web browser window and switch between them with tabs.

Use the following settings to activate tabbed browsing and define additional options. They resemble those also available in Apple Safari.
Note: The lower part of the preference window shows the keyboard commands for creating new tabs or opening links in new tabs, similar to Apple Safari. The keyboard commands may change with the options you select above.
Bookmarks
DEVONagent Pro makes the bookmarks defined in your favourite web browser available both in the Go menu and in a bookmark drawer in web browser windows.

Bookmarks
Select your favourite browser:
DEVONagent Pro comes with its own bookmark management. Choose DEVONagent Pro in the list to use the integrated bookmark management. [Read more...]
Bookmarks bar
Select whether DEVONagent Pro automatically mirrors Web servers announced via Bonjour, bookmarks stored in DEVONthink Pro, and workspaces in the bookmarks pane in a web browser windows sidebar or the Go menu.
Bookmarks menu
Select if you want to include Bonjour servicesin the Go menu.
DEVONagent Pro can send you reports of schedules search runs by email. Tell DEVONagent Pro how it shall send you messages on this tab.

Send Email
Choose if you want DEVONagent Pro to send you email using Apple Mail or using the built-in email function. If you don't use Apple Mail add your email account details:
Email Font
Set the font used for styled emails (rich text). Check Send styled emails to let DEVONagent Pro send summary emails as RTF text. Read more about sending summary email messages here.
Update
Change the settings on this tab to choose when you want DEVONagent Pro to check for new versions: never, on startup, daily, weekly or monthly. DEVONagent Pro only performs checks for updates when the computer is connected to the Internet.

Click Check Now to immediately check for a new version.
Note: Disable the check for new versions when your network connection is unstable and you experience very long delays when opening DEVONagent Pro.
Widgets & menu extra
DEVONagent Pro comes with a menu extra and a Dashboard widget that allow you to enter a query and start a search run at any time from either the menu bar or the Dashboard.
Menu extra
DEVONagent Pro adds a
menu extra to the right-hand side of the menu bar.

It looks similar to the Spotlight menu and works pretty similar:
DEVONagent Pro runs the query and shows the results in the menu.
DEVONagent Pro widget
The DEVONagent Pro widget allows you to search your DEVONagent Pro database directly from the Dashboard. The widget sends the entered query to DEVONagent Pro where you can then pick up your search results. Tip: Use an action for the used search set, e.g., a bouncing Dock icon or a Growl notification, that lets you know when the search run is done.
Front side

On the front side of the widget, enter your query and click the DEVONagent Pro icon to start the search run. If DEVONagent Pro is not running, it will be opened. The title bar of the widget shows the search set that DEVONagent Pro will use for the search run. You can select another search set on the back side of the widget.
Back side
You can flip the widget by clicking the i button that appears when you move the mouse into the lower right corner of the widget. The back side contains a pop-up menu for selecting the default search set.
Click Done to flip the widget back to the front side.
Scripts
DEVONagent Pro comes with a fully loaded AppleScript dictionary and some Automator actions that help you automate almost every aspect of your DEVONagent Pro workflow. Use the included scripts to perform often-used tasks and use them as templates for creating your own scripts and Automator workflows.
Introduction
DEVONagent Pro features an AppleScript dictionary and Automator actions that automate the application and integrate it with almost every other application supporting AppleScript and Automator.
Example scripts
To make it easier for you to start with scripting right away, we deliver a slew of scripts with DEVONagent Pro that you can access in the Scripts menu (which shows a stylized S symbol as its title instead of the word Scripts). These scripts interact directly with selected items, the currently displayed webpage or a window. All scripts delivered with DEVONagent Pro are useable in your daily work, not simple examples skeletons that need to be filled with life first.
Integrating other applications
In addition to the scripts that you use inside DEVONagent Pro, Mac OS X features a global script menu that allows you to access certain scripts from any application on your Mac, for example your web browser or Apple Mail. When activated, it appears at the right side of the menu bar (like other menu extras such as the AirPort signal strength or the Spotlight icon). It appears with a black stylized S icon.
Note: By using folders named after applications inside the '~/Library/Scripts/Applications' directory, it is also possible to make scripts application-specific. Such scripts will appear at the top level of the global script menu when the application they belong to is frontmost. This removes clutter and shows only scripts that make sense in the current application.
DEVONagent Pro does not come with scripts for other applications but you can use the global script menu for creating some and making them available in just the applications in which you want them to appear.
To activate the global script menu, do the following:
To install your own scripts, copy them into the folder '~/Library/Scripts'. You can use sub-folders to structure them in any way you like.
DEVONagent Pro's dictionary
DEVONagent Pro includes a large dictionary with commands, objects, and methods you can use for writing scripts that interact or extend DEVONagent Pro. To view the dictionary, open the Script Editor application (by default located in '/Applications/AppleScript'), select File > Open Dictionary and choose DEVONagent Pro in the appearing window.
You can also add DEVONagent Pro to your Script Editor library. Select Window > Library, click the + button and choose DEVONagent Pro. This way you keep DEVONagent Pro's dictionary at hand.
Caching
DEVONagent Pro caches pre-compiles and caches scripts as soon as they're called for the very first time. So, when you are modifying a script you need to make sure DEVONagent Pro takes notice of the changes. For scripts in the Scripts menu, use the Scripts > Update Scripts Menu command.
Learning AppleScript
This documentation is not an AppleScript language guide. Please refer to Apple's AppleScript website, other online resources, or introduction and reference books for more information on the AppleScript language. Here are some links for you:
DEVONagent Pro's Scripts menu
The internal scripts menu of DEVONagent Pro, located to the left of the Help menu, gives you access to pre-made scripts that extend DEVONagent Pro with additional, more specialized commands and functions. They are only visible from inside DEVONagent Pro and extend its functionality.

Of course, you can easily modify all these scripts using AppleScript Editor, and the workflows using Automator or add your own scripts and workflows to the menu. They are located in '~/Library/Application Support/DEVONagent Pro/Scripts'; you can open this folder in the Finder comfortably with Scripts > Open Scripts Folder.
Note: If you want to add keyboard shortcuts to scripts in this menu, you cannot do this using System Preferences. You need to add the shortcut description to the file name of the script in '~/Library/Application Support/DEVONagent/Scripts' or '~/Library/Scripts'. Example: 'eMail Current URL (Mail)___Cmd-Alt-M.scpt'. The naming convention is three underline characters followed by the shortcut description.
Scripts interacting with other applications
Scripts working with images
Scripts working with pages and results
Scripts for the toolbar
By default this contains no scripts. Add your own scripts here and add them also to the toolbar of search and browser windows using View > Customize Toolbar.
Automator
DEVONagent Pro also comes with a bundle of integrated Automator actions that you can use to create your own Automator workflows.
To see which actions DEVONagent Pro provides, open Automator and select DEVONagent Pro in the applications list on the left hand side. If you do not see DEVONagent Pro in the Library list, use View > Arrange Actions by > Application. Select any action to show a short description about what the action does, and have a look at Automator's built-in help to learn more about how to create a workflow.
Note: Cannot find the Automator action you need for your workflow? We're open to suggestions!
Plugin Development
DEVONagent Pro comes with a long list of ready-to-use plugins for popular search engines. However, if you want to write your own plugins to query your favorite search engine, no problem. Here is all what you need. The tutorial gives you a jump-start on how to write your own plugins for DEVONagent Pro, e.g., for integrating a search engine we haven't thought of yet. And the XML keys descriptions explain all the XML tags you can use for developing the perfect plugin.
Creating Your Own Plugins
Do you have one or more favorite websites that you would like to search using DEVONagent Pro? This document will show you how to create an XML plugin for DEVONagent Pro. It will be a step-by-step tutorial that will guide you through a real, practical example that is found in the list of plugins of the application.
It would be good to also have a look at the Keys section of this chapter. This describes the nitty-gritty details of the XML keywords that we are going to use.
DEVONagent Pro comes with an integrated plugin assistant that makes creating your own XML-based plugin as easy as possible. Let's create a first simple pluging from scratch in six steps.
Step 1
Open a web browser window for www.ipl.org in DEVONagent Pro or any other web browser. Then search for 'Test' and copy the 'Next >>' link leading to the second results page.
Step 2
Choose File > New Plugin, paste the copied link, and replace 'Test' with '_agentQuery_'.

Enter a name and description if desired (useful but not necessary). The Search Engine radio button is automatically selected by DEVONagent Pro.
The '_agentQuery_' placeholder is where DEVONagent Pro inserts the search term when using the plugin. The '_agentOffset_' placeholder, which is used by DEVONagent Pro to jump from result page to result page is automatically inserted instead of the '10' of the '&next=' parameter after clicking the Add button.
Step 3
Let's test the plugin. In this case, the created plugin is already fully functional but causing unnecessary traffic and might return unexpected results. Therefore select any 'www.ipl.org' URL in the log and choose Exlude Domain in the contextual menu. This excludes all pages on ipl.org from becoming possible results.

Step 4
Retry the test, only 10 links per page should be used.

Step 5
Finally, uncheck all operators as IPL does not support them.

That's it!
In other cases you might also have a look at the source of the plugin and validate the values for 'Start', 'OffsetPerPage', and 'ResultsPerPage', or add 'LinksMatching' definitions etc. Site-specific search engines might also require 'TitleStart'/'TitleEnd', 'TextStart'/'TextEnd', 'DateStart'/'DateEnd', 'NoTopics', or 'CrawlDelay' definitions. [Read more...]
In addition, DEVONagent Pro might not always be able to insert the '_agentOffset_' and '_agentNumber_' placeholders automatically. You might have to do this on your own or only the first results page is used.
Finetuning
We now have a working plugin for IPL and we might have gotten links but we may not have gotten good data. You can check both the pages and digest panes in the search window to fine-tune your plugin. If DEVONagent Pro extracts too much data from the result list pages you can use the following keys to tell the software what exactly is a result link and what is not.
In order to determine values for these parameters, you will need to look at the source code of a couple of articles and try to find strings that can be used for these keys.The 'NoTopics' list can be set when looking at the topics in the digest pane after you've done your searches. Any word that you think that should not be included, you can add to this list.
Congratulations
With the steps described in this tutorial, we hope you will be able to go through the steps of writing a plugin yourself. With a bit of practice, it is possible to write an optimized plugin that will deliver good results for DEVONagent Pro to work with. It might help to look at the additional plugins that already come with DEVONagent Pro.
And remember: If you think your plugin is great for others, share it with us!
XML Keys
XML based plugins use Apple's ".plist" file format and therefore it's possible to edit them using Property List Editor or any text editor like TextEdit, SubEthaEdit or Xcode/ProjectBuilder. DEVONagent Pro loads all plugins inside its application package and those stored in the folder "~/Library/Application Support/DEVONagent Pro/Plugins". If DEVONagent Pro is not able to load a plugin, the file is logged to the console. You can also place aliases or symbolic links to plugins here.
Note: Name, Info and Description are localizable. Specify a dictionary containing key/string pairs for multiple languages. The key contains the name of the language, for example German or English.
Notes
Operator Bitmap: The following table gives you the necessary values for calculating the operator bitmap for the "Operators" key (see above):
LinksStart, et al.: 'LinksStart', 'LinksEnd', 'LinksMatching', and 'LinksNotMatching' are three different ways to specifiy interesting links of a page. Specify none, some, or all of them depending on the search engine you are accessing. The more you specifiy, the higher the chances are that the plugin will still work after the structure of the HTML code or the links changed. First DEVONagent Pro retrieves links using 'LinksStart'/'LinksEnd', then filters them using 'LinksNotMatching', and finally matches them against 'LinksMatching'.
Links vs. Results: 'LinksStart'/'LinksEnd, 'LinksMatching', and 'LinksNotMatching' are used for pages listing the results, 'TextStart'/'TextEnd', 'TitleStart'/'TitleEnd', and 'DateStart'/'DateEnd' are used for the result pages.
FollowLinks: 'FollowLinks' applies to result pages only; the links of pages listing results are always used!
No case: All string values are case insensitive.
Troubleshooting
DEVONagent Pro was created with robustness in mind. But still, computer hard- and software can write defective data or destroy files. If you have troubles with this applications, please refer to the methods below and also have a look at the FAQ.
DEVONagent Pro behaves irrationally
There is no software on this planet that has no bugs and if an application behaves irrational there is a good chance that your have just found one. But there also can be another cause: The application package could have become damaged, for example during an update or through a bug in a totally unrelated piece of software on your computer.
Strange Application Behavior
If something happens like the following
please try to trash the application package. Then empty your web brower's cache, download the software in question again, and re-install it. In many cases this cures the problem.
If this does not help try deleting DEVONagent Pro's preferences files located in '~/Library/Preferences' and starting with 'com.devon-technologies.agent'. Visit the Go menu in the Finder with the ⌥ key held to access your Library folder.
Strange Behavior of Tabs
With Zooom/2 installed, tabs in tabbed windows behave stragely, e.g. close by just hovering the cursor over the tab. Another effect of Zooom/2 are scrolling problems in e.g. iTunes. Disabling Zooom/2 solves the problem.
Problems interacting with DEVONthink
DEVONagent Pro uses Mac OS X's Services internally to transfer the data to DEVONthink. It DEVONagent Pro beeps when you try to transfer data to DEVONthink the most likely reason for this problem is that there's something wrong with the Services.
You can use the third party application Service Scrubber to try and modify this behavior; Service Scrubber should allow you to enable/disable services, rename them, or give them new keyboard shortcuts, though, some of these modifications can lead to communication problems between DEVONthink and DEVONagent Pro. Restore to the default settings to enable the DEVONagent Pro/DEVONthink link again.
FAQ
Do you have questions regarding our licensing policy, our products in the Mac App Store, or specific questions about DEVONagent Pro?
General questions
Do you have any job opportunities?
Yes, we may. Please visit our Work @ DEVONtechnologies page for more information about current open jobs at DEVONtechnologies.
Can I be a beta tester?
Maybe. Our beta tester selection process is very deliberate; we try and select our beta testers carefully so that we're not wasting anybody's time, yours and ours. We're looking for people who can provide us with feedback quickly and clearly, who use different hardware and software from our other testers, and who are willing to send us their personal data if it's needed for debugging.
If you want to be a beta tester, the best way to catch our eye is to be active in our user forums. We often ask active participants on the user forums if they can help us test particular features and new products. You can, of course, simply contact us.
Is the documentation available in my language?
The online and PDF documentation is only available in English at the moment. Localizing documentation and other text-intensive materials to Deutsch, Francais, etc. is cost-intensive and error-prone so that we have decided to concentrate our resources on developing stable, robust, and feature-rich software. We will have localizations of the online help etc. as soon as we feel we have the necessary resources.
Where does the name DEVONtechnologies come from?
"Devonian (after Devon County, England), the geologic period from 410 to 360 million years ago. Also called the Reptile Age or Age of Fishes. First amphibians appeared on the land, that until then was only inhabited by trees and other plants — it was the departure into a new age." Named after the Devonian period, the DEVONtechnology marks the departure into a new age of data processing.
Note: Ray Troll has even created songs and other art about this extremely important evolution step.
Release schedules, Mac OS X, and Windows
When is the next release coming
We try not to announce precise timelines or feature lists for future releases, as we are a small software company with limited development resources; if one of us should happen to get the sniffles, or if there are other outside factors we need to devote our limited time to, it can easily impact our intended development schedules.
In planning releases, we try to strike a balance among:
We cannot make any assumptions on how those various factors will impact our daily workflow; in fact, it's often impossible to predict the final release date accurately when we start new projects. We try to plan our releases with a long term perspective so that they ultimately serve the needs of our customers, even if they don't necessarily get in everyone's favorite feature request every time.
Why are your applications not compatible with my pre-release version of Mac OS X?
In the past, we've noted that compatibility issues with a new major release of the operating system are usually resolved by Apple in the final stages before its release, and don't require any action on our part. If you are already using a pre-release version of Mac OS X, please check if our applications work with a newer pre-release, or wait until it reaches the release candidate status. We will then make all necessary adjustments for making our apps run on the first official release of the new version of Mac OS X.
Any chance of a Windows versions of your products?
We're very commited to Mac OS X and the superior Cocoa environment. For most of our applications, porting them to Windows would take longer than it would to rewrite them from scratch on the Mac. If you need to use Windows software but still don't want to miss our products consider running Windows on a Mac.
Purchasing
How do I purchase an upgrade?
Please use DEVONagent Pro > Check Upgrade Options to find out what you need to upgrade and how much the upgrade is for you. If this option is not available in your copy of DEVONagent Pro this application might not be upgradable. Please visit the Upgrade Assistant on our web site instead.
What is your policy on software updates?
Usually, all minor updates ('dot updates', such as version 1.2 to 1.3) to our applications are free and require neither purchasing an upgrade nor requesting a fresh license code. We charge for major upgrades, though, such as version 1.x to 2.x. If you purchased your license in our online shop within a reasonable time frame before a paid upgrade release (between 30 days and 6 months, announced on our website), we will provide you with a free upgrade. If you purchased this application on the Mac App Store click here.
Can I get the bundle discount also later?
Bundles are cheaper than multiple single licenses because a bundle means less fees for the shop provider. But we grant the bundle discount under certain circumstances. Please contact our sales staff if you purchased one of the bundled produts within the last two weeks.
Do you give a discount to students and educators?
Yes, we give 25 percent off the regular price of DEVONthink, DEVONagent, DEVONnote and the Infoworker's Bundle to students and educators. We also give volume discounts to institution or faculties. Please visit our Students, Educators and NPOs page.
Do you offer NPO licenses?
Yes, we offer free licenses to non-profit organizations (NPOs) in the sense of charities. Learn more about our NPO program.
Can I use your software on multiple computers?
Yes, our license explicitly allows one and the same person to use our application non-simultaneously on multiple Macs. So, for example, if you install one of our products on a laptop, your office Mac, and your home Mac, you may do so as long as you only use one of them at a time.
I have no credit card. How can I purchase your software?
We are selling currently through the online sales agent Share*It to keep our administration as lean as possible. If you don't have a credit card, you can also pay via PayPal or by purchase order, wire transfer, or even cash. See our online shop for more details.
In addition we are also selling some of our products through the Mac App Store. Please open the App Store application on your Mac to learn more about which payment options Apple offers.
Can I have more time for evaluating your apps?
No problem. We happily give out 30 day licenses for evaluation purposes. Choose Help > Support Assistant to request a 30 day trial extension. This option is not available e.g. in DEVONagent Express.
Why haven't I received my license code(s)?
If you have purchased your license in our online shop and if there have been no technical problems on our side, your license codes have been sent out to you immediately after your purchase. Sometimes, however, they get stuck in spam protection filters (either yours or your ISP's). Please, check your spam protection filter, and if you cannot find the license codes there, use Help > Support Assistant to get them resent to you. If this also doesn't work, please contact us and we'll try to get your license codes to you as quickly as possible.
Where can I buy a 1.x license code, e.g. for use on Mac OS X 10.4?
License codes for legacy versions are no longer available in our shop but even the latest license codes are always backward-compatible: You can use a version 2.x license code also for version 1.x of the same product. To use a legacy product simply purchase a license for the most recent version of the product in our online shop and use it with your legacy software.
Mac App Store
How can I upgrade apps purchased in the Mac App Store?
By Apple's rigid rules you couldn't. Upgrades are simply not available on the Mac App Store and upgrade offers outside of the Mac App Store are not allowed. In some of our apps there may be an upgrade option still available, though. Check the Read Me to see if this is the case for you.
Can I get a refund?
We freely refund licenses purchased in our own shop. For apps purchased in the Mac App Store this is not possible, though, as Apple does not provide a refund and license withdraw mechanism. Sorry.
Your software license
Why does DEVONagent Pro not accept my license code?
When you enter your license code and the 'Register' button stayes greyed out, try to enter ALL details, including your name and organisation, EXACTLY as they appear in our e-mail. Best practice is to copy-and-paste name, organisation (if entered) and license code from our email into the appropriate fields of the registration dialogue window. Also, please check if you have obtained the correct code for the correct edition of your software (e.g., a DEVONthink Pro license code will not work for DEVONthink Pro Office and vice versa) as well as version (DEVONthink 2.x will not accept a 1.x license code).
I have lost my license code. How can I retrieve it?
Use Help > Support Assistant to open the Support Assistant which has an option to get your license code resent to you. Alternatively visit the support area on our web site.
Does my license code work also for an older version?
Yes, it does. All our license codes are backward-compatible to legacy versions of the same product and edition.
Why do I have to enter my license code again?
You only have to re-enter your license code after a complete reinstall of your system without a backup of your home folder or when the license code file has been deleted, e.g. by a preferences cleaner app. The license code is stored in a preference file in '~/Library/Preferences' (where ~ is your home folder). As long as this file is intact, you'll NEVER have to enter your license code again.
Why does my DEVONagent Pro 1.x license not work anymore?
DEVONagent Pro with version numbers greater than 1.x are paid upgrades. To use them you may need a new license code. Please use DEVONagent Pro > Check Upgrade Options to find out what you need to upgrade and how much the upgrade is for you.
Why does your application say that it expired?
When we release a public beta of one of our applications, we remove the usual trial restrictions but make it expire at the end of the beta period. A new public beta or the final release is, of course, available when this happens.
Please simply visit our Download page, download a newer version that the one you have installed, and replace your copy with the newer one. FPlease first move the old application to the trash, then move the new one into its place.
Note: Your license code will, of course, NEVER expire.
Product-related questions
Click here to read questions and answers specific to DEVONagent Pro.
If you have problems with DEVONagent Pro click here to read the troubleshooting instructions and tips.
Technology
All commercial DEVONtechnologies applications are based on a proprietary AI technology, with rock-solid database foundation that allow them to manage large numbers of documents or knowledge bits while analyzing them almost instantly at the same time.
General Concept
DEVONtechnology, on which all DEVONtechnologies' applications are built, is a new technology at the very beginning of its development. DEVONtechnologies constantly improves the technology and enhances it for more functionality, efficiency, robustness and flexibility.
Development of the DEVONtechnology is a battle on two main forefronts of information processing technology. DEVONtechnologies is working hard on unifying both the top-down and the bottom-up AI concepts by imitating high-level functions and simulating the basic functionality of natural systems. This leads to highly functional, fast and efficient AI systems that can be used in a great variety of information processing contexts, such as pattern recognition, signal processing and information storage and retrieval.
Features
The DEVONtechnology is a rock-solid foundation suitable for a variety of completely independent applications. Therefore it is ideal for the rapid development of a huge range of new database-, signal-processing- and language-analysis-driven applications. The ability to deal with any kind of digital data makes it extremely flexible.
The size of DEVONtechnology-based databases can, depending on the type of data stored, grow logarithmically and make indexing is completely unnecessary. Also, applications based on the DEVONtechnology improve themselves continuously (the more data they handle, the better the results), are language-independent and iron out any irregularities by applying fuzzy logic.
Structure
The DEVONtechnology consists of a kernel and several layers. Together they perform all the underlying computing, from 'simple' data handling to complex signal processing.
Kernel: The kernel is the foundation for all layers and applications and is responsible for data handling, semantic and associative data processing, signal processing, fast statistic analyses and all fuzzy algorithms. It has to be as fast, flexible, and extensible as possible; it is 64-bit aware and uses a generic, proprietary file format (see above) allowing it to verify and repair low level data consistency, featuring logarithmic growth of the database and logarithmic speed decrease with increasing database size. The DEVONtechnology kernel is Unicode-aware, completely language-independent and self-optimizing and self-organizing.
Layers: The layers form a shell around the kernel and provide high-level functions for the applications built on top of them. The database layer, for example, is used to store and organize data and supports all kinds of relations (1:n, n:1, n:n), hierarchies and freeform databases. No indexing or primary keys are required, strings can be unlimited in size and it's possible at any time to extend the range of pre-defined data types (Boolean, character, float, double, signed, unsigned, string, date, time, blob, color, size, and point). Another layer, the XML layer, makes it easy to handle XML code within the DEVONtechnology; it has a very small overhead, compared to DOM parsers or available XML databases, requires no indexing and supports the tight integration of other databases (and vice versa).
Applications
Some of the most likely applications for the DEVONtechnology are databases (knowledge bases, expert systems, search engines, table-of-content-generators, instant data-mining), intelligent agents, encryption, compression and archiving. Other uses for DEVONtechnology may be chat-bots, context-sensitive help, optical character recognition (OCR), speech analysis, recognition and synthesis, staticstics, thesauri and automatic translations.
In particular, applications dependant on processing human language, either written or spoken, benefit from the flexible technology foundation. So, DEVONtechnologies' main focus in the development of new applications is in these areas: databases, 'intelligent' agents, text and speech analysis, statistics.
Look forward to see a great range of different applications based on the DEVONtechnology. A few have already been announced on the DEVONtechnologies web site: www.devontechnologies.com.
Other Products
Besides DEVONagent Pro, DEVONtechnologies publishes a number of other commercial, shareware, and freeware applications, and services that you may be interested in.
At a Glance
DEVONtechnologies is focused on developing innovative applications for finding, storing, and organizing information. Our main objective is to make complex yet flexible technology that is both easy to use and lightning fast.
All applications are based on the DEVONtechnology, a powerful and solid core unique to DEVONtechnologies. DEVONthink, DEVONnote, and DEVONagent are only the first of many more DEVONtechnology-applications yet to come.
Also, we publish and distribute useful shareware and freeware applications that help you in your everyday work with your Mac.
Newsletter & Forum
Would you like DEVONtechnologies to keep you informed about updates and new product releases? Subscribe to the newsletter.
And don't forget to have a look at our very lively user forum , where users of all skill levels meet to discuss our applications, talk about our technology, and exchange tips and tricks for DEVONthink & Co.
DEVONthink
Make the dream of the paperless office come true with DEVONthink and keep all your text and RTF files, scanned documents, notes, emails, images, chat logs, bookmarks, and multimedia files together in one simple to use database. DEVONthink allows you to integrate both local documents and live content from the Internet, keeping all project- related information stored in one easy-to-access place.
Why DEVONthink?
DEVONthink not only stores documents, it also facilitates editing, analyzing, organizing, finding, and archiving your documents with its flexible work environment, powerful organization tools, and built-in AI architecture.
Integrated Workspace
Unlike Mac OS X's Finder, DEVONthink provides an integrated work environment with all the tools you need for working with information of all kinds, from simple text to PDFs and multimedia files. DEVONthink can intelligently assist you with filing documents, finding similar files, or searching the database, saving you the trouble of having to manually manage thousands of files.
As a native Mac application, DEVONthink is also tightly integrated with the Mac OS X operating system and its frameworks. It provides a dock menu, Services menu commands, and even makes heavy use of the Safari web browser engine and Mac OS X 10.4's advanced PDF library.
A Paperless Life
DEVONthink Pro Office comes with a number of 'paperless office' functions not present in other editions of DEVONthink:
Click here to read more about DEVONthink.
DEVONthink To Go
Your document (literally) at your fingertips. DEVONthink on the Mac keeps your documents organized. But what about when you are away from your keyboard? Put your documents into your pocket with DEVONthink To Go, the DEVONthink and DEVONnote companion for the iPad, iPhone, and iPod touch.
Pocket Your Documents
Browse, view, and search your documents with the touch of your finger. Create new notes or take a picture of important information and convert it to a searchable PDF (requires DEVONthink Pro Office on the Mac). Quickly label documents and flag them for later review. Use the 'read' status to use it for reading the news feeds you archive in DEVONthink on the go.
You decide which databases and which groups and documents to synchronize with your device. DEVONthink To Go connects to its Mac counterpart via WiFi.
At a Glance
Read more more about DEVONthink To Go or visit the App Store.
DEVONagent Pro
DEVONagent Pro helps you search more efficiently on the web. It searches multiple sources, frees you from hunting for the really relevant results, and gives you power tools for your research.
Your personal meta search engine
DEVONagent Pro is not a simple Google interface. It knows how to talk to search engines — and how to squeeze the best out of them.
DEVONagent connects to as many search engines as you want, collects the data, and weeds out the junk that managed to slip through. It also scans your favorite websites and notifies you when it finds something that matches your query. It can even do all of this while you're sleeping; the results will be ready before you pour your first cup of coffee.
Get the good stuff, skip the junk
DEVONagent Pro is all about filtering what you don't want and giving you the best tools to find more of what you really want.
DEVONagent Pro doesn't simply trust the search engines. It filters all returned results again, allowing you to use advanced Boolean operators, proximity operators, and wildcards of unlimited complexity — something no single search engine allows you to do. DEVONagent's "scanners" can even find thumbnail galleries or linked PDF or Office documents for you. When you've found what you're looking but want a little more detail, the unique See Also list contains related pages from elsewhere in the search results, online and even from DEVONthink Pro.
The information you want, the way you want
Every research tasks is different. DEVONagent Pro supports this with many ways to list, read, even explore your data.
View the results as a list or as a smart text summary, and explore them with the topics map. Unread results are marked with a blue dot, just like in Apple Mail, so that you don't miss the one important piece of information you're looking for. Finally, for viewing web pages there's DEVONagent Pro's specialized web browser. Extract images, RSS feeds, links, email addresses, even linked documents with a single click and save them for reference or reuse.
Save your research and come back later
Research is not only about finding, it's about collecting data, sharing it, and using it to create something meaningful.
DEVONagent Pro exports your filtered and trimmed-to-the-max research results in a variety of formats, from a simple list of bookmarks to comprehensive RTF digests and PDF reports. The built-in, searchable archive keeps them for later reference, or you can send your results to DEVONthink. Finally, you can save your search and continue later on, or even share it with others via email.
How DEVONagent Pro can help your research
Click here to read more about DEVONagent.
DEVONagent Express
You love Spotlight but it searches only your Mac? DEVONagent Express combines the ease-of-use and ubiquity of Spotlight with the powerful web search technology of DEVONagent. Just like Spotlight searches your computer DEVONagent Express searches the web and presents the results directly in its menu.
Why DEVONagent Express
Perfect integration
DEVONagent Lite
DEVONagent Lite puts web search to where it belongs: next to Spotlight into your menu bar. Search all major and many specialized search engines and databases with a single click.
Search the web like with spotlight
DEVONagent Lite adds a web search field to your menu bar. Google, Bing, and many more always at your service. Its global keyboard shortcut saves you even that click.
Just click DEVONagent Lite's menu bar icon, or press its keyboard shortcut, and start typing instead of switching to your browser, opening a new window, and clicking the search field first. Hit Return and DEVONagent Lite opens the search results in your default browser.
Use the best engine for the job
Google & Co. are great for general questions but often it's better to ask the right people who really know.
Choose your search engine of choice from the magnifying glass pop-up menu to directly search in developer resources, blogs, dictionaries, directories, discussion lists, legal or medical databases, news, or reference sites such as Wikipedia. Find Facebook profiles, tweets, or images without deviation.
DEVONnote
DEVONnote helps you take notes and keep them organized. It keeps all your ideas, documents, important information, and even your web browser's bookmarks in one single, accessible place. DEVONnote supports you with professional, easy-to-use features, and helps create structure out of chaos with its unique AI functions.
DEVONnote is the most sophisticated notepad application for Mac OS X, and the only one that uses AI (artificial intelligence) instead of relying on you organizing your data completely manually.
Why DEVONnote?
DEVONnote was designed with the typical Mac user in mind-a user who is:
Consequently, DEVONnote comes with a clean, easy-to-use interface that gives you all the tools you need in a familiar Mac-like package. Even the most complex AI functions are just »buttons«, meaning one simple click can send DEVONnote into action, digging through all of your data to find a place for your latest note, or to show you all your ideas and concepts that are similar to the one you've just selected.
Brain Food Included
Of course, creative people don't just 'have thoughts', they often need new inspiration, too. We understand that, and that's the reason why DEVONnote comes with a complete Safari-based web browser and solid, but flexible, bookmark-managing capabilities. With DEVONnote, you can browse your favourite websites, then clip and save the most important information directly to your DEVONnote notebook.
But, of course, life is not just work! Use DEVONnote to watch and organize your favorite webcams, directly within your notepad.
Click here to read more about DEVONnote.
Needful Things
As an alternative to the Finder's find function, EasyFind finds files, folders, or contents in any file without the need for indexing. This is especially useful if you are tired of slow or impossible indexing, outdated or corrupted indices, or if you are just looking for missing features like case sensitive or insensitive search, Boolean operators, wildcards, or searching for phrases. In addition, EasyFind uses multi-threading and is therefore very responsive, even with multiple search processes running. The application provides contextual menus and Mac OS X Services, and displays the location of each item in a separate column for a better overview. EasyFind uses little memory, supports drag-and-drop and the clipboard, and optionally finds invisible items or items within packages.
PhotoStickies puts all your favorite pictures on your desktop, as stickies, floating or even borderless. Sticky pictures may reside on your computer, or on the Internet. PhotoStickies also displays live webcams on your desktop, updates them automatically, and even records them like a VCR.
Key features:
ThumbsUp
ThumbsUp is a simple, drag-and-drop based utility designed to create thumbnail images from batches of pictures. (The application supports all Mac OS X and QuickTime image formats, including PDF documents.) Image size, quality, sharpening, and antialiasing are configurable, and images can be scaled by percentage or limited to a maximum size. With a scaling of 100 percent, ThumbsUp may be used as an ultra-fast, comfortable image converter.
Use ThumbsUp to quickly create thumbnails, e.g., for using on your Web site or for sending by email.
XMenu
XMenu brings back Mac OS 9's Apple menu back from the dead, adding its functionality to Mac OS X. One or more global menus to the right side of the menu bar let you easily access your preferred applications, folders (and subfolders), documents and files Furthermore, there's no explicit need for a configuration (like creating lots of folders and aliases or adding items to user-defined setups)-just activate the menus you like: Applications, Developer Applications, Home, Documents, or User-Defined (like the old Apple menu found in Mac OS 9).
Besides the full-blown freeware applications, DEVONtechnologies also offers a variety of useful services that extend the functionality of Mac OS X's Services menu and that allow Cocoa applications like TextEdit or DEVONthink to open PDFs like simple RTF files. These services include:
Click here to read more about DEVONtechnologies' freeware applications and services.
Appendix
Glossary
Become familiar with these terms to get the most out of working with DEVONagent Pro.
Keyboard symbols
Interface Elements
Operators, Queries, Search Sets
FAQ (product-specific)
Is DEVONagent Pro an add-on to DEVONthink?
Although we sell DEVONagent Pro together with DEVONthink in a bundle, it is a stand-alone application. Many of our customers use DEVONagent Pro for their research work but don't necessarily archive the results in DEVONthink.
Can I write my own plug-ins for DEVONagent Pro?
Sure. The complete documentation on how to make plug-ins for DEVONagent Pro is included in DEVONagent Pro's online documentation.
Can I search my hard disk instead of the Internet?
Not with the current version of DEVONagent Pro, no. However, our freeware application EasyFind is able to preview found documents and highlight occurrences in file names. And there is still Spotlight, of course.
How can I search already archived pages
Open the archive (Tools & Open Archive) and use the search field there.
What advantages does DEVONagent Pro have over Google & Co?
The most important advantages over web search engines like Google are:
Why does DEVONagent Pro crash when displaying PDFs?
DEVONagent Pro can crash when trying to display PDF files on Macs with Adobe Acrobat installed. Acrobat's browser plug-in is incompatible to the web browser engine of both Mac OS X and DEVONagent Pro. Remove the Acrobat plug-in from "/Library/Internet Plug-Ins" and everything should work as advertised.
Why does DEVONagent Pro crash when I open a browser window or an archived page?
DEVONagent Pro uses Apple's WebKit as its browser engine. When WebKit crashes it draws DEVONagent Pro with it into the abyss and there is little we can do about it. So, most DEVONagent Pro crashes related to browsing are in fact WebKit crashes. Please send us your crash log (in ~/Library/Logs/CrashReporter/) if you want to know for sure what happened.
How do I completely uninstall DEVONagent Pro?
To completely remove DEVONagent Pro from your Mac, see the instructions in the Read Me.
List of Search Sets
Search sets are sets of parameters and options that control which search engines are used for a search run, which sites are crawled directly, what will be filtered, and what will be done with the returned results. DEVONagent Pro comes with a number of example search sets to get you started:
Start with the Web (Fast) search set for your first search runs, then use the Search Sets window to make your own or adapt an existing one for your requirements. [Read more...]
To built your own search set consider buying DEVONagent.
List of Plugins
Technically, plugins are collections of URLs and procedures that DEVONagent Pro uses to access search engines on the web. They are either written in Cocoa or in human-readable XML (plain text with special syntax). In addition to simple HTML queries, DEVONagent Pro also supports and analyzes RSS, RDF, RSD, and Atom feeds.
In the list below, you also find the associated quick search keywords in brackets. You use quick search keywords to send a query to a plugin directly from the address bar of a web browser window. You can change the quick search keyword in the Plugins & Scanners panel.
Note: Some sites need a valid log-in. If you want to query these sites with a plugin, you need to enable cookies and manually log in with your web browser in advance. Then when you use DEVONagent Pro, the websites will recognize you as a returning user. You will find a note in the plugin description if a site needs a log-in.
Search
Note: DEVONagent Pro presents this category in its menu separately above the other plugins to make them easier accessible.
Apple
Blogs
Browsers
Computer Science
Dictionaries
Directories
Discussion Lists
Government
Images & Videos
Legal
Medical
News
References
Science
Social Networking
List of Scanners
Scanners do not query search engines but filter webpages that to not match their criteria. For example, scanners can filter all pages that do not contain links to images or Office documents, pages that do not contain email addresses, or pages that have no embedded images. You can also use scanners to restrict search runs to RSS feeds, pages with linked documents, or to thumbnail galleries. Scanners filter out all pages that do not match.
Also, scanners are used by the sidebar of web browser windows to filter out certain elements and display them lists, e.g. links, images, or news feeds.
By default, DEVONagent Pro comes with the following scanners that you can use in search sets.
Log message codes
DEVONagent Pro logs all pages filtered out in the log, together with a short code describing why it was filtered. Use the log tab of search windows to find out which pages have been dropped and of which reason.
HTTP Error Codes
These error codes are standard HTTP error codes delivered directly from web server that DEVONagent Pro asked for a file:
DEVONagent Pro Error Descriptions
These errors appear in the log when communication problems with the web server occurred, or, more likely, when DEVONagent Pro filtered the page out due to its search strategy or user-defined settings.
Version history
Version 3.0 is a major upgrade bringing literally hundreds of new features and detail enhancements. Learn more about the highlights in DEVONagent Pro 3.0 compared to earlier versions: [Read more...]
Version 3.2
This maintenance release updates a number of plugins, improves the help integration, and fixes a number of minor issues. This update also makes it possible to download DEVONagent Pro as a trial version from the DEVONtechnologies website and use it with a valid Mac App Store receipt.
DEVONagent Pro:
DEVONagent Express or higher:
All editions:
Version 3.1.2
This update is a maintenance update that brings support for Google Chrome bookmarks, allows you to add scripts to toolbars, can generate preview thumbnails via Thumbshots.com, opens the menu extra also in OS X 10.7 Lion's fullscreen mode (via the hotkey), and fixes a number of minor bugs and glitches.
DEVONagent Pro:
DEVONagent Express or higher:
All editions:
Version 3.1.1
DEVONagent Pro:
DEVONagent Express or higher:
All editions:
Version 3.1
DEVONagent Pro:
DEVONagent Express or higher:
All editions:
Note: Characters separated by dots are now considered to be abbreviations and therefore handled like words separated by hyphens, e.g. the term a.b.c is equal to "a b c" OR abc and matches a b c, a.b.c, abc, a-b-c etc.
Version 3.0.5 — 3.0
Skipped.
Version 2.3.1
Version 2.3 — 1.0
Skipped.
License Agreement
PLEASE READ THIS LICENSE CAREFULLY BEFORE USING THIS SOFTWARE. BY USING THIS SOFTWARE, YOU ARE AGREEING TO BE BOUND BY THE TERMS OF THIS LICENSE AGREEMENT. IF YOU DO NOT AGREE TO THE TERMS OF THIS LICENSE, DELETE THE SOFTWARE OR RETURN THE SOFTWARE AND RELATED DOCUMENTATION TO DEVONTECHNOLOGIES, LLC.
1. License: The application and other components (sound and graphics) accompanying this License, whether on disk, in read only memory, or on any other media (the “Software”), and the related documentation are licensed to you by DEVONtechnologies. You own the disk on which the Software is recorded but DEVONtechnologies and/or DEVONtechnologies’ Licensor(s) retain title to the Software and related documentation. This License allows you to non-simultaneously use the Software on multiple computers by the same person.
2. Restrictions: The Software contains copyrighted material, trade secrets and other proprietary material and in order to protect them you may not decompile, reverse engineer, disassemble or otherwise reduce the Software to a human-perceivable form. You may not sub-license, modify, rent, lease, or create derivative works based upon the Software in whole or in part. You may not distribute the Software in any form, including, but not limited to, electronic information service distribution, bulletin board distribution, and magnetic or optical medium distribution.
3. Disclaimer of Warranty on Software: You expressly acknowledge and agree that use of the Software is at your sole risk. The Software and related documentation is provided “AS IS” and without warranty of any kind.
4. Limitation of Liability: UNDER NO CIRCUMSTANCES INCLUDING NEGLIGENCE, SHALL DEVONTECHNOLOGIES BE LIABLE FOR ANY INCIDENTAL, SPECIAL OR CONSEQUENTIAL DAMAGES THAT RESULT FROM THE USE OR INABILITY TO USE THE SOFTWARE OR RELATED DOCUMENTATION. In no event shall DEVONtechnologies’ total liability to you for all damages, losses and causes of action (whether in contract, tort (including negligence) or otherwise) exceed the amount paid by you for the Software.
Apple, Carbon, Classic, Cocoa, ColorSync, Darwin, Mac OS X, QuickTime, Quartz and all other registered names are trademarks of their respective owners.
Credits
SMTPMailDelivery
The SMTPMailDelivery library is used according to the MIT License.
Video JS
Copyright © 2010 Zencoder, Inc.
The Video JS player is used according to the LGPL v3.
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