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	Web Searching: Fed up with just a load of links? Using advanced search techniques, DEVONagent Pro takes on all those tedious search-and-review tasks releasing you to focus valuable time on relevant results.


	
	

	
	
	
	
	

	

	

	
	
	
	
	
	
The DEVONagent Pro Advantage

		[image: DEVONagent Pro Main Window]

		Why DEVONagent Pro? 

			Using advanced search techniques, DEVONagent Pro takes on all those tedious search-and-review tasks releasing you to focus valuable time on relevant results. It assists you in

			
					finding,

					collecting, and

					organizing

			

			information from the Web or your DEVONthink Pro Office  databases with a powerful and flexible search architecture, has a powerful, research-oriented web browser and simple built-in archive, and tightly integrates with DEVONthink. 

		
		What DEVONagent Pro Does for You 

			
					Using both standard and specialized search engines, DEVONagent Pro intelligently summarizes the results  fast!

					Alternatively, DEVONagent Pro shows you an even larger number of search results using its unique graphical topic map.

					DEVONagent Pro support your research while browsing the Web, e.g. by listing all objects such as images, linked documents, or outgoing links embedded into a viewed page.

					DEVONagent Pro archives your search results with a single click or sends them to e.g. your DEVONthink database.

					Instead of letting you repeat actions, DEVONagent Pro performs them for you. Combine search sets, schedule searches, etc. to create your very own personalized search assistant.

			

		
		Perfect Integration 

			
					DEVONagent Pro integrates seamlessly with DEVONthink.  With just one click, archive your search results, webpages, etc. to your DEVONthink database.

					Select text in any application and use DEVONagent Pro's Services menu or contextual menu item (Mac OS X 10.5 only) to search for it. The Dashboard widget  keeps DEVONagent Pro  at your fingertips.

					Use various actions including Growl  and AppleScript to inform you of search results, then send them to either DEVONthink or the application of your choice to process them in any way you wish.

			

			Learn more about why you should use DEVONagent Pro, when you should use it, and how to run your first query: [Read more...] 

		
	Highlights of Version 3.0

		DEVONagent Pro 3.0 comes with a reworked user interface, better browsing capabilities, new and updated plugins, and is based on a new technology foundation. Here's just a short list of what's new in DEVONagent Pro 3.0 compared to earlier versions:

		
				Better search results, summaries, digests, ranking.

				Support for wildcards, more natural phrase matching.

				New Plugin Assistant  that allows to easily create new search plugins.

				New possibility to edit and test plugins internally.

				Settings  drawer is now a tab.

				Searches can be saved  and reopened later.

				Results can be appended to (saved) searches, older results can be skipped.

				Searching in results, improved searching in the archive. 

				Express mode for fast searches without filtering.

				Integrated DEVONagent Express. 

		
	
		
				New scanners  and plugins,  e.g. for Bing,  the App Store, Unfolding News,  or DEVONthink Pro Office. 

				Updated plugins,  scanners,  and search sets. 

				Support for PDF, PostScript, OpenOffice,  Oracle Open Office,  RTF,  and Microsoft Word  documents.

				Possibility to match title, text, URL, keywords, description, and objects.

				New search operators  and options, e.g. 'OPT' and fuzzy searching.

		

		
				Much improved Web browsing  and news feed reading experience.

				Bookmark management. 

				Sidebar  in browser window unifies drawers.

				Customizable toolbar  in browser windows.

				Improved integration of scanners. 

				Cover Flow for searching and browsing plus previews/snapshots of webpages.

				See Also  drawer lists also archived results as well as documents from DEVONthink Pro and related webpages.

				Improved Archive  and Download Manager. 

		

		
				Reworked user interface.

				Improved performance, responsiveness, compatibility, and reliability.

				Improved interoperability with third-party applications and DEVONthink. 

				Support for Mac OS X 10.6 and OS X 10.7, e.g the extended Services menu and the Dock icon badge.

				Much extended export capabilities. 

				Growl  support.

				64 bit support.

				Welcome Assistant.

		

	System Requirements

		Every Apple Mac computer with at least 512 MB of RAM, Mac OS X 10.5 or later. In addition, a broadband Internet connection (2 Mbps or faster) is highly recommended.

	Installing, Updating, Removing

		
		

		
		Just move the DEVONagent Pro application package to the Applications folder or any other directory you have access to. Please note that Mac OS X Services and the connection to DEVONthink  work only for applications installed into one of the Applications folders, and that logout and login or a restart is required after installation.

		To update an existing version of DEVONagent Pro, simply copy the application package from the disk image to your Applications folder, replacing the old version. Your database(s) will not be affected.

		If you would like to switch from the Mac App Store variant of DEVONagent Pro to one directly downloaded from the DEVONtechnologies website  you can do so at any time. The official version will accept your Mac App Store receipt as a valid license. Copies not downloaded from the Mac App Store also allow you to buy an upgrade to a higher edition or version (if available).

		To remove DEVONagent Pro traceless from your computer, trash the following files and folders (~ represents your home folder):

		
				DEVONagent Pro

				~/Library/Application Support/DEVONagent Pro

				~/Library/Contextual Menu Items/DEVONagent Pro CM.plugin

				~/Library/Preferences/com.devon-technologies.agentexpress.*

		

		Depending on whether you have installed the following extras or not, remove them, too:

		
				The product-specific scripts in ~/Library/Scripts and ~/Library/Workflows

				The contextual menu plugin in ~/Library/Contextual Menu Items/

				The Dashboard widget

		

		Note: Some files may or may not be installed on your machine depending the version of Mac OS X you are using.


	Trial Restrictions

		Unregistered DEVONagent Pro runs for 60 hours of non-continous runtime. Close the app to stop the clock from ticking and re-open later to continue your evaluation. The menu extra  is restricted to 100 searches alltogether until DEVONagent Pro is registered.

	Getting Started


	This chapter helps you get started with DEVONagent Pro. It explains why and when to use DEVONagent Pro, and how to run a first query, step-by-step.
 

	
	
	
	
	
	
	

Why use DEVONagent Pro?

		The first misconception is that DEVONagent Pro is a simple front-end to Google  or Bing.  It is an Internet research assistant that takes over tedious research tasks such as weeding out bad search results, looking for linked documents, or finding information on a webpage.

		Searches with DEVONagent Pro take longer than a quick search on a Web search engine because DEVONagent Pro downloads each resulting page instead of only presenting you with a link to it. They also return fewer results as DEVONagent Pro already filters out broken links, advertisements, and outdated pages. So the search takes longer but you save time because you do not have to do all this manually.

		Reasons for using DEVONagent Pro include:

				You get much better search results.

				You don't have to do all the tedious, repetitive tasks of search; DEVONagent Pro does them for you while you can spend your time on more meaningful tasks.

				You can search more specifically, e.g., by using advanced operators and search sets.

				You get the results in a much more natural presentation in the Digest. 

				You can archive interesting searches and continue on another day.

				You use a specialized web browser with research-centric additions, e.g., the sidebar. 

				DEVONagent Pro can repeatedly run searches unattended for you and present the results, if any, when it has finished.

		

	When to use DEVONagent Pro?

		DEVONagent Pro does much more than a search on a Web search engine. And because it downloads all results to your Mac to analyse and post-process them, a search run takes between a few seconds and several minutes. Consequently, DEVONagent Pro is not necessarily the most useful tool for every search task.

		Use DEVONagent Pro for:

				Getting answers to a question

				Finding all available data about a subject

				Searching multiple search engines and websites with just one click

				Scraping objects from webpages, e.g. images, email addresses, or RSS feeds

				Keep up to date on a subject, e.g. with scheduled searches

		

		Don't use DEVONagent Pro for:

				Finding the webpage of company X or product Y

				Finding an very specific image or video

				Quickly finding the definition for a word, e.g. on Wikipedia 

		

	First steps with DEVONagent Pro

		A first search: While DEVONagent Pro is a real power tool, it does not need to be overly complex. Running a simple search using DEVONagent Pro is no more complicated than using Google or Bing.

		
				Run a first search with a few simple steps 

		

		The next steps: Now that you know how to run a first search you can make the next steps alone. Here are a few chapters for you to continue exploring DEVONagent Pro:

		
				More common tasks 

				How to formulate a good query 

				How to create your own search sets 

				Customize DEVONagent Proto your preferences 

				Create your own plugin  if your search engine is not supported

		

		Finally, DEVONagent Proitself and the DEVONtechnologies website offer additional information and assistance:

		
				Open the Support Assistant [special link, not enabled in ebook]  for on-screen tutorials and regularly updated tips

				Read the frequently asked questions 

				Visit our lively user forum 

		

	Common Tasks


	This chapter explains common tasks in DEVONagent Prostep-by-step and points you to related topics.


	
	
	
	
	
	

	

How to find on the Internet

		DEVONagent Pro's main objective is to find stuff on the Internet. It does so by sending a query, a search term, to a selected set of search engines, e.g. Google,  collecting the results, analysing them, and presenting them to you.

		You tell DEVONagent Pro which search engines to use by selecting a plugin (contains instructions telling DEVONagent Pro how to communicate with a search engine) or search set (combinations of multiple plugins and other options). DEVONagent Pro comes with a large number of pre-fab plugins and search sets. [Read more...] 

		
		[image: Finding on the internet]
 
		Step by step: You are trying to find information about the WikiLeaks disclosure of diplomatic cables.

		
			
				Step 1: Open a new search window with File > New Search. 

			
				Step 2: Choose the search set to use in the magnifying glass [image: ] pop-up menu: Web (Fast)

				Step 3: Enter your query (search term): wikileaks AND "diplomatic cables"

			
				Step 4: Click Start.

		

		[image: ]Click here [special link, not enabled in ebook]  to make DEVONagent Pro run this search for you.

		
		The best choice for a simple but comprehensive search is the pre-fab Web (Fast) search set. It is a multi-purpose search set that sends your query to the three major search engines: Google,  Bing,  and Yahoo.  Alternatively you can choose plugins directly, e.g. the one for Google, in the magnifying glass pop-up menu.

		DEVONagent Pro Advantage: You can use advanced Boolean operators and you are not presented by a simple list of links but a pre-processed summary including extracted topics. In addition, DEVONagent Proqueries multiple search engines for you with one single click.

		Next steps:

				Fine-tune your search with the Settings tab 

				Design a good query 

				Learn more about the advanced Boolean operators 

				Create your own search sets 

		

		Related topics:

				The search window explained 

				List of pre-fab search sets 

				List of built-in search engine plugins 

		

	How to search beyond Google

		DEVONagent Procan not only run queries on Google and Bing but comes with a large number of plugins that let it use less common search engines such as FindLaw,  PubMed,  or Highbeam. 

		Just choose the right plugin before you start your search from the magnifying glass [image: ] pop-up menu in the search field.

		[image: Advanced searching]
 
		Step by step: You are trying to find newspaper articles about the former German defence minister who had to resign because he copied large parts of his doctor thesis.

		
			
				Step 1: Open a new search window with File > New Search. 

				Step 2: Choose the plugin to use in the magnifying glass [image: ] pop-up menu: References > Highbeam

				Step 3: Enter your query (search term): "zu Guttenberg" plagiarism

			
				Step 4: Click Start.

		

		DEVONagent Pro sends the results to the Highbeam article search engine and presents you with the results.

		[image: ] Click here [special link, not enabled in ebook]  to make DEVONagent Pro run this search for you.

		Next steps:

				Design a good query 

				Learn more about the advanced Boolean operators 

		

		Related topics:

				The search window explained 

				List of pre-fab search sets 

				List of built-in search engine plugins 

		

	How to customize DEVONagent Pro

		DEVONagent Pro can be customized to better fit your needs like most other Mac apps. You adjust all of DEVONagent Pro's setting in its Preferences. 

		[image: Customize DEVONagent Pro]
 
		Step by step: You want to exclude all links to eBay from the results.

		
				Step 1: Open the Preferences, Search tab. 

				Step 2: Click into the Exclude Domains field.

				Step 3: Add 'ebay.' (with the dot, without the single quotes) to the list.

		

		This filters all results with addresses containing the string 'ebay.'

		Next steps:

				Set the other preferences to your needs 

				Learn more about the other options in the DEVONagent Pro menu 

				Learn more about the other options in the action menu 

		

	How to set up a search set to crawl feeds

		DEVONagent Pro not only queries search engines for you. It can also go searching on its own by "crawling" a given list of webpages or news feeds and scanning them for the search term. This can be handy when you have a number resources that you need to watch, e.g. subject-specific news sites or feeds.

		[image: Crawling feeds]
 
		Step by step: You want to search one of the New York Times news feeds.

		
				Step 1: [image: ] Click here [special link, not enabled in ebook]  to open the Search Sets  window. Open it manually using Window > Search Sets. 

				Step 2: Click the + button to create a new set. Name it, e.g., "New York Times".

				Step 3: Switch to the Sites tab.

				Step 4: [image: ] Click here [special link, not enabled in ebook]  to open the New York Times RSS page in a new web browser window.

				Step 5: Show the "Objects" tab of the sidebar  using Web > Sidebar > Objects  and switch to the [image: ] tab.

				Step 6: Copy the address of any RSS feed of interest for you by right-clicking it and choosing Copy from the contextual menu.

				Step 7: Switch to the Search Sets window and paste it, e.g., by pressing ⌘V. or using Edit > Paste. 

		

		Repeat steps 6 and 7 for any feeds that you want to add to your "New York Times" search set. You can now use this set like any other search set or plugin. Instead of querying any search engines it will download the current state of all the feeds you have added and search them for occurences of your search term.

		Next steps:

				Run a first query 

				Design a good query 

				Learn more about the advanced Boolean operators 

				Run your search automatically 

		

		Related topics:

				More about search sets 

		

	How to run a search automatically

		Search sets  are not only collections of rules about how to run a search. They are also the key to research automation in DEVONagent Pro. Add a default query  to a search set and set its scheduler to make DEVONagent Pro run the search fully unattended, e.g. in the middle of the night, and execute chosen actions when it's done.

		[image: Schedule a search run]
 
		Step by step: You want to run the "Marketing" search set automatically once every day and send the results to you by email.

		
				Step 1: [image: ] Click here [special link, not enabled in ebook]  to have the Search Sets  window opened and the "Marketing" search set selected for you.

				Step 2: Switch to the Actions tab.

				Step 3: Check Send mail to and enter your email address.

				Step 4: Switch to the Schedule tab.

				Step 5: Select Daily and set the time to, e.g., 9 a.m.

		

		As the "Marketing" search set contains a default query on the General tab you are done. Tomorrow morning at 9 a.m. DEVONagent Pro will automagically activate and run a search for the default query of the "Marketing" set. When it is done it will send a summary email to the email address you have entered.

		Note: Your Mac needs to be on at the time the search set is about to run. DEVONagent Pro is not able to wake your Mac up when it is sleeping.


		Next steps:

				Learn more about actions 

				Learn more about the schedule options 

		

		Related topics:

				More about search sets 

		

	How to archive search results

		When you have found good data on the Internet very likely you're only half-way there. You will want to keep the best results for future reference. For this DEVONagent Pro comes with a built-in archive.

		[image: Archiving a search]
 
		Step by step: You want to archive all results of a search run.

		
				Step 1: Run a search, e.g. with the Bing or Google plugin.

				Step 2: Choose Data > Add All To Archive. 

				Step 3: The results have been saved to the archive  in a group named after your query.

		

		Step by step: You want to archive some results of a search run.

		
				Step 1: Run a search, e.g. with the Bing or Google plugin.

				Step 2: Switch to the Results tab, e.g. by pressing ⌘2.

				Step 3: Select the results you want to archive.

				Step 4: Choose Data > Add To Archive. 

				Step 5: The results have been saved to the archive  in a group named after your query.

		

		Alternatively to using Data > Add To Archive, Data > Add All To Archive, and Window > Archive you can use the Add, Add All, and Archive toolbar icons of the search window.  You may need to add the tools to the toolbar using View > Customize Toolbar. 

		Next steps:

				Work with the archive 

		

		Related topics:

				Adding results to DEVONthink 

		

	Queries


	DEVONagent Pro provides powerful Boolean operators that allow one to precisely define a search query.

	Queries can range from very simple one-word search terms to complex multi-term queries. The rules for formulating queries are rather simple, and with a bit of study of the rules and the Boolean operators, together with practice, users can 'tell' DEVONagent Pro exactly what to look for in a search.


	

	
Operators

		Plugin/set selection 

			To quickly select which plugin or search set DEVONagent Pro uses start the query with the plugin's or search set's name or keyword  followed by a colon.

			Example: google:devonthink


		
		Case 

			All terms are case-insensitive. You may, if you wish, use capitalization for proper names in a query, but DEVONagent Pro will ignore case in interpreting the query.
 
		
		Precedence of terms 

			Search terms and associated operators will be interpreted from left to right, except as modified by including portions of the query within parentheses.
 
		
		Boolean operators 

			The operators (often called Boolean operators) are words or symbols that establish logical rules for the terms in the search query. These are:
 
			
					term1 AND term2: Contains term1 AND term2

					term1 BUT term2: Contains term1 AND term2

					term1 OR term2: Contains term1 OR term2

					term1 XOR term2: Contains term1 or term2, but not both

					term1 EOR term2: Contains term1 or term2, but not both
 
					NOT term: Does not contain term

					"term1": Contains the string term1, in exactly this form; uses fuzzy matching (e.g. "DEVON tech" matches also "DEVON-tech" or "DEVON++++tech"); accepts also the '*' operator, like 'BEFORE' but more precise.

			

			Beside the classic Boolean operators, DEVONagent Pro features a number of operators that can usually only be found on high-end databases. Use them as a replacement for AND and "quotes" to fine-tune your query.

			
					term1 NEAR term2: term1 occurs 10 words or less before or after term2

					term1 NEAR/n term2: term1 occurs n or less words before or after term2

					term1 BEFORE term2: term1 occurs before term2

					term1 BEFORE/n term2: term1 occurs n or less words before term2

					term1 NEXT term2: term1 occurs right before term2 (shortcut for BEFORE/1)

					term1 NEXT/n term2: term 1 occurs n or less words before term2 (synonym for BEFORE/n)

					term1 AFTER term2: term1 occurs after term2

					term1 AFTER/n term2: term1 occurs n or less words after term2

					term1 OPT term2: term1 is mandatory but term2 is optional. If term2 is also found the result is ranked higher.

					~term1: Contains all words that begin or end with term1 (words containing term1 as a part of the word; depends on the queried search engine)

			

			Note: See chapter Designing a Search Query  for examples on how to use all these operators effectively.

 
			For convenience, some of these operators can also be abbreviated using commonly used symbols:

			
					AND: &, &&, +

					OR: |, ||

					XOR: ^, ^^

					NOT: !, -

			

			Note: The symbols above are also used by the Finder and Spotlight for searches. Enter the vertical ruler character for the OR operator by pressing ⇧7, ⇧\ or the appropriate keyboard combination for your keyboard layout.


		
		Wildcards 

			You can replace parts of words with wildcards matching one, multiple, or a range of characters:

			
					?: Matches exactly one character.

					*: Matches none, one, or multiple characters.

					[a-b]: Matches one character of the range 'a' through 'b'.

					[abc...] or [a|b|c|...]: Matches one character out of the given list of characters.

					[^...]: Matches one character that is not contained in the given list or range.

			

			Note: Primary queries  only support wildcards for sites, not for plugins or search engines.


		
		Special rules 

			To search for a word that is also the name of an operator, put the word inside quotation marks. The following example searches all four terms including the word "near":
 
			Example: Beach "near" Los Angeles


		
	Designing a search query

		Writing your query as simply and as precisely as possible is the key to good search results. Following are some tips on how to write a good query.
 
		Designing a good query 

			Suppose you want to search for information about the mercury contamination of fish and to focus on information released by or referring to the United States Environmental Protection Agency.
 
			One problem with trying a simple AND search for a group of words is that the Environmental Protection Agency is referred to in various ways: 'Environmental Protection Agency', 'EPA' and 'E.P.A.'"
 
			If we tried the search string

			Example: Environmental AND Protection AND Agency AND EPA AND E.P.A. AND fish AND mercury

 
			we would probably get no results at all, as no single article would use all three terms for the environmental agency. And even if we were to get search results, we would get irrelevant results stemming from the terms environmental, protection and agency.
 
			Here's a better way to design the query:

			Example: ("Environmental Protection Agency" OR EPA OR "E.P.A.")


			which will pick up the variants in naming the agency in articles. Note that the two strings enclosed in quotation marks will now be treated as phrases. This reduces ambiguity. Also note the use of parentheses and the OR operator. We now cover all three variants of common names used for the environmental agency. DEVONagent Pro will look for pages containing any one of those names.
 
			There's another potential ambiguity, because it's possible that a large reference source might contain the word 'fish' in one section dealing with fishery resources, and contain the word 'mercury' in another section dealing with the history of barometers. We're simply not interested in that item. But if we use the NEAR operator between 'fish' and 'mercury' it's likely that we will get useful results, as this will place the space between the two terms at ten words or less.
 
			The refined query now becomes:

			Example: ("Environmental Protection Agency" OR EPA OR "E.P.A.") AND (fish NEAR mercury)

 
			Notice that a second set of parentheses was used, so that DEVONagent Pro won't wrongly interpret the query as requiring that both the environmental agency name and 'fish' must be NEAR 'mercury'. Just that confusion would be created if we had written the query as:
 
			Example: ("Environmental Protection Agency" OR EPA OR "E.P.A." AND fish) NEAR mercury

 
			Indeed, the refined search returned highly relevant pages. Of course, this search focused on literature about mercury contamination of fish in the United States. One could replace the search strings in the first set of parentheses with, e.g., ("European Union" OR EU) to change the geographical focus.
 
		
		Improving your query 

			Besides the typical Boolean operators AND, OR and NOT, DEVONagent Pro provides you with the much more powerful NEAR, BEFORE and AFTER operators. Typically, only scientific high-end databases feature them, but DEVONagent Pro makes them available for Web research, also.
 
			Note: Because almost none of the Web search engines support these operators, DEVONagent Pro sends the simpler AND query to them and applies the more sophisticated operators to the resulting pages.

 
			All three operators connect two search terms closer together than AND, but not as tightly as the phrase operator (double quotes). With the additional distance parameter (e.g., NEAR/5) you can also fine-tune the search results until you get only exactly the results you are looking for.
 
			Example: (steve NEAR/2 jobs) BEFORE (intel NEAR (imac OR macbook)) AND "San Francisco"

 
			Connecting 'steve' and 'jobs' with NEAR/2 prevents getting result pages of some Steve looking for a job in his page footer. BEFORE makes sure it's a page that mentions Steve Jobs first and then the Intel Macs. Finally, the quotes around 'San Francisco' find only pages dealing with the city of San Francisco, not the city San Jos and some Brother Francisco mentioned somewhere else on the page.
 
			Use the proprietary NEAR, BEFORE and AFTER operators when AND delivers too many results and quoting delivers too few. Another example:
 
			Example: document AND management AND mac


			This query run with the Web (Fast) search set deliveres good results. But, many are not what we are looking for. Among many good pages, it also finds the Wikipedia  article about Mac OS X because it contains all three words. But, of course, this article is not at all about document management on the Mac. But, we can refine this query with the special DEVONagent Pro operators:
 
			Example: document NEAR/2 management NEAR mac


			This time, DEVONagent Pro returns fewer results, all of them dealing exactly with our search subject, document management for the Macintosh, because the three words have to be mentioned near to each other in the text. In most cases, NEAR delivers more accurate results than AND.
 
		
		First principle of a successful query 

			Make the query precise and unambiguous. DEVONagent Pro's tools for clarifying your query are really quite simple and can help you obtain a high percentage of useful results rather than a confusing mess of irrelevant results.
 
		
	Search sets


	The quality of a query relies not only on the entered search term, but it also relies heavily on the selected settings. Search sets are collections of all the parameters (settings) related to a search run. You use search sets to quickly tweak your settings, depending on what you are searching for on the Internet. This ensures that you always get the best results.


	

	

	
	
	

	
	
	

	

	

	

	

What are search sets?

		Search sets are basically collections of all the parameters related to a search run:
 
		
				A default query

				Follow links settings

				Filters and associated  scanners 
 
				Sites to scan, plugins to use
 
				Actions to run when the search run is done

				A schedule

		

		Using these settings, you can create search sets specifically tailored for your research needs. For example, you could create your own sets for:
 
		
				Querying the US Patent Office and WIPO databases, along with scaning some important websites related to patents

				Looking for articles related to DEVONtechnologies  on Google, as well as some Mac news sites, scheduled every three hours and sending an email summary to your email address

				Searching the most important medical databases, e.g., PubMed, Medscape and FDA, in a single search run

				Querying a number of general search engines like Google, MSN and Yahoo, but filtering out everything except pages with links to Office documents

		

	Choosing a search set

		Choosing the search set that you want to use for a search run is easy: Click the magnifying glass icon [image: ] in a DEVONagent Prosearch field and choose a search set from the pop-up menu that appears.

		DEVONagent Pro comes with a number of predefined search set but you can easily also create your own. 

	Creating and managing sets

		[image: The search set editor and its elements]

		Search sets can be edited, rearranged, exported, imported or deleted. DEVONagent Pro comes with a couple of useful pre-defined sets, which you can tweak to your needs. Or, you can add new ones for your individual needs. Use Window > Search Sets  to open the search set editor.

		Note: Some of the settings can also be adjusted on-the-fly in the Settings  and Advanced  tabs.

 
		The search set editor shows a list of all defined search sets and allows you to add new sets or delete the selected set using the + and - buttons like other Mac OS X applications, e.g., iTunes or iPhoto.  Rearrange your search sets using drag-and-drop, and click the name of any set once to change its name.
 
		Note: Some items can be dragged from one search set to another set e.g., URLs from the sites tab.

 
		To change the settings defined in a set, select it in the list and change the parameters in the right-hand pane to fit your needs. Switch between the parameters areas, General,  Advanced,  Sites,  Plugins,  Actions,  and Schedule  by using the tabs above the parameter area.
 
		Shortcut 

			To create a new search set with exactly the same settings as the current search run, click the + button next to the Stop button in the search window.  This creates a new search set with exactly the same settings including the query as the default query.
 
		
		Action menu 

			The Action menu, available from the toothwheel button below the search set list, gives you access to additional commands. [Read more...] 
 
		
		Contextual menu 

			The contextual menu gives you direct access to frequently used commands.

			
					New: Creates a new, empty search set.

					Duplicate: Duplicates the selected search set.

					Delete: Deletes the selected search set. Attention: There is no undo!
 
					Import: Creates new search sets based on imported files. You can import previously exported sets, as well as OPML files, Camino,  Firefox,  Chrome,  OmniWeb or Safari bookmarks or the Safari history file. For OPML, bookmarks and history files, DEVONagent Pro creates a new search set with all URLs imported to the Sites  list.
 
					Export: Exports the selected search sets as separate files. Exported sets get the file name extension '.agentSet' and are XML/plist files. You can import them into DEVONagent Pro by double-clicking them in the Finder.
 
			

		
	Sharing sets

		You can easily share search sets with other DEVONagent Pro users. Exported sets using either the contextual menu,  the File > Sets  menu command, or by simply dragging them e.g. to the Desktop. You can email exported sets and import them again into DEVONagent Pro simply by double-clicking them in the Finder.

	General tab

		On the General tab, you define the main parameters for this search set such as the default query, which filter and/or which scanner  to use.
 
		[image: Search Set Editor, General Tab]
 
		Queries 

			Default Query: Define a default query for this search set. DEVONagent Pro will automatically fill the query field with the default query, when you select this search set. This is especially useful if you are using either the same query every time you use this search set or if you are running this set on a schedule. 
 
			Example: esa AND (mission NEAR "venus express")


			Read more about formulating a query here: [Read more...] 

			Secondary Query: When you enter something here, the primary term (the one that is entered or the default query) is only used for querying the search engines, but not for accepting or rejecting pages. Without a secondary query, DEVONagent Pro uses the primary query for both querying search engines and post-filtering the results.
 
			You can use secondary queries for using different terms for querying the search engines and accepting/rejecting pages. Although the primary query is restricted to ten words, the secondary query is not restricted.
 
			Example: Use the asterisk '*' as your default query to match everything, for example, when scanning a list of websites or RSS feeds; of course, this is not applicable with search engine plugins, only with the Sites  list. To accept all pages delivered by a primary query, use the asterisk '*' as secondary query.

 
		
		Follow links 

			These options tell DEVONagent Pro to follow promising links on HTML pages and in news feeds.

			Example: 'Devonian Period -County' follows links containing 'Devonian' or 'Period' but not containing 'County'.


			Use the slider to define how many levels deep you want DEVONagent Pro to follow links. One or two levels generally make sense, more is often overkill.

			Use the text field below the slider to provide an additional search query that defines which links DEVONagent Pro follows. Use this option to fine-tune your settings, if you find that DEVONagent Pro follows meanlingless links due to the construction of the result pages. Generally, you should leave this field blank and let DEVONagent Pro follow all links matching the entered or default query; the automatically chosen term is displayed in this case.

			Example: Enter '*' to let DEVONagent Pro follow all links, regardless if their text description matches the query or not.


		
		Express search 

			Check Express Search to enable 'express' mode. In 'express' mode DEVONagent Pro returns results fast but unfiltered. If unchecked DEVONagent Pro operates in 'agent' mode which is slower but returns post-filtered results and is much more precise and powerful.

			Note: Scanners and secondary search terms, the similar pages filter, and following links require 'agent' mode. Some plugins may also require 'agent' mode, other may not support 'express' mode.


		
		Language 

			Language: Use this pop-up menu to filter out all pages that do not match the selected language (Dutch, German, English,...) or script system (Arabic, Greek, Hebrew,...) This filter does not simply look for language tags in the pages, but actually analyzes the page itself.
 
			Ignore Diacritics: Check this option to automatically convert diacritics for the analysis into a normalized form. This also finds pages which contain German umlauts, French or Czech accents, or other diacritical characters.
 
			Example: Uncheck Ignore Diacritics to search for a word with accented characters when you definitely don't want to find the unaccented variant.

 
			Fuzzy: Check to search 'fuzzy'. This also finds words with similar but not identical spelling, e.g. 'gray' instead of 'grey'.

		
		Filters, scanners,... 

			Filters: Check the following filters to automatically filter out special pages you don't want to include in the results list:
 
			
					Similar Pages: Filters out pages similar to results previously found in this search run.

					Archived Pages: Filters out all pages that are already stored in the  archive.  DEVONagent Pro compares only the URLs here, not the actual current content of the pages.
 
			

			Scanner: Scanner plugins post-process and filter the list of found pages by formal criteria. Read more about about scanners in the appendix. 
 
			Example: Use the powerful feature unique to DEVONagent Pro to filter, for example, all pages except those containing a thumbnail gallery, linking to Office documents or containing email addresses.

 
		
		Comments 

			Enter a brief description for a search set here. This description is shown in the tool tips of the magnifier pop-up menu  in a search window. 
 
		
	Advanced tab

		On the Advanced tab, you define in which parts of webpages DEVONagent Pro searches, which type of files it searches, and whether it accepts all pages or only new results in a search run.

		[image: Search Set Editor, General Tab]
 
		Search in 

			Choose which parts of a document DEVONagent Pro searches for the query. Not all file types have all characteristics.

			
					Title

					Text

					URL

					Keywords

					Description

					Objects

			

		
		Files 

			Choose which file types DEVONagent Pro searches and accepts as results.

			
					HTML & XHTML pages

					Atom, RSS, RSD & RDF feeds

					Plain text documents

					PDF & PostScript documents

					OpenOffice & StarOffice documents

					Rich text documents

					Microsoft Word documents

			

		
		Results 

			Choose if you want DEVONagent Pro to accept only on new pages as results or all found pages.

			
					All pages: Always accept all matching pages.

					Only new pages: Accept only new matching pages.

			

			DEVONagent Pro keeps an internal log of found results to recognize what's new. It also lists the number of results stored in the log. To clear the internal log, click the Reset button.
 
		
	Sites tab

		The Sites tab allows you to define a list of webpages that DEVONagent Pro scans when you use this search set. DEVONagent Pro downloads each of these pages and tests whether it matches your query or not, like your private little Google. Use it together with the default query  to scan your frequently visited pages for important keywords.
 
		[image: Search Set Editor, Sites Tab]
 
		Managing the Sites List 

			To add a page to the list, enter the URL into the location field at the bottom of the window. If the page requires a user name and password, enter them into the appropriate fields. Click the + button to add the page. To remove a page, select it in the list and click the - button.
 
			You can also use drag-and-drop or copy/paste to add URLs to the sites list, and use the contextual menu to open the page in a browser window  or copy the URL. This also adds the title of the page to the Info column if possible. You can copy URLs in this list to the clipboard or drag them to other applications, too.
 
			You can use ranges like [01-31] or [1-31] to quickly add whole ranges of URLs. Add e.g. "http://www.classicfm.nl/playlist/per-dag/201202[01-29]" to add all playlist from .../20120201 through |20120229.

			Uncheck a page to exclude it temporarily from being scanned, check it to include it in the next search run.

		
		Taking over URLs 

			To take over bookmarks from other applications and create new search sets from them, use drag-and-drop, copy/paste, or import bookmarks or OPML files. Open the settings editor and use File > Import  or the Action  menu to import bookmarks from Camino,  Firefox,   OmniWeb  or Safari, as well as OPML files generated by news readers or DEVONthink. 
 
		
		Contextual menu 

			The contextual menu allows you to work with website addresses selected in the sites list.
 
			
					Open: Opens the selected sites in separate web browser windows. 

					Open In Tabs: Opens the selected sites in separate tabs in a new web browser window. 

					Launch URL: Opens the website in your default web browser.
 
					Enable/Disable: Checks or unchecks an item. Unchecked (disabled) websites are not scanned when using this search set.
 
					Copy: Copy the URL of the selected website to the clipboard.
 
					Paste: Pastes a URL from the clipboard to the list, effectively creating a new item.
 
					Delete: Deletes a selected item.

			

		
	Plugins tab

		The Plugins tab defines which plugins  (interfaces to search engines) DEVONagent Pro uses when you use this search set in the search window. 
 
		[image: Search Set Editor, Plugins Tab]

		Plugin List 

			The plugins are grouped. Expand or collapse groups by clicking the grey triangle in front of the group name, like in the Finder. Check all plugins that you want DEVONagent Pro to use for this search set, uncheck all others. Check or uncheck a group to check or uncheck all plugins contained in it. Select a plugin to display a short description.
 
			To find out which search engines a plugin uses to get results, use Window > Plugins & Scanners  or see the appendix. 
 
			Example: Check "Images", "Info (Pictures)" and "Picsearch (Images)" to search all major picture search engines.


		
		Results per Plugin 

			This value defines the number of results delivered by every plugin.  It limits the result pool to the most relevant <n> results. Adjust this to whatever suits your requirements, the default value is 100.

		
	Actions tab

		The Actions tab enables you to attach additional actions to a search set that DEVONagent Pro executes after finishing a search run with this search set.
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		Interface 

			
					Bounce Dock icon: Bounces DEVONagent Pro's Dock icon once when the search run is complete.
 
					Zoom and bring to front: Zooms the search window and makes it the frontmost window.

					Notify via Growl: Posts a Growl  notification. Use the Growl System Preferences pane to configure Growl notifications for DEVONagent Pro.

					Play sound: Plays a sound. Select the sound to be played from the pop-up menu; all system-wide available alarm sounds are available.
 
					Speak text: Speaks entered text. Use the escape sequence "%d" in the text to announce the number of found items.

			

		
		Results 

			
					Archive results: Adds all found pages to the internal archive. 
 
					Add results to DEVONthink: Adds all found pages to the currently open DEVONthink (Pro) database.
 
					Send mail to: Sends a summary of the found information to an entered email address. Especially useful when you use it with a  schedule. 
 
					Execute script: Executes an AppleScript.  Use this to do whatever you like with the found information, e.g., feed it into a local workflow or automatically post it to a website.

			

			Note: The email function uses the email account defined in Preferences, Email  tab.


		
	Schedule tab

		The Schedule tab is what makes DEVONagent Pro a real information agent. It lets you schedule automatic query runs every hour, day or week and return the results by email, archive them internally or add them to your DEVONthink  database.

		[image: Search Set Editor, Schedule Tab]

		Note: A scheduled search set uses the default query you enter on the "General" tab and runs this at the scheduled time. So, make sure to enter a default query when you use the scheduler.


		Frequency, ... 

			
					Frequency: Define if you want DEVONagent Pro to run this search set hourly, daily, or weekly, or select Never to switch the scheduler off.

					Time of Day: Define at which time of the day DEVONagent Pro runs this search set.

					Day of Week: Define on which day of the week DEVONagent Pro runs this search set.

			

		
		Options 

			
					Quit when done: Quick DEVONagent Pro after this search run is done.

					Close window: Close the search window when ths search run is done.

					Ignore cache: Ignore the cache and always load all pages from the Internet. Uncheck to use DEVONagent Pro's cache and to reduce network traffic.

					Next run: Check when this search set will run next (informative only).

			

		
	Menus


	A complete listing of all commands DEVONagent Pro offers in the menu bar, the global Services  menu, and the handy Dock  menu.


	
	
	
	
	
	
	
	
	
	

	
	
	
	
	

The DEVONagent Pro menu

		The DEVONagent Pro menu is similar to the application menu in any other Mac OS X application. It contains commands for displaying the splash screen, opening the preferences window, accessing the Services  menu, hiding and showing windows, and, of course, quitting the application.

		About DEVONagent Pro, ... 

			
					About DEVONagent Pro: Shows information about DEVONagent Pro including the version number and licensing information.

					Check for Updates: Checks if updates for DEVONagent Pro are available. By default, DEVONagent Prochecks for updates automatically; change your update settings in the Preferences, Update  pane.

			

			Note: For the check for updates no information is uploaded to the DEVONtechnologies server. DEVONagent Pro only downloads a file listing the most current versions to your Mac.


		
		Preferences, ... 

			
					Preferences: Opens the Preferences. 

					Private Browsing: Select this command to check or uncheck the private browsing mode. If this menu item is checked, DEVONagent Pro clears all caches and history files after quitting, so that other persons using this user account on this computer later cannot discover what you have been searching. Also, this options prevents DEVONagent Pro from storing previous search terms in the Recent Searches sub-menu of the magnifying glass pop-up menu  of search windows.
 
					Empty Cache: Empties the disk cache that is used to speed up browsing. Use this if you are running out of disk space or when you feel that some pages or elements are not up-to-date. Emptying the cache effectively forces DEVONagent Pro to download all files in their most recent version from the Internet again.

			

		
		Purchase, ... 

			
					Purchase: Opens the DEVONtechnologies Online Shop  and puts DEVONagent Pro into your shopping cart. If this copy of DEVONagent Pro is already licensed you will be presented with the choice of buying an upgrade for your existing license or buying another full license.

					Enter License: Use this command to enter your licence code. Make sure you enter ALL the details EXACTLY as they appear in the licence code email. It is best to use copy-and-paste for transferring name, organization, and licence code from the email message to the appropriate fields.

			

			Note: Enter License changes into License as soon as you have entered a valid license code.


		
		Services 

			
					The Services sub-menu gives your access to special commands published by other Mac OS X applications such as TextEdit or Safari, or by services extensions such as our own WordService or CalcService.  Also, DEVONagent Pro publishes its own services. [Read more...] 

			

		
	The File menu

		The "File" menu contains all commands that create new windows, open or save files or settings, and printing.

		New Search, ... 

			
					New Search: Opens a new search window.  You use search windows to send queries to a predefined search set  or a selected plugin,  that then queries one or multiple search engines and presents the weighted results. Search windows are what give DEVONagent Pro its name and purpose.

					New Plugin: Opens the Plugins & Scanners  window and lets you create a new custom plugin. Use it to easily create a plugin for your favorite but yet unsupported search engine.

			

		
		New Browser, ... 

			
					New Browser: Opens a new web browser window. Use this function to use DEVONagent Pro as a standard web browser but optimized for research. The web browser is based on the WebKit engine that is also used by Safari.
 
					New Tab: Creates a new tab in the frontmost web browser window. If the frontmost window is not a web browser window but a search window, this command opens a new web browser window instead.

					Open Location: Brings the address field of the frontmost web browser window into focus. If no web browser window is open, DEVONagent Pro opens a new one, equally to File > New Browser.
 
			

		
		Open File, ... 

			
					Open File: Opens a local file for viewing in a new web browser window  or a previsouly saved search. Alternatively drag the file onto DEVONagent Pro's icon in the Dock.

					Open Recent: Lists the recently used saved searches to quickly open them.

			

		
		Save As, ... 

			
					Save, Save As: Saves the content of the frontmost web browser window  in its original format or a search run for future reference. Webpages are saved as pure HTML code or webarchives (see below), images, movies, and PDFs in their respective formats. Search runs are saved as '.agentSearch' files that can be double-clicked in the Finder or opened via File & Open. They include the term, the used set or plugin, the settings, the results, their sorting, the digest, the log, and a Quick Look preview.

			

		
		Import 

			
					Sets: Imports saved search sets and adds them to the list of available search sets. You can also import saved search sets by double-clicking them in the Finder or by dragging them to DEVONagent Pro's Dock icon.
 
					OPML: Imports all URLs contained in an OPML file and creates a new search set with the URLs in the Sites tab. Use this to import e.g., RSS feeds exported as OPML from a news reader.
 
					<Application> Bookmarks: Imports Camino, Firefox, Chrome, OmniWeb, or Safari bookmarks and creates a new search set  with all imported URLs in the Sites tab. Both site and news feed bookmarks are supported. If a web browser window is frontmost the bookmarks will be added to DEVONagent Pro's own bookmark list. 

					Safari History: Imports the Safari history file and creates a new search set with all imported URLs in the Sites  tab.

			

		
		Export 

			
					Digest: Exports the digest as plain or rich text file. This command can also export the topics map as a PDF document.

					Report: Exports a search report as PDF, CSV (comma-separated values), HTML, or OPML file. Use the CSV or OPML formats to export all results in a structured way to re-import them into other applications such as Microsoft Excel or Apple Numbers.

					Results: Exports selected search results in their original formats, as bookmarks, plain text files, or rich text files.

					Sets: Exports one or more selected search sets  and saves them as files. These files can be re-imported using File > Import > Sets or by double-clicking them in the Finder. Use exported sets to shared them with other DEVONagent Prousers or between computers.

			

		
		Page Setup, Print 

			
					Page Setup: Opens the standard page setup dialog.

					Print: Prints the contents of the frontmost window.

			

		
	The Edit menu

		The "Edit" menu contains all commands and options relating to editing. You'll find the classic Mac cut/copy/paste and find/replace commands here, as well as many more.

		Undo, Redo 

			
					Undo: Takes your changes back one step. Undo mainly works for text edits, but does not bring back deleted documents.
 
					Redo: Redo re-does the last undone edit.

			

		
		Cut, Copy, Paste 

			
					Cut: Cuts the selected items or text passages.

					Copy: Copies the selected items or text passages to the clipboard.

					Copy URL: Copies the URL of the selected page or frontmost web browser window  to the clipboard.

					Paste: Pastes whatever is on the clipboard.

					Clear: Deletes the selected item or piece of text.

					Complete: Auto-completes a word in text and search fields as well as in text views. This Mac OS X standard function relies on the dictionary you have selected in the Mac OS X spell checker (see below).

					Select all: Selects all contents of the frontmost window.

					Deselect all: Deselects all contents of the frontmost window.

			

		
		Find 

			This sub-menu contains commands for finding and replacing text. In most parts it is similar to the Find command in most Mac application sbut also contains some DEVONagent Pro-specific items.
 
			
					In Internet: Opens a new search window. 

					In Results: 

					Find...: Open the standard find panel.

					Find Next/Previous: Jumps to the next or previous
				occurrence of the find term.

					Use Selection for Find: Copies the selected piece of
				text to the find clipboard or into the search field of the find
				panel if it is open.

					Scroll To Selection: Scrolls the displayed documents to
				the current selection.

			

		
		Spelling, ... 

			
					Spelling and Grammar: Gives you access to Mac OS X's standard spell and grammar checker. Useful for checking text e.g., when filling out form fields.

					Speech: Speaks a selected piece of text.

					Special Characters...: Shows the standard Mac OS X special characters panel for inserting characters that you cannot enter directly with your keyboard, such as accented or umlauted characters.

			

		
	The Data menu

		The Data menu provides commands for opening search results, exporting them to DEVONthink,  archiving them, or organzing them in the built-in archive. 

		New Group, ... 

			
					New Group: Creates a new group in the archive.  To create a sub-group, select an archive group first, then use this command.

					Open: Opens the selected search results in new web browser windows.  Same as double-clicking the results.

					Open In Tabs: Opens the selected search results in separate tabs in a new web browser window. 

					Launch URL: Opens selected search results in your default web browser. If DEVONagent Pro is your default browser, this command is equal to "Data > Open..."

				
			

		
		Add to DEVONthink, ... 

			
					via Clip to DEVONthink: 

					Resource: Adds the selected page or document as-is to DEVONthink. 

					Bookmark: Saves links to the selected pages as bookmarks.

					Rich Text: Saves selected text as a new text document.

					Summary: Saves the whole digest as text document. Available on the Digest  and Results  tabs of Search  windows as well as in the archive. 

					PDF (one page): Saves the selected pages as PDFs without page breaks. A long webpage will be saved as one, very long page. Ideal for archiving. Only available in the web browser. 
 
					PDF (paginated): Saves the selected pages as PDFs with page breaks. Use this for archiving webpages that you may want to print later.
 
					Web Archive: Saves webpages as webarchives. Webarchives are self-contained files that include one webpage that includes all additional files necessary for displaying, e.g., embedded images or movies. Only available in the web browser. 

			

			DEVONagent Pro adds 'DEVONagent Pro plus the name of the plugin used to find the page and its version to the comments when adding to DEVONthink.

		
		Add To Set, ... 

			
					Add To Set: Adds selected pages, e.g., search results, to the "Sites" list of a search set you select from the sub-menu. These pages will be scanned for an entered query the next time you are using this search set and can be useful to include in a page in future searches. Select "New Set..." from the sub-menu to create a new search with the selected pages.

					Add To Archive: Adds the selected results to the archive, creating a new group for current search run. If a group for this search run already exists, any subsequently added page from same search run will also be added to this archive group.
 
					Add All To Archive: Adds all results of a search run to the archive, creating a new group for them. Use this command to archive all results of a search run with one click.
 
			

		
		Mark All Read, ... 

			
					Mark All Read: Marks the selected results as read or unread.

					See Also: Opens the See also drawer in the frontmost web browser window. 

					Delete: Deletes search results from a results list in a search window, as well as groups or items from the  archive. 

					Delete & Exclude Domain: Deletes the selected search results from a results list in a search window  and adds the domains of the pages to the list of excluded domains.  All other search results matching the exluded domains are also removed. Use this to quickly exclude an unwanted domain without having to block it via the Preferences. 

					Clear Log: Clears the Log  tab of the frontmost Search  window.

			

			Note: Use Delete and Delete & Exclude Domain with care. You cannot undo these commands.


		
	The Sort menu

		The Sort menu sorts search results in a variety of ways.

		Unsorted, By Name, ...:

				Unsorted: List results in their natural order. Useful e.g. after opening a saved search to easily view new results.

				Name: List results sorted by name.

				Date: List results sorted by date.

				Size: List results sorted by size.

				URL: List results sorted by their URLs.

				Top Level Domain: List results sorted by their top level domain.

				Relevance: List results sorted by relevance.

				Number of Objects: List results sorted by the number of found objects.

		

		Top Level Domain means the last part of a website address. Usually it is defined by the country the website is located in, e.g., '.de' for Germany or '.cz' for the Czech Republic, or by function, such as '.com' for a world-wide commercial site or '.mil' for a US military site.

		Relevance is the relevance of a result compared to the all collected results in respect to the query. This is the default sorting order.

		Ascending, Descending:

				Ascending: Sorts items ascending.

				Descending: Sorts items descending.

		

	The View menu

		The View menu allows to switch between the various tabs of a Search  window, to switch Cover Flow on and off, and to customize how objects are presented in web browser  windows.

		Digest, ... 

			
					Digest: Switches to the "Digest" tab. The digest shows a summary of the found information (not the pages), sorted by relevance. In addition, it visualizes topics in a topics map that lets you navigate the results graphically. Use the digest and the topics map to work with the information itself instead of manually visiting webpage after webpage.

					Results: Switches to the "Pages" tab. The "Pages" tab lists all found pages, sorted by relevance (or any sorting order you choose in the "Sort" menu). A preview pane displays the relevant text parts of a selected result.

					Log: Switches to the "Log" tab. The log lists all webpages that DEVONagent Pro has sorted out as being irrelevant to the query or outdated. View a selected page in the preview page. Use the log to see how many pages you DON'T have to look at because you're using DEVONagent Pro instead of Google or other search engines.

					Settings: 

					Advanced: 

			

		
		Summary, Objects 

			
					Summary: Selects the Summary tab of the Pages tab of Search  windows.

					Objects: Selects the Objects tab of the Pages tab of Search  windows.

			

		
		Cover Flow, ... 

			
					Cover Flow: Switches between the regular display of results  or tabs  and Cover Flow. Cover Flow lets you browse graphically and quickly through results or the pages opened in multiple browser tabs.

					Inverse Appearance: Inverts the colors of the results list in search and browser windows to match it with Cover Flow. Uncheck to return to regular black-on-white appearance.

					Show Icon Preview: Shows or hides the icon previews in Results   tab of search windows,  Sidebar  and See Also  drawer of web browser windows  and the archive.  

					Use Small Icons: When checked objects are shown with small icons and more information in the sidebar  of web browser windows. When unchecked, objects are shown with larg icons and no details.

			

		
		Show Toolbar, ... 

			
					Hide/Show Toolbar: Hides or shows the toolbar of the frontmost window.
 
					Customize Toolbar: Lets you configure the toolbar of the frontmost window.

					Enter/Exit Full Screen: Puts the frontmost window into full screen or back into windowed mode. Press ⎋ to return to windowed mode.

			

		
	The Web menu

		The Web menu contains all commands that are directly related to Web browsing, from quickly switching Java on or off to switching between views and reloading a webpage. All commands in this menu act on the frontmost web browser window. 

		Enable Plugins, ... 

			
					Plugins: Enables or disables plugins.

					Java: Enables or disables Java.

					JavaScript: Enables or disables JavaScript.

			

			Use these options to quickly switch plugins, Java, or JavaScript on and off without visiting the Preferences. 

		
		Stop Loading, ... 

			
					Stop Loading: Stops loading a the webpage. This is equal to clicking the reload/stop button on the address bar of a web browser window when a page is loading.

					Reload Page: Reloads the webpage. This is equal to clicking the reload/stop button on the address bar of a web browser window when a page is completely loaded.

					Actual Size: Zooms the page to its actual size.

					Zoom In: Zooms in.

					Zoom Out: Zooms out.

					Zoom Text Only: When this option is checked, only the text of the page is made larger and smaller. When unchecked, DEVONagent Pro uses Safari-4-style zooming.

					Translate: Translates the displayed page using the Google language tools to your system's preferred language. This command is unavailable of if the recognized language of the displayed page is the same than the preferred language of your system.

					Text Encoding: Changes the text encoding used for displaying a webpage. Use this sub-menu to manually adjust the text encoding if DEVONagent Pro displays accented characters, umlauts or East Asian characters incorrectly. Generally, websites publish their encoding and DEVONagent Pro reads this metadata for adjusting the encoding automatically.

			

		
		View, ... 

			
					Source Code: Shows the source code of the webpage.

					Text: Shows only the pure text of the webpage.

					Layout: Shows the webpage rendered (normal).

			

			These three options switch the mode of the frontmost web browser window  between different modes. Use these modes to view only the raw text of a layout-intensive webpage, or to switch to the source code to find information that is hidden in the code but not visible in the layout. DEVONagent Pro displays the source code with syntax coloring. The text only mode is also useful for copying/extracting information from pages with a complex table layout.

		
		Sidebar 

			
					Show: Shows or hides the sidebar. 

					Bookmarks: Switches to the bookmarks pane of the sidebar. 

					Objects: Switches to the objects pane of the sidebar. 

					Results: Switches to the results pane of the sidebar. 

			

		
		Address Bar, Full Screen 

			
					Address Bar: Shows or hides the address bar. Hiding the address bar gives you more real screen space for the displayed webpage.

			

		
	The History menu

		As with any web browser, the History menu lists all webpages previously visited, divided into sub-folders for each day.

		Back, Forward, Clear History 

			
					Back, Forward: Moves back and forth between the visited pages. These commands are equal to the back and forward buttons in the address bar  of web browser windows.  As there is no history when private browsing  is active, these commands are not available when private browsing is switched on.

					Clear History: Clears the history.

			

		
		Visited webpages 

			The rest of the History menu lists the previously visited webpages, sorted from the top by their age.

		
	The Go menu

		The Go menu contains commands for navigating back and forth through all of the results of a results list in a search window  or occurrences of a search word, as well as using and managing bookmarks.
 
		Next/Previous Result/Occurrence 

			
					Next/Previous Result: Navigates back and forth through the results lists to which the displayed webpage belongs. Use these commands to go through the resulting pages of a search run.

					Next/Previous Occurrence: Jumps to the next or previous occurrence of the search term, e.g., in the digest or pages tabs of search windows. 

			

		
		Bookmarks 

			Besides the commands mentioned above, the Go menu gives you access to the bookmarks of Safari, Camino, Firefox, or OmniWeb, or DEVONagent Pro's own bookmarks list. Select which bookmarks DEVONagent Pro shows in the Go menu in the preferences. 

			
					Add: Adds a bookmark for the currently shown webpage.

					Add Folder: Adds an empty folder to the bookmarks list.

					Edit: Opens an edit sheet for the currently selected bookmark. Unavailable when two or more bookmarks are selected.

					Delete: Deletes the selected bookmarks.

					<Bookmarks>: Opens any selected bookmark; use Open in Tabs in any bookmark folder to open all bookmarks in the folder in separate tabs.

			

			For these commands to work a web browser window  needs to be active and DEVONagent Prouse its own bookmarks. You cannot yet edit e.g. Safari's bookmarks from within DEVONagent Pro.

		
		Bonjour 

			The Bonjour part of the Go menu lists web services advertised on the local network via Bonjour, e.g., printers with web interfaces or shared DEVONthink Pro Office  databases.

		
		Workspaces 

			Workspaces save the content and positions of all open windows so that you can restore them later. This is, e.g., ideal if you are working with the same set of windows over and over again. Save them as a workspace and recall them whenever you need them again.

			
					Add: Saves the currently open windows as a workspace.

					Edit: Opens a window that allows you to edit saved workspaces. Click on a workspace name to change it, reorder by dragging, and delete with the . button.

					Workspaces: Restores to a previously saved workspace.

			

		
	The Window menu

		As in any Mac application, the Window menu lists all open windows of DEVONagent Pro and gives you access to commands for managing them.

		Window Commands:

				Close/Zoom/Minimize: These three commands resemble the red, yellow and green buttons of any window title bar and consequently close the window, maximize it or iconize it to the dock. No magic here.

				Bring All to Front: Brings all windows of DEVONagent Pro to the front.

				<Window name>: Brings a selected window to the front.

		

		Tab Commands:

				Close Tab: Closes the current tab of the frontmost web browser window. 

				Select Next/Previous Tab: Switches to the next or previous tab of the frontmost web browser window. 

		

		Archive ... Downloads:

				Archive: Opens the Archive  window.

				Search Sets: Opens the Search Sets  panel which allows you to edit the available search sets. 

				Plugins & Scanners: Opens the Plugins & Scanners  panel that lists all installed plugins and scanner modules. Use this panel to see which plugins or scanner modules are available, get more information about them, and activate and deactivate them.

				Downloads: This command opens the Downloads  panel. Use it do can download files from the Internet to your computer.

		

	The Services menu

		The Application > Services menu (where 'Application' is the name of the frontmost application) allows access to special commands published either by other Mac OS X applications, such as TextEdit or Safari, or by services extensions such as DEVONtechnologies' WordService or CalcService.  Also, DEVONagent Pro publishes its own services in the Services menu.

		The Services menu is a sub-menu of every application's application menu, the menu named after the application itself and carrying the About X, Hide ... and Quit commands. Services usually act on a selection, e.g. selected text or files.

		Services provided by DEVONagent Pro:

				Lookup: Opens a new search window  in DEVONagent Pro with the selected text pre-filled into the query field. Use this command to quickly search for a selected piece of text.

				Open URL: Opens a selected piece of text as a URL in DEVONagent Pro. Use this to quickly select a URL, e.g., in an email message, and open it in a DEVONagent Pro web browser window. 

		

		Use Application > Services > Services Preferences to change keyboard shortcuts or hide selected commands to clean up the Services menu.

		Note: After installing DEVONagent Pro you may need to log out and back in again for the Finder to recognize the new Services menu commands and shortcuts. If one or more DEVONagent Pro Services menu commands does not have a keyboard shortcut assigned to them, perhaps another application grabbed it. Mac OS X automatically assigns the correct shortcut when no other application asks for the same key combination.


	The Scripts menu

		The Scripts menu is located left of the Help  menu and shows a graphic AppleScript 'S' symbol instead of a normal menu title. It contains a collection of useful, predefined AppleScripts you can use directly from within DEVONagent Pro.

		Some of the scripts work without a selected document, others require you to select the document you want the script to interact with. In general, the script will tell you what you have to do when you select it from the Scripts menu.
 
		[Read more...] 
 
	The Help menu

		The Help menu contains commands for opening the integrated help pages, the support assistant, or visiting the DEVONtechnologies website.

		DEVONagent Pro Help 

			These commands open the integrated help pages that are equal to the document you're just reading or open the release notes. 

		
		Support Assistant, Tutorials 

			Opens the support area of the Welcome to DEVONagent Pro assistant where you can e.g. read the FAQ, visit the user forum, download this documentation as printable or screen-readable PDFs, retrieve your license code, request a trial extension, or update your details in DEVONtechnologies' customer database. Choose Tutorials to directly open the assistant on the Tips & Tutorials page.

			Click here [special link, not enabled in ebook]  to directly open the assistant.

			Note: If you have purchased DEVONagent Pro on the Mac App Store all options dealing with licenses or upgrades are not available.


		
		DEVONtechnologies 

			These commands take you directly to the corresponding pages on the DEVONtechnologies website. Visit our home page or the lively user forum.  If you have a question or suggestion, send feedback directly to our development team.

		
	The Dock menu

		The Dock menu appears when you ⌃-click or right-click DEVONagent Pro's icon in the Dock. In addition, DEVONagent Pro's icon hows a badge with the number of found results.

		[image: The Dock menu]

		For all Mac OS X applications, the Dock menu provides a selection of the commands of the application menu. 

		
				<Window Name>: Brings any open window of DEVONagent Pro to the front.

				Options > ...: Keeps DEVONagent Pro in the Dock or removes it from it, adds DEVONagent Pro to your login items, or reveals the DEVONagent Proapplication package in the Finder.

				Hide: Hides all windows of DEVONagent Pro.

				Quit: Quits DEVONagent Pro.

		

		Besides these standard commands, DEVONagent Pro adds a number of its own commands to the Dock menu to make them easily accessible, whenever the application is running.

		
				New Search...: Opens a new DEVONagent Pro search window.  Same as File > New Search 

				New Browser...: Opens a new DEVONagent Pro web browser window.  Same as File > New Browser" 

				Bookmarks, Bonjour, Workspaces: Gives you access to your bookmarks, depending on your settings in Preferences > Bookmarks,  Bonjour services, and workspaces. Equals the Bookmarks, Bonjour, and Workspaces parts of the Go  menu.

		

	The contextual menu extension

		DEVONagent Pro installs its own contextual menu plugin. It inserts a Search in DEVONagent Pro menu item into the contextual menu of most Cocoa and Carbon applications.

		[image: The contextual menu extension]

		Select some text, such as in an email, webpage or Pages document, ⌃-click or right-click the selection and select "Find with DEVONagent Pro. DEVONagent Pro opens a new search window with the selected text pre-filled into the query field.

		Note: As Mac OS X 10.6 inserts the Services  menu system-wide into the contextual menu, this extension is only installed on Mac OS X 10.5.


	Windows and panels


	DEVONagent Pro uses a number of different windows for running search queries, displaying webpages, setting up search sets or downloading files.


	

	

	

	

	

	

	

	

Search window

		[image: The Search Window and its Elements]
 
		The search window is where you start search runs and work with the results. You open a new search window with File > New Search  In its minimized form, the search window consists only of an entry field for the query, including a pop-up menu for selecting the search sets to be used, a Start/Stop button, and an Append button. In maximized form, it is divided into three tabs: digest, pages, and log. You can switch between minimized and maximized form by clicking the green window gadget. Also, you can choose whether you want to open new search windows as either minimized or maximized in the preferences, "General" tab. 
 
		To start a search run, select the correct search set from the magnifier pop-up menu in the entry field, enter your query and click the Start button. DEVONagent Pro then queries all search engines and scans all webpages defined by the search set. As soon as the search run has finished (or you have clicked the Stop button), DEVONagent Pro expands the search window, if necessary, and presents the results in either the Digest  or the Results  tab, depending on your preferences. 

		If you had already performed a search run, you can also use the Append button instead of Start to append the search results to the already collected ones instead of replacing them.

		Note: DEVONagent Pro limites search runs to 500.000 result pages and 32 GB of data. This prevents flooding your hard disk when your search query or your Follow Links settings are too broad.

 

		Magnifying glass pop-up menu 

			The magnifying pop-glass up menu [image: ] lets you select the search set you want to use for your search. For a general search, use the search set Web (Fast). You can define your own search sets in the Search Sets  window which you can also open by selecting Edit Search Sets from the magnifier pop-up menu.

			User-defined plugins are listed in bold.

			Note: You can easily create a new search set by using the + button left of the search term field. Use this to run the same query with exactly the same settings again in the future.

 
			Plugins: In addition, this pop-up menu gives you direct access to every installed plugin. This way, you don't have to define a search set just for querying a special search engine once. You can simply pick the one you want to use, enter the query and hit the Start button. Tool tips give you more information about each plugin.
 
			Recent searches: Finally, the magnifying glass pop-up remembers the last 25 search terms (when private browsing is not enabled). You recall them simply by selecting them from the Recent Searches part of the menu. Remember to select the correct search set  or plugin.
 
		
		
		Status bar 

			The status bar below the search field shows information about the number and size of the downloaded files and found results and objects as well as unread results.

		

		Digest tab 

			DEVONagent Pro's search window is divided into three views that present different aspects of the information that has been collected in a search run. You switch between the views by clicking the tabs that separate the search field from the rest of the window.

			The digest differs from what traditional search engines and applications display. It is what makes DEVONagent Pro unique. Instead of simply listing the URLs of found pages, the digest shows a list of topic words and two-word expressions that DEVONagent Pro has extracted from the collected data. This list not only includes the entered search words, but also many other words that the artifical intelligence core of DEVONagent Pro found to be important and related to the query. You can sort this list by topic or relevance by clicking the column headers. The number of sentences with occurences is shown for each topic word.

			[image: The topics map]

			Topics map: In the right hand side pane, DEVONagent Pro first shows short paragraphs from every found webpage, until you select one or more topic words. DEVONagent Pro shows an AI-generated visual representation of the selected topic and its relations to other topics in a mind-map style. Two-word expressions do not show a topics map; for multiple selected topic words DEVONagent Proalways picks the top one.

			The selected topic becomes a big blob in the center of the map with all related topics arranged around it. The larger a blob and the more orange or red it is, the more important it is. Topics related to the selected word but that are not part of the topics list on the left, are shown in blue. Light grey lines show closer relationships between topics. Move the mouse over the topic blobs to highlight the connetions to other topics in the graph; click a blob to select it. Double-click a topic in the map to make it the center of the graph. DEVONagent Pro will recalculate the map accordingly. This is similar to selecting another topic word from the list to the left.

			Using the arrow buttons in the bottom bar of the topics map area you navigate back and forth through the results in the digest.

			Summary: Finally, below the topics map, DEVONagent Pro shows a summary of the extracted information sorted by relevance. At the end of each extract, you'll also find a link to the original source where DEVONagent Pro extracted the data from (click the link with ⌘ held to open it on a new tab instead of in a new window.) The summary delivers the actual answer to your query, effectively eliminating the need to go through a long list of links and visit hundreds of webpages manually.

			This summary dynamically changes with whatever topic word or words you select in either the left hand side pane or the topics map. This way, you can use the topics map to navigate through the found information and re-focus the summary to whatever you are interested in. You can also click words in the summary with ⌥ held to refocus the topics map on the clicked word.

			Note: You can also select multiple topics with the ⇧ and ⌘ keys, or enter your own keywords, separated by spaces, into the text field below the topics list. For the topics map, DEVONagent Pro will only use the first selected topic word. It does not work with words you enter into the keyword text field.


		

		Results Tab 

			List or Cover Flow: The Pages tab is similar to what most search engines deliver, a list of all found URLs including the name of the webpage and a two lines excerpt from where on the page the search terms are found. Sort the list by all the criteria that you can find in the Sort  menu. You can also drag results to DEVONthink to quickly archive them in your database.

			[image: The Pages tab]

			You can browse the results also with Cover Flow.  Double-click a page in Cover Flow to open it in a new web browser window;  hold the ⌘ key to open the new window in the background.

			All pages that you haven't checked yet show a dot in front of them, similar to unread messages in Apple Mail. You can also select results, drag them to other applications, such as an open TextEdit window, DEVONthink,  or the Finder, or delete pages from the list that you have found to be unrelated to your research. A badge shows the number of found scanner objects.

			Preview area: In the lower pane of the Pages tab, DEVONagent Pro displays either a text preview of the relevant text passages for pages selected in the list above, or all objects found by the automatically applied scanners . Switch between the text preview and the objects returned by the scanners using the navigation bar above the preview.

			In addition you switch between small and large icons, download all or selected objects, and access the action menu from the navigation bar.

 		

		Log tab 

			The Log tab lists all pages that DEVONagent Pro has skipped.

			DEVONagent Pro skipped them because they:

			
					Did not match the query

					Deliver an error message, e.g. the famous error 404 (file not found)

					Are an advertisement

					Are index spam created for fooling Google and other search engines

			

			You can find a complete list of all codes used in the log in the appendix. 

			Effectively, the log lists all pages you did not have to look at yourself because DEVONagent Pro did that job for you.

			[image: The Log tab]

			You can sort the list by date, address, or error message by clicking the respective column headers. Click them again to reverse the sorting order. Use copy-and-paste or drag-and-drop to e.g. move or copy URLs to the Downloads  panel, to a search set,  to DEVONthink,  or other applications, e.g. Safari.

		

		Settings tab 

			The Settings tab contains some of the options from the General  and Advanced  of search sets and overrides these settings TEMPORARILY.
 
			[image: Settings Tab]

			The Settings tabs offers the following options:

			
					Follow Links  

					Language  

					Filter & Scanner  

					Secondary Query  

			

			
					Search In 

					Files 

			

			Use the Settings tab to temporarily enable or disable options, for example to switch on a scanner  without permanently messing up the search set.

		

		Toolbar 

			The toolbar of DEVONagent Pro's main windows carries many commands for manipulating the way it displays information and for manipulating selected items. Many of them are simply shortcuts for menu bar commands. Here's a short list of the available tools:
 
			
					Open: Opens the selected page(s) in a separate web browser window. 
 
					Launch URL: Opens the selected page(s) in your default web browser.
 
					Export: Exports the selected page(s) as pure text, RTF(D) or HTML.
 
					DEVONthink: Adds the selected page(s) to the currently open DEVONthink  database in the format you choose from the pop-up menu.

					Add: Adds the selected page(s) to the internal archive. 
 
					Add All: Adds all found pages to the internal archive. 
 
					Archive: Opens a window for the internal archive. 

					Delete: Deletes the selected page(s) from the results list.
 
					Print: Prints the results list.

					Search: Searches the results on the Results  tab. Use the magnifying glass pop-up menu to adjust your search options.

					View: Enables or disables Cover Flow and shows or hides icon previews.

			

			Note: Not all of these commands are always available. You can customize the toolbar by selecting Viiew > Customize Toolbar  or by Control- or right-clicking the toolbar background and selecting Customize Toolbar from the contextual menu.

 
		

		Shortcuts & modifier keys 

			Like any Mac application, DEVONagent Pro uses modifier keys or shortcuts to quickly access frequently used functions or modifying a standard behavior.
 
			
					Command-click: Adds an item to the current selection of items.
 
					Shift-click: Selects a range of items.

					Space, Shift-Space: Scrolls down or up in non-editable text views, e.g., the summary.
 
			

		

		Contextual menu 

			The contextual menu, which appears when you click something with the right mouse button or when you click while holding the ⌃ Control key down, offers a range of commands tailored to what you can do with the clicked object, for example a text passage.
 
			Most of the commands offered by the contextual menu have counterparts in a main menu, so you'll recognize them immediately. However, to save menu bar real estate, DEVONagent Pro gives you access to some options only via the contextual menu.
 
			
					Open: Opens the selected pages in separate web browser windows. 

					Open In Tabs: Opens the selected pages in separate tabs in a new web browser window. 

					Copy URL: Copies the selected URL to the clipboard.
 
					Launch URL: Open the selected page(s) in your default web browser.
 
					Reveal in Finder: Reveals an externally archived page in the Finder.
 
					Add to DEVONthink: Adds the pages to your currently open DEVONthink database in a variety of formats. Same as Data > Add to DEVONthink. 
 
					Add to Set > ...: Adds the addresses of the selected page(s) to the sites list of a search set. Select "New Set..." to create a new search set with the selected page(s).
 
					Add to Archive: Adds the selected page(s) to the internal archive. 
 
					Add All to Archive: Adds all pages in the results list to the internal archive. 

					Export: Exports the selected page(s).

					Mark As Read: Marks the selected pages as read or unread.

					Delete: Deletes the selected page(s) from the results list.
 
					Delete & Exclude Domain: Deletes the selected search page(s) from the results list and adds the domain(s) of the page(s) to the list of excluded domain. Use this to quickly exclude an unwanted domain, without having to block it via the preferences. 
 	Sort by > ...: Sort the results list by the criteria listed in the sub-menu.

					Clear Log: Clears the log for the search run. Same as Data > Clear Log. 

					Sort By: Sorts the results list by the chosen sort key. [Read more...] 

			

			In text areas, e.g., the text preview on the "Pages" tab, DEVONagent Pro also offers the standard contextual menu commands for text views:
 
			
					Search with Spotlight: Searches for the selected text using Spotlight (Mac OS X 10.4 Tiger only).
 
					Search in Google: Opens your default browser and searches for the selected text in Google (Mac OS X 10.4 Tiger, only).
 
					Look Up in Dictionary: Looks up the selected piece of text in Mac OS X's Dictionary.
 
					Cut/Copy/Paste: Same as  "Edit > Cut/Copy/Paste". 
 
					Spelling > ...: Gives access to Mac OS X's integrated spell checker. Choose "Spelling..." to open the spell checker panel, and "Check Spelling" to run the spell checker on the text. "Check Spelling as You Type" is not available in read-only text views.
 
					Speech > ...: "Start Speaking" speaks selected text, "Stop Speaking" stops speaking, which is useful when speaking a very long piece of text.
 
			

		
	Web browser

		[image: The browser window and its elements]
 
		Besides being a research tool, DEVONagent Pro is a full-fledged web browser, based on the Safari engine (a.k.a. 'WebKit'). Open a new web browser window by choosing File > New Browser,  clicking a link, or by choosing File > Open Location  when no web browser window is frontmost.
 
		To visit a website, enter its address into the address field of the toolbar and press ⏎ or Enter. Alternatively, drag a URL to DEVONagent Pro's application icon in the Finder or in the Dock, or into an open browser window.
 
		Instead of a URL you can use keywords to directly send a simple query to a search engine. This effectively replaces the Google search field found in Safari and others. The keywords are defined by the plugins,  but can be individually edited.
 
		Example: Enter 'google apple computer' to query Google for 'apple computer'; enter 'mu devonthink' to query MacUpdate for 'devonthink'.


		Tab bar 

			The tab bar below the toolbar lists all tabs of the web browser window. Each tab contains a different webpage. Use tabs to open multiple webpages without cluttering your screen with dozens of separate windows. Switch between tabs by simply clicking the tab you want to bring to the foreground. If all tab do not fit into the available space DEVONagent Pro shows an optional pop-up menu at the right hand side of the tab bar listing all available tabs.

			Point to a tab for once second without clicking to shows a tooltip with a thumbnail preview of the webpage displayed on the tab. This is useful when you cannot remember which page you opened on which tab.

			Inactive tabs show a close button instead of the webpage icon. Also, after the last tab, DEVONagent Pro shows a "+" button for creating new, empty tabs.

		
		Toolbar 

			The toolbar of a web browser window can be customized like any other toolbar using View > Customize Toolbar.  The following tools are available:
 
			
					Window: Shows or hides the sidebar;  switches Cover Flow  mode on and off; switches to full screen mode. 

					View: Switches between source code, text, and layout views.  Use the source code view to inspect how a page is constructed and the text mode to see the raw text without any distracting layout.
 
					Action Menu: Access frequently used commands directly from the toolbar. [Read more...] 

					Back/Forward: Navigates back and forth through the visited pages, like a standard web browser. Similar to "History > Back/Forward". 
 
					Smaller/Bigger: Makes the text smaller or bigger.
 
					Reload/Stop: Reloads the current page (circle arrow icon) or stops loading a page ('X' icon).

					Address: Type in the URL to load here, or type in a keyword and a simple query. Read more about keywords here.  Select the whole address in the address field and drag it to other windows or applications, e.g., the Finder.
 
					Translate: Shows the language of the displayed page as recognized by DEVONagent Pro as a flag. If your system's preferred language is different, clicking the flag translates the page using Google language tools. 

					See Also: Opens a drawer with pages similar to the current one, sorted by relevance. Select a page in the drawer to display it. The originating page is always listed on the top of the list. Use See Also for finding related pages in the results pool. [Read more...] 

			

			If a bookmark for the current page exists in the open DEVONthink Pro  databases a small DEVONthink icon is shown on the right hand side of the address field.

		
		Sidebar 

			The sidebar is the place in a web browser window where all additional information is presented, from bookmarks to the list of search results (if the page is part of the results of a current search run) and extracted objects. The sidebar is divided into several sub-tabs:

			
					[image: ] Bookmarks

					[image: ] Results

			

			Bookmarks: Use the Preferences  to choose what bookmarks and additional elements, e.g. Web servers announced via Bonjour, DEVONthink Pro  bookmarks, or workspaces,  are listed on the Bookmarks pane. If you are using DEVONagent Pro for your bookmark management use e.g. cut/copy/paste,  drag-and-drop, or the contextual menu (see below) to edit your bookmarks.

			Results: The Results pane lists all results of the search run the shown webpage belongs to. This pane is unavailable if the page does not belong to a currently open search run.

			In addition, none, one, or multiple of the following tabs, unique to DEVONagent Pro, can be available:

			
					[image: ] AppleScript scripts

					[image: ] Audio

					[image: ] Code

					[image: ] Downloadable archives

					[image: ] Electronic business cards (.vcard)

					[image: ] Email addresses

					[image: ] Images

					[image: ] LaTeX files

					[image: ] Links

					[image: ] News feed (RSS, Atom)

					[image: ] Office documents

					[image: ] Spreadsheet documents

					[image: ] Thumbnail galleries

					[image: ] Video (live)

					[image: ] Videos

					[image: ] Wallpapers, desktop pictures

					[image: ] Webcams

			

			Which, if any, of the above tabs are available depends on the webpage shown in the window. DEVONagent Pro collects all objects from the page using the available scanners  and lists them in separate tabs in the sidebar. Click any found object to display it (double-click to open it in a new tab, if tabbed browsing  is enabled, or a new browser window). Click with ⌘ pressed to open the result in a new tab. The Back button brings you back to the original page.

			Bottom bar: The bar at the bottom of the sidebar gives you access to commonly used commands, depending on which tab is active.

			
					+: Adds the current page to the bookmarks.

					-: Removes the current page from the bookmarks.

					List: Shows objects in a list with small icons. [Read more...] 

					Icons: Shows objects as large icons. [Read more...] 

					Download: Adds the selected objects to the Download Manager.  If no item is selected all items will be added.

					Action: Gives access to the same options than the contextual menu (see below).

			

			Contextual menu: The contextual menu gives you direct access to commands acting on the selected items. Commands are only available when applicable.

			
					Next/previous result: Navigates back and forth through the list of results. Same as Go > Next/Previous Result. 

					Mark as Read/Unread: Marks the selected results as read/unread.

					Delete: Deletes the result from the results of the search run it was opened from.

					Delete & Exclude Domain: Deletes the result from the results of the search run it was opened from and adds it to the exclude list in the Preferences. 

					Sort: Changes the sorting of the result list.

			

			
					Cut: Copies the selected items to the clipboard and removes it from the list.

					Copy: Copies the selected items to the clipboard.

					Paste: Pastes bookmarks on the clipboard.

					Add Bookmark: Adds the current page to the bookmarks.

					Add Bookmark Folder: Adds a new folder to the bookmarks.

					Import: Imports bookmarks. [Read more...] 

					Edit: Opens an editing sheet for the selected bookmark.

					Delete: Deletes the selected items.

					Show Icon Preview: When checked DEVONagent Pro shows a preview icon for bookmarks.

			

			
					Open in New Window: Opens the selected items in a new web browser window.
 
					Open in New Tab: Opens the selected items in a new tab.
 
					Open in PhotoStickies: Opens a selected items in PhotoStickies. 

					Add Link to DEVONthink: Adds the link of the selected items to the currently open DEVONthink  database.
 
					Copy Link: Copies the selected links to the clipboard.
 
					Download: Downloads the selected items (or the items referred to by links).
 
					Select/Deselect All: Selects or deselects all items in the list.
 
					Use Small Icons: When checked (default), DEVONagent Pro displays small icons in the drawer, including the name and the link to or of the item; when unchecked, it displays large icons, 160 pixels wide, and shows no links.
 
			

		
		Action menu 

			The action menu (labeled with a toothwheel icon) makes frequently used commands conveniently accessible from the toolbar.

			
					Copy URL: Copies the address of the current page to the clipboard.

					Launch URL: Opens the selected pages in your default web browser.
 
					Add to DEVONthink: Adds the pages to your currently open DEVONthink database in a variety of formats. Same as Data > Add to DEVONthink. 
 
					Add to Set > ...: Adds the URL of the page to the "Sites" tab of the search set you select from the sub-menu. Select "New Set..." to create a new search set with the selected page(s).
 
					Add to Archive: Adds the page to the internal archive. 
 
					Save As: Saves the the selected pages as pure text, RTF(D) or HTML.

					Translate: Translates the displayed page using the Google language tools to your system's preferred language. This command is unavailable of if the recognized language of the displayed page is the same than the preferred language of your system.

					Inverse Appearance: Inverts the colors of the results list to match it with Cover Flow. Uncheck to return to regular black-on-white appearance.

			

		
		See Also pane 

			The See Also pane opens when you click the See Also button in the toolbar. It lists other pages related to the displayed page from three sources:

			
					Search: The results of the search run to which the page belongs.

					Archive: Pages in the internal archive. 

					DEVONthink Pro: The currently open DEVONthink  databases.

					Web: Related pages from the Web, either provided by plugins  or common search engines.

			

			Click any item in the pane to display it; double-clicking opens it in a new tab or window. The original page stays at the top of the list so that you can easily go back to it at any time. Results from DEVONthink that have a URL associated with are also shown with a single click; results without URL open in DEVONthink on a double-click.
 
		
		Shortcuts & modifier keys 

			
					Command-click: Opens a link or an item in the objects drawer in a new tab, if tabbed browsing is enabled. Otherwise, ⌘-click opens the clicked link in a new window.
 
					Option-click: Downloads an item on a webpage, a linked item or an item in the objects drawer via the download manager. 
 
					Space, Shift-Space: Scrolls down or up in non-editable text views, e.g., the source code or text-only view.
 
			

		
		Contextual menu 

			The contextual menu, which appears when you click something with the right mouse button or when you click while holding the ⌃ Control key down, offers a range of commands tailored to what you can do with the clicked object, for example a text passage.

			Most of the commands offered by the contextual menu have counterparts in a main menu, so you'll recognize them immediately. However, to save menu bar real estate, DEVONagent Pro gives you access to some options only via the contextual menu.

			
					Back/Forward: Navigates back and forth through previously visited pages, similar to the Back and Forward toolbar buttons or History > Back/Forward. 
 
					Reload: Reload the item or page.

					Search in Spotlight: Searches selected text with Spotlight.

					Look Up in Dictionary: Looks up selected text in Mac OS X's dictionary.

					Stop Loading: Stop loading the item or page.

					Open Image in New Window: Opens the selected image in a new web browser window.
 
					Open Image in New Tab: Opens the selected image in a new tab of the current web browser window.
 
					Open Image in PhotoStickies: Opens the selected image in  PhotoStickies. 
 
					Copy Image: Copies the selected image to the clipboard.
 
					Copy Image Address: Copies the address or the selected image to the clipboard.
 
					Add Image to DEVONthink: Adds the selected image to the currently open DEVONthink  database.

					Add Image to Archive: Adds the selected image to the archive. 

					Save Image As...: Saves the selected image to your computer.
 
					Save Image to Downloads: Saves the selected image to the default download folder.

					Use Image as Desktop Picture: Saves the selected image and sets it as desktop picture (requires Mac OS X 10.6 or later).

					Open Link in New Window: Opens the selected link in a new web browser window.

					Open Link in New Tab: Opens the selected link in a new tab.

					Open Link in PhotoStickies: Opens the selected link in PhotoStickies. 

					Copy Link: Copies the selected link to the clipboard.

					Download Linked File: Downloads the file referred to by the selected link via the Download Manager. 

					Add Selection to DEVONthink: Adds the selected text to the currently open DEVONthink database.

					Add Link to DEVONthink: Adds the selected link to the currently open DEVONthink database.

					Add Link to Set > ...: Adds the selected link to the sites list of a search set. 

					Add PDF to DEVONthink: Adds the displayed PDF to the currently open DEVONthink  database.

					Add page address to DEVONthink: Adds the address of the page to the currently open DEVONthink  database.

					Add frame address to DEVONthink: Adds the address of the selected frame to the currently open DEVONthink  database.

					Remember Selection: Remembers the current selection and re-applies it when you open the same page again.

					Forget Selection: Forgets the last saved selection.

			

			If the WebKit developer extras  are enabled more options are available.

			
			When you ⌃-click or right-click the background of the page instead of a item, additional options can be available:

			
					Open Page/Frame in New Window: Opens the page or frame in a new web browser window.

					Open Page in New Tab: Opens the page in a new tab.

					Copy Page/Frame Address: Copies the address of the page or frame to the clipboard.

					Add Page/Frame to Archive: Adds the page or frame to the internal archive. 

					Add Page to DEVONthink (Pro): Adds the HTML code of the page to the currently open DEVONthink (Pro) database.

					Add Web Archive to DEVONthink (Pro): Adds an webarchive (including all embedded images needed for correctly displaying it) of the page to the currently open DEVONthink (Pro) database.
 
					Add Page/Frame to Set > ...: Adds the page or frame address to the sites list of a search set. 
 
					Add All Links to Set > ...: Adds all links found on the page to the Sites list of a search set. 
 
			

			
			For PDF pages, different options become available:

			
					Add PDF to DEVONthink: Adds the PDF to the currently open DEVONthink database.

					Open with Preview: Opens the PDF in Preview.

					Automatically Resize: When checked, the zoom factor adjusts to the width resp. height of the browser window.

					Zoom Out, Zoom In, Actual Size: Zooms in or out of the document, or displays it in its actual size.

					Single Page, ...: Displays the PDF as single or double pages and either page by page (use the 'Next Page' and 'Previous Page' to skim through the pages forward and backwards) or continously.

					Next Page, Previous Page: Skims through the pages forward or backwards.

			

			
			On the Results pane of the sidebar the following additional options are available:

			
					Mark As Read: Marks the selected pages as read or unread.

			

			
		
	Archive window

		[image: The archive window and its elements]

		The integrated archive is where you can store found pages for later reference. Open the Archive window with Window > Archive. 

		The archive resembles the three panes view of Apple Mail or DEVONthink:  The left pane shows a list of groups, the right top pane displays page titles and URLs in a selected group, and the right bottom pane displays textual information related to the query that was used for finding a selected page. A search field in the toolbar allows you to search the archive by content, name or URL.

		Groups 

			All archived pages are stored in groups. Groups are automatically created when you archive pages from the search window and are named after the search query. You can change group names at any time, delete groups or manually create new ones. You can also create sub-groups by selecting a group and then creating a new one. The number of items contained in a group is shown as a badge.

			Note: Pages not related to a previous search run are archived in sub-groups of a top-level group named 'Incoming'. The sub-groups are named with the current date.


			Create new groups by using the toolbar, the contextual menu or Data > New Group.  Rename a group by clicking it once and waiting a second (like the Finder), or by selecting it and pressing the ⏎ or Enter key. Delete a group by selecting it and pressing Backspace, using the toolbar, the contextual menu or Data > Delete.  To make a group a sub-group, drag it with the mouse or use the contextual menu.

			Sort the groups by name or date with Sort > by Name  or Sort > by Date.  Reverse the sorting order with Sort > Ascending/Descending. 

		
		Pages 

			Like DEVONthink  or Apple Mail, DEVONagent Pro shows the pages filed in a group when you select the group in the left pane. Select a page, and DEVONagent Pro also shows a text preview in the lower right pane with the original search words highlighted.

			Rename a page by clicking it once and waiting a second (like the Finder), or by selecting it and pressing the ⏎ or Enter key. Delete an item by selecting it and pressing Backspace, using the toolbar, the contextual menu or Data > Delete.  To move an item to another group, drag it or use the contextual menu. Items can also be dragged to DEVONthink.

			To sort the pages list, click the relevance (first), title, URL or date column header. Click again to reverse the sorting order. The relevance column is only used when you search the archive using the toolbar search field.

		
		Toolbar 

			The toolbar of DEVONagent Pro archive windows carries many commands for manipulating the way it displays information and for manipulating selected items. Many of them are simply shortcuts for menu bar commands. Here's a short list of the available tools:

			
					Group +: Adds new groups to the archive. To create a sub-group, select the parent-to-be group first, then use this tool.

					Open: Opens the selected page(s) in a separate web browser window.

					Launch URL: Opens the selected page(s) in your default web browser.

					Export: Exports the selected page(s) as pure text, RTF(D) or HTML.

					DEVONthink (Pro): Adds the selected page(s) to the currently open DEVONthink (Pro) database.

					DEVONthink (Pro) pop-up: Adds the selected page(s) to the currently open DEVONthink (Pro) database, but allows you to select as HTML code or as a link via a pop-up menu.

					Delete: Deletes the selected page(s) from the results list.

					Search: Searches the archive for entered text. Select whether you want to search the contents, the names or the URLs of the stored pages with the magnifying glass pop-up menu. Also choose whether to ignore diacritics or to search fuzzy. This search field also supports all operators  and wildcards. 

					Print: Prints the results list.

			

			Note: Not all of these commands are always available. You can customize the toolbar by selecting View > Customize Toolbar  or by ⌃-clicking or right-clicking the toolbar background and selecting Customize Toolbar from the contextual menu.


		
		Shortcuts & modifier keys 

			Like any Mac application, DEVONagent Pro uses modifier keys or shortcuts to quickly access frequently used functions or modifying a standard behavior.

			
					Command-click: Adds an item to the current selection of items.

					Shift-click: Selects a range of items.

			

		
		Contextual menu 

			The contextual menu, which appears when you click something with the right mouse button or when you click while holding the ⌃ Control key down, offers a range of commands tailored for what you can do with the clicked object, forexample a text passage.

			Most ofthe commands offered by the contextual menu have counterparts in a main menu, so you'll recognize them immediately. However, to save menu bar real estate, DEVONagent Pro gives you access to some options only via the contextual menu.

			
					New Group: Adds a new group to the archive. To create a sub-group, select the parent-to-be group first, then use this command. (Only available in the left pane)

					Open: Opens the selected pages in separate web browser windows. 

					Open In Tabs: Opens the selected pages in separate tabs in a new web browser window. 

					Launch URL: Open the selected pages in your default web browser.

					Copy URL: Copies the selected URL to the clipboard.

					Reveal in Finder: Reveals an externally archived page in the Finder.

					Add to DEVONthink: Adds the selected pages to DEVONthink. 

					Add to Set...: Adds the URLs of selected pages to the Sites list of a search set so that it will get scanned when you use that search set in the future.

					Move To > ...: Moves the item to the group you select from the sub-menu.

					Export: Exports the selected pages.

					Delete: Deletes the selected pages from the results list.

					Delete & Exclude Domain: Deletes the selected search pages from the results list and adds the domains of the pages to the list of excluded domain. Use this to quickly exclude an unwanted domain without having to block it via the preferences. 

					Sort by > ...: Sorts the results list by the criteria listed in the sub-menu.

			

		
	Search sets

		The Search Set window is available via Window > Search Sets.  Use it to modify the existing search sets or create new ones specifically tailored for your needs.

		Because search sets are so important, we have created an extra chapter just about the search sets and the search sets editor. [Read more...] 

	Plugins and scanners

		The Plugins & Scanners panel, available via Window > Plugins & Scanners,  lists all installed plugins and scanners and shows additional information about them, for example their type, version and purpose. In addition it allows you to create new plugins for your favorite websites and search engines.
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		Also, you can enable or disable plugins or whole groups of plugins by checking or unchecking them. Use this to simplify the magnifying glass pop-up menu  in the search window or the plugin list in the Search Sets  window.

		Plugins & Scanners 

			All plugins and scanners are arranged in groups. Click the grey triangle in front of a group to expand it, click it again to close it. Select a plugin or scanner to show additional information:

			
					Name: Plugin name.

					Info: Additional information, e.g. copyright.

					Identifier: Internal and identification string.

					Keywords: Shortcuts for the plugin. [Read more...] 

					Description: Textual description of the plugin.

					Operators: List of supported operators. For plugins that you created yourself you can check and uncheck them to adjust which operators are supported by the search engine.

			

			Name, info, identifier, description, and keywords of self-made XML plugins can be edited. User-defined plugins as well as the groups Browser, DEVONsphere, and Scanner are shown in bold.

			Note: The group hierarchy is predefined and cannot be manually altered. If you have installed your own plugins, they appear in the top level of the hierarchy or are mirrored-in following the folder structure in '~/Library/Application Support/DEVONagent/Plugins/'.


		
		Keywords 

			Keywords are shortcuts that you can use to query the search engines defined by the plugin from the address bar of a web browser window.

			Example: The Bing  plugin comes with the predefined keyword 'bing'. To send a query to Bing, type e.g., 'bing devonthink' into the address bar of a DEVONagent Pro web browser window and press ⏎ or Enter.


			This effectively replaces the search engine field that can be found in other web browsers, such as Safari, with a far more flexible approach. You can add your own keyword(s) to most plugins, separated by spaces, to make them quickly accessable from any open DEVONagent Pro browser window.

			In addition the plugin's name is automatically used as keyword, too.

		
		Creating & testing 

			Using DEVONagent Pro's built-in plugin assistant you can easily create your own XML-based search plugin for your favorite search engine. To create your own plugin, choose File & New Plugin  or use the New  toolbar icon.

			In the appearing sheet enter:

			
					Name for the plugin

					Short description

					Website or search engine URL

			

			To get the URL for your search engine, run a search in your web browser, copy the URL, and paste it into the URL field of the to-be-created plugin. Then look for the URL parameter that transports the query, e.g. something like '&query=xxx'. Replace 'xxx' with '_agentQuery_'. This tells DEVONagent Pro where to enter the search term. The '_agentNumber_' and '_agentOffset_' placeholders are automatically inserted if necessary and possible. [Read more...] 

			Alternatively, if you want to create a plugin that simply searches a website, enter just the URL of the website. DEVONagent Pro will use standard search engines such as Google to run a site-specific search when you use this plugin.

			DEVONagent Pro selects the Website or Search Engine radio buttons automatically, depending on the entered URL.

			To test a build-in or self-created plugin use the Test  toolbar icon. DEVONagent Pro will send 'Test' as the standard search term to the plugin and present you with the list of returned pages. Double-click results to view them in a new web browser window. Only XML plugins using 'EngineUrl' can be tested as testing XML plugins using 'EngineSite' is not necessary.

			To edit and existing XML-based plugin double-click it or use the Edit  toolbar icon. DEVONagent Pro shows an XML text editor with error checking that allows you directly edit the source code of the plugin. [Read more...] 

		
		Toolbar 

			The toolbar of the Plugins & Scanners windows lets you easily create new plugins, edit, test, and delete them.

			
					New: Opens a sheet for creating a new XML-based plugin.

					Edit: Opens a sheet for editing the XML code of the selected plugin.

					Test: Runs a test on the selected plugin and displays the results.

					Delete: Deletes the selected plugins. Built-in plugins cannot be deleted.

					Show In Finder: Opens a new Finder window for the folder containing the selected plugin.

			

		
		Contextual menu 

			The contextual menu, which appears when you click something with the right mouse button or when you click while holding the ⌃ Control key down, offers a range of commands tailored for what you can do with the clicked object, forexample a text passage.

			
					New: Opens a sheet for creating a new XML-based plugin.

					Edit: Opens a sheet for editing the XML code of the selected plugin.

					Duplicate: Duplicates the selected plugins.

					Show In Finder: Opens a new Finder window for the folder containing the selected plugin.

					Test: Runs a test on the selected plugin and displays the results.

					Delete: Deletes the selected plugins. Built-in plugins cannot be deleted.

			

			The test sheet also presents the following options in the contuextual menu:

			
					Open: Opens the selected URLs in DEVONagent Pro's built-in web browser.

					Open In Tabs: Opens the selected URLs in separate tabs in DEVONagent Pro's built-in web browser.

					Launch URL: Opens the selected URLs in the default application for their types.

					Exclude URL: Adds the selected URLs to the plugin's internal exclude list. Use Retry to re-run the test after exluding a URL.

					Exclude Domain: Adds the domains of the selected URLs to the plugin's internal exclude list. Use Retry to re-run the test after exluding a domain.

					Include URL: Adds the URL to the "LinksMatching" key.

					Include Domain: Adds the domain to the "LinksMatching" key.

					Copy: Copies the selected URLs to the clipboard.

			


		
	Downloads

		Window > Downloads  opens the Downloads window. Use it to download files from the Internet to your computer. The download URL is automatically placed into the Finder comment of the downloaded file as well as in the 'kMDItemWhereFroms' extended file system attribute.
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		For URLs that require authentication, DEVONagent Pro asks for username and password. It also uses the system-wide cookies, and can start and stop downloads at any time.

		Adding, resuming, retrying 

			To add files to the download manager, drag a link to the item from any DEVONagent Pro web browser window or any other application to the download manager window, paste a copied URL or ⌃-click a link in a DEVONagent Pro web browser window  and choose "Add to Download Manager". ⌥-clicking links in the web browser or the objects drawer adds items to the download manager, too. Also, DEVONagent Pro automatically puts files it cannot display into the download manager, if you double-click them, e.g., .zip archive files.

			DEVONagent Pro downloads files added to the download manager immediately. To remove a file from the download manager, select it and click the - button at the bottom of the window. To temporarily prevent an item from being downloaded, uncheck the checkbox in front of it. Check the checkbox to download the item. Use this to add items to the download queue, but download them later.

			To resume or retry a failed download, select the file and click the back arrow button. Use the start/stop button (resembles the start/pause button of a VCR or tape player), to start or stop the entire queue.

			You can also drag items from the download manager to other windows or to the Finder, or copy it to the clipboard. Drag-and-drop will send the URL of the item to the target window or application.

		
		Action menu 

			The action menu provides the same options as the contextual menu. 

		
		Contextual menu 

			The contextual menu, which appears when you click something with the right mouse button or when you click while holding the ⌃ Control key down, offers a range of commands tailored to what you can do with the clicked object.
 
			
					Cut: Copies the selected link to the clipboard and removes it from the queue.
 
					Copy: Copies the selected link to the clipboard.

					Paste: Adds a link that is copied to clipboard to the download manager queue.

					Retry: Retries a stopped or stalled download.

					Show In Finder: Opens a Finder window for the enclosing folders of the selected items.

					Enable/Disable: Enables or disables the selected item(s). Disabled (unchecked) items are not downloaded but kept in the download queue.
 
					Reload: Reloads the selected items.

					Remove: Removes the selected items from the queue.
 
					Start/Stop Queue: Starts or stops the download queue.

					Purge Queue: Purges all completed items from the queue.

					Automatically Purge Queue: When checked, completed items are automatically purged from the queue.

			

		
	Preferences

		The Preferences window is, like in any Mac OS X application, available via DEVONagent Pro > Preferences.  It contains all available options that you can modify to adapt DEVONagent Pro to your personal needs.

		Because the preferences are so important, we have created a chapter just for them. [Read more...] 

	Assistant

		The integrated Assistant combines a welcome screen with tips, tricks, and tutorials, installable extras, and a suppport page that guides you through the available support options.

		Click here [special link, not enabled in ebook]  to directly open the assistant.
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		Welcome 

			This screen welcomes you when you start DEVONagent Pro for the very first time. It offers:

			
				
					The option to subscribe the free DEVONtechnologies newsletter as well as a number of welcome tips

					The tip of the day

					The extra of the day

			

			You can access all other screens of the assistant from here, too.

		
		Get support 

			The support screen guides you through the three common steps for troubleshooting DEVONagent Pro. In addition you can have your license code resent in case you don't have it anymore, request a trial extension, update your details in DEVONtechnologies' customer database, or buy an upgrade or a second license.

		
		Tips and tutorials 

			Here you can always find the latest tips sand tutorials  that help you squeeze the best out of DEVONagent Pro. Tutorials can be slideshows describing basic tasks in DEVONagent Pro or videos (as they become available).

			Both tips and tutorials are updated live from DEVONtechnologies' server so it's a good idea to check back from time to time. The latest tip or tutorial is also always mentioned on the welcome screen.

		
		Install extras 

			[image: ]

			On the extras screen DEVONagent Pro lists all available extras that you can download and install from DEVONtechnologies' server:

			
					Scripts

					Plugins

			

			Browse the list of extras and install them with the Install button. The last line of the description shows where in e.g. the Scripts  menu or Plugins  hierarchy the extra will show up after installation. Remove installed extras with the Remove button.

			The extras are updated live from DEVONtechnologies' server so it's a good idea to check back from time to time. The latest extra is also always mentioned on the welcome screen.

			Note: If one of these categories does not show up in your copy of DEVONagent Pro there might be no extras of this type  (yet) available for DEVONagent Pro.


		
	Preferences


	The preferences window, which you open by selecting Preferences in the DEVONagent Pro  menu, is the place where you change all global settings of DEVONagent Pro.

	
	For your convenience, the preference panel is divided into tabs, just like System preferences. Select the tab you want to check or modify with the icons at the top of the preferences window.

	
	
	
	
	
	
	
	
	
	

General
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		This tab contains all options modifying the user interface and the summarization of search results.

		Interface 

			These options define some parts of DEVONagent Pro's visual appearance.

			
					Highlight occurences in HTML pages: Check to highlight occurences of search words in web browser windows or views.
 
					Automatically zoom search panel: Check to open new search windows simplified.
 
					Floating simplified search panel: Makes the simplified search window float above all other windows. Use this to have the search window always handy.
 
					Alternating rows colors in views: When checked, DEVONagent Pro colors lines in lists slightly differently to make them easier to read.
 
			

		
		Search Panel 

			This option defines which tab DEVONagent Pro shall show when a search run is done.
 
			
					Digest: Switches to the Digest  tab when DEVONagent Pro has finished a search run.
 
					Results: Switches to the Results  tab when DEVONagent Pro has finished a search run.
 
					Log: Switches to the Log  tab when DEVONagent Pro has finished a search run.
 
					Settings: Switches to the Settings  tab when DEVONagent Pro has finished a search run.
 
			

		
		Summarization 

			These options define how DEVONagent Pro creates summaries.
 
			
					Based on sentences: Creates summaries based on sentences. Generally shorter summaries, but you may miss information that DEVONagent Pro classifies as not important.
 
					Based on paragraphs: Creates summaries based on whole paragraphs. Longer summaries, but they are not clipped.
 
			

		
		Startup 

			These options let you define what DEVONagent Pro does when you open it.
 
			
					Open new query: Opens a new, empty search window  when you open DEVONagent Pro.
 
					Open new browser: Opens a new web browser window  when you open DEVONagent Pro.
 
					Open browsers that were open on quit: Opens the web browser windows  that were open on quit.
 
					Do nothing: Does nothing when you open DEVONagent Pro.
 
			

		
		Home page, ... 

			These options define the default home page and the folder for downloaded files.

			
					Home page: Sets the home page that is loaded automatically every time you open a new web browser window. 

					Save downloaded files to: Sets the folder into which DEVONagent Pro saves downloaded files. [Read more...] 

			

		
		Fonts 

			Define the fonts you want to use for searching and reading texts. Click the Select buttons to open the standard Mac OS X font panel.
 
			
					Source font: Changes the font used for displaying source code. A monospaced font, such as Courier or Monaco, gives you the best results.
 
					Text font: Changes the font used for displaying plain text, e.g., text extracted from webpages.
 
			

		
	Search

		This tab contains all options dealing with the cache, the number of connections, and domains excluded from searching.
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		General 

			
					Ignore instructions for robots: Ignores instructions embedded into the HTML code of webpages that tell robots (like DEVONagent Pro) to not index this page. If unchecked (default setting), DEVONagent Pro tries to be nice and honours the wishes of the creator of the webpages.

					Cache downloaded pages: Check if you want DEVONagent Pro to store downloaded pages in its cache. This consumes disk space but leads to much faster searches when DEVONagent Pro scans an already cached page again.

					Clear on quit: When checked, DEVONagent Pro clears the cache when you quit it.

					Cache Directory: Shows the path to the folder used by DEVONagent Profor its cache. Double-click an item to reveal it in the Finder or select another folder for DEVONagent Proto use.

			

		
		Create Previews 

			Choose whether DEVONagent Pro should create previews of visited or found pages immediately or just on demand, and how it generates thumbnails of webpages.

			
					Immediately: Previews are created and cached immediately.

					On demand: Previews are created and cached only when needed (default).

					Directly: DEVONagent Pro generates thumbnails itself (higher quality).

					Via Thumbshots.com: DEVONagent Pro asks Thumbshots.com  to generate thumbnails (faster).

 			

 			Note: DEVONagent Pro never sends more than just the URLs of the to-be-thumbnailed webpages to Thumbshots.com.


		
		Max. Connections 

			Use this parameter to adjust the number of connections DEVONagent Pro uses concurrently to match the speed of your Internet connection and your computer.

			
		
		Max. Download Size 

			Choose how large files can be that DEVONagent Pro downloads in search runs. Adjust this to your Internet connection speed. Files skipped due to file size are marked as "Too big" in the log tab of the search window. 

		
		Exclude Domains,  

			Exclude Domains: Enter all domains you want to exclude from searching in this text field, separated by returns. Use this to exclude domains blocking automatic bots like DEVONagent Pro, e.g., 'sciencemag.org' or 'slashdot.org', or to ignore sites you don't like (for example 'google.com'). Domains skipped because they match one or more entries in this list are marked as 'Skipped' in the Log  tab of the Search  window.

			Exclude Links: Enter URLs you want to exclude from being searched.

			Note: Both fields also accept the '*' wildcards at the beginning or end of lines.


		
	Menu extra

		The options in this tab determine if DEVONagent Pro's menu extra  is automatically started when you log into your account, if the menu should show icon previews, how results are opened when they are selected, and what hotkey you want to use to call the menu.
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		General 

			
					Start at login: The menu extra is started automatically when you log in.

					Show icon preview: Check this option to show preview icons of the found pages in the menu.

					Show text summary in menu: Check this option to show a short summary directly in the menu. Uncheck this option to keep the menu less crowded; you can always read the full summary in the tooltip.

			

		
		Search 

			
					Agent: Download each result page and filter e.g. error pages.

					Express: Return the results unfiltered.

			

			In both cases DEVONagent Pro uses its unique artificial intelligence technology to rank the results, in Express mode only based on title, address, and a short summary, in Agent mode based on the full text of the page.

		
		Open Results 

			
					In DEVONagent Pro: Results you select in the menu extra's menu are opened using DEVONagent Pro's browser.

				
					In default web browser: Results you select in the menu extra's menuThe results are opened using your default web browser, e.g. Safari.

			

		
		Hotkey 

			Click the button to record any key combination you like to call the menu extra. Use the hotkey to open the menu extra also in OS X 10.7 Lion's fullscreen mode.

		
	Web

		The options in this tab resemble the settings of most web browsers. They define how DEVONagent Pro's built-in web browser windows  display HTML documents and live webpages.
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		Web Content 

			These settings define how DEVONagent Pro treats some special Web contents.
 
			
					Enable plugins: Check this option to use installed third-party plugins, e.g., Flash or RealPlayer.

					Enable Java: Check this option to run Java applets contained in or linked to webpages.

					Enable JavaScript: Check this option to run JavaScript scripts contained in webpages.

					Block pop-up windows: Check this option to block pop-up windows which are often advertisements. Uncheck this option if the webpage you're visiting uses pop-up windows for actual content (some Web content management systems do this, for example).

					Only automatic JavaScript windows: Check this option to block only pop-up windows opened by JavaScript instead of all pop-ups.
 
					Block zooming: Check this option to keep JavaScript from zooming the web browser window  to full screen.

					Block advertisment: Check this option to block common inline advertisements provided by major search engines.

					Zoom text only: Check to scale only the text when zooming in and out  of webpages. When unchecked DEVONagent Pro uses Safari-4-style zooming.

			

		
		Images 

			Use these otions to define how DEVONagent Pro displays graphics in webpages.
 
			
					Display images when the page opens: Check this option to diplay webpages with images or uncheck to load them without images. When unchecked, you may miss some information on graphic-oriented pages, though.
 
					Animate images: Check this option to run animated graphics or uncheck it to show the items statically instead.
 
					Loop animations of images: Check this to run animated graphics in a loop.
 
			

		
		Accept Cookies 

			Cookies are little text files with information that webpages store on your computer, for example to recognize you as a returning customer. While most of them are harmless, you may want to have control over what is being stored on your hard disk.
 
			
					Always: Accepts all cookies.

					Never: Doesn't accept any cookies

					Only from sites you navigate to: Accepts cookies, but only from websites you navigate to, not from other sites, e.g., ad trackers.
 
					Delete cookies on quit: Deletes all stored cookies when you quit DEVONagent Pro.
 
			

			Note: Delete cookies on quit deletes the cookies for all WebKit-based web browsers including Safari. All these browsers use the same single cookie file.

 
		
		Standard/Fixed-width font 

			Set the font you want to use for displaying webpages, separately for variable-width and fixed-width text.
 
		
		(Feed) Style Sheet 

			You can further control the way DEVONagent Pro displays webpages by applying a CSS style sheed for changing the rendering on-the-fly.

			
					Style Sheet: Click Select and choose your own style sheet to apply it.

					Feed Style Sheet: DEVONagent Pro comes with a number of different style sheets for RSS news feeds. Choose your preferred style. Note: The 'Newspaper' style does not display images. You can use your own CSS styles for news feeds by placing them in '~/Library/Application Support/DEVONagent/StyleSheets' (and restarting DEVONagent Pro if necessary).

			

			Note: Applying an external CSS style sheet to webpages is an expert option. It heavily affects the rendering of all webpages in DEVONagent Pro. It does not interfere with the search functionality of DEVONagent Pro, though.


		
		Text Encoding 

			Select your desired text encoding for displaying webpages. Generally the default setting, Automatic should work fine. If not, choose a more appropriate text encoding for your language.
 
		
		WebKit Developer Extras 

			Enable to use the standard WebKit developers extras in web browser, e.g. the element inspector or the JavaScript console.

		
	Tabs

		Like many modern web browsers, DEVONagent Pro features tabbed browsing. This enables you to display multiple webpages in one web browser window  and switch between them with tabs.
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		Use the following settings to activate tabbed browsing and define additional options. They resemble those also available in Apple Safari.
 
		
				Open links from applications: Defines whether DEVONagent Pro shows pages requested by other applications, such as the Finder, in a new window or in a new tab in the current web browser window. 
 
				Enable Tabbed Browsing: Switches tabbed browsing on or off. You can always create new tabs manually, but DEVONagent Pro will not open new tabs automatically or when you ⌘-click a link.
 
				Select new tabs as they are created: When checked, DEVONagent Pro automatically switches to a newly generated tab.
 
				Always show tab bar: When checked, the tab bar is always visible; when unchecked, DEVONagent Pro only shows the tab bar when at least two tabs are open.
 
		

		Note: The lower part of the preference window shows the keyboard commands for creating new tabs or opening links in new tabs, similar to Apple Safari. The keyboard commands may change with the options you select above.

 
	Bookmarks

		DEVONagent Pro makes the bookmarks defined in your favourite web browser available both in the Go  menu and in a bookmark drawer in web browser windows. 
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		Bookmarks 

			Select your favourite browser:

			
					Camino 

					DEVONagent Pro 

					Firefox 

					Chrome 

					OmniWeb 

					Safari 
 
			

			DEVONagent Pro comes with its own bookmark management. Choose DEVONagent Pro in the list to use the integrated bookmark management. [Read more...] 

		
		Bookmarks bar 

			Select whether DEVONagent Pro automatically mirrors Web servers announced via Bonjour, bookmarks stored in DEVONthink Pro,  and workspaces in the bookmarks pane in a web browser windows sidebar  or the Go  menu.

			
					Include Bonjour: List Web server announced via Bonjour.

					Include DEVONthink Pro: List bookmarks from open DEVONthink Pro  databases. The bookmarks are retrieved when DEVONagent Pro starts up and are caches so that they remain available even when DEVONthink Pro is no longer open.

					Include Workspaces: List workspaces. 

			

		
		Bookmarks menu 

			Select if you want to include Bonjour servicesin the Go  menu.

			
					Include Bonjour: List Web servers announced via Bonjour in Go  menu.

			

		
	Email

		DEVONagent Pro can send you reports of schedules search runs by email. Tell DEVONagent Pro how it shall send you messages on this tab.
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		Send Email 

			Choose if you want DEVONagent Proto send you email using Apple Mail or using the built-in email function. If you don't use Apple Mail add your email account details:

			
					Server Name: Your SMTP server's address

					User: Your SMTP user name

					Password: Your SMTP password

					Port: The port to use, usually the default port should work

					SSL: Check if you want to use a secure connection

			

		
		Email Font 

			Set the font used for styled emails (rich text). Check Send styled emails to let DEVONagent Pro send summary emails as RTF text. Read more about sending summary email messages here. 
 
		
	Update

		Change the settings on this tab to choose when you want DEVONagent Pro to check for new versions: never, on startup, daily, weekly or monthly. DEVONagent Pro only performs checks for updates when the computer is connected to the Internet.
 
		[image: Preferences, Update Tab]

		Click Check Now to immediately check for a new version.

		Note: Disable the check for new versions when your network connection is unstable and you experience very long delays when opening DEVONagent Pro.

 
	Widgets & menu extra


	DEVONagent Pro comes with a menu extra and a Dashboard widget that allow you to enter a query and start a search run at any time from either the menu bar or the Dashboard.

	
	

	

Menu extra

		DEVONagent Pro adds a [image: ] menu extra to the right-hand side of the menu bar.

		[image: Menu Extra]

		It looks similar to the Spotlight menu and works pretty similar:

		
				Choose a search set  or plugin  from the magnifying glass pop-up menu.

				Enter your query. 

				Hit ⏎ or Enter.

		

		DEVONagent Pro runs the query and shows the results in the menu.

		
				A colored bar in the search field shows how far the search has already progressed.

				Point with the mouse on any result to show a tooltip with a preview and a text summary.

				Click the result to open it in DEVONagent Proor your default browser. [Read more...] 

				Hold the ⌥ or ⌘ modifier key to open results in the background.

				Drag results to e.g. the Desktop or other applications. Dragging to the Desktop creates bookmarks (.webloc), dragging to other applications inserts the web address.

				Navigate through the list with the Up and Down keys, press ⏎ or Enter to open the result in your browser.

				Recall recent searches from the magnifying glass [image: ] pop-up menu.

				Click the [image: ] to clear your search.

		

	DEVONagent Pro widget

		The DEVONagent Pro widget allows you to search your DEVONagent Pro database directly from the Dashboard. The widget sends the entered query to DEVONagent Pro where you can then pick up your search results. Tip: Use an action for the used search set, e.g., a bouncing Dock icon or a Growl notification, that lets you know when the search run is done.

		Front side 

			[image: Dashboard widget]

			On the front side of the widget, enter your query and click the DEVONagent Pro icon to start the search run. If DEVONagent Pro is not running, it will be opened. The title bar of the widget shows the search set that DEVONagent Pro will use for the search run. You can select another search set on the back side of the widget.

		
		Back side 

			You can flip the widget by clicking the i button that appears when you move the mouse into the lower right corner of the widget. The back side contains a pop-up menu for selecting the default search set.

			Click Done to flip the widget back to the front side.

		
	Scripts


	DEVONagent Pro comes with a fully loaded AppleScript dictionary and some Automator actions that help you automate almost every aspect of your DEVONagent Pro workflow. Use the included scripts to perform often-used tasks and use them as templates for creating your own scripts and Automator workflows.


	

	
	
Introduction

		DEVONagent Pro features an AppleScript dictionary and Automator actions that automate the application and integrate it with almost every other application supporting AppleScript and Automator.

		Example scripts 

			To make it easier for you to start with scripting right away, we deliver a slew of scripts with DEVONagent Pro that you can access in the Scripts  menu (which shows a stylized S symbol as its title instead of the word Scripts). These scripts interact directly with selected items, the currently displayed webpage or a window. All scripts delivered with DEVONagent Pro are useable in your daily work, not simple examples skeletons that need to be filled with life first.

		
		Integrating other applications 

			In addition to the scripts that you use inside DEVONagent Pro, Mac OS X features a global script menu that allows you to access certain scripts from any application on your Mac, for example your web browser or Apple Mail. When activated, it appears at the right side of the menu bar (like other menu extras such as the AirPort signal strength or the Spotlight icon). It appears with a black stylized S icon.

			Note: By using folders named after applications inside the '~/Library/Scripts/Applications' directory, it is also possible to make scripts application-specific. Such scripts will appear at the top level of the global script menu when the application they belong to is frontmost. This removes clutter and shows only scripts that make sense in the current application.


			DEVONagent Pro does not come with scripts for other applications but you can use the global script menu for creating some and making them available in just the applications in which you want them to appear.

			To activate the global script menu, do the following:

			
					Open the AppleScript Utility (located in '/Applications/AppleScript').

					Check Show Script Menu in menu bar.

					Uncheck Show Library scripts if you only want to see the scripts you have installed yourself.

			

			To install your own scripts, copy them into the folder '~/Library/Scripts'. You can use sub-folders to structure them in any way you like.

		
		DEVONagent Pro's dictionary 

			DEVONagent Pro includes a large dictionary with commands, objects, and methods you can use for writing scripts that interact or extend DEVONagent Pro. To view the dictionary, open the Script Editor application (by default located in '/Applications/AppleScript'), select File > Open Dictionary and choose DEVONagent Pro in the appearing window.

			You can also add DEVONagent Pro to your Script Editor library. Select Window > Library, click the + button and choose DEVONagent Pro. This way you keep DEVONagent Pro's dictionary at hand.

		
		Caching 

			DEVONagent Pro caches pre-compiles and caches scripts as soon as they're called for the very first time. So, when you are modifying a script you need to make sure DEVONagent Protakes notice of the changes. For scripts in the Scripts menu,  use the Scripts > Update Scripts Menu command.

		
		Learning AppleScript 

			This documentation is not an AppleScript language guide. Please refer to Apple's AppleScript website,  other online resources, or introduction and reference books for more information on the AppleScript language. Here are some links for you:

			
					The Ultimate Beginner's Guide to AppleScript 

					Mac OS X AppleScript Resources Page 

					MacScripter 

					ScriptWeb 

			

			
					TECsoft Hands-On Trainings 

					Scripting Matters Trainings 

			

			
					AppleScript for Absolute Starters (free PDF book) 

					AppleScript: The Missing Manual 

					AppleScript: The Definitive Guide 

			

		
	DEVONagent Pro's Scripts menu

		The internal scripts menu of DEVONagent Pro, located to the left of the Help  menu, gives you access to pre-made scripts that extend DEVONagent Pro with additional, more specialized commands and functions. They are only visible from inside DEVONagent Pro and extend its functionality.

		[image: ${Software}'s Script menu]

		Of course, you can easily modify all these scripts using AppleScript Editor, and the workflows using Automator  or add your own scripts and workflows to the menu. They are located in '~/Library/Application Support/DEVONagent Pro/Scripts'; you can open this folder in the Finder comfortably with Scripts > Open Scripts Folder.

		Note: If you want to add keyboard shortcuts to scripts in this menu, you cannot do this using System Preferences. You need to add the shortcut description to the file name of the script in '~/Library/Application Support/DEVONagent/Scripts' or '~/Library/Scripts'. Example: 'eMail Current URL (Mail)___Cmd-Alt-M.scpt'. The naming convention is three underline characters followed by the shortcut description.


		Scripts interacting with other applications 

			
					Email Current Page (Mail): Creates a new message in Apple Mail with the currently displayed webpage attached as webarchive. Webarchives contain the HTML code of the page including all embedded elements that are necessary to display them.

					Email Current URL (Mail): Creates a new message in Apple Mail with the URL of the currently displayed webpage in the body.

					Email Current URL: Asks for an email address and sends the URL of the currently displayed webpage by email to this address. This script does not use Apple Mail, but sends the message directly via the messaging framework of Mac OS X. It requires that you have set up at least one email account correctly in Apple Mail.

					Email Results (Mail): Creates a new email in Apple Mail with the abstracts of all results in its body.

					Post to del.icio.us: Posts the selected items as bookmarks to del.icio.us. 

					Post to Twitter: Posts the selected items to Twitter. 

			

		
		Scripts working with images 

			
					Download Embedded JPEG Images: Downloads all JPEG images embedded into the currently displayed page to the default download location via the download manager. 

					Download Linked JPEG Images: Downloads all JPEG images linked from the currently displayed page to the default download location via the download manager. 

					Open Linked JPEG Images in Tabs: Opens all JPEG images linked from the currently displayed page in separate tabs,  then closes the current tab.

					Open Linked JPEG Images: Opens all JPEG images linked form from the currently displayed page in separate web browser windows. 

			

		
		Scripts working with pages and results 

			
					Download Objects of Results: Downloads all found objects of the frontmost search window. The search needs to be run with an active scanner  returning objects, e.g. Embedded Images.

					Open Current URL in RSS Reader: Opens the URL of the frontmost web browser window in the default RSS reader. Use it on displayed feeds to add them to your reader.

					Speak Titles of Results: Speaks the titles of the selected pages.

			

		
		Scripts for the toolbar 

			By default this contains no scripts. Add your own scripts here and add them also to the toolbar of search  and browser windows  using View > Customize Toolbar. 

		
		Scripts arranging windows 

			
					Open last Safari session: Opens the last Safari session in DEVONagent Pro.

					Browsers Side-by-Side: Arranges the currently open web browser windows  side-by-side.

					Tile Browsers: Arranges the currently open web browser windows  tiled to 800 pixel width.

					Combine Windows: Combines the currently open web browser windows  as separate tabs in one window.

					Windows to Full Screen: Resizes all web browser windows  to full screen.

			

		
	Automator

		DEVONagent Pro also comes with a bundle of integrated Automator actions that you can use to create your own Automator workflows.

		To see which actions DEVONagent Pro provides, open Automator and select DEVONagent Pro in the applications list on the left hand side. If you do not see DEVONagent Pro in the Library list, use View > Arrange Actions by > Application. Select any action to show a short description about what the action does, and have a look at Automator's built-in help to learn more about how to create a workflow.

		Note: Cannot find the Automator action you need for your workflow? We're open to suggestions! 


	Plugin Development


	DEVONagent Pro comes with a long list of ready-to-use plugins for popular search engines. However, if you want to write your own plugins to query your favorite search engine, no problem. Here is all what you need. The tutorial  gives you a jump-start on how to write your own plugins for DEVONagent Pro, e.g., for integrating a search engine we haven't thought of yet. And the XML keys descriptions  explain all the XML tags you can use for developing the perfect plugin.
 

	
	
Creating Your Own Plugins

		Do you have one or more favorite websites that you would like to search using DEVONagent Pro? This document will show you how to create an XML plugin for DEVONagent Pro. It will be a step-by-step tutorial that will guide you through a real, practical example that is found in the list of plugins of the application.
 
		It would be good to also have a look at the Keys section of this chapter. This describes the nitty-gritty details of the XML keywords that we are going to use.

		DEVONagent Pro comes with an integrated plugin assistant that makes creating your own XML-based plugin as easy as possible. Let's create a first simple pluging from scratch in six steps.

		Step 1 

			Open a web browser window for www.ipl.org  in DEVONagent Pro or any other web browser. Then search for 'Test' and copy the 'Next >>' link leading to the second results page.

		
		Step 2 

			Choose File > New Plugin, paste the copied link, and replace 'Test' with '_agentQuery_'.

			[image: ]

			Enter a name and description if desired (useful but not necessary). The Search Engine radio button is automatically selected by DEVONagent Pro.

			The '_agentQuery_' placeholder is where DEVONagent Pro inserts the search term when using the plugin. The '_agentOffset_' placeholder, which is used by DEVONagent Pro to jump from result page to result page is automatically inserted instead of the '10' of the '&next=' parameter after clicking the Add button.

		
		Step 3 

			Let's test the plugin. In this case, the created plugin is already fully functional but causing unnecessary traffic and might return unexpected results. Therefore select any 'www.ipl.org' URL in the log and choose Exlude Domain in the contextual menu. This excludes all pages on ipl.org  from becoming possible results.

			[image: ]

		
		Step 4 

			Retry the test, only 10 links per page should be used.

			[image: ]

		
		Step 5 

			Finally, uncheck all operators as IPL does not support them.

			[image: ]

			That's it!

			In other cases you might also have a look at the source of the plugin and validate the values for 'Start', 'OffsetPerPage', and 'ResultsPerPage', or add 'LinksMatching' definitions etc. Site-specific search engines might also require 'TitleStart'/'TitleEnd', 'TextStart'/'TextEnd', 'DateStart'/'DateEnd', 'NoTopics', or 'CrawlDelay' definitions. [Read more...] 

			In addition, DEVONagent Pro might not always be able to insert the '_agentOffset_' and '_agentNumber_' placeholders automatically. You might have to do this on your own or only the first results page is used.

		
		Finetuning 

			We now have a working plugin for IPL and we might have gotten links but we may not have gotten good data. You can check both the pages and digest panes in the search window  to fine-tune your plugin. If DEVONagent Pro extracts too much data from the result list pages you can use the following keys to tell the software what exactly is a result link and what is not.
 
			
					1. TitleStart and TitleEnd: Extract the title of the article.
 
					2. TextStart and TextEnd: Extract the article text.
 
					3. DateStart and DateEnd: Extract the article's date.
 
					4. NoTopics: Suppress useless topics that always occur for any search on a site.
 
					5. PostScan: Scan the results for the string you where searching for.
 
			

			In order to determine values for these parameters, you will need to look at the source code of a couple of articles and try to find strings that can be used for these keys.The 'NoTopics' list can be set when looking at the topics in the digest pane after you've done your searches. Any word that you think that should not be included, you can add to this list.

		
		Congratulations 

			With the steps described in this tutorial, we hope you will be able to go through the steps of writing a plugin yourself. With a bit of practice, it is possible to write an optimized plugin that will deliver good results for DEVONagent Pro to work with. It might help to look at the additional plugins that already come with DEVONagent Pro.

			And remember: If you think your plugin is great for others, share it with us! 
 
		
	XML Keys

		XML based plugins use Apple's ".plist" file format and therefore it's possible to edit them using Property List Editor or any text editor like TextEdit, SubEthaEdit  or Xcode/ProjectBuilder. DEVONagent Pro loads all plugins inside its application package and those stored in the folder "~/Library/Application Support/DEVONagent Pro/Plugins". If DEVONagent Pro is not able to load a plugin, the file is logged to the console. You can also place aliases or symbolic links to plugins here.

		Necessary Keys 

			
					Name: [string or dict] The name of the plugin. Example: "BBC News".

					Info: [string or dict] Information containing name, version and copyright. Example: "BBC News Plugin 1.0 2003-2005 DEVONtechnologies".

					Description: [string or dict] Describes the functionality of the plugin. Example: "Queries the BBC news archive."

					Version: [string] The version number (format major.minor). Example: "1.0".

					Identifier: [string] Unique identifier (format domain.name.plugin). Example: "com.devon-technologies.bbcnews.plugin".

					EngineUrl: [string or array of strings] The Internet address(es) of the search engine. The strings "_agentQuery_", "_agentNumber_" and "_agentOffset_" are replaced by the search term, the number of results and the offset of the current page. "_agentNumber_" and "_agentOffset_" are optional. '_agentLanguage_' is replaced by the language used by the plugin (ISO 639 two-letter codes).  Can contain the placeholders "_agentUser_" and "_agent_Password_" for HTTP authentification. Example: "http://www.bbc.co.uk/cgi-bin/search/results.pl? tab=news&amp;start=_agentOffset_& go=homepage&amp;q=_agentQuery_".

			

			Note: Name, Info and Description are localizable. Specify a dictionary containing key/string pairs for multiple languages. The key contains the name of the language, for example German or English.


		
		Additional Keys 

			
					CrawlDelay: [float] Minimal delay between two requests sent to the same server.

					DateEnd: [string or array of strings] String marking the end of the range of the HTML source code containing the date of a page.

					DateStart: [string or array of strings] String marking the beginning of the range of the HTML source code containing the date of a page. Note that "DateEnd" is optional if "DateStart" is specified. Useful if server provides no or wrong dates (for example a Usenet query using Google).

					EncodingPage: [string] Default character encoding for result pages (default: Latin-1). Examples: "ISO-8859-1", "UTF-8", "ISO-8859-2", "Shift-JIS".
 
					EncodingUrl: [string] Character encoding for search term "_agentQuery_" (default: Latin-1). Examples: "ISO-8859-1", "UTF-8", "ISO-8859-2", "Shift-JIS".
 
					EngineNextUrl: [string or array of strings] The Internet address(es) of the search engine(s) used for subsequent pages (if not identical to the address of the first page). The strings "_agentQuery_", "_agentNumber_" and "_agentOffset_" are replaced by the search term, the number of results and the offset of the current page. "_agentNumber_" is optional.

					EngineRelated: [string] Defines a URL for a 'see also' function of the search engine.

					EngineSite: [string or array of strings] Defines (a) (sub)domain(s) with or without a path to search. DEVONagent Pro uses an appropriate common search engine to perform the search. Example: 'devontechnologies.com/products/'.

					ExcludeLinksNamed: [array of strings] Defines an array of names of links which should be skipped.

					FilterSimilarPages: [Boolean] Enable or disable DEVONagent Pro's Similar Pages filter (default: true).

					FollowLinks: [Boolean] Enable or disable DEVONagent Pro's Follow Links option (default: true).

					GoogleTags: [Boolean] Defines whether 'googleon'/'googleoff' tags should be supported.

					HTTPShouldHandleCookies: [Boolean] Defines whether cookies should be handled by HTTP or not.

					Keyword: [string or array] One or more unique keywords used for quick searching (like "Mozilla Keywords") by entering the keyword followed by the search term in the URL field of browser windows.
 
					KeywordsUrl: [string] Defines an alternate URL used for the Mozilla-like keywords in the browser's address bar.

					LinksEnd: [string or array of strings] String marking the end of the range of the HTML source code containing the links to use (any position after the last link to use but before the next link). Example: "-- Footer Area --".

					LinksMatching: [string or array] Only links of the result pages matching this string or these strings are used (prefix/suffix * wildcards are supported). Examples: "*news.bbc.co.uk/*".

					LinksNotMatching: [string or array] Only links of the result pages not matching this string or these strings are used (prefix/suffix "*" wildcards are are supported).

					LinksStart: [string or array of strings] String marking the beginning of the range of the HTML source code containing the links to use (any position before the first link to use and after the last link to ignore). Note that "LinksEnd" is optional if "LinksStart" is specified. Example: "search results for".

					LoginPost: [string]Defines the optional HTTP POST parameters. Usage like "Post".  Can contain the placeholders "_agentUser_" and "_agent_Password_".

					LoginURL: [string] The address used to log into a website. Usage similar to "EngineUrl".  Can contain the placeholders "_agentUser_" and "_agent_Password_".

					NextLinkStart: [string] Defines the start of the range for the 'next results page' link.

					NextLinkEnd: [string] Defines the end of the range for the 'next results page' link.

					NextLinkName: [string] Defines the name of the link for the next results page (instead of having to use NextLinkStart/End).

					NoTopics: [array or string] Array of strings or string containing separated words to ignore in the topics list. Add site specific words here.

					OffsetPerPage: [integer] Increase for "_agentOffset_" after every page (default: 1).
 
					Operators: [integer] Bitmap describing the possibilities of the search engine and the required syntax (see below). The default value is 59 (1+2+8+16+32) meaning that AND, OR, NOT, phrases and parenthesis are supported.

					OperatorsDictionary: [dict] A dictionary containing key-string pairs to convert the name of operators to a different name required by the search engine. Possible keys are "AND", "ANDNOT", "OR", "NOT", "XOR", "NEAR", "BEFORE", "AFTER", "-".
 
					ParseLinks: [Boolean] Parse and unify links of common search engines (Google, Yahoo, Alltheweb, Altavista & Ask Jeeves) (default: false).

					Post: [dict or string] Send a HTTP POST instead of a HTTP GET action using this form data. Note: The strings of the form data can contain "_agentQuery_" and "_agentNumber_" placeholders.
 
					PostScan: [Boolean] Tell DEVONagent Pro to check if the retrieved pages match the search term (true) or to accept all (false) pages (default: true).

					ReformatPreformattedText: [Boolean] Usually DEVONagent Pro reformats preformatted text("<pre>...</pre>) by removing unnecessary line feeds or white spaces to increase the accuray of digests and summarizations. Turn this feature off if the result pages contain emails or Usenet postings. (default: true).

					ResultsPerPage: [integer] Number of results per page and maximal value for "_agentNumber_" (default: 10).
 
					RequiresCrawling: [Boolean] Marks this plugin as needing crawling.

					RequiresThumbnails: [Boolean] Marks this plugin as using only thumbnailed links. Crawling needs to be skipped.

					RoundResultsPerPage: [integer] Always round number of results per page ("_agentNumber_") to multiples of this value (default: 10).
 
					SkipsCrawling: [Boolean] Marks this plugin as skipping crawling.

					Start: [integer] The initial value for "_agentOffset_" (default: 0).
 
					StripTags: [array] Array of strings marking HTML tags defining blocks to strip.

					TextEnd: [string or array of strings] String marking the end of the range of the HTML source code containing the relevant text of a page. "TextStart" is optional if "TextEnd" is specified.

					TextStart: [string or array of strings] String marking the beginning of the range of the HTML source code containing the relevant text of a page. Note that "TextEnd" is optional if "TextStart" is specified. Useful if you're querying a specific site (all results have the same layout) to skip headers, footers or navigation of a page. This improves plain text display, digest and summarization.

					TextTags: [array] Array of strings marking HTML tags defining blocks to convert to text.

					Timeout: [integer] Sets the timeout for requests; default is 60 seconds.

					TitleEnd: [string or array of strings] String marking the end of the range of the HTML source code containing the title of a page.
 
					TitleStart: [string or array of strings] String marking the beginning of the range of the HTML source code containing the title of a page. Note that "TitleEnd" is optional if "TitleStart" is specified. Only useful if all results have identical or no titles (for example a Usenet query).

					UseListingResults: [Boolean] Treat the returned pages as results (and not as pages linking to the results). All "Links..." keys are unused in that case.

			

		
		Notes 

			Operator Bitmap: The following table gives you the necessary values for calculating the operator bitmap for the "Operators" key (see above):
 
			
					0 [value: 1]: Supports AND operator

					1 [value: 2]: Supports OR operator

					2 [value: 4]: Supports XOR operator

					3 [value: 8]: Supports NOT operator

					4 [value: 16]: Supports "" phrases

					5 [value: 32]: Supports () parenthesis

					6 [value: 64]: Supports NEAR operator

					7 [value: 128]: Supports AFTER operator

					8 [value: 256]: Supports BEFORE operator

					9 [value: 512]: Supports NEXT operator

					11 [value: 2048]: Use ANDNOT instead of NOT or '-'
 
					12 [value: 4096]: Convert search term to lower case
 
					13 [value: 8192]: Convert search term to upper case
 
					14 [value: 16384]: Engine scans for any word by default (not for all words) without an explicit operator
 
					15 [value: 32768]: Use AND/NOT instead of '+'/'-'
 
					16 [value: 65536]: Use '' instead of OR

					17 [value: 131072]: Supports OPT operator

			

			LinksStart, et al.: 'LinksStart', 'LinksEnd', 'LinksMatching', and 'LinksNotMatching' are three different ways to specifiy interesting links of a page. Specify none, some, or all of them depending on the search engine you are accessing. The more you specifiy, the higher the chances are that the plugin will still work after the structure of the HTML code or the links changed. First DEVONagent Pro retrieves links using 'LinksStart'/'LinksEnd', then filters them using 'LinksNotMatching', and finally matches them against 'LinksMatching'.
 
			Links vs. Results: 'LinksStart'/'LinksEnd, 'LinksMatching', and 'LinksNotMatching' are used for pages listing the results, 'TextStart'/'TextEnd', 'TitleStart'/'TitleEnd', and 'DateStart'/'DateEnd' are used for the result pages.
 
			FollowLinks: 'FollowLinks' applies to result pages only; the links of pages listing results are always used!

			No case: All string values are case insensitive.
 
		
	Troubleshooting


	DEVONagent Pro was created with robustness in mind. But still, computer hard- and software can write defective data or destroy files. If you have troubles with this applications, please refer to the methods below and also have a look at the FAQ. 

		
	
	
	
	
DEVONagent Pro behaves irrationally

		There is no software on this planet that has no bugs and if an application behaves irrational there is a good chance that your have just found one. But there also can be another cause: The application package could have become damaged, for example during an update or through a bug in a totally unrelated piece of software on your computer.

		Strange Application Behavior 

			If something happens like the following

			
					menus disappearing or silently refusing to do anything,

					windows showing graphical artefacts,

					or applications to opening at all or with strange error messages,

			

			please try to trash the application package. Then empty your web brower's cache, download the software in question again, and re-install it. In many cases this cures the problem.

			If this does not help try deleting DEVONagent Pro's preferences files located in '~/Library/Preferences' and starting with 'com.devon-technologies.agent'. Visit the Go menu in the Finder with the ⌥ key held to access your Library folder.

		
		Strange Behavior of Tabs 

			With Zooom/2 installed, tabs in tabbed windows behave stragely, e.g. close by just hovering the cursor over the tab. Another effect of Zooom/2 are scrolling problems in e.g. iTunes. Disabling Zooom/2 solves the problem.

		
	Problems interacting with DEVONthink

		DEVONagent Pro uses Mac OS X's Services internally to transfer the data to DEVONthink.  It DEVONagent Pro beeps when you try to transfer data to DEVONthink the most likely reason for this problem is that there's something wrong with the Services.

		You can use the third party application Service Scrubber  to try and modify this behavior; Service Scrubber should allow you to enable/disable services, rename them, or give them new keyboard shortcuts, though, some of these modifications can lead to communication problems between DEVONthink and DEVONagent Pro. Restore to the default settings to enable the DEVONagent Pro/DEVONthink link again.

	FAQ


	Do you have questions regarding our licensing policy, our products in the Mac App Store, or specific questions about DEVONagent Pro?

	
	
	
	
	
	
	

General questions

		Do you have any job opportunities? 
Yes, we may. Please visit our Work @ DEVONtechnologies page  for more information about current open jobs at DEVONtechnologies.

		Can I be a beta tester? 
Maybe. Our beta tester selection process is very deliberate; we try and select our beta testers carefully so that we're not wasting anybody's time, yours and ours. We're looking for people who can provide us with feedback quickly and clearly, who use different hardware and software from our other testers, and who are willing to send us their personal data if it's needed for debugging.

		If you want to be a beta tester, the best way to catch our eye is to be active in our user forums. We often ask active participants on the user forums if they can help us test particular features and new products. You can, of course, simply contact us. 

		Is the documentation available in my language? 
The online and PDF documentation is only available in English at the moment. Localizing documentation and other text-intensive materials to Deutsch, Francais, etc. is cost-intensive and error-prone so that we have decided to concentrate our resources on developing stable, robust, and feature-rich software. We will have localizations of the online help etc. as soon as we feel we have the necessary resources.

		Where does the name DEVONtechnologies come from? 
"Devonian (after Devon County, England), the geologic period from 410 to 360 million years ago. Also called the Reptile Age or Age of Fishes. First amphibians appeared on the land, that until then was only inhabited by trees and other plants  it was the departure into a new age." Named after the Devonian period, the DEVONtechnology  marks the departure into a new age of data processing.

		Note: Ray Troll  has even created songs and other art about this extremely important evolution step.


	Release schedules, Mac OS X, and Windows

		When is the next release coming 
We try not to announce precise timelines or feature lists for future releases, as we are a small software company with limited development resources; if one of us should happen to get the sniffles, or if there are other outside factors we need to devote our limited time to, it can easily impact our intended development schedules.

		In planning releases, we try to strike a balance among:

		
				responding to customer requests,

				the needs of our partners,

				supporting new operating systems features,

				providing consistent features across the product line,

				working efficiently within the structure of the code, (similar features often get handled at the same time),

				various business needs.

		

		We cannot make any assumptions on how those various factors will impact our daily workflow; in fact, it's often impossible to predict the final release date accurately when we start new projects. We try to plan our releases with a long term perspective so that they ultimately serve the needs of our customers, even if they don't necessarily get in everyone's favorite feature request every time.

		Why are your applications not compatible with my pre-release version of Mac OS X? 
In the past, we've noted that compatibility issues with a new major release of the operating system are usually resolved by Apple in the final stages before its release, and don't require any action on our part. If you are already using a pre-release version of Mac OS X, please check if our applications work with a newer pre-release, or wait until it reaches the release candidate status. We will then make all necessary adjustments for making our apps run on the first official release of the new version of Mac OS X.

		Any chance of a Windows versions of your products? 
We're very commited to Mac OS X and the superior Cocoa environment. For most of our applications, porting them to Windows would take longer than it would to rewrite them from scratch on the Mac. If you need to use Windows software but still don't want to miss our products consider running Windows on a Mac. 

	Purchasing

		How do I purchase an upgrade? 
Please use DEVONagent Pro > Check Upgrade Options  to find out what you need to upgrade and how much the upgrade is for you. If this option is not available in your copy of DEVONagent Pro this application might not be upgradable. Please visit the Upgrade Assistant  on our web site instead.

		What is your policy on software updates? 
Usually, all minor updates ('dot updates', such as version 1.2 to 1.3) to our applications are free and require neither purchasing an upgrade nor requesting a fresh license code. We charge for major upgrades, though, such as version 1.x to 2.x. If you purchased your license in our online shop within a reasonable time frame before a paid upgrade release (between 30 days and 6 months, announced on our website), we will provide you with a free upgrade. If you purchased this application on the Mac App Store click here. 

		Can I get the bundle discount also later? 
Bundles are cheaper than multiple single licenses because a bundle means less fees for the shop provider. But we grant the bundle discount under certain circumstances. Please contact our sales staff  if you purchased one of the bundled produts within the last two weeks.

		Do you give a discount to students and educators? 
Yes, we give 25 percent off the regular price of DEVONthink, DEVONagent, DEVONnote and the Infoworker's Bundle to students and educators. We also give volume discounts to institution or faculties. Please visit our Students, Educators and NPOs  page.

		Do you offer NPO licenses? 
Yes, we offer free licenses to non-profit organizations (NPOs) in the sense of charities. Learn more about our NPO program. 

		Can I use your software on multiple computers? 
Yes, our license explicitly allows one and the same person to use our application non-simultaneously on multiple Macs. So, for example, if you install one of our products on a laptop, your office Mac, and your home Mac, you may do so as long as you only use one of them at a time.

		I have no credit card. How can I purchase your software? 
We are selling currently through the online sales agent Share*It  to keep our administration as lean as possible. If you don't have a credit card, you can also pay via PayPal or by purchase order, wire transfer, or even cash. See our online shop  for more details.

		In addition we are also selling some of our products through the Mac App Store. Please open the App Store application on your Mac to learn more about which payment options Apple offers.

		Can I have more time for evaluating your apps? 
No problem. We happily give out 30 day licenses for evaluation purposes. Choose Help > Support Assistant to request a 30 day trial extension. This option is not available e.g. in DEVONagent Express.

		Why haven't I received my license code(s)? 
If you have purchased your license in our online shop and if there have been no technical problems on our side, your license codes have been sent out to you immediately after your purchase. Sometimes, however, they get stuck in spam protection filters (either yours or your ISP's). Please, check your spam protection filter, and if you cannot find the license codes there, use Help > Support Assistant to get them resent to you. If this also doesn't work, please contact us  and we'll try to get your license codes to you as quickly as possible.

		Where can I buy a 1.x license code, e.g. for use on Mac OS X 10.4? 
License codes for legacy versions are no longer available in our shop but even the latest license codes are always backward-compatible: You can use a version 2.x license code also for version 1.x of the same product. To use a legacy product simply purchase a license for the most recent version of the product in our online shop and use it with your legacy software. 

		

	Mac App Store

		How can I upgrade apps purchased in the Mac App Store? 
By Apple's rigid rules you couldn't. Upgrades are simply not available on the Mac App Store and upgrade offers outside of the Mac App Store are not allowed. In some of our apps there may be an upgrade option still available, though. Check the Read Me  to see if this is the case for you.

		Can I get a refund? 
We freely refund licenses purchased in our own shop. For apps purchased in the Mac App Store this is not possible, though, as Apple does not provide a refund and license withdraw mechanism. Sorry.

	Your software license

		Why does DEVONagent Pro not accept my license code? 
When you enter your license code and the 'Register' button stayes greyed out, try to enter ALL details, including your name and organisation, EXACTLY as they appear in our e-mail. Best practice is to copy-and-paste name, organisation (if entered) and license code from our email into the appropriate fields of the registration dialogue window. Also, please check if you have obtained the correct code for the correct edition of your software (e.g., a DEVONthink Pro license code will not work for DEVONthink Pro Office and vice versa) as well as version (DEVONthink 2.x will not accept a 1.x license code).

		I have lost my license code. How can I retrieve it? 
Use Help > Support Assistant to open the Support Assistant which has an option to get your license code resent to you. Alternatively visit the support area  on our web site.

		Does my license code work also for an older version? 
Yes, it does. All our license codes are backward-compatible to legacy versions of the same product and edition.

		Why do I have to enter my license code again? 
You only have to re-enter your license code after a complete reinstall of your system without a backup of your home folder or when the license code file has been deleted, e.g. by a preferences cleaner app. The license code is stored in a preference file in '~/Library/Preferences' (where ~ is your home folder). As long as this file is intact, you'll NEVER have to enter your license code again.

		Why does my DEVONagent Pro 1.x license not work anymore? 
DEVONagent Pro with version numbers greater than 1.x are paid upgrades. To use them you may need a new license code. Please use DEVONagent Pro > Check Upgrade Options  to find out what you need to upgrade and how much the upgrade is for you.

		Why does your application say that it expired? 
When we release a public beta of one of our applications, we remove the usual trial restrictions but make it expire at the end of the beta period. A new public beta or the final release is, of course, available when this happens.

		Please simply visit our Download page,  download a newer version that the one you have installed, and replace your copy with the newer one. FPlease first move the old application to the trash, then move the new one into its place.

		Note: Your license code will, of course, NEVER expire.


	Product-related questions

		Click here  to read questions and answers specific to DEVONagent Pro.

		If you have problems with DEVONagent Pro click here  to read the troubleshooting instructions and tips.

	Technology

	All commercial DEVONtechnologies applications are based on a proprietary AI technology, with rock-solid database foundation that allow them to manage large numbers of documents or knowledge bits while analyzing them almost instantly at the same time.

	
	
	
	
General Concept

		DEVONtechnology, on which all DEVONtechnologies' applications are built, is a new technology at the very beginning of its development. DEVONtechnologies constantly improves the technology and enhances it for more functionality, efficiency, robustness and flexibility.

		Development of the DEVONtechnology is a battle on two main forefronts of information processing technology. DEVONtechnologies is working hard on unifying both the top-down and the bottom-up AI concepts by imitating high-level functions and simulating the basic functionality of natural systems. This leads to highly functional, fast and efficient AI systems that can be used in a great variety of information processing contexts, such as pattern recognition, signal processing and information storage and retrieval.

	Features

		The DEVONtechnology is a rock-solid foundation suitable for a variety of completely independent applications. Therefore it is ideal for the rapid development of a huge range of new database-, signal-processing- and language-analysis-driven applications. The ability to deal with any kind of digital data makes it extremely flexible.

		The size of DEVONtechnology-based databases can, depending on the type of data stored, grow logarithmically and make indexing is completely unnecessary. Also, applications based on the DEVONtechnology improve themselves continuously (the more data they handle, the better the results), are language-independent and iron out any irregularities by applying fuzzy logic.

	Structure

		The DEVONtechnology consists of a kernel and several layers. Together they perform all the underlying computing, from 'simple' data handling to complex signal processing.

		Kernel: The kernel is the foundation for all layers and applications and is responsible for data handling, semantic and associative data processing, signal processing, fast statistic analyses and all fuzzy algorithms. It has to be as fast, flexible, and extensible as possible; it is 64-bit aware and uses a generic, proprietary file format (see above) allowing it to verify and repair low level data consistency, featuring logarithmic growth of the database and logarithmic speed decrease with increasing database size. The DEVONtechnology kernel is Unicode-aware, completely language-independent and self-optimizing and self-organizing.

		Layers: The layers form a shell around the kernel and provide high-level functions for the applications built on top of them. The database layer, for example, is used to store and organize data and supports all kinds of relations (1:n, n:1, n:n), hierarchies and freeform databases. No indexing or primary keys are required, strings can be unlimited in size and it's possible at any time to extend the range of pre-defined data types (Boolean, character, float, double, signed, unsigned, string, date, time, blob, color, size, and point). Another layer, the XML layer, makes it easy to handle XML code within the DEVONtechnology; it has a very small overhead, compared to DOM parsers or available XML databases, requires no indexing and supports the tight integration of other databases (and vice versa).

	Applications

		Some of the most likely applications for the DEVONtechnology are databases (knowledge bases, expert systems, search engines, table-of-content-generators, instant data-mining), intelligent agents, encryption, compression and archiving. Other uses for DEVONtechnology may be chat-bots, context-sensitive help, optical character recognition (OCR), speech analysis, recognition and synthesis, staticstics, thesauri and automatic translations.

		In particular, applications dependant on processing human language, either written or spoken, benefit from the flexible technology foundation. So, DEVONtechnologies' main focus in the development of new applications is in these areas: databases, 'intelligent' agents, text and speech analysis, statistics.

		Look forward to see a great range of different applications based on the DEVONtechnology. A few have already been announced on the DEVONtechnologies web site: 
		www.devontechnologies.com. 

	Other Products


	Besides DEVONagent Pro, DEVONtechnologies publishes a number of other commercial, shareware, and freeware applications, and services that you may be interested in.


	

	
	
	

	
	
	
	
	

	

	
At a Glance

		DEVONtechnologies is focused on developing innovative applications for finding, storing, and organizing information. Our main objective is to make complex yet flexible technology that is both easy to use and lightning fast.

		
				DEVONthink 

				DEVONagent 

				DEVONnote 

		

		All applications are based on the DEVONtechnology, a powerful and solid core unique to DEVONtechnologies. DEVONthink, DEVONnote, and DEVONagent are only the first of many more DEVONtechnology-applications yet to come.

		Also, we publish and distribute useful shareware and freeware applications that help you in your everyday work with your Mac.

		
				PhotoStickies 

				Freeware applications and Services 

		

		Newsletter & Forum 

			Would you like DEVONtechnologies to keep you informed about updates and new product releases? Subscribe to the newsletter. 

			And don't forget to have a look at our very lively user forum , where users of all skill levels meet to discuss our applications, talk about our technology, and exchange tips and tricks for DEVONthink & Co.

		
	DEVONthink

		Make the dream of the paperless office come true with DEVONthink and keep all your text and RTF files, scanned documents, notes, emails, images, chat logs, bookmarks, and multimedia files together in one simple to use database. DEVONthink allows you to integrate both local documents and live content from the Internet, keeping all project- related information stored in one easy-to-access place.

		Why DEVONthink? 

			DEVONthink not only stores documents, it also facilitates editing, analyzing, organizing, finding, and archiving your documents with its flexible work environment, powerful organization tools, and built-in AI architecture.

		
		Integrated Workspace 

			Unlike Mac OS X's Finder, DEVONthink provides an integrated work environment with all the tools you need for working with information of all kinds, from simple text to PDFs and multimedia files. DEVONthink can intelligently assist you with filing documents, finding similar files, or searching the database, saving you the trouble of having to manually manage thousands of files.

			As a native Mac application, DEVONthink is also tightly integrated with the Mac OS X operating system and its frameworks. It provides a dock menu, Services menu commands, and even makes heavy use of the Safari web browser engine and Mac OS X 10.4's advanced PDF library.

		
		A Paperless Life 

			DEVONthink Pro Office  comes with a number of 'paperless office' functions not present in other editions of DEVONthink:

			
					Advanced email archiving

					Scanner support including optical character recognition and special support for the Fujitsu ScanSnap

					Integrated Web server for sharing information with other users

			

		
		
		
			Click here to read more about DEVONthink. 
		

	DEVONthink To Go

		Your document (literally) at your fingertips. DEVONthink on the Mac keeps your documents organized. But what about when you are away from your keyboard? Put your documents into your pocket with DEVONthink To Go, the DEVONthink and DEVONnote companion for the iPad, iPhone, and iPod touch.

		Pocket Your Documents 

			Browse, view, and search your documents with the touch of your finger. Create new notes or take a picture of important information and convert it to a searchable PDF (requires DEVONthink Pro Office on the Mac). Quickly label documents and flag them for later review. Use the 'read' status to use it for reading the news feeds you archive in DEVONthink on the go.

			You decide which databases and which groups and documents to synchronize with your device. DEVONthink To Go connects to its Mac counterpart via WiFi.

		
		At a Glance 

			
					Take your DEVONthink or DEVONnote databases with you. Use the 'Sync' group to select only those groups and documents that are important for you.

					Use the global inbox to write down your notes without the need to immediately decide where to file them. If you use GTD you will know the idea.

					Quickly access all recently used items or view them as pins on a map. DEVONthink To Go stores your current location with every note you create on the go.

					Use the fast full text search to find the document you need with just a few taps. Use the power of SQLite on your mobile device.

					DEVONthink To Go honors the 'read' status of its Mac counterpart and can be used as a simple news feed reader.

					Set a password for your databases on your Mac and keep them from prying eyes on your iPad or iPhone.

					Capture data or open documents in third-party app like GoodReader. Add PDFs, images, or text documents from other apps to your DEVONthink Inbox.

			

		
		Read more  more about DEVONthink To Go or visit the App Store. 

	DEVONagent Pro

		DEVONagent Pro helps you search more efficiently on the web. It searches multiple sources, frees you from hunting for the really relevant results, and gives you power tools for your research.

		
				Filters bad results so you don't have to

				Shows results the way you want

				Creates reports in many formats

				Saves searches so you can continue later

		

		Your personal meta search engine 

			DEVONagent Pro is not a simple Google interface. It knows how to talk to search engines  and how to squeeze the best out of them.

			DEVONagent connects to as many search engines as you want, collects the data, and weeds out the junk that managed to slip through. It also scans your favorite websites and notifies you when it finds something that matches your query. It can even do all of this while you're sleeping; the results will be ready before you pour your first cup of coffee.

		
		Get the good stuff, skip the junk 

			DEVONagent Pro is all about filtering what you don't want and giving you the best tools to find more of what you really want.

			DEVONagent Pro doesn't simply trust the search engines. It filters all returned results again, allowing you to use advanced Boolean operators, proximity operators, and wildcards of unlimited complexity  something no single search engine allows you to do. DEVONagent's "scanners" can even find thumbnail galleries or linked PDF or Office documents for you. When you've found what you're looking but want a little more detail, the unique See Also list contains related pages from elsewhere in the search results, online and even from DEVONthink Pro.

		
		The information you want, the way you want 

			Every research tasks is different. DEVONagent Pro supports this with many ways to list, read, even explore your data.

			View the results as a list or as a smart text summary, and explore them with the topics map. Unread results are marked with a blue dot, just like in Apple Mail, so that you don't miss the one important piece of information you're looking for. Finally, for viewing web pages there's DEVONagent Pro's specialized web browser. Extract images, RSS feeds, links, email addresses, even linked documents with a single click and save them for reference or reuse.

		
		Save your research and come back later 

			Research is not only about finding, it's about collecting data, sharing it, and using it to create something meaningful.

			DEVONagent Pro exports your filtered and trimmed-to-the-max research results in a variety of formats, from a simple list of bookmarks to comprehensive RTF digests and PDF reports. The built-in, searchable archive keeps them for later reference, or you can send your results to DEVONthink. Finally, you can save your search and continue later on, or even share it with others via email.

		
		How DEVONagent Pro can help your research 

			
					Researchers: Stay up-to-date on your subject with scheduled searches. Search through specialized online databases, scan important web sites, and get smart summaries. Extract the key facts using DEVONagent Pro's research-centric web browser.

					Students & educators: Find better course materials faster, with DEVONagent Pro weed out the chaff. Cite references for your papers and extract images and lists of links with a single click. Save interesting results in DEVONagent's archive or in DEVONthink.

					Journalists: Keep an eye on as many other information sources as you like and dig deeper into the subject you are writing about. Use the smart See Also function to learn more about the article you're reading. Save a search and return to it later if you get interrupted.

					Lawyers: Search LexisWeb and FindLaw efficiently with advanced Boolean operations, and use See Also to find related data with a single click. Export comprehensive reports, or save the results for future reference in DEVONagents archive or in DEVONthink.

					Power users: Use DEVONagent Pro's specialized and easily automated browser to find and collect information and file it in DEVONthink. The object drawer and extensive AppleScript, JavaScript, and Automator support make it the #1 browser for DEVONthink users and enthusiasts.

			

		
		Click here to read more about DEVONagent. 

	DEVONagent Express

		You love Spotlight but it searches only your Mac? DEVONagent Express combines the ease-of-use and ubiquity of Spotlight with the powerful web search technology of DEVONagent. Just like Spotlight searches your computer DEVONagent Express searches the web and presents the results directly in its menu.

		Why DEVONagent Express 

			
					Let's you search the web as easy as using Spotlight

					Shows convenient summaries and preview pictures

					Express mode gives you results quickly but unfiltered

					Agent mode does a thorough research, filters advertisements and error pages, and gives you only really relevant results back

					Talks to Google, Bing, Yahoo, YouTube, Facebook, Twitter, the App Store, and more than 80 other general-purpose and specialized search engines

			

		
		Perfect integration 

			
					Located directly in the menu bar, always there when you need it

					You already know how to use it

					Opens results in your web browser or DEVONagent (if available)

					Drag results to other apps, e.g. your favorite bookmark manager, into documents, or to the Finder

					Accessible by pressing a hotkey

			

		
	DEVONagent Lite

		DEVONagent Lite puts web search to where it belongs: next to Spotlight into your menu bar. Search all major and many specialized search engines and databases with a single click.

		
				Web search always at your fingertips

				All major search engines and many special ones

				Opens results directly in your web browser

				Use it free of cost!

		

		Search the web like with spotlight 

			DEVONagent Lite adds a web search field to your menu bar. Google, Bing, and many more always at your service. Its global keyboard shortcut saves you even that click.

			Just click DEVONagent Lite's menu bar icon, or press its keyboard shortcut, and start typing instead of switching to your browser, opening a new window, and clicking the search field first. Hit Return and DEVONagent Lite opens the search results in your default browser.

		
		Use the best engine for the job 

			Google & Co. are great for general questions but often it's better to ask the right people who really know.

			Choose your search engine of choice from the magnifying glass pop-up menu to directly search in developer resources, blogs, dictionaries, directories, discussion lists, legal or medical databases, news, or reference sites such as Wikipedia. Find Facebook profiles, tweets, or images without deviation.

		
	DEVONnote

		DEVONnote helps you take notes and keep them organized. It keeps all your ideas, documents, important information, and even your web browser's bookmarks in one single, accessible place. DEVONnote supports you with professional, easy-to-use features, and helps create structure out of chaos with its unique AI functions.

		DEVONnote is the most sophisticated notepad application for Mac OS X, and the only one that uses AI (artificial intelligence) instead of relying on you organizing your data completely manually.

		Why DEVONnote? 

			DEVONnote was designed with the typical Mac user in mind-a user who is:

			
					Creative

					Savvy (whether at work or at home)

					Desiring quality software

			

			Consequently, DEVONnote comes with a clean, easy-to-use interface that gives you all the tools you need in a familiar Mac-like package. Even the most complex AI functions are just buttons, meaning one simple click can send DEVONnote into action, digging through all of your data to find a place for your latest note, or to show you all your ideas and concepts that are similar to the one you've just selected.

		
		Brain Food Included 

			Of course, creative people don't just 'have thoughts', they often need new inspiration, too. We understand that, and that's the reason why DEVONnote comes with a complete Safari-based web browser and solid, but flexible, bookmark-managing capabilities. With DEVONnote, you can browse your favourite websites, then clip and save the most important information directly to your DEVONnote notebook.

			But, of course, life is not just work! Use DEVONnote to watch and organize your favorite webcams, directly within your notepad.

		
		
			Click here to read more about DEVONnote. 
		

	Needful Things

		EasyFind 

			As an alternative to the Finder's find function, EasyFind finds files, folders, or contents in any file without the need for indexing. This is especially useful if you are tired of slow or impossible indexing, outdated or corrupted indices, or if you are just looking for missing features like case sensitive or insensitive search, Boolean operators, wildcards, or searching for phrases. In addition, EasyFind uses multi-threading and is therefore very responsive, even with multiple search processes running. The application provides contextual menus and Mac OS X Services, and displays the location of each item in a separate column for a better overview. EasyFind uses little memory, supports drag-and-drop and the clipboard, and optionally finds invisible items or items within packages.

		
		PhotoStickies 

			PhotoStickies puts all your favorite pictures on your desktop, as stickies, floating or even borderless. Sticky pictures may reside on your computer, or on the Internet. PhotoStickies also displays live webcams on your desktop, updates them automatically, and even records them like a VCR.

			Key features:

					Displays all image formats supported by Mac OS X

					Displays local images, pictures located on the Web or webcams

					Shows images as stickies or as desktop wallpaper

					Many live effects, e.g. alpha channels, transparency, color corrections

					Savable states

					Internet-based list of new webcams

					Can run as a menu extra

			

		
		ThumbsUp 

			ThumbsUp is a simple, drag-and-drop based utility designed to create thumbnail images from batches of pictures. (The application supports all Mac OS X and QuickTime image formats, including PDF documents.) Image size, quality, sharpening, and antialiasing are configurable, and images can be scaled by percentage or limited to a maximum size. With a scaling of 100 percent, ThumbsUp may be used as an ultra-fast, comfortable image converter.

			Use ThumbsUp to quickly create thumbnails, e.g., for using on your Web site or for sending by email.

		
		XMenu 

			XMenu brings back Mac OS 9's Apple menu back from the dead, adding its functionality to Mac OS X. One or more global menus to the right side of the menu bar let you easily access your preferred applications, folders (and subfolders), documents and files Furthermore, there's no explicit need for a configuration (like creating lots of folders and aliases or adding items to user-defined setups)-just activate the menus you like: Applications, Developer Applications, Home, Documents, or User-Defined (like the old Apple menu found in Mac OS 9).

		
		Freeware Services 

			Besides the full-blown freeware applications, DEVONtechnologies also offers a variety of useful services that extend the functionality of Mac OS X's Services menu and that allow Cocoa applications like TextEdit or DEVONthink to open PDFs like simple RTF files. These services include:

			
					BlueService

					CalcService

					PDF2RTFService

					WordService

			

		
		
			Click here to read more about DEVONtechnologies' freeware applications and services. 
		

	Appendix


	
	

	
	
	
	

	
	
	
	
Glossary

		Become familiar with these terms to get the most out of working with DEVONagent Pro.

		Keyboard symbols 

			
					⌘ The Command key, usually next to the Space bar.

					⌥ The Option key.

					⌃ The Control key (usually labeled with "ctrl").

					⇧ The Shift key.

				
					⇥ The Tab key.

					⏎ The Return key.

			

		
		Interface Elements 

			
					Contextual Menu: The menu that appears when you right-click, or click with the ⌃ Control key held, something; the contextual menu gives you access to frequently used commands that deal directly with the clicked object. [Read more...] 

					Plugin: Modules that act as the connector between DEVONagent Pro and search engines. Each plugin is the interface for one or more search engines. In addition, plugins can extend DEVONagent Pro with other functionality, e.g., scanners. DEVONagent Pro knows two types of search engine plugins: Cocoa-based (compiled) plugins, and XML-based plugins that can be created using the Plugin Assistant  or using a simple text editor. [Read more...] 

					Scanners: Plugins that act as filters for formal criteria such as 'is a thumbnail gallery' or 'contains links to Word documents'. Scanners are used to refine a search. [Read more...] 

					Search Window: A window in DEVONagent Pro that lets you select a search set, type in a query, start the search run, and finally view the search results. [Read more...] 

					Topics: A list of words extracted by DEVONagent Pro from the search results. Generally the most important words found in the found documents. Topics can be selected in the search window to focus the visualizer to this topic. [Read more...] 

					Visualizer: A graphic representation of topics and their relationships. Looks like a 'spider web' with 'bubbles' for each represented topic. [Read more...] 

			

		
		Operators, Queries, Search Sets 

			
					Boolean operators: Boolean operator are AND, OR, and NOT. They are used to define how words or parts of search terms relate to each other. Example: 'steve AND jobs'. [Read more...] 

					Query: A 'question' sent to one or multiple search engines through a search engine plugin. The query, the question, is written in a formalized style using search words, Boolean operators, and parenthesis. [Read more...] 

					Search engine: A computer that keeps an index of documents or information and that can be searched by providing it with a query. Search engines are generally used through a web browser. DEVONagent Pro emulates this human-computer interaction through plugins. 

					Search results: A pool of documents or links to documents, e.g., webpages or PDF documents, returned by a search run.

					Search run: The process of sending a query to one or multiple search engines.

					Search set: A set of parameters that defines how DEVONagent Pro conducts a search run. Search sets contain, e.g., which search engine plugins shall be used, which scanners shall be applied, and what to do with the search results when the search run is done. [Read more...] 

					Search term: See above: Query. [Read more...] 

			

		
	FAQ (product-specific)

		Is DEVONagent Pro an add-on to DEVONthink? 
Although we sell DEVONagent Pro together with DEVONthink in a bundle, it is a stand-alone application. Many of our customers use DEVONagent Pro for their research work but don't necessarily archive the results in DEVONthink.

		Can I write my own plug-ins for DEVONagent Pro? 
Sure. The complete documentation on how to make plug-ins for DEVONagent Pro is included in DEVONagent Pro's online documentation.

		Can I search my hard disk instead of the Internet? 
Not with the current version of DEVONagent Pro, no. However, our freeware application EasyFind  is able to preview found documents and highlight occurrences in file names. And there is still Spotlight, of course.

		How can I search already archived pages 
Open the archive (Tools & Open Archive) and use the search field there.

		What advantages does DEVONagent Pro have over Google & Co? 
The most important advantages over web search engines like Google are:

		
			
				DEVONagent Pro comes with an innovative visualizer

				It's possible to query multiple search engines at once

				Scanners look for certain kinds of webpages (in other words, pages with webcams, thumbnail galleries, videos, etc.)

				The application removes duplicate URLs/webpages, advertisements, spam, and HTTP errors

				DEVONagent Pro also removes similar pages on demand

				DEVONagent Pro scans the current contents of the pages and therefore doesn't return wrong results due to outdated search engine indexes

				DEVONagent Pro supports more advanced operators like NEAR, BEFORE, and AFTER

				DEVONagent Pro can follow promising links automatically

				DEVONagent Pro provides more useful and complete summaries in the Pages tab and complete digests based on selected/entered topics or the used query

				You can easily find similar results (See Also), archive results or transfer them to DEVONthink

		

		Why does DEVONagent Pro crash when displaying PDFs? 
DEVONagent Pro can crash when trying to display PDF files on Macs with Adobe Acrobat installed. Acrobat's browser plug-in is incompatible to the web browser engine of both Mac OS X and DEVONagent Pro. Remove the Acrobat plug-in from "/Library/Internet Plug-Ins" and everything should work as advertised.

		Why does DEVONagent Pro crash when I open a browser window or an archived page? 
DEVONagent Pro uses Apple's WebKit as its browser engine. When WebKit crashes it draws DEVONagent Pro with it into the abyss and there is little we can do about it. So, most DEVONagent Pro crashes related to browsing are in fact WebKit crashes. Please send us your crash log (in ~/Library/Logs/CrashReporter/) if you want to know for sure what happened.

		How do I completely uninstall DEVONagent Pro? 
To completely remove DEVONagent Pro from your Mac, see the instructions in the Read Me. 

	List of Search Sets

		Search sets are sets of parameters and options that control which search engines are used for a search run, which sites are crawled directly, what will be filtered, and what will be done with the returned results. DEVONagent Pro comes with a number of example search sets to get you started:
		
		
				Apple (Feeds): Crawls some RSS feeds (Downloads, PR and Hot News) provided by Apple.

				Blogs & Usenet: Queries Blogs and Usenet plugins.

				Macintosh News: Crawls the most popular Macintosh news sites and feeds (default query looks for Mac OS X 10.5 news).

				Marketing: Crawls more than 200 IT and Macintosh related news sites and feeds (default query looks for news related to DEVONtechnologies).

				New Software: Crawls some software trackers and directories for new releases by DEVONtechnologies.

				Web (Deep): Queries Bing, Exalead, Google and Yahoo plugins (up to 100 results per plugin).

				Web (Deeper): Queries Bing, Exalead, Google and Yahoo plugins (up to 100 results per plugin) and follows links (one level).

				Web (Deepest): Queries Bing, Exalead, Google and Yahoo plugins (up to 100 results per plugin) and follows links (maximal level).

				Web (Downloads): Queries the Web plugin and scans the results for downloadable archives.

				Web (Express): Queries the Web plugin (up to 60 results) in express mode (no filtering).

				Web (Fast): Queries the Web plugin (up to 100 results) but does not follow links to return results as soon as possible.

				Web (Movies): Queries the Web plugin and scans the results for linked movies and videos.

				Web (Thumbnail Galleries): Queries the Web plugin and scans the results for thumbnail galleries.

		

		Start with the Web (Fast) search set for your first search runs, then use the Search Sets  window to make your own or adapt an existing one for your requirements. [Read more...] 

		To built your own search set consider buying DEVONagent. 

	List of Plugins

		Technically, plugins are collections of URLs and procedures that DEVONagent Pro uses to access search engines on the web. They are either written in Cocoa or in human-readable XML (plain text with special syntax). In addition to simple HTML queries, DEVONagent Pro also supports and analyzes RSS, RDF, RSD, and Atom feeds.

		In the list below, you also find the associated quick search keywords in brackets. You use quick search keywords to send a query to a plugin directly from the address bar of a web browser window.  You can change the quick search keyword in the Plugins & Scanners  panel.

		Note: Some sites need a valid log-in. If you want to query these sites with a plugin, you need to enable cookies and manually log in with your web browser in advance. Then when you use DEVONagent Pro, the websites will recognize you as a returning user. You will find a note in the plugin description if a site needs a log-in.



		Search 

			Note: DEVONagent Pro presents this category in its menu separately above the other plugins to make them easier accessible.


			
					Bing: Searches the web using Bing,  Microsoft's  web search engine. Bing is considered to be the only real competitor to Google's search engine.

					Blekko: Searches selected websites on Blekko.  Blekko uses 'slashtags' to select the websites to search.

					Exalead: Searches the web using Exalead Search. 

					Google: Searches the web using Google.  Google is famous for ranking websites by the number of other sites linking to it. Google is now widely recognized as the world's largest search engine.

					Lucky Guess: Scans URLs derived from the search term. Very useful if you are looking for a company or a product website.

					Web: Searches the web using Bing,  Google,  and Yahoo.  Depending on the system language DEVONagent Proalso uses local search engines or local variants.

					Yahoo: Searches the web using Yahoo,  one of the three major search engines.

					Yandex: Searches the web using Yandex. 

			

		

		Apple 

			
					App Store: Searches Apple's App Store.

					Developer Connection: Searches the Apple Developer Connection database, the number one source for Mac OS X developers.

					Knowledge Base: Searches the Apple Knowledge Base , the #1 resource for finding technical information about Mac computers, the Mac Operating System and Apple software.

					Macintosh News: Scans major Macintosh news sites, namely Macworld,  MacCentral,  Macintouch,  and MacNN. Use this plugin to stay up-to-date about everything Macintosh.

					MacUpdate: Searches for Mac OS X software using Macupdate.  MacUpdate watches for the latest Macintosh software updates and visit over more than 800 websites a day, looking for version changes to software titles that developers themselves don't submit.

			

		
		Blogs 

			
					Google Blogs: Searches blogs using Google Blogsearch. 

					Technorati: Searches blogs using Technorati. Technorati indexes abut 27.4 million blogs (as of February 2006), classified by a staff of human editors.

			

		
		Browsers 

			
					All Cached Pages: Scans all pages cached by earlier search runs. Use this to include already scanned pages again in a new search.
 
					Bookmarks: Scans all websites bookmarked in DEVONagent, Safari, OmniWeb , Camino,  Chrome,  or Firefox for the search query. You can use this plugin to create your private mini-web with your bookmarks and search only this collection.
 
					DEVONthink Pro Office: Searches shared DEVONthink Pro Office  databases through the local web server. DEVONthink Pro Office has to be opened and web sharing started by the same user.

					History: Scans the pages you have visited recently with Safari or DEVONagent Pro for the search query. Useful to search for something you remember you have seen recently but you cannot remember where.
 
			

		
		Computer Science 

			
					ACM Digital Library: Searches the digital library of the Association for Computing Machinery. 

					Apple Cocoa-Dev: Searches Apple's cocoa-dev mailing list. Very useful if you do Mac OS X software development.

					Citeseer: Searches the CiteSeer library.  Citeseer is a scientific literature digital library and search engine that focuses primarily on the literature in computer and information science.
 
					Cocoabuilder: Searches Apple & Omnigroup  Cocoa mailing lists using Cocoabuilder. Very useful if you do Mac OS X software development.

					Koders Code Search: Searches for open source code examples and projects using Koders. Koders.com is a free search engine for open source code and new OSS (Open Source Software) projects. It indexes over 190 million lines of code and tens of thousands of projects.

			

		
		Dictionaries 

			
					Acronym Finder: Searches Acronym Finder,  the world's largest and most accurate dictionary of acronyms, abbreviations and initialisms.
 
					Dictionaries: Looks for word definitions in online dictionaries, namely Reference.com  and  Hyperdictionary. 
 
					Infoplease: Searches Infoplease,  a reference source that combines the contents of an encyclopedia, a dictionary, an atlas, and several almanacs with statistics, facts and historical records.
 
					Onelook: Searches for word definitions or translations using Onelook.  Onelook is a search engine that provides access to web-based dictionaries that define or translate words.
 
					Wiktionary: Looks for word definitions in the online dictionary Wiktionary.  Wiktionary is a free multilingual dictionary and thesaurus that's being written collaboratively. Anybody can edit any article and a record of changes is kept.
 
			

		
		Directories 

			
					Open Directory: Searches the Open Directory. The Open Directory (Dmoz.org) tries to be the largest free web catalog.

					WoW: Searches the WoW catalog. WoW categorizes websites by country, state or region and uses a professional editorial team.

					Yahoo Directory: Searches the Yahoo directory. The Yahoo directory was the world's first professionally edited web directory. It is currently divided into fourteen main categories.

			

		
		Discussion Lists 

			
					DEVONtech Forum: Searches DEVONtechnologies'  online discussion forum.  Find answers to your most pressing questions regarding DEVONagent Pro & Co.

					Usenet Groups: Looks for postings in Usenet groups using Google.  The Usenet is the oldest Internet-based community on the Internet with archives dating back to 1981, long before the web was widely used outside the academic community.

					Yahoo Answers: Looks for answers to user-posted questions on Yahoo Answers. 

			

		
		Government 

			
					FirstGov: Searches for US government information using FirstGov.gov. FirstGov.gov is the official US gateway to all government information, with millions of webpages from federal and state governments, the District of Columbia and U.S. territories.

					Google Government: Searches public US government materials using Google Goverment search.

			

		
		Images & Videos 

			
					Google Video: Finds videos using Google Video. 

					Images: Finds images using Google.com and Yahoo (including Flickr). Whatever image you are looking for, if it's on the Internet you should be able to find it.

					Info (Images): Searches for images using Info.com.  Info.com is a meta search engine that provides results from other search engines and pay-per-click directories.

					Info (Videos): Searches for videos using Info.com.  Info.com is a meta search engine that provides results from other search engines and pay-per-click directories.

					Picsearch: Searches for pictures using Picsearch. Picsearch is a search engine specialized in creating a searchable index of images.

					Webshots: Searches for pictures using Webshots. Webshots is the world's largest photo and wallpaper sharing site with more than 23 million monthly visitors and over 218 million photos.

					YouTube: Searches for videos on the popular video clip service YouTube. 

			

		
		Legal 

			
					FindLaw: Searches for legal materials using FindLaw.  FindLaw is the highest-trafficked legal website, providing a comprehensive set of legal resources on the Internet for legal professionals, businesses, students and individuals.

					Lexis: Searches for legal materials using Lexis.  LexisNexis provides customers with access to billions of searchable documents and records from more than 45,000 legal, news and business sources.

			

		
		Medical 

			
					Clinical Trials: Searches for materials on ClinicalTrials.  ClinicalTrials provides regularly updated information about US federally and privately supported clinical research on human volunteers.

					FDA: Searches for material on the website of the U.S. Food and Drug Administration.  The index is updated every night as many FDA documents are time sensitive.

					Healthfinder: Searches for health-related materials using Healthfinder.  Healthfinder is a gateway to selected consumer health and human services information resources provided by government agencies and other organizations.

					MedlinePlus: Searches for health-related materials using MedlinePlus.  MedlinePlus brings together authoritative information from the National Library of Medicie (NLM), the National Institutes of Health (NIH) and other government agencies and health-related organizations.

					PubMed: Searches the PubMed bibliographic database.  PubMed provides access to bibliographic information that includes MEDLINE and OLDMEDLINE, as well as out-of-scope citations, citations that precede the date that a journal was selected for MEDLINE indexing and some additional life science journals that submit full text to PubMedCentral and receive a qualitative review by the NLM.

					WebMD: Searches for health-related materials using WebMD.  WebMD provides valuable health information, tools for managing your health and support to those who seek information.

			

		
		News 

			
					BBC News: Searches for news on BBC News. 

					Google News: Searches for news using Google News.  Google uses its own search engine to scan important news websites and automatically compile a news portal using the found data.

					Info News: Searches for news using Info.com.  Info.com is a meta search engine that provides results from other search engines and pay-per-click directories.

					Reuters: Searches for news on the Reuters  news database. Reuters is a global information company providing information tailored for professionals in the financial services, media and corporate markets.

					RocketNews: Searches for news using Rocketinfo.  Rocketinfo continuously searches and indexes over 16,000 Internet sites, 70,000 RSS and blog sources as well as client-defined content channels, for current news and business information.

					Topix: Searches for news using Topix.  Topix provides a news portal that aggregates news from other sources.

					WorldNews: Searches for news on the World News Network.  World News Network ranks as one of the top sites for world news on the Internet. It includes more than 3,000 sites and covers 24 languages. These are categorized by geography and subject.

					Yahoo: Searches for news on Yahoo News.  Yahoo uses its own search engine to scan important news websites and automatically compile a news portal using the found data.

			

		
		Patents 

			
					Google Patent Search: Covers the entire collection of patents made available by the USPTO, from patents issued in the 1790s through those issued in the middle of 2006. It doesn't include patent applications, international patents, or U.S. patents issued over the last few months.

					US Patent Office: Searches for patents on the US Patent and Trademark Office homepage. 

					WIPO: Searches for patents using WIPO. The World Intellectual Property Organization (WIPO) is an international organization dedicated to promoting the use and protection of works of the human spirit.

			

		
		References 

			
					Google Scholar: Searches for scholarly literature using Google Scholar. Google Scholar indexes scholarly literature across many disciplines and sources.

					Googlism: Lists the 'knowledge' stored in the Google  database about a given search word. Googlism  will find out what Google thinks of you, your friends or anything.
 
					Gutenberg.de: Searches for literature in the German-language Project Gutenberg  database of free ebooks.

					Gutenberg.org: Searches for literature in the English-language Project Gutenberg  database of free ebooks.
 
					Highbeam: Searches for articles on Highbeam Research.  HighBeam names itself the premier online research tool for business and academic use with more than 80 million articles from the archives of over 6,500 newspapers, magazines, journals, and other publications.

					Internet Public Library: Searches for literature in the The Internet Public Library.  The Internet Public Library is a public service organization and a learning and teaching environment at the University of Michigan School of Information.
 
					JSTOR: Searches for articles on JSTOR.  With more than a thousand academic journals and over 1 million images, letters, and other primary sources, JSTOR claims to be one of the world's most trusted sources for academic content.

					Philosophy: Searches for literature in the Stanford Encyclopedia of Philosophy. The Stanford Encyclopedia of Philosophy is maintained and kept up to date by an expert or group of experts in the field.
 
					Poetry: Searches for English poetry using the Electronic Poetry Center,  founded by Loss Pequeo Glazier and Charles Bernstein.
 
					SEC: Searches the EDGAR database of the SEC. 

					Wikipedia: Searches for articles in the free online encylopedia Wikipedia.  The content of Wikipedia is free, written collaboratively by people from all around the world. Begun in 2001, Wikipedia has rapidly grown into the largest reference website on the Internet.
 
			

		
		Science 

			
					American Chemical Society: Searches for materials on the American Chemical Society (ACS)  website. The American Chemical Society is a self-governed individual membership organization that consists of more than 158,000 members at all degree levels and in all fields of chemistry.
 
					IngentaConnect: Searches online journals using IngentaConnect.  IngentaConnect publishes scholarly and professional journals in all subject areas. It supports and produces more than 3,000 online journals.
 
					ScienceGems: Searches for materials using ScienceGems.  ScienceGems indexes more than 14,000 science resources sorted by category, subcategory and grade level.
 
					Scinet: Searches for materials using Scinet.  SciNet claims to be the Internet's premier science and technology search engine since 1999.
 
					Scirus: Searches for materials using Scirus.  Scirus is a science-specific search engine indexing over 200 million science-specific webpages.
 
			

		
		Social Networking 

			
					Twitter: Searches for tweets on Twitter. 

					Facebook Profiles: Searches Facebook  profiles.

			

		
	List of Scanners

		Scanners do not query search engines but filter webpages that to not match their criteria. For example, scanners can filter all pages that do not contain links to images or Office documents, pages that do not contain email addresses, or pages that have no embedded images. You can also use scanners to restrict search runs to RSS feeds, pages with linked documents, or to thumbnail galleries. Scanners filter out all pages that do not match.

		Also, scanners are used by the sidebar  of web browser windows  to filter out certain elements and display them lists, e.g. links, images, or news feeds.

		By default, DEVONagent Pro comes with the following scanners that you can use in search sets. 

		
				All Links: Lists all links of a page, e.g. found by a secondary query.

				Code: Looks for code snippets.

				Email Addresses: Looks for email addresses and recognizes even non-linked and scrambled addresses like "info at devon-technologies dot com".

				Embedded Images: Lists all images of the page, e.g. found by a secondary query.

				Linked Audio files: Looks for linked audio files and audio streams.

				Linked BibTeX & LaTeX Files: Looks for linked BibTeX and LaTeX files.

				Linked Binary Files: Looks for linked downloadable compressed archives and disk images.

				Linked Documents: Looks for linked PDF, PostScript, OpenOffice, StarOffice, Microsoft Word, Microsoft PowerPoint or text documents.

				Linked Scripts: Looks for linked AppleScript scripts.

				Linked Spreadsheets: Looks for linked spreadsheet files (XMLSS, Microsoft Excel, CSV, TSV).

				Linked Vcard files: Looks for linked business card files (.vcf)

				Linked Video Files: Looks for linked video files and streams.

				RSS, RDF, RSD & Atom Feeds: Looks for linked RSS, RDF, RSD and Atom news feeds.

				Thumbnail Galleries: Looks for images in an image gallery. Lets pass all pages containing (usually little) images linked to (usually larger) image files a.k.a. thumbnail galleries.

				Tubes: Looks for embedded multimedia objects like audio, video, movies, streams, or Flash animations.

				Wallpapers: Looks for desktop background pictures.

				Webcams: Looks for web cams.

		

	Log message codes

		DEVONagent Pro logs all pages filtered out in the log, together with a short code describing why it was filtered. Use the log tab of search windows  to find out which pages have been dropped and of which reason.

		HTTP Error Codes 

			These error codes are standard HTTP error codes delivered directly from web server that DEVONagent Pro asked for a file:

			
					301: Moved permanently

					302: Moved temporarily

					401: Authorization required

					403: Forbidden

					404: Page not found

					500: Internal server error

			

		
		DEVONagent Pro Error Descriptions 

			These errors appear in the log when communication problems with the web server occurred, or, more likely, when DEVONagent Pro filtered the page out due to its search strategy or user-defined settings. 

			
					Advertisements: Link or frame probably contains only advertisement or banners

					Archived: Identical page has already been archived (if "Archived Pages" filter is activated)

					Failed: Search engine could not be reached

					Filtered by scanner: Page did not pass the selected scanner

					Identical: Identical page with different URL already found

					Incomplete: Download could not be completed

					Junk: Page contains almost no useful information (if the article filter  filter is activated)

					Language: Page does not match the language selected in the language filter

					Links: x of y: Pages delivered as a result by a search engine. Numbers indicate used links vs. returned links. If the number of used links is lower than the returned one, then either another search engine already returned the same link or the host is blocked. 

					Lookup failure: Domain of website not found

					No content: Page does not contain any text

					No match: Page does not match the query term

					Only links: Only links matching the query term found (if Follow Links  is activated)

					SPAM: Page tried to fool search engines but does not match the query term without those tricks

					Similar: Similar page (page with different layout but similar text) with different URL already found (if Similar Pages  is activated)

					Skipped: Domain was skipped because it matches one or more entries in the list of unwanted sites 

					Too big: Page is larger than the maximum size defined in the preferences 

					Unknown data: No HTML or text content

			

		
	Version history

		Version 3.0 is a major upgrade bringing literally hundreds of new features and detail enhancements. Learn more about the highlights in DEVONagent Pro3.0 compared to earlier versions: [Read more...] 

		Version 3.2 

			This maintenance release updates a number of plugins, improves the help integration, and fixes a number of minor issues. This update also makes it possible to download DEVONagent Pro as a trial version from the DEVONtechnologies website  and use it with a valid Mac App Store receipt.

			DEVONagent Pro:

					NEW: DEVONagent Pro accepts a valid Mac App Store receipt, too.

					NEW: Tutorials are directly accessible from the Help  menu and the front page of the Welcome Assistant. 

					NEW: Express mode is compatible to the DuckDuckGo plugin.

					NEW: Action scripts receive found scanner objects, too.

					Improved: See Also drawer uses only supported URL schemes returned by DEVONthink Pro. 

					Improved: Handling of feeds not containing dates.

					Improved: Scripting supports categories of Atom feeds.

					Fixed: Script Post > To del.icio.us doesn't require user/password anymore and uses the current tab instead of a new one.

					Fixed: Glitches of scheduled search windows.

					Fixed: Crash while browsing results.

					Fixed: Incompatibility of tab bar to Accessibility.

					Fixed: Removing user-defined XML plugins from subcategories didn't work.

					Fixed: Click to Play button in Welcome Assistant was not localized.

					Fixed: Keychain scripting is no longer used as its not available anymore on OS X 10.7 "Lion" and later.

					Fixed: Minor other user interface glitches.

			

			DEVONagent Express or higher:

				
				
					Improved: Retrieval of titles and descriptions for links, e.g. for the results of the Facebook Profiles plugin.

					Improved: Updated plugins:  Medical > PubMed, Images & Videos > Webshots, and Images & Videos > Picsearch.

					Improved: Updated Tube scanner. 

					Improved: Animated frame changes of tooltip of menu extra results.

					Fixed: Rare issue of search engine returning too many results in case of complex queries.

			

			All editions:

					Improved: Plugin Patents > Google Patents Search  updated.

					Improved: Help integration.

					Improved: Overall performance and stability.

					Fixed: Cursor is now an arrow instead of an I-beam over popup and clear buttons of search fields.

			

		
		
		Version 3.1.2 

			This update is a maintenance update that brings support for Google Chrome bookmarks, allows you to add scripts to toolbars, can generate preview thumbnails via Thumbshots.com, opens the menu extra also in OS X 10.7 Lion's fullscreen mode (via the hotkey), and fixes a number of minor bugs and glitches.

			DEVONagent Pro:

					NEW: Support for Google Chrome bookmarks.

					NEW: Scripts inside the subfolder "Toolbar" can be added to the toolbar of search and browser windows. Custom icons are used if available.

					Improved: See also support for the DEVONtechnologies user forum. 

					Improved: Apple Mail is no longer used as fallback if sending email fails.

					Improved: Support Assistant.

					Fixed: Disabled plugins were listed in the popup menu of the menu extra.

					Fixed: Search engines returned too many results in case of proximity operators followed by multiple other words or operators.

					Fixed: Localized names for Safari's reading list.

			

			DEVONagent Express or higher:

				
					NEW: Thumbnails can alternatively be generated via Thumbshots.com  (faster but lower quality). [Read more...] 

					Improved: Marketing default search set.

					Improved: Thumbnail Gallery scanner.

			

			All editions:

				
					Improved: Updated References > SEC plugin.

					Improved: French localization.

					Improved: About and splash panels.

				
					Fixed: Minor interface glitches.

			

		
		Version 3.1.1 

			DEVONagent Pro:

					NEW: Scripts > Window > Open Last Safari session  opens last Safari session.

					NEW: Search windows  display number of unread results in upper right corner.

					NEW: Names of plugins can be used as "Mozilla keywords"  in browser window address bar.

					Improved: Slightly revised scanner popup menus.

					Improved: See Also results for new DEVONtechnologies website and apple.com.

					Improved: Embedded Multimedia  scanner renamed to Tubes.

					Improved: Revised and completed German and French localizations of description of scanners.

					Fixed: See Also pane listed sometimes related websites twice.

					Fixed: Automator actions compatible to OS X 10.7 Lion and DEVONthink Pro (Office) 2.x. 

					Fixed: Issues with handling of saved searches.

					Fixed: Some menu items were not disabled in OS X Lion's fullscreen mode.

					Fixed: Support Assistant updated for new DEVONtechnologies website.

					Fixed: Support Assistant did no longer show tutorials.

			

			DEVONagent Express or higher:

					Improved: DEVONtech Forum, Googlism, PubMed, Twitter, and Wiktionary plugins updated.

					Improved: Wallpaper, Thumbnail Gallery, and Tubes scanners.

					Improved: Filtering of links to login pages or social bookmarking.

					Fixed: Various glitches of Preferences, Menu Extra tab. 

					Fixed: Memory leak of Wallpaper scanner.

			

			All editions:

					NEW: Search fields support also keywords and names of plugins as well as names of search sets followed by a colon, e.g. "google:term" or "marketing:apple", to easily switch the current plugin/search set.

					Improved: Tooltips of popup menus of search fields include keywords, too.

				
					Improved: Links updated for new DEVONtechnologies website. 

					Fixed: Various other minor bugs and glitches.

			

		
		Version 3.1 

			DEVONagent Pro:

					NEW: Completely revised, dynamic See Also  pane.

					NEW: More useful See Also  results for the DEVONtechnologies website  and Apple's developer website. 

					NEW: Contextual menu command Add Image To Archive.

					Improved: Slightly revised highlighting of selected objects in icon views.

					Improved: View > Show Icon Previews  toggles the icons in all currently visible panes.

					Improved: ⎋ key can be used to exit full screen mode of search windows on OS X 10.7 Lion.

					Improved: Scripts  menu supports custom icons.

					Improved: Plugin Assistant  recognizes additional parameters.

					Improved: AppleScript support.

					Improved: Mac App Store compatibility.

					Fixed: Frame and zooming of search windows were not always correct.

					Fixed: Advertisement filter didn't always work on OS X 10.7 Lion. 

					Fixed: Several glitches of download manager on OS X 10.7 Lion.

					Fixed: Adding images to DEVONthink sometimes submitted a wrong MIME type.

					Fixed: Random bug of See Also causing poor results.

					Fixed: Opening multiple selected objects in PhotoStickies  could launch multiple copies of PhotoStickies.

					Fixed: Icon previews were not shown for all DEVONthink Pro  results.

					Fixed: Several glitches in the Support Assistant. 

			

			DEVONagent Express or higher:

					NEW: Several additional symbols ($%) are now supported for searching for price or legal information.

					Improved: More reliable Webcam, Embedded Multimedia, Thumbnail Gallery, and Wallpaper scanners.

					Improved: Marketing and Apple (Feeds) search sets.

					Improved: Embedded Multimedia and Linked Video scanners recognize .f4v files.

					Improved: Thumbnail Gallery scanner.

					Improved: Advertising filter.

					Improved: Similar Pages filters now only pages without any additional, unique objects if a scanner is selected.

					Improved: Filtering of links to cached pages.

					Improved: Higher quality of icon previews for Facebook profiles.

					Improved: Default settings for some search sets.

					Improved: Handling of redirect/forward patterns.

					Improved: Compatibility of RSS parser to buggy feeds.

					Improved: Handling of storages used by background processes.

					Fixed: Various issues of handling of [range] wildcards.

					Fixed: Embedded Multimedia scanner is again compatible to YouTube. 

			

			All editions:

					Improved: DEVONtech Forum plugin.

					Improved: Reliability, performance, and memory management.

					Fixed: Further minor bugs and glitches.

			

			Note: Characters separated by dots are now considered to be abbreviations and therefore handled like words separated by hyphens, e.g. the term a.b.c is equal to "a b c" OR abc and matches a b c, a.b.c, abc, a-b-c etc.


		
		Version 3.0.5  3.0 

			Skipped.

		
		Version 2.3.1 

			
					NEW: 'Open Current URL in RSS Reader' script, opens the URL of the frontmost browser window in the default RSS reader.

					NEW: Button of web PDF views to save document to download folder (Mac OS X 10.5 'Leopard' only).

					NEW: Smart update handling using Sparkle.

			

			
					Improved: Plugins updated: Citeseer, Clinical Trials, DEVONtechnologies user forum, Email, Feeds, Linked Audio, Linked Video, Healthfinder, Nucleotide, PubMed, MedlinePlus, Medscape, WebMD.

					Improved: Scanners updated: Thumbnail Galleries, Wallpapers, Webcams.

					Improved: Search sets updated: Macintosh News, Marketing.

					Improved: Spam and advertisement filters.

					Improved: Thumbnail retrieval for scanners.

					Improved: Following of links.

					Improved: Unification of URLs.

					Improved: Retrieval of author from RSS feed.

					Improved: Retrieval of titles/descriptions for links.

					Improved: Filtering of links to social bookmarking and translation services, search engines.

					Improved: Compatibility to bad HTML/XML code and bookmarks not conforming to RFC 1808.

					Improved: Handling of browsing history.

					Improved: 'Open Linked JPEG Images' and 'Open Linked JPEG Images in Tabs' scripts.

					Improved: Shortcut for full screen mode changed to ⌘F8 for compatibility with Spaces on Mac OS X 10.5 'Leopard'.

					Improved: Contextual menu plugin more compatible on Mac OS X 10.5 'Leopard'.

					Improved: Further minor user interface enhancements.

					Improved: JavaScript support optimized for Mac OS X 10.4.11 or later.

					Improved: Naming of shortcuts for scripts supports also 'shft' instead of 'shift'.

					Improved: Error logging.

					Improved: French localization.

					Improved: Overall search and archiving performance.

					Improved: Compatibility to Mac OS X 10.4 'Tiger'.

			

			
					Fixed: Bug causing links to be followed.

					Fixed: Possible issues with Mac OS X 10.5 'Leopard' and Intel-based Macs.

					Fixed: Minor bugs and glitches.

			

			
					Removed: 'Add Results to DEVONthink Pro' script. Will be part of a future release of DEVONthink Pro.

			

		
		Version 2.3  1.0 

			Skipped.

		
	License Agreement

		PLEASE READ THIS LICENSE CAREFULLY BEFORE USING THIS SOFTWARE. BY USING THIS SOFTWARE, YOU ARE AGREEING TO BE BOUND BY THE TERMS OF THIS LICENSE AGREEMENT. IF YOU DO NOT AGREE TO THE TERMS OF THIS LICENSE, DELETE THE SOFTWARE OR RETURN THE SOFTWARE AND RELATED DOCUMENTATION TO DEVONTECHNOLOGIES, LLC.

		1. License: The application and other components (sound and graphics) accompanying this License, whether on disk, in read only memory, or on any other media (the Software), and the related documentation are licensed to you by DEVONtechnologies. You own the disk on which the Software is recorded but DEVONtechnologies and/or DEVONtechnologies Licensor(s) retain title to the Software and related documentation. This License allows you to non-simultaneously use the Software on multiple computers by the same person.

		2. Restrictions: The Software contains copyrighted material, trade secrets and other proprietary material and in order to protect them you may not decompile, reverse engineer, disassemble or otherwise reduce the Software to a human-perceivable form. You may not sub-license, modify, rent, lease, or create derivative works based upon the Software in whole or in part. You may not distribute the Software in any form, including, but not limited to, electronic information service 	distribution, bulletin board distribution, and magnetic or optical medium distribution.

		3. Disclaimer of Warranty on Software: You expressly acknowledge and agree that use of the Software is at your sole risk. The Software and related documentation is provided AS IS and without warranty of any kind.

		4. Limitation of Liability: UNDER NO CIRCUMSTANCES INCLUDING NEGLIGENCE, SHALL DEVONTECHNOLOGIES BE LIABLE FOR ANY INCIDENTAL, SPECIAL OR CONSEQUENTIAL DAMAGES THAT RESULT FROM THE USE OR INABILITY TO USE THE SOFTWARE OR RELATED DOCUMENTATION. In no event shall DEVONtechnologies total liability to you for all damages, losses and causes of action (whether in contract, tort (including negligence) or otherwise) exceed the amount paid by you for the Software.

		Apple, Carbon, Classic, Cocoa, ColorSync, Darwin, Mac OS X, QuickTime, Quartz and all other registered names are trademarks of their respective owners.

	Credits

		SMTPMailDelivery 

			Dante Palacios 

			The SMTPMailDelivery library is used according to the MIT License. 

		
		Video JS 

			Copyright  2010 Zencoder, Inc. 

			The Video JS player is used according to the LGPL v3. 
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