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READ ME
In this chapter:
The DEVONagent Pro Advantage
System Requirements
Installing, Updating, Removing
Trial Restrictions
Version history
License Agreement
Credits

5
6
6
6
7
10
10

Web Searching: Fed up with Web searches that
return loads of useless links? Using advanced search
techniques, DEVONagent Pro takes on all those
tedious search-and-review tasks, releasing you to
concentrate on relevant results.
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THE DEVONAGENT PRO ADVANTAGE

WHY DEVONAGENT PRO?

WHAT DEVONAGENT PRO DOES FOR YOU

Using advanced search techniques, DEVONagent

Using both standard and specialized search

Pro takes on all those tedious search-and-review
tasks, releasing you to concentrate on relevant

engines, DEVONagent Pro intelligently
summarizes the results -- fast!

results. It assists you in

Alternatively, DEVONagent Pro shows you an
even larger number of search results using its
unique graphical topic map.
DEVONagent Pro support your research while
browsing the Web, e.g., by listing all objects such
as images, linked documents, or outgoing links
embedded into a viewed page.
DEVONagent Pro archives your search results
with a single click or sends them to your
DEVONthink database.
Instead of making you repeat actions,
DEVONagent Pro performs those actions for
you. Combine search sets, schedule searches,
etc., to create your very own personalized search
assistant.

finding,
collecting, and
organizing
information from the Web or your DEVONthink Pro
Office databases with a powerful and flexible search
architecture. It also features a powerful, researchoriented web browser and simple built-in archive,
and tightly integrates with DEVONthink.
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PERFECT INTEGRATION
DEVONagent Pro integrates seamlessly with
DEVONthink. With just one click, archive your
search results, webpages, and other information
grabbed from the Web to your DEVONthink
database.
Select text in any application and use
DEVONagent Pro's Services menu or a
contextual menu item to search for it. The Menu
Extra keeps DEVONagent Pro at your fingertips.
Use various actions, including notifications and
AppleScript, to inform you of search results,
then send them to either DEVONthink or the
application of your choice to process them any
way you wish.
Learn more about why you should use DEVONagent
Pro, when you should use it, and how to run your
first query: See also p. 11ff

SYSTEM REQUIREMENTS
Every Mac running OS X Yosemite or later. In
addition, a fast Internet connection is highly
recommended.

INSTALLING, UPDATING,
REMOVING
Just move the DEVONagent Pro application
package to the Applications folder or any other
directory you have access to. Please note that OS
X Services and the connection to DEVONthink
work only for applications installed into one of the
Applications folders, and that logout and login or a
restart is required after installation.
To update an existing version of DEVONagent Pro,
simply copy the application package from the disk
image to your Applications folder, replacing the old
version. Your database(s) will not be affected.

If you would like to switch from the Mac App
Store variant of DEVONagent Pro to one directly
downloaded from the DEVONtechnologies website,
you can do so at any time. The official version will
accept your Mac App Store receipt as a valid license.
Copies not downloaded from the Mac App Store
also allow you to buy an upgrade to a higher edition
or version (if available).
To remove DEVONagent Pro traces from your
computer, trash the following files and folders (~
represents your home folder):
DEVONagent Pro
~/Library/Application Support/DEVONagent Pro
~/Library/Contextual Menu Items/DEVONagent
Pro CM.plugin
~/Library/Preferences/com.devontechnologies.agentexpress.*
Depending on whether you have installed the
following extras or not, remove them, too:
The product-specific scripts in ~/Library/Scripts
and ~/Library/Workflows
The contextual menu plugin in ~/Library/
Contextual Menu Items/
The Dashboard widget
Note: Depending the version of OS X you are
using, some files may or may not be installed on
your machine.

TRIAL RESTRICTIONS
Unregistered DEVONagent Pro runs for 60 hours
of non-continous runtime. Close the app to stop
the clock from ticking and re-open later to continue
your evaluation. The menu extra is restricted to 100
searches until DEVONagent Pro is registered.
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VERSION HISTORY
New

Improved

Fixed

Removed

VERSION 3.10
This release adds a new Google Scholar (Case Law) plugin and updates several other plugins and search sets.
For quick queries, it now supports DuckDuckgo Bangs in the internal browser. We've enhanced the support
for live streams with the webcam and video scanners and made it a bit easier to create a custom search plugin,
pasting in code you may find on our forums. And as always, we have improved the performance and stability of
DEVONagent Pro.
Note: Starting with version 3.10 DEVONagent Pro requires macOS 10.10 Yosemite or later.
Plugins added: Legal > Google Scholar (Case Law) plugin.
Added support for DuckDuckgo Bangs in the browser's address bar.
Added Markdown and Formatted Notes options to Window > Search Sets > Actions > Add results to DEVONthink >
Format.
Added Clutter-free layout option to Window > Search Sets > Actions > Add results to DEVONthink. Requires at
least DEVONthink 2.9.17.
Added support for XML with custom plugins.
Added "DatesKeyPath" key (JSON and XML) to retrieve the date of the result.
Added optional "method" AppleScript parameter to specify the HTTP method when downloading documents.
Added "last downloaded response" AppleScript property to retrieve the last HTTP-Status code and more.
Plugins updated: Patents > Google Patent Search, References > British Library plugins, News > BBC News,
News > Reuters, News > RocketNews, Legal > FindLaw, References > SEC.
Search sets updated: Marketing, Apple (Feeds), Blogs.
Video and webcam scanners work better with live streams.
Creating a new plugin no longer requires a URL, making it easier to create a plugin with code copied from our
forum.
If you have selected to download updates automatically, Update On Quit will be displayed depending on the
current progress of DEVONagent. Choosing this menu item will display a window about the pending update.
In the plugin editor, changing the default keywords of a plugin now resets the user customized keywords as
well.
The "paginated PDF" AppleScript property uses the last used print settings and sets the title.
Fonts of Preferences > General can be reset by holding the ⌥Option key.
Improved script Scripts > E-mail > Current URL.
Improved performance of scanner objects, browser window, search windows, and the Download Manager.
Improved character encoding support.
Improved filtering of social bookmarking links.
Using Help > Report Bug with the ⌥Option key held creates an extended bug report including the installation
path and startup volume format.
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Fixed an issue where an Express search didn't always return all results.
Fixed an issue where exporting a report required a .pdf extension, regardless of the previously selected
format.
Fixed an issue where Preferences > Menu Extra mounted volumes added to the user's startup items.
Fixed an issue where selecting a different scanner in browser and search windows caused an exception
(macOS 10.9 through 10.12)
Fixed an issue where the Express option of search sets was disabled when the secondary query was "*".
Fixed an issue where the number of scanner objects for a search result was not always identical to the number
of scanner objects shown in the scanner bar.
Fixed an issue with sending formatted notes or Markdown documents to DEVONthink.
Fixed some minor cosmetic issues with the user interface.
Fixed a rare crash caused by background processes.
Disabled Twitter plugin on macOS High Sierra as access to system-wide social accounts is no longer possible.
Removed script Scripts > E-mail > Current URL (Mail).
Removed plugins Info (News), Info (Images), and Info (Video).
VERSION 3.9.8
This maintenance release enhances the Search mode for automatically searching sites. It also improves
compatibility to Google Chrome bookmarks as well as the overall performance and reliability.
Improved Search mode for automatically searching sites.
Improved compatibility to Google Chrome bookmarks.
Improved handling of background processes.
Help > Report Bug sets the receiver if Postbox is the default email client.
Improved overall performance and reliability.
VERSION 3.9.7
This maintenance release sends all requests to Google or Bing over a secure connection (https). A new
contextual menu option returns more precise see-also results for selected text, and a contextual menu added
to the See Also pane of browser windows gives access to commonly used commands. The built-in search sets
Macintosh News (Latest/More) have been updated too.
Command See Related Text added to contextual menu of web views; useful to get more precise see-also results.
Contextual menu added to See Also pane of browser windows.
All requests sent to Google or Bing use secure connections (https) now.
Macintosh News (Latest/More) search sets updated.
See Also of search results lists also similar archived results now.
Related website are retrieved more reliably.
Improved installing and updating of scripts.
Issue where automatic naming of files, e.g. when dragging results to the desktop, could have failed.
Crash related to the DEVONthink databases plugin.
Rare crash related to closing the last tab if the tabs bar was always visible.
VERSION 3.9.6 ... 1.1
…
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VERSION 1.0
Initial release.
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LICENSE AGREEMENT
PLEASE READ THIS LICENSE CAREFULLY
BEFORE USING THIS SOFTWARE. BY USING THIS
SOFTWARE, YOU ARE AGREEING TO BE BOUND
BY THE TERMS OF THIS LICENSE AGREEMENT.
IF YOU DO NOT AGREE TO THE TERMS OF
THIS LICENSE, DELETE THE SOFTWARE OR
RETURN THE SOFTWARE AND RELATED
DOCUMENTATION TO DEVONTECHNOLOGIES,
LLC.
1. License: The application and other components
(sound and graphics) accompanying this License,
whether on disk, in read only memory, or on
any other media (the "Software"), and the
related documentation are licensed to you by
DEVONtechnologies. You own the disk on which
the Software is recorded but DEVONtechnologies
and/or DEVONtechnologies' Licensor(s) retain
title to the Software and related documentation.
This License allows you to non-simultaneously use
the Software on multiple computers by the same
person.
2. Restrictions: The Software contains copyrighted
material, trade secrets and other proprietary
material and in order to protect them you may
not decompile, reverse engineer, disassemble
or otherwise reduce the Software to a humanperceivable form. You may not sub-license, modify,
rent, lease, or create derivative works based upon
the Software in whole or in part. You may not
distribute the Software in any form, including,
but not limited to, electronic information service
distribution, bulletin board distribution, and
magnetic or optical medium distribution.

3. Disclaimer of Warranty on Software: You
expressly acknowledge and agree that use of the
Software is at your sole risk. The Software and
related documentation is provided "AS IS" and
without warranty of any kind.
4. Limitation of Liability: UNDER NO
CIRCUMSTANCES INCLUDING NEGLIGENCE,
SHALL DEVONTECHNOLOGIES BE LIABLE FOR
ANY INCIDENTAL, SPECIAL OR CONSEQUENTIAL
DAMAGES THAT RESULT FROM THE USE
OR INABILITY TO USE THE SOFTWARE OR
RELATED DOCUMENTATION. In no event shall
DEVONtechnologies' total liability to you for all
damages, losses and causes of action (whether in
contract, tort (including negligence) or otherwise)
exceed the amount paid by you for the Software.
Apple, Carbon, Classic, Cocoa, ColorSync, Darwin,
OS X, QuickTime, Quartz and all other registered
names are trademarks of their respective owners.

CREDITS
SMTPMAILDELIVERY
Dante Palacios
The SMTPMailDelivery library is used according to
the MIT License.
VIDEO JS
Copyright © 2010 Zencoder, Inc.
The Video JS player is used according to the LGPL
v3.
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GETTING STARTED
In this chapter:

Reasons for using DEVONagent Pro include:

Why use DEVONagent Pro?
When to use DEVONagent Pro?

11
11

DEVONagent Pro at a Glance
First steps with DEVONagent Pro

12
12

This chapter helps you get started with
DEVONagent Pro. It explains why and when to
use DEVONagent Pro, and gives you step-by-step
instruction in how to run a first query.

WHY USE DEVONAGENT PRO?
A common misconception is that DEVONagent Pro
is a simple front-end to Google or Bing. This is far
from the truth. DEVONagent Pro is a very capable
Internet research assistant that handles tedious
research tasks such as weeding out bad search
results, spotting linked documents, and finding
information on a webpage.
Searches with DEVONagent Pro take longer than
quick searches on a Web search engine because
DEVONagent Pro downloads each resulting page
instead of only presenting you with a link to it.
DEVONagent Pro searches also return fewer
results since DEVONagent Pro filters broken links,
advertisements, and outdated pages. This feature
actually saves time because you do not have to do all
this manually.

You get much better search results.
You don't have to do all the tedious, repetitive
tasks involved in a search; DEVONagent Pro does
them for you, freeing you to spend more time on
meaningful, more important tasks.
You can search more specifically using
DEVONagent Pro's advanced operators and
search sets.
You get the results in a much more natural
presentation in the Digest.
You can archive interesting searches and review or
expand those searches on another day.
You use a specialized web browser with researchcentric additions, e.g., the sidebar.
You can use DEVONagent Pro to run regular
searches when you are not at the computer,
and it will present the results, if any, when it has
finished.

WHEN TO USE DEVONAGENT
PRO?
DEVONagent Pro outperforms other Web search
engine, especially for research purposes, but it is
not necessarily a useful tool for simple, every-day
searches. Because DEVONagent Pro downloads all
results to your Mac to analyse and post-process, a
search run takes between a few seconds and several
minutes.
Use DEVONagent Pro for:
Getting answers to a question
Finding all available data about a subject
Searching multiple search engines and websites
with just one click
Scraping objects from webpages, e.g., images, email
addresses, or RSS feeds
Keeping up-to-date on a subject, e.g., with
scheduled searches
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Don't use DEVONagent Pro for:

THE ARCHIVE WINDOW

Finding the webpage of company X or product Y
Finding a very specific image or video
Finding the definition for a word quickly, e.g., on
Wikipedia

DEVONAGENT PRO AT A GLANCE
DEVONagent Pro hides complex functionality
but makes it available when you need it. Here's
a quick overview over the three main windows
DEVONagent Pro uses and what window elements
they offer.
SEARCH WINDOWS

You use the archive to save search results and recall
them later. See also p. 51ff

FIRST STEPS WITH DEVONAGENT
PRO
A first search: While DEVONagent Pro is a
real power tool, searches do not need to be
overly complex. Running a simple search using
DEVONagent Pro is no more complicated than
using Google or Bing.
Run a first search with a few simple steps
The next steps: Now that you know how to run a
first search you can take the next steps unaided.
Here are a few chapters for you to continue
exploring DEVONagent Pro:

You use search windows to enter your query (search
term), start the search, and view the results. See also
p. 39ff
WEB BROWSER WINDOWS

More common tasks
How to formulate a good query
How to create your own search sets
Customize DEVONagent Pro to your preferences
Create your own plugin if your search engine is not
supported
Finally, DEVONagent Pro and the
DEVONtechnologies website offer additional
information and assistance:
Open the Support Assistant for on-screen tutorials
and regularly updated tips
Read the frequently asked questions
Visit our lively user forum

You use web browser windows like any other web
browser plus DEVONagent Pro's research-centric
additions. See also p. 45ff
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COMMON TASKS
In this chapter:
How to find on the Internet
How to search beyond Google

13
13

How to customize DEVONagent Pro
How to set up a search set to crawl feeds
How to run a search automatically
How to archive search results

14
14
15
15

This chapter explains common tasks in
DEVONagent Pro in a step-by-step way and points
you to related topics.

HOW TO FIND ON THE INTERNET
DEVONagent Pro's main objective is to find stuff on
the Internet. It does so by sending a query (search
term) to a selected set of search engines, e.g.,
Google, collecting the results, analyzing them, and
presenting them to you.
You tell DEVONagent Pro which search engines
to use by selecting a plugin (contains instructions
telling DEVONagent Pro how to communicate with
a search engine) or search set (combinations of
multiple plugins and other options). DEVONagent
Pro comes with a large number of pre-fab plugins
and search sets already installed. See also p. 87ff

Click here to make DEVONagent Pro run the
search.
The best choice for a simple but comprehensive
search is the pre-fab Web (Fast) search set. It is a
multi-purpose search set that sends your query
to the three major search engines: Google, Bing,
and Yahoo. Alternatively, you can choose plugins
directly, e.g., the one for Google, in the magnifying
glass pop-up menu.
DEVONagent Pro Advantage: You can use
advanced Boolean operators. Doing so returns a
pre-processed summary including extracted topics
rather than just a simple list of links. In addition,
DEVONagent Pro queries multiple search engines
for you with one single click.
Next steps:
Fine tune your search with the Settings tab
Design a good query
Learn more about the advanced Boolean operators
Create your own search sets
Related topics:
The search window explained
List of pre-fab search sets
List of built-in search engine plugins

HOW TO SEARCH BEYOND
GOOGLE

Step by step: You are trying to find information
about the WikiLeaks disclosure of diplomatic cables.
Step 1: Open a new search window with File > New
Search.
Step 2: Choose the search set you want to use in
the magnifying glass pop-up menu: Web (Fast)
Step 3: Enter your query (search term): wikileaks
AND "diplomatic cables"
Step 4: Click Start.

DEVONagent Pro can not only run queries on
Google and Bing, but comes with a large number of
plugins that let it use less common search engines
such as FindLaw, PubMed, or Highbeam.
Just choose the right plugin before you start your
search from the magnifying glass pop-up menu in
the search field.
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Step by step: You are trying to find newspaper
articles about the former German defence minister
who had to resign because he copied large parts of
his doctor thesis.
Step 1: Open a new search window with File > New
Search.
Step 2: Choose the plugin to use in the magnifying
glass pop-up menu: References > Highbeam
Step 3: Enter your query (search term): "zu
Guttenberg" plagiarism
Step 4: Click Start.
DEVONagent Pro sends the results to the
Highbeam article search engine and presents you
with the results.
Click here to make DEVONagent Pro run this
search for you.
Next steps:
Design a good query
Learn more about the advanced Boolean operators
Related topics:
The search window explained
List of pre-fab search sets
List of built-in search engine plugins

HOW TO CUSTOMIZE
DEVONAGENT PRO

Step by step: You want to exclude all links to eBay
from the results.
Step 1: Open the Preferences, Search tab.
Step 2: Click into the Exclude Domains field.
Step 3: Add 'ebay.' (with the dot, but without the
single quotes) to the list.
This filters all results with addresses containing the
string 'ebay.'
Next steps:
Set the other preferences to your needs
Learn more about the other options in the
DEVONagent Pro menu
Learn more about the other options in the action
menu

HOW TO SET UP A SEARCH SET TO
CRAWL FEEDS
DEVONagent Pro not only queries search engines
for you, it can also search on its own by "crawling"
a specified list of webpages or news feeds and
scanning them for the search term. This feature is
handy when you have a number resources you want
to watch, e.g., subject-specific news sites or feeds.

Like most other Mac applications, DEVONagent
Pro can be customized to better fit your needs.
You adjust all of DEVONagent Pro's setting in its
Preferences.

Step by step: You want to search one of the New
York Times news feeds.
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Step 1: Click here to open the Search Sets
window. Open it manually using Window > Search
Sets.
Step 2: Click the + button to create a new set.
Name it, e.g., "New York Times".
Step 3: Switch to the Sites tab.
Step 4: Click here to open the New York Times
RSS page in a new web browser window.
Step 5: Show the Inspectors tab using Web >
Inspectors > Show and switch to the tab.
Step 6: Copy the address of any RSS feed of
interest by right-clicking it and choosing Copy
from the contextual menu.
Step 7: Switch to the Search Sets window and paste
it, e.g., by pressing ⌘V. or using Edit > Paste.
Repeat Steps 6 and 7 for any feeds that you want
to add to your "New York Times" search set. You
can now use this set like any other search set or
plugin. Instead of querying any search engines, it
will download the current state of all the feeds you
have added and search them for occurences of your
search term.
Next steps:
Run a first query
Design a good query
Learn more about the advanced Boolean operators
Run your search automatically
Related topics:
More about search sets

HOW TO RUN A SEARCH
AUTOMATICALLY
Search sets are not only collections of rules about
how to run a search, they are also the key to
research automation in DEVONagent Pro. Add a
default query to a search set and set its scheduler
to make DEVONagent Pro run the search when
you're not around, e.g., in the middle of the night,
and execute chosen actions when the search is
completed.

Step by step: You want to run the "Marketing"
search set automatically once every day and send
the results to you by email.
Step 1: Click here to have the Search Sets
window opened and the "Marketing" search set
selected for you.
Step 2: Switch to the Actions tab.
Step 3: Check Send mail to and enter your email
address.
Step 4: Switch to the Schedule tab.
Step 5: Select Daily and set the time to, e.g., 9 a.m.
As the "Marketing" search set contains a
default query on the General tab, you are done.
Tomorrow morning at 9 a.m. DEVONagent Pro
will automagically activate and run a search for
the default query of the "Marketing" set. When
it is finished, it will send a summary email to the
specified email address.
Note: Your Mac needs to be on at the time the
search set is scheduled to run. DEVONagent Pro
is not able to wake your Mac up from sleep mode.
Next steps:
Learn more about actions
Learn more about the schedule options
Related topics:
Learn more about search sets

HOW TO ARCHIVE SEARCH
RESULTS
After you have found good data on the Internet, it is
likely you're only halfway to your desired outcome.
You will want to keep the best results for future
reference. For this reason, DEVONagent Pro comes
with a built-in archive.
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Step by step: You want to archive results from a
search run.
Step 1: Run a search, e.g. with the Bing or Google
plugin.
Step 2: Switch to the Results tab, e.g., by pressing
⌘2.
Step 3: Select the results you want to archive.
Step 4: Choose Data > Add To Archive.
Step 5: The results have been saved to the archive
in a group named after your query.

Step by step: You want to archive all results of a
search run.
Step 1: Run a search, e.g., with the Bing or Google
plugin.
Step 2: Choose Data > Add All To Archive.
Step 3: The results have been saved to the archive
in a group named after your query.

As an alternative to using Data > Add To Archive, Data
> Add All To Archive, and Window > Archive, you can
use the Add, Add All, and Archive toolbar icons of the
search window. You may need to add the tools to
the toolbar using View > Customize Toolbar.
Next steps:
Work with the archive
Related topics:
Adding results to DEVONthink
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QUERIES
In this chapter:
Operators
Designing a search query

17
18

DEVONagent Pro provides powerful Boolean
operators that allow users to precisely define a
search query.
Queries can range from uncomplicated one-word
search terms to complex multi-term queries. The
rules for formulating queries are simple. By studying
the rules and the Boolean operators, and with a little
practice, users can 'tell' DEVONagent Pro exactly
what to look for in a search.

OPERATORS
PLUGIN/SET SELECTION

term1 AND term2: Contains term1 AND term2
term1 BUT term2: Contains term1 AND term2
term1 OR term2: Contains term1 OR term2
term1 XOR term2: Contains term1 or term2, but
not both
term1 EOR term2: Contains term1 or term2, but
not both
NOT term: Does not contain term
"term1": Contains the string term1, in exactly
this form; uses fuzzy matching (e.g. "DEVON
tech" matches also "DEVON-tech" or "DEVON
++++tech"); accepts also the '*' operator, like
'BEFORE' but more precise.
Besides the classic Boolean operators,
DEVONagent Pro features a number of operators
usually only found in high-end databases. Use them
as a replacement for AND and "quotes" to fine tune
your query.

BOOLEAN OPERATORS

term1 NEAR term2: term1 occurs 10 words or less
before or after term2
term1 NEAR/n term2: term1 occurs n or less
words before or after term2
term1 BEFORE term2: term1 occurs before term2
term1 BEFORE/n term2: term1 occurs n or less
words before term2
term1 NEXT term2: term1 occurs right before
term2 (shortcut for BEFORE/1)
term1 NEXT/n term2: term 1 occurs n or less
words before term2 (synonym for BEFORE/n)
term1 AFTER term2: term1 occurs after term2
term1 AFTER/n term2: term1 occurs n or less
words after term2
term1 OPT term2: term1 is mandatory but term2
is optional. If term2 is also found the result is
ranked higher.
~term1: Contains all words that begin or end with
term1 (words containing term1 as a part of the
word; depends on the queried search engine)

The operators (often called Boolean operators) are
words or symbols that establish logical rules for the
terms in the search query. These are:

Note: See chapter Designing a Search Query
for examples on how to use all these operators
effectively.

To quickly select which plugin or search set
DEVONagent Pro uses, start the query with
the name of the plugin or search set or keyword
followed by a colon.
Example: google:devonthink
CASE
Terms are NOT case sensitive. You may use
capitalization for proper names in a query, but
DEVONagent Pro will ignore case in interpreting
the query.
PRECEDENCE OF TERMS
Search terms and associated operators will be
interpreted from left to right, except as modified by
including portions of the query within parentheses.
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For convenience, some of these operators can also
be abbreviated using commonly used symbols:
AND: &, &&, +
OR: |, ||
XOR: ^, ^^
NOT: !, Note: The symbols above also are used by the
Finder and Spotlight for searches. Enter the
vertical ruler character for the OR operator by
pressing ⇧7, ⇧\ or the appropriate keyboard
combination for your keyboard layout.
WILDCARDS
You can replace parts of words with wildcards
matching one, multiple, or a range of characters:
?: Matches exactly one character.
*: Matches none, one, or multiple characters.
[a-b]: Matches one character of the range 'a'
through 'b'.
[abc...] or [a|b|c|...]: Matches one character out of
the given list of characters.
[^...]: Matches one character that is not contained
in the given list or range.
Note: Primary queries only support wildcards for
sites, not for plugins or search engines.
SPECIAL RULES
To search for a word that is also the name of an
operator, put the word inside quotation marks. The
following example searches all four terms including
the word "near":
Example: Beach "near" Los Angeles
Existing "site:<domain.com>" operators in primary
queries are removed before matching to facilitate
searching sites using the Google, Bing, and Web
plugins or search sets using them.

DESIGNING A SEARCH QUERY
Writing your query as simply and as precisely as
possible is the key to good search results. Following
are some tips on how to write a good query.

DESIGNING A GOOD QUERY
Suppose you want to search for information about
the mercury contamination of fish, and to focus on
information released by or referring to the United
States Environmental Protection Agency.
One problem with trying a simple AND search
for a group of words is that the Environmental
Protection Agency is referred to in various ways:
Environmental Protection Agency, EPA and E.P.A.
If we tried the search string
Example: Environmental AND Protection AND
Agency AND EPA AND E.P.A. AND fish AND
mercury
we would probably get no results at all, as no
single article would use all three terms for the
environmental agency. And even if we were to get
search results, we would get irrelevant results
stemming from the terms environmental, protection
and agency.
Here's a better way to design the query:
Example: ("Environmental Protection Agency"
OR EPA OR "E.P.A.")
which will pick up the variants in naming the agency
in articles. Note that the two strings enclosed in
quotation marks will now be treated as phrases. This
reduces ambiguity. Also note the use of parentheses
and the OR operator. We have now covered all
three variants of common names used for the
environmental agency. DEVONagent Pro will look
for pages containing any one of those names.
Another potential ambiguity is created because
it's possible that a large reference source might
contain the word 'fish' in one section dealing with
fishery resources, and contain the word 'mercury'
in another section dealing with the history of
barometers. We're simply not interested in that
item. But if we use the NEAR operator between
'fish' and 'mercury' it's likely that we will get useful
results, since this query places the space between
the two terms at 10 words or less.
The refined query now becomes:
Example: ("Environmental Protection Agency"
OR EPA OR "E.P.A.") AND (fish NEAR mercury)
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Notice that a second set of parentheses was used
so that DEVONagent Pro doesn't wrongly interpret
the query as requiring that both the environmental
agency name and 'fish' must be NEAR 'mercury'.

Connecting 'steve' and 'jobs' with NEAR/2 prevents
getting result pages of some Steve looking for a job
in his page footer. BEFORE makes sure it is a page
that mentions Steve Jobs first, followed by the Intel

That confusion would be created if we wrote the
query as:

Macs. Finally, the quotes around 'San Francisco' find
only pages dealing with the city of San Francisco, not
the city San Jose or a Brother Francisco mentioned
elsewhere on the page.

Example: ("Environmental Protection Agency"
OR EPA OR "E.P.A." AND fish) NEAR mercury
Indeed, the refined search returned highly relevant
pages. Of course, this search focused on literature
about mercury contamination of fish in the United
States. To change the geographical focus, one would
simply replace the search strings in the first set of
parentheses with, e.g., ("European Union" OR EU).
IMPROVING YOUR QUERY
Besides the typical Boolean operators AND, OR
and NOT, DEVONagent Pro provides much more
powerful NEAR, BEFORE and AFTER operators.
Typically, only scientific high-end databases feature
these operators, but DEVONagent Pro makes them
available for Web research.
Note: Because almost none of the Web search
engines support these operators, DEVONagent
Pro sends the simpler AND query to them and
applies the more sophisticated operators to the
resulting pages.
All three operators connect two search terms closer
together than AND, but not as tightly as the phrase
operator (double quotes). With the additional
distance parameter (e.g., NEAR/5) you can fine tune
search results until you get only the results you are
looking for.
Example: (steve NEAR/2 jobs) BEFORE (intel
NEAR (imac OR macbook)) AND "San Francisco"

Use the proprietary NEAR, BEFORE and AFTER
operators when AND delivers too many results and
quote marks delivers too few. Another example:
Example: document AND management AND mac
This query run with the Web (Fast) search set
deliveres good results. But, many are not what we
are looking for. Among good pages, it also presents
the Wikipedia article about OS X because it contains
all three words. But, of course, this article is not at
all about document management on the Mac. We
can refine this query, however, using the special
DEVONagent Pro operators:
Example: document NEAR/2 management NEAR
mac
This time, DEVONagent Pro returns fewer results,
all of them dealing exactly with our search subject,
document management for the Macintosh, because
the three words must appear near each other in the
text. In most cases, NEAR delivers more accurate
results than AND.
FIRST PRINCIPLE OF A SUCCESSFUL QUERY
Make the query precise and unambiguous.
DEVONagent Pro's tools for clarifying your query
are clear and simple and will help you obtain a high
percentage of useful results.
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SEARCH SETS
In this chapter:
What are search sets?
Choosing a search set

20
20

Creating and managing sets
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General tab
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Sites tab
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Exclude tab
Plugins tab
Actions tab
Schedule tab

25
25
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27

The quality of a query relies not only on the entered
search term, it also relies heavily on the selected
settings. Search sets are collections of all the
parameters (settings) related to a search run.
Use search sets to quickly tweak your settings,
depending on what you are searching for on the
Internet. This ensures that you always get the best
results.

WHAT ARE SEARCH SETS?
Search sets basically are collections of all the
parameters related to a search run:
A default query
Follow links settings
Filters and associated scanners
Sites to scan or search
Pluginsto use

Actions to run when the search run is completed
A schedule
Using these settings, you can create search sets
specifically tailored for your research needs. For
example, you could create your own sets for:
Querying the U.S. Patent Office and WIPO
databases, along with scanning some important
websites related to patents
Looking for articles related to
DEVONtechnologies on Google, as well as some
Mac news sites, with the search scheduled every
three hours and programmed to send a summary
to your email address
Searching the most important medical databases,
e.g., PubMed, Medscape and FDA, in a single
search run
Querying a number of general search engines
like Google, MSN and Yahoo, but filtering out
everything except pages with links to Office
documents

CHOOSING A SEARCH SET
Choosing the search set that you want to use for a
search run is easy: Click the magnifying glass icon
in a DEVONagent Pro search field and choose a
search set from the pop-up menu.
DEVONagent Pro comes with a number of
predefined search sets, but you can easily create
your own.
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CREATING AND MANAGING SETS

Search sets can be edited, rearranged, exported,
imported or deleted. DEVONagent Pro comes with
a couple of useful predefined sets, which you can
tweak to your needs. Or you can add new ones. Use
Window > Search Sets to open the search set editor.
Note: Some of the settings can also be adjusted
on-the-fly in the Settings and Advanced tabs.

SHORTCUT
To create a new search set with exactly the same
settings as the current search run, click the + button
next to the Stop button in the search window. This
creates a new search set with exactly the same
settings including the query as the default query.

The search set editor shows a list of all defined

ACTION MENU

search sets and allows you to add new sets or delete
the selected set using the + and - buttons, just
like other Mac applications, e.g., iTunes or iPhoto.
Rearrange your search sets using drag-and-drop,
and single-click the name of any set to change its
name.

The Action menu, available from the gear button
below the search set list, gives you access to
additional commands. See also p. 21ff

Note: Some items can be dragged from one
search set to another set, e.g., URLs from the sites
tab.

CONTEXTUAL MENU
The contextual menu gives you direct access to
frequently used commands.

To change the settings defined in a set, select it in
the list and change the parameters in the right-hand
pane. Switch between the areas, General, Advanced,
Sites, Plugins, Actions, and Schedule by using the tabs
above the parameter area.
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New: Creates a new, empty search set.
Duplicate: Duplicates the selected search set.
Delete: Deletes the selected search set. Attention:
There is NO undo!
Import: Creates new search sets based on
imported files. You can import previously
exported sets, as well as OPML files, Camino,
Firefox, Chrome, OmniWebor Safari bookmarks
or the Safari history file. For OPML, bookmarks
and history files, DEVONagent Pro creates a new
search set with all URLs imported to the Sites list.
Export: Exports the selected search sets as
separate files. Exported sets get the file name
extension '.agentSet' and are XML/plist files.
You can import them into DEVONagent Pro by
double-clicking them in the Finder.

SHARING SETS
You can easily share search sets with other
DEVONagent Pro users. Export sets using either
the contextual menu, the File > Sets menu command,
or by simply dragging them e.g. to the Desktop. You
can email exported sets and import them again into
DEVONagent Pro simply by double-clicking them in
the Finder.

GENERAL TAB
On the General tab, you define the main parameters
for this search set such as the default query, which
filter and which scanner to use.

QUERIES
Default Query: Define a default query for this
search set. DEVONagent Pro will automatically fill
the query field with the default query when you
select this search set. This is especially useful if you
are using either the same query every time you use
this search set or if you are running this set on a
schedule.
Example: esa AND (mission NEAR "venus
express")
Read more about formulating a query here: See also
p. 17ff
Secondary Query: When you enter something here,
the primary term (the one entered or the default
query) is only used for querying the search engines,
not for accepting or rejecting pages. Without
a secondary query, DEVONagent Pro uses the
primary query for both querying search engines and
post-filtering results.
You can use secondary queries for different terms
for querying the search engines and accepting/
rejecting pages. Although the primary query is
restricted to 10 words, the secondary query is not
restricted.
Example: Use the asterisk '*' as your default
query to match everything, e.g, when scanning
a list of websites or RSS feeds; this option is
not applicable with search engine plugins, only
with the Sites list. To accept all pages delivered
by a primary query, use the asterisk '*' as the
secondary query.
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FOLLOW LINKS
These options tell DEVONagent Pro to follow
promising links on HTML pages and in news feeds.
Links are considered 'promising' if they match the
entered or default query. If you enter an additional
query into the text field below the pop-up menu
instead, this query is used to indentify promising
links.
Example: The query 'Devonian Period -County'
follows links containing 'Devonian' or 'Period' but
not containing 'County'.
In the pop-up menu choose which links you want
DEVONagent Pro to follow:
Off: Follows no links.
All: Follows all promising links.
On Same Host: Follows all promising links leading
to the same server (domain).
In Same Directory: Follows all promising links
leading to pages in the same directory.
In Subdirectories: Follows all promising links
leading to pages in the same directory or its subdirectories.
On the right-hand side of the pop-up menu select
how many levels deep you want DEVONagent Pro
to follow links. One or two levels generally make
sense, more is often overkill.
Use the text field below the slider to provide an
additional search query that defines which links
DEVONagent Pro follows. Use this option to fine
tune your settings if you find that DEVONagent Pro
follows meanlingless links due to the construction
of the result pages. Generally, you should leave
this field blank and let DEVONagent Pro follow all
links matching the entered or default query; the
automatically chosen term is displayed in this case.
Example: Enter '*' to let DEVONagent Pro follow
all links, regardless whether or not their text
description matches the query.
EXPRESS SEARCH
Check Express Search to enable 'express' mode. In
'express' mode DEVONagent Pro returns results
fast, but does not filter the results. If unchecked,

DEVONagent Pro operates in 'agent' mode, which
is slower but returns post-filtered results and is a
more precise and powerful tool.
Note: Scanners and secondary search terms, the
similar pages filter, and following links require
'agent' mode. Some plugins may also require
'agent' mode; others may not support 'express'
mode.
LANGUAGE
Language: Use this pop-up menu to filter out all
pages that do not match the selected language
(Dutch, German, English,...) or script system (Arabic,
Greek, Hebrew,...) Instead of simply looking for
language tags, this filter actually analyzes the page
itself.
Ignore Diacritics: Check this option to
automatically convert diacritics for analysis into a
normalized form. This also finds pages that contain
German umlauts, French or Czech accents, or other
diacritical characters.
Example: Uncheck Ignore Diacritics to search
for a word with accented characters when you
definitely don't want to find the unaccented
variant.
Fuzzy: Check to search 'fuzzy'. This also finds words
with similar but not identical spelling, e.g., 'gray'
instead of 'grey'.
FILTERS, SCANNERS,...
Filters: Check the following filters to automatically
filter out special pages you don't want to include in
the results list:
Similar Pages: Filters out pages similar to results
previously found in the search run.
Archived Pages: Filters out all pages already
stored in the archive. DEVONagent Pro
compares only the URLs in this case, not the
actual page content.
Scanner: Scanner plugins post process and filter
the list of found pages by formal criteria. Read more
about scanners in the appendix.
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Example: Use this powerful feature unique to
DEVONagent Pro to filter, for example, all pages
except those containing a thumbnail gallery,
linking to Office documents, or containing email

HTML & XHTML pages
Atom, RSS, RSD & RDF feeds
Plain text documents
PDF & PostScript documents

addresses.

OpenOffice & StarOffice documents
Rich text documents
Microsoft Word documents

COMMENTS
Enter a brief description for a search set here. This
description is shown in the tooltips of the magnifier
pop-up menu in a search window.

ADVANCED TAB
On the Advanced tab, you define in which parts of
webpages DEVONagent Pro searches, which type of
files it searches, and whether it accepts all pages or
only new results.

RESULTS
Choose if you want DEVONagent Pro to accept
results only from new pages or from all found pages.
All pages: Always accept all matching pages.
Only new pages: Accept only new matching pages.
DEVONagent Pro keeps an internal log of found
results to recognize which are new. It also lists the
number of results stored in the log. To clear the
internal log, click the Reset button.

SITES TAB

SEARCH IN
Choose which parts of a document DEVONagent
Pro searches for the query. Not all file types have all
characteristics.

The Sites tab allows you to define a list of webpages
that DEVONagent Pro scans (crawls) or searches
when you use this search set. DEVONagent Pro
downloads each of these pages and tests whether
it matches your query, just like a private little
Google. Alternatively it runs a site search on it using
common search engines. Use it together with the
default query to scan your frequently visited pages
for important keywords.

Title
Text
URL
Keywords
Description
Objects
FILES
Choose which file types DEVONagent Pro searches
and accepts as results.

MANAGING THE SITES LIST
To add a page to the list, enter the URL into the
location field at the bottom of the window. If the
page requires a user name and password, enter
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them into the appropriate fields. Click the + button
to add the page. To remove a page, select it in the list
and click the - button.
You can also use drag-and-drop or copy/paste to add
URLs to the sites list, and use the contextual menu
to open the page in a browser window or copy the
URL. This also adds the title of the page to the Info
column when possible. You can copy URLs in this list
to the clipboard or drag them to other applications,
too.
You can use ranges like [01-31] or [1-31] to
quickly add whole ranges of URLs. Add "http://
www.classicfm.nl/playlist/per-dag/201202[01-29]"
to add all playlist from .../20120201
through .../20120229.
Uncheck a page to exclude it temporarily from being
scanned; check the page to include it in the next
search run.

Open: Opens the selected sites in separate web
browser windows.
Open In Tabs: Opens the selected sites in separate
tabs in a new web browser window.
Launch URL: Opens the website in your default
web browser.
Enable/Disable: Checks or unchecks an item.
Unchecked (disabled) websites are not scanned
when using this search set.
Copy: Copy the URL of the selected website to the
clipboard.
Paste: Pastes a URL from the clipboard to the list,
effectively creating a new item.
Delete: Deletes a selected item.

EXCLUDE TAB
The Exclude tab allows you to explicitly exclude
domains and links from being used or followed when
you use this search set.

CRAWL VS. SEARCH MODE
DEVONagent Pro can either crawl (scan) or search
sites added to the list. You can set this option
individually for each site.
Crawl: Downloads the page and adds it to results
when it matches the query.
Search: Searches the site using common search
engines. The found results are downloaded and
added to the results when they match the query.
Depending on your settings, promising links are
followed.
TAKING OVER URLS
To take over bookmarks from other applications
and create new search sets from them, use dragand-drop or copy/paste, or import bookmarks or
OPML files. Open the settings editor and use File
> Import or the Action menu to import bookmarks
from Camino, Firefox, OmniWeb or Safari, as
well as OPML files generated by news readers or
DEVONthink.

Add the domains or links that you want to be
excluded from search into the Domains and Links
text fields. You can use asterisk (*) wildcards to
include e.g. all subdomains or partial links.

PLUGINS TAB
The Plugins tab defines which plugins (interfaces to
search engines) DEVONagent Pro uses when you
use this search set in the search window.

CONTEXTUAL MENU
The contextual menu allows you to work with
website addresses selected in the sites list.
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PLUGIN LIST
Plugins are grouped. Expand or collapse groups by
clicking the grey triangle in front of the group name,
like in the Finder. Check all plugins that you want
DEVONagent Pro to use for this search set; uncheck
all others. Check or uncheck a group to check or
uncheck plugins contained within the group. Select a
plugin to display a short description.
To find out which search engines a plugin uses to get
results, use Window > Plugins & Scanners or see the
appendix.
Example: Check "Images", "Info (Pictures)" and
"Picsearch (Images)" to search all major picture
search engines.
RESULTS PER PLUGIN
This value defines the number of results delivered
by every plugin. It limits the results pool to the most
relevant <n> results. Adjust this to whatever suits
your requirements; the default value is 100.

ACTIONS TAB
The Actions tab lets you attach additional actions to
a search set that DEVONagent Pro executes after
finishing a search run using this search set.

INTERFACE
Bounce Dock icon: Bounces DEVONagent
Pro's Dock icon once when the search run is
completed.
Zoom and bring to front: Zooms the search
window and makes it the frontmost window.
Use Notifications: Posts a notification on OS X
10.8 "Mountain Lion" or later.
Play sound: Plays a sound. Select the sound to be
played from the pop-up menu; all systemwide
alarm sounds are available.
Speak text: Speaks entered text. Use the escape
sequence "%d" in the text to announce the
number of found items.
RESULTS
Archive results: Adds all found pages to the
internal archive.
Add results to DEVONthink: Adds all found pages
to the currently opened DEVONthink database.
Choose the desired format and destination from
the popup menus below this option.
Send mail to: Sends a summary of the found
information to an entered email address. This is
especially useful when used with a schedule.
Execute script: Executes an AppleScript. Use
this to do whatever you like with the found
information, e.g., feed it into a local workflow or
post automatically to a website.
Note: The email function uses the email account
defined in Preferences, Email tab.
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SCHEDULE TAB
The Schedule tab is what makes DEVONagent Pro
a bona fide information agent. It lets you schedule
automatic query runs hourly, daily or weekly, and
return the results by email, archive them internally,
or add them to your DEVONthink database.

FREQUENCY, ...
Frequency: Define if you want DEVONagent Pro
to run the search set hourly, daily, or weekly, or
select Never to switch the scheduler off.
Time of Day: Define at which time of the day
DEVONagent Pro runs the search set.
Day of Week: Define on which day of the week
DEVONagent Pro runs the search set.
OPTIONS

Note: A scheduled search set uses the default
query you enter on the "General" tab and runs
this query at the scheduled time. Make sure to
enter a default query when you use the scheduler.

Quit when done: Quits DEVONagent Pro after the
search run is completed.
Close window: Closes the search window when
the search run is completed.
Ignore cache: Ignores the cache and always load
all pages from the Internet. Uncheck to use
DEVONagent Pro's cache and to reduce network
traffic.
Next run: Checks when this search set will run
next (informative only).
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MENUS
In this chapter:
The DEVONagent Pro menu
The File menu

28
29

The Edit menu
The Data menu
The Sort menu
The View menu
The Web menu

30
31
32
32
33

The History menu
The Go menu
The Window menu
The Services menu
The Scripts menu
The Help menu
The Dock menu

34
35
35
36
36
36
37

A complete listing of all commands DEVONagent
Pro offers in the menu bar, the global Services menu,
and the handy Dock menu.

THE DEVONAGENT PRO MENU
The DEVONagent Pro menu is similar to the
application menu in any Mac application. It contains
commands for displaying the splash screen, opening
the preferences window,accessing the Services
menu, hiding and showing windows, and, of course,
quitting the application.
ABOUT DEVONAGENT PRO, ...
About DEVONagent Pro: Shows information
about DEVONagent Pro including the version
number and licensing information.
Check for Updates: Checks if updates for
DEVONagent Pro are available. By default,
DEVONagent Pro checks for updates
automatically; change your update settings in the
Preferences, Update pane.

Note: No information from your computer is
uploaded to the DEVONtechnologies server
during the check for updates. DEVONagent Pro
only downloads a file listing the most current
versions to your Mac.
PREFERENCES, ...
Preferences: Opens the Preferences.
Private Browsing: Select this command to check
or uncheck the private browsing mode. If this
menu item is checked, DEVONagent Pro clears
all caches, history files, and the find pasteboard
after quitting, so that anyone using this user
account on this computer cannot later discover
your search history. This option also prevents
DEVONagent Pro from storing previous search
terms in the Recent Searches sub-menu of
the magnifying glass pop-up menu of search
windows.
Empty Cache: Empties the disk cache that is used
to speed up browsing. Use this if you are running
out of disk space or when you feel that pages or
elements are not up-to-date. Emptying the cache
effectively forces DEVONagent Pro to download
from the Internet all files in their most recent
versions.
PURCHASE, ...
Purchase: Opens the DEVONtechnologies Online
Shop and places DEVONagent Pro into your
shopping cart. If this copy of DEVONagent Pro
is already licensed, you will be presented with
the choice of buying an upgrade for your existing
license or buying another full license.
Enter License: Use this command to enter your
licence code. Make sure you enter ALL the
details EXACTLY as they appear in the licence
code email. It is best to use copy-and-paste for
transferring name, organization, and licence code
from the email message to the appropriate fields.
Make sure not to highlight any spaces before or
after the required information.
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Note: Enter License changes into License as soon as
you enter a valid license code.
SERVICES
The Services sub-menu gives you access to
special commands published by other Mac
applications such as TextEdit or Safari, or by
services extensions such as our own WordService
or CalcService. Also, DEVONagent Pro publishes
its own services. See also p. 36ff

THE FILE MENU
The "File" menu contains all commands that create
new windows, open or save files or settings, and
print.
NEW SEARCH, ...
New Search: Opens a new search window. You use
search windows to send queries to a predefined
search set or a selected plugin, that then queries
one or multiple search engines and presents the
weighted results. Search windows are what give
DEVONagent Pro its name and purpose.
New Plugin: Opens the Plugins & Scanners window
and lets you create a new custom plugin. Use this
function to easily create a plugin for your favorite
yet-to-be search engine.
NEW BROWSER, ...
New Browser: Opens a new web browser
window.Use this function to use DEVONagent
Pro as a standard web browser that is optimized
for research. The web browser is based on the
same WebKit engine used by Safari.
New Tab: Creates a new tab in the frontmost
web browser window.If the frontmost window
is a search window rather than a web browser
window, this command opens a new web browser
window instead.
Open Location: Brings the address field of the
frontmost web browser window into focus. If no
web browser window is open, DEVONagent Pro
opens a new one, equal to File > New Browser.

OPEN FILE, ...
Open File: Opens a local file for viewing in a
new web browser window or in a previsouly
saved search. Alternatively, drag the file onto
DEVONagent Pro's icon in the Dock.
Open Recent: Lists the recently used saved
searches so that you can quickly open them.
SAVE AS, ...
Save, Save As: Saves the content of the frontmost
web browser window in its original format or
a search run for future reference. Webpages
are saved as pure HTML code or webarchives
(see below), images, movies, and PDFs in their
respective formats. Search runs are saved as
'.agentSearch' files that can be double-clicked in
the Finder or opened via File & Open. They include
the term, the used set or plugin, the settings, the
results and their sortings, the digest, the log, and
a Quick Look preview.
IMPORT
Sets: Imports saved search setsand adds them
to the list of available search sets. You also can
import saved search sets by double-clicking
them in the Finder or by dragging them to
DEVONagent Pro's Dock icon.
OPML: Imports all URLs contained in an OPML file
and creates a new search setwith the URLs in the
Sites tab. Use this to import RSS feeds exported
as OPML from a news reader.
<Application> Bookmarks: Imports Camino,
Firefox, Chrome, OmniWeb, or Safari bookmarks
and creates a new search set with all imported
URLs in the Sites tab. Both site and news feed
bookmarks are supported. If a web browser
window is frontmost, the bookmarks will be
added to DEVONagent Pro's own bookmark list.
Safari History: Imports the Safari history file and
creates a new search setwith all imported URLs in
the Sites tab.
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EXPORT

CUT, COPY, PASTE

Digest: Exports the digest as plain or rich text file.
This command can also export the topics map as a
PDF document or OPML for outliners and mind-

Cut: Cuts the selected items or text passages.
Copy: Copies the selected items or text passages
to the clipboard.

mapping applications.
Report: Exports a search report as PDF, CSV
(comma-separated values), HTML, or OPML
file. Use the CSV or OPML formats to export all

Copy URL: Copies the URL of the selected page or
frontmost web browser window to the Clipboard.
Paste: Pastes whatever is on the Clipboard.
Clear: Deletes the selected item or piece of text.

results in a structured way in order to re-import
them into other applications such as Microsoft
Excel or Apple Numbers.
Results: Exports selected search results in their
original formats, or as bookmarks, plain text files
or rich text files.
Sets: Exports one or more selected search sets
and saves them as files. These files can be reimported using File > Import > Sets or by doubleclicking them in the Finder. Use exported sets to
shared them with other DEVONagent Pro users
or between computers.

Complete: Auto-completes a word in text and
search fields as well as in text views. This OS X
standard function relies on the dictionary you
have selected in the spellchecker (see below).
Select all: Selects all contents of the frontmost
window.
Deselect all: Deselects all contents of the
frontmost window. Hold the ⌥Option key to

PAGE SETUP, PRINT
Page Setup: Opens the standard page setup dialog.
Print: Prints the contents of the frontmost
window.

THE EDIT MENU
The "Edit" menu contains all commands and options
related to editing. You'll find the classic Mac cut/
copy/paste and find/replace commands here, as well
as many more.

show this menu item.
FIND
This sub-menu contains commands for finding
and replacing text. In most ways it is similar to the
Find command in most Mac application, but it also
contains DEVONagent Pro-specific items.
In Internet: Opens a new search window.
In Results:
Find...: Opens the standard find panel.
Find Next/Previous: Jumps to the next or previous
occurrence of the find term.
Use Selection for Find: Copies the selected piece
of text to the find clipboard or into the search
field of the find panel if it is open.
Scroll To Selection: Scrolls the displayed
documents to the current selection.

UNDO, REDO
Undo: Takes your changes back one step. Undo
mainly works for text edits, but will not bring
back deleted documents.
Redo: Redo re-does the last undone edit.

SPELLING, ...
Spelling and Grammar: The spell and grammar
checker. Useful for checking text, e.g., when filling
out form fields.
Speech: Speaks a selected piece of text.
Special Characters...: Shows the standard special
characters panel for inserting characters that you
cannot enter directly with your keyboard, such as
accented or umlauted characters.
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THE DATA MENU
The Data menu provides commands for opening
search results, exporting them to DEVONthink,
archiving them, or organzing them in the built-in
archive.
NEW GROUP, ...
New Group: Creates a new group in the archive. To
create a sub-group, select an archive group first,
then use this command.
Open: Opens the selected search results in new
web browser windows. Same as double-clicking
the results.
Open In Tabs: Opens the selected search results in
separate tabs in a new web browser window.
Launch URL: Opens selected search results in your
default web browser. If DEVONagent Pro is your
default browser, this command is equal to "Data >
Open..."

ADD TO DEVONTHINK, ...
via Clip to DEVONthink:
Resource: Adds the selected page or document asis to DEVONthink.
Bookmark: Saves links to the selected pages as
bookmarks.
Rich Text: Saves selected text as a new text
document.
Summary: Saves the whole digest as text
document. Available on the Digest and Results
tabs of Search windows as well as in the archive.
Formatted Note: Saves the selected page as new
formatted note.
Markdown: Saves the selected page as new
Markdown document.
PDF (one page): Saves the selected pages as PDFs
without page breaks. A long webpage will be
saved as one, very long page, making this function
ideal for archiving. Only available in the web
browser.
PDF (paginated): Saves the selected pages as
PDFs with page breaks. Use this for archiving
webpages that you may want to print later.
Web Archive: Saves webpages as webarchives.
Webarchives are self-contained files that include
one webpage that includes all additional files
necessary for displaying, e.g., embedded images
or movies. Only available in the web browser.
DEVONagent Pro adds 'DEVONagent Pro plus
the name of the plugin used to find the page
and its version to the comments when adding to
DEVONthink.
Note: These items are only available when
DEVONthink is installed on your Mac.
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ADD TO SET, ...

Unsorted, By Name, ...:

Add To Set: Adds selected pages, e.g., search
results, to the "Sites" listof a search setyou select
from the sub-menu. These pages will be scanned

Unsorted: List results in their natural order. Useful
after opening a saved search to easily view new
results.

for an entered query the next time you use this
search set and can be useful to include in future
searches. Select "New Set..." from the sub-menu
to create a new search with the selected pages.

Name: List results sorted by name.
Date: List results sorted by date.
Size: List results sorted by size.
URL: List results sorted by URLs.

Add To Archive: Adds the selected results to the
archive,creating a new group for current search
run. If a group for this search run already exists,
any subsequently added page from same search
run will be added to this archive group.
Add All To Archive: Appears insteat of Add
To Archive when you hold the ⌥Option key

Top Level Domain: List results sorted by their top
level domain.
Relevance: List results sorted by relevance.
Number of Objects: List results sorted by the
number of found objects.

down. Adds all results of a search run to the
archive,creating a new group for them. Use this
command to archive all results of a search run
with one click.
MARK ALL READ, ...
Mark All Read: Marks the selected results as read
or unread.
Delete: Deletes search results from a results list in
a search window,as well as groups or items from
the archive.
Delete Domain: Deletes all results from the
selected domains from the current results list.
Delete & Exclude Domain: Deletes the selected
search results from a results list in a search
window and adds the domains of the pages to
the list of excluded domains. All other search
results matching the exluded domains are
removed. Use this function to quickly exclude an
unwanted domain without having to block it via
the Preferences. Alternative menu item to Delete
Domains.
Clear Log: Clears the Log tab of the frontmost
Search window.

Top Level Domain means the last part of a website
address. Usually it is defined by the country the
website is located in, e.g., '.de' for Germany or '.cz'
for the Czech Republic, or by function, such as '.com'
for a world-wide commercial site or '.mil' for a US
military site.
Relevance is the relevance of a result compared to all
collected results in respect to the query. This is the
default sorting order.
Ascending, Descending:
Ascending: Sorts items ascending.
Descending: Sorts items descending.

THE VIEW MENU
The View menu allows you to switch between the
various tabs of a Search window, to switch Cover
Flow on and off, and to customize how objects are
presented in web browser windows.

Note: Use Delete and Delete & Exclude Domain
with care. You cannot undo these commands.

THE SORT MENU
The Sort menu sorts search results in a variety of
ways.
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DIGEST, ...

COVER FLOW, ...

Digest: Switches to the "Digest" tab. The digest
shows a summary of the found information (not
the pages), sorted by relevance. In addition, it

Cover Flow: Switches between the regular display
of results or tabs and Cover Flow. Cover Flow
lets you browse graphically and quickly through

visualizes topics in a topics map that lets you
navigate the results graphically. Use the digest
and the topics map to work with the information
itself instead of manually visiting webpages.

results or the pages opened in multiple browser
tabs.
Inverse Appearance: Inverts the colors of the
results list in search and browser windows to

Results: Switches to the "Pages" tab. The "Pages"
tab lists all found pages, sorted by relevance (or
any sorting order you choose in the "Sort"menu).
A preview pane displays the relevant text parts of
a selected result.
Log: Switches to the "Log" tab. The log lists all
webpages that DEVONagent Pro has filtered out
as being irrelevant to the query or outdated. View
a selected page in the preview page. Use the log
to see how many pages you DON'T have to look
at because you're using DEVONagent Pro instead
of Google or other search engines.
Settings:
Advanced:

match it with Cover Flow. Uncheck to return to
the regular black-on-white appearance.
Show Icon Preview: Shows or hides the icon
previews in Results tab of search windows, Sidebar
drawer and See Also tab the Inspectors pane of
web browser windows and the archive.
Use Small Icons: When checked, objects are
shown with small icons and more information
in the sidebar of web browser windows. When
unchecked, objects are shown with large icons
and no details.

SUMMARY, OBJECTS
Summary: Selects the Summary tab of the Pages
tab of Search windows.
Objects: Selects the Objects tab of the Pages tab of
Search windows.

SHOW TOOLBAR, ...
Hide/Show Toolbar: Hides or shows the toolbar of
the frontmost window.
Customize Toolbar: Lets you configure the toolbar
of the frontmost window.
Enter/Exit Full Screen: Puts the frontmost window
into full screen or back into windowed mode.
Press Escape to return to windowed mode.

THE WEB MENU
The Web menu contains all commands that are
directly related to web browsing, from quickly
turning Java on or off to switching between views
and reloading a webpage. All commands in this
menu act on the frontmost web browser window.
ENABLE PLUGINS, ...
Plugins: Enables or disables plugins.
Java: Enables or disables Java.
JavaScript: Enables or disables JavaScript.
Use these options to quickly switch plugins, Java,
or JavaScript on and off without visiting the
Preferences.
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STOP LOADING, ...

SIDEBAR

Stop Loading: Stops loading a the webpage. This
is equal to clicking the reload/stop button on the
address bar of a web browser window when a

Show: Shows or hides the sidebar.
Bookmarks: Switches to the bookmarks pane of
the sidebar.

page is loading.
Reload Page: Reloads the webpage. This is equal
to clicking the reload/stop button on the address
bar of a web browser window when a page is

Results: Switches to the results pane of the
sidebar.

completely loaded.
Actual Size: Zooms the page to its actual size.
Zoom In: Zooms in.
Zoom Out: Zooms out.
Zoom Text Only: When this option is checked,
only the text of the page is made larger and
smaller. When unchecked, DEVONagent Pro uses
Safari-4-style zooming.
Translate: Translates the displayed page using the
Google language tools to your system's preferred
language. This command is unavailable if the
recognized language of the displayed page is the
same as the preferred language of your system.
Text Encoding: Changes the text encoding
used for displaying a webpage. Use this submenu to manually adjust the text encoding if
DEVONagent Pro displays accented characters,
umlauts or East Asian characters incorrectly.
Generally, websites publish their encoding
and DEVONagent Pro reads this metadata for
adjusting the encoding automatically.
VIEW, ...
Source Code: Shows the source code of the
webpage.
Text: Shows only the pure text of the webpage.
Layout: Shows the webpage rendered (normal).
These three options switch the mode of the
frontmost web browser window between different
modes. Use these modes to view only the raw text
of a layout-intensive webpage, or to switch to the
source code to find information that is hidden in the
code but not visible in the layout. DEVONagent Pro
displays the source code with syntax coloring. The
text only mode is also useful for copying/extracting
information from pages with a complex table layout.

INSPECTORS
Show: Shows or hides the Inspectors tab of the
frontmost web browser window.
Properties: Switches to the properties tab.
Objects: Switches to the objects tab.
See Also: Switches to the See also tab.
ADDRESS BAR
Address Bar: Shows or hides the address bar.
Hiding the address bar gives you more useable
screen space for the displayed webpage.

THE HISTORY MENU
As with any web browser, the History menu lists all
webpages previously visited, divided into subfolders
for each day, and marked with the date and time you
last viewed them.
BACK, FORWARD, CLEAR HISTORY
Back, Forward: Moves back and forth between the
visited pages. These commands are equal to the
back and forward buttons in the address bar of
web browser windows. Since there is no history
when private browsing is active, these commands
are not available when private browsing is
switched on.
Clear History: Clears the history.
VISITED WEBPAGES
The rest of the History menu lists the previously
visited webpages, sorted from the top by age.
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THE GO MENU
The Go menu contains commands for navigating
back and forth through a results list in a search
window or occurrences of a search word, as well as
for using and managing bookmarks.
NEXT/PREVIOUS RESULT/OCCURRENCE
Next/Previous Result: Navigates back and forth
through the results lists to which the displayed
webpage belongs. Use these commands to go
through the pages resulting from a search run.
Next/Previous Occurrence: Jumps to the next or
previous occurrence of the search term, e.g., in
the digest or pages tabs of search windows.

WORKSPACES
Workspaces save the content and positions of all
open windows so that you can restore them later.
This is ideal if you are working with the same set of
windows over and over again. Save the windows as a
workspace and recall them whenever needed.
Add: Saves the currently open windows as a
workspace.
Edit: Opens a window that allows you to edit
saved workspaces. Click on a workspace name
to change it, reorder it by dragging, and delete it
with the . button.
Update: Updates an existing workspace to the
currently open windows.
Workspaces: Restores to a previously saved
workspace.

BOOKMARKS
Besides the commands mentioned above, the Go
menu gives you access to the bookmarks of Safari,
Camino, Firefox, or OmniWeb, or DEVONagent
Pro's own bookmarks list. Select which bookmarks
DEVONagent Pro shows in the Go menu in the
preferences.
Add: Adds a bookmark for the currently shown
webpage.
Add Folder: Adds an empty folder to the
bookmarks list.
Edit: Opens an edit sheet for the currently
selected bookmark. This function is unavailable
when two or more bookmarks are selected.
Delete: Deletes the selected bookmarks.
<Bookmarks>: Opens any selected bookmark; use
Open in Tabs in any bookmark folder to open all
bookmarks in the folder in separate tabs.
For these commands to work, a web browser
window needs to be active and DEVONagent Pro
use its own bookmarks. You cannot yet edit Safari's
bookmarks from within DEVONagent Pro.

THE WINDOW MENU
As with any Mac application, the Window menu lists
all open windows of DEVONagent Pro and gives you
access to commands for managing them.
Window Commands:
Close/Zoom/Minimize: These three commands
resemble the red, yellow and green buttons of
any window title bar and consequently close the
window, maximize it or create an icon on the
dock. No magic here.
Bring All to Front: Brings all windows of
DEVONagent Pro to the front.
<Window name>: Brings a selected window to the
front.
Tab Commands:
Close Tab: Closes the current tab of the frontmost
web browser window.
Select Next/Previous Tab: Switches to the next
or previous tab of the frontmost web browser
window.

BONJOUR
The Bonjour part of the Go menu lists web services
advertised on the local network via Bonjour, e.g.,
printers with web interfaces or shared DEVONthink
Pro Office databases.
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Archive ... Downloads:

Services provided by DEVONagent Pro:

Archive: Opens the Archive window.
Search Sets: Opens the Search Sets panel, which
allows you to edit the available search sets.

Lookup: Opens a new search window in
DEVONagent Pro with the query field pre-filled
with the selected text. Use this command to

Plugins & Scanners: Opens the Plugins & Scanners
panel that lists all installed plugins and scanner
modules. Use this panel to see which plugins
or scanner modules are available, get more

quickly search for a selected piece of text.
Open URL: Opens a selected piece of text as a URL
in DEVONagent Pro. Use this to quickly select
a URL, e.g., in an email message, and open it in a

information about them, and activate and
deactivate them.
Downloads: This command opens the Downloads
panel. Use it to download files from the Internet
to your computer.

DEVONagent Pro web browser window.

THE SERVICES MENU
The Application > Services menu (where 'Application'
is the name of the frontmost application) allows
access to special commands published by other
applications, such as TextEdit or Safari, or by
services extensions such as DEVONtechnologies'
WordService or CalcService. Also, DEVONagent
Pro publishes its own services in the Services menu.

Use Application > Services > Services Preferences
to change keyboard shortcuts or hide selected
commands to clean up the Services menu.
Note: After installing DEVONagent Pro you
may need to log out and back in again for the
Finder to recognize the new Services menu
commands and shortcuts. If one or more
DEVONagent Pro Services menu commands
does not have a keyboard shortcut assigned to
them, perhaps another application grabbed it.
OS X automatically assigns the correct shortcut
when no other application asks for the same key
combination.

THE SCRIPTS MENU
The Scripts menu is located left of the Help menu and
shows a graphic AppleScript 'S' symbol instead of a
normal menu title. It contains a collection of useful
predefined AppleScripts you can use directly from
within DEVONagent Pro.

The Services menu is a sub-menu of every
application's application menu, the menu named
after the application itself and carrying the About X,
Hide ... and Quit commands. Services usually act on a
selection, e.g., selected text or files.

Some of the scripts work without a selected
document; others require you to select the
document you want the script to interact with. In
general, the script will tell you what you have to do
when you select it from the Scripts menu.
See also p. 66ff

THE HELP MENU
The Help menu contains commands for opening the
integrated help pages or the support assistant, or
for visiting the DEVONtechnologies website.
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DEVONAGENT PRO HELP
These commands open the integrated help pages
that are equal to the document you reading or open
the release notes.
SUPPORT ASSISTANT, TUTORIALS
Opens the support area of the Welcome to
DEVONagent Pro assistant where you can, for
example, read the FAQ, visit the user forum,
download this documentation as printable or
screen-readable PDFs, retrieve your license code,
request a trial extension, or update your details in
DEVONtechnologies' customer database. Choose
Tutorials to open the assistant on the Tips & Tutorials
page.
Click here to open the assistant.
Note: If you purchased DEVONagent Pro from
the Mac App Store, not all options dealing with
licenses or upgrades are available.
DEVONTECHNOLOGIES
Visit the DEVONtechnologies website and ask
questions or meet your fellow users in the lively
user forum. Contact the DEVONtechnologies team
and provide feedback directly to the development
team.
You can also send a bug report including the most
recent crash logs. This is an alternative menu item to
Contact us.

THE DOCK MENU
The Dock menu appears when you ⌃-click or
right-click DEVONagent Pro's icon in the Dock. In
addition, DEVONagent Pro's icon shows a badge
with the number of found results.

For all Mac applications, the Dock menu provides a
selection of the commands of the application menu.
<Window Name>: Brings any open window of
DEVONagent Pro to the front.
Options > ...: Keeps DEVONagent Pro in the Dock
or removes it, adds DEVONagent Pro to your
login items, or reveals the DEVONagent Pro
application package in the Finder.
Hide: Hides all windows of DEVONagent Pro.
Quit: Quits DEVONagent Pro.
Besides these standard commands, DEVONagent
Pro adds a number of its own commands to
the Dock menu to make them easily accessible
whenever the application is running.
New Search...: Opens a new DEVONagent Pro
search window. Same as File > New Search
New Browser...: Opens a new DEVONagent
Pro web browser window. Same as File > New
Browser"
Bookmarks, Bonjour, Workspaces: Gives you
access to your bookmarks, depending on your
settings in Preferences > Bookmarks, Bonjour
services, and workspaces. Equals the Bookmarks,
Bonjour, and Workspaces parts of the Go menu.
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WINDOWS AND PANELS
In this chapter:
Search window
Web browser

39
45

Archive window
Search sets
Plugins and scanners
Downloads
Preferences

51
53
53
55
56

Assistant

56

DEVONagent Pro uses a number of different
windows for running search queries, displaying
webpages, setting up search sets, and downloading
files.
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SEARCH WINDOW

The search window is where you start search runs
and work with the results. You open a new search
window with File > New Search In its minimized form,
the search window consists only of an entry field for
the query, a pop-up menu for selecting the search
sets to be used, a Start/Stop button, and an Append
button. In maximized form, it is divided into four
tabs: Digest, Results, Log, and Settings. You can switch
between minimized and maximized form by clicking
the green window gadget. Also, you can choose
whether you want to open new search windows as
either minimized or maximized in the preferences,
"General" tab.
To start a search run, select the correct search
set from the magnifier pop-up menu in the entry
field, enter your query and click the Start button.
DEVONagent Pro then queries all search engines
and scans all webpages defined by the search set.
As soon as the search run has finished (or you have
clicked the Stop button), DEVONagent Pro expands
the search window, if necessary, and presents
the results in either the Digest or the Results tab,
depending on your preferences.

If you have already performed a search run, you
can also use the Append button instead of Start
to append the search results to the previously
collected ones instead of replacing them.
Note: DEVONagent Pro limits search runs to
500.000 result pages and 32 GB of data. This
prevents flooding your hard disk when your
search query or your Follow Links settings are too
broad.
MAGNIFYING GLASS POP-UP MENU
The magnifying glass pop-up menu lets you select
the search set you want to use for your search. For
a general search, use the search set Web (Fast). You
can define your own search sets in the Search Sets
window, which you can open by selecting Edit Search
Sets from the magnifier pop-up menu.
User-defined plugins are listed in bold.
Note: You can easily create a new search set by
using the + button left of the search term field.
Use this to run the same query with exactly the
same settings again in the future.
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Plugins: In addition, this pop-up menu gives you
direct access to every installed plugin. This way, you
don't have to define a search set just for querying
a special search engine once. You can simply pick
the one you want to use, enter the query and hit the
Start button. Tool tips give you more information
about each plugin.
Recent searches: The magnifying glass pop-up

Topics map: In the right-hand side pane,

remembers the last 25 search terms (when private
browsing is not enabled). You recall the terms simply
by selecting them from the Recent Searches part of
the menu. Remember to select the correct search
set or plugin. Clearing the recent serarches empties
the system-wide find pasteboard too.

DEVONagent Pro shows short paragraphs from
every found webpage until you select one or
more topic words. DEVONagent Pro shows an AIgenerated visual representation of the selected
topic and its relations to other topics in a mind-map
style. Two-and three-word word expressions do not
show a topics map; for multiple selected topic words
DEVONagent Pro always picks the top one.

Recently used: Finally, find here the most recently
used plugins or search sets for quick access.
STATUS BAR
The status bar below the search field shows
information about the number and size of the
downloaded files, found results and objects, as well
as unread results.
DIGEST TAB
DEVONagent Pro's search window is divided into
three views, each presenting different aspects of
the information that has been collected in a search
run. You switch between the views by clicking the
tabs separating the search field from the rest of the
window.
The digest differs from what traditional search
engines and applications display. This is what makes
DEVONagent Pro unique. Instead of simply listing
the URLs of found pages, the digest shows a list of
topic words and two- and three-word expressions
that DEVONagent Pro has extracted from the
collected data. This list not only includes the
entered search words, but also many other words
that the artifical intelligence core of DEVONagent
Pro found to be important and related to the query.
You can sort this list by topic or relevance by clicking
the column headers. The number of sentences with
occurences is shown for each topic word.

The selected topic becomes a big blob in the center
of the map with related topics arranged around
it. The larger a blob, and the more orange or red it
is, the more important it is. Topics that are related
to the selected word but are not part of the topics
list on the left, are shown in blue. Light grey lines
indicate closer relationships between topics. Move
the mouse over the topic blobs to highlight the
connetions to other topics in the graph; click a blob
to select it. Double-click a topic in the map to make
it the center of the graph. DEVONagent Pro will
recalculate the map accordingly. This is similar to
selecting another topic word from the list on the
left.
Use the arrow buttons in the bottom bar of the
topics map area to navigate back and forth through
the results in the digest.
Summary: Finally, below the topics map,
DEVONagent Pro shows a summary of the
extracted information, sorted by relevance. At the
end of each extract, you'll find a link to the original
source where DEVONagent Pro extracted the data
from (click the link with ⌘ held to open it on a new
tab instead of in a new window). The summary
delivers the actual answer to your query, effectively
eliminating the need to go through a long list of links
or visit hundreds of webpages manually.
The summary dynamically changes with whatever
topic word or words you select in either the lefthand side pane or the topics map. This way, you can
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use the topics map to navigate through the found
information and refocus the summary to whatever
you are interested in. You can also click words in the
summary with ⌥ held to refocus the topics map on
the clicked word.
Note: You can also select multiple topics with
the ⇧ and ⌘ keys, or enter your own keywords
separated by spaces, into the text field below the
topics list. For the topics map, DEVONagent Pro
will only use the first selected topic word. It does
not work with words you enter into the keyword
text field.

delete pages from the list that you have found to
be unrelated to your research. A badge shows the
number of found scanner objects.
Preview area: In the lower pane of the Pages tab,
DEVONagent Pro displays either a text preview of
the relevant text passages for pages selected in the
list above, or all objects found by the automatically
applied scanners. Switch between the text preview
and the objects returned by the scanners using the
navigation bar above the preview.
In addition, you switch between small and large
icons, download all or selected objects, and access
the action menu from the navigation bar.

RESULTS TAB
List or Cover Flow: The Pages tab is similar to what
most search engines deliver: a list of all found URLs
including the name of the webpage and a two lines
excerpt from where the search terms are found on
the page. Sort the list by all the criteria that you
can find in the Sort menu. You can also drag results
to DEVONthink to quickly archive them in your
database.

LOG TAB
The Log tab lists all pages that DEVONagent Pro has
skipped.
DEVONagent Pro skipped them because they:
Did not match the query
Delivers an error message, e.g., the famous error
404 (file not found)
Are an advertisement
Are index spam created for fooling Google and
other search engines
You can find a complete list of all codes used in the
log in the appendix.
Effectively, the log lists all pages you did not have to
look at yourself because DEVONagent Pro did that
job for you.

You can browse the results also with Cover Flow.
Double-click a page in Cover Flow to open it in a
new web browser window; hold the ⌘ key to open the
new window in the background.
All pages that you haven't checked yet show a
dot in front of them, similar to unread messages
in Apple Mail. You can also select results and
drag them to other applications, such as an open
TextEdit window, DEVONthink, or the Finder, or

You can sort the list by date, address, or error
message by clicking the respective column headers.
Click them again to reverse the sorting order. Use
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copy-and-paste or drag-and-drop to move or copy
URLs to the Downloads panel, to a search set, to
DEVONthink, or other applications, e.g., Safari.

Open: Opens the selected page(s) in a separate
web browser window.
Launch URL: Opens the selected page(s) in your
default web browser.

SETTINGS TAB

Export: Exports the selected page(s) as pure text,
RTF(D) or HTML.
DEVONthink: Adds the selected page(s) to the
currently open DEVONthink database in the

The Settings tab contains some of the options
from the General and Advanced of search sets and
TEMPORARILY overrides these settings.

The Settings tabs offers the following options:
Follow Links
Language
Filter & Scanner
Secondary Query
Search In
Files
Use the Settings tab to temporarily enable or
disable options, e.g., to switch on a scanner without
permanently messing up the search set.
TOOLBAR
The toolbar of DEVONagent Pro's main windows
carries many commands for manipulating the way it
displays information and for manipulating selected
items. Many of these are simply shortcuts for menu
bar commands. Here's a short list of the available
tools:

format you choose from the pop-up menu. Only
available if DEVONthink is installed on your Mac.
Add: Adds the selected page(s) to the internal
archive.
Add All: Adds all found pages to the internal
archive.
Archive: Opens a window for the internal archive.
Delete: Deletes the selected page(s) from the
results list.
Print: Prints the results list.
Search: Searches the results on the Results tab. Use
the magnifying glass pop-up menu to adjust your
search options.
View: Enables or disables Cover Flow and shows
or hides icon previews.
Note: Not all of these commands are always
available. You can customize the toolbar by
selecting Viiew > Customize Toolbar or by Controlor right-clicking the toolbar background and
selecting Customize Toolbar from the contextual
menu.
SHORTCUTS & MODIFIER KEYS
Like any Mac application, DEVONagent Pro uses
modifier keys or shortcuts to access frequently used
functions or modify a standard behavior.
Command-click: Adds an item to the current
selection of items.
Shift-click: Selects a range of items.
Space, Shift-Space: Scrolls down or up in noneditable text views, e.g., the summary.
CONTEXTUAL MENU
The contextual menu, which appears when you click
something with the right mouse button or when you
click while holding the ⌃ Control key down, offers a
range of commands tailored to what you can do with
the clicked object.
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Most of the commands offered by the contextual
menu have counterparts in a main menu, so you'll
recognize them immediately. However, to save
menu bar real estate, DEVONagent Pro gives you

Open: Opens the selected pages in separate web
browser windows.
Open In Tabs: Opens the selected pages in
separate tabs in a new web browser window.

access to some options only via the contextual
menu.

Copy URL: Copies the selected URL to the
clipboard.
Launch URL: Opens the selected page(s) in your
default web browser.
Reveal in Finder: Reveals an externally archived
page in the Finder.
Add to DEVONthink: Adds the pages to your
currently open DEVONthinkdatabase in a variety
of formats. Same as Data > Add to DEVONthink.
Only available if DEVONthink is installed on your
Mac.
Add to Set > ...: Adds the addresses of the selected
page(s) to the sites list of a search set.Select "New
Set..." to create a new search set with the selected
page(s).
Add to Archive: Adds the selected page(s) to the
internal archive.
Add All to Archive: Adds all pages in the results list
to the internal archive.
Export: Exports the selected page(s).
Mark As Read: Marks the selected pages as read
or unread.
Delete: Deletes the selected page(s) from the
results list.
Delete Domain: Deletes all pages from the
selected domains from the results list.
Delete & Exclude Domain: Deletes the selected
search page(s) from the results list and adds the
domain(s) of the page(s) to the list of excluded
domains. Use this to quickly exclude an unwanted
domain, without having to block it via the
preferences.
Sort by > ...: Sorts the results list by the criteria
listed in the sub-menu. Alternative menu item to
Delete Domains.
Clear Log: Clears the log for the search run. Same
as Data > Clear Log.
Sort By: Sorts the results list by the selected sort
key. See also p. 32ff
In text areas, e.g., the text preview on the "Pages"
tab, DEVONagent Pro also offers the standard
contextual menu commands for text views:
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Search with Spotlight: Searches for the selected
text using Spotlight.
Search in Google: Opens your default browser and
searches for the selected text in Google.

Spelling > ...: OS X's integrated spell checker.
Choose "Spelling..." to open the spellchecker
panel, and "Check Spelling" to run the spell
checker on the text. "Check Spelling as You Type"

Look Up in Dictionary: Looks up the selected piece
of text in the system dictionary.
Cut/Copy/Paste: Same as "Edit > Cut/Copy/
Paste".

is not available in read-only text views.
Speech > ...: "Start Speaking" speaks selected text,
"Stop Speaking" stops speaking, which is useful
when speaking a very long piece of text.
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WEB BROWSER

Besides being a research tool, DEVONagent Pro is a
full-fledged web browser, based on the Safari engine
(a.k.a. 'WebKit'). Open a new web browser window
by choosing File > New Browser, clicking a link, or by
choosing File > Open Location when no web browser
window is frontmost.

TAB BAR
The tab bar below the toolbar lists all tabs of
the web browser window. Each tab contains a
different webpage. Use tabs to open multiple

To visit a website, enter its address into the
address field of the toolbar and press ↩ or Enter.

webpages without cluttering your screen with
dozens of separate windows. Switch between tabs
by simply clicking the tab you want to bring to the
foreground. If all tabs do not fit into the available

Alternatively, drag a URL to DEVONagent Pro's
application icon in the Finder or in the Dock, or into
an open browser window.

space, DEVONagent Pro shows an optional pop-up
menu at the right-hand side of the tab bar listing all
available tabs.

Instead of a URL, you can use keywords to directly
send a simple query to a search engine. This
effectively replaces the Google search field found
in Safari and other browsers. The keywords
are defined by the plugins, but can be edited
individually. If the plugin supports it, keywords use
a search engine specific to the system language.
Another option is to use DuckDuckgo Bangs in the
address field.

Point to a tab for one second without clicking to
show a tooltip with a thumbnail preview of the
webpage displayed on the tab. This is useful when
you cannot remember which page you opened on
which tab. Right- or ⌃Control-click a tab to show a

Example: Enter 'google devonthink' to query
Google for 'devonthink'; enter '!nws saginaw,mi'
to ask the National Weather Service for the
weather of Saginaw, MI.

contextual menu.
Inactive tabs show a close button instead of the
webpage icon. Also, after the last tab, DEVONagent
Pro shows a "+" button for creating new, empty
tabs.
TOOLBAR
The toolbar of a web browser window can be
customized like any other toolbar using View >
Customize Toolbar. The following tools are available:
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Window: Shows or hides the sidebar; switches
Cover Flow mode on and off; switches to full
screen mode; hides or shows the Inspectors pane.
View: Switches between source code, text, and

AppleScript scripts
Audio
Code
Downloadable archives

layout views. Use the source code view to inspect
how a page is constructed and the text mode to
see the raw text without any distractions.
Action Menu: Access frequently used commands

Electronic business cards (.vcard)
Email addresses
Twitter posts
Images

directly from the toolbar. See also p. 48ff
Back/Forward: Navigates back and forth through
the visited pages, like a standard web browser.
Similar to "History > Back/Forward".
Smaller/Bigger: Makes the text smaller or bigger.
Reload/Stop: Reloads the current page (circle
arrow icon) or stops loading a page ('X' icon).
Address: Type in the URL to load here, or type in
a keyword and a simple query. Read more about
keywords here. Select the whole address in the
address field and drag it to other windows or
applications, e.g., the Finder.
Translate: Shows the language of the displayed
page as recognized by DEVONagent Pro as a flag.
If your system's preferred language is different,
clicking the flag translates the page using Google
language tools.
See Also: Opens a drawer with pages similar to the
current one, sorted by relevance. Select a page
in the drawer to display it. The originating page
is always listed on the top of the list. Use See Also
for finding related pages in the results pool. See
also p. 46ff
Share: Shares the page via services like iMessage,
Mail, Twitter, Facebook, and AirDrop, or adds it to
Safari's Reading List.

LaTeX files
Links
News feed (RSS, Atom)
Office documents
Spreadsheet documents
Thumbnail galleries
Cooking recipes
Video (live)
Videos
Wallpapers, desktop pictures
Webcams

If a bookmark for the current page exists in the open
DEVONthink Pro databases, a small DEVONthink
icon is shown on the right-hand side of the address
field.
INSPECTORS
The Inspectors pane presents additional information
about the displayed web page, e.g. metadata or
extracted objects. Depending on the displayed page,
none, one, or multiple of the following tabs, can be
available:

Properties tab: The Properties tab shows metadata
about the displayed web page.
See Also tab: The See Also tab lists other pages
related to the displayed page from three sources:
Search: The results of the search run to which the
page belongs.
Archive: Pages in the internal archive.
DEVONthink Pro: The currently open
DEVONthink databases.
Web: Related pages from the Web, either provided
by plugins or common search engines.
Click any item in the pane to display it; doubleclicking opens it in a new tab or window. The original
page stays at the top of the list so that you can
easily go back to it. Results from DEVONthink that
have a URL associated with them are also shown
with a single click; results without URLs open in
DEVONthink on a double-click.
Objects: Which, if any, of the other above tabs are
available depends on the web page shown in the
window. DEVONagent Pro collects all objects from
the page using the available scanners and lists them
in separate tabs in the sidebar. Click any found
object to display it (double-click to open it in a new
tab, if tabbed browsing is enabled, or a new browser

Properties
See Also
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window). Click with ⌘ pressed to open the result in
a new tab. The Back button brings you back to the
original page.
Botttom bar: The bar at the bottom of the sidebar
gives you access to commonly used commands,
depending on which tab is active.
List: Shows objects in a list with small icons. See
also p. 33ff
Icons: Shows objects as large icons. See also p. 33ff
Download: Adds the selected objects to the
Download Manager. If no item is selected all items
will be added.
Action: Gives access to the same options as the
contextual menu (see below).
Contextual menu: The contextual menu gives
you direct access to commands acting on the
selected items. Commands are only available when
applicable.
Open in New Window: Opens the selected items
in a new web browser window.
Open in New Tab: Opens the selected items in a
new tab.
Open in PhotoStickies: Opens a selected items in
PhotoStickies.
Open in DEVONthink: Opens a document located
in DEVONthink.
Reveal in DEVONthink: Reveals a document
located in DEVONthink.
Add Link to DEVONthink: Adds a link to the result
to DEVONthink.
Copy: Copies the selected items to the clipboard.
Download: Downloads the selected items (or the
items referred to by links).
Select/Deselect All: Selects or deselects all items
in the list.
Use Small Icons: When checked (default),
DEVONagent Pro displays small icons in the
drawer, including the name and the link to or of
the item; when unchecked, it displays large icons,
160 pixels wide, and shows no links.
Open Video in Tab: Opens an HTML 5 video in a
new tab.
Open Video in New Window: Opens an HTML 5
video in a new window
Download Video: Downloads an HTML 5 video.

SIDEBAR
The sidebar is the place in a web browser window
where all additional information is presented, from
bookmarks to the list of search results (if the page
is part of the results of a current search run) to
extracted objects. The sidebar is divided into several
sub-tabs:
Bookmarks
Results
Bookmarks: Use the Preferences to choose what
bookmarks and additional elements, e.g., Web
servers announced via Bonjour, DEVONthink
Pro bookmarks, or workspaces, are listed on the
Bookmarks pane. If you are using DEVONagent Pro
for your bookmark management, use cut/copy/
paste, drag-and-drop, or the contextual menu (see
below) to edit your bookmarks.
Results: The Results pane lists all results of the
search run that the shown webpage belongs to. This
pane is unavailable if the page does not belong to a
currently open search run.
Bottom bar: The bar at the bottom of the sidebar
gives you access to commonly used commands,
depending on which tab is active.
+: Adds the current page to the bookmarks.
-: Removes the current page from the bookmarks.
Back: Selects the previous search results from the
current results set.
Forward: Selects the next search results from the
current results set.
Delete: Deletes the current page from the current
results set.
Action: Gives access to the same options as the
contextual menu (see below).
Contextual menu: The contextual menu gives
you direct access to commands acting on the
selected items. Commands are only available when
applicable.
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Next/previous result: Navigates back and forth
through the list of results. Same as Go > Next/
Previous Result.
Mark as Read/Unread: Marks the selected results

Copy URL: Copies the address of the current page
to the Clipboard.
Launch URL: Opens the selected pages in your
default web browser.

as read/unread.
Delete: Deletes the result from the results of the
search run it was opened from.
Delete & Exclude Domain: Deletes the result from

Add to DEVONthink: Adds the pages to your
currently open DEVONthinkdatabase in a variety
of formats. Same as Data > Add to DEVONthink.
Only available if DEVONthink is installed on your

the results of the search run it was opened from
and adds it to the exclude list in the Preferences.
Sort: Changes the sorting of the result list.
Cut: Copies the selected items to the clipboard and
removes it from the list.
Copy: Copies the selected items to the clipboard.
Paste: Pastes bookmarks on the clipboard.
Add Bookmark: Adds the current page to the
bookmarks.
Add Bookmark Folder: Adds a new folder to the
bookmarks.
Import: Imports bookmarks. See also p. 29ff
Edit: Opens an editing sheet for the selected
bookmark.
Delete: Deletes the selected items.
Show Icon Preview: When checked, DEVONagent
Pro shows a preview icon for bookmarks.

Mac.
Add to Set > ...: Adds the URL of the page to the
"Sites" tabof the search set you select from the
sub-menu. Select "New Set..." to create a new
search set with the selected page(s).
Add to Archive: Adds the page to the internal
archive.
Save As: Saves the the selected pages as pure text,
RTF(D) or HTML.
Translate: Translates the displayed page using the
Google language tools to your system's preferred
language. This command is unavailable if the
recognized language of the displayed page is the
same as the preferred language of your system.
Inverse Appearance: Inverts the colors of the
results list to match it with Cover Flow. Uncheck
to return to regular black-on-white appearance.

Add Link to DEVONthink: Adds the link of
the selected items to the currently open
DEVONthink database. Only available if
DEVONthink is installed on your Mac.
Copy Link: Copies the selected links to the
clipboard.
ACTION MENU
The action menu (labeled with a gear icon) makes
frequently used commands conveniently accessible
from the toolbar.

SHORTCUTS & MODIFIER KEYS
Command-click: Opens a link or an item in the
objects drawer in a new tab, if tabbed browsingis
enabled. Otherwise, ⌘-click opens the clicked link
in a new window.
Option-click: Downloads an item on a webpage, a
linked item or an item in the objects drawer via
the download manager.
Space, Shift-Space: Scrolls down or up in noneditable text views, e.g., the source code or textonly view.
CONTEXTUAL MENU
The contextual menu, which appears when you click
something with the right mouse button or when you
click while holding the ⌃ Control key down, offers a
range of commands tailored to what you can do with
the clicked object, for example a text passage.
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Most of the commands offered by the contextual
menu have counterparts in a main menu, so you'll
recognize them immediately. However, to save
menu bar real estate, DEVONagent Pro gives you

Back/Forward: Navigates back and forth through
previously visited pages, similar to the Back
and Forward toolbar buttons or History > Back/
Forward.

access to some options only via the contextual
menu.

Reload: Reload the item or page.
Search in Spotlight: Searches selected text with
Spotlight.
See Related Text: Opens the inspector with
archived results related to the selected text
passage.
Look Up in Dictionary: Looks up selected text in
the system dictionary.
Stop Loading: Stops loading the item or page.
Open Image in New Window: Opens the selected
image in a new web browser window.
Open Image in New Tab: Opens the selected image
in a new tab of the current web browser window.
Open Image in PhotoStickies: Opens the selected
image in PhotoStickies.
Copy Image: Copies the selected image to the
clipboard.
Copy Image Address: Copies the address or the
selected image to the clipboard.
Add Image to DEVONthink: Adds the selected
image to the currently open DEVONthink
database. Only available if DEVONthink is
installed on your Mac.
Add Image to Archive: Adds the selected image to
the archive.
Save Image As...: Saves the selected image to your
computer.
Save Image to Downloads: Saves the selected
image to the default download folder.
Use Image as Desktop Picture: Saves the selected
image and sets it as the desktop picture.
Open Link in New Window: Opens the selected
link in a new web browser window.
Open Link in New Tab: Opens the selected link in a
new tab.
Open Link in PhotoStickies: Opens the selected
link in PhotoStickies.
Copy Link: Copies the selected link to the
clipboard.
Download Linked File: Downloads the file
referred to by the selected link via the Download
Manager.
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Share: Shares the selected item using OS X's
standard share mechanism (requires at least OS X
Mountain Lion).
Add Selection to DEVONthink: Adds the selected

Copy Page/Frame Address: Copies the address of
the page or frame to the Clipboard.
Add Page/Frame to Archive: Adds the page or
frame to the internal archive.

text to the currently open DEVONthinkdatabase.
Only available if DEVONthink is installed on your
Mac.
Add Link to DEVONthink: Adds the selected link

Add Page to DEVONthink (Pro): Adds the
HTML code of the page to the currently open
DEVONthink (Pro)database. Only available if
DEVONthink is installed on your Mac.

to the currently open DEVONthinkdatabase.
Only available if DEVONthink is installed on your
Mac.
Add Link to Set > ...: Adds the selected link to the
sites list of a search set.
Add PDF to DEVONthink: Adds the displayed PDF
to the currently open DEVONthink database.
Only available if DEVONthink is installed on your
Mac.
Add page address to DEVONthink: Adds the
address of the page to the currently open
DEVONthink database. Only available if
DEVONthink is installed on your Mac.
Add frame address to DEVONthink: Adds the
address of the selected frame to the currently
open DEVONthink database. Only available if
DEVONthink is installed on your Mac.
Remember Selection: Remembers the current
selection and re-applies it when you open the
same page again.
Forget Selection: Forgets the last saved selection.

Add Web Archive to DEVONthink (Pro): Adds
an webarchive (including all embedded images
needed for correctly displaying it) of the page to
the currently open DEVONthink (Pro)database.
Only available if DEVONthink is installed on your
Mac.
Add Page/Frame to Set > ...: Adds the page or
frame address to the sites list of a search set.
Add All Links to Set > ...: Adds all links found on the
page to the sites list of a search set.

If the WebKit developer extras are enabled more
options are available.
When you ⌃-click or right-click the background of
the page instead of a item, additional options can be
available:
Open Page/Frame in New Window: Opens the
page or frame in a new web browser window.
Open Page in New Tab: Opens the page in a new
tab.

For PDF pages, different options become available:
Add PDF to DEVONthink: Adds the PDF to the
currently open DEVONthinkdatabase. Only
available if DEVONthink is installed on your Mac.
Open with Preview: Opens the PDF in Preview.
Automatically Resize: When checked, the zoom
factor adjusts to the width resp. height of the
browser window.
Zoom Out, Zoom In, Actual Size: Zooms in or out
of the document, or displays it in its actual size.
Single Page, ...: Displays the PDF as single or
double pages and either page by page (use the
'Next Page' and 'Previous Page' to skim through
the pages forward and backwards) or continously.
Next Page, Previous Page: Skims through the
pages forwards or backwards.
On the Results pane of the sidebar, the following
additional options are available:
Mark As Read: Marks the selected pages as read
or unread.
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ARCHIVE WINDOW

The integrated archive is where you can store found
pages for later reference. Open the Archive window

Enter key. Delete a group by selecting it and pressing
Backspace, using the toolbar, the contextual menu or

with Window > Archive.

Data > Delete. To make a group a sub-group, drag it
with the mouse or use the contextual menu.

The archive resembles the three panes view of
Apple Mail or DEVONthink: The left pane shows a
list of groups, the right top pane displays page titles
and URLs in a selected group, and the right bottom
pane displays textual information related to the
query that was used for finding a selected page. A
search field in the toolbar allows you to search the
archive by content, name or URL.
GROUPS
All archived pages are stored in groups. Groups
are automatically created when you archive pages
from the search window and are named after the
search query. You can change group names at any
time, delete groups or manually create new ones.
You can also create sub-groups by selecting a group
and then creating a new one. The number of items
contained in a group is shown as a badge.
Note: Pages not related to a previous search run
are archived in sub-groups of a top-level group
named 'Incoming'. The sub-groups are named
with the current date.
Create new groups by using the toolbar, the
contextual menu or Data > New Group. Rename a
group by clicking it once and waiting a second (like
the Finder), or by selecting it and pressing the ↩ or

Sort the groups by name or date with Sort > by Name
or Sort > by Date. Reverse the sorting order with Sort
> Ascending/Descending.
PAGES
Like DEVONthink or Apple Mail, DEVONagent
Pro shows the pages filed in a group when you
select the group in the left pane. Select a page and
DEVONagent Pro also shows a text preview in the
lower right pane with the original search words
highlighted.
Rename a page by single-clicking it and waiting
a second (like the Finder), or by selecting it and
pressing the ↩ or Enter key. Delete an item by
selecting it and pressing Backspace, using the
toolbar, the contextual menu or Data > Delete. To
move an item to another group, drag it or use the
contextual menu. Items can also be dragged to
DEVONthink.
To sort the pages list, click the relevant (first), title,
URL or date column header. Click again to reverse
the sorting order. The relevance column is only
used when you search the archive using the toolbar
search field.
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TOOLBAR

SHORTCUTS & MODIFIER KEYS

The toolbar of DEVONagent Pro archive windows
carries many commands for manipulating the way it
displays information and for manipulating selected

Like any Mac application, DEVONagent Pro
uses modifier keys or shortcuts to quickly access
frequently used functions or modify a standard

items. Many of them are simply shortcuts for menu
bar commands. Here's a short list of the available
tools:

behavior.

Group +: Adds new groups to the archive. To
create a sub-group, select the parent-to-be group
first, then use this tool.
Open: Opens the selected page(s) in a separate
web browser window.
Launch URL: Opens the selected page(s) in your
default web browser.
Export: Exports the selected page(s) as pure text,
RTF(D) or HTML.
DEVONthink (Pro): Adds the selected page(s) to
the currently open DEVONthink (Pro) database.
Only available if DEVONthink is installed on your
Mac.
DEVONthink (Pro) pop-up: Adds the selected
page(s) to the currently open DEVONthink (Pro)
database, but allows you to select as HTML code
or as a link via a pop-up menu. Only available if
DEVONthink is installed on your Mac.
Delete: Deletes the selected page(s) from the
results list.
Search: Searches the archive for entered text.
Select whether you want to search the contents,
the names or the URLs of the stored pages with
the magnifying glass pop-up menu. Also choose
whether to ignore diacritics or to search fuzzy.
This search field also supports all operators and
wildcards.
Print: Prints the results list.

Command-click: Adds an item to the current
selection of items.
Shift-click: Selects a range of items.
CONTEXTUAL MENU
The contextual menu, which appears when you click
something with the right mouse button or when you
click while holding the ⌃ Control key down, offers
a range of commands tailored for what you can do
with the clicked object.
Most of the commands offered by the contextual
menu have counterparts in a main menu, so you'll
recognize them immediately. However, to save
menu bar real estate, DEVONagent Pro gives you
access to some options only via the contextual
menu.

Note: Not all of these commands are always
available. You can customize the toolbar by
selecting View > Customize Toolbar or by ⌃-clicking
or right-clicking the toolbar background and
selecting Customize Toolbar from the contextual
menu.
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New Group: Adds a new group to the archive. To
create a sub-group, select the parent-to-be group
first, then use this command. (Only available in
the left pane)
Open: Opens the selected pages in separate web
browser windows.
Open In Tabs: Opens the selected pages in
separate tabs in a new web browser window.
Launch URL: Opens the selected pages in your
default web browser.
Copy URL: Copies the selected URL to the
clipboard.
Reveal in Finder: Reveals an externally archived
page in the Finder.
Add to DEVONthink: Adds the selected pages to
DEVONthink. Only available if DEVONthink is
installed on your Mac.
Add to Set...: Adds the URLs of selected pages
to the sites list of a search set so that it will get
scanned when you use that search set in the
future.
Move To > ...: Moves the item to the group you
select from the sub-menu.
Export: Exports the selected pages.
Delete: Deletes the selected pages from the
results list.
Delete Domain: Deletes all pages from the
selected domains from the result list.
Delete & Exclude Domain: Deletes the selected
search pages from the results list and adds the
domains of the pages to the list of excluded
domains. Use this to quickly exclude an unwanted
domain without having to block it via the
preferences. Alternative menu item to Delete
Domains.
Sort by > ...: Sorts the results list by the criteria
listed in the sub-menu.

SEARCH SETS
The Search Set window is available via Window >
Search Sets. Use it to modify the existing search sets
or to create new ones specifically tailored for your
needs.
Because search sets are so important, we have
created a separate chapter about the search sets
and the search sets editor. See also p. 20ff

PLUGINS AND SCANNERS
The Plugins & Scanners panel, available via Window
> Plugins & Scanners, lists all installed plugins and
scanners and shows additional information about
them, e.g., their type, version and purpose. In
addition, it allows you to create new plugins for your
favorite websites and search engines.

Also, you can enable or disable plugins or whole
groups of plugins by checking or unchecking them.
Use this to simplify the magnifying glass pop-up
menu in the search window or the plugin list in the
Search Sets window.
PLUGINS & SCANNERS
All plugins and scanners are arranged in groups.
Click the grey triangle in front of a group to expand
it; click it again to close it. Select a plugin or scanner
to show additional information:
Name: Plugin name.
Info: Additional information, e.g., copyright.
Identifier: Internal and identification string.
Keywords: Shortcuts for the plugin. See also p.
54ff
Description: Textual description of the plugin.
Operators: List of supported operators. For
plugins that you created yourself, you can check
and uncheck them to adjust which operators are
supported by the search engine.
Name, info, identifier, description, and keywords of
self-made XML plugins can be edited. User-defined
plugins, as well as the groups Browser, DEVONsphere,
and Scanner are shown in bold.
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Note: The group hierarchy is predefined and
cannot be manually altered. If you have installed
your own plugins, they appear in the top level
of the hierarchy or are mirrored-in following
the folder structure in '~/Library/Application
Support/DEVONagent/Plugins/'.

and '_agentOffset_' placeholders are automatically
inserted if necessary and possible. See also p.
69ff
Alternatively, if you want to create a plugin that

KEYWORDS

simply searches a website, enter just the URL of the
website. DEVONagent Pro will use standard search
engines such as Google to run a site-specific search
when you use this plugin.

Keywords are shortcuts that you can use to query
the search engines defined by the plugin from the
address bar of a web browser window.

DEVONagent Pro selects the Website or Search
Engine radio buttons automatically, depending on
the entered URL.

Example: The Bing plugin comes with the
predefined keyword 'bing'. To send a query to
Bing, type e.g., 'bing devonthink' into the address
bar of a DEVONagent Pro web browser window
and press ↩ or Enter.
This effectively replaces the search engine field that
is found in other web browsers, such as Safari, with
a far more flexible approach. You can add your own
keyword(s) to most plugins, separated by spaces,
to make them quickly accessable from any open
DEVONagent Pro browser window.
In addition, the plugin's name is automatically used
as a keyword.
CREATING & TESTING
Using DEVONagent Pro's built-in plugin assistant,
you can easily create your own XML-based search
plugin for your favorite search engine. To create
your own plugin, choose File > New Plugin or use the
New toolbar icon.
In the sheet enter:
Name for the plugin
Short description
Website or search engine URL
To get the URL for your search engine, run a search
in your web browser, copy the URL, and paste it into
the URL field of the to-be-created plugin. Then look
for the URL parameter that transports the query,
e.g., something like '&query=xxx'. Replace 'xxx' with
'_agentQuery_'. This tells DEVONagent Pro where
to enter the search term. The '_agentNumber_'

To test a build-in or self-created plugin use the Test
toolbar icon. DEVONagent Pro will send 'Test' as
the standard search term to the plugin and present
you with the list of returned pages. Double-click
results to view them in a new web browser window.
Only XML and JSON plugins using 'EngineUrl' can
be tested since testing XML and JSON plugins using
'EngineSite' is unnecessary.
To edit an existing XML- or JSON-based plugin,
double-click it or use the Edit toolbar icon.
DEVONagent Pro shows an XML text editor with
error checking that allows you directly edit the
source code of the plugin. Switch between XML and
JSON format using the button at the bottom of the
editing sheet. See also p. 69ff
TOOLBAR
The toolbar of the Plugins & Scanners windows lets
you easily create new plugins, edit, test, and delete
them.
New: Opens a sheet for creating a new XML-based
plugin.
Edit: Opens a sheet for editing the XML code of the
selected plugin.
Test: Runs a test on the selected plugin and
displays the results.
Delete: Deletes the selected plugins. Built-in
plugins cannot be deleted.
Show In Finder: Opens a new Finder window for
the folder containing the selected plugin.
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CONTEXTUAL MENU
The contextual menu, which appears when you click
something with the right mouse button or when you
click while holding the ⌃ Control key down, offers
a range of commands tailored for what you can do
with the clicked object, forexample a text passage.
New: Opens a sheet for creating a new XML-based
plugin.
Edit: Opens a sheet for editing the XML code of the
selected plugin.
Duplicate: Duplicates the selected plugins.
Show In Finder: Opens a new Finder window for
the folder containing the selected plugin.
Test: Runs a test on the selected plugin and
displays the results.
Delete: Deletes the selected plugins. Built-in
plugins cannot be deleted.
The test sheet also presents the following options in
the contuextual menu:
Open: Opens the selected URLs in DEVONagent
Pro's built-in web browser.
Open In Tabs: Opens the selected URLs in separate
tabs in DEVONagent Pro's built-in web browser.
Launch URL: Opens the selected URLs in the
default application for their types.
Exclude URL: Adds the selected URLs to the
plugin's internal exclude list. Use Retry to re-run
the test after exluding a URL.
Exclude Domain: Adds the domains of the selected
URLs to the plugin's internal exclude list. Use
Retry to re-run the test after exluding a domain.
Include URL: Adds the URL to the "LinksMatching"
key.
Include Domain: Adds the domain to the
"LinksMatching" key.
Copy: Copies the selected URLs to the clipboard.

DOWNLOADS
Window > Downloads opens the Downloads window.
Use it to download files from the Internet to your
computer. The download URL is automatically
placed into the Finder comment of the downloaded
file, as well as in the 'kMDItemWhereFroms'
extended file system attribute.

For URLs that require authentication, DEVONagent
Pro asks for a username and password. It also uses
the systemwide cookies, and can start and stop
downloads at any time.
ADDING, RESUMING, RETRYING
To add files to the Download Manager, drag a link to
the item from any DEVONagent Pro web browser
window or any other application to the Download
Manager window, paste a copied URL or ⌃-click a
link in a DEVONagent Pro web browser window
and choose "Add to Download Manager". ⌥-clicking
links in the web browser or the objects drawer
adds items to the Download Manager, too. Also,
DEVONagent Pro automatically puts files it cannot
display into the Download Manager, if you doubleclick them, e.g., .zip archive files.
DEVONagent Pro downloads files added to the
Download Manager immediately. To remove a file,
select it and click the - button at the bottom of the
window. To temporarily prevent an item from being
downloaded, uncheck the checkbox in front of it.
Check the checkbox to download the item. Use this
to add items to the download queue, but download
them later.
To resume or retry a failed download, select the file
and click the back arrow button. Use the start/stop
button (resembles the start/pause button of a VCR
or tape player), to start or stop the entire queue.
You can also drag items from the Download
Manager to other windows or to the Finder, or copy
it to the Clipboard. Drag-and-drop will send the URL
of the item to the target window or application.
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DEVONagent Pro puts the web address where
the file was downloaded from into the Spotlight
comments of the file (not available if DEVONagent
Pro was purchased in the Mac App Store).
ACTION MENU
The action menu provides the same options as the
contextual menu.

ASSISTANT
The integrated Assistant combines a welcome screen
with tips, tricks, and tutorials, installable extras,
and a suppport page that guides you through the
available support options.
Click here to directly open the assistant.

CONTEXTUAL MENU
The contextual menu, which appears when you click
something with the right mouse button or when you
click while holding the ⌃ Control key down, offers a
range of commands tailored to what you can do with
the clicked object.
Cut: Copies the selected link to the Clipboard and
removes it from the queue.
Copy: Copies the selected link to the Clipboard.
Paste: Adds a link that is copied to Clipboard to the
download manager queue.
Retry: Retries a stopped or stalled download.
Show In Finder: Opens a Finder window for the
enclosing folders of the selected items.
Enable/Disable: Enables or disables the selected
item(s). Disabled (unchecked) items are not
downloaded but kept in the download queue.
Reload: Reloads the selected items.
Remove: Removes the selected items from the
queue.
Start/Stop Queue: Starts or stops the download
queue.
Purge Queue: Purges all completed items from the
queue.
Automatically Purge Queue: When checked,
completed items are automatically purged from
the queue.

WELCOME
This screen welcomes you when you start
DEVONagent Pro for the very first time. It offers:
The option to subscribe to the free
DEVONtechnologies newsletter, as well as a
number of welcome tips
The tip of the day
The extra of the day
You can access all other screens of the assistant
from here, too.
GET SUPPORT
The support screen guides you through the three
common steps for troubleshooting DEVONagent
Pro. In addition you can have your license code
resent, request a trial extension, update your details
in DEVONtechnologies' customer database, or buy
an upgrade or a second license.

PREFERENCES

TIPS AND TUTORIALS

The Preferences window is available via
DEVONagent Pro > Preferences. It contains all
available options that you can modify to adapt
DEVONagent Pro to your personal needs.

Here you can always find the latest tips sand
tutorials that help you squeeze the best out of
DEVONagent Pro. Tutorials can be slideshows
describing basic tasks in DEVONagent Pro or videos
(as they become available).

Because the preferences are so important, we have
created a chapter just for them. See also p. 58ff
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Both tips and tutorials are updated live from
DEVONtechnologies' server, so it's a good idea
to check back from time to time. The latest tip or
tutorial is always mentioned on the welcome screen.
INSTALL EXTRAS

Scripts
Plugins
Browse the list of extras and install them with
the Install button. The last line of the description
shows where in the Scripts menu or Plugins hierarchy
the extra will show up after installation. Remove
installed extras with the Remove button.
The extras are updated live from
DEVONtechnologies' server so it's a good idea to
check back from time to time. The latest extra is
always mentioned on the welcome screen.
Note: If one of these categories does not show
up in your copy of DEVONagent Pro, there
may not be extras of this type available yet for
DEVONagent Pro.

On the extras screen, DEVONagent Pro lists
available extras that you can download and install
from DEVONtechnologies' server:
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PREFERENCES
In this chapter:

INTERFACE
These options define some parts of DEVONagent
Pro's visual appearance.

General
Search

58
59

Menu extra
Web
Tabs
Bookmarks
Email

60
61
62
63
63

Highlight occurences in HTML pages: Check to
highlight occurences of search words in web
browser windowsor views.
Automatically zoom search panel: Check to open
new search windowssimplified.

Update

64

Floating simplified search panel: Makes the
simplified search windowfloat above all other
windows. Use this to have the search window
always handy.
Alternating rows colors in views: When checked,
DEVONagent Pro colors lines in lists differently
to make them easier to read.

The preferences window, which you open by
selecting Preferences in the DEVONagent Pro menu,
is the place where you change all global settings of
DEVONagent Pro. Click here to open the Preferences
window.
For your convenience, the preference panel is
divided into tabs, just like System preferences. Use
the icons at the top of the preferences window to
select the tab you want to check or modify.

ALERTS
Click Reset to make DEVONagent Pro show alerts
again that you previously dismissed with "Don't
show again" checked.

GENERAL
SEARCH PANEL
This option defines which tab DEVONagent Pro
shows when a search run is done.
Digest: Switches to the Digest tab when
DEVONagent Pro has finished a search run.
Results: Switches to the Results tab when
DEVONagent Pro has finished a search run.
Log: Switches to the Log tab when DEVONagent
Pro has finished a search run.
Settings: Switches to the Settings tab when
DEVONagent Pro has finished a search run.
SUMMARIZATION
This tab contains all options modifying the user
interface and the summarization of search results.

These options define how DEVONagent Pro creates
summaries.
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Based on sentences: Creates summaries based
on sentences. These are generally shorter
summaries, so you may miss information that
DEVONagent Pro classifies as not important.
Based on paragraphs: Creates summaries
based on whole paragraphs. These are longer
summaries that are not clipped.

SEARCH
Contains all options dealing with the cache, the
number of connections, and domains excluded from
searching.

STARTUP
These options let you define what DEVONagent Pro
does when you open it.
Open new query: Opens a new, empty search
window when you open DEVONagent Pro.
Open new browser: Opens a new web browser
window when you open DEVONagent Pro.
Open browsers that were open on quit: Opens the
web browser windows that were open on quit.
Do nothing: Does nothing when you open
DEVONagent Pro.
HOME PAGE, ...
These options define the default home page and the
folder for downloaded files.
Home page: Sets the home page that is loaded
automatically each time you open a new web
browser window.
Save downloaded files to: Sets the folder into
which DEVONagent Pro saves downloaded files.
See also p. 55ff
FONTS
Define the fonts you want to use for searching and
reading texts. Click the Select buttons to open the
standard font panel. Hold the ⌥Option key to
reveal options for resetting the fonts to the defaults.
Source font: Changes the font used for displaying
source code. A monospaced font, such as Courier
or Monaco, gives you the best results.
Text font: Changes the font used for displaying
plain text, e.g., text extracted from webpages.

GENERAL
Ignore instructions for robots: Ignores
instructions embedded into the HTML code of
webpages that tell robots (like DEVONagent Pro)
to not index a page. If unchecked (default setting),
DEVONagent Pro tries to honor the wishes of the
webpages creator.
Cache downloaded pages: Check if you want
DEVONagent Pro to store downloaded pages in
its cache. This consumes disk space, but leads to
much faster searches when DEVONagent Pro
scans an already cached page.
Clear on quit: When checked, DEVONagent Pro
clears the cache upon quit.
Cache Directory: Shows the path to the folder
used by DEVONagent Pro for its cache. Doubleclick an item to reveal it in the Finder or select
another folder for DEVONagent Pro to use.
CREATE PREVIEWS
Choose whether DEVONagent Pro should create
previews of visited or found pages immediately
or on demand, and set how DEVONagent Pro
generates thumbnails of webpages.
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Immediately: Previews are created and cached
immediately.
On demand: Previews are created and cached only
when needed (default).
Directly: DEVONagent Pro generates thumbnails
itself (higher quality).
Via Thumbshots.com: DEVONagent Pro asks
Thumbshots.com to generate thumbnails (faster).

MENU EXTRA
The options in this tab determine if DEVONagent
Pro's menu extra is automatically started when you
log into your account, if the menu should show icon
previews, how results are opened when selected,
and what hotkey to use to call the menu.

Note: DEVONagent Pro never sends more than
just the URLs of the to-be-thumbnailed webpages
to Thumbshots.com.
MAX. CONNECTIONS
Use this parameter to adjust the number of
connections DEVONagent Pro uses concurrently so
as to match the speed of your Internet connection
and your computer.
MAX. DOWNLOAD SIZE
Choose how large files can be that DEVONagent
Pro downloads in search runs. Adjust this to your
Internet connection speed. Files skipped due to file
size are marked as "Too big" in the log tab of the
search window.
EXCLUDE DOMAINS, ...
Exclude Domains: Enter all domains you want to
exclude from searching in this text field, separated
by returns. Use this to exclude domains blocking
automatic bots like DEVONagent Pro, e.g.,
'sciencemag.org' or 'slashdot.org', or to ignore sites
you don't like (for example 'google.com'). Domains
skipped because they match one or more entries in
this list are marked as 'Skipped' in the Log tab of the
Search window.
Exclude Links: Enter URLs you want to exclude from
being searched.
Note: Both fields also accept the '*' wildcards at
the beginning or end of lines.

GENERAL
Start at login: The menu extra is started
automatically when you log in.
Show icon preview: Shows preview icons of the
found pages in the menu.
Show text summary in menu: Shows a short
summary directly in the menu. Uncheck this
option to keep the menu less crowded; you can
always read the full summary in the tooltip.
Cancel search after opening a result: Stops the
search run as soon as you double-click a result to
view it. This option has no effect when you open
the result in the background.
SEARCH
Agent: Downloads each result page and filter e.g.
error pages.
Express: Returns the results unfiltered.
In both cases DEVONagent Pro uses its unique
artificial intelligence technology to rank the results,
in Express mode only based on title, address, and a
short summary, in Agent mode based on the full text
of the page.
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OPEN RESULTS
In DEVONagent Pro: Results you select in
the menu extra's menu are opened using
DEVONagent Pro's browser.
In default web browser: Results you select in the
menu extra's menuThe results are opened using
your default web browser.
HOTKEY
Click the button to record any key combination you
like to call the menu extra. Using the hotkey will
open the menu extra in OS X 10.7 Lion's fullscreen
mode, too.

WEB
The options in this tab resemble the settings of
most web browsers. They define how DEVONagent
Pro's built-in web browser windows displays HTML
documents and live webpages.

Enable plugins: Check this option to use installed
third-party plugins, e.g., Flash or RealPlayer.
Enable Java: Check this option to run Java applets
contained in or linked to webpages.
Enable JavaScript: Check this option to run
JavaScript scripts contained in webpages.
Block pop-up windows: Check this option
to block pop-up windows, which are often
advertisements. Uncheck this option if the
webpage you're visiting uses pop-up windows
for actual content (which ome Web content
management systems do).
Only automatic JavaScript windows: Check this
option to block only pop-up windows opened by
JavaScript, instead of all pop-ups.
Block zooming: Check this option to keep
JavaScript from zooming the web browser
window to full screen.
Block advertisment: Check this option to block
common inline advertisements provided by major
search engines.
Zoom text only: Check to scale only the text when
zooming in and out of webpages. If unchecked,
DEVONagent Pro uses Safari-4-style zooming.
IMAGES
Use these otions to define how DEVONagent Pro
displays graphics in webpages.

WEB CONTENT
These settings define how DEVONagent Pro treats
special Web contents.

Display images when the page opens: Check
this option to diplay webpages with images
or uncheck to load them without images. If
unchecked, you may miss some information on
graphic-oriented pages.
Animate images: Check this option to run
animated graphics; uncheck it to show the items
statically.
Loop animations of images: Check this to run
animated graphics in a loop.
ACCEPT COOKIES
Cookies are little text files with information that
webpages store on your computer to recognize you
as a returning customer. While most cookies are
harmless, you may want to control what is being
stored on your hard disk.
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Always: Accepts all cookies.
Never: Doesn't accept any cookies
Only from sites you navigate to: Accepts cookies,
but only from websites you navigate to, not from
other sites, e.g., ad trackers.
Delete cookies on quit: Deletes all stored cookies
when you quit DEVONagent Pro.
Note: Delete cookies on quit deletes the cookies
for all WebKit-based web browsers including
Safari. All these browsers use the same single
cookie file.

WEBKIT DEVELOPER EXTRAS
Enable to use the standard WebKit developers
extras in web browser, e.g., the element inspector or
the JavaScript console.

TABS
Like many modern web browsers, DEVONagent
Pro features tabbed browsing. This enables you
to display multiple webpages in one web browser
window and switch between them with tabs.

STANDARD/FIXED-WIDTH FONT
Set the font you want to use for displaying
webpages separately for variable-width and fixedwidth text. Holding the ⌥Option key changes the
Select buttons to Reset for resetting the font to the
factory default.
(FEED) STYLE SHEET
You can further control the way DEVONagent Pro
displays webpages by applying a CSS style sheed for
changing the rendering on-the-fly.
Style Sheet: Click Select and choose your own style
sheet to apply it.
Feed Style Sheet: DEVONagent Pro comes with
a number of different style sheets for RSS news
feeds. Choose your preferred style. You can
use your own CSS styles for news feeds by
placing them in '~/Library/Application Support/
DEVONagent/StyleSheets' (restart DEVONagent
Pro if necessary).
Note: Applying an external CSS style sheet to
webpages is an expert option. It heavily affects
the rendering of all webpages in DEVONagent
Pro, though it does not interfere with the search
functionality of DEVONagent Pro.
TEXT ENCODING
Select your desired text encoding for displaying
webpages. Generally the default setting, Automatic
should work fine. If not, choose a more appropriate
text encoding for your language.

Use the following settings to activate tabbed
browsing and define additional options. They
resemble those available in Apple Safari.
Open links from applications: Defines whether
DEVONagent Pro shows pages requested by
other applications, such as the Finder, in a new
window or in a new tab in the current web
browser window.
Enable Tabbed Browsing: Switches tabbed
browsing on or off. You can always create new
tabs manually, but DEVONagent Pro will not
open new tabs automatically or when you ⌘-click
a link.
Select new tabs as they are created: When
checked, DEVONagent Pro automatically
switches to a newly generated tab.
Always show tab bar: When checked, the tab bar
is always visible; when unchecked, DEVONagent
Pro only shows the tab bar when at least two tabs
are open.
Note: The lower part of the preference window
shows the keyboard commands for creating
new tabs and opening links in new tabs, similar
to Apple Safari. The keyboard commands may
change with the options you select above.
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BOOKMARKS
DEVONagent Pro makes the bookmarks defined
in your favorite web browser available both in the
Go menu and in a bookmark drawer in web browser
windows.

BOOKMARKS MENU
Select if you want to include Bonjour services in the
Go menu.
Include Bonjour: List Web servers announced via
Bonjour in Go menu.

EMAIL
DEVONagent Pro can send you reports of schedules
search runs by email. Tell DEVONagent Pro how it
shall send you messages on this tab.

BOOKMARKS
Select your favorite browser:
Camino
DEVONagent Pro
Firefox
Chrome
OmniWeb
Safari
DEVONagent Pro comes with its own bookmark
management. Choose DEVONagent Pro in the list to
use the integrated bookmark management. See also
p. 47ff
BOOKMARKS BAR
Select whether DEVONagent Pro automatically
mirrors Web servers announced via Bonjour,
bookmarks stored in DEVONthink Pro, and
workspaces in the bookmarks pane in a web
browser windows sidebar or the Go menu.
Include Bonjour: List Web server announced via
Bonjour.
Include DEVONthink: List bookmarks from open
DEVONthink databases. The bookmarks are
retrieved when DEVONagent Pro starts up. Since
they are cached, they remain available even when
DEVONthink isn't open.
Include Workspaces: List workspaces.

SEND EMAIL
Choose if you want DEVONagent Pro to send you
email using Apple Mail or using the built-in email
function. If you don't use Apple Mail, add your email
account details:
Server Name: Your SMTP server address
User: Your SMTP user name
Password: Your SMTP password
Port: The port to use; usually the default port
should work
SSL: Check if you want to use a secure connection
EMAIL FONT
Set the font used for styled emails (rich text). Check
Send styled emails to let DEVONagent Pro send
summary emails as RTF text. Read more about
sending summary email messages here.
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UPDATE
Change the settings on this tab to choose when
you want DEVONagent Pro to check for new
versions: never, on startup, daily, weekly or monthly.
DEVONagent Pro only checks for updates when the
computer is connected to the Internet.

Click Check Now to immediately check for a new
version.
Note: This feature is not available when
DEVONagent Pro was purchased through the
Mac App Store.
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MENU EXTRA
In this chapter:

DEVONagent Pro runs the query and shows the
results in the menu.

DEVONagent Pro adds a menu extra to the righthand side of the menu bar that allows you to enter a

A colored bar in the search field shows search
progress.

query and search run at any time from the menu bar.

Point with the mouse at any result to show a
tooltip with a preview and a text summary.
Click the result to open it in DEVONagent Pro or
your default browser. See also p. 60ff
Hold the ⌥ or ⌘ modifier key to open results in the

It looks similar to the Spotlight menu and works
pretty much the same way:
Choose a search set or plugin from the magnifying
glass pop-up menu.
Enter your query.
Hit ↩ or Enter.

background.
Drag results to the Desktop or other applications.
Dragging to the Desktop creates bookmarks
(.webloc); dragging to other applications inserts
the web address.
Navigate through the list with the Up and Down
keys, press ↩ or Enter to open the result in your
browser.
Recall recent searches or recently used plugins or
search sets from the magnifying glass pop-up
menu.
Click the to clear your search.
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SCRIPTS
In this chapter:
Introduction
DEVONagent Pro's Scripts menu

66
67

Automator

68

DEVONagent Pro comes with a fully loaded
AppleScript dictionary and several Automator
actions that help you automate almost every
aspect of your DEVONagent Pro workflow. Use
the included scripts to perform regular tasks and
as templates for creating your own scripts and
Automator workflows.

INTRODUCTION
DEVONagent Pro features an AppleScript
dictionary and Automator actions that automate
the application and integrate it with almost every
other application supporting AppleScript and
Automator.

Note: By using folders named after applications
inside the '~/Library/Scripts/Applications'
directory, it is also possible to make scripts
application-specific. Such scripts will appear
at the top level of the global script menu when
the application they belong to is frontmost. This
removes clutter and shows only scripts that make
sense in the current application.
DEVONagent Pro does not come with scripts for
other applications, but you can use the global script
menu for creating application-specific scripts.
To activate the global script menu, do the following:
Open the AppleScript Utility (located in '/
Applications/AppleScript').
Check Show Script Menu in menu bar.
Uncheck Show Library scripts if you only want to see
the scripts you have installed yourself.
To install your own scripts, copy them into the
folder '~/Library/Scripts'. You can use subfolders to
structure them in any way you like.

EXAMPLE SCRIPTS
To make it easier for you to start using and
writing scripts, we deliver a slew of scripts with
DEVONagent Pro that you can access in the Scripts
menu (which shows a stylized S symbol as its title
instead of the word Scripts). These scripts interact
directly with selected items, the currently displayed
webpage or a window. All scripts delivered with
DEVONagent Pro are useable in your daily work
and don't require modification.
INTEGRATING OTHER APPLICATIONS
In addition to the scripts that you use inside
DEVONagent Pro, OS X features a global script
menu that allows you to access certain scripts from
any application on your Mac, e.g., your web browser
or Apple Mail. When activated, the global script icon
appears at the right side of the menu bar (like other
menu extras such as the AirPort signal strength or the
Spotlight icon). It appears with a black stylized S icon.

DEVONAGENT PRO'S DICTIONARY
DEVONagent Pro includes a large dictionary with
commands, objects, and methods you can use for
writing scripts that interact or extend DEVONagent
Pro. To view the dictionary, open the Script Editor
application (by default located in '/Applications/
AppleScript'), select File > Open Dictionary and
choose DEVONagent Pro in the window.
You can also add DEVONagent Pro to your Script
Editor library. Select Window > Library, click the +
button and choose DEVONagent Pro. This way you
keep DEVONagent Pro's dictionary at hand.
LEARNING APPLESCRIPT
This documentation is not an AppleScript language
guide. Please refer to Apple's AppleScript website,
other online resources, or introductory and
reference books for more information on the
AppleScript language. Here are some links for you:
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The Ultimate Beginner's Guide to AppleScript
MacScripter
ScriptWeb
TECsoft Hands-On Trainings
Scripting Matters Trainings
AppleScript for Absolute Starters (free PDF book)
AppleScript: The Missing Manual
AppleScript: The Definitive Guide

DEVONAGENT PRO'S SCRIPTS
MENU
The internal scripts menu of DEVONagent Pro,
located to the left of the Help menu, gives you access
to pre-made scripts that extend DEVONagent
Pro with additional, more specialized commands
and functions. They are only visible from inside
DEVONagent Pro.

Of course, you can easily modify all these scripts
using AppleScript Editor, and the workflows using
Automator. And you can add your own scripts
and workflows--located in '~/Library/Application
Support/DEVONagent Pro/Scripts'--to the menu.
You can open this folder in the Finder using Scripts >
Open Scripts Folder.

Caching: All scripts in this menu are cached and
therefore their properties are persistent until you
quit and relaunch the application or DEVONagent
Pro automatically updates the menu, e.g. after
adding or removing scripts.
Note: If you have modified the contents of
the script menu and want to go back to the
default set, delete the Scripts folder in "~/
Library/Application Support/DEVONagent/".
DEVONagent Pro will recreate this folder,
including it's content, the next time you launch
the application.
SCRIPTS INTERACTING WITH OTHER
APPLICATIONS
Email Current Page (Mail): Creates a new message
in Apple Mail with the currently displayed
webpage attached as webarchive. Webarchives
contain the HTML code of the page including all
embedded elements that are necessary to display
them.
Email Current URL: Asks for an email address
and sends the URL of the currently displayed
webpage by email to this address. This script
does not use Apple Mail, but sends the message
directly via the messaging framework of OS X. It
requires that you have set up at least one email
account correctly in Apple Mail.
Email Results (Mail): Creates a new email in Apple
Mail with the abstracts of all results in its body.
Post to del.icio.us: Posts the selected items as
bookmarks to del.icio.us.
Post to Twitter: Posts the selected items to
Twitter.

Keyboard shortcuts: If you want to add keyboard
shortcuts to scripts in this menu, either use
the System Preferences or add the shortcut
description to the file name of the script in "~/
Library/Application Support/DEVONagent Pro/
Scripts" or "~/Library/Scripts". Example: "eMail
Current URL (Mail)___Cmd-Alt-M.scpt". The naming
convention is three underline characters followed
by the shortcut description. "Cmd" stands for the
⌘Command, "Alt" for the ⌥Option, "Ctrl" for the
⌃Control, and "Shift" for the ⇧Shift keys.
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SCRIPTS WORKING WITH IMAGES

SCRIPTS FOR THE TOOLBAR

Download Embedded JPEG Images: Downloads
all JPEG images embedded into the currently
displayed page to the default download location

By default this contains no scripts. Add your own
scripts here and also add them to the toolbar of
search and browser windows using View > Customize

via the download manager.
Download Linked JPEG Images: Downloads all
JPEG images linked from the currently displayed
page to the default download location via the

Toolbar.

download manager.
Open Linked JPEG Images in Tabs: Opens all JPEG
images linked from the currently displayed page
in separate tabs, then closes the current tab.
Open Linked JPEG Images: Opens all JPEG images
linked form from the currently displayed page in
separate web browser windows.
SCRIPTS WORKING WITH PAGES AND RESULTS
Download Objects of Results: Downloads all
found objects of the frontmost search window.
The search needs to be run with an active scanner
returning objects, e.g. Embedded Images.
Convert Results to RSS: Creates an RSS feed
file for the found or selected results and puts
it into ~/Sites/rss. Enable web sharing to easily
view your feeds locally using your web browser
by browsing to, e.g., "http://127.0.0.1/rss/
mysearchset.rss".
File Results in DEVONthink: Files new results
in DEVONthink. One group is created for each
search set/query. This script can is used as a
search set action.
Speak Titles of Results: Speaks the titles of the
found or selected pages.

SCRIPTS ARRANGING WINDOWS
Open last Safari session: Opens the last Safari
session in DEVONagent Pro.
Browsers Side-by-Side: Arranges the currently
open web browser windows side-by-side.
Tile Browsers: Arranges the currently open web
browser windows tiled to 800 pixel width.
Combine Windows: Combines the currently open
web browser windows as separate tabs in one
window.
Windows to Full Screen: Resizes all web browser
windows to full screen.

AUTOMATOR
DEVONagent Pro also comes with a bundle of
integrated Automator actions you can use to create
your own Automator workflows.
To see which actions DEVONagent Pro provides,
open Automator and select DEVONagent Pro in the
applications list on the left hand side. If you do not
see DEVONagent Pro in the Library list, use View >
Arrange Actions by > Application. Select any action
to show a short description about what the action
does, and have a look at Automator's built-in help to
learn more about how to create a workflow.
Note: Cannot find the Automator action you need
for your workflow? We're open to suggestions!
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PLUGIN DEVELOPMENT
In this chapter:
Creating Your Own Plugins
XML and JSON Keys

STEP 2
69
71

Choose File > New Plugin, paste the copied link, and
replace 'Test' with '_agentQuery_'.

DEVONagent Pro comes with a long list of readyto-use plugins for popular search engines. However,
you easily can write your own plugins to query your
favorite search engine. Here is all what you need.
The tutorial gives you a jump-start on how to write
your own plugins for DEVONagent Pro, e.g., for
integrating a search engine we haven't thought
of yet. And the XML and JSON keys descriptions
explain all the XML tags/JSON keys you can use in
developing the perfect plugin.

CREATING YOUR OWN PLUGINS
Do you have one or more favorite websites you
would like to search using DEVONagent Pro?
This document shows you how to create an XML
plugin for DEVONagent Pro. It is a step-by-step
tutorial that guides you through a real, practical
example--one that is found in the list of plugins of
the application.
It would be good to also have a look at the Keys
sectionof this chapter. This describes the XML
keywords in nitty-gritty detail.
DEVONagent Pro comes with an integrated plugin
assistant that makes creating your own XML-based
plugin convenient and easy. Let's create a simple
plugin from scratch in six steps.

Enter a name and description (useful but not
necessary). The Search Engine radio button is
automatically selected by DEVONagent Pro.
The '_agentQuery_' placeholder is where
DEVONagent Pro inserts the search term when
using the plugin. The '_agentOffset_' placeholder,
which is used by DEVONagent Pro to jump from
result page to result page, is automatically inserted
instead of the '10' of the '&next=' parameter after
clicking the Add button.
STEP 3
Let's test the plugin. In this case, the created plugin
is fully functional but is causing unnecessary traffic
and might return unexpected results. Therefore,
select any 'www.ipl.org' URL in the log and choose
Exlude Domain in the contextual menu. This excludes
all pages on ipl.org from becoming possible results.

STEP 1
Open a web browser window for www.ipl.org in
DEVONagent Pro or any other web browser. Then
search for 'Test' and copy the 'Next >>' link leading
to the second results page.
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STEP 4
Retry the test. In the log you can see that
DEVONagent Pro uses now 27 links per page
returned by IPL. But not all of them are actual
results, therefore we could exclude additional, static
URLs like:
ischool.syr.edu
ischool.uw.edu
theipl.wordpress.com
theipl2blog.wordpress.com
twitter.com/theipl
www.delicious.com/TheInternetPublicLibrary
www.diigo.com/user/Theipl2
www.facebook.com/pages/Internet-Public-Library
www.ipl.org
www.ischool.drexel.edu
www.ischool.pitt.edu
www.ischool.utexas.edu
www.myspace.com/internetpubliclibrary
www.youtube.com/iplcommunity
Or we could have a closer look at the results page
and its HTML source. Just double-click on the
results page in the log to open a browser window,
then switch to the HTML source. All unncessary
links are part of the footer, right after "Connect
With Us On". Therefore it's sufficient to add this
snippet to the plugin's code:
<key>LinksEnd</key> <string>Connect With
Us On</string>

Retry the test once again. Finally DEVONagent Pro
uses 10 links per page as expected.

STEP 5
Finally, uncheck all operators since IPL does not
support them.

That's it!
In other cases, you might also want to look at the
source of the plugin and validate the values for
'Start', 'OffsetPerPage', and 'ResultsPerPage', or add
'LinksMatching' definitions etc. Site-specific search
engines may also require 'TitleStart'/'TitleEnd',
'TextStart'/'TextEnd', 'DateStart'/'DateEnd',
'NoTopics', or 'CrawlDelay' definitions. See also p.
71ff
In addition, DEVONagent Pro may not always
be able to insert the '_agentOffset_' and
'_agentNumber_' placeholders automatically. You
might have to do this on your own; otherwise, only
the first results page is used.
FINETUNING
We now have a working plugin for IPL. While we
might have received links, we didn't necessarily get
good data. You can check both the pages and digest
panes in the search window to fine tune your plugin.
If DEVONagent Pro extracts too much data from
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the result list pages, you can use the following keys
to tell the software what constitutes a result link
and what doesn't.
1. TitleStart and TitleEnd: Extract the title of the
article.
2. TextStart and TextEnd: Extract the article text.
3. DateStart and DateEnd: Extract the article's
date.
4. NoTopics: Suppress common topics that always
occur for any search on a site.
5. PostScan: Scan the results for the string you
where searching for.
To determine values for these parameters, you
will need to look at the source code of a couple of
articles, and try to find strings that can be used for

these keys. When looking at the topics in the digest
pane after you've done your searches, you can set
the 'NoTopics' list. Any word that should not be
included as a topic can be added to this list.
CONGRATULATIONS
With the steps described in this tutorial, you should
be able to go through the steps of writing a plugin
yourself. With a bit of practice, it is possible to write
an optimized plugin that will deliver good results
for DEVONagent Pro to work with. It might help to
look at the additional plugins that already come with
DEVONagent Pro before designing your own plugin.
And remember: If you think your plugin is great for
others, please share it with us!

XML AND JSON KEYS
XML-based plugins use Apple's ".plist" file format; therefore, it's possible to edit them using Property List Editor
or any text editor like TextEdit, SubEthaEdit or Xcode/ProjectBuilder. JSON-based plugins are simple text files
that you can also edit using any plain text editor.
DEVONagent Pro loads all plugins inside its application package or stored in the folder "~/Library/Application
Support/DEVONagent Pro/Plugins". If DEVONagent Pro is not able to load a plugin, the file is logged to the
console. You can also place aliases or symbolic links to plugins here.
LOCALIZATION
The following XML and JSON plugin keys can be suffixed with a language identifier to use language-specific
search engines: EngineUrl, EngineNextUrl, KeywordsUrl, and NextLinkName. Language identifiers are: DE, DA, NL,
ES, HU, FR, IT, CS, PT, PL, SV, FI, EN, NO, RU, EL, AR, and HE.
Example: A URL in the key EngineUrl_DE is used to target the German variant of a search engine.

DEVONagent Pro 3.10 Documentation, page 71

NECESSARY KEYS
Name: [string or dict] The name of the plugin. Example: "BBC News".
Info: [string or dict] Information containing name, version and copyright. Example: "BBC News Plugin 1.0 ©
2003--2005 DEVONtechnologies".
Description: [string or dict] Describes the functionality of the plugin. Example: "Queries the BBC news
archive."
Version: [string] The version number (format major.minor). Example: "1.0".
Identifier: [string] Unique identifier (format domain.name.plugin). Example: "com.devontechnologies.bbcnews.plugin".
EngineUrl: [string or array of strings] The Internet address(es) of the search engine. The strings
"_agentQuery_", "_agentNumber_" and "_agentOffset_" are replaced by the search term, the number
of results and the offset of the current page. "_agentNumber_" and "_agentOffset_" are optional.
'_agentLanguage_' is replaced by the language used by the plugin (ISO 639 two-letter codes).
Can contain the placeholders "_agentUser_" and "_agent_Password_" for HTTP authentification.
Example: "http://www.bbc.co.uk/cgi-bin/search/results.pl? tab=news&amp;start=_agentOffset_&
go=homepage&amp;q=_agentQuery_".
Note: Name, Info and Description can be localized. Specify a dictionary containing key/string pairs for
multiple languages. The key contains the name of the language, e.g., German or English.
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ADDITIONAL KEYS
CrawlDelay: [float] Minimal delay between two requests sent to the same server.
DateEnd: [string or array of strings] String marking the end of the range of the HTML source code containing
the date of a page.
DateStart: [string or array of strings] String marking the beginning of the range of the HTML source code
containing the date of a page. Note that "DateEnd" is optional if "DateStart" is specified. Useful if server
provides no dates or the wrong dates (for example a Usenet query using Google).
EncodingPage: [string] Default character encoding for result pages (default: Latin-1). Examples: "ISO-8859-1",
"UTF-8", "ISO-8859-2", "Shift-JIS".
EncodingUrl: [string] Character encoding for search term "_agentQuery_" (default: Latin-1). Examples:
"ISO-8859-1", "UTF-8", "ISO-8859-2", "Shift-JIS".
EngineNextUrl: [string or array of strings] The Internet address(es) of the search engine(s) used
for subsequent pages (if not identical to the address of the first page). The strings "_agentQuery_",
"_agentNumber_" and "_agentOffset_" are replaced by the search term, the number of results and the offset
of the current page. "_agentNumber_" is optional.
EngineRelated: [string] Defines a URL for a 'see also' function of the search engine.
EngineSite: [string or array of strings] Defines (a) (sub)domain(s) with or without a path to search.
DEVONagent Pro uses an appropriate common search engine to perform the search. Example:
'devontechnologies.com/products/'.
ExcludeLinksNamed: [array of strings] Defines an array of names of links which should be skipped.
FileTypes: [string] List of all supported file types: html, feed/rss, text, pdf, OpenOffice, Microsoft/Word, RTF or
all. Default is 'all'.
FilterLanguage: [Boolean] Enable or disable filtering by language.
FilterSimilarPages: [Boolean] Enable or disable DEVONagent Pro's Similar Pages filter (default: true).
FollowLinks: [Boolean] Enable or disable DEVONagent Pro's Follow Links option (default: true).
GoogleTags: [Boolean] Defines whether 'googleon'/'googleoff' tags should be supported.
HTTPShouldHandleCookies: [Boolean] Defines whether cookies should be handled by HTTP or not.
Keyword: [string or array] One or more unique keywords used for quick searching (like "Mozilla Keywords")
by entering the keyword followed by the search term in the URL field of the browser window.
KeywordsUrl: [string] Defines an alternate URL used for the Mozilla-like keywords in the browser's address
bar.
LinksEnd: [string or array of strings] String marking the end of the range of the HTML source code containing
the links to use (any position after the last link to use but before the next link). Example: "-- Footer Area --".
LinksMatching: [string or array] Only links of result pages matching this string or these strings are used
(prefix/suffix * wildcards are supported). Examples: "*news.bbc.co.uk/*".
LinksNotMatching: [string or array] Only links of result pages not matching this string or these strings are
used (prefix/suffix "*" wildcards are are supported).
LinksStart: [string or array of strings] String marking the beginning of the range of the HTML source code
containing the links to use (any position before the first link to use and after the last link to ignore). Note that
"LinksEnd" is optional if "LinksStart" is specified. Example: "search results for".
LoginPost: [string] Defines the optional HTTP POST parameters. Usage like "Post". Can contain the
placeholders "_agentUser_" and "_agent_Password_".
LoginURL: [string] The address used to log into a website. Usage similar to "EngineUrl". Can contain the
placeholders "_agentUser_" and "_agent_Password_".
NextLinkStart: [string] Defines the start of the range for the 'next results page' link.
NextLinkEnd: [string] Defines the end of the range for the 'next results page' link.
NextLinkName: [string] Defines the name of the link for the 'next results page' (instead of having to use
NextLinkStart/End).
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NoTopics: [array or string] Array of strings or string containing separated words to ignore in the topics list.
Add site specific words here.
OffsetPerPage: [integer] Increase for "_agentOffset_" after every page (default: 1).
Operators: [integer] Bitmap describing the possibilities of the search engine and the required syntax (see
below). The default value is 59 (1+2+8+16+32), meaning that AND, OR, NOT, phrases and parenthesis are
supported.
OperatorsDictionary: [dict] A dictionary containing key-string pairs to convert the name of operators to a
different name required by the search engine. Possible keys are "AND", "ANDNOT", "OR", "NOT", "XOR",
"NEAR", "BEFORE", "AFTER", "-".
ParseLinks: [Boolean] Parse and unify links of common search engines (Google, Yahoo, Alltheweb, Altavista &
Ask Jeeves) (default: false).
Post: [dict or string] Send a HTTP POST instead of a HTTP GET action using this form data. Note: The strings
of the form data can contain "_agentQuery_" and "_agentNumber_" placeholders.
PostScan: [Boolean] Tell DEVONagent Pro to check if the retrieved pages match the search term (true), or to
accept all (false) pages (default: true).
ResultsPerPage: [integer] Number of results per page and maximal value for "_agentNumber_" (default: 10).
RequiresCrawling: [Boolean] Marks this plugin as needing crawling.
RequiresThumbnails: [Boolean] Marks this plugin as using only thumbnailed links. Crawling needs to be
skipped.
RoundResultsPerPage: [integer] Always round number of results per page ("_agentNumber_") to multiples of
this value (default: 10).
ScanTerm: [string] String specifiying a term used to filter results (e.g. instead of or in addition to the secondary
query defined by the user).
SkipsCrawling: [Boolean] Marks this plugin as skipping crawling.
Start: [integer] The initial value for "_agentOffset_" (default: 0).
StripTags: [array] Array of strings marking HTML tags defining blocks to strip.
TextEnd: [string or array of strings] String marking the end of the range of the HTML source code containing
the relevant text of a page. "TextStart" is optional if "TextEnd" is specified.
TextStart: [string or array of strings] String marking the beginning of the range of the HTML source code
containing the relevant text of a page. Note that "TextEnd" is optional if "TextStart" is specified. Useful if
you're querying a specific site (all results have the same layout) to skip headers, footers or navigation of a
page. This improves plain text display, digest and summarization.
TextTags: [array] Array of strings marking HTML tags defining blocks to convert to text.
Timeout: [integer] Sets the timeout for requests; default is 60 seconds.
TitleEnd: [string or array of strings] String marking the end of the range of the HTML source code containing
the title of a page.
TitleStart: [string or array of strings] String marking the beginning of the range of the HTML source code
containing the title of a page. Note that "TitleEnd" is optional if "TitleStart" is specified. Only useful if all
results have identical or no titles (for example a Usenet query).
UseListingResults: [Boolean] Treat the returned pages as results (and not as pages linking to the results). All
"Links..." keys are unused in that case.
UserAgent: [string] Custom HTTP user agent string.
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JSON AND XML-SPECIFIC KEYS
ResultsKeyPath: [string] The JSON key path to the results in the JSON output.
DatesKeyPath: [string] The JSON key path to the result dates relative to ResultsKeyPath.
LinksKeyPath: [string] The JSON key path to the links relative to ResultsKeyPath.
TitlesKeyPath: [string] The JSON key path to the titles relative to ResultsKeyPath.
DescriptionsKeyPath: [string] The JSON key path to the descriptions relative to ResultsKeyPath.
ContentsKeyPath: [string] The JSON key path to the contents relative to ResultsKeyPath.
ThumbnailsKeyPath: [string] The JSON key path to the thumbnails relative to ResultsKeyPath.
NOTES
Operator Bitmap: The following table gives you the necessary values for calculating the operator bitmap for
the "Operators" key (see above):
0 [value: 1]: Supports AND operator
1 [value: 2]: Supports OR operator
2 [value: 4]: Supports XOR operator
3 [value: 8]: Supports NOT operator
4 [value: 16]: Supports "" phrases
5 [value: 32]: Supports () parenthesis
6 [value: 64]: Supports NEAR operator
7 [value: 128]: Supports AFTER operator
8 [value: 256]: Supports BEFORE operator
9 [value: 512]: Supports NEXT operator
11 [value: 2048]: Use ANDNOT instead of NOT or '-'
12 [value: 4096]: Convert search term to lower case
13 [value: 8192]: Convert search term to upper case
14 [value: 16384]: Engine scans for any word by default (not for all words) without an explicit operator
15 [value: 32768]: Use AND/NOT instead of '+'/'-'
16 [value: 65536]: Use | instead of OR
17 [value: 131072]: Supports OPT operator
LinksStart, et al.: 'LinksStart', 'LinksEnd', 'LinksMatching', and 'LinksNotMatching' are three different ways to
specify interesting links of a page. Specify none, some, or all of them depending on the search engine you are
accessing. The more you specifiy, the higher the chances are that the plugin will still work after the structure of
the HTML code or the links changed. First DEVONagent Pro retrieves links using 'LinksStart'/'LinksEnd', then it
filters them using 'LinksNotMatching', and finally it matches them against 'LinksMatching'.
Links vs. Results: 'LinksStart'/'LinksEnd, 'LinksMatching', and 'LinksNotMatching' are used for pages listing the
results, 'TextStart'/'TextEnd', 'TitleStart'/'TitleEnd', and 'DateStart'/'DateEnd' are used for the result pages.
FollowLinks: 'FollowLinks' applies to result pages only; the links of pages listing results are always used!
No case: All string values are case insensitive.
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TROUBLESHOOTING
In this chapter:
DEVONagent Pro behaves irrationally
Problems interacting with DEVONthink

76
76

DEVONagent Pro was created with robustness in
mind. But any computer hardware and software
can write defective data or destroy files. If you have
trouble with this application, please refer to the
methods below, and also review the FAQ.

DEVONAGENT PRO BEHAVES
IRRATIONALLY

If this does not help, try deleting DEVONagent Pro's
preferences files located in '~/Library/Preferences'
and starting with 'com.devon-technologies.agent'.
Access your LIbrary folder by visiting the Go menu
in the Finder with the ⌥ key held down.
STRANGE BEHAVIOR OF TABS
With Zooom/2 installed, tabs in tabbed windows
behave stragely, e.g., close by just hovering the
cursor over the tab. Another effect of Zooom/2 are
scrolling problems. Disabling Zooom/2 solves the
problem.

No software on this planet is bug-free. If an
application behaves irrationally, there is a good
chance that your have just found a bug. But there

PROBLEMS INTERACTING WITH
DEVONTHINK

may be another: The application package could have
become damaged, e.g, during an update or through
a bug in an unrelated piece of software on your
computer.

DEVONagent Pro uses OS X's Services internally
to transfer data to DEVONthink. If DEVONagent
Pro beeps when you try to transfer data to
DEVONthink, the most likely reason for this
problem is that there's something wrong with the
Services.

If DEVONagent Pro crashes or you have found a
bug, please send us a bug report.
STRANGE APPLICATION BEHAVIOR
If something happens like the following
menus disappearing or silently refusing to do
anything,
windows showing graphical artifacts,
or applications not opening or opening with
strange error messages,

You can use the third party application Service
Scrubber to try and modify this behavior; Service
Scrubber should allow you to enable/disable
services, rename them, or give them new keyboard
shortcuts. Some of these modifications, however,
can lead to communication problems between
DEVONthink and DEVONagent Pro. Restore to the
default settings to enable the DEVONagent Pro/
DEVONthink link again.

please try to trash the application package. Then
empty your web brower's cache, re-download the
software in question, and re-install it. In many cases
this cures the problem.
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FAQ
In this chapter:
General questions
Release schedules, Mac OS X, and Windows

77
77

Purchasing
Mac App Store
Your software license
Product-related questions
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Do you have questions regarding our licensing
policy, our products in the Mac App Store, or
specific questions about DEVONagent Pro?

GENERAL QUESTIONS
Do you have any job opportunities? Yes, we may. Please visit our Work @ DEVONtechnologies page for more
information about current open jobs at DEVONtechnologies.
Can I be a beta tester? Maybe. Our beta tester selection process is very deliberate; we try and select our beta
testers carefully so that we're not wasting anybody's time, yours and ours. We're looking for people who can
provide us with feedback quickly and clearly, who use different hardware and software from our other testers,
and who are willing to send us their personal data if it's needed for debugging.
If you want to be a beta tester, the best way to catch our eye is to be active in our user forums. We often ask
active participants on the user forums if they can help us test particular features and new products. You can, of
course, simply contact us.
Is the documentation available in my language? The online and PDF documentation is only available in English
at the moment. Localizing documentation and other text-intensive materials to Deutsch, Francais, etc. is costintensive and error-prone so that we have decided to concentrate our resources on developing stable, robust,
and feature-rich software. We will have localizations of the online help etc. as soon as we feel we have the
necessary resources.
Where does the name DEVONtechnologies come from? "Devonian (after Devon County, England), the
geologic period from 410 to 360 million years ago. Also called the Reptile Age or Age of Fishes. First amphibians
appeared on the land, that until then was only inhabited by trees and other plants -- it was the departure into a
new age." Named after the Devonian period, the DEVONtechnology marks the departure into a new age of data
processing.
Note: Ray Troll has even created songs and other art about this extremely important evolution step.

RELEASE SCHEDULES, MAC OS X, AND WINDOWS
When is the next release coming We try not to announce precise timelines or feature lists for future releases,
as we are a small software company with limited development resources; if one of us should happen to get
the sniffles, or if there are other outside factors we need to devote our limited time to, it can easily impact our
intended development schedules.
In planning releases, we try to strike a balance among:
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responding to customer requests,
the needs of our partners,
supporting new operating systems features,
providing consistent features across the product line,
working efficiently within the structure of the code, (similar features often get handled at the same time),
various business needs.
We cannot make any assumptions on how those various factors will impact our daily workflow; in fact, it's
often impossible to predict the final release date accurately when we start new projects. We try to plan our
releases with a long term perspective so that they ultimately serve the needs of our customers, even if they
don't necessarily get in everyone's favorite feature request every time.
Why are your applications not compatible with my pre-release version of Mac OS X? In the past, we've noted
that compatibility issues with a new major release of the operating system are usually resolved by Apple in the
final stages before its release, and don't require any action on our part. If you are already using a pre-release
version of Mac OS X, please check if our applications work with a newer pre-release, or wait until it reaches
the release candidate status. We will then make all necessary adjustments for making our apps run on the first
official release of the new version of Mac OS X.
Any chance of a Windows versions of your products? We're very commited to Mac OS X and the superior
Cocoa environment. For most of our applications, porting them to Windows would take longer than it would
to rewrite them from scratch on the Mac. If you need to use Windows software but still don't want to miss our
products consider running Windows on a Mac.

PURCHASING
Note: If you purchased or plan to purchase DEVONagent Pro in the Mac App Store please click here to learn
more about the differences between our shop and the Mac App Store.
How do I purchase an upgrade? Please use DEVONagent Pro > Check Upgrade Options to find out what you need
to upgrade and how much the upgrade is for you. If this option is not available in your copy of DEVONagent Pro
this application might not be upgradable. Please visit the Upgrade Assistant on our web site instead.
What is your policy on software updates? Usually, all minor updates ('dot updates', such as version 1.2 to 1.3)
to our applications are free and require neither purchasing an upgrade nor requesting a fresh license code. We
charge for major upgrades, though, such as version 1.x to 2.x. If you purchased your license in our online shop
within a reasonable time frame before a paid upgrade release (between 30 days and 6 months, announced on
our website), we will provide you with a free upgrade. If you purchased this application on the Mac App Store
click here.
Can I get the bundle discount also later? Bundles are cheaper than multiple single licenses because a bundle
means less fees for the shop provider. But we grant the bundle discount under certain circumstances. Please
contact our sales staff if you purchased one of the bundled produts within the last two weeks.
Do you give a discount to students and educators? Yes, we give 25 percent off the regular price of
DEVONthink, DEVONagent, DEVONnote and the Infoworker's Bundle to students and educators. We also give
volume discounts to institution or faculties. Please visit our Students, Educators and NPOs page.
Do you offer NPO licenses? Yes, we offer free licenses to non-profit organizations (NPOs) in the sense of
charities. Learn more about our NPO program.
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Can I use your software on multiple computers? Yes, our license explicitly allows one and the same person to
use our application non-simultaneously on multiple Macs. So, for example, if you install one of our products on a
laptop, your office Mac, and your home Mac, you may do so as long as you only use one of them at a time.
I have no credit card. How can I purchase your software? We are selling currently through the online sales
agent Share*It to keep our administration as lean as possible. If you don't have a credit card, you can also pay via
PayPal or by purchase order, wire transfer, or even cash. See our online shop for more details.
In addition we are also selling some of our products through the Mac App Store. Please open the App Store
application on your Mac to learn more about which payment options Apple offers.
Can I have more time for evaluating your apps? No problem. We happily give out 30 day licenses for evaluation
purposes. Choose Help > Support Assistant to request a 30 day trial extension. This option is not available e.g. in
DEVONagent Express.
Why haven't I received my license code(s)? If you have purchased your license in our online shop and if there
have been no technical problems on our side, your license codes have been sent out to you immediately after
your purchase. Sometimes, however, they get stuck in spam protection filters (either yours or your ISP's).
Please, check your spam protection filter, and if you cannot find the license codes there, use Help > Support
Assistant to get them resent to you. If this also doesn't work, please contact us and we'll try to get your license
codes to you as quickly as possible.
Where can I buy a 1.x license code, e.g. for use on Mac OS X 10.4? License codes for legacy versions are no
longer available in our shop but even the latest license codes are always backward-compatible: You can use
a version 2.x license code also for version 1.x of the same product. To use a legacy product simply purchase a
license for the most recent version of the product in our online shop and use it with your legacy software.

MAC APP STORE
How do apps purchased in the Mac App Store differ? The Mac App Store requires so-called "sandboxing" of all
apps. Sandboxing puts the apps into a closed environment and restricts access to e.g. files, networks, printers,
etc. Therefore many apps sold through the Mac App Store have less features than their counterparts available
outside of the Mac App Store.
Do you charge for updates in the Mac App Store? No, updates are generally free in the Mac App Store (and we
don't charge for them outside of the Mac App Store, too).
Why are updates available always later that in your shop? All apps sold through the Mac App Store
are reviewed by Apple before being released. Therefore new versions appear immediately on the
DEVONtechnologies website but have to pass Apple's review before appearing also in the Mac App Store.
Do I get a license code? Apps purchased in the Mac App Store do not come with a license code but are "signed"
directly before downloading for your iTunes account.
Do you offer bundles in the Mac App Store? No, bundles are not supported by the Mac App Store.
How can I upgrade apps purchased in the Mac App Store? By Apple's rigid rules you couldn't. Upgrades are
simply not available on the Mac App Store and upgrade offers outside of the Mac App Store are not allowed. In
some of our apps there may be an upgrade option still available, though. Check the Read Me to see if this is the
case for you.
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Can I get a refund? We freely refund licenses purchased in our own shop. For apps purchased in the Mac App
Store we don't have access to the refund mechanism. Please contact Apple's Mac App Store support for a
refund.

YOUR SOFTWARE LICENSE
Why does DEVONagent Pro not accept my license code? When you enter your license code and the 'Register'
button stayes greyed out, try to enter ALL details, including your name and organisation, EXACTLY as they
appear in our e-mail. Best practice is to copy-and-paste name, organisation (if entered) and license code
from our email into the appropriate fields of the registration dialogue window. Also, please check if you have
obtained the correct code for the correct edition of your software (e.g., a DEVONthink Pro license code will
not work for DEVONthink Pro Office and vice versa) as well as version (DEVONthink 2.x will not accept a 1.x
license code).
I have lost my license code. How can I retrieve it? Use Help > Support Assistant to open the Support Assistant
which has an option to get your license code resent to you. Alternatively visit the support area on our web site.
Does my license code work also for an older version? Yes, it does. All our license codes are backwardcompatible to legacy versions of the same product and edition.
Why do I have to enter my license code again? You only have to re-enter your license code after a complete
reinstall of your system without a backup of your home folder or when the license code file has been
deleted, e.g. by a preferences cleaner app. The license code is stored in a preference file in '~/Library/
Preferences' (where ~ is your home folder). As long as this file is intact, you'll NEVER have to enter your license
code again.
Why does my DEVONagent Pro 1.x license not work anymore? DEVONagent Pro with version numbers
greater than 1.x are paid upgrades. To use them you may need a new license code. Please use DEVONagent Pro >
Check Upgrade Options to find out what you need to upgrade and how much the upgrade is for you.
Why does your application say that it expired? When we release a public beta of one of our applications, we
remove the usual trial restrictions but make it expire at the end of the beta period. A new public beta or the final
release is, of course, available when this happens.
Please simply visit our Download page, download a newer version that the one you have installed, and replace
your copy with the newer one. FPlease first move the old application to the trash, then move the new one into
its place.
Note: Your license code will, of course, NEVER expire.

PRODUCT-RELATED QUESTIONS
All frequently asked questions specific to DEVONagent Pro are located in the appendix. Please continue
reading on the following pages:
FAQ specific to DEVONagent Pro
Troubleshooting tips and tricks
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TECHNOLOGY
In this chapter:
General Concept
Features

81
81

Structure
Applications

81
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All commercial DEVONtechnologies applications
are based on a proprietary AI technology, with
rock-solid database foundation that allow them to
manage large numbers of documents or knowledge
bits while analyzing them almost instantly at the
same time.

GENERAL CONCEPT
DEVONtechnology, on which all
DEVONtechnologies' applications are built, is a new
technology at the very beginning of its development.
DEVONtechnologies constantly improves the
technology and enhances it for more functionality,
efficiency, robustness and flexibility.
Development of the DEVONtechnology is a battle
on two main forefronts of information processing
technology. DEVONtechnologies is working hard
on unifying both the top-down and the bottomup AI concepts by imitating high-level functions
and simulating the basic functionality of natural
systems. This leads to highly functional, fast and
efficient AI systems that can be used in a great
variety of information processing contexts, such
as pattern recognition, signal processing and
information storage and retrieval.

FEATURES
The DEVONtechnology is a rock-solid foundation
suitable for a variety of completely independent
applications. Therefore it is ideal for the rapid
development of a huge range of new database-,

signal-processing- and language-analysis-driven
applications. The ability to deal with any kind of
digital data makes it extremely flexible.
The size of DEVONtechnology-based databases
can, depending on the type of data stored,
grow logarithmically and make indexing is
completely unnecessary. Also, applications based
on the DEVONtechnology improve themselves
continuously (the more data they handle, the better
the results), are language-independent and iron out
any irregularities by applying fuzzy logic.

STRUCTURE
The DEVONtechnology consists of a kernel and
several layers. Together they perform all the
underlying computing, from 'simple' data handling
to complex signal processing.
Kernel: The kernel is the foundation for all layers
and applications and is responsible for data
handling, semantic and associative data processing,
signal processing, fast statistic analyses and all
fuzzy algorithms. It has to be as fast, flexible, and
extensible as possible; it is 64-bit aware and uses a
generic, proprietary file format (see above) allowing
it to verify and repair low level data consistency,
featuring logarithmic growth of the database
and logarithmic speed decrease with increasing
database size. The DEVONtechnology kernel is
Unicode-aware, completely language-independent
and self-optimizing and self-organizing.
Layers: The layers form a shell around the kernel
and provide high-level functions for the applications
built on top of them. The database layer, for
example, is used to store and organize data and
supports all kinds of relations (1:n, n:1, n:n),
hierarchies and freeform databases. No indexing or
primary keys are required, strings can be unlimited
in size and it's possible at any time to extend the
range of pre-defined data types (Boolean, character,
float, double, signed, unsigned, string, date, time,
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blob, color, size, and point). Another layer, the XML
layer, makes it easy to handle XML code within the
DEVONtechnology; it has a very small overhead,
compared to DOM parsers or available XML
databases, requires no indexing and supports the
tight integration of other databases (and vice versa).

APPLICATIONS
Some of the most likely applications for the
DEVONtechnology are databases (knowledge
bases, expert systems, search engines, table-ofcontent-generators, instant data-mining), intelligent
agents, encryption, compression and archiving.
Other uses for DEVONtechnology may be chatbots, context-sensitive help, optical character

recognition (OCR), speech analysis, recognition
and synthesis, staticstics, thesauri and automatic
translations.
In particular, applications dependant on processing
human language, either written or spoken,
benefit from the flexible technology foundation.
So, DEVONtechnologies' main focus in the
development of new applications is in these areas:
databases, 'intelligent' agents, text and speech
analysis, statistics.
Look forward to see a great range of different
applications based on the DEVONtechnology.
A few have already been announced
on the DEVONtechnologies web site:
www.devontechnologies.com.
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Besides DEVONagent Pro, DEVONtechnologies
publishes a number of other commercial, shareware,
and freeware applications, and services that you
may be interested in.

OVERVIEW
DEVONtechnologies is focused on developing
innovative applications for finding, storing, and
organizing information. Our main objective is to
make complex yet flexible technology that is both
easy to use and lightning fast.
DEVONthink
DEVONagent
DEVONsphere
DEVONnote
All applications are based on the
DEVONtechnology, a powerful and solid core
unique to DEVONtechnologies. DEVONthink,
DEVONnote, DEVONsphere, and DEVONagent
are only the first of many more DEVONtechnologypowered applications to come.
Also, we publish useful freeware apps and services
that help you in your everyday work with your Mac.
NEWSLETTER & USER FORUM
Would you like DEVONtechnologies to keep you
informed about updates and new product releases?
Subscribe to the newsletter.

And don't forget to have a look at our very lively
user forum, where users of all skill levels meet to
discuss our applications, talk about our technology,
and exchange tips and tricks for DEVONagent Pro &
Co.

DEVONTHINK
Organize and work with all your documents,
bookmarks, email messages, text files, images, PDFs,
in one place, regardless where they originated.
Quickly capture data without interrupting your
workflow. DEVONthink's unique AI assists you in
getting the most out of your data collection.
Learn more about DEVONthink
Learn more about DEVONthink To Go for iOS
Check your upgrade options if you want to
upgrade to a higher edition
Check your upgrade options if own DEVONnote
and want to upgrade to DEVONthink

DEVONAGENT
DEVONagent Pro helps you search more efficiently
on the web. It searches multiple sources, frees
you from hunting for the really relevant results,
and gives you power tools for your research.
DEVONagent Express and DEVONagent Lite (free)
make searching the web as easy as using Spotlight.
Search Google, Bing, YouTube, Facebook, Twitter,
even the Mac App Store, right from the menu bar.
Learn more about DEVONagent Pro
Learn more about DEVONagent Express
Learn more about DEVONagent Lite

DEVONSPHERE
Make your Mac smarter: Let DEVONsphere Express
keep track of related emails, articles on the same
subject, and similar web pages. Discover the hidden
connection between seemingly unrelated files.
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Learn more about DEVONsphere Express

DEVONNOTE
Your thoughts and ideas are valuable. DEVONnote
keeps them and provides you with unique tools and
artificial intelligence so that you can focus on things
that really matter: creating even more ideas.
Learn more about DEVONnote
Check your upgrade options if you want to
upgrade to DEVONthink

NEEDFUL THINGS
Search files on your hard disk, watch web cams,
create thumbnails, or access all your files and apps
from the menu bar. Reformat paragraphs in your
favorite word processor, do little calculations
anywhere you can type in text, or send text to your
Bluetooth-enabled mobile phone. And all this for
free.
Learn more about our freeware apps
Learn more about our freeware services
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GLOSSARY
Become familiar with these terms to get the most
out of working with DEVONagent Pro.
KEYBOARD SYMBOLS
⌘ The Command key, usually next to the Space bar.
⌥ The Option key.
⌃ The Control key (usually labeled with "ctrl").
⇧ The Shift key.
⇥ The Tab key.
↩ The Return key.

Alternative menu item: Some menu items have
less frequently used counterparts that are hidden
by default. Press the ⌥Option key when visiting
the menu or contextual menu to make them
appear.
Contextual Menu: The menu that appears when
you right-click, or click on something with the ⌃
Control key held, something; the contextual menu
gives you access to frequently used commands
that deal directly with the clicked object. See also
p. 38ff
Plugin: Modules that act as the connector
between DEVONagent Pro and search engines.
Each plugin is the interface for one or more
search engines. In addition, plugins can extend
DEVONagent Pro with other functionality, e.g.,
scanners. DEVONagent Pro knows two types of
search engine plugins: Cocoa-based (compiled)
plugins, and XML-based plugins that can be
created using the Plugin Assistant or using a
simple text editor. See also p. 87ff
Scanners: Plugins that act as filters for formal
criteria such as 'is a thumbnail gallery' or
'contains links to Word documents'. Scanners are
used to refine a search. See also p. 93ff
Search Window: A window in DEVONagent Pro
that lets you select a search set, type in a query,
start the search run, and view the search results.
See also p. 39ff
Topics: A list of words extracted by DEVONagent
Pro from search results--generally the most
important words in the found documents. Topics
can be selected in the search window to focus the
visualizer to this topic. See also p. 40ff
Visualizer: A graphic representation of topics
and their relationships. The graphic looks like a
'spider web,' with 'bubbles' representing each
topic. See also p. 40ff
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OPERATORS, QUERIES, SEARCH SETS
Boolean operators: Boolean operators are AND,
OR, and NOT. They are used to define how words
or parts of search terms relate to each other.
Example: 'steve AND jobs'. See also p. 17ff
Query: A 'question' sent to one or multiple search
engines through a search engine plugin. The
query (the question) is written in a formalized
style using search words, Boolean operators, and
parentheses. See also p. 17ff
Search engine: A computer that keeps an index
of documents or information and that can be
searched by providing it with a query. Search
engines are generally used through a web
browser. DEVONagent Pro emulates this humancomputer interaction through plugins.
Search results: A pool of documents or links to
documents, e.g., webpages or PDF documents,
returned by a search run.
Search run: The process of sending a query to one
or multiple search engines.
Search set: A set of parameters that defines how
DEVONagent Pro conducts a search run. Search
sets contain which search engine plugins shall be
used, which scanners shall be applied, and what
to do with the search results when the search run
is completed. See also p. 20ff
Search term: See above: Query. See also p. 17ff

FAQ (PRODUCT-SPECIFIC)
Is DEVONagent Pro an add-on to DEVONthink?
Although we sell DEVONagent Pro with
DEVONthink in a bundle, it is a stand-alone
application. Many of our customers use
DEVONagent Pro for their research work, but don't
necessarily archive the results in DEVONthink.
Can I write my own plug-ins for DEVONagent
Pro? Sure. The complete documentation on how to
make plug-ins for DEVONagent Pro is included in
DEVONagent Pro's online documentation.
Can I search my hard disk instead of the Internet?
Not with the current version of DEVONagent Pro,
no. However, our freeware application EasyFind

is able to preview found documents and highlight
occurrences in file names. And, of course, there is
still Spotlight.
How can I search already archived pages Open the
archive (Tools & Open Archive) and use the search
field there.
What advantages does DEVONagent Pro have
over Google & Co? The most important advantages
over web search engines like Google are:
DEVONagent Pro comes with an innovative
visualizer.
DEVONagent Pro can query multiple search
engines simultaneously.
Scanners look for certain kinds of webpages, e.g.,
pages with webcams, thumbnail galleries, videos,
etc.
DEVONagent Pro removes duplicate URLs/
webpages, advertisements, spam, and HTTP
errors.
DEVONagent Pro also removes similar pages on
demand.
DEVONagent Pro scans the current contents of
the pages; therefore, it doesn't return wrong
results from outdated search engine indexes
DEVONagent Pro supports more advanced
operators like NEAR, BEFORE, and AFTER
DEVONagent Pro can follow promising links
automatically.
DEVONagent Pro provides more useful and
complete summaries in the Pages tab and
complete digests based on selected/entered
topics or the used query.
You can easily find similar results ("See Also"),
archive results or transfer them to DEVONthink.
Why does DEVONagent Pro crash when displaying
PDFs? DEVONagent Pro can crash when trying
to display PDF files on Macs with Adobe Acrobat
installed. Acrobat's browser plugin is incompatible
to the web browser engine of both OS X and
DEVONagent Pro. Remove the Acrobat plugin from
"/Library/Internet Plug-Ins" and everything should
work as advertised.
Why does DEVONagent Pro crash when I
open a browser window or an archived page?
DEVONagent Pro uses Apple's WebKit as its
browser engine. When WebKit crashes it draws

DEVONagent Pro 3.10 Documentation, page 86

DEVONagent Pro with it into the abyss and there
is little we can do about it. So most DEVONagent
Pro crashes related to browsing are, in fact, WebKit
crashes. Please send us your crash log (in ~/Library/

How do I completely uninstall DEVONagent Pro?
To completely remove DEVONagent Pro from your
Mac, see the instructions in the Read Me.

Logs/CrashReporter/) if you want to know what
happened.

LIST OF SEARCH SETS
Search sets are sets of parameters and options that control which search engines are used for a search run,
which sites are crawled directly, what is filtered, and what is done with the returned results. DEVONagent Pro
comes with a number of example search sets to get you started:
Apple (Feeds): Crawls some RSS feeds (Downloads, PR and Hot News) provided by Apple.
Blogs: Queries plugins searching blogs.
Macintosh News (Latest): Crawls the most popular Macintosh news sites and feeds.
Macintosh News (More): Searches (not just crawls) the popular Macintosh news sites and feeds.
Marketing: Crawls more than 200 IT and Macintosh related news sites and feeds (the default query looks for
news related to DEVONtechnologies).
New Software: Crawls some software trackers and directories for new releases by DEVONtechnologies.
Web (Deep): Queries Bing, Exalead, Google and Yahoo plugins (up to 100 results per plugin).
Web (Deeper): Queries Bing, Exalead, Google and Yahoo plugins (up to 100 results per plugin) and follows
links (one level).
Web (Deepest): Queries Bing, Exalead, Google and Yahoo plugins (up to 100 results per plugin) and follows
links (maximum level).
Web (Downloads): Queries the Web plugin and scans the results for downloadable archives.
Web (Express): Queries the Web plugin (up to 60 results) in express mode (no filtering).
Web (Fast): Queries the Web plugin (up to 100 results), but does not follow links to return results as soon as
possible.
Web (Movies): Queries the Web plugin and scans the results for linked movies and videos.
Web (Thumbnail Galleries): Queries the Web plugin and scans the results for thumbnail galleries.
Start with the Web (Fast) search set for your first search runs, then use the Search Sets window to make your
own or adapt an existing one for your requirements. See also p. 20ff
To build your own search set consider buying DEVONagent.

LIST OF PLUGINS
Technically, plugins are collections of URLs and procedures that DEVONagent Pro uses to access search
engines on the Web. They are either written in Cocoa or in human-readable XML (plain text with special
syntax). In addition to simple HTML queries, DEVONagent Pro also supports and analyzes RSS, RDF, RSD, and
Atom feeds.
In the list below, you will find the associated quick search keywords in brackets. You use quick search keywords
to send a query to a plugin directly from the address bar of a web browser window. You can change the quick search
keyword in the Plugins & Scanners panel.
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Note: Some sites need a valid log-in. If you want to query these sites with a plugin, you need to enable
cookies and manually log in with your web browser in advance. When you use DEVONagent Pro, the
websites then will recognize you as a returning user. You will find a note in the plugin description if a site
requires a log-in.
SEARCH
Note: DEVONagent Pro presents this category separately in its menu, above the other plugins to make them
more easily accessible.
Baidu: Searches the web using Baidu.
Bing: Searches the web using Bing, Microsoft's web search engine. Bing is considered to be the only real
competitor to Google.
DuckDuckGo: Searches the web using DuckDuckGo, a search engine that claims that it doesn't track its users
and delivers unbiased results (see also: filter bubble).
Google: Searches the web using Google. Google is famous for ranking websites by the number of other sites
linking to it. Google is now widely recognized as the world's largest search engine.
Google (PDF): Searches for PDFs using Google.
Lucky Guess: Scans URLs derived from the search term. This is very useful if you are looking for a company or
product website.
Qwant: Searches the web using Qwant, a search engine that, like DuckDuckGo, claims that it doesn't track its
users and has no filter bubble.
StartPage: Searches the web using StartPage. The search engines uses results from Google and claims that it
respects its users' privacy and has no filter bubble.
Web: Searches the web using Bing, Google, and Yahoo. Depending on the system language, DEVONagent Pro
also uses local search engines or local variants.
Yahoo: Searches the web using Yahoo, one of the three major search engines.
Yandex: Searches the web using Yandex.
APPLE
App Store: Searches Apple's App Store.
Developer Connection: Searches the Apple Developer Connection database, the number one source for OS X
developers.
Knowledge Base: Searches the Apple Knowledge Base, the #1 resource for finding technical information
about Mac computers, Mac OS and Apple software.
Macintosh News: Scans major Macintosh news sites, namely Macworld, MacCentral, Macintouch, and
MacNN.Use this plugin to stay up-to-date about everything Macintosh.
MacUpdate: Searches for OS X software using Macupdate. MacUpdate watches for the latest Macintosh
software updates and visits over more than 800 websites a day, looking for version changes to software titles
not submitted by developers.
BLOGS
Google Blogs: Searches blogs using Google Blogsearch.
Technorati: Searches blogs using Technorati. Technorati indexes abut 27.4 million blogs (as of February 2006),
which are classified by a staff of human editors.
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BROWSERS
All Cached Pages: Scans all pages cached by earlier search runs. Use this to include already scanned pages
again in a new search.
Bookmarks: Scans all websites bookmarked in DEVONagent, Safari, OmniWeb, Camino, Chrome, or
Firefoxfor the search query. You can use this plugin to create your private mini-web with bookmarks and
search only this collection.
DEVONthink databases: Searches all web sites bookmarkes in the currently opened DEVONthink databases.
DEVONthink server: Searches shared DEVONthink Pro Office databases through the local web server.
DEVONthink Pro Office has to be running and web sharing started by the same user.
History: Scans the pages you have visited recently with Safari or DEVONagent Pro for the search query.
This is useful for searching for something you remember you have seen recently, but you cannot remember
where.
COMPUTER SCIENCE
ACM Digital Library: Searches the digital library of the Association for Computing Machinery.
Apple Cocoa-Dev: Searches Apple's cocoa-dev mailing list. This is very useful if you do OS X software
development.
Citeseer: Searches the CiteSeer library. Citeseer is a scientific literature digital library and search engine that
focuses primarily on the literature in computer and information science.
Cocoabuilder: Searches Apple & Omnigroup Cocoa mailing lists using Cocoabuilder. Very useful if you do OS X
software development.
GitHub Code Search: Searches GitHub for code.
Ohloh Code Search: Searches for open source code examples and projects using Ohloh. ohloh.net is a free
search engine for open source code.
Stack Overflow: Searches Stack Overflow for answers to development questions.
DICTIONARIES
Acronym Finder: Searches Acronym Finder, the world's largest and most accurate dictionary of acronyms,
abbreviations and initialisms.
Dictionaries: Looks for word definitions in online dictionaries, namely Reference.com and Hyperdictionary.
Infoplease: Searches Infoplease, a reference source that combines the contents of an encyclopedia, a
dictionary, an atlas, and several almanacs with statistics, facts and historical records.
Onelook: Searches for word definitions or translations using Onelook. Onelook is a search engine that
provides access to web-based dictionaries that define or translate words.
Wiktionary: Looks for word definitions in the online dictionary Wiktionary. Wiktionary is a free multilingual
dictionary and thesaurus that's being written collaboratively. Anybody can edit any article and a record of
changes is kept. This plugin is localized and searches in the selected language.
DIRECTORIES
Open Directory: Searches the Open Directory. The Open Directory (Dmoz.org) seeks to be the largest free
web catalog.
WoW: Searches the WoW catalog. WoW categorizes websites by country, state or region and uses a
professional editorial team.
Yahoo Directory: Searches the Yahoo directory. The Yahoo directory was the world's first professionally
edited web directory. It is currently divided into 14 main categories.
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DISCUSSION LISTS
DEVONtech Forum: Searches DEVONtechnologies' online discussion forum. Find answers to your most
pressing questions regarding DEVONagent Pro & Co.
Yahoo Answers: Looks for answers to user-posted questions on Yahoo Answers.
GOVERNMENT
USA.gov: Searches for U.S. government information using FirstGov.gov. FirstGov.gov is the official U.S.
gateway to all government information, with millions of webpages from federal and state governments, the
District of Columbia and U.S. territories.
IMAGES & VIDEOS
Google Video: Finds videos using Google Video.
Images: Finds images using Google.com and Yahoo (including Flickr). Whatever image you are looking for, if
it's on the Internet, you should be able to find it.
Picsearch: Searches for pictures using Picsearch. Picsearch is a search engine specialized in creating a
searchable index of images.
YouTube: Searches for videos on the popular video clip service YouTube.
LEGAL
EUR-Lex: Searches EUR-Lex for law documents and other public documents of the European Union. The
contents of the site amount to more than 2.8 million documents with texts dating back to 1951. The
database is updated daily and every year around 12,000 documents are added.
FindLaw: Searches for legal materials using FindLaw. FindLaw is the highest-trafficked legal website,
providing a comprehensive set of legal resources on the Internet for legal professionals, businesses, students
and individuals.
Google Scholar (Case Law): Searches for legal materials using Google Scholar. Google Scholar provides a way
to broadly search for scholarly literature.
Lexis: Searches for legal materials using Lexis. LexisNexis provides customers with access to billions of
searchable documents and records from more than 45,000 legal, news, and business sources.
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MEDICAL
Clinical Trials: Searches for materials on ClinicalTrials. ClinicalTrials provides regularly updated information
about U.S. federally and privately supported clinical research on human volunteers.
FDA: Searches for material on the website of the U.S. Food and Drug Administration. The index is updated
every night as many FDA documents are time sensitive.
Healthfinder: Searches for health-related materials using Healthfinder. Healthfinder is a gateway to selected
consumer health and human services information resources provided by government agencies and other
organizations.
MedlinePlus: Searches for health-related materials using MedlinePlus. MedlinePlus brings together
authoritative information from the National Library of Medicie (NLM), the National Institutes of Health
(NIH) and other government agencies and health-related organizations.
PubMed: Searches the PubMed bibliographic database. PubMed provides access to bibliographic information
that includes MEDLINE and OLDMEDLINE, as well as out-of-scope citations, citations that precede the date
that a journal was selected for MEDLINE indexing, and some additional life science journals that submit full
text to PubMedCentral and receive a qualitative review by the NLM.
WebMD: Searches for health-related materials using WebMD. WebMD provides valuable health information,
tools for managing your health and support to those who seek information.
NEWS
BBC News: Searches for news on BBC News.
Google News: Searches for news using Google News. Google uses its own search engine to scan important
news websites and automatically compile a news portal using the found data.
Reuters: Searches for news on the Reuters news database. Reuters is a global information company providing
information tailored for professionals in the financial services, media, and corporate markets.
RocketNews: Searches for news using Rocketinfo. Rocketinfo continuously searches and indexes over 16,000
Internet sites, 70,000 RSS and blog sources, as well as client-defined content channels, for current news and
business information.
Topix: Searches for news using Topix. Topix provides a news portal that aggregates news from other sources.
WorldNews: Searches for news on the World News Network. World News Network ranks as one of the top
sites for world news on the Internet. It includes more than 3,000 sites and covers 24 languages, categorized
by geography and subject.
Yahoo: Searches for news on Yahoo News. Yahoo uses its own search engine to scan important news websites
and automatically compile a news portal using the found data.
PATENTS
Google Patent Search: Covers the entire collection of patents made available by the USPTO, from patents
issued in the 1790s through those issued in the middle of 2006. It doesn't include patent applications,
international patents, or U.S. patents issued over the last few months.
US Patent Office: Searches for patents on the US Patent and Trademark Office homepage.
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REFERENCES
British Library: Searches the British Library.
Google Scholar (Articles): Searches for scholarly literature using Google Scholar. Google Scholar indexes
scholarly literature across many disciplines and sources.
Googlism: Lists the 'knowledge' stored in the Google database about a given search word. Googlism will find
out what Google thinks of you, your friends or anything else.
Gutenberg.de: Searches for literature in the German-language Project Gutenberg database of free ebooks.
Gutenberg.org: Searches for literature in the English-language Project Gutenberg database of free ebooks.
Highbeam: Searches for articles on Highbeam Research. HighBeam regards itself as the premier online
research tool for business and academic use, with more than 80 million articles culled from the archives of
over 6,500 newspapers, magazines, journals, and other publications.
Internet Public Library: Searches for literature in the The Internet Public Library. The Internet Public Library
is a public service organization and a learning and teaching online environment at the University of Michigan
School of Information.
JSTOR: Searches for articles on JSTOR. With more than a thousand academic journals and over 1 million
images, letters, and other primary sources, JSTOR claims to be one of the world's most trusted sources for
academic content.
Philosophy: Searches for literature in the Stanford Encyclopedia of Philosophy.The Stanford Encyclopedia of
Philosophy is maintained and kept up-to-date by an expert or group of experts in the field.
Poetry: Searches for English poetry using the Electronic Poetry Center, founded by Loss Pequeno Glazier and
Charles Bernstein.
SEC: Searches the EDGAR database of the SEC.
Wikipedia: Searches for articles in the free online encylopedia Wikipedia. The content of Wikipedia is free
and is written collaboratively by people from all around the world. Begun in 2001, Wikipedia has grown
rapidly into the largest reference website on the Internet. This plugin is localized and searches in the selected
language.
SCIENCE
American Chemical Society: Searches for materials on the American Chemical Society (ACS) website. The
American Chemical Society is a self-governed individual membership organization that consists of more than
158,000 members at all degree levels and in all fields of chemistry.
IEEE Xplore: Searches the IEEE Xplore digital library published by the IEEE (and its publishing partners. IEEE
Xplore provides Web access to more than 3 million documents from some of the world's most highly cited
publications in electrical engineering, computer science, and electronics.
IngentaConnect: Searches online journals using IngentaConnect. IngentaConnect publishes scholarly and
professional journals in all subject areas. It supports and produces more than 3,000 online journals.
SHOPPING
Amazon: Searches for articles on Amazon. Chooses Amazon in the USA, Germany, or France depending on the
system language.
SOCIAL NETWORKING
Twitter: Searches for tweets on Twitter. No available on macOS High Sierra as access to system-wide social
accounts is no longer possible.
Facebook Profiles: Searches Facebook profiles.
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Note: The Twitter plugin is not available when you purchased DEVONagent Pro in the Mac App Store due to
sandboxing restrictions.

LIST OF SCANNERS
Scanners do not query search engines, but rather filter webpages that do not match their criteria. For example,
scanners can filter all pages that do not contain links to images or Office documents, pages that do not contain
email addresses, or pages that have no embedded images. You can also use scanners to restrict search runs
to RSS feeds, pages with linked documents, or to thumbnail galleries. Scanners filter out all pages that do not
match.
Also, scanners are used by the sidebar of web browser windows to filter certain elements and display them lists,
e.g. links, images, or news feeds.
By default, DEVONagent Pro comes with the following scanners that you can use in search sets.
All Links: Lists all links of a page, e.g., those found by a secondary query.
Audio files: Looks for linked or embeddedaudio files and audio streams.
Code: Looks for code snippets.
Email Addresses: Looks for email addresses and recognizes even non-linked and scrambled addresses like
"info at devon-technologies dot com".
Embedded Images: Lists all images of the page, e.g., those found by a secondary query.
Linked BibTeX & LaTeX Files: Looks for linked BibTeX and LaTeX files.
Linked Binary Files: Looks for linked downloadable compressed archives and disk images.
Linked Documents: Looks for linked PDF, PostScript, OpenOffice, StarOffice, WordPerfect, Microsoft Word,
Microsoft PowerPoint, or text documents.
Linked Scripts: Looks for linked AppleScript scripts.
Linked Spreadsheets: Looks for linked spreadsheet files (XMLSS, Microsoft Excel, CSV, TSV).
Linked Vcard files: Looks for linked business card files (.vcf).
Recipies: Looks for cooking recipies.
RSS, RDF, RSD & Atom Feeds: Looks for linked RSS, RDF, RSD and Atom news feeds.
Thumbnail Galleries: Looks for images in an image gallery, but lets pass all pages containing (usually smaller)
images linked to (usually larger) image files, a.k.a. thumbnail galleries.
Twitter Accounts: Looks for links referencing unique Twitter IDs.
Video Files: Looks for linked or embedded video files and streams.
Wallpapers: Looks for desktop background pictures.
Webcams: Looks for web cams and live streams.

LOG MESSAGE CODES
DEVONagent Pro logs all pages filtered out in the log, together with a short code describing why the page was
filtered. Use the log tab of search windows to find out which pages have been dropped and for what reason.
HTTP ERROR CODES
These error codes are standard HTTP error codes delivered directly from web server that DEVONagent Pro
asked for a file:
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204: No response
301: Moved permanently
302: Moved temporarily
401: Authorization required
403: Forbidden
404: Page not found
408: Request timeout
410: Gone
500: Internal server error
501: Not implemented
502: Service temporarily overloaded
503: Gateway timeout
522: Connection timed out
Wikipedia has a complete list of all possible HTTP error codes.
DEVONAGENT PRO ERROR DESCRIPTIONS
These errors appear in the log when communication problems with the web server occurred, or, more likely,
when DEVONagent Pro filtered the page out due to search strategy or user-defined settings.
Advertisements: Link or frame probably contains only advertisement or banners
Archived: Identical page has already been archived (if "Archived Pages"filter is activated)
Disabled format: Page isn't in a suitable format
Disallowed: Page couldn't be downloaded due to permissions
Duplicate: Identical page already found
Excluded: URL or domain excluded by the user
Failed: Search engine could not be reached
Filtered by scanner: Page did not pass the selected scanner
Host not found: Website not found
Identical: Identical page with different URL already found
Incomplete: Download could not be completed
Junk: Page contains almost no useful information (if the article filter filter is activated)
Language: Page does not match the language selected in the language filter
Links: x of y: Pages delivered as a result by a search engine. Numbers indicate used links vs. returned links. If
the number of used links is lower than the returned one, then either another search engine already returned
the same link or the host is blocked.
Lookup failure: Domain of website not found
No content: Page does not contain any text
No match: Page does not match the query term
Only links: Only links matching the query term found (if Follow Links is activated)
SPAM: Page tried to fool search engines, but does not match the query term without those tricks
Similar: Similar page (different layout but similar text) with different URL already found (if Similar Pages is
activated)
Skipped: Domain was skipped because it matches one or more entries in the list of unwanted sites
Timeout: Web server didn't respond in time
Too big: Page is larger than the maximum size defined in the preferences
Unknown data: No HTML or text content
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