Rhinoceros®
modeling tools for designers

Using Layouts in Rhino 5
Introduction to Layouts

A Layout in Rhino is the full size representation of the sheet or paper that will be sent to the printer, plotter or virtual printer, like a PDF creator. You can add a Layout or multiple Layouts to any Rhino model.

On the Layout (sometimes called a page Layout), you will add Details and Annotation objects like title blocks and text. You can even add Dimensions that reflect the model geometry on the Layout. The Layout is typically plotted full size, or 1:1, since the scale has already been set to each Detail.

The Layout is arranged with views of the model called Details. Details are like “windows” into the model or views of the model that show different parts of the model. Here are some features of Details:

- The Details can be set to a scale.
- Details allow for layer and color visibility per viewport.
- Layers in the Detail can be turned off so that the objects on these layers are not visible in that Detail, only.
- Specific objects in the Detail can also be hidden, while other objects on the same layer remain visible.
- Layers can be assigned print and display colors that may be different in each Detail.
- The Details are activated to add Text and Dimensions. Or Text and Dimensions can be added on the Layout.

In this tutorial, we will:

1. Setup a Layout with two Details, each at a different scale.
2. Turn certain layers off in one Detail and leave it visible in the other.
3. Arrange the Details on the title block, add title block labels, and include a raster image in the title block.
4. Add Dimensions and Annotations that are appropriately sized for each Detail using Annotation scaling.
5. Set color and print weight to layers in one Detail and not the other.
6. Print the Layout to PDF.
Using Layouts in Rhinoceros 5

It is our goal to have a similar image to this drawing:
Table of Contents

Introduction to Layouts ........................................................................................................................................3

Setting-Up the Model ........................................................................................................................................6

Adding the Layout and Inserting a Title Block .................................................................................................9

Adding Details to the Layout ............................................................................................................................15

Defining Annotation Scaling ............................................................................................................................24

Model Space Scale ........................................................................................................................................26

Setting-Up a Model to Use Annotation Scale ...............................................................................................27

Adding Text to the Page Layout .......................................................................................................................29

Setting Detail Edge Plot Width ..........................................................................................................................32

Adding Dimensions to the Detail .......................................................................................................................33

Configuring Print Width and Print Color .........................................................................................................39

  Configuring Print Width ...............................................................................................................................39

  Configuring Print Color ..............................................................................................................................42

Adding a Logo to the Title Block ....................................................................................................................44

Printing the Layout .........................................................................................................................................46

  Monochrome Plot .....................................................................................................................................46

  Print Color Plot .....................................................................................................................................48

  Display Color Plot ................................................................................................................................49
Using Layouts in Rhinoceros 5

Setting-Up the Model

1. In Rhinoceros 5, open model *Floor1.3dm*.

2. From Tools menu, click **Toolbar Layout...** or type **Toolbar**.

3. From Rhino Options, Toolbars section, highlight **default** (1) and check the **Layout** toolbar (2).
Or right-click at the end of the Standard toolbar, pick Show Toolbar > Layout.
4. From the Tools menu, click Options..., under the Document Properties area, expand Units and click Layout. From the right pane, under Units and tolerances set Layout units to Inches, if it is not already set.

Rule: Model and Layout units must be in the same unit system for Annotation scaling to work properly. For example, if the Model units are metric, the Layout units should be metric. If the Model units are imperial, then the Layout units should be imperial.
Adding the Layout and Inserting a Title Block

1. To add a new Layout, go to the View menu, select Layout and New Layout. Or click New Layout from the Layout toolbar.

Or click the “+” tab in the viewport tabs.

2. The New Layout dialog appears.

3. In the New Layout dialog enter the following:

   - **Name**: First Floor Plan
   - **Printer**: Any Printer or PDF Printer
   - **Orientation**: Landscape
   - **Width**: 17
   - **Height**: 11
   - **Detail Count**: 0

   Click OK when done.
Using Layouts in Rhinoceros 5

You can also access **New Layout** command from **View > Layout**.

4. Pick **OK** and the new Layout tab will appear as “First Floor Plan”. 
Using Layouts in Rhinoceros 5

5. To bring up **Layout Properties**, right-click over the Layout tab and select **Layout Properties…**

   ![Layout Properties]

   Here you can change the settings that you selected when you added the Layout. However, Detail count or Detail placement cannot be modified here.

6. From the **Layer** pane in the status bar (or the **Layers** panel), make the **Annotations > Title_Block** layer current. (This will be the layer that controls the visibility of the title block.)

   ![Layers Panel]

7. Next insert the Title Block on to the Layout. It is in the DWG format.
   From **Edit** menu, select **Blocks** and **Insert Block Instance**…
   Or click **Insert** from the **Block** toolbar.

   ![Insert Block]

   ![Title Block]
8. **From Insert** dialog, click **Select File to Insert** button in the upper right to insert an external file as a block.

![Select File to Insert dialog](image)

9. In the lower right of **Select File to Insert** dialog, select file type as **AutoCAD Drawing (*.dwg)**. Navigate to and select **Titleblock-17x11.dwg**. Double-click to select it or pick the **Open** button.

![Select File to Insert dialog](image)
Using Layouts in Rhinoceros 5

10. Set insert options from **Insert** dialog. Check **Insertion point** and uncheck **Scale** and **Rotation**. Click **OK**.

11. From **Insert File Options** dialog, select **Embed** as the block type.
Using Layouts in Rhinoceros 5

12. Use default options for **DWG/DXF Import Options**. Click **OK**.

   ![DWG/DXF Import Options dialog box]


   ![First Floor Plan]

   *The title block is placed and you are ready to arrange the Detail views of your model.*
Using Layouts in Rhinoceros 5

Adding Details to the Layout

1. From the Layer pane in the status bar (or the Layers panel), make the Annotations > Details layer current. (This will be the layer that controls the visibility of the Details.)

2. From the Layout toolbar, pick the Add Detail button.

You can also access the Layout and Add Detail command by clicking the viewport label.

Or do this by right-clicking over the Model or Layout viewport tabs.
3. **Pick two diagonal corners that match the location with Detail 1 below.**

*Hint: you may use Grid Snap or construction geometry to line up the Details on the Layout.*

The Detail appears.

![Image of two diagonal corners on a layout with a detail highlighted](image-url)
Using Layouts in Rhinoceros 5

4. Next, activate the Detail on the left by double-clicking in it. Zoom it to center the entire plan. Scale will be addressed in the next few steps.

5. Make the Layout active by double-clicking anywhere on the Layout, even in the Detail. Then pick on the edge of the Detail to highlight it or select it. *Important: Do not double-click to activate the Detail.*

6. Open the **Properties** panel with **F3** or go to the **Edit** menu and select **Object Properties...** Next, set the scale and lock the zooming on the Detail.

7. With the Detail highlighted, from the **Properties** panel, above the Object label, select the **Detail** page. (**F3** will open the **Properties panel** or go to the **Edit** menu and select **Object Properties...**)

8. Set the **Scale** units **inches on layout** to **1** and the **inches in model** to **96**. If the placement looks good, you may check “**Locked**”. In imperial units, this is the same as **1/8”=1’-0”**.

*This means that in every 1 unit on the paper there is 96 model units in the Details. In this model the unit is inches, so we can say that 1” on the Layout contains 96” or 8’ of model units.*
You may prefer to pan the Detail as necessary before returning here to lock it later.
Using Layouts in Rhinoceros 5

10. Now create the second Detail.

11. Next, activate the smaller Detail on the right by double-clicking. Zoom in on the kitchen only.
Using Layouts in Rhinoceros 5

12. Make the page Layout active by double-clicking anywhere on the Layout, except over a Detail.

13. Then highlight the edge of the Detail on the right.

14. Next set the scale and lock the zooming on the Detail. From the Properties panel select the Detail page.
Using Layouts in Rhinoceros 5

15. Set the **Scale** units **inches on layout** to **1** and the **inches in model** to **48**. In Imperial units, this is the same as 1/4”=1'-0”

16. If the placement looks good, you can check “Locked”. Or you may prefer to pan the Detail some before returning here later to lock it.

17. To resize the Detail use Control Points. You can do this with the **PointsOn** command on the **Main** toolbar or **F10** on the keyboard. **ESC** or **F11** to turn Control Points display **off**.

*Details can also be copied, moved and deleted.*
18. Highlight Detail by picking on the Detail’s edge. Pick **PointsOn** command. Click and drag control point to resize the Detail. **ESC** to turn **off** Control Points.

19. Your Layout should look like this:
Using Layouts in Rhinoceros 5
Defining Annotation Scaling
Rhino 5 will scale the Annotation objects – Text, Dimensions, and Hatching – so they will appear and plot reasonably on the sheet Layout automatically. This option is called Annotation Scale. It can be on or off and the model will save the setting.

Even without Annotations scale, Text, Dimensions and Hatching can be created to look good in Details that are at the same scale. However if you try to show the same Annotation objects in a Detail that is at a different scale, the objects will not look or plot the proper size.

Annotation Scale OFF for Text, Dimensions, and Hatch
Annotation Scale ON for Text, Dimensions, and Hatch

When Annotation Scale is “on”, Text, Dimensions, and Hatch objects display and print the appropriate and exact size they were created, regardless of the scale assigned to the Details. This is even true in Details that have been assigned different scales.
Using Layouts in Rhinoceros 5

**Model Space Scale**

For this to work, text needs to be created the size you want it to be on the Layout. For example, if you want your text to be at the printed height of 1/8” or .125, you will need to create your text this height. In the Large Floor Plan, the text that is 1/8” high may not be readable in model space.

It is helpful to assign a model space scale, so you can actually read the text in a Model viewport. But acknowledge that the Layout will show the exact printed text height. It is helpful to make them close in size. For example, the viewport in model space is ¼”=1’ so assign the model space scale to 48.

We will also assign the “Model Space Scale for Hatch” to the same value, as well as the “Model space scale for the Dimensions”.

Setting-Up a Model to Use Annotation Scale

1. To turn on the feature, go to Tools > Options...

2. Check “Enable scaling of text, Dimensions and leaders”
   Check “Enable hatch scaling”
   Set Model space text scale to 48
   Set Model space hatch scale to 48.

3. Pick the “plus” next to “Annotation” and select Dimensions.
4. Pick New and select the *(built-in)* Foot-Inch Architectural. Pick OK.

5. Set the Model space scale to 48. Enter 48 or use the list control box to select common scale that will add the units to the field. Here select ¼”=1’. Model space scale will be set to 48.
Adding Text to the Page Layout

1. Confirm that the page Layout viewport is active (not a Detail).

2. Make the Text layer current.

3. From the Dimension menu, select Text Block. Or type Text.
Using Layouts in Rhinoceros 5

4. Pick a start point under the first Detail. Set **Height** of .25 and enter text **First Floor Plan**. Under the second Detail, add the text **Kitchen Plan**.
Using Layouts in Rhinoceros 5

5. Add additional text of \(\frac{1}{8}''=1'-0''\) under First Floor Plan and text of \(\frac{1}{4}''=1'-0''\) under the Kitchen Plan.

6. Optional: Add line as separator between the text to finish off Detail labeling.
Using Layouts in Rhinoceros 5

**Setting Detail Edge Plot Width**

The Detail edges are set to “No Print” by default. This is accessed from the **Properties** panel in the object **Print Width** setting.

1. Pick or highlight the edge of the Detail, open **Properties**.
2. Under **Print Width** field, see the “No Print” setting is already selected.
3. You can change the Detail edge to print by selecting a width.
Adding Dimensions to the Detail

Now create the Dimensions in both the overall First Floor Plan, the Kitchen Plan and on the Layout.

1. Make the **Dim-Plan** layer current.

2. In **Options > Annotation > Dimensions**, select **Dimension Properties**. Pick the **Foot-Inch Architectural**.

**Note:** Typically Dimensions are created on the model or in model space. Dimensions are more related to the model geometry and work best for most users if they are created here. However, you can create them on the Layout too. Here they will reflect model geometry, if you use Osnap. They will also only be visible on the one Layout. To do this, use your Osnap like End Pt or Intersection Pt when picking the Dimension origin points.
Using Layouts in Rhinoceros 5

3. With the First Floor Plan Detail active, create these linear Dimensions. Create horizontal, vertical, angular and aligned Dimensions. Here are some suggestions:

Using Layouts in Rhinoceros 5

5. With the **Kitchen Plan** Detail active, create these linear Dimensions on the model. Create horizontal, vertical, and radial Dimensions. Here are some suggestions:

- Dimensions are same size even when created in different details.

6. Compare Dimensions. Dimensions that were created in each viewport are generated the same size. *This is Annotation Scale at work!* This is also true for text and hatch.
Using Layouts in Rhinoceros 5

7. Now create a couple Dimensions directly on the Layout. Use Osnaps with Dimensions commands to snap to model geometry. If Osnaps are used, these Dimensions will reflect values of model units, not page units.

The Dimensions for the **Kitchen Plan** should not be visible in the **First Floor Plan** Detail. Using layer visibility setting for layer in the Detail, turn off the **Dim-Kitchen** layer in the **First Floor Plan** Detail.

8. First make the **First Floor Plan** Detail active.

9. Next, in the **Layers** panel, select **View detail layer settings**. This will only display Detail layer settings, not the model layer settings.
Using Layouts in Rhinoceros 5

10. In the **Layers** panel, select the **Dim-Kitchen** layer. Click the light bulb to turn off the layer visibility in this Detail only.

11. The Dimensions on the **Dim-Kitchen** layer are no longer visible in the larger **First Floor Plan** Detail.
Using Layouts in Rhinoceros 5

Go to the **Top viewport**. Dimensions and Text are readable in the **Model viewports** as well as the **Layout Details**, because of the “**Model space text scale**” in **Options** and the **Model space scale** in the **Dimension style**.
Using Layouts in Rhinoceros 5

Configuring Print Width and Print Color
Rhino has layer properties that are set globally for the entire model and layer properties that are assigned only to a Detail. These Detail settings override the global settings and allow objects in a Detail to look different than the objects on the same layer in another Detail or in a model viewport. This is called “Detail layer settings.”

To see the Detail layer settings, start by making the Detail active. With the Detail active, you will see the model and Detail layer setting. With no Detail active, you will see the model and Layout layer setting.

Layer settings per Detail and per Layout include:
- Visibility (on/off – we did this in the last section.)
- Display Color
- Print Color
- Print Width

Configuring Print Width
1. On the Layout, make sure no Detail is active.

2. In the Layers panel, change the Model Print Width of the following layers: Walls and Windows from Default to .35mm. Any layer set to Default will use the setting in the Plot dialog.
3. Make the Kitchen Plan Detail active by double-clicking anywhere on the page, but not over a Detail.

4. Next, in the Layers panel, select View detail layer settings. This will only display Detail layer settings, not the model layer settings.

5. Highlight the Cabinet layer. Set the Detail Print Width to .60mm. Objects on the Cabinet layer will now print with the .60mm print width.

6. Can you see it? Type PrintDisplay. Set the Print Display to On.

   Command: PrintDisplay
   Print Display (Model Viewports) ( State=Off Color=Print Thickness=40 ): State
   State <Off> ( On Off Toggle ): On

7. Highlight the Cabinet layer. Select Detail Print Width and set the width to .60mm.
Using Layouts in Rhinoceros 5

8. Double-click back on the Layout. The Cabinets are magenta and .60mm.

9. Double-click back on the Layout. Select the Title_Block layer and set the Print Width to .70mm.

10. With Print Display on, the title block lines will update to show the new width.
Configuring Print Color

1. Make the **First Floor Plan Detail** active.

2. Highlight the **Cabinet** layer. Set the **Detail Display Color** to **Red** and set the **Detail Print Color** to **Cyan**. 
   In the Layers panel, the diamond marker is used to access Print Color. Pick it in the Cabinet layer row and set the color of the layer to **Cyan**. This color will be used if Print Color option is selected from the Print dialog. It will not be used if color is set to Display or Black and White.
When printing with Display Color the cabinets will print Red. When printing with Print Color the cabinets will print Cyan. We will see this shortly.
Using Layouts in Rhinoceros 5

Adding a Logo to the Title Block

1. Double-click to edit the title block in-place. When you see the dialog, you can begin editing the geometry.

2. From the Surface menu, pick Plane > Picture Frame. Navigate to the Rhino logo. Pick two diagonal points in the title block area.
Using Layouts in Rhinoceros 5

3. Use the **Gumball** to modify the lines of the title block to fit around the Rhino logo.

4. Pick **OK** to close the BlockEdit.

The drawing now looks like this.
Using Layouts in Rhinoceros 5

**Printing the Layout**

When printing the Layout, there are numerous options to configure in the Print dialog.

The Print dialog includes controls on the left and a dynamically updating print preview pane on the right.

The printing tools have to make it as quick and easy as possible to:

- Identify what you want to print
- Position it on the page where you want it
- Scale the display to something useful
- Manage line pattern scales and line widths

The general categories are:

- **Destination**: Displays the list of installed printers, including any PDF printer drivers.
- **View and Output Scale**: List of viewport names and Layout pages
- **Margins and Position** (Model views only, not when printing Layouts.)
- **Linetypes and Line Widths**
- **Visibility**: Optional items to include on the printed page.
- **Printer Details**: Displays a description of the currently selected printer Details as reported by the driver and configuration settings.

**Monochrome Plot**

For the first plot, configure the Print dialog as follows:

- **Destination**: Adobe PDF or other PDF printer
- **Sheet Size**: 11x17
- **Orientation**: Landscape
- **Output**: Raster for Picture Frame.
- **Output Color**: Black and White
- **View**: Layout 1 – First Floor Plan
Using Layouts in Rhinoceros 5

- Scale: 1:1 (optional: Scale to Fit if print does not need to be to scale.)
- Line Widths: Default set to .25mm
Using Layouts in Rhinoceros 5

Print Color Plot

Print color allows for overrides on the display color. This can be set to the layer or to the object. In the print below the Cabinet layer in the First Floor Plan Detail on the left, is set to a Print Color of Cyan.

- **Destination**: Adobe PDF or other PDF printer
- **Sheet Size**: 11x17
- **Orientation**: Landscape
- **Output**: Raster for Picture Frame.
- **Output Color**: Print Color
- **View**: Layout 1 – First Floor Plan
- **Scale**: 1=1 (optional: Scale to Fit if print does not need to be to scale.)
- **Line Widths**: Default set to .25mm
Using Layouts in Rhinoceros 5

Display Color Plot

Display color can be assigned to the layer or objects can have their own display color as an object property override. In the plot below, the Detail on the left has the cabinet Display Color set to red, and the Detail on the right has the cabinet Display Color set to magenta.

- **Destination**: Adobe PDF or other PDF printer
- **Sheet Size**: 11x17
- **Orientation**: Landscape
- **Output**: Raster for Picture Frame.
- **Output Color**: Display Color
- **View**: Layout 1 – First Floor Plan
- **Scale**: 1=1 (optional: Scale to Fit if print does not need to be to scale.)
- **Line Widths**: Default set to .25mm