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1 Step-by-step Guide for Creating a Flexible Mesh for MIKE 

Products 

1.1 Data Requirements 

You will need the following data in order to complete the mesh build: 

Type Purpose 

Coastline To provide a land boundary (or edge) to your model domain 

Bathymetry To provide a bottom boundary to your model domain 

 

1.2 Data Sources 

Some standard data sources are given in the tables below, however, the lists are not exhaustive.  It is 

also very important that you know what coordinate system / vertical datum your data is relative to.  

These can be geographical (giving latitude/longitude (and sometime height) values relative to a specific 

ellipsoid) or map projections (giving Easting (x) / Northing (y) values to a specific 2D projection). 

1.2.1 Coastline 

Source Cost Details 

GSHHS (Global Self-consistent, 
Heirarchical, High-resolution 
Shoreline) 

http://www.ngdc.noaa.gov/mgg/sh
orelines/gshhs.html 

 

FREE WGS84 datum. 

V2.2.0 (July 2011) is latest version of the data. 

Extract data to xyz format using GEODAS Software: 
http://www.ngdc.noaa.gov/mgg/gdas/gx_announce.Html 

Version 5.0.19 is latest version of the software and 
Coastline Extractor is the tool to use. 

Reasonable resolution for large areas 

Digitise from Map/Chart FREE Make sure you know what coordinate system you are 
digitising from. 

SeaZone 

http://www.seazone.com/bathymet
ry.php 

 

£100-£1000 or 
more depending 
on area 

Coastline that comes with SeaZone bathymetry data is 
generally quite coarse but is also up to date. 

Expect data to the tidal limits of all rivers/estuaries to be 
included. 

Comes with bathymetry so one off cost. 

Generally WGS84 but is clearly specified. 

Ordnance Survey MasterMap 

http://www.ordnancesurvey.co.uk/
oswebsite/public-sector/mapping-
agreement/index.html 

 

FREE* Mean high water line could be used as coastline if it is 
supplied as a separate polyline which can be exported. 

Datum is British National Grid 

* through the Public Sector Mapping Agreement which the many local authorities and the EA are 

signed up to with the OS 

 

http://www.ngdc.noaa.gov/mgg/shorelines/gshhs.html
http://www.ngdc.noaa.gov/mgg/shorelines/gshhs.html
http://www.ngdc.noaa.gov/mgg/gdas/gx_announce.Html
http://www.seazone.com/bathymetry.php
http://www.seazone.com/bathymetry.php
http://www.ordnancesurvey.co.uk/oswebsite/public-sector/mapping-agreement/index.html
http://www.ordnancesurvey.co.uk/oswebsite/public-sector/mapping-agreement/index.html
http://www.ordnancesurvey.co.uk/oswebsite/public-sector/mapping-agreement/index.html
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1.2.2 Bathymetry 

Source Cost Details 

GEBCO (General Bathymetric 
Chart of the Oceans) 

http://www.gebco.net/data_and_pr
oducts/gridded_bathymetry_data/ 

FREE The GEBCO_08 dataset has a resolution of 30 arc 
seconds which is ~900m. 

20100927 (Sep 2010) is latest version. 

View and extract data to xyz format using Grid Display 
Software:  

http://www.gebco.net/data_and_products/grid_display_s
oftware/ 

Vertical datum is global Mean Sea Level (MSL). 

Horizontal coordinate system is WGS84. 

EMODNet (European Marine 
Observation and Data Network) 

http://portal.emodnet-
hydrography.eu/EmodnetPortal/ind
ex.jsf#close 

 

FREE This dataset has a resolution of 15 arc seconds (~450m) 

Vertical datum is LAT which will need to be converted to 
MSL or ODN 

Horizontal coordinate system is WGS84 

Choose ‘Download Bathymetry as ESRI ASCII files’ from 
first drop down list and ‘Show all’ from the next list.  
Choose Celtic Seas dataset from the list and read the 
unzipped downloaded file into MIKE using MikeZero 
Toolbox > GIS > Grd2Mike. 

Channel Coastal Observatory FREE Usually good source of data if you are working on the 
south coast. 

SeaZone 

 

£100-£1000 or 
more depending 
on area 

TruDepth Points or Charted data are good quality data 
from fare charts and UKHO charts, respectively. 

Usually provided to Chart Datum (CD) vertically and 
WGS84 horizontally. 

 

1.3 File Format 

a. Coastline (land boundary) data 

 

This needs to be supplied to MIKE in one of the following formats: 

 X, Y, Z, Connectivity 

 X, Y, Connectivity, Z 

 X, Y, Connectivity 

 

where: 

 X is the easting/longitude value of the location on the coastline 

 Y is the northing/latitude value of the location on the coastline 

 Z is optional and represents the depth at the coastline if you know it 

 Connectivity is either a 1, meaning the next point is located on the same part of the coastline 

as the present one or 0 meaning this point represents the end of a section of coastline. 

 

For most of the data sources listed above, you will need to add the Connectivity value to the X,Y 

data.  A simple first stab at this can be done by loading your X,Y data into Excel (or similar), 

calculating the distance between each point and its subsequent point.  You can then define the 

connectivity to be 0 if the distance is greater than the typical distance (usually by a factor of 10 to 

100) and 1 otherwise. 

 

http://www.gebco.net/data_and_products/grid_display_software/
http://www.gebco.net/data_and_products/grid_display_software/
http://portal.emodnet-hydrography.eu/EmodnetPortal/index.jsf#close
http://portal.emodnet-hydrography.eu/EmodnetPortal/index.jsf#close
http://portal.emodnet-hydrography.eu/EmodnetPortal/index.jsf#close
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b. Bathymetry data 

 

This needs to be supplied to MIKE in one of the following formats: 

 X, Y, Z where X, Y are defined as for coastline data and Z is the height above the vertical 

datum of the ground/bed level meaning that water depths, which are generally below the 

vertical datum, are given as negative values. 

 dfs2 file, which can be easily generated from bathymetry data which given in ASCII format 

(.asc) by using the Grd2Mike tool in the MikeZero Toolbox (MZToolbox > GIS > Grd2Mike) 

as outlined below: 

 

1. Open the New file dialog (either click on the blank page icon at the far left of the toolbar 

or select File>New>File…) 

2. Select the MikeZero Toolbox by double clicking on the large icon on the right hand side 

panel 

3. Expand the menu under the GIS heading by clicking the + sign located to the left of 

GIS 

4. Double click on the Grd2Mike tool to open it 

5. Give the tool a name if you like (useful if you are going to save the toolbox for repeat 

use later) 

6. Click Next > and, using the ‘…’ button, navigate to where you have saved your ASCII 

file (should have .asc extension) 

7. Click Next > and choose the projection that your data is in (likely to be LONG/LAT for 

your unprocessed bathymetry data) 

8. Click Next > and give your output file (which will be a dfs2 file) a location and name – 

use the ‘…’ button to ensure it is saved where you want it! 

9. Click Next > and the click the Execute button and wait for the confirmation dialog to be 

displayed indicating that your dfs2 file has been created. 

10. Click Finish and save your MZ Toolbox if you want to reuse the tool in the future 

 

1.4 Coordinate System Conversion 

You need to make sure you know which coordinate systems each of your datasets are in.  The GSHHS 

coastline is in WGS84 geographical coordinates (degrees longitude, degrees latitude) as is the 

GEBCO/EMODnet bathymetry data.  Typically, data from UKHO or SeaZone will also be in WGS84 

lat/long. 

If your study area is in the UK, you will find the British_National_Grid projection to be the most suitable 

for your model.  You may, therefore, need to convert from WGS84 (or other coordinate systems) to 

BNG. 

This is done using the Datum Convert application, accessed from the MikeZero environment using 

File>Options>Datum Convert… to open a new tool window.  Open your xyz files (one at a time) using 

the Open icon or following File>Open… and navigating to your xyz file location.  Once the tool opens, 

you should see your data (as Longitude, Latitude, Z, Text) on the right hand side of the page and the 

coordinate system information on the left hand side.  The Z column should contain your connectivity 

(1s and 0s) for your coastline file and your depth data (+ve upwards) for your bathymetry file.  There 

should be no data in the Text column. 

NOTE:  The following instructions are for converting from WGS84 lat/long coordinates in the UK to 

British National Grid.  If your data are to a different coordinate system or you want to use a different 

projection, you will need to make changes accordingly. 
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You will now need to populate the left hand side of the tool with the relevant information.  Under 

Coordinate System A, choose ‘WGS_1984_UTM_Zone_30N’ from the top drop-down list (if it is not 

immediately displayed, choose ‘Browse…’ from the list and you will find it located under D_WGS_1984 

on the left hand side menu).  Select ‘Geographical’ from the Type of coordinates drop-down list and ‘7 

Parameter’ from the Datum shift drop-down list. 

In the text boxes which are now enabled, enter the following values: 

dx (m) - 446.448 Rx (arcsecs) - 0.1502   

dy (m) + 125.157 Ry(arcsecs) - 0.2470 Scale + 20.4894 

dz (m) - 542.060 Rz (arcsecs) - 0.8421   

 

NOTE:  These values are specific for conversion from WGS84 to OSGB36-based projections and are 

taken from section 6.6 of the Ordnance Survey document 

(http://www.ordnancesurvey.co.uk/oswebsite/gps/docs/A_Guide_to_Coordinate_Systems_in_Great_Bri

tain.pdf).  If you are using other coordinate systems or projections, you will need to source the 

respective relevant values. 

Under Coordinate System B, select ‘British_National_Grid’ as your grid projection (again, if it is not on 

your drop-down list, choose ‘Browse…’ and you will find BNG under D_OSGB_1936 on the left hand 

menu).  Choose ‘Map projection’ as your Type of coordinates and ‘None’ from the Datum shift drop-

down list. 

Click on the Convert from A to B button and your data in WGS84 long/lat on the right hand side will be 

replaced by the related BNG Easting/Northing.  Copy and paste these data, with the Z column, into a 

new text file and make sure you identify the projection (BNG) in the filename as this makes things 

easier as you progress through the mesh build! 

 

1.5 Mesh Generation 

a. Open up a Mesh Generator (.mdf) application in MikeZero. 

b. If you are working within the UK, specify the workspace projection to be ‘British_National_Grid’, 

unless you have not converted your data from WGS84 datum and you are happy to use UTM30.  

This will use the OS National Grid as a horizontal reference system.  Elsewhere on the globe you 

will probably be best using the local UTM zone.  If your model is larger than a few hundred 

kilometres in extent, you may want to use the LONG/LAT geographical projection. 

c. From the Data menu, choose Import Boundary… and navigate to the location of your chosen land 

boundary file.  Choose the correct order of X, Y, Z and Connectivity and make sure you specify 

correctly the projection that the land boundary data is in (typically it should be 

British_National_Grid if you have followed Step 4). 

d. Use the Delete tool to remove the vertices from the areas which are obviously outside of your 

chosen model domain. 

e. Starting at one end of your land boundary, check your nodes carefully for spacing, strange 

looking intrusions/headlands and islands. 

1. Remember that narrow channels will create small elements within your mesh so if they are not 

important to the propagation of waves or tide, remove them. 

2. Similarly, islands which are important for refraction/diffraction of waves but are very close to 

the mainland can be joined to the mainland arc by converting suitable vertices to nodes and 

using the draw arc tool to connect them. 

3. Remember you can change the spacing of vertices on an arc by selecting the arc and 

choosing Redistribute Vertices from the right-click menu.  You can then choose the number of 

vertices you want on an arc or, more usually, the distance between vertices.  The values of 

http://www.ordnancesurvey.co.uk/oswebsite/gps/docs/A_Guide_to_Coordinate_Systems_in_Great_Britain.pdf
http://www.ordnancesurvey.co.uk/oswebsite/gps/docs/A_Guide_to_Coordinate_Systems_in_Great_Britain.pdf
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the Spline tension factor will control the closeness of fit of the new arc to the original one with 

higher values (e.g. 10) allowing a closer fit. 

4. You can split the main coastline arc into sections by converting vertices into nodes at each 

end of the section, creating a separate arc and specifying a smaller or larger vertex spacing 

for each arc.  Each vertex will have the corner of an element located at it, although sometimes 

element corners will also be placed between vertices on a coastline if the resolution is 

appropriate.  This means you can control which sections of the coastline are more highly 

resolved. 

f. Once you are happy with the extent of your coastline arc and the distribution of vertices on it, 

close your domain by adding open boundaries.  The location of the open boundaries is usually 

dependant on where you have boundary condition data (such as tidal water levels or wave data).  

You may only need one open boundary or you may need to take your domain offshore in which 

case you will need more, see below for example. 

 

 

Make sure each open boundary is a separate arc (i.e. has a node at the start and end). 

g. Starting at a suitable point on your land arc, move anti-clockwise around your closed domain and 

number your open boundaries starting at 2 and counting up.  You do this by selecting the 

boundary arc and then accessing Properties from the right-click menu.  Type the boundary 

number code into each of the three text boxes.  By working anti-clockwise, the Start and End 

node values will be correct for each boundary. 

h. Now you can add additional internal arcs within your closed domain to create polygons which 

have varying resolutions.  Connect your internal arcs to the main domain by changing selected 

vertices to nodes and using the draw arc tool.  Add a polygon marker to enclosed areas then, 

using the select polygon tool, set the properties of each polygon using the right-click menu. 

i. Remember that the more elements you have in your mesh, the longer your runs will take so aim 

for less than 80000 total elements to ensure a reasonable run time – less than 40000 is even 

better.  You only need higher resolution at your study site, which should be a suitable distance 

from your boundaries.  As a rule of thumb, element sizes should be in the order of water depths 

(i.e. if your water depth is 5m, your element area should be greater than ~25m
2
 (5x5m), whereas 

if your water depth is 100m, your element area should be greater than ~10000m
2
 (100x100m)).  

You should try to avoid, for example, having 50m
2
 elements defined where the water depth is 

20m. 

j. Polygons which are adjacent should not have a difference in maximum area of greater than 10 

times for a successful mesh so you may need to add layers of polygons around an area where 

you want high resolution.  See below for example. 
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k. Once you are happy with your polygons, choose Generate mesh from the Mesh menu and don’t 

forget to make a note of the total number of elements in your mesh.  You can make your mesh 

more regular by increasing the smallest allowable angle but this will increase the number of 

elements and decrease the size of the smallest element making your time step smaller and your 

runs slower.  Something between 26 and 28 degrees is usually acceptable. 

l. You can smooth your mesh by choosing Smooth mesh from the Mesh menu and you can see the 

expected maximum time step and location of the smallest element by choosing Analyse mesh. 

m. Once you are happy with your mesh, access the Manage Scatter Data dialog via the Data menu.  

Add the bathymetry data which you have prepared and don’t forget to choose the correct 

projection for the data. 

n. Once your data is loaded it will be visible in the main window.  You can now choose Interpolate 

from the Mesh menu.  By keeping the Set value from scatter data distance small (or just not using 

it) your scatter data will be interpolated onto your mesh smoothly. 

o. As the scatter data is shaded, large differences in vertical datum between your datasets should 

show up, however, you may need to revisit the mesh generator once you have generated your 

mesh file if there are clear steps between your datasets.  One way to avoid this is to ensure there 

are clear gaps between your horizontal data extents so there is no overlap between datasets.  

The interpolation routine will then provide a smooth fill between the datasets. 

p. Once your scatter data has been interpolated onto your mesh, you can choose to refine your 

mesh based on depth if you wish.  If you use this option, you will need to reinterpolate your 

scatter data to your new mesh after the refinement has been completed.  When you are happy 

that your mesh is ready for testing, export both a .mesh and a .dfsu file using the Export mesh 

option on the Mesh menu. 

q. Don’t forget to save your .mdf file! 
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r. Finally, load the .mesh file into an Animator window to check the interpolation and interfaces 

between datasets.  Anything you don’t like, you can go back into the Mesh Generator (reload your 

.mdf file) application and make changes to mesh or scatter data. 
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2 Step-by-step Guide for Creating a MIKE21 FM HD model 

2.1 Data Requirements 

You will need the following data in order to complete the model set up: 

Type Purpose 

Mesh file To provide information on the model domain (extent, flexible mesh, bathymetry and 
boundary locations) 

Boundary 
Conditions 

These can be velocity or flux values but more typically are water levels and are used to 
move energy into and out of the model domain (i.e. ‘drive’ the model) 

Wind OPTIONAL To provide a surface boundary condition for your model domain so that the 
effect of wind-driven currents can be included 

 

2.2 Data Sources 

Some standard data sources are given in the tables below, however, the lists are not exhaustive. 

2.2.1 Water Levels 

Source Cost Details 

DHI Global Tide Model FREE Access via M21 Toolbox (see Section 3 for detailed 
instructions) 

Provides water level predictions globally 

Uses mesh file to automatically identify boundary 
locations for prediction 

Admiralty Tide Tables FREE Predict water levels using the tidal constants data 
in Part III 

EasyTide 

http://easytide.ukho.gov.uk/Easy
Tide/EasyTide/index.aspx 

From £1 for 7 days UKHO online prediction service 

Ordnance Survey MasterMap 

http://www.ordnancesurvey.co.u
k/oswebsite/public-
sector/mapping-
agreement/index.html 

FREE through the 
Public Sector Mapping 
Agreement which the 
EA are signed up to 
with the OS 

Mean high water line could be used as coastline if it 
is supplied as a separate polyline which can be 
exported. 

 

 

 

 

 

 

http://easytide.ukho.gov.uk/EasyTide/EasyTide/index.aspx
http://easytide.ukho.gov.uk/EasyTide/EasyTide/index.aspx
http://www.ordnancesurvey.co.uk/oswebsite/public-sector/mapping-agreement/index.html
http://www.ordnancesurvey.co.uk/oswebsite/public-sector/mapping-agreement/index.html
http://www.ordnancesurvey.co.uk/oswebsite/public-sector/mapping-agreement/index.html
http://www.ordnancesurvey.co.uk/oswebsite/public-sector/mapping-agreement/index.html
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2.2.2 Offshore Wind Data 

Source Cost Details 

ECMWF (European Centre for 
Medium-range Weather 
Forecasting) 

http://data-
portal.ecmwf.int/data/d/interim_full
_daily/ 

 

Nominal for data 
preparation 

Use the ERA Interim data, it’s the most recent. 

Data is 6 hourly predicted values. 

Data is exported in GRIB format. 

View and extract data using GRIB viewing freeware 
(such as xconv: 

http://badc.nerc.ac.uk/help/software/xconv/#xconv) or 
http://sourceforge.net/projects/ecmwfparser/files/ECM
WFinstaller.exe/download (although this one seems a 
little slow) 

Met Office 

enquries@metoffice.gov.uk 

 

~£200 - £1000 
or more per 
point 

Hindcast wind data are available on a 12km and 35km 
mesh. 

Extreme Value Analysis (EVA) can be requested for 
each point both for the full 360° sector or for reduced 
direction sectors. 

 

2.3 DHI Global Tide Model 

You can use this tool, available through the MIKE21 Toolbox, in conjunction with a .mesh or .dfs2 file, 

to generate water level boundaries for your model.  The GTM has a resolution of 0.25 degrees (0.125 

degrees will be issued soon) so you should check that the length of the boundary for your model is 

sufficient to cover at least two points in the GTM (i.e. is longer than ~30km) to ensure acceptable 

boundary resolution.  Data in shallow water are less reliable than deep water. 

You generate water level boundary conditions using the GTM as follows: 

a. Open a new MIKE21 Toolbox using either the blank page icon at the far left of the toolbar or select 

File>New>File… and navigating to the MIKE21 menu using the left hand menu then double 

clicking on the MIKE 21 Toolbox icon on the right hand side list. 

b. Expand the menu under the Tidal option and open the Tidal Predictions of Heights tool by double 

clicking. 

c. Provide a suitable Setup Name to help remind you what the tool is for and then press Next >. 

d. On the Constituent Description page, click the ‘Prediction based on global tide model data’ radio 

button and check that the default Constituent file is the 0.25degree one.  Then click Next >. 

e. This is the General Parameters page.  If your boundary is sufficiently large (say >30km long) and 

you want to include variations along the boundary as well as in time, you should choose the ‘Line 

series (.dfs1)’ radio button under Type of output.  For shorter boundaries, choose the ‘Point series 

(.dfs0)’ radio button. 

f. Now choose the Prediction Period by entering a Start Date and a Stop Date for your simulation 

and choosing an output Interval in hours.  It is normally advisable to generate a boundary time 

series which is longer than that which you intend to use for your model simulation period.  Then 

click Next >. 

g. If you chose to output a water level time series at a point, you will now see the Time Series 

Output page.  You can predict water levels for a Number of Stations which you specify in the table 

by giving a Name and then location in Longitude and Latitude for each.  You also need to specify 

your output file name where the predicted water level time series will be saved.  Use the ‘…’ button 

to correctly locate your output file within your modelling directory.  Then click Next >. 

 

If you chose to output a water level time series for a line, you will now see the Line Series Output 

page.  You can manually define the location of a line along which you want to predict water levels, 

however, if you want to create boundary conditions for a model, you can use the model bathymetry 

to identify the lines along which to predict.  Under the Type of input section (lower half) of the 

http://data-portal.ecmwf.int/data/d/interim_full_daily/
http://data-portal.ecmwf.int/data/d/interim_full_daily/
http://data-portal.ecmwf.int/data/d/interim_full_daily/
http://badc.nerc.ac.uk/help/software/xconv/#xconv
http://sourceforge.net/projects/ecmwfparser/files/ECMWFinstaller.exe/download
http://sourceforge.net/projects/ecmwfparser/files/ECMWFinstaller.exe/download
mailto:enquries@metoffice.gov.uk
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page, select either the ‘Bathymetry file (.dfs2)’ or ‘Mesh file (.mesh)’ radio button (for an FM model 

this will be the Mesh file option).  The table in the top half of the page should then be populated 

with the locations of the open boundaries you have defined in your mesh.  Move the slider bar 

along the table until you can see the ‘Data file’ column and enter suitable names for the boundary 

data outputs by using the ‘…’ button.  Then click Next >. 

h. You are now on the Status page where you can check the values you have entered.  If you are 

happy with your set up then click on the ‘Execute’ button to make the prediction.  When the 

prediction is complete you will either see a preview of the time series for the point output or just 

see an ‘OK’ button for the line series which you should click.  If you then click on the ‘Finish’ 

button you can save your MIKE21 Toolbox for later use. 

 

2.4 FM HD Model Set Up 

a. Open a new MIKE21 FM HD interface using either the blank page icon at the far left of the toolbar 

or select File>New>File… and navigating to the MIKE21 menu using the left hand menu then 

double clicking on the Flow Model FM icon on the right hand side list.  After expanding the left 

hand menu you should see the view below: 

 

 

b. Click on Domain on the list in the left hand window to load the Domain page.  On the Mesh and 

Bathymetry tab, load a .mesh file that you have already created by clicking on the ‘…’ button and 

navigating to the file location. 

c. On the Domain Specification tab, check that the Minimum Cut Off Depth is acceptable (ground 

levels greater than this value will be treated as land and not included in the wave calculations).  

Also untick the Include reordering tickbox if you have exported a .dfsu version of your .mesh file 

and want the model to output results using the same element values as those in the .dfsu file.  

This can be useful if you want to compare results at a location with bathymetry value at the same 

location. 

d. Click onto the Boundary Names tab and rename your boundaries to something more memorable! 

e. Open the Time page via the left hand menu.  MIKE21 FM HD operates an internal adaptive time 

step within the numerical solver so the time step which you specify here is the maximum 

allowable time step.  It also provides a reference time step for model outputs.  Ensure your 

simulation period is covered by the duration of your boundary condition data (i.e. you have 
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boundary data which starts on or before the simulation start date and ends on or after the 

simulation end date).  You may find some guidance for a first stab at the time step by analysing 

your model mesh in your Mesh Generator application. 

f. Click onto the Module Selection page on the left hand menu.  If you are coupling your model to 

another product then you should select the appropriate tickbox. 

g. Click onto the Solution Technique page on the left hand menu.  It is recommended that you 

leave the solution methods as ‘Higher order’.  The Maximum time is limited by the time step you 

specified on the Time page.  However, you can specify a Minimum time step.  Generally the 

default settings are suitable, however, you can reduce the Shallow water equations minimum time 

if your model is unstable.  You should leave the Critical CFL number at 0.8 or less to ensure 

stability. 

h. Click onto the Flood and Dry page on the left hand menu.  If you have shallow water areas, such 

as a beach, you will need to include the flood and dry option.  For coastal applications, typical 

values are 0.02, 0.05 and 0.1 for the three parameters. 

i. Click onto the Density page on the left hand menu and make sure the ‘Barotropic’ option is 

selected from the drop-down list.  You should only change this if you are considering temperature 

or salinity variations. 

j. Click onto the Eddy Viscosity page on the left hand menu.  It is recommended that you use the 

‘Smagorinsky formulation’ as this allows the local variation in sub-grid processes to be included. 

k. Click onto the Bed Resistance page on the left hand menu and choose an appropriate Manning’s 

M or Chezy number.  You may need to use a spatially varying bed resistance map to ensure 

stability, although this is usually a last resort.  You can use the .dfsu file which you exported from 

your Mesh Generator application to create a spatially varying bed resistance map. 

l. Click onto the Coriolis Forcing page on the left hand menu.  For small area models (in the order 

of 10s of km), Coriolis can be neglected so set the Coriolis type to ‘No Coriolis Force’.  For larger 

domains, Coriolis should be included as either varying or constant in the domain. 

m. Click onto the Wind Forcing page on the left hand menu.  If you wish to include the effect of wind 

on the depth-averaged flow field you should activate this page by ticking the Include box.  You 

can then choose to provide a constant wind or varying in time and/or space.  If you choose 

‘Varying in time, constant in domain’ from the Format drop-down list, you will need to supply a 

.dfs0 (time series) file with the wind speed and direction.  If you choose ‘Varying in time and 

domain’ from the Format drop-down list, you will need to supply a .dfsu or .dfs2 (area series) file 

with the wind speed and direction as it varies across your domain. 

n. Click onto the Ice Forcing page on the left hand menu and ensure the ‘No ice coverage’ option is 

selected from the Type drop-down list, unless you need to consider ice coverage. 

o. Click onto the Tidal Potential page on the left hand menu.  Typically, you will not need to include 

tidal potential unless your model covers a large area of open ocean and has minimal forcing at 

the open boundaries.  This is because the tides generated in the ocean within your model domain 

will generally be significantly smaller than those input the model boundaries.  However, for large 

ocean models, this may be the only source of tidal forcing and so should be included.  Default 

values under Format ‘Specified from dialog’ can be used if tidal potential is included. 

p. Click onto the Precipitation – Evaporation page on the left hand menu.  You can include both 

gains and losses to the system here but typically both processes are excluded. 

q. Click onto the Wave Radiation page on the left hand menu.  You can include the radiation stress 

outputs from a wave model run here to generate wave-driven currents if you wish. 

r. Click onto the Sources page on the left hand menu.  You can add rivers and discharges as point 

sources here.  To add a source, if you know the coordinates, you can access the List View tab 

and click the New Source button then click Edit Source and modify the coordinates accordingly.  

You can also double click on the plot shown on the Geographic View tab and a new source will be 

added automatically where you click.  ‘Simple sources’ have no momentum while ‘Standard 

sources’ require velocity components to be provided.  Positive discharge values put water into the 

domain.  You can also link to another source if you wish. 

s. Click onto the Structures page on the left hand menu.  You can add sub-grid structures to the 

model using this page. 

t. Click onto the Initial Conditions page on the left hand menu.  Here you define your starting water 

level and flow field.  If you are using the results from a previous model run to start your model you 
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should choose ‘Spatially varying water depth and velocities’ or ‘Spatially varying surface 

elevation’ from the Type drop-down menu and select the output file from your previous run 

making sure you specify the correct item from the file.  For a cold start, you would normally 

choose ‘Constant’ from the Type drop-down list and then enter a value into the Surface elevation 

that corresponds with the value in your boundary conditions at the start time for the run.  This will 

avoid initial shocks which can cause the model to crash. 

u. Click onto the Boundary Conditions page on the left hand menu.  Your land boundary will be 

automatically detected and assigned the Type Land (zero normal velocity).  Any other open 

boundaries will appear in the List view tab and you should assign the relevant boundary condition 

files to each boundary.  If you have used the GTM to generate a line series of water levels (see 

Section 3) then you should choose ‘Specified level’ from the Type drop-down list and then 

‘Varying in time and along boundary’ for the Format.  For a point time series, choose the Format 

‘Varying in time, constant along boundary’. 

 

If you have a very rapidly varying water level, you may need to use a Soft start period.  You can 

choose to increase your boundary value from a specified Reference value over a specified Time 

interval using either a ‘Sinus variation’ or a ‘Linear variation’. 

You can also choose ‘Linear’ or ‘Piecewise cubic’ interpolation In time for water level values that 

are between defined values in the time series. 

Finally, if you are using a line series boundary condition, you can choose ‘Normal’ or ‘Reverse 

order’ for the In space interpolation.  Normal interpolation means that the first column of the .dfs1 

boundary condition file is assumed to relate to the start of the boundary (bearing in mind that 

when looking from the start point to the end point of an open boundary, the model domain is 

always located to the left of the boundary) whereas Reverse order means that the last column of 

the .dfs1 boundary condition file corresponds with the start of the boundary. 

v. Click onto the Decoupling page on the left hand menu and ensure the Include tickbox is empty. 

w. Click onto the Outputs page on the left hand menu.  Add new outputs by clicking on the New 

output button and giving the output a suitable name.  Click on Go To… to access the dialog page 

for each output. 

 

Use the Output specification tab on the dialog to define your output file type and content.  You 

can output ‘Point’, ‘Line’ or ‘Area series’ Output formats and can choose Field type to be ‘2D 

(horizontal)’, ‘Mass budget’ or ‘Discharge’.  Typically, you will be outputting area series with 2D 

(horizontal) data. 

Enter a name for the output file and the file extension will be added automatically.  If you don’t 

add a path, the file will be stored in a directory with the name of your model run file plus – Results 

Files which prevents accidental overwriting of results. 

You can choose the extent of the output when cells are wet using the Treatment of flood and drop 

down list.  You can also choose the period over which output is written and the frequency, in 

terms of the time step you defined on the Time page. 

Use the Geographic View tab to check your output location definition and the Output items tab to 

choose which parameters to include in the output file. 

x. Save your set up file and, making sure there are no red crosses on the left-hand menu, execute 

the model using the Run menu. 
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2.5 Troubleshooting 

a. Things to try if your model crashes or if the results look odd (which is down to personal 

judgement): 

1. Check your mesh doesn’t contain too many steep slopes or tiny elements.  Refine your mesh 

if needed.  You can always increase water depth at your boundary as it should not affect your 

site as long as your site is far enough away from the boundaries. 

2. Decrease the minimum time step for the shallow water equations.  Check the log file first to 

see if the previous minimum was reached. 

3. Change the flood and dry conditions.  This can be a source of instability and either smaller or 

larger values may help. 

4. Add a soft start period or extend it if you have one already.  Most instabilities arise during the 

‘warm up’ period of a model before a cyclic pattern can be developed. 

5. Change the bed resistance to include high values where the blow up occurs.  This should only 

be done if the blow up and high friction area is away from your site. 

b. Contact MIKE by DHI Customer Support on mikebydhi.uk@dhigroup.com 

  

mailto:mikebydhi.uk@dhigroup.com
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3 Step-by-step Guide for Creating a MIKE21 SW model 

3.1 Data Requirements 

You will need the following data in order to complete the model set up: 

Type Purpose 

MIKE Mesh File To provide information on the model domain (extent, flexible mesh, bathymetry and 
boundary locations) 

Offshore Waves To provide an offshore boundary condition for your model so that waves generated outside 
the model domain (such as swell) can be included 

Wind To provide a wind boundary condition for your model so that waves can be generated 
inside the model domain 

 

3.2 Data Sources 

Some standard data sources for wind and wave data are given in the tables below, however, the list is 

not exhaustive. 

3.2.1 Offshore Wind & Wave Data 

Source Cost Details 

ECMWF (European Centre for 
Medium-range Weather Forecasting) 

http://data-
portal.ecmwf.int/data/d/interim_full_d
aily/ 

 

Nominal for data 
preparation 

Use the ERA Interim data, it’s the most recent. 

Data is 6 hourly predicted values so you’ll need 10 
years (minimum recommended) data in order to 
undertake an Extreme Value Analysis (EVA) if you 
want to look at extreme conditions. 

Data is exported in GRIB format. 

View and extract data using GRIB viewing freeware 
(such as xconv: 

http://badc.nerc.ac.uk/help/software/xconv/#xconv) 
or 
http://sourceforge.net/projects/ecmwfparser/files/EC
MWFinstaller.exe/download (although this one 
seems a little slow) 

Met Office 

enquries@metoffice.gov.uk 

 

~£200 - £1000 or 
more per point 

Hindcast wave data are available on a 12km and 
35km mesh. 

Time series of 3 hourly spectra are available at 
each point. 

Extreme Value Analysis (EVA) can be requested for 
each point both for the full 360° sector or for 
reduced direction sectors. 

 

3.3 SW Model Set Up 

a. Open a new MIKE21 SW interface using either the blank page icon at the far left of the toolbar or 

select File>New>File… and navigating to the MIKE21 menu using the left hand menu then double 

clicking on the Spectral Waves FM icon on the right hand side list.  After expanding the left hand 

menu you should see the view below: 

http://data-portal.ecmwf.int/data/d/interim_full_daily/
http://data-portal.ecmwf.int/data/d/interim_full_daily/
http://data-portal.ecmwf.int/data/d/interim_full_daily/
http://badc.nerc.ac.uk/help/software/xconv/#xconv
http://sourceforge.net/projects/ecmwfparser/files/ECMWFinstaller.exe/download
http://sourceforge.net/projects/ecmwfparser/files/ECMWFinstaller.exe/download
mailto:enquries@metoffice.gov.uk


  

16  

 

b. Click on Domain on the list in the left hand window to load the Domain page.  On the Mesh and 

Bathymetry tab, load a .mesh file that you have already created by clicking on the ‘…’ button and 

navigating to the file location. 

c. On the Domain Specification tab, check that the Minimum Cut Off Depth is acceptable (ground 

levels greater than this value will be treated as land and not included in the wave calculations).  

Also untick the Include reordering tickbox if you have exported a .dfsu version of your .mesh file 

and want the model to output results using the same element values as those in the .dfsu file.  

This can be useful if you want to compare results at a location with bathymetry value at the same 

location. 

d. Click onto the Boundary Names tab and rename your boundaries to something more memorable! 

e. Open the Time page via the left hand menu.  For a single extreme wave condition with swell only, 

you only need to use 0 or 1 time steps as you will be defining a single wave condition which 

doesn’t change over time.  If you choose one time step, choose a suitable interval (an hour would 

do, or three hours if you prefer).  If you are including wind wave generation, you will need to allow 

the model time to account for the additional energy input into the spectrum so you should use 10-

15 time steps typically to allow the equilibrium solution to be found.  Bear in mind that your output 

data will have the time stamp that you set here so if you have other time stamped data that you 

will want to associate with your results, make sure you set the correct start time. 

f. Click onto the Basic Equations page on the left hand menu.  If you are just considering offshore 

waves input at the model boundary (swell) then you can choose the ‘Directionally Decoupled’ 

spectral formulation as there is unlikely to be much redistribution of the energy between 

frequencies within the spectrum.  If you want to include locally generated wind waves, the ‘Fully 

Spectral’ formulation is recommended, but not essential as it could reasonably be assumed that 

energy does not move between frequencies under constant wind conditions.  If you are able, 

sensitivity testing on this option should be undertaken. 

 

For single, extreme wave conditions, always choose the ‘Quasi Stationary’ time formulation as 

this represents a stationary case with no additional energy input in the model domain.  For most 

other applications Quasi-Stationary will give sensible results, however, for large domains 

dominated by wind-driven waves, you may wish to choose the ‘Instationary’ time formulation.  

This will enable you to simulate the development of the wave spectrum over time.  Bear in mind 

that this option is very time-intensive for the solver and simulations can take a long time to run. 

g. Click onto the Spectral Discretisation page on the left hand menu.  If you have chosen the Fully 

Spectral formulation, you may need to change the Frequency Discretisation if you have a large 
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mesh (say >100000 elements) or are resolving a large number of directions (say >36) as the 

Number of frequencies (default value of 25) can be reduced to free up memory.  Generally, the 

default values in the Frequency Discretisation are suitable as they cover the wave period range 

from ~1.8s to ~20s.  If you have larger or much smaller waves than these within your spectrum, 

you may need to adjust the Minimum frequency (for larger wave periods) and Frequency factor. 

 

In the Directional Discretisation section, if you are only considering swell waves then wave 

spreading will be reduce so you should consider using a ‘Directional sector’ Discretization type 

using the approach angle for the waves as the centre of 120-180 degree sector, rather than the 

full 360 rose.  The Number of directions should be chosen to produce intervals of 2-10 degrees 

(typically 5 degree intervals).  If you are considering swell and wind waves then you should 

typically use the full ‘360 degree rose’ as wave spreading will be more significant.  The Number of 

directions should be chosen to produce intervals of 10-30 degrees (typically 10 degree intervals). 

h. Click onto the Solution Technique page on the left hand menu.  You are advised to leave the 

two drop down menus on the default values (‘Low order, fast algorithm’ and ‘Newton-Raphson 

iteration’).  Unless you are having convergence issues (i.e. non-convergence in a time step) you 

can leave the other values at default too.  However, you can help your model to achieve 

convergence by making the tolerances (see below) a bit less strict such as increasing the RMS-

norm residual tolerance to 1e-5 or 1e-4 and maybe reducing the Max-norm sig. wave. height to 2 

or 5mm. 

 

 

i. Click onto the Output of Convergence Information tab and choose ‘Standard output’ from the 

drop-down list in the top section.  This will provide an average value for each of the tolerance 

items for each iteration to allow you to monitor progress towards convergence.  You can also 

output map plots of the tolerance items (choose ‘Intermediate output’ from the lower drop-down 

box and put, for example, 50 in the Output box - this is the frequency, in iterations, that results will 

be written) to help identify areas where poor convergence is found (see below). 
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The convergence results are very useful to identify how close to convergence a non-convergent 

time step is and if the cause of the non-convergence is near the area of interest or if it can be 

safely disregarded. 

j. Click onto the Water Level Conditions page on the left hand menu.  If you are using an extreme 

water level with your extreme wave conditions, choose ‘Specify water level variation’ from the top 

drop-down list, leave the Format as ‘Constant’ and enter the water level relative to the bathymetry 

datum in the water level text box. 

k. Click onto the Current Conditions page on the left hand menu and make sure the ‘No current 

variation’ option is showing on the drop-down list. 

l. Click onto the Wind Forcing page on the left hand menu.  If you are only considering swell 

waves, input at the boundary, then choose the ‘No wind’ option from the drop-down list.  If you 

want to include locally derived wind waves, choose ‘Wind, speed and direction’ from the drop-

down list.  Choose ‘Constant’ for the Format and enter your wind Speed and Direction (from °N) in 

the relevant text boxes.  There are a number of different options under the Wind Generation 

Formula drop-down list – your wind data will most likely be U10 (measured or predicted at 10m 

above the water surface) so you should choose the ‘JONSWAP’ option from the list (see below). 
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m. Click onto the Ice Coverage page on the left hand menu and make sure the ‘No ice coverage’ 

option is showing on the drop-down list. 

n. Click onto the Diffraction page on the left hand menu and choose ‘Diffraction’ from the drop-

down list.  Leave the Smoothing factor and Number of smoothing steps at 1 for now but bear in 

mind these can be useful to help the model achieve convergence if it is struggling. 

o. If you are using the Fully Spectral formulation, click onto the Energy transfer page on the left 

hand menu and make sure the Quadruplet-wave interaction box is ticked and the Triad-wave 

interaction box is not ticked.  This set up will be sufficient for the large area models you are 

producing. 

p. Click onto the Wave Breaking page on the left hand menu.  Inclusion of wave breaking can 

reduce overall wave heights due to energy losses.  Exclusion of wave breaking can result in 

unrealistically large waves in shallow water.  If you are looking at coastal / nearshore / shallow 

water wave conditions, you should include wave breaking but, if time permits, sensitivity testing to 

see the effect of removing wave breaking could be undertaken.  All values on the Wave breaking 

page should be left at default for your models. 

q. Click onto the Bottom Friction page on the left hand menu and make sure the ‘No bottom 

friction’ option is showing on the drop-down list.  Including bottom friction can reduce wave 

heights and, for an assessment of extreme wave heights, can be safely excluded without 

devaluing the model results. 

r. If you are using the Fully Spectral formulation, click onto the White Capping page on the left 

hand menu and make sure the ‘No white capping’ option is showing on the drop-down list.  

Including white capping can reduce wave heights and, for an assessment of extreme wave 

heights, can be safely excluded without devaluing the model results. 

s. You can ignore the Structures page on the left hand menu for the seminar. 

t. Click onto the Initial Conditions page on the left hand menu and choose the ‘Spectra from 

empirical formulas’ option from the drop-down box.  Make sure the ‘JONSWAP’ option is showing 

in the Type of formulas box and leave the other values as defaults (see below).  If you have a 

problem with convergence, you can try using the ‘Zero Spectra’ Type instead. 
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u. Open the Boundaries menu in the left hand menu and navigate to each of your boundary pages 

in turn.  For each of the boundaries, use ‘Wave Parameters (version 1)’ for the Type and 

‘Constant’ for the Format and provide the relevant wave climate conditions in each text box (if you 

have the directional standard deviation, then use version 2).  Typically, swell waves have a 

spreading index of 5-10.  See page 89 of the MIKE21 SW User Guide for the relation between 

index and standard deviation in degrees. 

v. Click onto the Outputs page on the left hand menu.  Add new outputs by clicking on the New 

output button.  Click on the Go To... button to access each individual output dialog.  Use the tabs 

on the dialog to define your output file contents.  You will definitely need an ‘Area Series’ output 

(on Output specification tab) to generate map plots of the resulting wave climate and you should 

ensure that you have chosen the parameters you want from the Integral wave items, Model items 

and Input items tabs.  If you type a filename without a path into the Output file textbox on the 

Output specification tab, a new directory will be created when you run the model to store the 

output files in.  This prevents overwriting of results files on subsequent runs. 

w. Save your set up file and, making sure there are no red crosses on the left-hand menu, execute 

the model using the Run menu. 

3.4 Troubleshooting 

a. Things to try if your model doesn’t converge or if the results look odd (which is down to personal 

judgement): 

1. Check the convergence files to see if the model was anywhere close to converging and to see 

if there are any particular trouble areas which may require a remesh. 

2. Increase the Number of iterations to allow convergence if it looks like convergence was nearly 

achieved. 

3. Change the convergence tolerance criteria to allow convergence if the runs looks stable. 

4. Turn diffraction off or reduce the smoothing factor (in the range 0-1, try 0.9) and increase the 

number of smoothing steps (2-4 should make a difference). 

5. Change the initial conditions to the ‘Zero Spectra’. 

b. Contact MIKE by DHI Customer Support on mikebydhi.uk@dhigroup.com 
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