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Chapter 1

Installation Instructions

This chapter describes how to install VoiceArtisan, VoiceCatalyst and VoiceArtisan Libraries. Vocollect provides
an Eclipse installation that you must use in order to license the VoiceArtisan plugin.

System Requirements

Operating Systems
• Windows XP Professional, Version 2002, SP2 or higher
• Windows 7 Professional

Hardware
VoiceArtisan® and VoiceCatalyst® Emulator were tested on computers with Intel Core 2 Duo processors
with between 1.8-2.2 GHz processing speed and 2 GB RAM.

To test a voice application on your computer, you will need a Vocollect wired headset.

We recommend you use a CMedia CM108 USB Virtual 7.1 Channel Sound Adapter for your headset.
This adapter has been tested by Vocollect and is recommended for testing applications through
VoiceCatalyst Emulator.

Software
provided in zip fileEclipse version 3.7 or 3.6

only the 32-bit version is provided

provided in zip filePyDev plugin for Eclipse version 2.6

not provided--you must supplyJava version 6 or higher

must be 32-bit version to run with the Eclipse version we
provide

Installing VoiceArtisan
Important: Always download and install the latest version of the VoiceArtisan plugin and restart
Eclipse before installing other new plugins or before upgrading other plugins.

1. If you have not downloaded the software already, go to
https://s3.amazonaws.com/VoiceArtisan/downloads.html. This site lets you download the software
and the documentation.

2. Extract the downloaded zip file.

https://s3.amazonaws.com/VoiceArtisan/downloads.html


Note: When you select a directory to which to extract Eclipse, select a folder that is not in too
deep a subdirectory. Paths longer than 100 characters will cause issues, including unexpected
termination. We recommend installing to C: or C:\onefolderdown.

3. Navigate to the eclipse folder in the folder to which you extracted the bundle, and locate the file
setup.exe.

DescriptionOptions

run setup.exeIf you are running Windows XP

right-click setup.exe and select Run as
administrator

If you are running Windows 7

4. Start VoiceArtisan by running eclipse.exe.
You will be prompted for a workspace, which is a directory that will contain your projects.

You can enter a name for a new workspace, or select the default.

If you activate theUse this as the default and do not ask again check box, the selected workspace
will open automatically when you start VoiceArtisan.

You can now install your VoiceArtisan license. See Importing and Activating a VoiceArtisan License on
page 8 for more information.

Importing and Activating a VoiceArtisan License
How to import and activate a VoiceArtisan license.

You must have internet access to activate your license.

1. From the Window menu, select Preferences. In the Preferences dialog box, select VoiceArtisan
> License .

2. Click Import license and activate the IDE...
The next step will appear.

3. Click Please select a valid license file...
4. Browse to and select the license file you received from Vocollect.

The IDE determines whether the file is valid. If it is, the Next > button will become enabled.
5. Click Next >
6. Enter the requested information and click Next >.

VoiceArtisan will connect to a server and activate the license.

You will be notified of the success of the activation.

The file will be imported and you will be able to create VoiceArtisan distributable files. You will receive
pop up dialog warnings beginning 30 days before the license is due to expire when VoiceArtisan starts
and once it has expired. After the license has expired, you will be unable to export or run an application
from VoiceArtisan. This will be indicated in the status bar.

You can now configure VoiceCatalyst Emulator. See Configuring VoiceCatalyst Emulator on page 9 for
more information.

Confidential: For informational use by Vocollect Resellers and customers only | Pub: 2013-01
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Configuring VoiceCatalyst Emulator
How to configure installed instances of VoiceCatalyst Emulator

After you install one or more VoiceCatalyst Emulator plug-ins, you need to configure these instances so
that you can use each of them when running a voice application.

1. From the Window menu, select Preferences. In the Preferences dialog box, select VoiceArtisan
> VoiceCatalyst Emulator
The installed instances of VoiceCatalyst Emulator are displayed in the dialog.

2. Click on Configure.
The proper interpreter will be associated with the installations.

Installing Voice Development Plugins
Note that this procedure is standard Eclipse functionality. See Eclipse's Workbench Help for more
information on installing plugins. These steps are generally not needed if you have downloaded the
software from Vocollect and have followed the installation instructions up to this point.

1. From the Help menu, select Install New Software...

2. From the Work With: drop down list, select Vocollect Voice Update Site.
3. Select the plugins you want to install.
4. Click Next.

The Install Details dialog box will appear.
5. Review the details and click Next.

The Review License dialog box will appear.
6. Review the license agreements and activate the radio button next to I Accept.
7. Click Finish.

Note: If you are installing on Windows 7 and a Required operation requires elevation
message appears, run eclipse.exe as an administrator. See Installing VoiceArtisan in the Release
Notes for more information.

Libraries
Vocollect provides libraries of Python code and dialog diagrams that can be reused in other projects.

To view the VoiceArtisan Libraries that you have downloaded, from the Window menu, select
Show View > Other . In the Show View dialog box, select VoiceArtisan > VoiceArtisan Libraries
.

This section contains information extracting these libraries to your workspace.

Extracting a VoiceArtisan Library into Your Workspace
How to extract a library plug-in into your project workspace

You must have downloaded at least one VoiceArtisan library plug-in.

Pub: 2013-01 | Confidential: For informational use by Vocollect Resellers and customers only
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If you currently have any VoiceArtisan libraries installed, we recommend that you delete them from
your workspace (do not uninstall) before installing updated ones.

We provide VoiceArtisan libraries as plug-ins to make it easier to download and update. However, the
downloaded plug-ins are not ready to be used and referenced by other projects until you extract them to
your workspace. This procedure is described below.

1. Open the VoiceArtisan Libraries view.
See Eclipse's Workbench User Guide for more information on opening views.

2. Select the plug-ins you want to extract.
3. Either click the Add as Project button or select Add as Project from the drop down menu.

Confidential: For informational use by Vocollect Resellers and customers only | Pub: 2013-01
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Chapter 2

The VoiceArtisan Perspective

VoiceArtisan has a standard perspective that lets you view the information relevant to voice applications. It
contains the following views by default:

DescriptionView

Displays the directories and files in the projectVoice Explorer

Displays a smaller version of the dialog diagram with the area visible in the main
editor highlighted. You can move the highlight around to focus on different areas
of the dialog in the main editor.

Outline

Displays and lets you edit the properties of a node or link. This view will come to
the front of the tabset when you select a node or link.

Properties

Displays any validation errors or warnings for the voice applicationProblems

To open the VoiceArtisan perspective, from the Window menu, select
Open Perspective > Other > VoiceArtisan .





Chapter 3

Creating and Running Your First Voice Application

Make sure your Vocollect headset is attached to your computer using the required USB audio adapter. Verify
that you can hear audio through the headset.

This topic will walk you through the steps of creating and running a basic voice application project.

1. From the File menu, select New > Project... .
The New Project dialog box appears.

2. Select VoiceArtisan > VoiceArtisan Project .
3. Enter Hello World as the name for the project.
4. Ensure that all of the check boxes in the Project contents area are activated.
5. Click Finish.

If you have not yet opened the VoiceArtisan perspective, you will be prompted to switch to it. Select
Remember my decision. A Hello World project will appear in the Project Explorer pane.

6.
In the Operators view, click the Add button to add an operator.

7. From the Run menu, select Run As > VoiceCatalyst Application .
You should begin to see logging in the Voice Device view. You can use the filters on the right side of this
view to limit what appears in the Voice Device view.

You will then hear "Current operator is entered name. Nine words not trained. Good night."

8. Press the Play/Pause button. .

You will hear "Please keep quiet for a few seconds" and you will be prompted to begin template training.

9. Train the templates as requested.
The application will run. You will hear "Hello World" followed by "Task execution complete. Good night."

10. Press the Stop button.
You will hear "Powering off."

If you want to run the application again, press the Run button and select Hello World Application.

See the VoiceArtisan online help for more detailed information on creating voice applications.





Chapter 4

If You're Unfamiliar With Eclipse...

Preferences
Eclipse and most of its plugins let you set workspace preferences. You can access preferences by selecting
Window >Preferences . You can use the filter in the upper left of the dialog box to locate a specific preference.

Automatically Saving
You can configure Eclipse to automatically save edited files. To use this feature, select
Window > Preferences > General > Workspace and set the workspace save interval.

Local Revision History
Eclipse maintains a history of edits on all files by default. To access the local history, right click on a file and
select Compare With > Local History… .

Building Workspace
Some processes are set to work in the background, so you don't have to deal with an intrusive dialog box.
However, it is not immediately obvious that the process is occurring. If it seems that the UI is unresponsive
or if something seems to be taking longer than expected, look for the progress bar in the lower right corner of
the application. This is an indicator that the workspace is being built. When the process is complete, the
progress bar will disappear.

Quick Fixes
Pressing Ctrl + 1 brings up options for fixing warnings and errors.

Auto-Completions
Pressing Ctrl + spacebar displays autocompletions. Pressing the key combination repeatedly scrolls through
the possible completions.

Importing VoiceArtisan Projects
If you have an existing VoiceArtisan project, you can import it into your workspace. From the File menu,
select Import... then follow the steps in the wizard. If you are importing a VoiceArtisan project, be sure to
select Existing Projects into Workspace in the wizard.

Code Navigation
To navigate from one piece of Python code to another, either:

• Select a call to a method or a variable and press F3 to take you to the definition of the method or variable
(If Python can determine it).

• Hold the Ctrl key down. Hover over a method call or variable and click the hyperlink that appears.

To navigate from a dialog diagram to Python code, do one of the following:



• Click the node containing the method, select the method in the Properties view and press F3
• Click the link containing the method and press F3
• Double-click the link containing the method.

Shortcut Keys in VoiceArtisan
How to navigate in VoiceArtisan using the keyboard

Note: Pressing Ctrl + Shift + L displays a menu of all of the shortcut key bindings enabled for
your current context.

For information on accelerators, shortcut keys and other means of using the keyboard in VoiceArtisan,
see the following topics in the Eclipse Workbench help.

• List of Key Bindings
• Navigating the user interface using the keyboard
• Preferences: Keys

Confidential: For informational use by Vocollect Resellers and customers only | Pub: 2013-01
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